




A - 1

SAFETY PRECAUTIONS
                         (Always read these instructions before using this product.)

Before using this product, thoroughly read this manual and the relevant manuals introduced in this manual 

and pay careful attention to safety and handle the products properly.

The precautions given in this manual are concerned with this product. For the safety precautions of the 

programmable controller system, refer to the User’s Manual for the CPU module.

In this manual, the safety precautions are ranked as " WARNING" and " CAUTION".

Note that the CAUTION level may lead to serious consequences according to the circumstances.

Always follow the precautions of both levels because they are important for personal safety.

Please save this manual to make it accessible when required and always forward it to the end user.

[Design Instructions] 

[Startup/Maintenance Instructions]

WARNING
When data change, program change, or status control is performed from a personal computer to a running 

programmable controller, create an interlock circuit outside the programmable controller to ensure that the whole 

system always operates safely. 

Furthermore, for the online operations performed from a personal computer to a programmable controller CPU, the 

corrective actions against a communication error due to such as a cable connection fault should be predetermined as 

a system.

CAUTION
The online operations performed from a personal computer to a running programmable controller CPU (Program 

change when a programmable controller CPU is RUN, forced input output operation, operating status change such as

RUN-STOP switching, and remote control operation) must be executed after the manual has been carefully read and

the safety has been ensured.

When changing a program while a programmable controller CPU is RUN, it may cause a program corruption in some 

operating conditions. Fully understand the precautions described in GX Works2 Version 1 Operating Manual 

(Common) before use.

The positioning test functions of OPR, JOG, inching or positioning data for QD75/LD75 positioning module must be 

executed with the programmable controller set to STOP after the manual has been carefully read and the safety has 

been ensured. Specially when executing the function on the network system, ensure the safety thoroughly since the 

machinery whose operation cannot be checked by an operator may be activated. The operation failure may cause the 

injury or machine damage.

WARNING

CAUTION

Indicates that incorrect handling may cause hazardous conditions, resulting in 

death or severe injury.

Indicates that incorrect handling may cause hazardous conditions, resulting in 

minor or moderate injury or property damage.

●

●

●

The online operations performed on the intelligent function module such as data writing to flash ROM must be

executed after the operations of the external devices have been carefully considered and the safety has been

ensured.

●
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CONDITIONS OF USE FOR THE PRODUCT

(1) Mitsubishi programmable controller ("the PRODUCT") shall be used in conditions;

i) where any problem, fault or failure occurring in the PRODUCT, if any, shall not lead to any major or 

serious accident;  and 

ii) where the backup and fail-safe function are systematically or automatically provided outside of the 

PRODUCT for the case of any problem, fault or failure occurring in the PRODUCT.

(2) The PRODUCT has been designed and manufactured for the purpose of being used in general 

industries.

MITSUBISHI SHALL HAVE NO RESPONSIBILITY OR LIABILITY (INCLUDING, BUT NOT LIMITED 

TO ANY AND ALL RESPONSIBILITY OR LIABILITY BASED ON CONTRACT, WARRANTY, TORT, 

PRODUCT LIABILITY) FOR ANY INJURY OR DEATH TO PERSONS OR LOSS OR DAMAGE TO 

PROPERTY CAUSED BY the PRODUCT THAT ARE OPERATED OR USED IN APPLICATION NOT 

INTENDED OR EXCLUDED BY INSTRUCTIONS, PRECAUTIONS, OR WARNING CONTAINED IN 

MITSUBISHI'S USER, INSTRUCTION AND/OR SAFETY MANUALS, TECHNICAL BULLETINS AND 

GUIDELINES FOR the PRODUCT.

("Prohibited Application")

Prohibited Applications include, but not limited to, the use of the PRODUCT in;

 • Nuclear Power Plants and any other power plants operated by Power companies, and/or any other 

cases in which the public could be affected if any problem or fault occurs in the PRODUCT.

 • Railway companies or Public service purposes, and/or any other cases in which establishment of a 

special quality assurance system is required by the Purchaser or End User.

 • Aircraft or Aerospace, Medical applications, Train equipment, transport equipment such as Elevator 

and Escalator, Incineration and Fuel devices, Vehicles, Manned transportation, Equipment for 

Recreation and Amusement, and Safety devices, handling of Nuclear or Hazardous Materials or 

Chemicals, Mining and Drilling, and/or other applications where there is a significant risk of injury to 

the public or property.

 

Notwithstanding the above, restrictions Mitsubishi may in its sole discretion, authorize use of the 

PRODUCT in one or more of the Prohibited Applications, provided that the usage of the PRODUCT is 

limited only for the specific applications agreed to by Mitsubishi and provided further that no special 

quality assurance or fail-safe, redundant or other safety features which exceed the general 

specifications of the PRODUCTs are required. For details, please contact the Mitsubishi representative 

in your region.
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■ MANUALS

Related manuals are separately issued according to the purpose of their functions in GX Works2.

● Related manuals
The manuals related to this product are shown below.
Refer to the following tables when ordering required manuals.

1) Operation of GX Works2

2) Structured programming

Manual name Manual number
 (Model code)

GX Works2 Version 1 Operating Manual (Common)
Explains the system configuration of GX Works2 and the functions common to Simple project and 
Structured project such as parameter setting, operation method for the online function.

(Sold separately)

SH-080779ENG
(13JU63)

GX Works2 Version 1 Operating Manual (Simple Project)
Explains methods for such as creating and monitoring programs in Simple project of GX Works2.

(Sold separately)

SH-080780ENG
(13JU64)

GX Works2 Version 1 Operating Manual (Simple Project, Function Block)
Explains methods for such as creating function blocks, pasting function blocks to sequence programs, 
and operating FB library in Simple project of GX Works2. (Sold separately)

SH-080984ENG
(13JU72)

GX Works2 Version 1 Operating Manual (Structured Project)
Explains methods for such as creating and monitoring programs in Structured project of GX Works2.

(Sold separately)

SH-080781ENG
(13JU65)

GX Works2 Beginner's Manual (Simple Project)
Explains fundamental methods for such as creating, editing, and monitoring programs in Simple project 
for users inexperienced with GX Works2. (Sold separately)

SH-080787ENG
(13JZ22)

GX Works2 Beginner's Manual (Structured Project)
Explains fundamental methods for such as creating, editing, and monitoring programs in Structured 
project for users inexperienced with GX Works2. (Sold separately)

SH-080788ENG
(13JZ23)

Manual name Manual number
 (Model code)

MELSEC-Q/L/F Structured Programming Manual (Fundamentals)
Explains the programming methods, types of programming languages, and other information required 
to create structured programs. (Sold separately)

SH-080782ENG
(13JW06)

MELSEC-Q/L Structured Programming Manual (Common Instructions)
Explains the specifications and functions of common instructions such as sequence instructions, basic 
instructions, and application instructions, that can be used in structured programs. (Sold separately)

SH-080783ENG
(13JW07)

MELSEC-Q/L Structured Programming Manual (Application Functions)
Explains the specifications and functions of application functions that can be used in structured 
programs. (Sold separately)

SH-080784ENG
(13JW08)

MELSEC-Q/L Structured Programming Manual (Special Instructions)
Explains the specifications and functions of special instructions such as module dedicated instruction, 
PID control instruction, and built-in I/O function dedicated instruction, that can be used in structured 
programs. (Sold separately)

SH-080785ENG
(13JW09)

FXCPU Structured Programming Manual [Device & Common]
Explains the devices and parameters provided in GX Works2 for structured programming.

(Sold separately)

JY997D26001
(09R925)

FXCPU Structured Programming Manual [Basic & Applied Instruction]
Explains the sequence instructions provided in GX Works2 for structured programming.

(Sold separately)

JY997D34701
(09R926)

FXCPU Structured Programming Manual [Application Functions]
Explains the application functions provided in GX Works2 for structured programming.

(Sold separately)

JY997D34801
(09R927)
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3) Operation of iQ Works

4) User's manual of each intelligent function module

The Operating Manuals are included on the CD-ROM of the software package in a PDF file format. Manuals in printed 
form are sold separately for single purchase. Order a manual by quoting the manual number (model code) listed in the 
table above.

Manual name Manual number
 (Model code)

iQ Works Beginner's Manual
Explains fundamental methods for such as managing the system using MELSOFT Navigator and using 
system labels for users inexperienced with GX Works2. (Sold separately)

SH-080902ENG
(13JZ44)
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● Purpose of this manual
This manual explains the operation related to the intelligent function modules using the functions 
supported by GX Works2.
Manuals for reference are listed in the following table according to their purpose.
For information such as the content and number of each manual, refer to the list of 'Related manuals'.

1) Installation of GX Works2 and USB driver

2) Operation of GX Works2

Purpose GX Works2 Installation Instructions
GX Works2 Version 1 

Operating Manual

Common

Learning the operating 
environment and installation 
method

Learning a USB driver installation 
method

DetailsDetails

DetailsDetails

Purpose

GX Works2 Beginner's 
Manual

GX Works2 Version 1 
Operating Manual

Simple 
Project

Structured 
Project Common

Simple Project
Structured 

Project

Intelligent 
Function 
Module

Function 
Block

Learning all functions of GX 
Works2

Learning the project types and 
available languages in GX 
Works2

Learning the basic operations 
and operating procedures when 
creating a simple project for the 
first time

Learning the basic operations 
and operating procedures when 
creating a structured project for 
the first time

Learning the operations of 
available functions regardless of 
project type.

Learning the functions and 
operation methods for 
programming

Learning the operations and 
operating procedures when 
creating function blocks (FB) in 
Simple project.

Learning data setting methods for 
intelligent function module

Outline

Outline

DetailsDetails

DetailsDetails

DetailsDetails

Outline DetailsDetails DetailsDetails

DetailsDetails

DetailsDetails
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3) Operations in each programming language
For details of instructions used in each programming language, refer to the section 4 and the 
section 5 on the following pages.

Purpose
GX Works2 Beginner's Manual GX Works2 Version 1 

Operating Manual

Simple 
Project

Structured
Project

Simple 
Project

Structured
Project

Simple 
Project

Ladder Diagram

Sequential 
Function Chart

Structured Text

Structured 
Project

Ladder Diagram

Sequential 
Function Chart

Structured Ladder
/FBD

Structured Text

*1 : MELSAP3 and FX series SFC only

Outline DetailsDetails

Outline

*1

DetailsDetails

Outline DetailsDetails

Outline DetailsDetails

Outline

*1

DetailsDetails

Outline DetailsDetails

Outline DetailsDetails
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4) Details of instructions in each programming language (for QCPU (Q mode)/LCPU)

Purpose

MELSEC-Q/L/F 
 Structured 

Programming 
Manual

MELSEC-Q/L
Structured Programming

Manual

MELSEC- Q/L 
Programming 

Manual

MELSEC-Q/L/QnA 
Programming Manual

Manual 
for 

module
 to be 
used

Fundamentals Common 
Instructions

Special  
Instructions

Application 
Functions

Common 
Instruction

PID Control 
Instructions SFC -

All 
languages

Learning details 
of programmable 
controller CPU 
error codes, 
special relays, 
and special 
registers

Using 
Ladder 
Diagram

Learning the 
types and details 
of common 
instructions

Learning the 
types and details 
of instructions for 
intelligent 
function modules

Learning the 
types and details 
of instructions for 
network modules

Learning the 
types and details 
of instructions for 
the PID control 
function

Using 
Sequential 
Function 
Chart 

Learning details 
of specifications, 
functions, and 
instructions of 
SFC (MELSAP3)

Using 
Structured 
Ladder/
FBD or 
Structured 
Text

Learning the 
fundamentals for 
creating a 
structured 
program

Learning the 
types and details 
of common 
instructions

Learning the 
types and details 
of instructions for 
intelligent 
function modules

Learning the 
types and details 
of instructions for 
network modules

Learning the 
types and details 
of instructions for 
the PID control 
function

Learning the 
types and details 
of application 
functions

DetailsDetails

DetailsDetails

DetailsDetails

DetailsDetails

DetailsDetails

DetailsDetails

DetailsDetails

DetailsDetails

Outline DetailsDetails

Outline DetailsDetails

Outline DetailsDetails

DetailsDetails
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5) Details of instructions in each programming language (for FXCPU)

Purpose

MELSEC-
Q/L/F

Structured 
Programming

Manual

FXCPU
Structured Programming

Manual

FXCPU
 Programming 

Manual

Fundamentals Device & 
Common

Basic & 
Applied 

Instruction

Application 
Functions

FX0,FX0S, 
FX0N,FX1, 
FXU,FX2C

FX1S,FX1N, 
FX2N,FX1NC, 

FX2NC

FX3G,FX3U,
FX3GC,FX3UC

Using 
Ladder 
Diagram

Learning the 
types and details 
of basic/
application 
instructions, 
descriptions of 
devices and 
parameters

Using 
Sequential 
Function 
Chart 

Learning details 
of specifications, 
functions, and 
instructions of 
SFC

Using 
Structured 
Ladder/
FBD or 
Structured 
Text

Learning the 
fundamentals for 
creating a 
structured 
program

Learning the 
descriptions of 
devices, 
parameters, and 
error codes

Learning the 
types and details 
of sequence 
instructions

Learning the 
types and details 
of application 
instructions

DetailsDetails DetailsDetails DetailsDetails

DetailsDetails DetailsDetails DetailsDetails

DetailsDetails

DetailsDetails

DetailsDetails

DetailsDetails
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● How to read this manual

Screen display

Describes the screen display procedure.

Follow the      and select [(menu)] to open 

the screen.

*Screen display may differ depending on the 

CPU type.

Display contents

Describes the display contents on the screen.

Operating procedure

Describes the operating procedure of the 

function.

Section title

Clarifies the section of currently open page.

Chapter heading

Index on the right of the page number clarifies 

the chapter of currently open page.

Reference location

leads to the reference location and 

reference manual.

Screen button

Describes the buttons on the screen.
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This manual also uses the following columns:

This indicates notes requiring attention or useful functions relating to the information given on the 
same page.

Restrictions

This indicates restrictions relating to the information given on the same page.

● Symbols used in this manual
The following shows the symbols used in this manual with descriptions and examples.

No. Symbol Description Example

 [       ] Menu name on a menu bar [Project]

 Toolbar icon

 (Underline) Screen name Q Parameter Setting screen

 <<     >> Tab name on a screen <<PLC System>>

 "     " Item name on a screen "Timer Limit Setting"

 Button on a screen  button

-  Keyboard key 

1

2

4

5

6

3
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■ GENERIC TERMS AND ABBREVIATIONS IN THIS MANUAL

The following are the generic terms/abbreviations of such as software packages and programmable 
controller CPUs used in this manual.

Generic term and 
abbreviation Description

GX Works2 Generic product name for SWnDNC-GXW2-E
(n: version)

Existing application -

GX Developer
Generic product name for SWnD5C-GPPW-E, SWnD5C-GPPW-EA, SWnD5C-GPPW-EV, and 
SWnD5C-GPPW-EVA
(n: version)

GX IEC Developer Product name for SWnD5C-MEDOC3
(n: version)

GX Simulator
Generic product name for SWnD5C-LLT-E, SWnD5C-LLT-EA, SWnD5C-LLT-EV, and SWnD5C-
LLTEVA
(n: version)

GX Configurator Generic product name for GX Configurator-AD/DA/SC/CT/TC/TI/FL/PT/AS/QP

MELSOFT Navigator
Product name for the integrated development environment included in SWnDNC-IQWK (iQ Platform 
compatible engineering environment MELSOFT iQ Works)
(n: version)

iQ Works Abbreviation for iQ platform supporting engineering environment MELSOFT iQ Works

Personal computer Generic term for personal computer on which Windows® operates

Basic model QCPU Generic term for Q00J, Q00, and Q01

High Performance
model QCPU Generic term for Q02, Q02H, Q06H, Q12H, and Q25H

Universal model QCPU
Generic term for Q00UJ, Q00U, Q01U, Q02U, Q03UD, Q03UDE, Q03UDV, Q04UDH, Q04UDEH, 
Q04UDV, Q06UDH, Q06UDEH, Q06UDV, Q10UDH, Q10UDEH, Q13UDH, Q13UDEH, Q13UDV, 
Q20UDH, Q20UDEH, Q26UDH, Q26UDEH, Q26UDV, Q50UDEH, and Q100UDEH

High-speed Universal 
model QCPU Generic term for Q03UDV, Q04UDV, Q06UDV, Q13UDV, and Q26UDV

Process CPU Generic term for Q02PH, Q06PH, Q12PH, and Q25PH

Redundant CPU Generic term for Q12PRH and Q25PRH

QCPU (Q mode) Generic term for Basic model QCPU, High Performance model QCPU, Process CPU, Redundant 
CPU, and Universal model QCPU

LCPU Generic term for L02S, L02, L02-P, L06, L26, L26-BT, and L26-PBT

CPU module Generic term for QCPU (Q mode) and LCPU

A/D converter module Generic term for Q64AD, Q68ADV, Q68ADI, Q64AD-GH, Q62AD-DGH, Q68AD-G, Q66AD-DG, 
Q64ADH, Q64AD2DA, L60AD4, and L60AD4-2GH

D/A converter module Generic term for Q62DAN, Q64DAN, Q68DAVN, Q68DAIN, Q62DA, Q64DA, Q68DAV, Q68DAI, 
Q62DA-FG, Q66DA-G, Q64DAH, Q64AD2DA, Q61LD, Q68CT, and L60DA4

QD75M/QD75MH Generic term for QD75M1, QD75M2, QD75M4, QD75MH1, QD75MH2, and QD75MH4

QD75 positioning 
module

Generic term for QD75P1, QD75P2, QD75P4, QD75P1N, QD75P2N, QD75P4N, QD75D1, 
QD75D2, QD75D4, QD75D1N, QD75D2N, QD75D4N, QD75M1, QD75M2, QD75M4, QD75MH1, 
QD75MH2, and QD75MH4

LD75 positioning module Generic term for LD75P1, LD75P2, LD75P4, LD75D1, LD75D2, and LD75D4

QD75/LD75 positioning 
module Generic term for QD75 positioning module and LD75 positioning module

Serial communication 
module

Generic term for QJ71C24, QJ71C24-R2, QJ71C24N, QJ71C24N-R2, QJ71C24N-R4, LJ71C24, 
and LJ71C24-R2

Simple Motion module Generic term for QD77MS2, QD77MS4, QD77MS16, QD77GF16, LD77MH4, and LD77MH16

AnyWireASLINK 
Interface Module Generic term for QJ51AW12AL and LJ51AW12AL

Q series C24N Generic term for QJ71C24N, QJ71C24N-R2, and QJ71C24N-R4

L series C24 Generic term for LJ71C24 and LJ71C24-R2
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Common instruction
Generic term for sequence instructions, basic instructions, application instructions, data link 
instructions, multiple CPU dedicated instructions, and multiple CPU high-speed transmission 
dedicated instructions

Special instruction Generic term for module dedicated instructions, PID control instructions, socket communication 
function instructions, built-in I/O function instructions, and data logging function instructions

Generic term and 
abbreviation Description
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1 OVERVIEW
This manual describes operating methods of the intelligent function module, such as setting 
parameters, writing/reading data, and monitoring.
For the features and functions of GX Works2, refer to the following manual.
GX Works2 Version 1 Operating Manual (Common)

1.1 Overview 1 - 2

1.2 Features of Operations of Intelligent Function Module 1 - 2

1.3 Intelligent Function Module Data 1 - 5

1.4 List of Functions 1 - 11



1 - 2

GX Works2

1  OVERVIEW

1.1 Overview

This manual describes operations of the intelligent function module with GX Works2.
The operations of the intelligent function module with GX Works2 enable to easily set, monitor, and 
test settings and parameters, such as the intelligent function module parameters (initial setting/auto 
refresh) for the analog module, the system settings for the serial communication module, and the 
positioning data and parameters for the positioning module, without regard for the input/output 
signals and buffer memory.

For the detailed settings of the intelligent function module, refer to the user's manual of the module to 
be used.

1.2 Features of Operations of Intelligent Function Module

■ Adding intelligent function modules

By adding an intelligent function module to a project, its data such as the intelligent function module 
parameters (initial setting/auto refresh) can be set, monitored, and tested.
The I/O assignment information of the added intelligent function module is applied to the I/O 
assignment setting of the PLC parameter. Intelligent function module data can also be added from the 
I/O assignment setting of the PLC parameter.

Add an intelligent function module

Add/apply the settings to the I/O assignment setting of the PLC parameter

Manage intelligent function modules 

on the Project view
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■ Setting data to intelligent function modules

● Intelligent function module parameters (initial setting/auto refresh)
The intelligent function module parameters can be set by opening the data of each intelligent function 
module on the Project view.
On the intelligent function module parameter list, the number of set parameters (initial setting/auto 
refresh) can be checked. In addition, the enabled/disabled status of the parameters can be switched.
The maximum number of parameters (initial setting/auto refresh) may differ depending on the CPU 
module to be used. For details of the limit of the number of parameters depending on the CPU 
module, refer to Section 2.1.7.

● Switch setting of intelligent function module
The switch setting of the intelligent function module can easily be performed without regard to the 
order of bits.
The switch setting of the intelligent function module links with the switch setting of the PLC 
parameter.

● Writing/reading data to/from intelligent function module
Using the Write to PLC and Read from PLC functions, the intelligent function module parameters can 
be written/read. Data can also be written/read to/from the buffer memory and flash ROM.

<Data setting screen for the intelligent function module> <Intelligent function module parameter list>

<Switch setting of the intelligent function module> <Switch setting of the PLC parameter>
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GX Works2

1  OVERVIEW

■ Monitoring/testing intelligent function modules

On the Intelligent Function Module Monitor windows, the input/output signals and buffer memory can be 
monitored on module by module basis.
The input/output signals and buffer memory can be tested by changing their current values on the 
Intelligent Function Module Monitor window.

■ Intelligent function module tools

The functions such as the offset/gain setting of the analog module and temperature input module, and 
the circuit trace of the serial communication module can be performed using the intelligent function 
module tools.
For details of the intelligent function module tools, refer to Chapter 3.

<Monitoring of the serial communication module>

<Offset/gain setting of the analog module> <Circuit trace of the serial communication module>
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1.3 Intelligent Function Module Data

This section explains intelligent function module data which can be used in GX Works2.
For details of each item, refer to the user's manual of the module to be used.

Intelligent function module parameters are created when the intelligent function data are set. The 
intelligent function module parameters include the data for initial setting and auto refresh.
The following table shows the intelligent function module data and the data registered to the 
intelligent function module parameters as initial setting and auto refresh.
Note that the auto refresh configures the settings to automatically store the error information and 
status information stored in buffer memory to the specified device in the programmable controller 
CPU.
● QCPU (Q mode)

Module type Module model Data Description

Intelligent function 
module parameter

Initial 
setting

Auto 
refresh

Analog Module

Q64AD
Q68ADV
Q68ADI
Q64AD-GH
Q62AD-DGH
Q68AD-G
Q66AD-DG
Q64ADH

Switch Setting Set the intelligent function module switches. - -

Parameter Set the basic settings and warning output function 
settings.  -

Auto Refresh Set the devices for auto refresh. - 

Q62DAN
Q64DAN
Q68DAVN
Q68DAIN
Q62DA
Q64DA
Q68DAV
Q68DAI
Q62DA-FG
Q66DA-G
Q64DAH

Switch Setting Set the intelligent function module switches. - -

Parameter Set the basic settings and warning output function 
settings.  -

Auto Refresh Set the devices for auto refresh. - 

Q64AD2DA

Switch Setting Set the intelligent function module switches. - -

Parameter (A/D 
conversion part)

Set the basic settings, scaling function settings, shift 
function, input signal error detected function, and logging 
function.

 -

Parameter (D/A 
conversion part)

Set the basic settings, scaling function settings, and shift 
function.  -

Auto Refresh Set the devices for auto refresh. - 

Q61LD
Parameter Set the basic settings and warning output function 

settings.  -

Auto Refresh Set the devices for auto refresh. - 

Q68CT

Switch Setting Set the intelligent function module switches. - -

Parameter Set the basic settings and warning output function 
settings.  -

Auto Refresh Set the devices for auto refresh. - 

Temperature 
Input Module

Q64RD
Q64RD-G
Q64TD
Q64TDV-GH
Q68TD-G-H02
Q68TD-G-H01
Q68RD3-G

Switch Setting Set the intelligent function module switches. - -

Parameter Set the basic settings, warning output function settings, 
and scaling function settings.  -

Auto Refresh Set the devices for auto refresh. - 
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1  OVERVIEW

Temperature 
Control Module

Q64TCTT
Q64TCTTBW
Q64TCRT
Q64TCRTBW
Q64TCTTN
Q64TCTTBWN
Q64TCRTN
Q64TCRTBWN

Switch Setting Set the intelligent function module switches. - -

Parameter
Set the basic settings, control basic parameters, control 
detailed parameters, warning function settings, and CT 
settings.

 -

Auto Refresh Set the devices for auto refresh. - 

Q62HLC

Switch Setting Set the intelligent function module switches. - -

Parameter (MAIN)
Set the basic setting, control basic parameters, control 
detailed parameters, warning function settings, and 
scaling settings.

 -

Parameter 
(Program Control 
Function)

Set the program control function settings.  -

Auto Refresh Set the devices for auto refresh. - 

Counter Module

QD62
QD62E
QD62D

Switch Setting Set the intelligent function module switches. - -

Parameter Set the basic settings and counter function settings.  -

Auto Refresh Set the devices for auto refresh. - 

QD63P6

Switch Setting Set the intelligent function module switches. - -

Parameter Set the basic settings and periodic pulse counter function 
settings.  -

Auto Refresh Set the devices for auto refresh. - 

QD64D2

Switch Setting Set the intelligent function module switches. - -

Parameter Set the basic settings, coincidence output function, and 
continuous comparison function settings.  -

Auto Refresh Set the devices for auto refresh. - 

QD60P8-G

Switch Setting Set the intelligent function module switches. - -

Parameter Set the basic settings and warning output function 
settings.  -

Auto Refresh Set the devices for auto refresh. - 

QD65PD2

Switch Setting Set the intelligent function module switches. - -

Parameter Set the basic settings.  -

Auto Refresh Set the devices for auto refresh. - 

Module type Module model Data Description

Intelligent function 
module parameter

Initial 
setting

Auto 
refresh
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QD75 Type 
Positioning 
Module

QD75P1
QD75P2
QD75P4
QD75P1N
QD75P2N
QD75P4N

Parameter
Set the basic parameters 1, basic parameters 2, detailed 
parameters 1, detailed parameters 2, OPR basic 
parameters, and OPR detailed parameters.

- -

Positioning Axis #n 
Data

Set the positioning data including the pattern, control 
method, acceleration/deceleration time, and address for 
each axis. (n = number of axes)

- -

Starting Axis #n 
Block Data

Set the execution sequence and execution conditions for 
the positioning data. (n = number of axes) - -

Auto Refresh Set the devices for auto refresh. - 

QD75D1
QD75D2
QD75D4
QD75D1N
QD75D2N
QD75D4N

Parameter
Set the basic parameters 1, basic parameters 2, detailed 
parameters 1, detailed parameters 2, OPR basic 
parameters, and OPR detailed parameters.

- -

Positioning Axis #n 
Data

Set the positioning data including the pattern, control 
method, acceleration/deceleration time, and address for 
each axis. (n = number of axes)

- -

Starting Axis #n 
Block Data

Set the execution sequence and execution conditions for 
the positioning data. (n = number of axes) - -

Auto Refresh Set the devices for auto refresh. - 

QD75M1
QD75M2
QD75M4

Parameter
Set the basic parameters 1, basic parameters 2, detailed 
parameters 1, detailed parameters 2, OPR basic 
parameters, and OPR detailed parameters.

- -

Servo Parameter
Set the servo basic parameters, servo regulation 
parameters, servo extended parameters, and servo 
extended parameters 2.

- -

Positioning Axis #n 
Data

Set the positioning data including the pattern, control 
method, acceleration/deceleration time, and address for 
each axis. (n = number of axes)

- -

Starting Axis #n 
Block Data

Set the execution sequence and execution conditions for 
the positioning data. (n = number of axes) - -

Auto Refresh Set the devices for auto refresh. - 

QD75MH1
QD75MH2
QD75MH4

Parameter
Set the basic parameters 1, basic parameters 2, detailed 
parameters 1, detailed parameters 2, OPR basic 
parameters, and OPR detailed parameters.

- -

Servo Parameter
Set the basic setting parameters, gain/filter parameters, 
extension setting parameters, I/O setting parameters, 
extension settings, and special settings.

- -

Positioning Axis #n 
Data

Set the positioning data including the pattern, control 
method, acceleration/deceleration time, and address for 
each axis. (n = number of axes)

- -

Starting Axis #n 
Block Data

Set the execution sequence and execution conditions for 
the positioning data. (n = number of axes) - -

Auto Refresh Set the devices for auto refresh. - 

QD70 Type 
Positioning 
Module

QD70P4
QD70P8
QD70D4
QD70D8
QD72P3C3
QD73A1

Switch Setting Set the intelligent function module switches. - -

Parameter Set the basic parameters and OPR parameters.  -

Positioning Axis #n 
Data

Set the positioning data including the operation pattern, 
control method, and acceleration/deceleration time. (n = 
number of axes)

 -

Auto Refresh Set the devices for auto refresh. - 

Module type Module model Data Description

Intelligent function 
module parameter

Initial 
setting

Auto 
refresh
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Serial 
Communication/ 
Modem 
Interface 
Module

QJ71C24N
QJ71C24N-R2
QJ71C24N-R4
QJ71C24
QJ71C24-R2

Switch Setting Set the intelligent function module switches. - -

Various Control 
Specifications

Make system settings for transmission control, MC 
protocol, nonprocedural protocol, and bidirectional 
protocol.

- -

PLC Monitoring 
Function

Make system settings to use the programmable 
controller CPU monitoring function. - -

Modem Function Make system settings for data communications using the 
model function. (Not available for QJ71C24N-R4) - -

User Register 
Frame Content Set the content of user frames. - -

User Register 
Frame 
Specification

Set the frame numbers for data transmission/reception. - -

Auto Refresh Set the devices for auto refresh. - 

AS-i Master 
Module QJ71AS92

Auto Refresh 
(System Common)

Set the devices for auto refresh.

- 

Auto Refresh 
(System 
Individual)

- 

FL-net 
(OPCN-2)
interface 
module

QJ71FL71-F01
QJ71FL71-T-F01
QJ71FL71-B2-F01
QJ71FL71-B5-F01
QJ71FL71
QJ71FL71-T
QJ71FL71-B2
QJ71FL71-B5

Switch Setting Set the intelligent function module switches. - -

Parameter Set the basic settings.  -

Auto Refresh Set the devices for auto refresh. - 

MODBUS® 
Interface 
Module

QJ71MT91
QJ71MB91

Switch Setting Set the intelligent function module switches. - -

Basic Parameter 
(Router 
Information)

Set the TCP/UDP/IP, GX Works2 connection.  -

Basic Parameter 
(Preferred Node 
Specification 
(MODBUS®/TCP 
settings)

Set the MODBUS®/TCP.  -

Automatic 
Communication 
Parameter

Set the automatic communication parameter.  -

MODBUS® Device 
Assignment 
Parameter

Set the MODBUS® device assignment parameter.  -

Auto Refresh Set the devices for auto refresh. - 

Simple
Motion
Module

QD77MS2
QD77MS4
QD77MS16
QD77GF16

Simple Motion 
Module Setting Start the simple motion module setting tool. - -

Auto Refresh Set the devices for auto refresh. - 

AnyWire
ASLINK 
Interface 
Module

QJ51AW12AL

Switch Setting Set the intelligent function module switches. - -

Auto Refresh Set the devices for auto refresh. - 

AnyWireASLINK 
Configuration Set the equipment configuration of AnyWireASLINK. - -

Module type Module model Data Description

Intelligent function 
module parameter

Initial 
setting

Auto 
refresh
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Energy 
Measuring 
Module

QE81WH
QE81WH4W

Switch Setting Set the intelligent function module switches. - -

Parameter Set the rate setting, the alarm monitoring function, the 
data acquisition clock function.  -

Auto Refresh Set the devices for auto refresh. - 

QE84WH
QE83WH4W

Switch Setting Set the intelligent function module switches. - -

Parameter
(Normal operation 
mode) Set the rate setting, the alarm monitoring function, the 

data acquisition clock function.

 -

Parameter
(Current 
measuring mode)

 -

Auto Refresh 
(Normal operation 
mode)

Set the devices for auto refresh.

- 

Auto Refresh 
(Current 
measuring mode)

- 

QE82LG

Switch Setting Set the intelligent function module switches. - -

Parameter
Set the common setting, the leak current (Io) alarm 
monitoring function, the leak current for resistance (Ior) 
alarm monitoring function.

 -

Auto Refresh Set the devices for auto refresh. - 

Module type Module model Data Description

Intelligent function 
module parameter

Initial 
setting

Auto 
refresh
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● LCPU

Module type Module model Data Description

Intelligent function 
module parameter

Initial 
setting

Auto 
Refresh

Analog Module
L60AD4
L60AD4-2GH
L60DA4

Switch Setting Set the intelligent function module switches. - -

Parameter Set the basic settings and warning output function 
settings.  -

Auto Refresh Set the devices for auto refresh. - 

Temperature 
Control Module

L60TCTT4
L60TCTT4BW
L60TCRT4
L60TCRT4BW

Switch Setting Set the intelligent function module switches. - -

Parameter
Set the basic settings, control basic parameters, control 
detailed parameters, warning function settings, and CT 
settings.

 -

Auto Refresh Set the devices for auto refresh. - 

Counter LD62
LD62D

Switch Setting Set the intelligent function module switches. - -

Parameter Set the basic settings and warning output function 
settings.  -

Auto Refresh Set the devices for auto refresh. - 

LD75 Type 
Positioning 
Module

LD75P1
LD75P2
LD75P4
LD75D1
LD75D2
LD75D4

Parameter
Set the basic parameters 1, basic parameters 2, detailed 
parameters 1, detailed parameters 2, OPR basic 
parameters, and OPR detailed parameters.

- -

Positioning Axis #n 
Data

Set the positioning data including the pattern, control 
method, acceleration/deceleration time, and address for 
each axis. (n = number of axes)

- -

Starting Axis #n 
Block Data

Set the execution sequence and execution conditions for 
the positioning data. (n = number of axes) - -

Auto Refresh Set the devices for auto refresh. - 

Simple 
Motion

LD77MH4
LD77MH16

Simple Motion 
Module Setting Start the simple motion module setting tool. - -

Auto Refresh Set the devices for auto refresh. - 

Serial 
Communication 
Module

LJ71C24
LJ71C24-R2

Switch Setting Set the intelligent function module switches. - -

Various Control 
Specifications

Make system settings for transmission control, MC 
protocol, nonprocedural protocol, and bidirectional 
protocol.

- -

PLC Monitoring 
Function

Make system settings to use the programmable 
controller CPU monitoring function. - -

Modem Function Make system settings for data communications using the 
model function. - -

User Register 
Frame Content Set the content of user frames. - -

User Register 
Frame 
Specification

Set the frame numbers for data transmission/reception. - -

Auto Refresh Set the devices for auto refresh. - 

AnyWire
ASLINK 
Interface 
Module

LJ51AW12AL

Switch Setting Set the intelligent function module switches. - -

Auto Refresh Set the devices for auto refresh. - 

AnyWireASLINK 
Configuration Set the equipment configuration of AnyWireASLINK. - -
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1.4 List of Functions

This section shows the list of functions of GX Works2 related to the intelligent function module.
For (Common) indicated in the Reference column, refer to the following manual.
GX Works2 Version 1 Operating Manual (Common)

1.4.1 List of functions common to intelligent function module

The following tables show the functions common to operations of the intelligent function module.

Project (common function) Reference

Intelligent Function Module -

New Module Add new intelligent function module data. Section 2.1.1

Delete Module Delete intelligent function module data. Section 2.1.5

Property Display properties of the intelligent function module data. Section 2.1.6

Intelligent Function Module Parameter List Display a list of set/unset parameters of the intelligent 
function module. Section 2.1.7

Print Window Print the open screen.

(Common)Print Window Preview Display the print preview of the open screen.

Printer Setup Change the printer settings.

View (common function) Reference

Docking Window -

Intelligent Function Module Monitor Display/hide the Intelligent Function Module Monitor 
window. Section 2.4

Module 1 to 10

Intelligent Function Module 
Guidance

Display/hide the Intelligent Function Module Guidance 
window. Section 3.5.6

Automatic Adjustment for Height Automatically adjust the height of intelligent function module 
data table and auto refresh data table.

Section 2.1.2
Automatic Adjustment for Width Automatically adjust the width of intelligent function module 

data table and auto refresh data table.

Online (common function) Reference

Read from PLC Read data from the programmable controller CPU.
(Common)

Write to PLC Write data to the programmable controller CPU.

Monitor -

Start Monitoring (All Windows) Start monitoring of all open windows.

(Common)
Stop Monitoring (All Windows) Stop monitoring of all open windows.

Start Monitoring Start monitoring of the open window.

Stop Monitoring Stop monitoring of the open window.

Watch -

Start Watching Start monitoring the current values of registered devices/
labels and intelligent function module.

Section 2.4
Stop Watching Stop monitoring the current values of registered devices/

labels and intelligent function module.

Tool (common function) Reference

Check Intelligent Function Module Parameter -

Check Auto Refresh Duplication Check the duplication of devices set in the Auto refresh 
function and displays the result. Section 2.1.8
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1.4.2  List of functions for analog module

1.4.2 List of functions for analog module

The following tables show the functions for analog module.

1.4.3 List of functions for temperature input module

The following tables show the functions for temperature input module.

Edit (analog module) Reference

Channel Copy Utilize specified channel data to another channel. Section 2.1.3

Auto Device Assignment Assign sequential devices to the items selected for auto 
refresh. Section 2.1.2

Tool (analog module) Reference

Intelligent Function Module Tool -

Analog Module - -

Offset/Gain Setting Set an offset/gain of analog module. Section 3.1.1

Q61LD Two-Point Calibration Setting Set a Q61LD two-point calibration. Section 3.1.2

Q61LD Default Setting Configure the Q61LD default setting. Section 3.1.3

Create Waveform Output Data Create waveform output data. Section 3.1.4

Data Initialization Initialize the set data of specified channel. Section 2.1.4

Edit (temperature input module) Reference

Channel Copy Utilize specified channel data to another channel. Section 2.1.3

Auto Device Assignment Assign sequential devices to the items selected for auto 
refresh. Section 2.1.2

Tool (temperature input module) Reference

Intelligent Function Module Tool -

Temperature Input Module - -

Offset/Gain Setting Set an offset/gain of temperature input module. Section 3.2.1

Data Initialization Initialize the set data of specified channel. Section 2.1.4
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1.4.4 List of functions for temperature control module

The following tables show the functions for temperature control module.

1.4.5 List of functions for counter module

The following tables show the functions for counter module.

Edit (temperature control module) Reference

Channel Copy Utilize specified channel data to another channel. Section 2.1.3

Auto Device Assignment Assign sequential devices to the items selected for auto 
refresh. Section 2.1.2

Setting Item Reduction Mode Reduce the number of auto refreshes. Section 3.3.3

Tool (temperature control module) Reference

Intelligent Function Module Tool -

Temperature Control Module - -

Auto Tuning Execute the Auto tuning function of temperature control 
module. Section 3.3.1

Sensor Correction Execute the Sensor Correction function of the temperature 
control module. Section 3.3.2

Data Initialization Initialize the set data of specified channel. Section 2.1.4

Edit (counter module) Reference

Channel Copy Utilize specified channel data to another channel. Section 2.1.3

Auto Device Assignment Assign sequential devices to the items selected for auto 
refresh. Section 2.1.2

Tool (counter module) Reference

Intelligent Function Module Tool -

Counter Module - -

Preset Execute the Preset function of counter module. Section 3.4.1

Data Initialization Initialize the set data of specified channel. Section 2.1.4
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1.4.6  List of functions for QD75/LD75 positioning module

1.4.6 List of functions for QD75/LD75 positioning module

The following tables show the functions for QD75/LD75 positioning module.

Project (QD75/LD75 positioning module) Reference

Intelligent Function Module -

Save the Positioning Module Data Save data of the positioning module selected on the Project 
view to a file.

Section 3.5.7
Read from the Positioning Module Data Read data from the positioning module and apply it to the 

positioning module selected on the Project view.

Save GX Configurator-QP Data Save the positioning module data in GX Configurator-QP 
format. Section 3.5.8

Import GX Configurator-QP Data Read the data created with GX Configurator-QP, and add a 
new positioning module. Section 3.5.9

Edit for Parameter (QD75/LD75 positioning module) Reference

Set Maximum Value Set the maximum value to the specified parameter item.

Section 3.5.6
Set Minimum Value Set the minimum value to the specified parameter item.

Set Default Value Set the default to the specified parameter item.

Computation of Electronic Gear Calculate the electronic gear from the data set on the 
parameter screen.

Axis Copy Utilize the specified axis data to another axis. Section 2.1.3

Edit for Servo Parameter (QD75/LD75 positioning module) Reference

Set Maximum Value Set the maximum value to the specified servo parameter 
item.

Section 3.5.6Set Minimum Value Set the minimum value to the specified servo parameter 
item.

Set Default Value Set the default to the specified servo parameter item.

Axis Copy Utilize the specified axis data to another axis. Section 2.1.3

Edit for Positioning Data (QD75/LD75 positioning module) Reference

Select All Select all items.

Section 3.5.6

Jump Jump to the specified positioning data number.

Initialization of Row Initialize the row at the cursor position.

Initialization of Column Initialize the column at the cursor position.

Insert Row Add a row above the cursor position.

Delete Row Delete the row at the cursor position.

Positioning Data Copy Copy the data in the row at the cursor position.

Positioning Data Paste Paste the data to the row at the cursor position.

Axis Copy Utilize specified axis data to another axis. Section 2.1.3

M Code Comment Edit Edit the M code comment.
Section 3.5.6

Condition Data Edit Edit the condition data.
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Edit for Block Starting (QD75/LD75 positioning module) Reference

Select All Select all items.

Section 3.5.6

Jump Jump to the specified positioning data number.

Initialization of Row Initialize the row at the cursor position.

Initialization of Column Initialize the column at the cursor position.

Insert Row Add a row above the cursor position.

Delete Row Delete the row at the cursor position.

Axis Copy Utilize specified axis data to another axis. Section 2.1.3

Block Start Copy Utilize specified block start data to another block start data.
Section 3.5.6

Condition Data Edit Edit the condition data.

Edit for Auto Refresh (QD75/LD75 positioning module) Reference

Auto Device Assignment Assign sequential devices to the items selected for auto 
refresh. Section 2.1.2

Tool (QD75/LD75 positioning module) Reference

Intelligent Function Module Tool -

QD75/LD75 Positioning Module - -

Positioning Monitor Execute the positioning monitoring. Section 3.5.1

Positioning Test Execute the positioning test. Section 3.5.2

Wave Trace Execute the wave trace. Section 3.5.3

Location Trace Execute the location trace. Section 3.5.4

Data Initialization Initialize the set data of specified axis. Section 2.1.4

Request of Parameter Initialization/Flash ROM 
Write Request

Request a command to write buffer memory data of QD75/
LD75 positioning module to the flash ROM. Section 3.5.5

Offline Simulation Simulate the waveform and location of set positioning data 
offline.

Section 3.5.6Automatic Command Speed Calculation Calculate the constant speed of traveling time between the 
start position and the target position.

Automatic Sub Arc Calculation
Calculate the positioning data of circular interpolation control 
to form a smooth arc (curve line) from the angle position 
created by two continuous linear interpolation controls.
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1.4.7  List of functions for QD70 positioning module

1.4.7 List of functions for QD70 positioning module

The following tables show the functions for QD70 positioning module.

1.4.8 List of functions for simple motion module

The following tables show the functions for simple motion module.

Edit (QD70 positioning module) Reference

Initialization of Row Initialize the row at the cursor position.
Section 3.5.6

Initialization of Column Initialize the column at the cursor position.

Axis Copy Utilize specified axis data to another axis. Section 2.1.3

Auto Device Assignment Assign sequential devices to the items selected for auto 
refresh. Section 2.1.2

Tool (QD70 positioning module) Reference

Data Initialization Initialize the set data of specified axis. Section 2.1.4

Edit (simple motion module) Reference

Auto Device Assignment Assign sequential devices to the items selected for auto 
refresh. Section 2.1.2

Tool (simple motion module) Reference

Data Initialization Initialize the auto refresh data of specified axis. Section 2.1.4



1.4  List of Functions

1.4.9  List of functions for serial communication/modem interface module 1 - 17

1

O
V

E
R

V
IE

W

2

CO
M

M
ON

 O
PE

RA
TI

ON
S 

FO
R 

IN
TE

LL
IG

EN
T 

FU
NC

TI
ON

 M
OD

UL
ES

3

O
PE

RA
TI

NG
 

IN
TE

LL
IG

EN
T 

FU
NC

TI
O

N 
M

O
DU

LE
S

4

PR
ED

EF
IN

ED
 

PR
O

TO
CO

L 
SU

PP
O

RT
 F

UN
CT

IO
N

A

AP
P

EN
D

IX

I

IN
D

E
X

1.4.9 List of functions for serial communication/modem interface 
module

The following tables show the functions for serial communication/modem interface module.

1.4.10 List of functions for AS-i master module

The following tables show the functions for AS-i master module.

Edit (serial communication/modem interface module) Reference

Channel Copy Utilize specified channel data to another channel. Section 2.1.3

Auto Device Assignment Assign sequential devices to the items selected for auto 
refresh. Section 2.1.2

View (serial communication/modem interface module) Reference

String/Hexadecimal Switch Format Switch between the string display and the hexadecimal 
display on the User Register Frame Content screen. Section 2.1.2

Tool (serial communication/modem interface module) Reference

Intelligent Function Module Tool -

Serial Communication Module - -

Circuit Trace Execute the circuit trace. Section 3.7.2

Predefined Protocol Support Function Start the predefined protocol support function. Chapter 4

Data Initialization Initialize the set data of specified channel. Section 2.1.4

Flash ROM Operation
Execute the flash ROM write permission/protection, module 
initialization, and flash ROM write command of serial 
communication module.

Section 3.7.4

Edit (AS-i master module) Reference

Auto Device Assignment Assign sequential devices to the items selected for auto 
refresh. Section 2.1.2

Tool (AS-i master module) Reference

Data Initialization Initialize the set data of specified channel. Section 2.1.4
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1.4.11  List of functions for FL-net (OPCN-2) interface module

1.4.11 List of functions for FL-net (OPCN-2) interface module

The following tables show the functions for FL-net (OPCN-2) interface module.

1.4.12 List of functions for MODBUS® interface module

The following tables show the functions for MODBUS® interface module.

1.4.13 List of functions for AnyWireASLINK interface module

The following tables show the functions for AnyWireASLINK interface module.

1.4.14 List of functions for Energy Measuring Module

The following tables show the functions for Energy Measuring Module.

Edit (FL-net (OPCN-2) interface module) Reference

Auto Device Assignment Assign sequential devices to the items selected for auto 
refresh. Section 2.1.2

Tool (FL-net (OPCN-2) interface module) Reference

Data Initialization Initialize the set data of specified channel. Section 2.1.4

Edit (MODBUS® interface module) Reference

Auto Device Assignment Assign sequential devices to the items selected for auto 
refresh. Section 2.1.2

Tool (MODBUS® interface module) Reference

Data Initialization Initialize the specified set data. Section 2.1.4

Edit (AnyWireASLINK interface module) Reference

Auto Device Assignment Assign sequential devices to the items selected for auto 
refresh. Section 2.1.2

Tool (AnyWireASLINK interface module) Reference

Data Initialization Initialize the specified set data. Section 2.1.4

Edit (Energy Measuring Module) Reference

Automatic Device Assignment Assign sequential devices to the items selected for auto 
refresh. Section 2.1.2

Tool (Energy Measuring Module) Reference

Data Initialization Initialize the set data of specified channel. Section 2.1.4
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2 - 1

2 COMMON OPERATIONS 
FOR INTELLIGENT 
FUNCTION MODULES

This chapter explains common operations for the intelligent function modules, such as adding a new 
project, and setting the parameters.

2.1 Operations of Intelligent Function Module Data 2 - 2

2.2 Utilizing Sample Comments of Intelligent Function 
Module 2 - 22

2.3 Writing/Reading Intelligent Function Module Data 2 - 22

2.4 Monitoring Intelligent Function Modules 2 - 23
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2.1.1  Adding intelligent function module data

2.1 Operations of Intelligent Function Module Data

This section explains how to set the intelligent function module data.
Adding an intelligent function module to a project, the data settings (parameter and switch settings) 
of the intelligent function module become available.

2.1.1 Adding intelligent function module data

Add the intelligent function module data to the project being edited. The installation slot number and 
start XY address of the added intelligent function module are applied to the I/O assignment setting of 
the PLC parameter.

Screen display
Select [Project] ⇒ [Intelligent Function Module] ⇒ [New Module].
(A module can be added by clicking the    button on the <<I/O Assignment>> tab of 
the PLC parameter.)

Operating procedure

1. Set the items on the screen.

Occupied I/O 
points information

< QCPU (Q mode) >

Occupied I/O 
points information

< LCPU >

Item Description

Module Selection —

Module type Select the type of the intelligent function module to be added.

Module model Select the model of the intelligent function module to be added.

Setting Item Reduction Mode for 
Auto-refresh*1 Select this to reduce the number of auto refreshes. (Section 3.3.3)

Mount Position —

Base No.*2 Specify the base number where the intelligent function module is mounted.

Mounted Slot No. Set the slot number of the intelligent function module.

Specify Start XY Address Set the start XY address of the intelligent function module.

Occupied I/O points information

For QCPU (Q mode), display the number of occupied slots and the number of 
occupied I/O points of the module selected for "Module Name".
For LCPU, display the number of logically-occupied modules and the number of 
occupied I/O points of the module selected for "Module Name".

Title Setting —

Title Set the title.
(The number of applicable characters is 32)

*1 : For temperature control modules (except for Q62HLC) only
*2 : For QCPU (Q mode) only



2.1  Operations of Intelligent Function Module Data

2.1.1  Adding intelligent function module data 2 - 3

1

O
V

E
R

V
IE

W

2

CO
M

M
ON

 O
PE

RA
TI

ON
S 

FO
R 

IN
TE

LL
IG

EN
T 

FU
NC

TI
ON

 M
OD

UL
ES

3

O
PE

RA
TI

NG
 

IN
TE

LL
IG

EN
T 

FU
NC

TI
O

N 
M

O
DU

LE
S

4

PR
ED

EF
IN

ED
 

PR
O

TO
CO

L 
SU

PP
O

RT
 F

UN
CT

IO
N

A

AP
P

EN
D

IX

I

IN
D

E
X

2. Click the  button.
The specified intelligent function module data are added to the 
Project view.

Screen button

●  
Displays the Acknowledge I/O Assignment screen. On the Acknowledge I/O Assignment screen, the 
current I/O assignment settings can be checked. The mounting position for the intelligent function 
module to be added can also be set. The following explains how to set the mounting position.

Operation
1. Select the line of the mounting position 

for the intelligent function module to be 
added.

2. Click the  button.
The selected mounting position is set on the 
New Module screen.
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2.1.1  Adding intelligent function module data

● Switch setting
The switch setting of the intelligent function module is applied to "Switch Setting" on the <<I/O Assignment>> tab of the 
PLC parameter.

● Changing the positioning data display range
The display range of the positioning data can be changed by the following setting.
Select [Tool] ⇒ [Options] ⇒ "Intelligent Function Module" ⇒ "QD75/LD75 Type Positioning", and set the setting for 
"Display Specification of Positioning Data".

If the display range is enlarged by setting "Display Specification of Positioning Data", it takes longer time to display the 
positioning data editing window.
When positioning data No. 101 and above are not necessary, select "Data No. 1 to 100".

● Display when mismatches of data assignment exist between PLC parameters and intelligent function module 
data
When mismatches of data assignment exist between the I/O assignment setting of the PLC parameter and the 
intelligent function module data, the icon on the Project view is displayed as shown below.
Even after a module is added by clicking the    button on the <<I/O Assignment>> tab of the PLC parameter, 
the icon on the Project view is displayed as shown below by clicking the   button on the <<I/O Assignment>> 
tab, and the I/O assignment setting becomes incorrect status.

If the added module is not necessary, delete it from the Project view.
● Opening project data which contain modules not supported by version of GX Works2 being used

When project data which contain an intelligent function module not supported by version of GX Works2 being used are 
opened, "Reserved Module" is displayed on the tree of the Project view.
It cannot be edited, displayed, or printed, however, it can be saved in the project. In addition, its intelligent function 
module parameters can be written to the programmable controller CPU.
(Example of display on the Project view)

● Adding modules to project data that contain modules not supported by version of GX Works2 being used
A module not supported by version of GX Works2 being used is regarded as the one uses single slot, even if it uses 
multiple slots. Therefore, the setting of I/O assignment may be duplicated when a module is added to project data 
where unsupported modules exist.
In this case, set the I/O assignment settings on the <<I/O Assignment>> tab of PLC parameter again.

<Normal display> <Duplicate display>
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2.1.2 Setting intelligent function module data

Edit the intelligent function module data.

Screen display
Select Project view ⇒ "Intelligent Function Module" ⇒ "(module)" ⇒ "(intelligent function 
module data)".
The screen image below is an example when the data of QJ71C24N is selected.

Operating procedure

• Set the items on the screen.
For details of the setting items, refer to the manual of each intelligent function module.
• Detailed explanation of a setting item is displayed at the bottom of the screen when it is selected. 

For LD75 positioning module, a detailed explanation is displayed on the Intelligent Function 
Module Guidance window. (Section 3.5.6)

• For a multiple-choice item, the available choices can be displayed on a combo box by double-
clicking the cell.

• For a text input item, the cell becomes editable by double-clicking it.
• "Display Filter" filters the settings so that only those related to the selected item are displayed.
• For Q64TCTTN/Q64TCTTBWN/Q64TCRTN/Q64TCRTBWN/L60TCTT4/L60TCTT4BW/

L60TCRT4/L60TCRT4BW, "Control Mode" set on the Switch Setting is displayed. 
Click the  button to set the unnecessary items for the mode set on the Switch 
Setting to '0'.
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2.1.2  Setting intelligent function module data

● Adjusting height/width of data table when characters are illegible
Height and width of cells can be adjusted by selecting [View] ⇒ [Automatic Adjustment for Height]/[Automatic 
Adjustment for Width].
The adjusted height and width are saved to the project.

● Switching display on the setting screen of serial communication module
The display can be switched to either string or hexadecimal format by selecting [View] ⇒ [String/Hexadecimal Switch 
Format] on the User Register Frame Content screen.

■ Switch setting

Edit the switch setting of the intelligent function module.

Screen display
Select Project view ⇒ "Intelligent Function Module" ⇒ "(module)" ⇒ "Switch Setting".

Operating procedure

1. Set the items on the screen.
For details of the setting items, refer to the manual of each intelligent function module.
• The available choices can be displayed on a combo box by double-clicking the cell.

2. Click the  button.
This setting is applied to the switch setting on the <<I/O Assignment>> tab of the PLC parameter.
The switch setting set on the <<I/O Assignment>> tab of the PLC parameter is also applied to this 
setting.

● Switch setting data that is not supported by version of GX Works2 being used
To set the switch setting data that is not supported by version of GX Works2 being used, set the parameter with the 
switch setting on the <<I/O assignment>> tab of PLC parameter.

[View]

[Automatic Adjustment

for Height]
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■ Auto refresh function

Set the auto refresh function of the intelligent function module.

Screen display
Select Project view ⇒ "Intelligent Function Module" ⇒ "(module)" ⇒ "Auto Refresh".

Operating procedure

• Setting devices.
For details of the setting items, refer to the manual of each intelligent function module.
• Detailed explanation of a setting item is displayed at the bottom of the screen when it is selected. 

For LD75 positioning module, a detailed explanation is displayed on the Intelligent Function 
Module Guidance window. (Section 3.5.6)

• For Structured projects, device format and address format can be switched by selecting "Device 
Program Display Mode".

• "Display Filter" filters the settings so that only those related to the selected item are displayed.
• For the items of which the offset values of buffer memory and the transfer word counts can be 

changed, set the items such as auto refresh devices on another screen.
Example: Setting screens of AS-i master module and FL-net (OPCN-2) interface module

<AS-i master module> < FL-net (OPCN-2) interface module >
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2.1.2  Setting intelligent function module data

● Contents displayed on explanation field
The following shows the contents displayed on the explanation field.

● Items of which offset values of buffer memory and transfer word counts can be changed
The set value of the items of which the offset values of buffer memory and the transfer word counts can be changed, is 
displayed as shown below.

● Assigning sequential devices for auto refresh
The following screen is displayed by selecting [Edit] ⇒ [Auto Device Assignment] after selecting cells to assign 
sequential devices. Devices are assigned sequentially from the one specified.

● Display of the Project view when the devices set in the auto refresh setting are duplicated in the module
When the screen is closed while the duplicated devices of the auto refresh setting exist, the icon on the Project view is 
displayed as shown below. To check the device duplications in multiple intelligent function modules, select [Tool] ⇒ 
[Check Intelligent Function Module Parameter] ⇒ [Check Auto Refresh Duplication].

Item Description

Transfer 
Direction

Intelligent Function 
Module ⇒ PLC

Transfer the buffer memory data of the intelligent function module to the specified 
device of the programmable controller CPU.

PLC ⇒ Intelligent 
Function Module

Transfer the specified device data of the programmable controller CPU to the 
buffer memory of the intelligent function module.

Buffer Memory Address Display the buffer memory address of the item to be auto refreshed.

Offset Display the offset value according to the target buffer memory address.

Transfer Word Counts Display the transfer word counts of the item to be auto refreshed.

Maximum Transfer Word Counts Display the maximum transfer word counts of the item to be auto refreshed.

Device Comment Display the device comment that is set to the selected device.

Device number (offset value, 

transfer word counts)

<Normal display> <Display when duplication occurs>
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■ Data setting screen of intelligent function modules

On the data setting screen of an intelligent function module, the setting status is identified by colors as 
shown below.

2.1.3 Channel copy/axis copy

Utilize specified channel/axis data to another channel/axis data when setting intelligent function module 
data.
The Channel copy function is not supported by the Auto refresh function.

Operating procedure

1. Select [Edit] ⇒ [Channel Copy]/[Axis Copy].
The Channel Copy screen is displayed.
The image below is a screen when the operation is performed on the data of Q68DAIN.

2. Select the copy target channel/axis and data, and click the  button.
The channel/axis data are copied.

Color
Setting status

Text Background

Blue White Default values

Black White Values other than default values

White Red Items whose values outside the setting range

Red White Items for which device is duplicated in auto refresh setting.

Black Gray Items for which setting is not required.

Black Yellow
Items for which setting (partner axis) is not required at the data number specified for axis 
to be interpolated.
(For QD75/LD75 positioning module only)

Green White Comments (Positioning module only)

Blue Gray Item with the transfer direction of [Intelligent Function Module ⇒ PLC]

Green Gray Item with the transfer direction of [PLC ⇒ Intelligent Function Module]
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2.1.4  Data initialization

2.1.4 Data initialization

Initialize the set data of intelligent function module.
For Simple Motion Module, only the auto refresh data are initialized.

Operating procedure

1. Select [Tool] ⇒ [Data Initialization].
The Data Initialization screen is displayed.
The image below is a screen when the operation is performed with the data of Q68DAIN.

2. Select the target channel(s) whose data to be initialized, and click the  
button.
The data of selected channel(s) are initialized.

● Selection items of the Data Initialization screen
When the auto refresh of temperature control modules is set with the Setting item reduction mode, only "ALL" can be 
selected from "Auto Refresh". Each channel cannot be selected independently.
For details of the Setting item reduction mode, refer to Section 3.3.3.

2.1.5 Deleting intelligent function modules

Delete an intelligent function module from the project being edited.

Operating procedure

1. Select the intelligent function module to be deleted from the Project view.

2. Select [Project] ⇒ [Intelligent Function Module] ⇒ [Delete Module].
The selected intelligent function module is deleted.
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2.1.6 Displaying properties of intelligent function modules

Check the setting information of an intelligent function module. This operation can also change the 
installation slot number, start XY address, module name, and title.

Screen display
Select [Project] ⇒ [Intelligent Function Module] ⇒ [Property].

Operating procedure

1. Set the items on the screen.

2. Click the  button.

Screen button
For the buttons on the screen, refer to Section 2.1.1.

Occupied I/O 

points information

Item Description

Module Selection —

Module type Display the type of the intelligent function module.

Module Name Display the model of the intelligent function module.

Mount Position —

Base No.*1 Display the base number where the intelligent function module is mounted.

Mounted Slot No. Display the current slot number.

Specify start XY address Display the current start XY address.

Occupied I/O points 
information

For QCPU (Q mode), display the number of occupied slots and the number of 
occupied I/O points of the module selected for "Module Name".
For LCPU, display the number of logically-occupied modules and the number of 
occupied I/O points of the module selected for "Module Name".

Title Setting —

Title Display the current title.
(The number of applicable characters is 32)

*1 : For QCPU (Q mode) only
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2.1.7  Checking/changing the applicable number of intelligent function module parameters

2.1.7 Checking/changing the applicable number of intelligent 
function module parameters

Display a list of the intelligent function module parameters (initial setting/auto refresh) set to the current 
project.
Set for enabling/disabling initial setting and auto refresh as intelligent function module parameters.

■ Enabling/disabling intelligent function module parameters

Set for enabling/disabling initial setting and auto refresh as intelligent function module parameters.
Since a programmable controller CPU limits the number of parameters that can be set for the mounted 
intelligent function modules, check the applicable number of parameters using this function and switch 
enabling/disabling for the parameters so that the number of set parameters is within the allowable 
range.
For the maximum number of parameters, refer to the manual of each intelligent function module.

Screen display
Select [Project] ⇒ [Intelligent Function Module] ⇒ [Intelligent Function Module Parameter List].
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Operating procedure

1. Set the items on the screen.

2. Click the  button.

● When the initial setting and the number of auto refresh settings cannot be changed
In case of the following conditions, the number of initial settings and auto refresh settings cannot be changed. Even 
when "Setting Exist" is selected, the display is masked and the check box is not displayed.
• Reserved module
• The access authority for security is in the write-protected mode.

■ Intelligent function module parameters

When the intelligent function module data are set, intelligent function module parameters are created. 
The intelligent function module parameters consist of initial setting and auto refresh.
The intelligent function module parameters, when written to a programmable controller CPU, operate 
as explained below. Write the intelligent function module parameters to the programmable controller 
CPU using the Write to PLC function. ( GX Works2 Version 1 Operating Manual (Common))
● Initial setting

The parameters of the individual intelligent function module data are set as initial setting data.
The initial setting data are registered to the programmable controller CPU parameters and 
automatically written to the intelligent function module when the programmable controller CPU turns 
to the RUN state.

● Auto refresh
If auto refresh is set to the buffer memory of an intelligent function module, data are write/read 
automatically to/from the specified devices when the END instruction is executed on the 
programmable controller CPU.

For the intelligent function module type and the availability of initial setting/auto refresh setting, refer to 
Section 2.1.1.

Item Description

XY Address Display the start XY address of the target intelligent function module.

Module Name Display the model of the target intelligent function module.

Initialization (Count)
Select whether to enable/disable initial setting. Clear the item if it is not set as an 
intelligent function module parameter. For a module that has no initial setting, "-" is 
displayed.

Auto Refresh (Count)
Select whether to enable/disable auto refresh. Clear the item if it is not set as an 
intelligent function module parameter. For a module for which auto refresh is not 
set, "No setting" is displayed.

Intelligent Function Module 
Parameter Setting Count Total Display the applicable number of intelligent function module parameters.

initial Display the number of initial settings set as intelligent function module parameters.

Auto Refresh Display the number of auto refreshes set as intelligent function module 
parameters.
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2.1.7  Checking/changing the applicable number of intelligent function module parameters

■ Number of parameter settings for intelligent function modules

The number of parameter settings for intelligent function modules (initial setting and auto refresh) are 
limited according to the programmable controller CPUs or MELSECNET/H Remote I/O modules. In 
addition, the number of parameter settings are also limited according to the type of intelligent function 
modules.
Be sure to set the total number of parameter settings of the intelligent function modules, not exceeding 
the maximum number of parameter settings of the programmable controller CPUs or MELSECNET/H 
Remote I/O modules.

● Limit for the number of parameter settings of the programmable controller CPUs or 
MELSECNET/H Remote I/O modules
The following table shows the number of parameter settings for the initial setting and the auto refresh 
that can be set on the programmable controller CPUs or MELSECNET/H Remote I/O modules.

Application target of intelligent function module
Maximum number of parameter settings

Initial setting Auto refresh

QCPU (Q mode)

Basic model QCPU,
High Performance model QCPU, 
MELSECNET/H Remote I/O module

512 256

Q00UJ, Q00U, Q01U, Q02U 2048 1024

Q03UD, Q03UDE, Q03UDV, Q04UDH, Q04UDEH,
Q04UDV, Q06UDH, Q06UDEH, Q06UDV, Q10UDH, 
Q10UDEH, Q13UDH, Q13UDEH, Q13UDV, Q20UDH, 
Q20UDEH, Q26UDH, Q26UDEH, Q26UDV, Q50UDEH, 
Q100UDEH

4096 2048

LCPU
L02S, L02, L02-P 2048 1024

L06, L26, L26-BT, L26-PBT 4096 2048
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● Limit for the number of parameter settings of the intelligent function modules
The following table shows the number of parameter settings for the initial setting and auto refresh 
that can be set on the intelligent function modules.
'-' in the Initial setting column indicates that the corresponding module does not have the initial 
setting.

CPU Module type Module model Initial setting 
(Fixed)

Auto refresh 
(maximum 

number of auto 
refreshes)

QCPU (Q mode)

Analog module

Q64AD 2 13

Q68ADV 1 25

Q68ADI 1 25

Q64AD-GH 5 27

Q62AD-DGH 9 15

Q68AD-G 7 36

Q66AD-DG 11 28

Q64ADH 11 75

Q62DAN 1 5

Q64DAN 1 9

Q68DAVN 1 17

Q68DAIN 1 17

Q62DA 1 5

Q64DA 1 9

Q68DAV 1 17

Q68DAI 1 17

Q62DA-FG 4 9

Q66DA-G 5 14

Q64DAH 4 11

Q64AD2DA 8 61

Q61LD 3 14

Q68CT 14 73

Temperature input module

Q64RD 5 18

Q64RD-G 5 18

Q64TD 6 13

Q64TDV-GH 6 13

Q68TD-G-H02 6 24

Q68TD-G-H01 6 24

Q68RD3-G 6 24

Temperature control module

Q64TCTT*1 21 61

Q64TCTTBW*1 21 73

Q64TCRT*1 21 61

Q64TCRTBW*1 21 73

Q64TCTTN*1 53 103

Q64TCTTBW*1 54 115

Q64TCRTN*1 52 103

Q64TCRTBW*1 53 115

Q62HLC 24 52
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QCPU (Q mode)

Counter module

QD62 8 14

QD62D 8 14

QD62E 8 14

QD63P6 6 48

QD64D2 6 16

QD60P8-G 24 8

QD65PD2 18 62

QD75 positioning module

QD75P1 - 7

QD75P2 - 14

QD75P4 - 28

QD75P1N - 7

QD75P2N - 14

QD75P4N - 28

QD75D1 - 7

QD75D2 - 14

QD75D4 - 28

QD75D1N - 7

QD75D2N - 14

QD75D4N - 28

QD75M1 - 7

QD75M2 - 14

QD75M4 - 28

QD75MH1 - 7

QD75MH2 - 14

QD75MH4 - 28

QD70 positioning module

QD70P4 12 26

QD70P8 24 50

QD70D4 16 26

QD70D8 32 50

QD72P3C3 12 18

QD73A1 4 5

CPU Module type Module model Initial setting 
(Fixed)

Auto refresh 
(maximum 

number of auto 
refreshes)
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QCPU (Q mode)

Serial communication/
Modem interface module

QJ71C24N - 46

QJ71C24N-R2 - 47

QJ71C24N-R4 - 46

QJ71C24 - 46

QJ71C24-R2 - 47

AS-i master module QJ71AS92 - 30

FL-net (OPCN-2) interface module

QJ71FL71-F01 2 14

QJ71FL71-T-F01 2 14

QJ71FL71-B2-F01 2 14

QJ71FL71-B5-F01 2 14

QJ71FL71 2 14

QJ71FL71-T 2 14

QJ71FL71-B2 2 14

QJ71FL71-B5 2 14

MODBUS® Interface Module
QJ71MT91 3 5

QJ71MB91 3 5

Simple motion module

QD77MS2 - 124

QD77MS4 - 224

QD77MS16 - 981

QD77GF16 - 7

AnyWireASLINK interface module QJ51AW12AL - 32

Energy measuring module

QE81WH 4 36

QE84WH 38 184

QE81WH4W 4 46

QE83WH4W 35 178

QE82LG 5 16

LCPU

Analog module

L60AD4 12 75

L60AD4-2GH 11 57

L60DA4 4 11

Temperature control module

L60TCTT4*1 43 103

L60TCTT4BW*1 43 115

L60TCRT4*1 43 103

L60TCRT4BW*1 43 115

Counter module
LD62 8 14

LD62D 8 14

LD75 positioning module

LD75P1 - 7

LD75P2 - 14

LD75P4 - 28

LD75D1 - 7

LD75D2 - 14

LD75D4 - 28

Simple motion module
LD77MH4 - 28

LD77MH16 - 112

Serial communication module
LJ71C24 - 50

LJ71C24-R2 - 51

AnyWireASLINK interface module QJ51AW12AL - 32

CPU Module type Module model Initial setting 
(Fixed)

Auto refresh 
(maximum 

number of auto 
refreshes)
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2.1.7  Checking/changing the applicable number of intelligent function module parameters

● Number of auto refresh settings
The number of auto refresh settings in which devices are set is counted.
In the following settings, the number of auto refresh settings is 8.

*1 : For the temperature control modules (except for Q62HLC), the number of auto refreshes can be reduced by switching 
to the Setting item reduction mode. For details of the Setting item reduction mode, refer to Section 3.3.3.
The following shows the maximum number of auto refreshes after reduction.

CPU Temperature control module

Auto refresh 
(maximum 

number of auto 
refreshes)

QCPU (Q mode)

Q64TCTT 11

Q64TCTTBW 12

Q64TCRT 11

Q64TCRTBW 12

Q64TCTTN 35

Q64TCTTBWN 36

Q64TCRTN 35

Q64TCRTBWN 36

LCPU

L60TCTT4 35

L60TCTT4BW 36

L60TCRT4 35

L60TCRT4BW 36
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2.1.8 Checking device duplication of auto refresh setting

Check the device duplication of auto refresh settings among intelligent function modules.

Screen display
Select [Tool] ⇒ [Check Intelligent Function Module Parameter] ⇒ [Check Auto Refresh 
Duplication].

Operating procedure

1. Select the modules to check the device duplication of auto refresh settings.

2. Click the  button.
If device duplication is found, the check result is displayed on the Output window.
By double-clicking the result, the corresponding error location in the program is displayed.

● When the device duplication of auto refresh settings cannot be checked
In case of the following conditions, the module is recognized as a module that cannot check the device duplication of 
auto refresh settings, and "Cannot Select" is displayed.
• No device is set on the Auto Refresh screen.
• The check box is cleared in the intelligent function module parameter list.
• The module start XY address is not set.
• Reserved module
• The access authority for security is in the read-protected mode.
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2.1.9  Changing intelligent function module type

2.1.9 Changing intelligent function module type

The following explains the operating procedure to change intelligent function module type, for instance, 
from QD75P4 to QD75D4, or from LD75D4 to LD75P4.
The intelligent function module type can be changed by copying and pasting the original data onto the 
parameter setting screen of the new module data.

The following operating procedure is the instance when changing the type from QD75P4 to QD75D4.

Operating procedure

1. Add new intelligent function module 
data. (Section 2.1.1)

2. Display both parameter setting screens of the original module and the new module.

3. On the parameter setting screen of the original module, right-click the top left cell 
and select [Copy] from the shortcut menu to copy all data.

Add a new module.
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4. On the parameter setting screen of the new module, right-click the top left cell and 
select [Paste] from the shortcut menu to paste all data.
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2.2 Utilizing Sample Comments of Intelligent Function Module

Utilize sample comments of intelligent function module devices for device comments.
For details of the operation method, refer to the following manual.
GX Works2 Version 1 Operating Manual (Common)

2.3 Writing/Reading Intelligent Function Module Data

Write the set intelligent function module data to the programmable controller CPU, or the buffer 
memory and flash ROM of the intelligent function module.
For details of the operation method, refer to the following manual.
GX Works2 Version 1 Operating Manual (Common)
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2.4 Monitoring Intelligent Function Modules

This section explains how to monitor input/output signals and buffer memory of an intelligent 
function module.
For QD75/LD75 positioning module, this function is used to debug a program such as a ladder 
program. For checking an operation of QD75/LD75 positioning module or debugging, use the 
positioning monitoring.
(Section 3.5.1)

2.4.1 Registering and monitoring intelligent function modules

Register and monitor module information of an intelligent function module.

Screen display
Select [View] ⇒ [Docking Window] ⇒ [Intelligent Function Module Monitor], and select from 
[Module 1] to [Module 10].

Display contents

Operating procedure

1. Register the intelligent function module to be monitored.
For the registration method, refer to Section 2.4.2.

2. Select [Online] ⇒ [Watch] ⇒ [Start Watching].
The current values of the registered intelligent function module are displayed on the window.

Item Description

Item
Display the name of the module information.
When "Data Type" is 'Detail Dialog' ( )/'Error Code' or 'Warning Code' ( ), an icon is displayed at 
the head of each item.

Current value Display the current value of the module information. Display character strings such as ON/OFF.

Device Display the device assigned to the module information.

Data Type
Display the data type of the module information.
For 'Detail Dialog'/'Error Code'/'Warning Code', details of each item can be confirmed. For details, 
refer to Point in this section.
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2.4.1  Registering and monitoring intelligent function modules

■ Customizing monitoring items

The module information registered to the Intelligent Function Module Monitor window can be 
customized by cutting/copying/pasting/deleting unnecessary items.
The customized settings are saved along with the project.
Note that the operations to 'undo' the customized items cannot be performed.

Operating procedure

• Select an unnecessary item on the Intelligent Function Module Monitor window, 
right-click it and select [Cut]/[Copy]/[Paste]/[Delete] from the shortcut menu.

● Paste
The cut/copied items can be pasted in the same project in the same window only.

● Project created in former version
If a project to which the Intelligent Function Module Monitor is registered in GX Works2 Version 1.07H or earlier is 
opened in GX Works2 Version 1.50C or later, all registered module information is discarded.

● Changing current value
The current value can be changed by directly inputting the desired value in "Current value" area during monitoring.
When the current value to be changed is displayed in character strings such as ON/OFF, available choices are shown 
in a combo box. The current value cannot be changed is displayed in gray background.
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● Detailed display of history information
For the analog module, QD75/LD75 type positioning module, and FL-net (OPCN-2) interface module, details of the 
history information can be displayed during the monitoring.
To display details of the history information, double-click a row in which 'Detail Dialog' is displayed in the "Data Type" 
column, or right-click it and select [Detail Dialog] from the shortcut menu.
The following shows the Detail Dialog screen for QD75P4.

● Detailed display of error code/warning code
Details of the error code/warning code can be displayed from the Intelligent Function Module Monitor windows or the 
screen of error/warning history.
To display details of the error code/warning code, double-click a row in which an error code/warning code is displayed, 
or right-click it and select [Detail Display] from the shortcut menu.
The following shows the Detail Display screen of error code for QD75P4.

● Using multiple Intelligent Function Module Monitor windows
Each axis of positioning module can be monitored by activating multiple Intelligent Function Module Monitor windows 
and customizing the settings of each window.

Restrictions

● Updating values on the Intelligent Function Module Monitor window
The Intelligent Function Module Monitor updates only values within the range displayed on the window for monitoring 
acceleration.
When executing operation such as copy and paste on an Excel spreadsheet, "--" or the previously monitored value is 
displayed for the data outside the range displayed on the window.

For Axis #1 For Axis #2 For Axis #3 For Axis #4
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2.4.2  Registering intelligent function modules

2.4.2 Registering intelligent function modules

Register an intelligent function module to the Intelligent Function Module Monitor window.

■ Registering intelligent function modules using shortcut menu from Project 
view

Register an intelligent function module using the shortcut menu from the Project view.

Operation
1. Select a module to be registered to the Intelligent Function Module Monitor window from 

the Project view.

2. Right-click and select [Register to Intelligent Function Module Monitor] in the shortcut 
menu.
The module is registered to the Intelligent Function Module Monitor window.

■ Registering intelligent function modules with drag-and-drop operation

Register an intelligent function module with the drag-and-drop operation from the Project view.

Operation
1. Select a module to be registered from the Project view.

2. Drag and drop it to the Intelligent Function Module Monitor window.
The module is registered.

Drag and drop
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■ Registering intelligent function modules using shortcut menu from 
Intelligent Function Module Monitor window

Register an intelligent function module using the shortcut menu from the Intelligent Function Module 
Monitor window.

Operation
1. On the Intelligent Function Module Monitor window on which the registration is to be 

canceled, right-click and select [Register Module Information] in the shortcut menu.
The Module Information Selection screen is displayed.

2. Select a module to be registered from "Module List" and click the  button.
The module is registered to the Intelligent Function Module Monitor window.

When selecting the positioning module, AS-i master module, or FL-net (OPCN-2) interface 
module in "Module List", select an item displayed on "Monitor Item Category List".

Example: AS-i master module

● Customizing monitoring items
The registered intelligent function module information can be customized by right-clicking the desired 
module information on the Intelligent Function Module Monitor window and selecting [Cut]/[Copy]/[Paste]/[Delete] in the 
shortcut menu. (Section 2.4.1)

● Copying module information
Module information can be copied by right-clicking a desired module information and selecting [Copy] from the shortcut 
menu on the Intelligent Function Module Monitor window, and pasted to such as text files.
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2.4.3  Canceling registration of intelligent function modules

2.4.3 Canceling registration of intelligent function modules

Cancel the registration of the module information which is registered to the Intelligent Function Module 
Monitor.

Operation
1. On the Intelligent Function Module Monitor window on which the registration is to be 

canceled, right-click and select [Register Module Information] in the shortcut menu.
The Module Information Selection screen is displayed.

2. Select "(Disable registration)" and click the  button.
The registration of the module is canceled.
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3 - 1

3 OPERATING 
INTELLIGENT FUNCTION 
MODULES

This chapter explains the operations of such as the intelligent function module tools.

3.1 Analog Module 3 - 2

3.2 Temperature Input Module 3 - 11

3.3 Temperature Control Module 3 - 13

3.4 Counter Module 3 - 18

3.5 QD75/LD75 Positioning Module 3 - 20

3.6 Simple Motion Module 3 - 53

3.7 Serial Communication/Modem Interface Module 3 - 54

3.8 AnyWireASLINK Configuration Window 3 - 60
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3.1.1  Offset and gain settings

3.1 Analog Module

This section explains the operations of the intelligent function module tools related to the analog 
module.

3.1.1 Offset and gain settings

Perform the offset/gain settings of the analog module.
For details of offset/gain settings, refer to the user's manual of the module to be used.

Operating procedure

1. Select [Tool] ⇒ [Intelligent Function Module Tool] ⇒ [Analog Module] ⇒ [Offset/
Gain Setting] (  ).
The Module Selection (Offset/Gain Setting) screen is displayed.

2. Select a module and click the  button.
The Offset/Gain Setting screen is displayed.
For details of the operations of offset and gain settings of analog modules, refer to the following 
sections.
■ Settings on A/D converter module
■ Settings on D/A converter module
■ Settings on Q68CT

● Module operation mode
When the offset/gain settings are performed, the following operation mode transition confirmation message is displayed 
according to the module's function version.
If the message is not displayed, the module operation mode needs to be set to the offset/gain setting mode by the 
switch setting of intelligent function module.
For details, refer to the user's manual of the module to be used.
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■ Settings on A/D converter module

The following explains the operation of offset/gain settings using Q68AD-G as an example.

Operating procedure

1. Select the offset/gain setting target channel(s) under "Channel Selection".

2. Apply an electric current or voltage to the module.

3. Click the    or    button.

The   button sets the analog value which is input to the specified channel as an offset 
value.

The   button performs the gain setting to the specified channel.
When the settings are completed normally, "Changed" is displayed on the 'Offset/Gain status' 
fields.
When an error occurs, an error code is displayed at "Error Code".

4. Click the   button.
The offset values and gain values are registered to the module.

Screen button

●

Displays the error description and the corrective action for the displayed error code.

●

Clears the error.

Offset/Gain status
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3.1.1  Offset and gain settings

■ Settings on D/A converter module

The following explains the operation of offset/gain settings using Q68DAIN as an example.

Operating procedure

1. Select the channel number and select either "Offset Setting" or "Gain Setting".

2. Select or enter a value for "Adjustment Value".

3. Click the    or    button.
The offset/gain values increase or decrease for the amount set as an adjustment value.
When the settings are completed normally, "Changed" is displayed on the 'Offset/Gain status' 
fields.
When an error occurs, an error code is displayed at "Error Code".

4. Click the    button.
The offset values and gain values are registered to the module.

Screen button
For the screen buttons, refer to ■ Settings on A/D converter module.

Offset/Gain status
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■ Settings on Q68CT

The following explains the operation of offset/gain settings using Q68CT.

Operating procedure

1. Select the offset/gain setting target channel(s) under "Channel Selection".

2. Apply an electric current or voltage to the module.

3. Click the   or     button.
The following confirmation message is displayed.*1

*1 : The message will not be displayed when the module operation mode is already set to the offset/gain setting mode 
by the switch setting of the intelligent function module.

Offset/Gain status
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3.1.1  Offset and gain settings

4. Click the    button.
The Input Range Setting screen is displayed.

5. Set "Input Range", and click the    button.
When the settings are completed normally, "Changed" is displayed in the 'Offset/Gain status' 
fields.
When an error occurs, an error code is displayed at "Error Code".

6. Click the    button.
The offset values and gain values are registered to the module.

Screen button
For the screen buttons, refer to ■ Settings on A/D converter module.
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3.1.2 Q61LD two-point calibration

Perform the two-point calibration to use Q61LD as a measuring device.
For the detailed settings, refer to the user's manual of the module to be used.

Operating procedure

1. Select [Tool] ⇒ [Intelligent Function Module Tool] ⇒ [Analog Module] 
⇒ [Q61LD Two-Point Calibration Setting].
The Module Selection (Q61LD Two-Point Calibration Setting) screen is displayed.

2. Select a module, and click the    button.
The Two-Point Calibration Setting screen is displayed.
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3.1.2  Q61LD two-point calibration

3. Click the    button.
The Scale Initial Setting screen is displayed.

4. Set the conditions on the left side of the screen, and click the    
button.
The settings are written to the module.

5. Click the    button.
The two-point zero calibration is performed.

6. Click the    button.
The two-point span calibration is performed.

Screen button

●

Opens the screen to set the installation site gravitational acceleration.

●

Opens the screen to correct the two-point calibration value of the scale.
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3.1.3 Q61LD default settings

Batch restore the Q61LD parameters to the factory default settings when the setting of module is 
incorrect, an error occurs, or using in another system.
For details of such as setting items, refer to the user's manual of the module.

Operating procedure

1. Select [Tool] ⇒ [Intelligent Function Module Tool] ⇒ [Analog Module] 
⇒ [Q61LD Default Setting].
The  Module Selection (Q61LD Default Setting) screen is displayed.

2. Select a module, and click the    button.
The following message is displayed.

3. Click the    button.
The default settings are written to Q61LD.
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3.1.4  Waveform output data creation

3.1.4 Waveform output data creation

Create the waveform output data. Complicated output waveform can be created with simple mouse 
operations.
Created data can be saved as a CSV file or written to a device memory in a project. 
For details of such as functions and setting items, refer to the user's manual of the module.

Screen display
● Creating waveform output data

Select [Tool] ⇒ [Intelligent Function Module Tool] ⇒ [Analog Module] ⇒ [Create Waveform Output 
Data].
Register waveform pattern, set waveform output data, and write/read waveform output data on the 
following screen.

● Registering waveform pattern
Double-click on the graph under "Register waveform pattern" on the Create Waveform Output Data 
screen, or select the graph and press the  key.
Set waveform pattern information, edit waveform graph, and set waveform details on the following 
screen.
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3.2 Temperature Input Module

This section explains the operations of the intelligent function module tools related to the 
temperature input module.

3.2.1 Offset and gain settings

Perform the offset/gain settings of the temperature input module.
For details of offset/gain settings, refer to the user's manual of the module to be used.

Operating procedure

1. Select [Tool] ⇒ [Intelligent Function Module Tool] ⇒ [Temperature Input Module] ⇒ 
[Offset/Gain Setting] (  ).
The Module Selection (Offset/Gain Setting) screen is displayed.

2. Select a module and click the    button.
The Offset/Gain Setting screen is displayed.

The following indicates the operation of offset/gain settings using Q68TD-G-H02 as an example.
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3.2.1  Offset and gain settings

3. Select the offset/gain setting target channel(s) under "Channel Selection".

4. Set an offset value or a gain value on the thermocouple or the standard direct 
current voltage generator for the channel whose offset/gain setting to be adjusted.

5. Enter values to "Offset Temperature Setting Value" or "Gain Temperature Setting 
Value".

6. Click the    or    button.

The    button sets the analog value which is input to the specified channel as an 
offset value.

The    button performs the gain setting to the specified channel.
When the settings are completed normally, "Changed" is displayed on the "Offset Status" or "Gain 
Status" fields.
When an error occurs, an error code is displayed at "Error Code".

7. Click the    button.
The offset values and gain values are registered to the module.



3.3  Temperature Control Module

3.3.1  Automatic tuning 3 - 13

1

O
V

E
R

V
IE

W

2

CO
M

M
ON

 O
PE

RA
TI

ON
S 

FO
R 

IN
TE

LL
IG

EN
T 

FU
NC

TI
ON

 M
OD

UL
ES

3

O
PE

RA
TI

NG
 

IN
TE

LL
IG

EN
T 

FU
NC

TI
O

N 
M

O
DU

LE
S

4

PR
ED

EF
IN

ED
 

PR
O

TO
CO

L 
SU

PP
O

RT
 F

UN
CT

IO
N

A

AP
P

EN
D

IX

I

IN
D

E
X

3.3 Temperature Control Module

This section explains the operations of the intelligent function module tools related to the 
temperature control module.

3.3.1 Automatic tuning

Perform the automatic tuning of the temperature control module.
For details of automatic tuning, refer to the user's manual of the module to be used.

Operating procedure

1. Select [Tool] ⇒ [Intelligent Function Module Tool] ⇒ [Temperature Control Module] 
⇒ [Auto Tuning].
The Module Selection (Auto Tuning) screen is displayed.

2. Select a module and click the    button.
The Auto Tuning screen is displayed.
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3.3.1  Automatic tuning

3. When "Mode" is set to "Setting Mode", click the    button.
The operation mode of the temperature control function is changed to "Operation Mode".

4. Select the <<Auto Tuning Setting>> Tab.

5. Configure the automatic tuning settings.
For details of setting items, refer to the user's manual of the module to be used.

6. Click the    button.
The set values are written to the buffer memory of the module.

7. Select the <<Auto Tuning Execution>> tab.

8. Click the    button.
The automatic tuning is started.

Screen button
For the screen buttons, refer to Section 3.1.1.
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3.3.2 Sensor Correction

Perform the sensor correction of temperature control module.
For details of sensor correction, refer to the user's manual of the module to be used.

Operating procedure

1. Select [Tool] ⇒ [Intelligent Function Module Tool] ⇒ [Temperature Control Module] 
⇒ [Sensor Correction].
The Module Selection (Sensor Correction Function) screen is displayed.

2. Select a module, and click the    button.
The Sensor Correction screen is displayed.

3. Select the target channel from "(1) Target Channel".

4. Select a method for sensor correction from "(3) Sensor Correction Function 
Selection".
For details of setting items, refer to the user's manual of the module to be used.
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5. Enter a correction value on "(4) Normal Sensor Correction (One-point Correction)" 
or "(4) Sensor Two-point Correction", and click the   /  / 

  button.
The set values are written to the buffer memory of the module.

6. For "(4) Sensor Two-point Correction", click the    button.

7. Click the    button.
The correction value is registered to the module.

Screen button
For details of screen buttons, refer to Section 3.1.1.

● Considerations when initial settings are set on PLC parameter
When the initial settings are set on the PLC parameter, if the power is turned OFF to ON, or the CPU module is reset 
and then canceled after the execution of sensor correction on the Sensor Correction screen, the value of "Sensor 
correction value setting" set on the PLC parameter is given priority at the start of the module.
When using the value set on the Sensor Correction screen after the power is turned OFF to ON, or the CPU module is 
reset and then canceled, correct the setting value of "Sensor correction value setting" on the PLC parameter, and 
execute Write to PLC.
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3.3.3 Reducing number of auto refreshes

Change the mode of auto refresh of open temperature control module to the Setting item reduction 
mode.
When changed to the Setting item reduction mode, the parameter items are grouped, and devices are 
set only on the start item of group. This operation reduces the number of settings of intelligent function 
module parameters when using multiple temperature control modules.
For the number of auto refreshes after reduction, refer to Section 2.1.7.

Operating procedure

1. Select [Edit] ⇒ [Setting Item Reduction Mode].
The following message is displayed.

2. Click the    button.
The mode is changed to the Setting item reduction mode, and the parameter items are grouped.

3. Set a start device on the parameter item.
The sequential devices are set in the group automatically.

● When returning to the normal mode from the Setting item reduction mode
When returning to the normal mode from the Setting item reduction mode, select [Edit] ⇒ [Setting Item Reduction 
Mode].

● Considerations when changing modes
Changing modes clears all the previous settings.

● Reading auto refresh that is set with the Setting item reduction mode in GX Configurator-TC
• The settings of auto refresh set in group unit cannot be displayed properly when reading in GX Configurator-TC. The 

device set on the start item of group is displayed.
• Do not edit the settings of auto refresh being read in GX Configurator-TC.

The sequential 

devices are set 

in the group.
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3.4.1  Preset function

3.4 Counter Module

This section explains the operations of the intelligent function module tools related to the counter 
module.

3.4.1 Preset function

Perform the preset function.
For details of preset function, refer to the user's manual of the module to be used.

Operating procedure

1. Select [Tool] ⇒ [Intelligent Function Module Tool] ⇒ [Counter Module] ⇒ [Preset].
The Module Selection (Preset) screen is displayed.

2. Select a module and click the    button.
The Preset screen is displayed.

3. Select a channel number to which the preset is performed.
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4. Click the  button.

The Change Preset Value screen is displayed.

5. Enter a preset value to "New Preset Value".

6. Click the    button.
The set preset value is written to the buffer memory of the module.

Screen button

●

Click to execute the preset from this screen.
Updates the current value of the selected channel with the preset value.

●

Click to execute the preset by the external control signal.
Validates the reception of the external preset request of the selected channel.
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3.5 QD75/LD75 Positioning Module

This section explains the operations of the intelligent function module tools related to the QD75/LD75 
positioning module.

3.5.1 Positioning monitoring

Execute the positioning monitoring of QD75/LD75 positioning module.
The positioning monitoring is used for checking an operation of QD75/LD75 positioning module or 
debugging. When debugging a program such as a ladder program, use the Intelligent Function Module 
Monitor. 
(Section 2.4)
For details of the monitoring items, refer to the user's manual of the module to be used.

Operating procedure

1. Select [Tool] ⇒ [Intelligent Function Module Tool] ⇒ [QD75/LD75 Positioning 
Module] ⇒ [Positioning Monitor] ( ).
The Module Selection (Positioning Monitor) screen is displayed.

 CAUTION
● The positioning test functions of OPR, JOG, inching or positioning data for QD75/LD75 positioning module must be 

executed with the programmable controller set to STOP after the manual has been carefully read and the safety has been 
ensured. Specially when executing the function on the network system, ensure the safety thoroughly since the machinery 
whose operation cannot be checked by an operator may be activated. The operation failure may cause the injury or 
machine damage.
Ensure the high-speed line condition as much as possible by such as stopping other monitoring functions during 
execution, and connecting the personal computer and the CPU module directly with USB.
Since the stop request from GX Works2 to the positioning module is delayed depending on the transmission speed, the 
stop of the motor connected to the positioning module may be delayed.

● Error occurrence on positioning module with error code 103 at positioning test execution
Refer to Point in Section 3.5.2.
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2. Select a module and click the    button.
The monitor screen of positioning module is displayed.

Display contents

Toolbar

Item Description

Toolbar

Display tool buttons for executing each function. Check the histories and start/stop 
monitoring with each tool button. For details of each history, refer to the following 
sections.
■ Starting history
■ Error history
■ Warning history

Axis Monitor Display the monitoring result of positioning module.

Monitor type

Select a monitoring item. The monitoring items are as follows:
• Operation monitor
• Operation monitor (Axis control)
• Operation monitor (Speed-position switching control)
• Operation monitor (Position-speed switching control)
• Operation monitor (OPR monitor)
• Operation monitor (JOG/manual pulse)
• Servo monitor (Servo state)
• Servo monitor (Torque control/servo load factor)
• Servo monitor (Content of servo parameter setting)
• Servo monitor (Servo parameter error)

Font Size Set a font for the Axis Monitor screen.

Module Information List

QD75 READY (X0), Synchronization flag (X1), M code ON for each axis.

The color is turned to green 

when it is turned ON.
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Screen button

●

Displays the Monitor Item Selection screen.
Select axes of monitoring target or monitoring items.
The screen when "Operation monitor" is selected as a monitoring type is as shown below.

■ Starting history

Monitor the starting history which is stored in a buffer memory of QD75/LD75 positioning module.

Operating procedure

• Right-click on the Positioning Monitor screen and select [Starting History] ( ) from 
the shortcut menu.

Screen button

●

Saves the currently displayed history to a file in the CSV file format.
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■ Error history

Monitor the error history which is stored in a buffer memory of QD75/LD75 positioning module.

Operating procedure

• Right-click on the Positioning Monitor screen and select [Error History] ( ) from 
the shortcut menu.

Screen button
For the screen buttons, refer to ■ Starting history.

■ Warning history

Monitor the warning history which is stored in a buffer memory of QD75/LD75 positioning module.

Operating procedure

• Right-click on the Positioning Monitor screen and select [Warning History] ( ) 
from the shortcut menu.

Screen button
For the screen buttons, refer to ■ Starting history.
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3.5.2 Positioning test

Perform the positioning test of QD75/LD75 positioning module.
For details of testing items, refer to the user's manual of the module to be used.

Operating procedure

1. Select [Tool] ⇒ [Intelligent Function Module Tool] ⇒ [QD75/LD75 Positioning 
Module] ⇒ [Positioning Test] ( ).
The Module Selection (Positioning Test) screen is displayed.
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2. Select a module, and click the  button.
The Positioning Test screen is displayed.

The test function can be switched by selecting an item in "Select Function" under "Test" section.
For details of each test function, refer to the following sections.
■ Positioning start test
■ JOG, manual pulse generator, and OPR tests
■ Speed change test
■ Current value change test

Screen button

●

Starts the positioning operation.

●

Decelerates and stops the currently-running sequential positioning operation, and starts the 
operation of the next positioning number by clicking the button during the positioning operation.

●

Stops the positioning control of the selected "Target Axis" by clicking the button during the positioning 
operation.

●

Stops the positioning control of all the axes by clicking the button during the positioning operation.

●

Restarts the suspended positioning operation by clicking the button when the positioning operation is 
in a suspended status.

●

Ends the positioning operation prior to the operation of the next positioning number.

●

Displays the Error/Warning Details Confirmation screen when an error or warning is occurring to the 
axis set for "Target Axis". Check the error description and the corrective action.

Test function selection
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●

Clears the error or warning of the target axis when an error or warning is occurring to the axis set for 
"Target Axis".

●

Turns the M code status OFF when the axis with M code ON is set for "Target Axis".

●

Performs the servo ON/OFF command for QD75M/MH.

● Testing before installing external devices such as servo amplifiers and motors.
The following message is displayed after selecting a module. Click the  button.

● Error occurrence on positioning module with error code 103 during positioning test execution
Take a corrective action such as setting the transmission speed to high speed on the Transfer Setup screen, 
connecting the personal computer to the communication I/F of CPU module directly, and stopping other functions (such 
as monitoring function) that use the communication port.
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■ Positioning start test

Perform the test operation by specifying a positioning data number or a point number of block start 
data.

Operating procedure

1. Select "Positioning start signal" for "Select Function" on the Positioning Test 
screen.

2. Set the items on the screen.

Item Description

Start Type Select a start type for the test operation.

Positioning Start Signal Select this to perform the positioning start.

Positioning Data No. Set a positioning data number.

Block start Select this to perform the block start.

Block No. Set a block number.

Point No. Set a point number.

Multiple Axes Simultaneous Start Select this to perform the multiple axes simultaneous start.

Multiple Axes 
Simultaneous Positioning 
Start Data No.

Set positioning data numbers for each axis.

Step Select this to perform the step start, and select the step mode.

External Command Validate a speed-position switch and/or a position-speed switch.

External Command Valid Select this to validate external commands.

Speed-position Switching Enable 
Flag Select this to validate the external command of speed-position switch.

Position-speed Switching Enable 
Flag Select this to validate the external command of speed-position switch.
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3. Click the  button.
The positioning operation is started.

Screen button

●

Performs the step start from the next positioning data number when the button is clicked during the 
step standby status.

●

Validates the items selected for "External Command".

■ JOG, manual pulse generator, and OPR tests

Perform the JOG, manual pulse generator, and OPR tests.

Operating procedure

1. Select "JOG/Manual Pulse Generator/OPR" for "Select Function" on the 
Positioning Test screen.
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2. Set the items on the screen.

3. Click the   /   button.
For the JOG operation (when "Inching Movement Amount" is '0'), performs the JOG operation in 
forward rotation or reverse rotation while pressing the button.
For the inching operation (when "Inching Movement Amount" is more than '1'), outputs pulses for 
the amount of inching in forward rotation or reverse rotation by each click.

Screen button

●

Performs the OPR control when the positioning operation is in a suspended status.

Item Description

JOG -

JOG Speed Set the JOG speed for JOG operation. 
This item is ignored for inching operation.

Inching Movement Amount Set the travel amount for inching operation. 
Set '0' for JOG operation.

Manual Pulse Generator
Select "Manual pulse generator enable flag" to perform the manual pulse 
generator operation and enter a value for "Manual Pulse1 Pulse Generator Input 
Magnification".

OPR Operation Select the OPR method.
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■ Speed change test

Change the speed of axis which is being operated under the positioning start test, JOG test, or OPR 
test.

Operating procedure

1. Select "New Speed" for "Select Function" on the Positioning Test screen.

2. Set the items on the screen.

3. Click the    button.
The speed is changed.

Screen button

●

Performs the speed override during the positioning operation.

Item Description

New Speed Set a speed. Set '0' to stop the operation.

Override Set a value to override the speed of positioning operation.

Acceleration/Deceleration Time 
Change

Select this to permit the change on acceleration/deceleration time, and specify the 
acceleration time and/or deceleration time.
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■ Current value change test

Change the current feed value when the positioning operation is in a suspended status or a step 
standby status.

Operating procedure

1. Select "Current Value Changing" for "Select Function" on the Positioning Test 
screen.

2. Set the item on the screen.

3. Click the    button.
The current feed value is changed.

Item Description

Current Value Changing Set a new current value.
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3.5.3 Wave trace

Perform the wave trace of QD75/LD75 positioning module.
The wave trace function displays the waveform data of speed command during the positioning 
operation. The value shifts of each axis operated online by the positioning module are displayed.
This function is not supported by QD75M/QD75MH.

Screen display
Select [Tool] ⇒ [Intelligent Function Module Tool] ⇒ [QD75/LD75 Positioning Module] ⇒ 
[Wave Trace] ( ).
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Operating procedure

1. Click the    button.
The Module Selection (Wave Trace) screen is displayed.

2. Select a module to perform the wave trace and click the    button.

3. Click the    button.
The Wave Trace Condition Setting screen is displayed.

4. Set the trace condition and click the    button.
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5. Click the   button.
The wave trace is started.
When the completion condition is satisfied, or by clicking the    button, the 
trace data are read and displayed on the screen.
The values at each position can be checked on the <<AB Cursor Position>> tab by dragging the 
AB cursor in "Trace Result".

Screen button

●

Returns the width and height scales to 100%, and initializes the graph display scale.

●

Reads the trace data stored on a personal computer and displays them on the Wave Trace 
screen.

●

Stores the obtained trace data on a personal computer.

AB cursor
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3.5.4 Location trace

Perform the location trace of QD75/LD75 positioning module.
The location trace function displays the location data of two-axis interpolation and simultaneous start 
(two axes).
This function is not supported by QD75M/QD75MH.

Screen display
Select [Tool] ⇒ [Intelligent Function Module Tool] ⇒ 
[QD75/LD75 Positioning Module] ⇒ [Location Trace] ( ).
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Operating procedure

1. Click the    button.
The Module Selection (Location Trace) screen is displayed.

2. Select a module to perform the location trace and click the    button.

3. Click the    button.
The  Location Trace Condition Setting screen is displayed.

4. Set the trace condition and click the    button.
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5. Click the    button.
The location trace is started.
When the completion condition is satisfied, or by clicking the    button, the 
trace data are read and displayed on the screen.
The values at each position can be checked on the <<AB Cursor Position>> tab by dragging the 
AB cursor in "Trace Result".

Screen button
For the screen buttons, refer to Section 3.5.3.

AB cursor

cd cursor
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3.5.5  Requesting parameter initialization and flash ROM write

3.5.5 Requesting parameter initialization and flash ROM write

Request a buffer memory data write from the QD75/LD75 positioning module to the flash ROM. Buffer 
memory data can be initialized and applied to the flash ROM.
Parameters, servo parameters, positioning data, and block start data (including condition data) of all 
ranges are written in batch from the buffer memory to the flash ROM.

Operating procedure

1. Select [Tool] ⇒ [Request of Parameter Initialization/Flash ROM Write Request].
The Request of Parameter Initialization/Flash ROM Write Request screen is displayed.

2. Select an item under "Execution Item", and click the    button.
The request of the selected item is executed.
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3.5.6 Convenient functions for editing data

The following explains the convenient functions for editing data of QD75/LD75 positioning module.

■ Displaying guidance of QD75/LD75 positioning module

For QD75/LD75 positioning module, the explanations of each item of intelligent function module data 
can be checked on the Intelligent Function Module Guidance window.
A detailed explanation of the item at the cursor position is displayed when editing data.

Screen display
Select [View] ⇒ [Docking Window] ⇒ [Intelligent Function Module Guidance] ( ).

● Items displayed in blue
A detailed explanation of the selected item can be displayed by clicking the item displayed in blue.

● Displaying/hiding the Intelligent function module guidance window
To display/hide the Intelligent function module guidance window, select [Tool] ⇒ [Options] ⇒ "Intelligent Function 
Module" ⇒ "Guidance" ⇒ "Display intelligent function module guidance".
For details of displaying/hiding the Intelligent function module guidance window, refer to the following manual.
GX Works2 Version 1 Operating Manual (Common)
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■ Jump

Move the cursor to the specified data number on the positioning data setting screen.

Operating procedure

1. Select [Edit] ⇒ [Jump].
The Jump screen is displayed.

2. Enter a positioning data number of the jump destination.

3. Click the    button.
The cursor moves to the specified positioning data number.

■ Setting maximum/minimum/default value

Set a maximum value, minimum value, or default value on the setting screen of parameters or servo 
parameters.

Operating procedure

1. Select the item to which a maximum value, minimum value, or default value is set.

2. Select [Edit] ⇒ [Set Maximum Value]/[Set Minimum Value]/[Set Default Value].
The maximum/minimum/default value is set.

■ Calculating electronic gear

Check the electronic gear on the parameter setting screen according to the set data.

Operating procedure

• Select [Edit] ] ⇒ [Computation of Electronic Gear].
The calculation result of the electronic gear is displayed.
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■ Initialization of rows/columns

Initialize data in the rows/columns on the positioning data setting screen or the block start data setting 
screen.

Operating procedure

1. Select the row(s) or column(s) whose data to be initialized.

2. Select [Edit] ⇒ [Initialization of Row]/[Initialization of Column].
The data of the selected row(s) or column(s) are initialized.

■ Inserting/deleting rows

Insert/delete rows on the positioning data setting screen or the block start data setting screen.

Operating procedure

1. Select the item(s) where a row(s) is/are inserted above or whose row(s) to be 
deleted.

2. Select [Edit] ⇒ [Insert Row]/[Delete Row].
The row(s) is/are inserted above the selected item, or the row(s) of the selected item(s) is/are 
deleted.

■ Copying/Pasting positioning data

Copy/paste the setting of positioning data on the positioning data setting screen.

Operating procedure

1. Select the item of the positioning data number to be copied.

2. Select [Edit] ⇒ [Positioning Data Copy].
Data of the positioning data number at the cursor position are copied.

3. Select the item of the positioning data number to be pasted.

4. Select [Edit] ⇒ [Positioning Data Paste].
The copied data of positioning data number is pasted to the selected row.
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■ Block start copy

Utilize specified block start data to another axis or block on the block start data setting screen.

Operating procedure

1. Select [Edit] ⇒ [Block Start Copy].
The Block Start Copy screen is displayed.
The screen image below is an example when the operation is performed on the data of QD75P4.

2. Specify the axis or block number of the copy destination, and click the    
button.
The block start copy is executed.

■ Editing M code comments

Set comments to the M code, which is required for synchronizing with the positioning control, on the 
positioning data setting screen. M code comments are saved only within the project.

Operating procedure

1. Select [Edit] ⇒ [M Code Comment Edit].
The M Code Comment Edit screen is displayed.

2. Set the items on the screen.

3. Click the    button.
M code comments are set.

Item Description

M Code Enter M code numbers within the range from 1 to 65535.
A maximum number of M code comments that can be set is 50.

M Code Comment Enter M code comments.
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Screen button

●

Applies the M code at the cursor position on the M Code Comment Edit screen to the row where the 
cursor is positioned on the positioning data setting screen.

●

Deletes the M code and M code comment of the row at the cursor position.

■ Editing condition data

Set condition data such as condition start, wait start, simultaneous start of block start data, and start 
condition of FOR condition on the positioning data setting screen or the block start data setting screen.

Operating procedure

1. Select [Edit] ⇒ [Condition Data Edit].
The Condition Data List screen is displayed.

2. Select the item to which condition data are set, and click the    button.
The Condition Data Edit screen is displayed.

3. Set the items on the screen.

Item Description

Condition Operator

Select a condition operator.
"**" indicates buffer memory address.
"P1" and "P2" indicate parameters (values to be specified).
"Device" indicates X and Y devices.

Condition Identifier Select a condition identifier.

Condition Data Enter the condition data such as buffer memory address and parameter.
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4. Click the    button.
The condition data are set.

Screen button

●

Deletes the condition data at the cursor.

■ Offline simulation

Simulate the waveform and location of set positioning data offline.

Operating procedure

• Open the positioning data setting screen, and select [Tool] ⇒ [Offline Simulation], 
or click the    button.
The Offline Simulation screen is displayed.
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■ Automatic command speed calculation

Automatically calculate the constant speed of traveling time between the start position and the target 
position.

Operating procedure

1. Open the positioning data setting screen, and select [Tool] ⇒ [Automatic 
Command Speed Calculation], or click the    button.
The Automatic Command Speed Calculation screen is displayed.

2. Set the items according to the instructions on the screen.

3. Click the    button.
The calculation result of command speed is displayed under "Calculation Result".
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4. Click the    button.
The Simulate Calculation Result screen is displayed.

5. Click the    button.

6. Click the    button.
The calculation result is applied to the positioning data.
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■ Automatic sub arc calculation

Automatically calculate the positioning data of circular interpolation control to form a smooth arc (curve 
line) from the angle position created by two continuous linear interpolation controls.

Operating procedure

1. Open the positioning data setting screen, and select [Tool] ⇒ [Automatic Sub Arc 
Calculation], or click the    button.
The Automatic Sub Arc Calculation screen is displayed.

2. Set the items according to the instructions on the screen.

3. Click the    button.
The calculation result of sub arc is displayed under "Calculation Result".
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4. Click the    button.
The Simulate Calculation Result screen is displayed.

5. Click the    button.

6. Click the    button.
The arc interpolation control data are added to the positioning data.
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3.5.7 Saving/reading data of positioning module

Save the data of positioning module set with GX Works2. Also, read the data of positioning module 
from the saved file, and update the data of positioning module on a project.
Use this operation to utilize only the data of positioning module from a GX Works2 project.
The parameter, positioning data, block starting data, servo parameter data of the QD75/LD75 
positioning module can be saved/read.

■ Saving data of positioning module

Save the data of positioning module to a file.

Operating procedure

1. Select a positioning module to be saved to a file from the Project view.

2. Select [Project] ⇒ [Intelligent Function Module] ⇒ [Save the Positioning Module 
Data].
The Save the Positioning Module Data screen is displayed.

3. Enter a name of the file to be saved, and click the    button.
The data of positioning module is saved in the save destination.
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■ Reading data of positioning module

Read the data of positioning module from a file, and update the data of positioning module on an open 
project.

Operating procedure

1. Select a positioning module to which the data of positioning module is updated 
from the Project view.

2. Select [Project] ⇒ [Intelligent Function Module] ⇒ [Read from the Positioning 
Module Data].
The Read from the Positioning Module Data screen is displayed.

3. Select a file name, and click the    button.
The Select Data to Read screen is displayed.

4. Select the data of positioning module to be read, and select the    button.
The following message is displayed.

5. Click the    button.
The data of positioning module selected on the Project view is overwritten.

● Reading applicability by module model
For QD75M/QD75MH, data can be read only when the module from which data is read and the module selected on the 
Project view are the same model.
For the QD75/LD75 positioning module other than QD75M/QD75MH, data can be read from the modules whose 
number of axes is same, even when the module from which data is read and the module selected on the Project view 
are the different model.
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3.5.8 Saving data to project files in GX Configurator-QP format

Save data of QD75/LD75 positioning module to a project file in GX Configurator-QP format.
This function is not supported by LD75P1/LD75P2/LD75D1/LD75D2.

Operating procedure

1. Select a positioning module to be saved to a file from the Project view.

2. Select [Project] ⇒ [Intelligent Function Module] ⇒ [Save GX Configurator-QP Data].
The Save GX Configurator-QP Data screen is displayed.

3. Enter a project name, and click the  button.
The data of positioning module is saved in the save destination.

● Considerations for using project files in GX Configurator-QP
The following are the considerations for using project files saved with this function in GX Configurator-QP.
• Read project files with GX Configurator-QP Version 2.34L or later.
• The connection destination setting for GX Works2 is not saved.
• The auto refresh data is not saved.

For saving the auto refresh data, select [Project] ⇒ [Export to GX Developer Format File].
• The maximum number of characters that can be saved for positioning comment, M code comment and title is 32. 

Note that the title is saved as project title.
• When entering characters of the language other than the one set for the project language, the data is saved as 

garbled characters.
The data cannot be restored to the original character strings even if the garbled project file is read with GX Works2.

• QD75xxN*1 is saved as QD75xx*1.
The parameter range expanded with QD75xxN*1 is saved as it is written.

*1 : "xx" indicates P1/P2/P4/D1/D2/D4.
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3.5.9 Importing GX Configurator-QP format project files

Utilize a project file created in GX Configurator-QP and add a new intelligent function module.

Operating procedure

1. Select [Project] ⇒ [Intelligent Function Module] ⇒ [Import GX Configurator-QP 
Data].
The Import GX Configurator-QP Data screen is displayed.

2. Select a project file to be utilized.

3. Click the   button.
The New Module screen is 
displayed.
Section 2.1.1

● Auto refresh
Since a GX Configurator-QP format project file does not contain the auto refresh data, the setting of auto refresh is not 
configured when the GX Configurator-QP data are imported.
Configure the auto refresh setting as necessary.

● Projects on QD75xx*1 module*1

When utilizing the project on a QD75xx*1 module, the project can be read as it is on a QD75xxN*1 module.
*1 : 'xx' indicates P1, P2, P4, D1, D2, or D4.
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3.6 Simple Motion Module

This section explains the operations of the intelligent function module tools related to the simple 
motion module.

3.6.1 Data setting of simple motion module

Parameters and positioning data of simple motion module are set by the simple motion module setting 
tool.
For the operating method of simple motion module setting tool, refer to the following manual.
"Help" on the Simple Motion Module Setting Tool

Screen display
Select Project view ⇒ "Intelligent Function Module" ⇒ "(module)", and double-click "Simple 
Motion Module Setting".

● Saving simple motion module settings 
The simple motion module settings are managed as a project of simple motion module setting tool. 
Therefore, the simple motion module settings are not saved by saving a project of GX Works2. 
Save the simple motion module settings with the simple motion module setting tool.
The simple motion module settings are managed as a project of simple motion module setting tool. Therefore, the 
simple motion module settings are not saved by saving a project of GX Works2. 
Save the simple motion module settings with the simple motion module setting tool.
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3.7 Serial Communication/Modem Interface Module

This section explains the operations of the intelligent function module tools related to the serial 
communication module.

3.7.1 Applicable CPUs and Modules

The following table shows CPUs and modules applicable to each function.

Applicable CPU Applicable module Circuit trace Predefined protocol 
support function

QCPU (Q mode)
QJ71C24,QJ71C24-R2 × ×

QJ71C24N*1,QJ71C24N-R2*1,
QJ71C24N-R4*1  

LCPU LJ71C24,LJ71C24-R2  

*1 : Use a module of which the function version is B with a serial number of which the first five digits are '10122' or later.
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3.7.2 Circuit trace

Trace the communication data and communication control signals of the communication with the 
device controller.
The circuit trace function displays data stored in the monitoring buffer of the module.

■ Starting circuit trace

Store the trace data in the monitoring buffer to trace the communication data and communication 
control signal status.

Screen display
Select [Tool] ⇒ [Intelligent Function Module Tool] ⇒ [Serial Communication Module] ⇒ [Circuit 
Trace] ( ).

Communication

control signals
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Operating procedure

1. Click the    button.
The Module Selection (Circuit Trace) screen is displayed.

2. Select a module to perform the circuit trace and click the    button.

3. Select a channel from "Channel Selection".

4. Click the    button.
The message shown on the right is displayed.

5. Click the   button.
The circuit trace is started.

Display contents

Item Description

Send Packet Display send data and receive data respectively. For the data display format, the ASCII code or 
hexadecimal can be selected.Receive Packet

Communication control 
signals Display the status of the RS/DTR/DSR/CS/CD signal and the receive error.

RS/DTR/DSR/CS/
CD signal

All signals are displayed with blue lines. When the obtained data does not have signal information, 
the signal is displayed as an OFF status.

Reception error Display three kinds of errors: errors of overrun error, parity error and framing error.

Signal status Display

When signal is ON

When signal is OFF
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Screen button

●

Displays the Find screen.

Operation
1. Enter content to search for in "Direct/Support Input", or select data to search for in 

"Control Code Input", and click the   /  .
Enter content in "Direct/Support Input" in display format selected in "Send/Receive Packet" on 
the Circuit Trace screen (Hexadecimal or ASCII characters).

2. Click the    button.
The cursor moves to the corresponding part of the circuit trace.

● When the circuit trace has already been executed
When the circuit trace has already been executed, the following message is displayed.
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3.7.2  Circuit trace

■ Setting circuit trace option

Set the monitoring buffer area starting address and size of the module on which the circuit trace data 
are stored, and the stopping condition.

Screen display

Click the    button on the Circuit Trace Option screen.

Operating procedure

1. Set the items on the screen.

2. Click the    button.
The following message is displayed.

3. Click the   button.
The set values are written to the module.

Item Description

Circuit Trace Data Storage Area Setting -

Start Address Set the starting address of the monitoring buffer area to which the trace 
data are stored.

size

Set the size of the monitoring buffer area to which the trace data are 
stored.*1 Set the maximum address*1 for the trace data storage space in the 
range between 2602H to 3FFFH (C02H to 1AFFH for the user-specified 
area). Note that the range of this value is checked at start of the circuit trace 
when using the user-specified area.

Stop setting -

Stop by occurrence of timer 0 time-
out error Select this to stop the circuit trace when the timer 0 is timeout.

*1 : The maximum address for the trace data storage space can be calculated by the following formula.
Maximum address for the trace data storage space = "Monitoring buffer starting address" + "Monitoring buffer size" -
1
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■ Saving circuit trace result

Save the circuit trace data obtained by the circuit trace on the personal computer.

Operating procedure

• Click the    button on the Circuit Trace screen.

■ Opening trace files

Read the trace data saved on the personal computer and display the data on the Circuit Trace screen.

Operating procedure

• Click the    button on the Circuit Trace screen.

3.7.3 Predefined protocol support function

For the predefined protocol support function, refer to Chapter 4.

3.7.4 Flash ROM operation

The following explains the flash ROM operation such as permitting/prohibiting data write to the flash 
ROM of serial communication module.

Operating procedure

1. Open the intelligent function module data to which the flash ROM operation is 
performed.

2. Select [Tool] ⇒ [Flash ROM Operation].
The Flash ROM Operation screen is displayed.

3. Select an item under "Execution Item", and click the  button.
The selected item is executed.
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3.8.1  Setting AnyWireASLINK system configuration

3.8 AnyWireASLINK Configuration Window

This section explains the operations on the AnyWireASLINK configuration window.

For the online operations, refer to the following manual.
 iQ Sensor Solution Reference Manual

3.8.1 Setting AnyWireASLINK system configuration

For QCPU (Q mode)/LCPU projects, set the system configuration by dragging and dropping the module 
data from "Module List".

The actual system configuration can also be applied to the AnyWireASLINK configuration window with 
the auto-detect function of connected device.
For the auto-detect function of connected device, refer to the following manual.
 iQ Sensor Solution Reference Manual

Screen display
Select Project view ⇒ "Intelligent Function Module" ⇒ "(AnyWireASLINK interface module)" ⇒ 
"AnyWireASLINK Configuration".

Output window

Equipment

 configuration

Module information

 list
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Operating procedure

1. Select the module from "Module List", and drag and drop it to the 'module 
information list' or 'equipment configuration'.
The slave module is added to the 'module information list'.
The added module is displayed on the 'equipment configuration'.

2. Set the address for the added slave module.
For general-purpose AnyWireASLINK module, set the input/output type, address, and occupied I/O 
points.
The addresses of all slave modules can be set automatically. (Section 3.8.4)

3. Select [Close with Saving the Setting].
Exit the settings of AnyWireASLINK configuration.

Screen button

●

Applies the module information and the equipment configuration to the AnyWireASLINK configuration 
window from the actual system configuration.
For the setting operation procedure with the auto-detect function of connected device and its 
considerations of the 'module information list' and 'equipment configuration', refer to the following 
manual.
iQ Sensor Solution Reference Manual

● /
Moves the position of the module selected in the 'module information list' up/down.

Drag and drop
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3.8.2  Replacing general-purpose AnyWireASLINK module

3.8.2 Replacing general-purpose AnyWireASLINK module

Replace a general-purpose AnyWireASLINK module with the specific module.

Operating procedure

1. Select the general-purpose AnyWireASLINK module to be replaced from the 
'module information list' on the AnyWireASLINK configuration window.

2. Select [AnyWireASLINK Configuration] ⇒ [Change Module] ⇒ [Replace General 
AnyWireASLINK Module].
The Replace General AnyWireASLINK Module screen is displayed.

3. Set the items on the screen.

List of modules

 to be replaced

Item Description

Replacement Target Display the input/output type of the general-purpose AnyWireASLINK module selected on the 
AnyWireASLINK configuration window.

List of modules to be 
replaced

Display the modules with the same condition as the one selected for "Replacement Target". 
Select the check box(es) on the "Address" column of the module to be replaced.
Two or more modules can be selected.

Replacement 
Candidate Select the module to be replaced with.
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4. Click the  button.
The general-purpose AnyWireASLINK module in the 'module information list' is replaced with the 
module selected for "Replacement Candidate". The general-purpose AnyWireASLINK module 
displayed on the 'equipment configuration' is replaced with the module selected for "Replacement 
Candidate".

Screen display

●

Selects all modules displayed on "Replacement Target".

●

Cancels the selected status of all modules selected for "Replacement Target".

3.8.3 Replacing to general-purpose AnyWireASLINK module

Replace a slave module to a general-purpose AnyWireASLINK module.

Operating procedure

1. Select the module to be replaced in the 'module information list' on the 
AnyWireASLINK configuration window.

2. Select [AnyWireASLINK Configuration] ⇒ [Change Module] ⇒ [Replace General 
AnyWireASLINK Module].
The module is replaced to the corresponding general-purpose AnyWireASLINK module.

3.8.4 Entering address automatically

Enter the address for the slave module on the 'module information list' automatically.
The address is set by number in ascending order based on the input/output type and occupied I/O 
points.

Operating procedure

• Select [AnyWireASLINK Configuration] ⇒ [Address Auto-Input].
The address is entered for the "Address" column automatically.

The general-purpose 

module is replaced with 

the selected module.
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3.8.5  Checking system configuration

3.8.5 Checking system configuration

Check whether the equipment configuration of AnyWireASLINK is correct after setting the module 
information on the AnyWireASLINK configuration window.

Operating procedure

• Select [AnyWireASLINK Configuration] ⇒ [Check] ⇒ [System Configuration].
The system configuration of AnyWireASLINK is checked.
Check the result of the system configuration check on the Output window.
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4 PREDEFINED 
PROTOCOL SUPPORT 
FUNCTION

This chapter explains the operations of the predefined protocol support function of the serial 
communication module.

4.1 List of Functions of Predefined Protocol Support 
Function 4 - 2

4.2 Operating Procedure of Predefined Protocol Support 
Function 4 - 3

4.3 Starting and Exiting Predefined Protocol Support 
Function 4 - 4

4.4 Screen Configuration 4 - 5

4.5 File Operations of Predefined Protocol Support 
Function 4 - 7

4.6 Editing Protocols 4 - 10

4.7 Setting Packets 4 - 19

4.8 Writing/Reading/Verifying Protocol Settings 4 - 31

4.9 Debugging 4 - 35

4.10 Printing Protocol Settings 4 - 43
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4.1 List of Functions of Predefined Protocol Support Function

This section shows the list of functions of the predefined protocol support function.

File Reference

New Create a new protocol setting file. Section 4.5.1

Open Open the existing protocol setting file. Section 4.5.2

Close Close an open protocol setting file. Section 4.5.4

Save Save the protocol setting file.
Section 4.5.3

Save As Name and saves a protocol setting file.

Print Print such as a protocol setting. Section 4.10

Exit Exit the predefined protocol support function. Section 4.3

Edit Reference

Add Protocol Add a protocol. Section 4.6.1

Change to Editable Protocol Change the protocol selected from the predefined protocol library to an 
editable one. Section 4.6.2

Protocol Detailed Setting
Set the protocol detailed setting such as the number of retries of 
protocol transmission and whether to clear OS area (receive data 
area).

Section 4.6.3

Add Receive Packet Add a receive packet. -

Delete Delete the protocol. Section 4.6.5

Copy Copy the protocol.

-

Paste Paste the protocol.

Delete Multiple Protocols Batch-delete multiple protocols.

Copy Multiple Protocols Batch-copy multiple protocols.

Paste Multiple Protocols Batch-paste multiple protocols.

Device Batch Setting Batch-set devices used in a protocol. Section 4.7.4

Save User Protocol Library Save the protocol being set as a user protocol library. Section 4.6.6

Module Read/Write Reference

Read from Module Read protocol settings from the module.
Section 4.8.1

Write to Module Write registered protocol settings to the module.

Module Verification Compare protocol settings being opened with those written in the 
module. Section 4.8.2

Tool Reference

Setting Device List Display the list of devices used in protocols. Section 4.7.5

Register Predefined Protocol Library Import the predefined protocol library provided by Mitsubishi Electric 
Corporation. Section 4.6.7

Debugging Support Function Reference

Module Selection Select a module to be debugged. Section 4.9.1

Protocol Execution Log Display the protocol execution logs and the protocol execution results. Section 4.9.2

State Monitor
Monitor signals, communication error information, operation setting 
switches, and protocol execution status of the Q series C24N/L series 
C24 module.

Section 4.9.3

Window Reference

Cascade Cascade windows.

-Tile Horizontally Tile windows horizontally.

(Switch to other window) Display the open window.



4.2  Operating Procedure of Predefined Protocol Support Function

4 - 3

1

O
V

E
R

V
IE

W

2

CO
M

M
ON

 O
PE

RA
TI

ON
S 

FO
R 

IN
TE

LL
IG

EN
T 

FU
NC

TI
ON

 M
OD

UL
ES

3

O
PE

RA
TI

NG
 

IN
TE

LL
IG

EN
T 

FU
NC

TI
O

N 
M

O
DU

LE
S

4

PR
ED

EF
IN

ED
 

PR
O

TO
CO

L 
SU

PP
O

RT
 F

UN
CT

IO
N

A

AP
P

EN
D

IX

I

IN
D

E
X

4.2 Operating Procedure of Predefined Protocol Support Function

This section shows the operating procedure for writing protocols to the module using the predefined 
protocol support function.

*1 : Section 4.3
*2 : Section 4.5.1
*3 : Section 4.5.2
*4 : Section 4.6.1
*5 : Section 4.6
*6 : Section 4.7
*7 : Section 4.8.1

● Executing a predefined protocol by a dedicated instruction
To execute a predefined protocol, a program to execute the dedicated instruction (CPRTCL instruction) is required.
For details of the dedicated instruction, refer to the following manual.
User's manual of each module
When using the dedicated instruction in Structured Ladder/FBD, refer to the following manual
MELSEC-Q/L Structured Programming Manual (Special Instructions)

Open the Protocol Setting screen�*2,*3

Start up the predefined protocol support function�*1

Exit the predefined protocol support function�*1

Add a protocol to be used�*4

YES

NO

Set the protocol as an 

editable one?�*4

Select a registered protocol from

the predefined protocol library�*4 Configure details of the protocol�*5,*6

Write protocols to a module�*7
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4.3 Starting and Exiting Predefined Protocol Support Function

This section explains how to start and exit the predefined protocol support function.

■ Starting up

Start the predefined protocol support function.

Operating procedure

• Select GX Works2 menu [Tool] ⇒ [Intelligent Function Module Tool] ⇒ [Serial 
Communication Module] ⇒ [Predefined Protocol Support Function].
The Predefined protocol support function is started up.

■ Exiting

Exit the predefined protocol support function.

Operating procedure

• Select [File] ⇒ [Exit].
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4.4 Screen Configuration

This section explains the main frame (basic screen) of the predefined protocol support function that is 
displayed when it is started up. 

4.4.1 Main frame configuration

The following shows the configuration of the main frame.

Screen display

Display contents

Title bar

Menu bar
Toolbar

Status bar

Protocol

Setting screen

Item Description Reference

Title bar Display a file name. -

Menu bar Display menu options for executing each function. -

Toolbar Display tool buttons for executing each function. -

Protocol Setting screen A sub screen to configure/change protocols to be set to a 
module. Section 4.5

Status bar Display information about a protocol being edited. Section 4.4.2
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4.4.2  Status bar

4.4.2 Status bar

The status bar displays information about a protocol being edited at the bottom of the screen.

The following shows the information to be displayed.

Protocols Packets Packet Data Area Usage Module for Debugging
Caps

Lock

Num 

Lock

Scroll 

Lock

Item Description

Protocols Display the number of registered protocols.

Packets Display the number of registered packets.

Packet Data Area Usage
Display the percentage of the size of packet data being registered in the maximum registration 
area of the packet data area (flash ROM area in a module to store packet data for 
communication with other devices).

Module for Debugging Display the module name, IO address, and channel of a debugging object module being 
selected.

Caps Lock Display the effective status of the Caps Lock.

Num Lock Display the effective status of the Num Lock.

Scroll Lock Display the effective status of the Scroll Lock.
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4.5 File Operations of Predefined Protocol Support Function

This section explains the basic file operations of the predefined protocol support function, such as 
creating new files, opening files, and saving files.

4.5.1 Creating files

Create a new file of the protocol setting.

Operating procedure

• Select [File] ⇒ [New] ( ).
The Protocol Setting screen is displayed.

Protocol row
Send packet row
Receive packet row

Cell for 

adding protocol
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4.5.1  Creating files

Display contents

Item Description

Protocol No.

Display the protocol number to be used in a pre-defined protocol dedicated instruction for ladder 
programs. 
The protocol number can be changed by selecting a number from the list. 
The assignable number is 1 to 128.

Manufacturer Display the manufacturer's name of a target device of a protocol to be set.

Model Display the target model of a protocol to be set.

Protocol Name Display the name of a protocol to be set.

Communication Type

Display the communication type in a protocol to be set.

-> Send/<- Receive

Display the packet direction.

Packet Name Display the packet name.

Packet Setting

Display the existence or non-existence of variables in an element, and set or unset of the variables. 
With 'Variable Unset', 'Element Unset', or 'Element error', the setting cannot be written to a module.

Protocol row

One protocol row is displayed for each protocol. 
The background is displayed in the following colors.

Send packet row

One send packet row is displayed for each send packet. ('Send' means the communication toward an 
external device from a module.) 
The background is displayed in the following colors.

Receive packet row

One receive packet row is displayed for each receive packet. ('Receive' means the communication 
toward a module from an external device.) 
The background is displayed in the following colors.

Cell for adding 
protocol Display Add Protocol screen by clicking this cell or pressing the  key.

Send Only : Send one send packet once.
Receive Only : Receive a packet if it matches any of up-to-16 defined receive packets.
Send&Receive : Send one send packet, and receives a packet if it matches any of up-to-16 defined

receive packets.

-> : Send
<-(1) to <-(16) : Receive

A receive packet number is displayed in ().

No Variable : There is no variable in the element.
Variable Set (in blue) : All variables are set.
Variable Unset (in red) : There are one or more unset variables.
Element Unset (in red) : There is no element in the editable protocol.
Element error (in red) : The element does not meet requirement.

Deep sky blue: Protocol selected from the predefined protocol library
Orange : Editable protocol

Light sky blue : Protocol selected from the predefined protocol library
Light yellow : Editable protocol

Pale green : Protocol selected from the predefined protocol library
Yellow : Editable protocol
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4.5.2 Opening files

Read a protocol setting file saved on a personal computer or another data storage device.

Operating procedure

1. Select [File] ⇒ [Open] ( ).
The Open screen is displayed.

2. Select a protocol setting file (*.pcf) and open the file.
The Protocol Setting screen is displayed.

4.5.3 Saving files

Save a protocol setting being edited on a personal computer or another data storage device.

■ Saving protocol settings under the specified name

Save a protocol setting being edited under the specified name.

Operating procedure

1. Select [File] ⇒ [Save As].
The Save As screen is displayed.

2. Set "Save in" and "File name" and save the file.
The file is saved with the specified name and in the specified destination.

■ Saving protocol settings

Overwrite and save a protocol setting being edited.

Operating procedure

• Select [File] ⇒ [Save] ( ).
The data to be saved is overwritten on the existing protocol setting file.

4.5.4 Closing files

Close a protocol setting being opened.

Operating procedure

• Select [File] ⇒ [Close].
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4.6.1  Adding protocols

4.6 Editing Protocols

This section explains how to configure/change protocols to be set to a module on the Protocol Setting 
screen.

4.6.1 Adding protocols

Add a protocol.

Screen display
Click the "Add" cell, or press the  key on the Protocol Setting screen.

Operating procedure

• Set the items on the screen.

● "Select from Predefined Protocol Library"
When "Select from Predefined Protocol Library" is selected, configure only "Send/Receive Data Storage Area" in a 
Non-conversion Variable/Conversion Variable among packet elements.

Item Description

Selection of Protocol Type to Add -

Type

Select a protocol type to be added. 

For "User Protocol Library", click the    button and specify the file of 
user protocol library.
(■ Protocol type)

Protocol to Add -

Protocol No. Set the number of the protocol to be added.

Manufacturer Set a manufacturer's name of the protocol to be added.

Model Set a model of the protocol to be added.

Protocol Name Set a name of the protocol to be added.



4.6  Editing Protocols

4.6.1  Adding protocols 4 - 11

1

O
V

E
R

V
IE

W

2

CO
M

M
ON

 O
PE

RA
TI

ON
S 

FO
R 

IN
TE

LL
IG

EN
T 

FU
NC

TI
ON

 M
OD

UL
ES

3

O
PE

RA
TI

NG
 

IN
TE

LL
IG

EN
T 

FU
NC

TI
O

N 
M

O
DU

LE
S

4

PR
ED

EF
IN

ED
 

PR
O

TO
CO

L 
SU

PP
O

RT
 F

UN
CT

IO
N

A

AP
P

EN
D

IX

I

IN
D

E
X

■ Protocol type

The following shows the 3 types of the protocol types.

Item Description

Predefined Protocol Library Add a protocol by selecting a protocol from the predefined protocol library and 
specifying "Protocol No.", "Manufacturer", "Model", and "Protocol Name".

User Protocol Library Add a protocol by utilizing a protocol saved as a user protocol library. 
(Saving protocols as user protocol library Section 4.6.6 )

Add New (Editable Protocol) Add a protocol which can be edited by specifying only "Protocol No.". 
"Manufacturer", "Model", and "Protocol Name" can be changed after a protocol addition.
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4.6.2  Changing to editable protocols

4.6.2 Changing to editable protocols

Change a protocol selected from the predefined protocol library to an editable one.

Operating procedure

1. Select a row of a protocol to be changed on the Protocol Setting screen.

2. Select [Edit] ⇒ [Change to Editable Protocol].
The following message is displayed.

3. Click the   button.

● Restriction on changing a predefined protocol to an editable protocol
Once a protocol has been changed to an editable protocol, it cannot be restored.
In addition, an editable protocol cannot be changed to a predefined protocol.
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4.6.3 Configuring details of protocols

Configure the number of retries of a protocol and whether to clear the OS area (receive data area).

Screen display
Select a protocol row on the Protocol Setting screen and select [Edit] ⇒ [Protocol Detailed 
Setting].

Operating procedure

• Set the items on the screen.

Item Description

Connected 
Device 
Information*1

Manufacturer Set a manufacturer's name of the protocol.

Type Set a device type of the protocol.

Model Set a model of the protocol.

Version Set a device version of the protocol.

Explanation Set a description for a device of the protocol.

Protocol Setting 
Information*1

Protocol No. Displays a protocol number of the selected protocol.

Protocol Name Set a protocol name of the protocol.

Communication 
Type Select a communication type of the protocol.

Receive Setting

Clear OS area 
(receive data 
area) before 
protocol 
execution

Select whether to clear the OS area (receive data area) of the Q series C24N/L 
series C24 module before the protocol execution.
If 'Disable' is selected, the data received in the Q series C24N/L series C24 module 
before the protocol execution also become a receive target of the protocol.

Receive Wait 
Time

Set waiting time after the Q series C24N/L series C24 module turns to the 'waiting 
for reception' status.
If the communication with other devices is not available due to such as a cable 
disconnection and no matched packet can be received within the set time, the Q 
series C24N/L series C24 module determines an error and cancels the 'waiting for 
reception' status.



4 - 14

GX Works2

4  PREDEFINED PROTOCOL SUPPORT FUNCTION

4.6.3  Configuring details of protocols

Screen button

●

Displays the Communication Parameter Batch Setting screen. (Section 4.6.4)

● Example of when the data cannot be sent
When the set value of "Number of Retries" is 2, the Q series C24N/L series C24 module determines an error at the 
following timing if it cannot send the data.

Send Setting

Number of
Retries

Set the number of times the Q series C24N/L series C24 module retries to send 
when the sending from the Q series C24N/L series C24 module has not been 
completed within the set time of "Monitoring Time".
The Q series C24N/L series C24 module determines an error if the sending has not 
been completed despite the specified number of times of sending retries.

Retry Interval
Set the interval between the failure of sending from the Q series C24N/L series C24 
module and the retry when the sending from the Q series C24N/L series C24 
module has not been completed within the set time of "Monitoring Time".

Standby Time

Set standby time between when a protocol set to the Q series C24N/L series C24 
module turns to the execution status and when it actually sends the data. By setting 
this item, the send timing of the Q series C24N/L series C24 module can be 
adjusted to readiness of other devices to receive data.

Monitoring Time

Set waiting time between when the Q series C24N/L series C24 module turns to the 
'sending' status and when the sending is completed.
If the communication with other devices is not available due to such as a cable 
disconnection and the sending cannot be completed within the set time, the Q 
series C24N/L series C24 module determines an error and cancels the 'sending' 
status.

*1 : For a protocol selected from the predefined protocol library, "Connected Device Information" and "Protocol Setting 
Information" cannot be modified.

Item Description

Standby time Monitoring time Retry interval Monitoring time Monitoring time

Monitoring
timeout

Q series C24N/L series C24

Monitoring
timeout

Monitoring
timeout

CPRTCL instruction
abnormal completion

CPRTCL instruction execution

Data sending First retry Second retry

Retry interval
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4.6.4 Setting send/receive parameters in batch

Configure parameters used for sending/receiving a protocol.

Screen display

Click the  button on the Protocol Detailed Setting screen.

Operating procedure

• Set the items on the screen.

Item Description

Setting Protocol No. Range Select the start number and end number of the range of protocols to be set at once.

Receive Setting Select items to be set at once. 
Specified values of selected items are to be set at once.Send Setting
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4.6.5  Deleting protocols/packets

4.6.5 Deleting protocols/packets

Delete a protocol/packet.

Operating procedure

1. Select a row of a protocol/packet to be deleted on the Protocol Setting  screen.

2. Select [Edit] ⇒ [Delete], or press the  key.
 The row of the protocol/packet is deleted.

● Deleting protocols/packets
• To delete multiple protocols at once, select [Edit] ⇒ [Delete Multiple Protocols] and specify the range.
• A send packet cannot be deleted.
• A receive packet cannot be deleted when the communication type is "Send&Receive" or "Receive Only" and there is 

only one receive packet.
• A packet in a protocol selected from the predefined protocol library cannot be deleted.

4.6.6 Saving protocols as user protocol library

Save a protocol being set as a user protocol library.

Operating procedure

1. Select a cell of a protocol line on the Protocol Setting screen.

2. Select [Edit] ⇒ [Save User Protocol Library].
The Save User Protocol Library screen is displayed.
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3. Set the items on the screen.

4. Click the    button.
The Save As screen is displayed.

5. Enter a file name and click the    button.
Saved as a user protocol library.

Item Description

ALL Select this to save all protocols.

Selected Protocol No. Select this to save a protocol of protocol number being selected.

Specify Protocol No.

Select this to save a protocol by specifying a protocol number. 
For specifying multiple protocol numbers, separate each protocol number with ",". 
For specifying consecutive protocol numbers, connect the first protocol number 
and last protocol number with "-".
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4.6.7  Registering predefined protocol library

4.6.7 Registering predefined protocol library

Register the predefined protocol library provided by Mitsubishi Electric Corporation.
Registering the predefined protocol library enables to select the predefined protocol library which is 
registered on "Predefined Protocol Library" of the Add Protocol screen.

Operating procedure

1. Select [Edit] ⇒ [Register Predefined Protocol Library].
The Open screen is displayed.

2. Select a file name and click the    button.
After the registration is completed, the following message is displayed.
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4.7 Setting Packets

Set packet elements of a registered protocol.

Screen display
Click a desired packet setting on the Protocol Setting screen.

Operating procedure

• Set the items on the screen.

Item Description

Protocol No. Display the protocol number of the specified protocol.

Protocol Name Display the protocol name of the specified protocol.

Packet Type Display 'Send Packet' or 'Receive Packet' as the type of the specified packet.

Packet Name Set the packet name of the specified packet.*1

Packet No. (Receive packet 
only) Display the packet number of the receive packet.

Element 
List

Element No. Display the number of the packet element. 
The element number can be changed by selecting a number from the list.

Element Type

Display the type of each element. 
For details, refer to the user's manual of the module.

Element Name Display the name of each element.

Element Setting

Display the setting outline of each element. 
For details, refer to "■ Display examples of element settings" in this section. 
Display contents may vary depending on types of elements. 
To display the respective setting screen, click an editable cell*2, or press the  key.

*1 : Not editable for a protocol selected from the predefined protocol library.
*2 : Displayed in red when a Variable unset error, Element error, or Calculating range error occurs, and displayed in blue 

when no error occurs.

Header Conversion
Variable

Static
Data

Check
Code Terminator

Data division

Up to 32 elements can be allocated

Conversion
Variable
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Screen button

●

Changes the type of the packet element. (Section 4.7.3)

●

Adds a new packet element. (Section 4.7.1)

●

Copies the packet element at the cursor position.

●

Pastes the copied packet element to the row next to the cursor position.

●

Deletes the packet element at the cursor position.

■ Display examples of element settings

Element type Display content Display example

Header Static 
Data 
Terminator

"Code Type" is 'ASCII 
String'

Display the set value (ASCII string) with 
" ", and data length with ( ). "TEXT" (4Byte)

"Code Type" is 'ASCII 
Control Code'

Display the set value (ASCII control 
code) with [ ], and data length with ( ). [CR](1Byte)

"Code Type" is 'HEX' Display the set value (HEX), and data 
length with ( ). 1AB2C3(3Byte)

Length

Range for calculation of data length Object element3-8

Display the code type using elliptical expressions.

Hexadecimal

Display the data flow using elliptical expressions.

Forward

Data size 2Byte

Non-
conversion 
Variable

For 'Fixed Length', display the address range of a device or 
buffer to be specified as a variable with [ ].For 'Variable Length', 
additionally display the starting address of a device or buffer 
memory which specifies the data length (or number of data) with 
another [ ].

Fixed Length/Variable Length Fixed Length

Length of send/receive data 600Byte

Displays the unit of stored data using elliptical expressions.
Lower/Upper Byte

Displays the byte swap using elliptical expressions.
Swap

ASCII Hexadecimal : Hexadecimal
ASCII Decimal : Decimal
HEX : HEX

Forward Direction (Upper Byte -> Lower Byte) : Forward
Forward Direction (Upper Byte -> Lower Byte) : Reverse
Byte Swap (by Word) : Byte

Fixed Length : [D1-D2]
Variable Length: [D1] [D2-D11]

Lower Byte + Upper Byte: Lower/Upper Byte
Lower Bytes Only : Lower Byte

Disable (Lower -> Upper) : No Swap
Enable (Upper -> Lower) : Swap
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Conversion 
Variable

For 'Fixed Number of Data', display the address range of a 
device or buffer to be specified as a variable with [ ]. 
For 'Variable Number of Data', additionally display the starting 
address of a device or buffer memory which specifies the data 
length with another [ ].

Display "Conversion" using elliptical expressions.

-> Hex

Fixed Number of Data/Variable Number of Data Variable Number

Display "Number of data" using elliptical expressions. Number of data (3)

Number of digits of data Digit (3)

Display a blank-padded character (0/Space). Padded (0)

Display the conversion unit using elliptical expressions.
Double

Display whether signed or not.
Signed

When 'Signed' is selected in "Sign", display the sign character 
using elliptical expressions.

Sign character (none)

Display the number of decimals using elliptical expressions. Decimal point (5)

Display the delimiter using elliptical expression.

Delimiter (comma)

Check Code

Range for calculation of a check code Object element2-7

Display the processing method using elliptical expressions.

Parity

Display "Code Type" using elliptical expressions.

Hexadecimal

Display the complement calculation using elliptical expressions.

1 complement

Display the data flow using elliptical expressions.

Forward

Data size 2Byte

Non-verified 
Reception 
(Receive 
only)

Display the check size with ( ).
("Variable" is displayed when the set value is '0'.) (123Byte)

Element type Display content Display example

Fixed Number of Data : [D1-D2]
Variable Number : [D1] [D2-D11]

HEX -> ASCII Decimal : - Dec
HEX -> ASCII 
Hexadecimal : - Hex

ASCII Decimal -> HEX : Dec ->
ASCII Decimal -> HEX : Hex ->

Word : Word
Double Word : Double

Unsigned
Signed

None : none
+ : +
0 : 0
Space : space

No Delimiter : none
Comma : comma
Space : space

Horizontal Parity : Parity
Sum Check : Sum Check 
16-bit CRC (for MODBUS) : CRC MOD

ASCII 
Hexadecimal : -> Hex

ASCII Decimal : Decimal
HEX : HEX

No Complement Calculation : No calculation
One's Complement : 1 complement
Two's Complement : 2 complement

Forward Direction (Upper Byte -> Lower Byte) : Forward
Forward Direction (Upper Byte -> Lower Byte) : Reverse
Byte Swap (by Word) : Byte
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4.7.1  Adding new elements

4.7.1 Adding new elements

Add an element.

Screen button

Click the  button on the Packet Setting screen.

Operating procedure

• Select "Element Type" and click the   button.
The Element Setting screen for the selected element type is displayed.
For details, refer to Section 4.7.2.

4.7.2 Setting elements

Set each element.

■ Setting of header/static data/terminator

Configure the header/static data/terminator setting.

Screen display
Select "Header"/"Static Data"/"Terminator" on the Add New screen.

Operating procedure

• Set the items on the screen.

Item Description

Element Name Set a name of the element.

Code Type Set a data type of the setting value.

Setting Value Set value of the Header/Static Data/Terminator.
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Screen button

●

When "Code Type" is 'ASCII Control Code', displays the ASCII Code Input screen to select a control 
code to be set.

Operation
1. Select an ASCII code from the list of "ASCII Code Input".

2. Click the  button.
The ASCII code is inserted to the cursor position.

■ Setting of length

Configure the length setting.

Screen display
Select "Length" on the Add New screen.

Operating procedure

• Set the items on the screen.

Item Description

Element Name Set a name of the element.

Code Type Set a data type of the setting value.

Data Length Select the data length on the line.

Data Flow Select the sequence of data when "Data Length" is other than '1'.

Calculating Range 
(Start)/Calculating 
Range (End)

Select element numbers for the start and end of the calculating range.
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4.7.2  Setting elements

■ Setting of non-conversion variable

Configure the non-conversion variable setting.

Screen display
Select "Non-conversion Variable" on the Add New screen.

Operating procedure

• Set the items on the screen.

Item Description

Element Name Set a name of the element.

Fixed Length/Variable Length Select 'Fixed Length'/'Variable Length'.

Data Length/ Maximum Data 
Length

Set the data length. 
For 'Variable Length', set the maximum data length that can be specified to the data 
storage area.

Unit of Stored Data Select 'Lower Byte + Upper Byte'/'Lower Bytes Only'.

Byte Swap Select 'Disable (Lower -> Upper)'/'Enable (Upper - Lower)'.

Send (Receive) Data Length 
Storage Area (For 'Variable 
Length' only)

Set a starting address of devices on which the data length of the send (receive) data of 
the element is stored.

Send (Receive) Data Storage 
Area

Fixed Length : Set a starting address of devices on which the value of a variable is 
stored.
An ending address is automatically displayed.

Variable Length : Devices of a starting address and an ending address on which the 
value of a variable is stored are automatically displayed according to 
the setting of the data storage area for the send (receive) area.
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■ Setting of conversion variable

Configure the conversion variable.

Screen display
Select "Conversion Variable" on the Add New screen.

Operating procedure

• Set the items on the screen.

Item Description

Element Name Set a name of the element.

Conversion Select a conversion type.

Fixed Number of Data/Variable 
Number of Data Select 'Fixed Number of Data'/'Variable Number of Data'.

Number of Send (Receive) 
Data

Set the number of the data (1 to 256). 
For 'Variable Number of Data', set the maximum number of data that can be specified to 
the data number storage area.

Number of Send (Receive) 
Digits of Data Select 1 to 10 or 'Variable Number of Digits'.

Blank-padded Character
 at Send (Receive)

Select 'Space'/'0'. 
The setting value is invalidated and '-' is displayed when "Number of Send (Receive) 
Digits of Data" is 'Variable Number of Digits'.

Conversion Unit Select 'Word'/'Double Word'.

Sign Select 'Unsigned'/'Signed'.*1

Sign Character Select 'None'/'+'/'0'/'Space' when "Sign" is 'Signed'.

Number of Decimals Select 'No Decimal Point'/1 to 9/'Variable Point'.*1

Delimiter Select 'No Delimiter'/'Comma'/'Space'.

Send (Receive) Data Quantity 
Storage Area (For 'Variable 
Number of Data' only)

Specify a starting address of devices on which the number of the send (receive) data of 
the element is stored.*2

Send (Receive) Data Storage 
Area

*1 : Applicable only when "Conversion" is 'HEX -> ASCII Decimal' or 'ASCII Decimal -> HEX'.
*2 : For the setting range, refer to ■ List of available devices for "Send (Receive) Data Storage Area".

Fixed Length : Specify a starting address of devices on which the value of a variable 
is stored.*2
An ending address is automatically displayed.

Variable Length : Devices of a starting address and an ending address on which the 
value of a variable is stored are automatically displayed according to 
the setting of the data storage area for the send (receive) area.
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4.7.2  Setting elements

■ Setting of check code

Configure the check code setting.

Screen display
Select "Check Code" on the Add New screen.

Operating procedure

• Set the items on the screen.

Item Description

Element Name Set a name of the element.

Processing Method Select a calculating method.

Code Type*1 Select a send/receive format of the check code.

Data Length*1 Select the data length on the line.

Data Flow*1 Select the sequence of data when "Data Length" is other than '1'.

Complement 
Calculation*1 Select a type of complement calculation.

Calculating Range 
(Start)/Calculating 
Range (End)

Select element numbers for the start and end of the calculating range.

*1 : Not applicable when "Processing Method" is '16-bit CRC (for MODBUS)'.
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■ Setting of non-verified reception

Configure the non-verified reception setting.

Screen display
Select "Non-verified Reception" on the Add New screen.

Operating procedure

• Set the items on the screen.

■ List of available devices for "Send (Receive) Data Storage Area"

The following list shows the available devices for "Send (Receive) Data Storage Area".
● QCPU (Q mode)

Item Description

Element Name Set a name of the element.

Data Length Set the number of characters not to be verified.

Category Device type Symbol

Device range

Other than 
those 

mentioned 
right

Basic
model
QCPU

Other than 
those 

Universal 
model QCPU 
mentioned on 

the right 

High-speed
Universal

model
QCPU

Q00U/Q01U Q00UJ

Internal 
user*1,*2

*1 : Do not specify a local device.
*2 : Specify devices within the range specified in the Device setting of the PLC parameter.

Input X 0 to 1FFFH 0 to 7FFH 0 to 1FFFH 0 to 1FFFH 0 to 1FFFH 0 to 1FFFH

Output Y 0 to 1FFFH 0 to 7FFH 0 to 1FFFH 0 to 1FFFH 0 to 1FFFH 0 to 1FFFH

Internal relay M 0 to 32767 0 to 32767 0 to 61439 0 to 61439 0 to 61439 0 to 61439

Latch relay L 0 to 32767

Link relay B 0 to 1FFFH 0 to 1FFFH 0 to EFFFH 0 to EFFFH 0 to EFFFH 0 to EFFFH

Data register D 0 to 32767 0 to 32767 0 to 4212735 0 to 4910079 0 to 94207 0 to 32767

Link register W 0 to 1FFFH 0 to 1FFFH 0 to 4047FFH 0 to 4AEBFFH 0 to 16FFFH 0 to 7FFFH

File 
register

File 
register

R*2 0 to 32767 0 to 32767 0 to 32767 0 to 32767 0 to 32767 -

ZR 0 to 
1042431 0 to 1042431 0 to 4184063 0 to 4849663 0 to 65535 -

Buffer 
memory

Intelligent 
function module 
device

U\G 1024 to 6911, 9728 to 16383, 20480 to 24575
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4.7.3  Changing element types

● LCPU

● CPU device
When a CPU device is specified as the data storage area, the Q series C24N/L series C24 module performs the read/
write CPU device process.
If the total length of variables used in a packet exceeds 1920 bytes, 'read CPU device process'/'write CPU device 
process' of the Q series C24N/L series C24 module needs to be performed more than once, and the processing time 
might be longer.

● Intelligent function module device (buffer memory)
High-speed protocol processing is available because a Intelligent function module device (buffer memory) is not 
affected by the sequence scan of a programmable controller CPU.

● Execution of a protocol including a Non-conversion Variable or Conversion Variable
When executing a protocol including a Non-conversion Variable or Conversion Variable, do not change the value of a 
CPU device specified as a variable during execution of the dedicated instruction.

4.7.3 Changing element types

Change a type of an element to another.

Screen display

Select a cell of an element to be changed on the Packet Setting screen and click the  
button.

Category Device type Symbol
Device range

L02S/L02/L02-P L06/L26/L26-BT/L26-PBT

Internal 
user*1,*2

Input X 0 to 1FFFH

Output Y 0 to 1FFFH

Internal relay M 0 to 61439

Latch relay L 0 to 32767

Link relay B 0 to EFFFH

Data register D 0 to 94207 0 to 421887

Link register W 0 to 16FFFH 0 to 66FFFH

File 
register

File 
register

R*2 0 to 32767

ZR 0 to 65535 0 to 393215

Buffer
memory

Intelligent function 
module device U\G 1024 to 6911, 9728 to 16383, 20480 to 24575

*1 : Do not specify a local device.
*2 : Specify devices within the range specified in the Device setting of the PLC parameter.
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Operating procedure

1. Select a new element type and click the  button.
The following message is displayed.

2. Click the  button.
The element setting screen for the selected element type is displayed.

4.7.4 Batch-setting devices

Batch-set devices used in protocols.

Screen display
Select [Edit] ⇒ [Device Batch Setting].

Operating procedure

1. Set the items on the screen.

2.  Click the  button.
The following message is displayed.

3. Click the  button.
The devices are set at once.

Item Description

Setting Protocol No. Range Select a starting number and ending number of protocols to be batch-set.

Start Device No. Select a starting number of devices to be batch-set.
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4.7.5  Confirming set devices in list view

4.7.5 Confirming set devices in list view

Display a list of devices used in protocols in list view.

Screen display
Select [Tool] ⇒ [Setting Device List].
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4.8 Writing/Reading/Verifying Protocol Settings

This section explains how to write/read/verify protocol settings to/from/with the module.

4.8.1 Writing/reading protocol settings

Write data of the registered protocol settings to a selected module, and read the protocol settings from 
a selected module.

Screen display
Select [Module Read/Write] ⇒ [Write to Module]/[Read from Module].

Operating procedure

• Select a module and click the    button.
For the write to module process, the following message is displayed.
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4.8.1  Writing/reading protocol settings

■ Workaround when the Q series C24N/L series C24 module detects a 
protocol setting data error

The settings of editable protocols may not be correct when the Q series C24N/L series C24 module 
detects a protocol setting data error after the protocol settings are written to the module.
In such case, correct the protocol settings according to the following procedure and rewrite them to the 
module.

Operation
1. Confirm the protocol number, packet number, and element number of the detected error 

in the protocol setting data error information (buffer memory 4086H to 4089H) of the Q 
series C24N/L series C24 module.

2. Confirm whether or not the following conditions are satisfied in the packet setting in 
which the error has been detected.
When any elements of No. 1 and any elements of No. 2 described in the following table are in 
the same packet, No. 1 must be placed before No. 2.

3. Modify the protocol settings, and rewrite them to the module.

● Settings which may cause a 'protocol setting data error'
A protocol setting data error may occur when any of the following data are set and written to the Q series C24N module 
with the serial number of which the first five digits are '10122'.

● Execution of write to module function during execution of CPRTCL instruction
An error may occur when the protocol setting data is written to a module during execution of the CPRTCL instruction.

● Data not to be written to module
The following data cannot be written to a module. Save these data in a protocol setting file.
• Manufacturer
• Packet Name
• Type, Version, Explanation in the protocol detailed setting
• Element Name in the packet setting

No. Setting

1

• Conversion Variable (Fixed number of data, Fixed number of digits (1 to 10 digits), No sign character)
• Conversion Variable (Fixed number of data, Fixed number of digits (1 to 10 digits), Variable decimal point)
• Conversion Variable (Fixed number of data, Variable number of digits, Number of data is 1, Delimiter is comma 

or space)

2

• Non-conversion Variable (Variable length)
• Conversion Variable (Variable number of data)
• Conversion Variable (Fixed number of data, Variable number of digits, Number of data is 1, No delimiter)
• Conversion Variable (Fixed number of data, Variable number of digits, Number of data is 2 or more)
• Non-verified Reception (Variable number of characters)

Element type Setting

Conversion Variable
• "Sign" is 'Signed'
• "Number of Decimals" is 1 to 9 or 'Variable Point'
• "Delimiter" is 'Comma' or 'Space'

Non-verified 
Reception • "Data Length" is '0' (variable number of characters)
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4.8.2 Verifying protocol settings in personal computer side with 
those in module side

Compare the protocol setting being opened with that written to a selected module.

Operating procedure

1. Select [Module Read/Write] ⇒ [Module Verification].

2. Select a module and click the    button.
If any mismatches are found, the following message is displayed.

3. Click the    button.
The verification result screen is displayed.
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4.8.2  Verifying protocol settings in personal computer side with those in module side

Display contents

Screen button

●

Copies all contents being displayed on the screen to the clip board in text format.

■ Contents displayed on "Target Item"

The following table shows items displayed on "Target Item" of the verification result screen.

● Target of verification
As the following data cannot be written to a module, these data are not compared.
• Manufacturer
• Packet Name
• Type, Version, Explanation in the protocol detailed setting
• Element Name in the packet setting

Item Description

Target Item Display mismatch items. 
For items displayed on "Target Item", refer to ■ Contents displayed on "Target Item".

Result Display 'Mismatch'.

Item Description

Number of Protocols This item is displayed when the total of registered protocols is mismatched.

Protocol No.1 to 128 The protocol number of a protocol which include any mismatches is displayed.

Protocol No.

The first mismatched item is displayed by comparing items in top down order.

Predefined Protocol Library/
Editable Protocol

Protocol Detailed Setting 
Information

Number of Packets

Packet Setting Information
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4.9 Debugging

This section explains how to debug the communication processing between the Q series C24N/L 
series C24 module and device controller.

4.9.1 Selecting debugging target modules

Select a module to be debugged. The protocol execution log display function and the state monitoring 
function are executed against the module selected in this function.

Screen display
Select [Debugging Support Function] ⇒ [Module Selection].

Operating procedure

1. Set the items on the screen.

2. Click the    button.
The selected module and channel are set to "The Present Object Module".

3. Click the    button.
The set values displayed on "The Present Object Module" are set as the target module.

Screen button

●

Displays the latest module list.

Item Description

The Present Object 
Module Display the information of the selected module.

Module List Select a debugging target module.

Channel Specification Select the channel of the module.
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4.9.2  Displaying protocol execution logs

4.9.2 Displaying protocol execution logs

Display the protocol execution logs and the protocol execution results when the protocol settings are 
set.

Operating procedure

1. Select a module to be debugged. (Section 4.9.1)

2. Select [Debugging Support Function] ⇒ [Protocol Execution Log].
The Protocol Execution Log screen is displayed.

Display contents

Item Description

Object Module Display the target module (I/O address and module type) and channel of the protocol execution 
logs being displayed.

No. Display the execution logs in the order from the latest.

Start Time and Date Display the start date of the protocol execution.

End time and Date Display the end date of the protocol execution.

Model Display the external device name.

Protocol No. Display the executed protocol number.

Protocol Name Display the executed protocol name.

Type

Display the communication type of protocol: 'Send Only', 'Receive Only', or 'Send&Receive'. 
When a functional protocol is executed, "Functional protocol" is displayed. 
When a protocol is executed using the dedicated instruction (CPRTCL instruction) by specifying 
its protocol number which is not written to the module, "Unregistered protocol No." is displayed.
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● Execution log option
The registration conditions of logs can be specified by the execution log option specification for buffer memory (buffer 
memory address: 40E2H, 40F2H) or by the various control designations of the intelligent function module utility.
The following are the registration conditions.

Note that, only the logs of error protocols are displayed at the default setting. To display all protocol logs, set the 
registration condition in "Execution log options" of the various control designations in the intelligent function module 
data.
For details, refer to the following manuals.
Q Corresponding Serial Communication Module User's Manual (Basic)
MELSEC-L Serial Communication Module User's Manual (Basic)

Execution Result

Display the execution results of the protocols.

For protocols with the 'waiting for transmission', 'sending', 'waiting for reception', or 'receiving' 
status, the corresponding logs are displayed in light blue.

Error Code
Display the error code of error completion in red when the execution result is an error 
completion. 
When the result is a normal completion, '-' is displayed.

Retry Display the number of send retries.

Packet No. Display the receive packet numbers which are matched by the verification.

Item Description

Error completion : Displayed with red background.
Normal completion : Displayed with light green background.

0th bit is OFF (0) : Stores the execution log for the protocols with the error completion only.
0th bit is ON (1) : Stores the execution status and the execution logs of all protocols.



4 - 38

GX Works2

4  PREDEFINED PROTOCOL SUPPORT FUNCTION

4.9.3  State monitoring

4.9.3 State monitoring

Monitor signals, communication error information, operation setting switches, and protocol execution 
status.
For details, refer to the user's manual of each module.

Operating procedure

1. Select a module to be debugged. (Section 4.9.1)

2. Select [Debugging Support Function] ⇒ [State Monitor].
The State Monitor screen is displayed.

Display contents

Item Description

<<Signal>> Display the ON/OFF status of the X/Y/RS-232 signals.
■ Display contents of <<Signal>>

<<Error Information>> Display the information of errors, such as a communication error.
■ Display contents of <<Error Information>>

<<Operation Setting Switch>> Display the information of such as the operation switches and mode switch.
■ Display contents of <<Operation Setting Switch>>

<<Predefined Protocol 
Function>>

Display the information of such as the protocol execution status.
■ Display contents of <<Predefined Protocol Function>>
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■ Display contents of <<Signal>>

Screen display
Select [Debugging Support Function] ⇒ [State Monitor] ⇒ <<Signal>>.

Display contents

Item Description

X signal state monitor Display the ON/OFF status of the X signals.*1

Y signal state monitor Display the ON/OFF status of the Y signals.

RS-232 signal monitor Display the ON/OFF status of the RS-232 control signals.

*1 : Protocols can be executed while the Predefined protocol ready (X1D) is ON.
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4.9.3  State monitoring

■ Display contents of <<Error Information>>

Screen display
Select [Debugging Support Function] ⇒ [State Monitor] ⇒ <<Error Information>>.

Display contents

Screen button

●

Resets the error information when XnE on CH1 or XnF on CH2 is ON.

Item Description

Communication Error Status Display the communication error status.

Switch Setting, Mode Switching 
Error Display the switch setting and/or mode selection error status.

Communication Result Display the error status of the communication result.
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■ Display contents of <<Operation Setting Switch>>

Screen display
Select [Debugging Support Function] ⇒ [State Monitor] ⇒ <<Operation Setting Switch>>.

Display contents

Item Description

Switch Setting Status for The 
Operation Display the operation switch setting status.

Mode Switch Display the communication protocol setting.

Station Switch Display the station number setting.
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4.9.3  State monitoring

■ Display contents of <<Predefined Protocol Function>>

Screen display
Select [Debugging Support Function] ⇒ [State Monitor] ⇒ <<Predefined Protocol Function>>.

Display contents

Item Description

Execution Status Display the protocol execution status.

Protocol Cancel Designation Display the protocol cancel designation status.

Predefined Protocol Function Error 
Code Display the error code of the result from the error completion.
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4.10 Printing Protocol Settings

This section explains how to print protocol settings, packet settings, and setting device lists.

4.10.1 Print screen

Execute printing.

Screen display
Select [File] ⇒ [Print] ( ).

Operating procedure

1. Set "Print item".

2. Click the    button.

Screen button

●

Displays the Printer Setting screen.

●

Displays the Print Preview screen.
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4.10.2  Print examples

4.10.2 Print examples

The following shows print examples.

■ Protocol setting
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■ Packet setting
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4.10.2  Print examples

■ Setting device list
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Appendix 1 List of Toolbars and Shortcut Keys

This section shows the list of toolbars and shortcut keys that can be used in operations of the 
intelligent function module.

For (Common) indicated in the Reference column and details of functions not described in this 
section, refer to the following manual.
GX Works2 Version 1 Operating Manual (Common)

Appendix 1.1 Common toolbars and shortcut keys

The following explains the toolbars that are available regardless of the editing target and the 
corresponding shortcut keys.

■ "Program Common" toolbar icons

The following table shows the "Program Common" toolbar icons and the corresponding shortcut keys.

■ "Docking Window/Switch Project Data" toolbar icons

The following table shows the "Docking Window/Switch Project Data" toolbar icons.

Toolbar 
icon Shortcut key Corresponding menu Description Reference

- Write to PLC Write data to the programmable controller 
CPU.

(Common)

- Read from PLC Read data from the programmable 
controller CPU.

- Start Monitoring (All Windows) Start monitoring all windows being 
opened.

- Stop Monitoring (All Windows) Stop monitoring all windows being 
opened.

 Start Monitoring Start monitoring the window being 
operated.

+ Stop Monitoring Stop monitoring the window being 
operated.

Toolbar
icon Shortcut key Corresponding menu Description Reference

- Intelligent Function Module 
Monitor

Display/hide the Intelligent Function Module 
Monitor window. Section 2.4

- Intelligent Function Module 
Guidance

Display/hide the Intelligent Function Module 
Guidance window. Section 3.5.6
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■ "Intelligent Function Module" toolbar icons

The following table shows the "Intelligent Function Module" toolbar icons.

■ Other shortcut keys

The following table shows other shortcut keys that are available regardless of the editing target.

Toolbar
icon Shortcut key Corresponding menu Description Reference

- QD75/LD75 Positioning 
Module Wave Trace

Execute a wave trace of the QD75/LD75 
positioning module. Section 3.5.3

- QD75/LD75 Positioning 
Module Location Trace

Execute a location trace of the QD75/LD75 
positioning module. Section 3.5.4

- Serial Communication 
Module Circuit Trace

Execute a circuit trace of the serial 
communication module. Section 3.7.2

- QD75/LD75 Positioning 
Module Test Monitor

Execute a positioning monitoring of the 
QD75/LD75 positioning module. Section 3.5.1

- QD75/LD75 Positioning 
Module Test

Execute a positioning test of the QD75/LD75 
positioning module. Section 3.5.2

- Offset/Gain Setting of 
Temperature Input Module

Execute offset/gain setting of the 
temperature input module. Section 3.2.1

- Offset/Gain Setting of 
Analog Module

Execute offset/gain setting of the analog 
module. Section 3.1.1

Toolbar 
icon Shortcut key Corresponding menu Description Reference

-  ++ Add New Module Add the intelligent function module data to 
the project being edited. Section 2.1.1

- + Start Watching
Start monitoring the current values of 
registered devices/labels and intelligent 
function module.

Section 2.4

- ++ Stop Watching
Stop monitoring the current values of 
registered devices/labels and intelligent 
function module.
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Appendix 1.2  Shortcut keys for operating intelligent function module data

Appendix 1.2 Shortcut keys for operating intelligent function module 
data

The following explains the toolbar icons and the corresponding shortcut keys for operating intelligent 
function module data.

■ Toolbar icons for positioning monitoring function

The following table shows the toolbar icons for the positioning monitoring function.

■ Toolbar icons and shortcut keys for predefined protocol support function

The following table shows the toolbar icons and the corresponding shortcut keys for the predefined 
protocol support function.

Toolbar 
icon Shortcut key Corresponding menu Description Reference

- - Monitor the operating status of positioning 
module.

Section 3.5.1- - Monitor the start history.

- - Monitor the error history.

- - Monitor the warning history.

 - Start the positioning monitoring. -

+ - Stop the positioning monitoring. -

Toolbar 
icon Shortcut key Corresponding menu Description Reference

+ New Create a new protocol setting. Section 4.5.1

+ Open Open an existing protocol setting. Section 4.5.2

+ Save Save the protocol information. Section 4.5.3

+ Copy Copy the selected data. -

+ Paste Paste the cut/copied data at the cursor 
position. -

- Print Print the protocol information. Section 4.10

- Write to Module Write data to a module.
Section 4.8.1

- Read from Module Read data from a module.
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Appendix 2 Compatibility with GX Configurator-QP

The QD75/LD75 positioning module functions in GX Works2 are different in functionality and 
operability compared to the functions of GX Configurator-QP. Review the following considerations 
before use.

Appendix 3 Procedure for Use of GX Configurator-QP

GX Configurator-QP is included on the CD-ROM (Disc 2) of GX Works2 and can be installed by the 
following procedure.

Operating procedure

1. Copy the compressed file of GX Configurator-QP from the CD-ROM (Disc 2) onto 
HDD of the personal computer.
The compressed file of GX Configurator-QP means the following file on the CD-ROM.
• 'CD-ROM drive'\Others\qp2-xxx.dat*1

*1 : 'xxx' are replaced with numbers and/or alphabets.

2. Change the extension of the file copied onto the personal computer from 'dat' to 
'exe'.
The file name changes from 'qp2-xxx.dat' to 'qp2-xxx.exe'.

3. Double-click 'qp2-xxx.exe' and decompress it to the desired directory.

4. Run 'SETUP.EXE' among the decompressed files.
The installation of GX Configurator-QP starts.
For details of the installation procedure, refer to the following manual.
Use the product ID of GX Works2 for the installation.
GX Configurator-QP Version 2 Operating Manual

GX Configurator-QP function Considerations for using GX Works2

Navigation Use GX Configurator-QP*1

Sampling monitor Use the sampling trace function. (GX Works2 Version 1 Operating Manual 
(Common))

Diagnostics Use the positioning test function. (Section 3.5.2)

*1 : GX Configurator-QP is included on the CD-ROM of GX Works2.
For the installation procedure, refer to Appendix 3. Note that GX Works2 and GX Configurator-QP can be used 
simultaneously.
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