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SAFETY PRECAUTIONS
(Always read these instructions before using this product.)

Before using this product, thoroughly read this manual and the relevant manuals introduced in this manual 

and pay careful attention to safety and handle the products properly.

The precautions given in this manual are concerned with this product. For the safety precautions of the 

programmable controller system, refer to the User's Manual for the CPU module.

In this manual, the safety precautions are ranked as " WARNING" and " CAUTION".

Note that the CAUTION level may lead to serious consequences according to the circumstances.

Always follow the precautions of both levels because they are important for personal safety.

Please save this manual to make it accessible when required and always forward it to the end user.

[Design Instructions]

[Startup/Maintenance Instructions]

 WARNING
● When data change, program change, or status control is performed from a personal computer to a running 

programmable controller, create an interlock circuit outside the programmable controller to ensure that the whole 

system always operates safely.

Furthermore, for the online operations performed from a personal computer to a programmable controller CPU, the 

corrective actions against a communication error due to such as a cable connection fault should be predetermined as 

a system.

 CAUTION
● The online operations performed from a personal computer to a running programmable controller CPU (Program 

change when a programmable controller CPU is RUN, operating status changes such as forced input/output 

operation and RUN-STOP switching, and remote control operation) must be executed after the manual has been 

carefully read and the safety has been ensured.

When changing a program while a programmable controller CPU is RUN, it may cause a program corruption in some 

operating conditions. Fully understand the precautions described in Section 12.9 before use.

● The positioning test functions of OPR, JOG, inching or positioning data for QD75/LD75 positioning module must be 

executed with the programmable controller set to STOP after the manual has been carefully read and the safety has 

been ensured. Specially when executing the function on the network system, ensure the safety thoroughly since the 

machinery whose operation cannot be checked by an operator may be activated. The operation failure may cause the 

injury or machine damage.

WARNING

CAUTION

Indicates that incorrect handling may cause hazardous conditions, resulting in 

death or severe injury.

Indicates that incorrect handling may cause hazardous conditions, resulting in 

minor or moderate injury or property damage.
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CONDITIONS OF USE FOR THE PRODUCT

(1) Mitsubishi programmable controller ("the PRODUCT") shall be used in conditions;

i) where any problem, fault or failure occurring in the PRODUCT, if any, shall not lead to any major or 

serious accident;  and 

ii) where the backup and fail-safe function are systematically or automatically provided outside of the 

PRODUCT for the case of any problem, fault or failure occurring in the PRODUCT.

(2) The PRODUCT has been designed and manufactured for the purpose of being used in general 

industries.

MITSUBISHI SHALL HAVE NO RESPONSIBILITY OR LIABILITY (INCLUDING, BUT NOT LIMITED 

TO ANY AND ALL RESPONSIBILITY OR LIABILITY BASED ON CONTRACT, WARRANTY, TORT, 

PRODUCT LIABILITY) FOR ANY INJURY OR DEATH TO PERSONS OR LOSS OR DAMAGE TO 

PROPERTY CAUSED BY the PRODUCT THAT ARE OPERATED OR USED IN APPLICATION NOT 

INTENDED OR EXCLUDED BY INSTRUCTIONS, PRECAUTIONS, OR WARNING CONTAINED IN 

MITSUBISHI'S USER, INSTRUCTION AND/OR SAFETY MANUALS, TECHNICAL BULLETINS AND 

GUIDELINES FOR the PRODUCT.

("Prohibited Application")

Prohibited Applications include, but not limited to, the use of the PRODUCT in;

 • Nuclear Power Plants and any other power plants operated by Power companies, and/or any other 

cases in which the public could be affected if any problem or fault occurs in the PRODUCT.

 • Railway companies or Public service purposes, and/or any other cases in which establishment of a 

special quality assurance system is required by the Purchaser or End User.

 • Aircraft or Aerospace, Medical applications, Train equipment, transport equipment such as Elevator 

and Escalator, Incineration and Fuel devices, Vehicles, Manned transportation, Equipment for 

Recreation and Amusement, and Safety devices, handling of Nuclear or Hazardous Materials or 

Chemicals, Mining and Drilling, and/or other applications where there is a significant risk of injury to 

the public or property.

 

Notwithstanding the above, restrictions Mitsubishi may in its sole discretion, authorize use of the 

PRODUCT in one or more of the Prohibited Applications, provided that the usage of the PRODUCT is 

limited only for the specific applications agreed to by Mitsubishi and provided further that no special 

quality assurance or fail-safe, redundant or other safety features which exceed the general 

specifications of the PRODUCTs are required. For details, please contact the Mitsubishi representative 

in your region.
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REVISIONS
Print date Manual number*1 Revision

Jul. 2008 SH(NA)-080779ENG-A First edition

Jan. 2009 SH(NA)-080779ENG-B Model Addition
Q00UJ, Q00U, Q01U, Q10UDH, Q10UDEH, Q20UDH, Q20UDEH, FX series

Addition
MANUALS, Section 2.1, Section 2.1.2, Section 2.1.3, Section 2.1.5, Section 2.1.6,
Section 2.1.7, Section 2.1.8, Section 2.3, Section 3.2.8, Section 5.2, Section 12.8,
Section 13.2, Section 14.5, Section 14.6, Section 14.7, Section 15.2.2, Section 15.3,
Section 15.4, Section 17.1.2, Section 17.4.3, Section 17.4.4, Appendix 6

Correction
GENERIC TERMS AND ABBREVIATIONS IN THIS MANUAL, Section 1.3, Section 2.1.4,
Section 2.3, Section 2.5, Section 3.2.1, Section 3.2.2, Section 3.2.3, Section 3.2.4,
Section 3.2.6, Section 3.3.1, Section 3.3.4, Section 4.1.6, Section 4.1.7, Section 4.2.1,
Section 4.3, Section 4.3.1, Section 4.3.5, Section 4.4, Section 4.4.1, Section 4.5.2,
Section 4.5.3, Section 4.6, Section 4.6.1, Section 4.7, Section 6.1, Section 6.1.1,
Section 6.2, Section 6.2.1, Section 7.1.2, Section 7.2.2, Section 7.2.4, Section 8.1.2,
Section 9.1.1, Section 9.1.2, Section 10.1.2, Section 10.2, Section 10.3, Section 11.1.1,
Section 11.2.3, Section 11.3, Section 11.8.1, Section 12.2, Section 12.5, Section 12.9.1,
Section 12.9.5, Section 13.1.1, Section 14.1, Section 14.3, Section 15.5.4, Section 16.1,
Section 16.3, Section 16.5, Section 17.4.1, Section 17.4.2, Section 18.3.2, Chapter 19,
Appendix 1, Appendix 2, Appendix 3, Appendix 4, Appendix 5, Appendix 7, Appendix 8,
Appendix 9.3

Jul. 2009 SH(NA)-080779ENG-C Model Addition
Q00J, Q00, Q01

Addition
Section 4.1.4, Section 7.2.4, Section 10.3.2, Section 10.3.3, Section 10.3.4, Section 10.3.5,
Section 11.1.2, Section 12.9.3, Section 12.10, Section 15.2.1, Section 15.2.2,
Section 15.2.3, Section 16.5, Section 18.6.1, Chapter 19

Correction
MANUALS, GENERIC TERMS AND ABBREVIATIONS IN THIS MANUAL, Section 1.3,
Section 2.3, Section 2.5, Section 3.2.1, Section 3.2.8, Section 4.1.1, Section 4.1.8,
Section 4.2.1, Section 4.3.1, Section 4.3.5, Section 4.4, Section 4.6, Section 4.8,
Section 5.2, Section 6.1.1, Section 7.1.2, Section 7.2.2, Section 7.2.3, Section 7.3,
Section 7.4.2, Section 8.2, Section 9.1.1, Section 9.2.1, Section 9.2.2, Section 10.3.1,
Section 10.3.6, Section 11.1, Section 11.2.3, Section 11.4, Section 11.9, Section 12.1,
Section 12.1.5, Section 12.5, Section 12.9.1, Section 12.9.4, Section 12.9.6, Section 12.11,
Section 14.2.2, Section 14.7, Section 15.1, Section 15.2, Section 16.2, Section 16.4,
Section 17.2, Section 18.3, Section 18.4, Section 18.6, Section 20.2, Section 20.3,
Section 21.2, Section 22.2.2, Appendix 1, Appendix 2, Appendix 4, Appendix 5, Appendix 6,
Appendix 7, Appendix 8, Appendix 9, Appendix 10

Modification
Section 4.1.4 to 4.1.7 → Section 4.1.5 to 4.1.8, Section 4.6.4 → Section 4.7,
Section 4.7 to 4.8 → Section 4.8 to 4.9, Section 7.2.4 to 7.2.5 → Section 7.2.5 to 7.2.6,
Section 10.2 to 10.3 → Section 10.1 to 10.2, Section 11.1.2 → Section 11.2.3,
Section 11.9.3 to 11.9.5 → Section 11.9.4 to 11.9.6, Section 12.10 → Section 12.11,
Section 14.2.3 to 14.2.4 → Section 14.2.2 to 14.2.3, Section 15.1.1 → Section 15.2,
Section 15.1.2 → Section 15.4, Section 15.2 to 15.5 → Section 16.1 to 16.4,
Chapter 16 to 17 → Chapter 17 to 18, Chapter 18 to 19 → Chapter 20 to 21,
Appendix 7 → Appendix 6, Appendix 10 → Appendix 8

Deletion
Section 3.3.5, Section 4.4.1

Oct. 2009 SH(NA)-080779ENG-D Addition
Appendix 13

Correction
GENERIC TERMS AND ABBREVIATIONS IN THIS MANUAL, Section 1.3.1,
Section 1.3.6, Section 2.1, Section 4.1.7, Section 6.1, Section 10.1.1, Section 10.3,
Section 11.8.1, Section 11.8.2, Section 12.2, Section 20.3.2, Section 21.1, Section 21.2,
Appendix 1.2, Appendix 1.6, Appendix 4.2, Appendix 4.3, Appendix 4.4, Appendix 4.5,
Appendix 4.9, Appendix 4.10, Appendix 4.14, Appendix 7, Appendix 8, Appendix 10.1,
Appendix 12
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Jan. 2010 SH(NA)-080779ENG-E Model Addition
L02, L26-BT

Addition
CONDITIONS OF USE FOR THE PRODUCT, Section 3.3.4, Section 13.2, Section 16.6,
Section 18.4.5, Section 18.6.1, Section 18.7, Appendix 10.7, Appendix 14

Correction
MANUALS, GENERIC TERMS AND ABBREVIATIONS IN THIS MANUAL, Section 1.3,
Section 2.1, Section 2.2, Section 2.3, Section 2.4, Section 3.2.7, Section 4.1.1,
Section 4.1.3, Section 4.1.7, Section 4.1.8, Section 4.3, Section 4.5.1, Section 4.5.5,
Section 4.6, Section 6.1, Section 6.2, Section 6.3, Section 6.4, Section 7.1.2, Section 7.2.6,
Section 7.3, Section 9.1.2, Section 9.4.2, Section 10.1, Section 10.2, Section 10.3,
Section 11.2.1, Section 11.2.3, Section 11.3, Section 11.5, Section 11.7, Section 11.8.1,
Section 11.8.2, Section 12.1, Section 12.1.2, Section 12.1.4, Section 12.2, Section 12.3,
Section 12.5, Section 12.6, Section 12.8, Section 12.8.2, Section 12.9.1, Section 12.9.2,
Section 12.9.4, Section 12.9.5, Section 12.9.6, Section 12.10.2, Section 12.10.3,
Section 12.10.4, Section 12.11, Section 12.11.1, Section 12.11.2, Section 13.3.1,
Section 13.3.2, Section 13.3.3, Section 14.1.2, Section 14.5, Section 14.7, Section 15.1,
Section 15.2, Section 15.2.1, Section 15.2.3, Section 16.1, Section 16.4.1, Section 16.4.2,
Section 16.4.3, Section 16.4.4, Section 17.1, Section 17.2, Section 17.3, Section 17.4,
Section 17.5, Section 18.1.1, Section 18.1.2, Section 18.1.3, Section 18.1.4, Section 18.4.1,
Section 18.4.3, Section 18.5, Section 18.5.2, Section 18.5.3, Section 18.6, Section 19.3,
Section 19.4.1, Section 19.4.2, Section 19.5.3, Section 19.6, Section 19.8, Section 21.1,
Section 21.2, Appendix 1, Appendix 1.1, Appendix 1.3, Appendix 1.4, Appendix 1.5,
Appendix 1.6, Appendix 1.7.1, Appendix 1.8, Appendix 2.1, Appendix 2.2, Appendix 2.3,
Appendix 2.4, Appendix 4.2, Appendix 4.9, Appendix 4.13, Appendix 5, Appendix 6,
Appendix 7, Appendix 8.1, Appendix 9, Appendix 10, Appendix 10.1, Appendix 10.2,
Appendix 10.3, Appendix 10.4, Appendix 10.5, Appendix 10.6, Appendix 10.7, Appendix 12

Apr. 2010 SH(NA)-080779ENG-F Model Addition
Q50UDEH, Q100UDEH, LJ72GF15-T2

Addition
Section 4.1.8, Section 6.1.1, Section 6.1.2, Section 6.2.1, Section 12.12, Section 18.1.4,
Section 18.4, Appendix 4.13, Appendix 10.8

Correction
MANUALS, GENERIC TERMS AND ABBREVIATIONS IN THIS MANUAL, Section 1.1,
Section 1.2, Section 1.3.1, Section 2.1.1, Section 2.1.2, Section 2.1.3, Section 2.1.8,
Section 2.3, Section 2.5, Section 3.2, Section 3.4, Section 3.5, Section 4.1.2, Section 4.6,
Section 4.6.3, Section 4.8, Section 4.8.5, Section 6.1, Section 6.1.1, Section 6.4,
Section 10.1.1, Section 11.1.1, Section 11.2.3, Section 11.3, Section 11.4, Section 11.5,
Section 11.6, Section 11.7, Section 12.4.1, Section 12.6, Section 12.8, Section 12.9.1,
Section 12.9.2, Section 12.9.6, Section 11.2.3, Section 14.1.2, Section 14.2.2, Section 16.1,
Section 16.4.2, Section 16.4.3, Section 17.1, Section 17.2, Section 17.3, Section 17.6,
Section 18.1, Section 18.3, Section 18.4, Section 18.5.3, Section 18.7, Section 18.7.2,
Section 20.1, Section 20.3.2, Section 21.1, Section 21.2, Chapter 22, Appendix 1.1,
Appendix 1.6, Appendix 2, Appendix 4.1, Appendix 4.2, Appendix 4.5, Appendix 4.9,
Appendix 4.13, Appendix 5, Appendix 6, Appendix 7, Appendix 10, Appendix 12,
Appendix 13

Modification
Section 18.4 to 18.6 → Section 18.5 to 18.7,
Appendix 4.13 to 4.14 → Appendix 4.14 to 4.15

Print date Manual number*1 Revision
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Sept. 2010 SH(NA)-080779ENG-G Model Addition
QJ72LP25, QJ72BR15

Addition
Section 16.2.2, Section 17.7, Section 18.8, Appendix 2.3, Appendix 15

Correction
GENERIC TERMS AND ABBREVIATIONS IN THIS MANUAL, Section 1.2, Section 1.3.1,
Section 1.3.2, Section 1.3.4, Section 1.3.5, Section 1.3.8, Section 2.1, Section 2.1.2,
Section 2.1.4, Section 2.1.6, Section 2.1.7, Section 2.2, Section 2.2.1, Section 2.3,
Section 3.2.1, Section 3.2.2, Section 3.2.3, Section 3.2.4, Section 3.2.6, Section 3.3,
Section 3.3.4, Section 3.3.5, Section 4.1.1, Section 4.1.2, Section 4.1.3, Section 4.1.7,
Section 4.1.8, Section 4.2.1, Section 4.2.5, Section 4.5.3, Section 4.5.5, Section 4.6,
Section 4.6.1, Section 4.7, Section 4.8, Section 4.8.5, Section 4.9, Section 6.1.1,
Section 6.2, Section 6.2.1, Section 9.1.2, Section 9.2.1, Section 9.2.2, Section 10.1,
Section 10.1.1, Section 10.2, Section 10.3, Section 10.3.1, Section 10.3.2, Section 10.3.3,
 Section 10.3.4, Section 10.3.5, Section 11.1, Section 11.1.1, Section 11.2, Section 11.2.1,
Section 11.2.2, Section 11.2.3, Section 11.3, Section 11.4, Section 11.5, Section 11.6,
Section 11.7.1, Section 11.7.2, Section 11.8.1, Section 11.8.2, Section 11.9, Section 12.1,
Section 12.1.3, Section 12.1.4, Section 12.1.5, Section 12.2, Section 12.3, Section 12.4,
Section 12.8, Section 12.9.1, Section 12.9.5, Section 12.12, Section 13.1, Section 13.1.1,
Section 13.2, Section 13.2.1, Section 14.1.1, Section 14.1.2, Section 14.2.1, Section 14.2.2,
Section 14.3, Section 15.1.2, Section 15.2, Section 17.1, Section 17.2, Section 17.3,
Section 17.4, Section 17.7, Section 18.1.1, Section 18.1.4, Section 18.2.5, Section 18.2.7,
Section 18.2.8, Section 18.3, Section 18.4, Section 18.4.4, Section 18.4.5, Section 18.4.6,
Section 18.5.1, Section 18.5.3, Section 18.6.2, Section 18.6.3, Section 18.6.4, Section 18.7,
Section 21.2, Appendix 1.1, Appendix 1.2, Appendix 1.6, Appendix 2.1, Appendix 2.2,
Appendix 2.4, Appendix 2.5, Appendix 4.2, Appendix 4.5, Appendix 4.12, Appendix 4.14,
Appendix 4.15, Appendix 6.1, Appendix 6.2, Appendix 7, Appendix 8, Appendix 9,
Appendix 10.1, Appendix 10.2, Appendix 10.3, Appendix 10.4, Appendix 10.5,
Appendix 10.6, Appendix 10.7, Appendix 10.9, Appendix 12, Appendix 15

Modification
Appendix 4.6.3 → Appendix 4.6.2, Appendix 2.3 → Appendix 2.4

Jan. 2011 SH(NA)-080779ENG-H Addition
TERMS, Section 3.3, Section 4.1, Section 12.5, Section 14.1, Section 14.3.4, Section 20.4,
Appendix 16

Correction
MANUALS, GENERIC TERMS AND ABBREVIATIONS IN THIS MANUAL, Section 1.3,
Section 2.1.1, Section 2.1.3, Section 2.2, Section 2.3, Section 3.2.5, Section 3.2.6,
Section 4.1.2, Section 4.2.1, Section 4.2.2, Section 4.2.3, Section 4.2.4, Section 4.2.5,
Section 4.2.7, Section 4.2.8, Section 4.3.1, Section 4.3.5, Section 4.7.1, Section 4.8,
Section 6.1.2, Section 8.2, Section 9.4.1, Section 9.4.2, Section 10.1.1, Section 10.2,
Section 11.8, Section 12.1.5, Section 12.1.6, Section 12.2, Chapter 14, Section 16.3,
Section 18.1.1, Section 18.7, Section 19.1.1, Section 19.1.3, Section 20.2, Section 20.3.1,
 Section 20.3.2, Section 21.2, Appendix 1.1, Appendix 1.4, Appendix 1.8, Appendix 4,
Appendix 7, Appendix 12, Appendix 15, Appendix 16

Modification
Section 4.1 to 4.9 → Section 4.2 to 4.10, Section 12.5 → Section 12.6,
Section 14.1 to 14.7 → Section 14.2 to 14.8

Mar. 2011 SH(NA)-080779ENG-I Addition
Section 4.9, Section 16.6, Section 20.1, Section 20.3, Section 20.4, Section 20.5,
Section 20.6, Section 20.11,

Correction
MANUALS, GENERIC TERMS AND ABBREVIATIONS IN THIS MANUAL, Section 1.1,
Section 1.3.1, Section 1.3.3, Section 2.2, Section 2.3, Section 3.3, Section 4.2.1,
Section 4.2.2, Section 4.2.3, Section 4.2.4, Section 4.3.2, Section 4.6.1, Section 4.7.1,
Section 6.1.1, Section 6.2, Section 6.4, Section 10.1, Section 10.2, Section 10.3,
Section 11.1.1, Section 12.1.5, Section 12.7.1, Section 12.9.1, Section 14.1.2,
Section 14.6.2, Section 15.1.2, Section 15.3, Section 16.6.3, Section 18.4, Section 18.6.3,
Section 20.5.7, Section 20.8.1, Section 21.2, Appendix 1.1, Appendix 1.6, Appendix 4,
Appendix 7, Appendix 10, Appendix 12, Appendix 13, Appendix 16, Appendix 17

Modification
Section 20.1 → Section 20.2, Section 20.2 → Section 20.9, Section 20.3.1 → Section 20.7,
Section 20.3.2 → Section 20.10, Section 20.4 → Section 20.8,
Appendix 15 and 16 → Appendix 16 and 17

Print date Manual number*1 Revision
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Jul. 2011 SH(NA)-080779ENG-J Model Addition
L02-P, L26-PBT

Addition
Section 2.1.9, Section 3.4.1, Section 4.1.2, Section 5.2, Section 5.3, Section 10.1.2,
Section 12.10.4, Section 20.5.1, Section 20.5.2, Section 20.5.3, Section 20.5.8,
Section 20.5.12, Section 20.5.13, Section 20.5.14, Section 20.5.15, Section 20.5.16,
Section 20.5.18, Appendix 1.2

Correction
MANUALS, GENERIC TERMS AND ABBREVIATIONS IN THIS MANUAL, TERMS,
Section 1.3.1, Section 1.3.2, Section 1.3.3, Section 1.3.6, Section 2.1, Section 2.2,
Section 2.3, Section 2.5, Section 3.1, Section 3.3, Section 3.4, Section 4.1, Section 4.1.1,
Section 4.2.1, Section 4.2.2, Section 4.2.3, Section 4.2.7, Section 4.2.8, Section 4.3.1,
Section 4.11, Section 4.11.2, Section 6.1.1, Section 9.1.1, Section 9.2.2, Section 9.4.2,
Section 10.1, Section 10.1.1, Section 10.1.3, Section 10.2, Section 10.3.1, Section 10.3.2,
Section 10.3.3, Section 10.3.4, Section 11.6, Section 12.1, Section 12.1.5, Section 12.1.6,
Section 12.9.1, Section 12.9.6, Section 12.10.1, Section 12.10.2, Section 12.10.3,
Section 13.3, Section 16.6, Section 16.6.1, Section 16.6.2, Section 16.6.3, Section 16.6.4,
Section 16.6.5, Section 16.6.8, Section 17.1, Section 17.5, Section 18.1.1, Section 18.4,
Section 18.5.1, Section 18.6.2, Section 20.1, Section 20.3, Section 20.4, Section 20.5.2,
Section 20.5.3, Section 20.5.13, Section 20.5.18, Section 20.5.4, Section 20.5.5,
Section 20.5.6, Section 20.5.9, Section 20.5.11, Section 20.10, Section 20.11, Section 21.1,
Section 21.2, Appendix 1.1, Appendix 1.7, Appendix 4.2, Appendix 4.5, Appendix 4.10,
Appendix 4.13, Appendix 4.16, Appendix 4.18, Appendix 6.1, Appendix 6.2, Appendix 7,
Appendix 10.9, Appendix 12

Modification
Section 2.1.9 → Section 2.1.10,
Section 3.4.6 and Section 3.4.7 → Section 3.4.3 and Section 3.4.4,
Section 4.1.2 → Section 4.1.3, Section 5.2 → Section 5.4, Section 10.1.2 → Section 10.1.3,
Section 12.10.4 → Section 12.10.5,
Section 20.5.1 to Section 20.5.4 → Section 20.5.4 to Section 20.5.7,
Section 20.5.5 to Section 20.5.7 → Section 20.5.9 to Section 20.5.11,
Section 20.5.8 → Section 20.5.17,
Appendix 1.2 to Appendix 1.8 → Appendix 1.3 to Appendix 1.9

Deletion
Section 3.4.2, Section 3.4.3, Section 3.4.5, Section 3.4.6

Sept. 2011 SH(NA)-080779ENG-K Addition
Section 2.1.10, Section 9.5, Section 11.9, Section 20.3.1

Correction
TERMS, Section 1.3.1, Section 2.1, Section 3.2.6, Section 3.4, Section 4.2.7, Section 4.2.8,
Section 4.6.5, Section 6.2, Section 9.1.2, Section 9.2.1, Section 9.4.2, Section 11.1.1,
Section 12.1.3, Section 12.2, Section 18.1.1, Section 20.2, Section 20.3, Section 20.4,
Section 20.5.4, Section 20.5.5, Section 20.5.6, Section 20.5.9, Section 20.5.11,
Section 20.5.12, Section 20.5.14, Section 20.11, Appendix 4.3, Appendix 4.6,
Appendix 4.16, Appendix 5.1, Appendix 6.1, Appendix 7, Appendix 8, Appendix 10,
Appendix 12, Appendix 13.1, Appendix 13.2

Modification
Section 2.1.10 → Section 2.1.11, Section 11.9 → Section 11.10

Deletion
Section 6.2.2

Print date Manual number*1 Revision
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Nov. 2011 SH(NA)-080779ENG-L Addition
Section 1.3.7, Section 4.3.5, Section 6.2.2, Section 6.2.3, Section 6.2.4, Section 6.5,
Section 6.6, Chapter 22, Appendix 4.16, Appendix 18

Correction
MANUALS, GENERIC TERMS AND ABBREVIATIONS IN THIS MANUAL, TERMS,
Section 1.1, Section 1.3.1, Section 1.3.2, Section 1.3.3, Section 1.3.6, Section 2.1,
Section 2.1.7, Section 2.1.10, Section 3.2.1, Section 4.2.7, Section 4.2.8, Section 4.7.1,
Section 6.1.2, Section 6.2, Section 6.4, Section 9.3.1, Section 9.3.2, Section 9.4.2,
Section 10.1, Section 10.2, Section 11.1, Section 11.2.1, Section 11.3, Section 11.8.1,
Section 11.9, Section 12.1.3, Section 12.1.6, Section 12.2, Section 12.11.1, Section 13.1,
Section 13.2, Section 14.1.1, Section 15.1.2, Section 16.4.3, Section 18.5.1, Section 18.5.2,
Section 18.5.3, Section 18.5.4, Section 18.5.5, Section 18.7, Section 20.1, Section 21.2,
Appendix 1.1, Appendix 1.3, Appendix 1.6, Appendix 1.7, Appendix 2.2, Appendix 2.3,
Appendix 2.4, Appendix 4.1, Appendix 4.3, Appendix 4.5, Appendix 4.6, Appendix 4.11,
Appendix 4.17, Appendix 4.19, Appendix 7, Appendix 8.1, Appendix 9, Appendix 12,
Appendix 15, Appendix 17

Modification
Section 1.3.7 to Section 1.3.9 → Section 1.3.8 to Section 1.3.10,
Section 4.3.5 → Section 4.3.6,
Appendix 2.1 to Appendix 2.2 → Appendix 2.2 to Appendix 2.3,
Appendix 2.3 → Appendix 2.1,
Appendix 4.16 to Appendix 4.18 → Appendix 4.17 to Appendix 4.19

Jan. 2012 SH(NA)-080779ENG-M Model Addition
FX3GC

Addition
Section 18.4.2

Correction
Section 1.3.1, Section 2.1.3, Section 2.1.7, Section 2.1.10, Section 2.3, Section 3.4.1,
Section 4.2.8, Section 6.1.1, Section 6.2.1, Section 6.2.2, Section 11.1.1, Section 11.9,
Section 12.1, Section 12.1.6, Section 12.9.6, Section 18.4, Section 18.4.4, Section 18.4.6,
Section 18.4.7, Section 20.5.2, Section 21.2, Appendix 4.17, Appendix 7, Appendix 10.1,
Appendix 10.7, Appendix 12

Modification
Section 18.4.2 to Section 18.4.6 → Section 18.4.3 to Section 18.4.7

Deletion
Section 4.7.3

Print date Manual number*1 Revision
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May 2012 SH(NA)-080779ENG-N Model Addition
Q02PH, Q06PH, Q12PH, Q12PRH, Q25PH, Q25PRH

Addition
Section 6.2, Section 9.4, Section 11.5, Section 12.11.2, Section 17.2, Section 20.5.1,
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■ MANUALS

Related manuals are separately issued according to the purpose of their functions in GX Works2.

● Related manuals
The manuals related to this product are shown below.
Refer to the following tables when ordering required manuals.

1) Operation of GX Works2

2) Structured programming

Manual name Manual number
(Model code)

GX Works2 Version 1 Operating Manual (Simple Project)
Explains methods for such as creating and monitoring programs in Simple project of GX Works2.

(Sold separately)

SH-080780ENG
(13JU64)

GX Works2 Version 1 Operating Manual (Simple Project, Function Block)
Explains methods for such as creating function blocks, pasting function blocks to sequence programs, 
and operating FB library in Simple project of GX Works2. (Sold separately)

SH-080984ENG
(13JU72)

GX Works2 Version 1 Operating Manual (Structured Project)
Explains methods for such as creating and monitoring programs in Structured project of GX Works2.

(Sold separately)

SH-080781ENG
(13JU65)

GX Works2 Version 1 Operating Manual (Intelligent Function Module)
Explains methods of intelligent function module for such as parameter setting, monitoring programs, 
and predefined protocol support function in GX Works2. (Sold separately)

SH-080921ENG
(13JU69)

GX Works2 Beginner's Manual (Simple Project)
Explains fundamental methods for such as creating, editing, and monitoring programs in Simple project 
for users inexperienced with GX Works2. (Sold separately)

SH-080787ENG
(13JZ22)

GX Works2 Beginner's Manual (Structured Project)
Explains fundamental methods for such as creating, editing, and monitoring programs in Structured 
project for users inexperienced with GX Works2. (Sold separately)

SH-080788ENG
(13JZ23)

Manual name Manual number
(Model code)

MELSEC-Q/L/F Structured Programming Manual (Fundamentals)
Explains the programming methods, types of programming languages, and other information required 
to create structured programs. (Sold separately)

SH-080782ENG
(13JW06)

MELSEC-Q/L Structured Programming Manual (Common Instructions)
Explains the specifications and functions of common instructions such as sequence instructions, basic 
instructions, and application instructions, that can be used in structured programs. (Sold separately)

SH-080783ENG
(13JW07)

MELSEC-Q/L Structured Programming Manual (Application Functions)
Explains the specifications and functions of application functions that can be used in structured 
programs. (Sold separately)

SH-080784ENG
(13JW08)

MELSEC-Q/L Structured Programming Manual (Special Instructions)
Explains the specifications and functions of special instructions such as module dedicated instruction, 
PID control instruction, and built-in I/O function dedicated instruction, that can be used in structured 
programs. (Sold separately)

SH-080785ENG
(13JW09)

FXCPU Structured Programming Manual [Device & Common]
Explains the devices and parameters provided in GX Works2 for structured programming.

(Sold separately)

JY997D26001
(09R925)

FXCPU Structured Programming Manual [Basic & Applied Instruction]
Explains the sequence instructions provided in GX Works2 for structured programming.

(Sold separately)

JY997D34701
(09R926)

FXCPU Structured Programming Manual [Application Functions]
Explains the application functions provided in GX Works2 for structured programming.

(Sold separately)

JY997D34801
(09R927)
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3) Operation of iQ Works

The Operating Manuals are included on the CD-ROM of the software package in a PDF file format. Manuals in printed 
form are sold separately for single purchase. Order a manual by quoting the manual number (model code) listed in the 
table above.

Manual name Manual number
(Model code)

iQ Works Beginner’s Manual
Explains fundamental methods for such as managing the system using MELSOFT Navigator and using 
system labels for users inexperienced with GX Works2. (Sold separately)

SH-080902ENG
(13JZ44)



A - 26

● Purpose of this manual
This manual explains the functions that are common to Simple project and Structured project, 
including system configuration, parameter settings, and operation methods for online functions of GX 
Works2. Manuals for reference are listed in the following table according to their purpose.
For information such as the content and number of each manual, refer to the list of 'Related manuals'.

1) Installation of GX Works2 and USB driver

2) Operation of GX Works2

Purpose GX Works2 Installation Instructions
GX Works2 Version 1

Operating Manual

Common

Learning the operating 
environment and installation 
method

Learning a USB driver installation 
method

DetailsDetails

DetailsDetails

Purpose

GX Works2 Beginner's 
Manual

GX Works2 Version 1
Operating Manual

Simple 
Project

Structured 
Project Common

Simple Project
Structured 

Project

Intelligent 
Function 
Module

Function 
Block

Learning all functions of GX 
Works2

Learning the project types and 
available languages in GX 
Works2

Learning the basic operations 
and operating procedures when 
creating a simple project for the 
first time

Learning the basic operations 
and operating procedures when 
creating a structured project for 
the first time

Learning the operations of 
available functions regardless of 
project type.

Learning the functions and 
operation methods for 
programming

Learning the operations and 
operating procedures when 
creating function blocks (FB) in 
Simple project.

Learning data setting methods for 
intelligent function module

Outline

Outline

DetailsDetails

DetailsDetails

DetailsDetails

Outline
DetailsDetails DetailsDetails

DetailsDetails

DetailsDetails
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3) Operations in each programming language
For details of instructions used in each programming language, refer to the section 4 and the 
section 5 on the following pages.

Purpose
GX Works2 Beginner's Manual GX Works2 Version 1

Operating Manual

Simple Project Structured Project Simple Project Structured Project

Simple 
Project

Ladder Diagram

Sequential 
Function Chart

Structured Text

Structured 
Project

Ladder Diagram

Sequential 
Function Chart

Structured Ladder/
FBD

Structured Text

*1 : MELSAP3 and FX series SFC only

Outline
DetailsDetails

Outline

*1
DetailsDetails

Outline
DetailsDetails

Outline
DetailsDetails

Outline

*1
DetailsDetails

Outline
DetailsDetails

Outline
DetailsDetails
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4) Details of instructions in each programming language (for QCPU (Q mode)/LCPU)

Purpose

MELSEC-Q/L/F 
Structured 

Programming 
Manual

MELSEC-Q/L Structured Programming 
Manual

MELSEC-Q/L 
Programming 

Manual

MELSEC-Q/L/QnA 
Programming 

Manual

Manual 
for 

module to 
be used

Fundamentals Common 
Instructions

Special 
Instructions

Application 
Functions

Common 
Instruction

PID Control 
Instructions SFC –

All 
languages

Learning details 
of programmable 
controller CPU 
error codes, 
special relays, 
and special 
registers

Using 
Ladder 
Diagram

Learning the 
types and details 
of common 
instructions

Learning the 
types and details 
of instructions for 
intelligent 
function modules

Learning the 
types and details 
of instructions for 
network modules

Learning the 
types and details 
of instructions for 
the PID control 
function

Using 
Sequential 
Function 
Chart

Learning details 
of specifications, 
functions, and 
instructions of 
SFC (MELSAP3)

Using 
Structured 
Ladder/
FBD or 
Structured 
Text

Learning the 
fundamentals for 
creating a 
structured 
program

Learning the 
types and details 
of common 
instructions

Learning the 
types and details 
of instructions for 
intelligent 
function modules

Learning the 
types and details 
of instructions for 
network modules

Learning the 
types and details 
of instructions for 
the PID control 
function

Learning the 
types and details 
of application 
functions

DetailsDetails

DetailsDetails

DetailsDetails

DetailsDetails

DetailsDetails

DetailsDetails

DetailsDetails

DetailsDetails

Outline
DetailsDetails

Outline
DetailsDetails

Outline
DetailsDetails

DetailsDetails
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5) Details of instructions in each programming language (for FXCPU)

Purpose

MELSEC-Q/L/F 
Structured 

Programming 
Manual

FXCPU Structured Programming Manual FXCPU Programming Manual

Fundamentals Device & 
Common

Basic & 
Applied 

Instruction

Application 
Functions

FX0, FX0S,
FX0N, FX1,
FXU, FX2C

FX1S, FX1N,
FX2N, FX1NC,

FX2NC

FX3G, FX3U,
FX3GC, FX3UC

Using 
Ladder 
Diagram

Learning the types 
and details of basic/
application 
instructions, 
descriptions of 
devices and 
parameters

Using 
Sequential 
Function 
Chart

Learning details of 
specifications, 
functions, and 
instructions of SFC

Using 
Structured 
Ladder/
FBD or 
Structured 
Text

Learning the 
fundamentals for 
creating a 
structured program

Learning the 
descriptions of 
devices, 
parameters, and 
error codes

Learning the types 
and details of 
sequence 
instructions

Learning the types 
and details of 
application 
instructions

DetailsDetails DetailsDetails DetailsDetails

DetailsDetails DetailsDetails DetailsDetails

DetailsDetails

DetailsDetails

DetailsDetails

DetailsDetails
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● How to read this manual

Supported CPU

Supported programmable 

controller CPUs are shown in 

icons under the section title.

Screen display

Describes the screen display 

procedure.

Follow the      and select 

[(menu)] to open the screen.

*Screen display may differ 

depending on the CPU type.

In that case, typical example is 

described.

Display contents

Describes the display contents 

on the screen.

Operating procedure

Describes the operating 

procedure of the function.

Section title

Clarifies the section of currently 

open page.

Chapter heading

Index on the right of the page 

number clarifies the chapter of 

currently open page.

Reference location

leads to the reference 

location and reference manual.

Screen button

Describes the buttons in the 

screen.

6.1 Setting PLC Parameter
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The following table explains the CPU module icons that indicate the function availability.

This manual also uses the following columns:

This indicates notes requiring attention or useful functions relating to the information given on the 
same page.

Restrictions

This indicates restrictions relating to the information given on the same page.

● Symbols used in this manual
The following shows the symbols used in this manual with descriptions and examples.

Icon
DescriptionQCPU

(Q mode) LCPU Remote I/O Communication 
head module FXCPU

Normal icons indicate that the corresponding 
function is available.

–
Icons with * (asterisk) symbol indicate that the 
corresponding function is available with 
restrictions such as CPU types.

Icons with × symbol indicate that the 
corresponding function is not available.

Q CPU L CPU Remote Head FX

Q CPU

*1

L CPU

*1

Head

*1

FX

*1

Q CPU L CPU Remote Head FX

No. Symbol Description Example

 [      ] Menu name on a menu bar [Project]

 Toolbar icon

 (Underline) Screen name Q Parameter Setting screen

 Tab name in a screen <<PLC System>>

 "      " Item name in a screen "Timer Limit Setting"

 Button on a screen  button

–  Keyboard key 

1

2

4

5

6

3
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■ GENERIC TERMS AND ABBREVIATIONS IN THIS MANUAL

The following are the generic terms/abbreviations of such as software packages and programmable 
controller CPUs used in this manual.

Generic term and 
abbreviation Description

GX Works2 Generic product name for SWnDNC-GXW2-E (n: version)

Existing application –

GX Developer
Generic product name for SWnD5C-GPPW-E, SWnD5C-GPPW-EA, SWnD5C-GPPW-EV, and 
SWnD5C-GPPW-EVA
(n: version)

GX IEC Developer Product name for SWnD5C-MEDOC3
(n: version)

GX Simulator
Generic product name for SWnD5C-LLT-E, SWnD5C-LLT-EA, SWnD5C-LLT-EV, and 
SWnD5C-LLT-EVA
(n: version)

GX Configurator Generic product name for GX Configurator-AD/DA/SC/CT/TC/TI/FL/PT/AS/QP

MELSOFT Navigator
Product name for the integrated development environment included in SWnDNC-IQWK (iQ Platform 
compatible engineering environment MELSOFT iQ Works)
(n: version)

iQ Works Abbreviation for iQ platform supporting engineering environment MELSOFT iQ Works

GX Simulator2 Abbreviation for GX Works2 simulation function

Personal computer Generic term for personal computer on which Windows® operates

Q series Abbreviation for Mitsubishi programmable controller MELSEC-Q series

L series Abbreviation for Mitsubishi programmable controller MELSEC-L series

FX series Abbreviation for Mitsubishi programmable controller MELSEC-F series

Basic model QCPU Generic term for Q00J, Q00, and Q01

High Performance 
model QCPU Generic term for Q02, Q02H, Q06H, Q12H, and Q25H

Process CPU Generic term for Q02PH, Q06PH, Q12PH, and Q25PH

Redundant CPU Generic term for Q12PRH and Q25PRH

Universal model QCPU
Generic term for Q00UJ, Q00U, Q01U, Q02U, Q03UD, Q03UDE, Q03UDV, Q04UDH, Q04UDEH, 
Q04UDV, Q06UDH, Q06UDEH, Q06UDV, Q10UDH, Q10UDEH, Q13UDH, Q13UDEH, Q13UDV, 
Q20UDH, Q20UDEH, Q26UDH, Q26UDEH, Q26UDV, Q50UDEH, and Q100UDEH

QnUD(H)CPU Generic term for Q03UD, Q04UDH, Q06UDH, Q10UDH, Q13UDH, Q20UDH, and Q26UDH

QnUDE(H)CPU Generic term for Q03UDE, Q04UDEH, Q06UDEH, Q10UDEH, Q13UDEH, Q20UDEH, Q26UDEH, 
Q50UDEH, and Q100UDEH

High-speed Universal 
model QCPU Generic term for Q03UDV, Q04UDV, Q06UDV, Q13UDV, and Q26UDV

Built-in Ethernet port 
QCPU Generic term for QnUDE(H)CPU and Universal model high-speed type QCPU

QCPU (Q mode) Generic term for Basic model QCPU, High Performance model QCPU, Process CPU, Redundant 
CPU, and Universal model QCPU

LCPU Generic term for L02S, L02, L02-P, L06, L26, L26-BT, and L26-PBT

FXCPU Generic term for FX0, FX0S, FX0N, FX1, FXU, FX2C, FX1S, FX1N, FX1NC, FX2N, FX2NC, FX3G, FX3GC, 
FX3U, and FX3UC

CPU module Generic term for QCPU (Q mode), LCPU, and FXCPU

Built-in Ethernet type 
CPU Generic term for Built-in Ethernet port QCPU and LCPU

Display module A module with LCD to be mounted to LCPU

Base unit/Block
Generic term for the following:
• base unit
• a composition of modules from the power supply module to the END cover in MELSEC-L series

FXGP(WIN) Abbreviation for SW0PC-FXGP/WIN-E
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C24 Generic term for QJ71C24, QJ71C24-R2, QJ71C24N, QJ71C24N-R2, QJ71C24N-R4, LJ71C24, 
and LJ71C24-R2

ACPU Generic term for A2A, A2A-S1, A3A, A2AP21/R21, A2AP21/R21-S1, A3AP21/R21, A2U, A2U-S1, 
A3U, A4U, A2US, A2US-S1, A2USH-S1, Q02(H)-A, and Q06H-A

QnACPU Generic term for Q2AS, Q2AS-S1, Q2ASH, Q2ASH-S1, Q2A, Q3A, and Q4A

Q series C24 Generic term for QJ71C24, QJ71C24-R2, QJ71C24N, QJ71C24N-R2, and QJ71C24N-R4

CC-Link IE Controller 
Network module Generic term for QJ71GP21-SX and QJ71GP21S-SX

CC-Link IE Field 
Network master/local 
module

Generic term for QJ71GF11-T2, LJ71GF11-T2

CC IE Field head 
module Generic term for LJ72GF15-T2

SSCNET III/H head 
module Generic term for LJ72MS15

Communication head 
module Generic term for CC IE Field head module and SSCNET III/H head module

CC-Link IE Generic term for CC-Link IE Controller Network and CC-Link IE Field Network

MELSECNET/H network 
module

Generic term for QJ71LP21, QJ71LP21-25, QJ71LP21S-25, QJ71LP21G, QJ71BR11, 
QJ72LP25-25, QJ72LP25G, QJ72BR15, and QJ71NT11B

QJ72LP25 Generic term for QJ72LP25-25 and QJ72LP25G

Remote I/O module Generic term for QJ72LP25 and QJ72BR15

Ethernet adapter module Generic term for NZ2GF-ETB

Ethernet adapter Generic term for FX3U-ENET-ADP

Q series-compatible E71 Generic term for QJ71E71-100, QJ71E71-B5, QJ71E71-B2, and QJ71E71

QE71
Generic term for AJ71QE71, AJ71QE71-B5, A1SJ71QE71-B2, A1SJ71QE71-B5, AJ71QE71N-T, 
A1SJ71QE71N-T, AJ71QE71N-B5, A1SJ71QE71N-B5, AJ71QE71N-B2, A1SJ71QE71N-B2, 
AJ71QE71N-B5T, A1SJ71QE71N-B5T, AJ71QE71N3-T, and A1SJ71QE71N3-T

A series-compatible E71
Generic term for AJ71E71-S3, A1SJ71E71-B2-S3, A1SJ71E71-B5-S3, AJ71E71N-B2,
AJ71E71N-B5T, A1SJ71E71N-B2, A1SJ71E71N-B5T, AJ71E71N-T, A1SJ71E71N-T,
AJ71E71N-B5, A1SJ71E71N-B5, AJ71E71N3-T, and A1SJ71E71N3-T

L series-compatible E71 Generic term for LJ71E71-100

Ethernet module Generic term for Q series-compatible E71, QE71, A series-compatible E71, and L series-compatible 
E71

CC-Link master/local 
module Generic term for QJ61BT11, QJ61BT11N, and LJ61BT11

Q series CC-Link Generic term for QJ61BT11 and QJ61BT11N

CC-Link bridge module Abbreviation for AJ65SBT-CLB CC-Link - CC-Link/LT bridge module

CC-Link IE Field 
Network bridge module Generic term for NZ2GF-CCB

CC-Link IE Field 
Network high-speed 
counter module

Generic term for NZ2GFCF-D62PD2

Simple motion module Generic term for QD77MS2, QD77MS4, QD77MS16, QD77GF16, LD77MH4, and LD77MH16

G4 module Generic term for AJ65BT-G4(-S3) peripheral connection module and AJ65BT-R2N CC-Link system 
RS-232 interface module

QA extension base unit Generic term for QA1S65B, QA1S68B, QA65, and QA68B

CC-Link IE Field 
Network communication 
unit

Generic term for GT15-J71GF13-T2

MELSECNET/H board Generic term for Q80BD-J71BR11, Q80BD-J71LP21-25, and Q80BD-J71LP21G

CC-Link IE Controller 
Network board

Generic term for Q80BD-J71GP21-SX and Q80BD-J71GP21S-SX
Abbreviation for CC-Link IE Controller Network interface board

CC-Link IE Field 
Network board Abbreviation for Q81BD-J71GF11-T2 CC-Link IE Field Network interface board

Generic term and 
abbreviation Description
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Ethernet board Generic term for Ethernet cards for personal computer and Ethernet interface boards

CC-Link board Generic term for CC-Link Ver.1 board and CC-Link Ver.2 board

CC-Link Ver.1 board Generic term for A80BD-J61BT11 and A80BD-J61BT13

CC-Link Ver.2 board Generic term for Q80BD-J61BT11N

GOT Generic term for Mitsubishi Graphic Operation Terminal GOT1000 series, GOT-A900 series, and 
GOT-F900 series

Windows® XP
Generic term for Microsoft® Windows® XP Professional Operating System
and Microsoft® Windows® XP Home Edition Operating System

Windows Vista®

Generic term for Microsoft® Windows Vista® Home Basic Operating System,
Microsoft® Windows Vista® Home Premium Operating System,
Microsoft® Windows Vista® Business Operating System,
Microsoft® Windows Vista® Ultimate Operating System,
and Microsoft® Windows Vista® Enterprise Operating System

Windows® 7

Generic term for Microsoft® Windows® 7 Starter Operating System,
Microsoft® Windows® 7 Home Premium Operating System,
Microsoft® Windows® 7 Professional Operating System,
Microsoft® Windows® 7 Ultimate Operating System,
and Microsoft® Windows® 7 Enterprise Operating System

MELSAP3 Abbreviation for the SFC function in MELSAP3 display format

MELSAP-L Generic term for the SFC function in MELSAP-L (instruction format) and MELSAP-L (start conditions 
format)

SFC Generic term for MELSAP3, MELSAP-L, and FX series SFC

MELSOFT Library

Generic term for components (FB library, sample programs, drawing data) which provide easy 
operation of programmable controller related modules and GOTs, and various devices that are 
connected to them
Contact your local Mitsubishi representative to obtain components of MELSOFT Library.

Generic term and 
abbreviation Description
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■ TERMS

The following are the terms used in this manual.

Term Description

Execution program A compiled program created in a project with labels
A program that can be executed on a programmable controller CPU

Actual device An actual device assigned to label after compiling a project with labels, or a device that is not 
described using a label

Common instruction
Generic term for sequence instructions, basic instructions, application instructions, data link 
instructions, multiple CPU dedicated instructions, and multiple CPU high-speed transmission 
dedicated instructions

Special instruction Generic term for module dedicated instructions, PID control instructions, socket communication 
function instructions, built-in I/O function instructions, and data logging function instructions

Simple project Generic term for projects created using Ladder Diagram/Sequential Function Chart/Structured Text

Without labels Generic term for projects created without selecting "Use Label" when creating new projects

With labels Generic term for projects created with selecting "Use Label" when creating new projects

Structured project Generic term for projects created using Ladder Diagram/Sequential Function Chart/Structured 
Text/Structured Ladder/FBD

Project without labels Generic term for Simple projects that do not use labels

Project with labels Generic term for Simple projects that use labels and Structured projects

Project with security Generic term for projects whose securities are set

New project creation with 
data read from 
programmable controller 
CPU

A function to create a new project with data read from a programmable controller CPU without 
opening a project

Direct connection A connection method using a USB/serial/Ethernet port of a programmable controller CPU

Slave station Stations other than the master station (local stations, remote I/O stations, remote device stations, 
intelligent device stations, etc.)

Redundant system A system configured using Redundant CPUs

Connective system A Redundant CPU selected on the Transfer Setup screen

Target system The other Redundant CPU connected to the connective system with a tracking cable

System A A system to which system A connector for tracking cable is connected in the redundant system

System B A system to which system B connector for tracking cable is connected in the redundant system

Control system A system that performs program operation, system control, and network communication in the 
redundant system

Standby system A backup system to continue system control in case of a module failure or an error in the control 
system in the redundant system

Backup mode A mode for normal operation of the redundant system

Separate mode
A mode for maintaining a system (partial modification of a program, replacement of modules 
mounted on the main base unit) without stopping the control during an operation of the redundant 
system

Debug mode A mode for performing a debug using a single system prior to a redundant system operation
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1 - 1

1 OVERVIEW
This chapter explains an overview of GX Works2.

1.1 Product Overview 1 - 2

1.2 Features 1 - 4

1.3 List of Functions 1 - 9
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GX Works2

1  OVERVIEW

1.1 Product Overview

GX Works2 is a programming tool for designing, debugging, and maintaining programs on Windows®.
GX Works2 has improved functionality and operability, with easier-to-use features compared to 
existing GX Developer.

■ Main functions of GX Works2

GX Works2 can manage programs and parameters in units of projects for each programmable 
controller CPU.
The following explains the main functions.

● Programming
Programs can be created in a Simple project in a similar way with existing GX Developer. Structured 
programming in a Structured project is also available with GX Works2.

● Setting parameters
Programmable controller parameter and network parameter can be set with GX Works2.
Intelligent function module parameter can be set as well.

● Writing/reading data to/from a programmable controller CPU
Created sequence programs can be written to/read from a programmable controller CPU using the 
Read from PLC/Write to PLC function. Also, using the Online program change function, the 
sequence programs can be changed even when the programmable controller CPU is in RUN.

Writing data

Reading data 
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● Monitoring/debugging
Created sequence programs can be written to the programmable controller CPU and device value at 
operation can be monitored online/offline.

● Diagnostics
The current error status and error history of the programmable controller CPU can be diagnosed. 
Using the diagnostics function, the recovery work is completed in a short time.
Using the System monitor function (for QCPU (Q mode)/LCPU), detailed information on such as 
intelligent function modules can be obtained. This helps to shorten the recovery work time at error 
occurrence.

Programs can be monitored and debugged.

 

Diagnosing the programmable controller 

CPU status (PLC diagnostics screen)

Diagnosing the 

programmable controller 

CPU status
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1  OVERVIEW

1.2 Features

This section explains the features of GX Works2.

■ Project types in GX Works2

In GX Works2, the project type can be selected from either of Simple project or Structured project.

● Simple project
The Simple project creates sequence programs using instructions for Mitsubishi programmable 
controller CPU.
Programs in a Simple project can be created in a similar way to existing GX Developer.
Programming without labels and label programming are supported as in GX Developer.

● Structured project
In a Structured project, programs can be created by structured programming.
By segmenting a whole control process program into common program parts, highly manageable 
and usable programming (structured programming) is possible.
Only label programming is supported.

Program file

Programs are created using programmable controller 

CPU instructions. 

Created programs can be operated as sequence 

programs.

Programming in a similar way with existing 

GX Developer is possible.

Program MAIN

Program SUB1

Program SUB2

 
Program MAINProgram block A

Program block B

Program block C

Program block D

Program block E

Function block 1

Function block 2

Function 1

Function 2

Program SUB1

Program filePOU

Sequence programs are created 

by combining POUs (Program 

Organization Units).
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■ Programming using labels

Using the label programming, programs can be created without regard for the device numbers.
By compiling a program created with the label programming, devices are automatically assigned and 
the program becomes available as an actual program.

Created global labels can be utilized for other programs.

In addition, global labels can be registered as system labels and be shared within iQ Works compliant 
products (GX Works2, MT Developer2, and GT Designer3).
For details of system labels, refer to the following manual.
(iQ Works Beginner's Manual)

Created labels can be

utilized for other programs.
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■ Enhanced use of program assets

Projects created with existing GX Developer can be utilized in a Simple project. Utilizing the past assets 
improves the efficiency of program design.

■ Sharing Program Organization Unit (POU) registered as libraries

In a Structured project, programs, global labels, and structures frequently used can be registered as 
user libraries. Utilizing these user libraries reduces time required for creating programs.

 
Project created 

with GX Developer

<GX Developer> <GX Works2>

Can be used in 

GX Works2.

 

Library file

Project A

Project B

Project C

Project D
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■ Wide variety of programming languages

The wide variety of programming languages available with GX Works2 enables to select the optimum 
programming language according to control.

ST programs can be used on the ladder editor of GX Works2 using the Inline structured text function.

<Sequential Function Chart>

Programming to clarify the procedure

<Ladder Diagram>

Programming similar to existing GX Developer

<Structured Ladder>

Programming a ladder diagram graphically
<Structured Text>

Programming in a text language similar to  

C language 



1 - 8

GX Works2

1  OVERVIEW

■ Other features

● Offline debugging
Offline debugging using the simulation function is possible with GX Works2. This enables debugging 
to ensure the normal operation of created sequence programs without connecting GX Works2 to the 
programmable controller CPU.

● The screen layout can be customized to the user's preference
Use dockable windows to change the screen layout of GX Works2.

Simulation function

Without connecting to the programmable controller CPU, programs can 

be monitored and debugged in the same way with debugging by the 

programmable controller CPU.

Connecting to the 

programmable 

controller is unnecessary.

Screen layout can be 

changed.
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1.3 List of Functions

This section shows the list of functions of GX Works2.
The functions are divided into common functions available (Project, Online, Debug, Diagnostics, Tool, 
Window, and Help) and functions used for each editing or setting target (Edit, Find/Replace, Compile, 
and View).
For (Simple), (FB), (Structured), and (Intelligent) indicated in the Reference column, refer to the 
following manuals respectively:

1.3.1 List of functions common to Simple project and Structured 
project

This section explains the functions common to Simple project and Structured project.

■ List of common functions

The following tables show functions that are available regardless of the type of editing or setting target.

(Simple) … GX Works2 Version 1 Operating Manual (Simple Project)
(FB) … GX Works2 Version 1 Operating Manual (Simple Project, Function Block)
(Structured) … GX Works2 Version 1 Operating Manual (Structured Project)
(Intelligent) … GX Works2 Version 1 Operating Manual (Intelligent Function Module)

Project (common function) Reference

New Create a new project. Section 4.2.1

Open Open an existing project. Section 4.2.2

Close Close the open project. Section 4.2.6

Save Save the project.
Section 4.2.3

Save As Name and save the project.

Compress/Unpack –

Compress Compress and save a project.
Section 4.2.4

Unpack Decompress a compressed project.

Delete Delete an existing project. Section 4.2.5

Verify Verify between two project data. Section 4.2.7

Project Revision –

Revision Entry Register the project change history. Section 4.6.1

Revision List Display the list of project change history. Section 4.6.2

Change PLC Type Change the programmable controller CPU type. Section 4.2.8

Change Project Type
Change the project type from Simple project (without labels) to 
Simple project (with labels), or from Simple project (with labels) 
to Structured project.

Section 4.5
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1.3.1  List of functions common to Simple project and Structured project

Object –

New Add data to the project. Section 4.3.1

Rename Rename the selected data. Section 4.3.3

Delete Delete the selected data. Section 4.3.4

Copy Copy the selected data.
Section 4.3.2

Paste Paste the copied data.

Set as Default Connection Specify data in selected connection destination as a connection 
destination for regular use. Section 11.1.3

Property Display the selected data properties. Section 4.3.6

Intelligent Function Module –

New Module Add new intelligent function module data.

(Intelligent)

Delete Module Delete intelligent function module data.

Property Display properties of the intelligent function module data.

Save the Positioning Module Data Save data of the positioning module selected on the Project 
view to a file.

Read from the Positioning Module Data Read data from the positioning module and apply it to the 
positioning module selected on the Project view.

Save GX Configurator-QP Data Save the positioning module data in GX Configurator-QP 
format.

Import GX Configurator-QP Data Read a project created with GX Configurator-QP.

Intelligent Function Module Parameter 
List

Display a list of set/unset parameters of the intelligent function 
module.

Open Other Data –

Open Other Project Open a project created with GX Developer. Section 4.7.1

Read ASC Format File Read an ASC format file. Section 4.7.2

Export to GX Developer Format File Save the open project in GX Developer format. Section 4.8

Library –

Create Create a new library. (Structured)

Install
For Simple projects (with labels), import an FB library to the 
project.
For Structured projects, import a created library to the project.

(FB)
(Structured)

Deinstall Delete the library from the project.

(Structured)

Reload Update the library imported to the project.

Rename Rename the library.

Open Enable editing of the library.

Close Disable editing of the library.

Change Password Set a password for the library.

Save As Name and save the project.

Save Save the library file.

Help Display help information of the library.

Security –

Change Password Change the password of the current login user. Section 4.10.2

User Management Manage user information of the project.
Add/delete a user, or change the user information.

Section 4.10.1
Section 4.10.2

Data Security Setting Set the access authorization of each user related to reading/
writing data. Section 4.10.4

Soft Security Key Management Manage the security key which is used to lock or unlock the 
project. Section 4.11

Print Batch print multiple data in the project. Section 20.3

Print Preview Display the print preview of data to be batch printed. Section 20.6

Print Window Print the open screen. Section 20.7

Print Window Preview Display the print preview of the open screen. Section 20.9

Project (common function) Reference
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Printer Setup Change the printer settings. Section 20.2

(Recently used files 1 to 4) Display the recently used GX Works2 project paths, and open 
the selected project. –

Start GX Developer Start GX Developer from GX Works2. Section 4.9

Exit Exit GX Works2. Section 3.1

Project (common function) Reference

Edit (common function) Reference

Undo Restore the previous processing status.

–

Redo Restore the processing deleted with [Undo].

Cut Cut the selected data.

Copy Copy the selected data.

Paste Paste the cut or copied data at the cursor position.

Find/Replace (common function) Reference

Cross Reference Display the usage of selected device or label. Section 10.1

Device List Display the usage of devices. Section 10.2

Find Device Search a device/label in the program. Section 10.3.1

Find Instruction Search an instruction.
Section 10.3.2

Find Contact or Coil Search a contact or coil corresponding to the specified device.

Find String Search a string. Section 10.3.3

Replace Device Replace a device/label in the program. Section 10.3.1

Replace Instruction Replace an instruction. Section 10.3.2

Replace String Replace a string. Section 10.3.3

Change Open/Close Contact Change an open contact to a closed contact, or change a 
closed contact to an open contact. Section 10.3.4

Device Batch Replace Batch-replace devices with the specified device.
Section 10.3.5

Register to Device Batch Replace Register selected devices on the Device Batch Replace screen.

Compile (common function) Reference

Build Convert/compile a program being edited.

Section 5.4Online Program Change Write sequence programs to a programmable controller CPU 
after the conversion/compilation.

Rebuild All Convert/compile all programs in the project.



1 - 12

GX Works2

1  OVERVIEW

1.3.1  List of functions common to Simple project and Structured project

View (common function) Reference

Toolbar –

Toolbar name Display/hide each toolbar.
Section 3.2.2

Display All Display/hide all toolbars.

Statusbar Display/hide the status bar. Section 3.2.6

Color and Font Set the display color for characters such as labels and device 
comments on the work window. Section 3.2.7

Docking Window –

Navigation Display/hide the Navigation window. Section 3.2.5

Element Selection
Display/hide the Function Block Selection window.
Select a part such as function block and function on the window 
for utilizing it to a program.

(FB)
(Structured)

Output Display/hide the Output window.
The conversion (compilation) result is displayed.

(Simple)
(Structured)

Cross Reference Display/hide the Cross Reference window.
The devices/labels used in the project are displayed. Section 10.1

Device Use List Display/hide the Device List window.
The usage of selected device is displayed. Section 10.2

CC-Link Device Reference Window
Display/hide the CC-Link Device Reference window. 
Assignments of CC-Link refresh devices and link devices are 
displayed.

Section 6.3.5

Watch 1 to 4 Display/hide the Watch window.
The monitoring result is displayed. Section 14.6

Intelligent Function Module Monitor –

Module 1 to 10 Display/hide the Intelligent Function Module Monitor window.
(Intelligent)

Intelligent Function Module Guidance Display/hide the Intelligent Function Module Guidance window.

Find/Replace Display/hide the Find/Replace window.
The search/replace result is displayed. Section 10.3

Debug –

Break Point Display/hide the Break Point window. Section 16.6.2

Break Device Display/hide the Break Device window. Section 16.6.3

Skip Range Display/hide the Skip Range window. Section 16.6.4
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Online (common function) Reference

Read from PLC Read data from the programmable controller CPU.
Section 12.1

Write to PLC Write data to the programmable controller CPU.

Verify with PLC Verify a project being edited against the data on the 
programmable controller CPU. Section 12.2

Remote Operation Remotely control RUN/PAUSE/STOP of the programmable 
controller CPU from GX Works2. Section 17.1

Redundant Operation Remotely control the system switch, operation mode change, or 
memory copy on the Redundant CPU from GX Works2. Section 17.2

Password/Keyword –

New Set a password/keyword to the programmable controller CPU.
Section 13.2.1
Section 13.3.1
Section 13.4.1

Delete Cancel the password/keyword set to the programmable 
controller CPU.

Section 13.2.2
Section 13.3.2
Section 13.4.2

Disable Temporarily unlock the password/keyword set to the 
programmable controller CPU.

Section 13.2.3
Section 13.3.3
Section 13.4.3

Soft Security Key Management Manage the security key which is used to lock or unlock the 
programmable controller CPU. Section 13.5

PLC Memory Operation –

Format PLC Memory Format the programmable controller CPU memory. Section 17.3

Clear PLC Memory Clear the programmable controller CPU memory. Section 17.4

Arrange PLC Memory Arrange the programmable controller CPU memory. Section 17.5

Delete PLC Data Delete data on the programmable controller CPU. Section 12.3

PLC User Data –

Read Read the programmable controller CPU user data.

Section 12.5Write Write the programmable controller CPU user data.

Delete Delete the programmable controller CPU user data.

Export to ROM Format Copy the program memory data on the programmable 
controller CPU to ROM. Section 12.4

Program Memory Batch Download Transfer the content of program cache memory to program 
memory in batch. Section 12.6

Latch Data Backup –

Backup Back up device memory/file register/error history data to the 
standard ROM. Section 12.7.1

Delete Backup Data Delete the backup data on the programmable controller CPU. Section 12.7.2

PLC Module Change –

Create Backup Data Back up data on the programmable controller CPU to the 
memory card. Section 12.8.1

Restore Restore the backup data to another programmable controller 
CPU. Section 12.8.2

Set Clock Set the clock on the programmable controller CPU. Section 17.6

Register/Cancel Display Module Menu Register/cancel menus to operate intelligent function module 
using the LCPU display module menu. Section 17.7
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Monitor –

Monitor Mode Switch the mode of the open window to "Monitor Mode" during 
monitoring.

(Simple)
Monitor (Write Mode) Switch the mode of the open window to "Monitor (Write Mode)" 

during monitoring.

Start Monitoring (All Windows) Start monitoring the programs of all open windows.
Section 14.8

Stop Monitoring (All Windows) Stop monitoring the programs of all open windows.

Start Monitoring Start monitoring the program of the open window. Section 14.2

Stop Monitoring Stop monitoring the program of the open window. Section 14.1

Change Value Format (Decimal) Display the current device value in decimal in program 
monitoring. (Simple)

(Structured)
Change Value Format (Hexadecimal) Display the current device value in hexadecimal in program 

monitoring.

Device/Buffer Memory Batch Monitor device/buffer memory in batch. Section 14.3

Program List Monitor the processing time of programs being executed. Section 14.4

Interrupt Program List Monitor the number of executions of interrupt programs. Section 14.5

Change Instance (Function Block) Select an instance of the function block to be monitored. (FB)
(Structured)

SFC All Block Batch Monitoring Batch monitor all blocks in the SFC program.
(Simple)

SFC Auto Scroll Scroll the screen to display active steps automatically when 
they are out of the screen during monitoring.

Watch –

Start Watching Start monitoring the current values of registered devices/labels 
and intelligent function module.

Section 14.6

Stop Watching Stop monitoring the current values of registered devices/labels 
and intelligent function module.

Bit Device Display Format

Numerical Display Switch the display format of the current value of bit device to 
the numerical display (1/0).

ON/OFF Display Switch the display format of the current value of bit device to 
the 'ON/OFF' display.

Symbol Display Switch the display format of the current value of bit device to 
the symbol display (/).

Register to Watch Register the selected devices/labels to the Watch window.

Local Device Batch Read + Save CSV Read local device data from the programmable controller CPU 
and saves them on a personal computer in CSV format. Section 12.12

Online (common function) Reference

Debug (common function) Reference

Start/Stop Simulation Start/stop simulation. Section 15.2

Instructions Unsupported by Simulation Display a list of the instructions and devices used in the 
program that is not supported by the simulation function. Section 15.3

Modify Value For ladder and SFC (Zoom) programs, change the ON/OFF 
status and values of devices and labels used in the program. Section 16.1

Forced Input Output Registration/
Cancellation Register/cancel the forced input/output of the device 'X'/'Y'. Section 16.2

Device Test with Execution Condition –

Register Register the device test with execution condition. Section 16.3.1

Registration Check/Disable Check/disable the registration of device test with execution 
condition. Section 16.3.2

Batch Disable Batch disable the device test with execution condition in batch. Section 16.3.3

Sampling Trace –

Open Sampling Trace Display the Sampling Trace screen. Section 16.4.1

Scan Time Measurement Measure the scan time of a desired section. Section 16.5
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Step Execution –

Stop Stop the step execution. Section 16.6.9

Cancel Cancel the step execution. Section 16.6.7

Break Execution Execute the break execution. Section 16.6.6

Step Execution Execute the step execution. Section 16.6.5

Execution Option Display the "Execution Option" screen of the step execution. Section 16.6.8

Break Setting –

Set/Cancel Break Point Set a break point at the cursor position, or cancel the set break 
point.

Section 16.6.2Enable/Disable Break Point Enable/disable the break point at the cursor position.

Cancel All Break Points Cancel all break points.

Break Point Window Display the Break Point window.

Cancel All Break Devices Cancel all break devices.
Section 16.6.3

Break Device Window Display the Break Device window.

Skip Setting –

Set/Cancel Skip Range Set a skip range, or cancel the set skip range.

Section 16.6.4
Enable/Disable Skip Range Enable/disable the skip range at the cursor position.

Cancel All Skip Ranges Cancel all skip ranges.

Skip Range Window Display the Skip Range window.

Debug (common function) Reference

Diagnostics (common function) Reference

PLC Diagnostics Diagnose the operating status of the programmable controller 
CPU. Section 18.1

Ethernet Diagnostics Diagnose Ethernet. Section 18.6

CC IE Control Diagnostics Diagnose CC-Link IE Controller Network. Section 18.3

CC IE Field Diagnostics Diagnose CC-Link IE Field Network. Section 18.4

MELSECNET Diagnostics Diagnose MELSECNET/10(H). Section 18.2

CC-Link Diagnostics Diagnose CC-Link and CC-Link/LT. Section 18.5

Sensor/Device Monitor Monitor the status of the equipment connected with 
AnyWireASLINK or CC-Link. Section 18.7

System Monitor Monitor the system status of the programmable controller CPU. Section 18.8

Online Module Change Change modules online. Section 18.9

Tool (common function) Reference

IC Memory Card –

Read IC Memory Card Read data from the IC memory card.
Section 12.11.1

Write IC Memory Card Write data to the IC memory card.

Read from IC Memory Card
(Edit and Data Copy)

Read data saved by the batch save function of programmable 
controller CPU from the IC memory card.

Section 12.11.2
Write to IC Memory Card
(Edit and Data Copy)

Write data to the IC memory card in the format which can be 
used for the batch load function of programmable controller 
CPU.

Check Program Check programs of the project without labels and display 
errors. (Simple)

Check Parameter Check parameters and display errors. Section 6.5

Clear All Parameters Delete all selected parameters. Section 6.7

Check Device Duplication of Global Label Check duplications of devices assigned to global labels, and 
display the result.

(Simple)
(Structured)

Device/Label Automatic-Assign Setting Set device range to be automatically assigned to a label. (Simple)
(Structured)

Block Password Set a block password to data. Section 4.12
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Confirm Memory Size Calculate the size of files to be written to the programmable 
controller CPU. Section 12.10

Merge Data Merge ladder programs or device comment data. Section 4.3.5

Set TEL Data/Connect via Modem –

Line Connection Connect the line.
Section 11.10.2

Line Disconnection Disconnect the line.

AT Command Registration
Register a modem between a personal computer and a serial 
communication module, or a personal computer and an 
FXCPU. Section 11.10.1

Phone Book Set phone numbers of targets such as remote access targets.

Options Set options for TEL data. Section 11.10.3

Logging Configuration Tool Start QnUDVCPU & LCPU Logging Configuration Tool. Section 16.7

Ethernet Adapter Module Configuration Tool Start the Ethernet adapter module configuration tool. Section 17.8

Built-in I/O Module Tool –

Positioning Monitor Display the Positioning Monitor screen.

Section 18.10High-Speed Counter Monitor Display the High-Speed Counter Monitor screen.

I/O Monitor Display the I/O Monitor screen.

Check Intelligent Function Module Parameter –

Check Auto Refresh Duplication Check duplications of devices set in the Auto refresh function 
and display the result. (Intelligent)

Intelligent Function Module Tool –

Analog Module –

(Intelligent)

Offset/Gain Setting Configure the offset/gain setting of the analog module.

Q61LD Two-Point Calibration 
Setting Configure the Q61LD two-point calibration setting.

Q61LD Default Setting Configure the Q61LD default setting.

Create Wave Output Data Create waveform output data.

Temperature Input Module –

Offset/Gain Setting Configure the offset/gain setting of the temperature input 
module.

Temperature Control Module –

Auto Tuning Execute the auto tuning function of the temperature control 
module.

Sensor Correction Function Execute the sensor correction function of the temperature 
control module.

Counter Module –

Preset Execute the preset function of the counter module.

QD75/LD75 Positioning Module –

Positioning Monitor Execute the positioning monitor.

Positioning Test Execute the positioning test.

Wave Trace Execute the wave trace.

Location Trace Execute the location trace.

Serial Communication Module – –

Circuit Trace Execute the circuit trace.
(Intelligent)Predefined Protocol Support 

Function Start the predefined protocol support function.

Language Selection Select a language used in the project. Section 3.3

Register Profile Register profiles of CC IE Field modules and CC-Link modules 
to GX Works2. Section 6.3.4

Key Customize Change the settings of the shortcut keys. Section 3.2.8

Options Set various options. Chapter 21

Tool (common function) Reference
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Window (common function) Reference

Cascade Cascade windows.

Section 3.2.3

Tile Vertically Tile windows vertically.

Tile Horizontally Tile windows horizontally.

Arrange Icons Arrange the icons at the bottom of the window.

Close All Close all open windows.

(Switch to other window) Display the open window.

Other Windows Display the list of open windows.
Also, open or arrange specified windows.

Help (common function) Reference

GX Works2 Help Display the GX Works2 Help screen. Section 3.4.1

Operating Manual –

GX Works2 Beginner's Manual
(Simple Project)

Display the operating manuals. Section 3.4.2

GX Works2 Beginner's Manual
(Structured Project)

Operating Manual Common

Operating Manual (Simple Project)

Operating Manual (Structured Project)

Operating Manual (Intelligent Function 
Module)

Operating Manual (Simple Project, 
Function Block)

About Display product information such as the version. Section 3.4.3
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■ List of functions for setting labels

The following table shows the functions for setting and editing labels.

Edit (function for label setting) Reference

Delete Delete the selected data. –

Select All Select all items.

(Simple)
(Structured)

New Declaration (Before) Add a row above the cursor position.

New Declaration (After) Add a row below the cursor position.

Delete Row Delete the row at the cursor position.

Read from CSV File Read label settings from the CSV file.

Write to CSV File Write label settings to the CSV file.

System Label –

Reservation to Register System Label Reserve the selected global label for registration as a system 
label.

(Simple)
(Structured)

Reservation to Release System Label Reserve the selected global label for deregistration of system 
label.

Import System Label Import the system label information and apply it to global labels.

Reflect to System Label Database Apply the registration-reserved/deregistration-reserved global 
labels to the system label data base.

Confirm Update of System Label 
Database

Apply system label information changed in another project to 
global labels.

–
Execute Verification Synchronous with 
System Label Resolve a mismatch when system label information contains it.

Sort –

Class

Sort the labels in ascending/descending order with the selected 
item.

(Simple)
(Structured)

Label Name

Data Type

Constant

Device

Address

Comment

Remark

Unused label list Extract and display unused labels.
Extracted unused labels can be deleted in batch.

(Simple)
(Structured)
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■ List of functions for editing device comments

The following table shows functions for editing device comments.

Edit (function for editing device comments) Reference

Delete Delete the selected data. –

Select All Select all data being displayed. –

Import from Sample Comment –

Special Relay/Special Register Utilize sample comments of SM/SD. Section 9.5.1

Intelligent Function Module Utilize sample comments of intelligent function module device. Section 9.5.2

Clear All (All Devices) Delete all device comment data. Section 9.3.1

Clear All (All Displayed Devices) Delete all device comment data being displayed. Section 9.3.2

Read from CSV File Read device comments from the CSV file.
Section 9.6

Write to CSV File Write device comments to the CSV file.

Hide Bit Specification Information Hide the bit-specified word device comment of the selected 
row.

Section 9.2.1

Show Bit Specification Information Display the bit-specified word device comment of the selected 
row.

Cut The Range including Hidden Bit 
Specification Information Cut data including hidden bit-specified comment.

Copy The Range including Hidden Bit 
Specification Information Copy data including hidden bit-specified comment.

Paste The Range including Hidden Bit 
Specification Information Paste data including hidden bit-specified comment.
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■ List of functions for setting device memory

The following tables show the functions for setting device memory.

■ List of functions for verification result

The following tables show the functions for verification result.

Edit (function for setting device memory) Reference

Delete Delete the selected data. –

Insert Row Insert a row at the cursor position. Section 7.2

Input Device Enter a device. Section 7.2.2

Paste Text Enter a character string. Section 7.2.3

FILL Set the same value to consecutive devices simultaneously. Section 7.2.4

Find/Replace (function for setting device memory) Reference

Find Device Cell Search for a device. Section 7.3

View (function for setting device memory) Reference

Display Mode –

Binary Display data in binary.

Section 7.2.5

Octal Display data in octal.

Decimal Display data in decimal.

Hexadecimal Display data in hexadecimal.

Float Display data in real number.

String Display data in character string.

String (ASCII only) Display data in ASCII string.

Register –

16-bit Display data in units of words.

Section 7.2.532-bit Display data in units of double words.

64-bit Display data in units of 64 bits.

Setup Change the editor size. Section 7.2.6

Tool (function for setting device memory) Reference

Read Device Memory from PLC Read device memory data from the programmable controller 
CPU. Section 7.4.1

Write Device Memory to PLC Write device memory data to the programmable controller CPU.

Read from Excel File Read data from an Excel file.
Section 7.4.2

Write to Excel File Write data to an Excel file.

Edit (function for verification result) Reference

Write to CSV File Write verification result to a CSV file. Section 4.2.7

Find/Replace (function for verification result) Reference

Next Unmatch Move to the next mismatched data.
Section 4.2.7

Previous Unmatch Move to the previous mismatched data.

View (function for verification result) Reference

Return to Result List Return to the <<Verify Result List>> tab from the <<Detail 
Verify Result>> tab.

Section 4.2.7Close Detail Result Close the <<Detail Verify Result>> tab being displayed.

Close All Detail Result Close all <<Detail Verify Result>> tabs being displayed.
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■ List of functions for executing sampling trace

The following tables show the functions for executing sampling trace.

View (function for executing sampling trace) Reference

Result Position –

Move to Trigger Point Display the trigger position. –

Switching Display Items –

Device

Display/hide the display item titles. Section 16.4.3

Address

Comment

Data Types

Radix

Timing Chart Scale –

Narrow Scale
Enlarge/reduce the timing chart scale. Section 16.4.4

Wide Scale

Trend Graph Scale –

Narrow Scale

Enlarge/reduce the trend graph scale. Section 16.4.4Wide Scale

Initial Display

Additional Information –

Past Time
Display/hide the additional information. Section 16.4.2

Section 16.4.4Program Name

Debug (function for executing sampling trace) Reference

Sampling Trace –

Open Sampling Trace Display the Sampling Trace screen. Section 16.4.1

Trace Setting Display the screen on which the sampling trace conditions are 
set. Section 16.4.2

Start Trace Start sampling trace. Section 16.4.4

Stop Trace Suspend sampling trace. –

Execute Manual Trigger Generate a trigger at any given timing. –

Register Trace

Write trace settings to the programmable controller CPU.
Execute this to control the sampling trace start by a sequence 
program.
Sampling trace starts when the Trace start command (SM801) 
is executed after executing "Register Trace".

Section 16.4.4

Forced Execution Registration Effective Enable to execute the sampling trace from the peripherals.

Display Trace Buffer Condition Display trace data storage status.

Export CSV Data Save the trace data (trace settings + results) on the personal 
computer in CSV file format.

Section 16.4.5Read from PLC Read the sampling trace data (trace settings + results) from the 
programmable controller CPU.

Write to PLC Write the trace data (trace settings + results) to the 
programmable controller CPU.

Delete All Data
Delete all information including the device data registered and 
the sampling trace result displayed on the Sampling Trace 
screen.

–
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1.3.2 List of functions for editing in Ladder Diagram

The following tables show the functions for the ladder editor.

Edit (function for editing in Ladder Diagram) Reference

Continuous Paste Increment the device number of device in the cut/copied ladder 
block and paste it consecutively.

(Simple)

Delete Delete the selected data.

Restore After Ladder Conversion Return the ladder program being edited to the last converted 
status.

Insert Row Insert a row at the cursor position.

Delete Row Delete the row at the cursor position.

Insert Column Insert a column at the cursor position.

Delete Column Delete the column at the cursor position.

NOP Batch Insert Insert an NOP in front of the ladder block at the cursor position.

NOP Batch Delete Batch-delete NOPs in the program being edited.

Edit Line Enter a line at the cursor position.

Delete Line Delete the line at the cursor position.

Change TC Setting Batch-change timer/counter setting values used in the program.

Ladder Edit Mode –

Read Mode Switch the mode of the open window to "Read Mode".
(Simple)

Write Mode Switch the mode of the open window to "Write Mode".

Ladder Symbol –

Open Contact Insert  at the cursor position.

(Simple)

Close Contact Insert  at the cursor position.

Open Branch Insert  at the cursor position.

Close Branch Insert  at the cursor position.

Coil Insert  at the cursor position.

Application Instruction Insert  at the cursor position.

Vertical Line Insert  at the cursor position.

Horizontal Line Insert  at the cursor position.

Delete Vertical Line Insert  at the cursor position.

Delete Horizontal Line Insert  at the cursor position.

Pulse Contact Symbol –

Rising Pulse Insert  at the cursor position.

(Simple)

Falling Pulse Insert  at the cursor position.

Rising Pulse Branch Insert  at the cursor position.

Falling Pulse Branch Insert  at the cursor position.

Rising Pulse Close Insert  at the cursor position.

Falling Pulse Close Insert  at the cursor position.

Rising Pulse Close Branch Insert  at the cursor position.

Falling Pulse Close Branch Insert  at the cursor position.

Invert Operation Results Insert  at the cursor position.

Operation Result Rising Pulse Insert  at the cursor position.

Operation Result Falling Pulse Insert  at the cursor position.
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Inline Structured Text –

Insert Inline Structured Text Box Insert an inline structured text box. (Simple)

Display Template Insert a template corresponds to the instruction, function, or 
control syntax.

(Structured)Mark Template (Left) Set an argument of the template in the selected status from the 
left by selecting the menu each time.

Mark Template (Right) Set an argument of the template in the selected status from the 
right by selecting the menu each time.

Edit FB Instance Rename an FB instance name. (FB)

Documentation –

Device Comment Edit device comments. Chapter 9

Statement Edit statements.

(Simple)Note Edit notes.

Statement/Note Batch Edit Batch-edit the statements/notes in the program.

Easy Edit –

Connect Line to Right-Side Symbol Connect a horizontal line to the instruction or the line at the right 
of the cursor position.

(Simple)

Connect Line to Left-Side Symbol Connect a horizontal line to the instruction or the line at the left 
of the cursor position.

Enter/Delete HLine Rightward Enter/delete a line at the right of the cursor position.

Enter/Delete HLine Leftward Enter/delete a line at the left of the cursor position.

Enter/Delete VLine Downward Enter/delete a line at the downward of the cursor position.

Enter/Delete VLine Upward Enter/delete a line at the upward of the cursor position.

Switch Open/Close Contact Switch between an open contact and a closed contact. Section 10.3.4

Switch Statement/Note Type Change the type of the statement/note.

(Simple)

Instruction Partial Edit Display the Enter Symbol screen in which the first argument is 
in the selected status.

Edit List for Ladder Block Display/edit the ladder block in list format.

Read from CSV File Read a list format program from a CSV file and display it as a 
ladder program.

Write to CSV File Write a ladder program to a CSV file in list format.

Edit (function for editing in Ladder Diagram) Reference

Find/Replace (function for editing in Ladder Diagram) Reference

Change Module I/O No. Replace the start module I/O number of the buffer memory 
address instruction.

(Simple)

Switch Statement/Note Type Change the type (PLC/Peripheral) of a statement/note.

Line Statement List Display a list of line statements used in the program.

Jump Move the cursor to the specified step position.

Jump to Next Ladder Block Start Move the cursor from the current position to the start of the next 
ladder block.

Jump to Previous Ladder Block Start Move the cursor from the current position to the start of the 
previous ladder block.

Next Device Move the cursor to the same device as the one at the cursor 
position.

Next Contact Move the cursor to the contact where the same device as the 
one at the cursor position is used.

Next Coil Move the cursor to the coil where the same device as the one 
at the cursor position is used.

Back Return the cursor to the previous position before the [Next 
Device]/[Next Contact]/[Next Coil] function execution.
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Online (function for editing in Ladder Diagram) Reference

Monitor –

Monitor Condition Setting Set a condition to start monitoring.

(Simple)
Monitor Stop Condition Setting Set a condition to stop monitoring.

Entry Ladder Monitor Register and monitor ladder blocks.

Delete All Entry Ladder Delete all registered ladder blocks.

View (function for editing in Ladder Diagram) Reference

Comment Display device comments or label comments. Chapter 9

Statement Display statements.

(Simple)

Note Display notes.

Display Lines of Monitored Current Value Open the Options screen and display/hide the lines of 
monitored current value.

Display Format for Device Comment Open the Options screen and set the display format for device 
comment.

Display Ladder Block

Hide Ladder Block Hide the ladder block at the cursor position.

Display Ladder Block Display the hidden ladder block at the cursor position.

Hide All Ladder Block Hide all ladder blocks.

Display All Ladder Block Display all hidden ladder blocks.

Device Display

Device Display Display the device assigned by compilation.

Batch Device Display Batch-change the label display on the program editors to the 
device display.

Cancel All Device Display Cancel the device display on the program editors, and display 
data in the format at the time of data entry.

Display Compile Result Display the compilation result of the program on the inline 
structured text box in a list format.

Zoom Change the display magnification of the ladder program.

Text Size –

Bigger Enlarge the text display size on the editing screen.
(Simple)

Smaller Reduce the text display size on the editing screen.

Open Other Windows –

Open Reference Window Open the reference window of the ladder editor.

(Simple)Update Reference Window Apply the most recent ladder program to the reference window.

Open Reference Source Window Display the source of the referenced ladder editor.

Tile FB Horizontally Tile the ladder editor and the function block program editor 
horizontally. (FB)

Open Label Setting Open the Local Label Setting screen for the program being 
edited. (Simple)

Open Zoom SFC Block Display the SFC diagram of the Zoom editor window.

Move SFC Cursor –

Up Move the cursor on the SFC diagram upward.

(Simple)

Down Move the cursor on the SFC diagram downward.

Left Move the cursor on the SFC diagram to the left.

Right Move the cursor on the SFC diagram to the right.

Open Instruction Help Display the Instruction Help screen.
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1.3.3 List of functions for editing SFC diagrams

The following tables show the functions for editing SFC diagrams.

Edit (function for editing SFC diagrams) Reference

Delete Delete the selected data.

(Simple)

Arrange SFC Redisplay the SFC diagram.

Insert Row Insert a row at the cursor position.

Delete Row Delete the row at the cursor position.

Insert Column Insert a column at the cursor position.

Delete Column Delete the column at the cursor position.

Edit Line –

Vertical Line Segment Insert  at the cursor position.

(Simple)

Selection Divergence Insert  at the cursor position.

Simultaneous Divergence Insert  at the cursor position.

Selection Convergence Insert  at the cursor position.

Simultaneous Convergence Insert  at the cursor position.

Delete Line Delete the line at the cursor position.

Change TC Setting Batch-change timer/counter setting values used in the program.

Ladder Edit Mode –

Read Mode Switch the mode of the open window to "Read Mode".
(Simple)

Write Mode Switch the mode of the open window to "Write Mode".

SFC Step Attribute –

No Attribute Set the step attribute to No Attribute.

(Simple)

Stored Coil Set the step attribute to Stored Coil.

Stored Operation (without Transition 
Check) Set the step attribute to Stored Operation (SE).

Stored Operation (with Transition 
Check) Set the step attribute to Stored Operation (ST).

Reset Reset the step attribute.

SFC Symbol –

[STEP] Step Insert  at the cursor position.

(Simple)

[B] Block Start Step (with END Check) Insert  at the cursor position.

[BS] Block Start Step (without END 
Check) Insert  at the cursor position.

[JUMP] Jump Insert  at the cursor position.

[END] END Step Insert  at the cursor position.

[DUMMY] Dummy Step Insert  at the cursor position.

[TR] Transition Insert  at the cursor position.

[--D] Selection Divergence Insert  at the cursor position.

[==D] Simultaneous Divergence Insert  at the cursor position.

[--C] Selection Convergence Insert  at the cursor position.

[==C] Simultaneous Convergence Insert  at the cursor position.

[ | ] Vertical Line Insert  at the cursor position. –

Sort SFC Step No. Sort the SFC step/transition numbers in ascending/descending 
order. (Simple)

Documentation –

SFC Step/Transition Comment Change to the SFC step/transition comment editing mode. (Simple)
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1.3.4 List of functions for editing SFC block list

The following tables show the functions for editing SFC block list.

Find/Replace (function for editing SFC diagrams) Reference

Jump Move the cursor to the specified position.

(Simple)Find Jump Step Move to the jump source step.

Change SFC Step No. Replace the SFC step number.

Compile (function for editing SFC diagrams) Reference

Convert Block Convert a single block. (Simple)

View (function for editing SFC diagrams) Reference

Program Display Display MELSAP-L programs.

(Simple)

SFC Step/Transition Comment Display the SFC step/transition comments.

Zoom Change the display magnification ratio of the SFC diagram.

Text Size

Bigger Enlarge the text display size on the editing screen.

Smaller Reduce the text display size on the editing screen.

SFC Row Setting Set the number of rows of SFC diagram.

Open SFC Blocklist Display the SFC block list screen.

MELSAP3 Display Display SFC in MELSAP3 format.

MELSAP-L (Instruction Format) Display Display SFC in MELSAP-L (instruction format).

MELSAP-L (Start Conditions Format) 
Display Display SFC in MELSAP-L (start conditions format).

Open Zoom/Start Destination Block Display the Zoom editor window or the start destination block.

Back to Start SFC Block Display the SFC block of the start source.
–

Open Header Open the Local Label Setting screen for the program being 
edited.

Online (function for editing in SFC diagrams) Reference

Monitor –

Monitor Condition Setting Set a condition to start monitoring.
(Simple)

Monitor Stop Condition Setting Set a condition to stop monitoring.

Find/Replace (function for editing SFC block list) Reference

Jump Move the cursor to the specified block number.
(Simple)

Block Information Find Device Search for a device.

View (function for editing SFC block list) Reference

SFC Block List Comment Display comments of the SFC block list.

(Simple)
Device Display Display devices.

Open SFC Body Open the SFC diagram.

Open Header Display the label setting editor.
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1.3.5 List of functions for editing in Structured Text

The following tables show the functions for the ST editor.

Edit (function for editing in Structured Text) Reference

Delete Delete the selected data. –

List Operands Display the screen for inserting a label by selecting an existing 
label.

(Structured)
Display Template Insert a template corresponds to the instruction, function, or 

control syntax.

Mark Template (Left) Set an argument of the template in the selected status from the 
left by selecting the menu each time.

Mark Template (Right) Set an argument of the template in the selected status from the 
right by selecting the menu each time.

Find/Replace (function for editing in Structured Text) Reference

Jump Jump to the specified line. (Structured)

Bookmark –

Toggle Bookmark Set a bookmark at the cursor line. The bookmark is deleted 
when one is already set at the cursor line.

(Structured)
Bookmark List Jump to the specified bookmark from the bookmark list.

Next Bookmark Display the next bookmark position.

Previous Bookmark Display the previous bookmark position.

Delete All Bookmarks Cancel all bookmarks.

View (function for editing in Structured Text) Reference

Display Compile Result Display the compilation result in a list format. (Structured)

Zoom –

Set Zoom Factor

Change the display size of the program. (Structured)Increase Zoom

Decrease Zoom

Zoom Header/Body –

Header Open the label setting editor in the selected POU.

(Structured)Body Open the program editor in the selected POU.

Open Header Open the Local Label Setting screen for the program being 
edited.

Online (function for editing in Structured Text) Reference

Monitor –

Start Monitoring Start monitoring with the split window format that displays 
monitor data of numeric value and character strings. (Structured)

Start Monitoring (Bit Type only) Start monitoring only bit type devices/labels.
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1.3.6 List of functions for editing in Structured Ladder/FBD

The following tables show the functions for the Structured Ladder/FBD editor.

Edit (function for editing in Structured Ladder/FBD) Reference

Delete Delete the selected data. –

Select Mode Change to the contact and coil input mode.
(Structured)

Interconnect Mode Change to the line drawing mode.

Guided Mode –

Guided Editing Change to the keyboard input mode.

(Structured)

Overwrite Mode Overwrite the element entered in Guided editing at the cursor 
position.

Insert Mode Insert the element entered in Guided editing at the cursor 
position.

Line Mode Change the input format to draw lines in Guided editing.

Auto Comment Add a comment entry field at the start of the ladder block added 
in Guided editing.

Auto Connect Specify and connect the start and end points to draw a line.

Recalculate Line Arrange a line automatically to redraw it.

Insert Row Insert a row into the ladder program being edited.

Insert Column Insert a column into the ladder program being edited.

New Ladder Block List –

Top Insert a new ladder block at the start of all ladder blocks.

(Structured)

Before Insert a new ladder block in front of the ladder block being 
edited.

After Insert a new ladder block after the ladder block being edited.

Bottom Insert a new ladder block at the end of all ladder blocks.

Input Instruction Open the Input Instruction screen.

Ladder Symbol –

Open Contact Insert  at the cursor position.

(Structured)

Close Contact Insert  at the cursor position.

Coil Insert  at the cursor position.

Jump Insert  at the cursor position.

Return Insert  at the cursor position.

Open Branch Insert  at the cursor position.

Close Branch Insert  at the cursor position.

Input Label Insert  at the cursor position.

Output Label Insert  at the cursor position.

Horizontal Line Segment Insert  at the cursor position.

Vertical Line Segment Insert  at the cursor position.

Rising Pulse Insert  at the cursor position.

Falling Pulse Insert  at the cursor position.

Rising Pulse Close Insert  at the cursor position.

Falling Pulse Close Insert  at the cursor position.

Comment Insert a comment entry field at the cursor position.
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Ladder Symbol –

Ladder Block Label Display the Ladder Block screen.
(Structured)

Left Power Rail Display/hide the left power rail.

List Operands Display the screen for inserting a label by selecting an existing 
label. (Structured)

Number of Pins –

Increment Increase the number of arguments of functions and function 
blocks.

(Structured)Delete Decrease the number of arguments of functions and function 
blocks.

Ladder Block List Display a list of ladder blocks in a program.

Signal Configuration –

Configure Set the type of a contact and a coil.

(Structured)
Toggle

Change the contact and coil type per execution in the following 
order.
• Contact: Open Contact → Close Contact
• Coil: Normal → Negation → Set → Reset

Edit (function for editing in Structured Ladder/FBD) Reference

Find/Replace (function for editing in Structured Ladder/FBD) Reference

Jump Jump to the specified ladder block number. (Structured)

View (function for editing in Structured Ladder/FBD) Reference

View Mode –

Label Display variables by its entered format.

(Structured)

Device Display devices/addresses in device format. Devices assigned 
to labels are displayed in device format.

Address Display devices/addresses in address format. Devices 
assigned to labels are displayed in address format.

Comment Display label comments.

Change Label-Device-Address Mode Switch the display format in order (label, device, address).

Change Label-Comment Mode Switch the display between label and comment.

All Device Display Batch-change all labels on the program editors to the device 
display.

Cancel All Device Display Cancel the device display on the program editors, and display 
data in the format at the time of data entry.

Grid Show a grid on the screen being edited to display the start/end 
positions of a line.

Print Wrap Position Display the wrapping position for printing.

Display Compile Result Display the compilation result in a list format.

Zoom –

Set Zoom Factor

Change the display size of the program. (Structured)Increase Zoom

Decrease Zoom

Zoom Header/Body –

Header Open the label setting editor in the selected POU.

(Structured)Body Open the program editor in the selected POU.

Open Header Open the Local Label Setting screen for the program being 
edited.
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1.3.7 List of functions for CC IE Field configuration window

The following tables show the functions for the CC IE Field configuration window.

CC IE Field configuration (function on the CC IE Field configuration window) Reference

Change Module –

Replace General CC IE Field Module Replace the general-purpose CC IE Field module to a specific 
module.

Section 6.3.2
Change to General CC IE Field Module Change the specific module to a general-purpose CC IE Field 

module.

Change Transmission Path Method –

Line/Star Change the transmission path method to line or star.

Section 6.3.2

Ring Change the transmission path method to ring.

Supplementary Setting Set the link scan mode setting, loopback function setting, block 
data assurance per station, and operation setting for returning.

Equal Assignment Assign the number of link device points of all stations equally.

Identical Point Assignment Assign the equal number of link device points based on the 
total number of set stations.

Check –

System Configuration Check whether the set equipment configuration of CC-Link IE 
Field Network is correct.

Section 6.3.2Parameter Processing of Slave Station Perform the parameter processing on a slave station.

Command Execution of Slave Station Perform commands on a slave station.

Close with Discarding the Setting Discard the settings and close the CC IE Field configuration 
window. –

Close with Reflecting the Setting Apply the settings and close the CC IE Field configuration 
window. Section 6.3.2

Edit (function on the CC IE Field configuration window) Reference

Copy Copy the information of the slave station of the selected row.

Section 6.3.2
Paste Paste the copied slave station to the last row of the list of 

stations.

Select All Select all cells on the list of stations.

Delete Delete the slave station of the selected row.

View (function on the CC IE Field configuration window) Reference

Docking Window –

Module List Display/hide the Module List window of CC-Link IE Field 
Network.

Section 6.3.2Output Display/hide the Output window.

Supplementary Information Display/hide the Supplementary Information window.
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1.3.8 List of functions for CC-Link configuration window

The following tables show the functions for the CC-Link configuration window.

CC-Link configuration (function on the CC-Link configuration window) Reference

Change Module –

Replace General CC-Link Module Replace the general-purpose CC-Link module to a specific 
module.

Section 6.3.3
Change to General CC-Link Module Change the specific module to a general-purpose CC-Link 

module.

Check –

System Configuration Check whether the set equipment configuration of CC-Link is 
correct. Section 6.3.3

Online –

Detect Now Apply the actual system configuration to the CC-Link 
configuration window.

Section 6.3.3Parameter Processing of Slave Station Perform the parameter processing on a slave station.

Command Execution of Slave Station Perform commands on a slave station.

Close with Discarding the Setting Discard the settings and close the CC-Link configuration 
window. –

Close with Reflecting the Setting Apply the settings and close the CC-Link configuration window. Section 6.3.3

Edit (function on the CC-Link configuration window) Reference

Copy Copy the information of the slave station of the selected row.
Section 6.3.3

Paste Paste the copied slave station to the last row of the list of 
stations.

Select All Select all cells on the list of stations. –

Delete Delete the slave station of the selected row. Section 6.3.3

View (function on the CC-Link configuration window) Reference

Docking Window –

Module List Display/hide the Module List window of CC-Link.
Section 6.3.3

Output Display/hide the Output window.
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1.3.9 List of functions for AnyWireASLINK configuration window

The following tables show the functions for the AnyWireASLINK configuration window.

AnyWireASLINK configuration (function on the AnyWireASLINK configuration window) Reference

Change Module –

Replace General AnyWireASLINK 
Module

Replace the general-purpose AnyWireASLINK module to a 
specific module.

(Intelligent)Change to General AnyWireASLINK 
Module

Change the specific module to a general-purpose 
AnyWireASLINK module.

Address Auto-Input Enter the address of the slave module automatically.

Check –

System Configuration Check whether the set equipment configuration of 
AnyWireASLINK is correct. (Intelligent)

Online –

Detect Now Apply the actual system configuration to the AnyWireASLINK 
configuration window. (Intelligent)

Parameter Processing of Slave Module Perform the parameter processing on a slave module.
–

Close with Discarding the Setting Discard the settings and close the AnyWireASLINK configuration 
window.

Close with Saving the Setting Apply the settings and close the AnyWireASLINK configuration 
window. (Intelligent)

Edit (function on the AnyWireASLINK configuration window) Reference

Copy Copy the information of the slave module of the selected row.

–
Paste Paste the copied slave module to the last row of module 

information list.

Select All Select all cells on the module information list.

Delete Delete the slave module of the selected row.

View (function on the AnyWireASLINK configuration window) Reference

Docking Window

–Module List Display/hide the Module List window of AnyWireASLINK.

Output Display/hide the Output window.
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1.3.10 List of functions for the Sensor/Device Monitor screen

The following tables show the functions for the Sensor/Device Monitor screen.

1.3.11 List of functions for GX Simulator2 screen

The following tables show the functions for the GX Simulator2 screen.

Sensor/Device Monitor (function on the Sensor/Device Monitor screen) Reference

Close Close the Sensor/Device Monitor screen. –

View (function on the Sensor/Device Monitor screen) Reference

Docking Window
–

Monitor Information Display/hide the Monitor Information window.

Online (function on the Sensor/Device Monitor screen) Reference

Parameter Processing of Slave Station Perform the parameter processing on a slave station when 
monitoring the sensors and equipment of CC-Link.

–

Command Execution of Slave Station Perform commands on a slave station when monitoring sensors 
and equipment of CC-Link.

Parameter Processing of Slave Module Perform the parameter processing on a slave module when 
monitoring sensors and equipment of AnyWireASLINK.

Start Monitoring Start monitoring sensors and equipment.

Stop Monitoring Stop monitoring sensors and equipment.

Tool (function on the GX Simulator2 screen) Reference

Backup Device Memory in Simulation –

Save Save device memory/buffer memory in simulation temporarily. Section 15.2.1

Read Read device memory/buffer memory saved temporarily. Section 15.2.2

I/O System Setting Execute simulation with the I/O system setting. Section 19.1

Options (function on the GX Simulator2 screen) Reference

Start in minimized status Start the GX Simulator2 screen in the minimized status at 
starting simulation. Section 15.2

Save device memory at stop Save device memory/buffer memory in simulation automatically 
at stopping simulation. Section 15.2.1
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1.3.12 List of functions for I/O system setting screen

The following tables show the functions for the I/O System Setting screen.

File (function for the I/O system setting) Reference

New Create a new I/O system setting. Section 19.8.1

Open Open an existing I/O system setting. Section 19.8.2

Save Save an I/O system setting. –

Save As Name and save an I/O system setting. Section 19.8.3

(Recently used I/O system setting files 1 to 
4)

Display the recently used I/O system setting file names and 
open the selected I/O system setting file. –

Execute I/O System Setting Execute the I/O system setting and start simulation. Section 19.6.1

Disable I/O System Setting Disable execution of the I/O system setting. Section 19.6.2

Exit I/O System Settings Exit the I/O system setting. –

Edit (function for the I/O system setting) Reference

Cut Cut the selected data.

Section 19.4.2Copy Copy the selected data.

Paste Paste the cut or copied data at the cursor position.

Delete Delete the selected data. –

Enable/Disable Setting –

Enable All Enable all I/O system settings.
Section 19.4

Disable All Disable all I/O system settings.

View (function for the I/O system setting) Reference

Toolbar Display/hide the toolbar.
–

Statusbar Display/hide the status bar.

Online (function for the I/O system setting) Reference

Target Simulator Setting Set the target simulation with which the I/O system setting is 
executed. Section 19.3

Start Monitoring Start monitoring the I/O System Setting screen.
Section 19.7.1

Stop Monitoring Stop monitoring the I/O System Setting screen.

Window (function for the I/O system setting) Reference

Cascade Cascade windows.

–
Tile Vertically Tile windows on the I/O System Setting screen vertically.

Tile Horizontally Tile windows on the I/O System Setting screen horizontally.

Arrange Icons Arrange the icons at the bottom of the I/O System Setting 
screen.
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1.3.13 List of functions for predefined protocol support function

The following tables show the functions for the predefined protocol support function.

File (function of the predefined protocol support function) Reference

New Create a new protocol setting file.

(Intelligent)

Open Open an existing protocol setting file.

Close Close the open protocol setting file.

Save Save the protocol setting file.

Save As Name and save a protocol setting file.

Print Print such as protocol setting.

Exit Exit the predefined protocol support function.

Edit (function of the predefined protocol support function) Reference

Add Protocol Add a protocol.

(Intelligent)

Change to Editable Protocol Change the protocol selected from the predefined protocol 
library to an editable one.

Protocol Detailed Setting
Set the protocol detailed setting such as the number of retries 
of protocol transmission and whether to clear OS area (receive 
data area).

Add Receive Packet Add a receive packet.

Delete Delete the protocol.

Copy Copy the protocol.

Paste Paste the protocol.

Delete Multiple Protocols Batch-delete multiple protocols.

Copy Multiple Protocols Batch-copy multiple protocols.

Paste Multiple Protocols Batch-paste multiple protocols.

Device Batch Setting Batch-set devices used in the protocol.

Save User Protocol Library Save the set protocol as a user protocol library.

Module Read/Write (function of the predefined protocol support function) Reference

Read from Module Read protocol settings from the module.

(Intelligent)Write to Module Write registered protocol settings to the module.

Module Verification Compare protocol settings being opened with those written in 
the module.

Tool (function of the predefined protocol support function) Reference

Setting Device List Display the list of devices used in protocols.
(Intelligent)

Register Predefined Protocol Library Import predefined protocol library provided by Mitsubishi 
Electric Corporation.

Debugging Support Function (function of the predefined protocol support function) Reference

Module Selection Select a module to be debugged.

(Intelligent)
Protocol Execution Log Display the protocol execution logs and the protocol execution 

results.

State Monitor
Monitor signals, communication error information, operation 
setting switches, and protocol execution status of the Q series 
C24N/L series C24 module.

Window (function of the predefined protocol support function) Reference

Cascade Cascade windows.

(Intelligent)Tile Horizontally Tile windows horizontally.

(Switch to other window) Display the open window.
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2 - 1

2 SYSTEM 
CONFIGURATION

This chapter explains the system configuration, configuration devices, and supported languages of 
GX Works2.

2.1 Connection from USB/Serial Port 2 - 2

2.2 Connection from I/F Boards 2 - 13

2.3 Interfaces and Connectable Modules 2 - 15

2.4 System Configuration with Memory Card on Personal 
Computer 2 - 19

2.5 Supported Programming Languages 2 - 20
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2.1 Connection from USB/Serial Port

The following shows the possible system configuration for connecting to the programmable 
controller CPU using the USB/serial port of a personal computer.
For ACPU, use GX Developer. For details of the use of ACPU, refer to Appendix 14.

*1 : Section 2.1.1
*2 : Section 2.1.2
*3 : Section 2.1.3
*4 : Section 2.1.4
*5 : Section 2.1.5
*6 : Section 2.1.6
*7 : Section 2.1.7
*8 : Section 2.1.8

Remote HeadQ CPU L CPU FX

GX Works2

(SW1DNC-GXW2-E)

Programmable controller

direct connection

(Serial port communication)

QC30R2

QCPU (Q mode)/

Remote I/O module
USB Cable

Programmable controller

direct connection

(USB communication)

QCPU (Q mode)/

Remote I/O module

FXCPU

FXCPU

(FX1S/FX1N/FX2N/FX3G/

 FX3U/FX3UC)

Converter/Cable

Converter/Cable

FXCPU
(FX1S/FX1N/FX2N/FX1NC/
 FX2NC/FX3G/FX3U/FX3GC/
 FX3UC)

FXCPU
(FX0/FX0S/FX1S/FX0N/
 FX1N/FX2N/FX1NC/FX2NC/
 FX3U/FX3UC)

Converter/Cable

Cable

FXCPU

(FX1S/FX1N/FX2N/FX3U/

 FX3UC)
Converter/Cable

FXCPU

(FX3U/FX3UC)
USB Cable

FXCPU

(FX3G/FX3GC)
USB Cable

LCPU/

Communication

head module

LCPUQC30R2

RS-232 adapter

*1

*2
*2

*3

*4

*4

*4

*5

*5

*7

*8

*8

*6

*6

*7
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*1 : Section 2.1.9
*2 : Section 2.1.10
*3 : Section 2.1.11

QCPU (Q mode)/

Remote I/O module

G4 module

QCPU (Q mode)/

Remote I/O module

Via CC-Link(G4)

Via MELSECNET/H

RS-232

Converter/Cable

C24

Converter/Cable

Remote station

Via Serial communication

Remote module Control station

CC-Link

QCPU (Q mode)/

Remote I/O module
Cable

Via GOT

GOT

GX Works2

(SW1DNC-GXW2-E)

FXCPU

LCPU/

CC IE Field 

head module

LCPU/

CC IE Field 

head module

LCPU/

CC IE Field 

head module

QCPU (Q mode)

LCPU

Via modem
Modem

Cable included in modem package

Modem

C24

Cable included in modem package

FXCPU

(FX1S/FX1N/FX2N/FX1NC/

FX2NC/FX3G/FX3U/FX3GC/

FX3UC)

*1

*3

*2
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2  SYSTEM CONFIGURATION

2.1.1  USB cables (compatible with QCPU (Q mode), LCPU, and communication head module)

2.1.1 USB cables (compatible with QCPU (Q mode), LCPU, and 
communication head module)

The following table shows USB cables and USB adapters whose operations have been confirmed by 
Mitsubishi Electric Corporation.

● Using a USB cable for the first time
Install the USB driver. (Appendix 16)

● Considerations and restrictions
For the considerations and restrictions when accessing a programmable controller CPU, refer to Section 11.11.

● Using a USB/RS-232 conversion cable
For checking the COM port number as connecting a personal computer to a programmable controller CPU using such 
as USB/RS-232 conversion cable, refer to the user's manual of each cable.

■ Configurations for USB connection

Only one programmable controller CPU can be connected to a personal computer using a USB cable.
Connection to a programmable controller CPU is not applicable to the configuration examples below.

Product name Model Manufacturer

USB cable
(USB A type - USB B type)*1

AU230 BUFFALO KOKUYO SUPPLY INC.

USB cable
(USB A type - USB miniB type)*2

KU-AMB530 SANWA SUPPLY INC.

U2C-M30BK ELECOM Co., Ltd.

MR-J3USBCBL3M Mitsubishi Electric Corporation

GT09-C30USB-5P Mitsubishi Electric System & Service Co., Ltd.

*1 : For QCPU (Q mode) only
*2 : For Universal model QCPU/LCPU/communication head module only

Programmable controller CPU

USB cable

USB cable

USB cable

USB hub
USB cable

USB cable

Programmable controller CPU

Programmable controller CPU

Programmable controller CPU

Connection to several programmable controller CPUs from the personal
computer with several USB ports

Connection to several programmable controller CPUs via USB hub

<Inapplicable configurations>
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2.1.2  USB cables and function expansion boards (compatible with FX3U/FX3UC) 2 - 5
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2.1.2 USB cables and function expansion boards (compatible with 
FX3U/FX3UC)

● Using a USB cable for the first time
• Install the driver from the CD-ROM included with FX-USB-AW and FX3U-USB-BD.
• GX Works2 selects data from the Connection Destination view on the Navigation window and assigns a serial COM 

port number.

● Considerations and restrictions
• For the considerations and restrictions relating to FX3U-USB-BD, refer to the user's manual included.
• When "Operate Communication Setting" is selected on the <<PLC System (2)>> tab of PLC parameter, the 

corresponding port cannot communicate with the programmable controller CPU. Write the setting in which "Operate 
Communication Setting" is cleared from the built-in programming port of the programmable controller CPU.
When the programmable controller type of the project is FX3U/FX3UC, the channel setting (CH1/CH2) combo box is 
displayed. Select 'CH1' to confirm the setting.

2.1.3 USB cables (compatible with FX3G and FX3GC)

For details of cables, refer to the following manuals.
FX3G Series Programmable Controllers User's Manual [Hardware Edition]
FX3GC Series Programmable Controllers User's Manual [Hardware Edition]
Only one programmable controller CPU can be connected to a personal computer using a USB cable.
(Section 2.1.1 "■ Configurations for USB connection")

● Using a USB cable for the first time
Install the USB driver. (Appendix 16)
GX Works2 selects data from the Connection Destination view on the Navigation window and configures a USB.

FX3U-USB-BD USB cable (included)
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2  SYSTEM CONFIGURATION

2.1.4  RS-232 cables (compatible with QCPU (Q mode), LCPU, and remote I/O module)

2.1.4 RS-232 cables (compatible with QCPU (Q mode), LCPU, and 
remote I/O module)

The following table shows RS-232 cables whose operations have been confirmed at Mitsubishi Electric.
LCPU can be connected with an RS-232 adapters (L6ADP-R2).

● High-speed communication
For high-speed communication (transmission speed: 115.2/57.6kbps), use a personal computer compatible with high-
speed communication.
When a communication error occurs, retry the communication after reducing the transmission speed setting.

2.1.5 Converters/cables for RS-232 connection (compatible with 
FXCPU)

● Transmission speed
When connecting to FX3G/FX3GC/FX3U/FX3UC using FX-232AWC-H, select any of 9.6kbps, 19.2kbps, 38.4kbps, 
57.6kbps, or 115.2kbps for the transmission speed.
When connecting using FX-232AWC or FX-232AW, select either 9.6kbps or 19.2kbps for the transmission speed.

● Connecting to FXCPU
Be sure to use equipment shown in the table when connecting to FXCPU.

Model Product name

QC30R2
(Personal computer connector: 9-pin D-sub connector)

Mitsubishi Electric Corporation RS-232 cable

Personal computer side (RS-232 cable) RS-232/RS-422
converter

Programmable controller CPU side
(RS-422 cable)

F2-232CAB
(25-pin D-sub↔25-pin D-sub)

FX-232AW

FX-232AWC

FX-232AWC-H

For FX1/FXU/FX2C

FX-422CAB (0.3 m)
FX-422CAB-150 (1.5 m)

F2-232CAB-1
(9-pin D-sub↔25-pin D-sub)

For FX0/FX0S/FX0N/FX1S/FX1N/FX1NC/FX2N/FX2NC/
FX3G/FX3GC/FX3U/FX3UC

FX-422CAB0 (1.5 m)F2-232CAB-2
(Half pitch↔25-pin D-sub)

AC30N2A(25-pin↔25-pin) –
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2.1.6  Connection using function expansion boards (compatible with FXCPU) 2 - 7
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■ Considerations for using RS-422 interface cables/converters

For the specifications of an RS-422 interface conversion cable/converter and the considerations for 
using them, please read the following instructions as well as the manuals of each product for correct 
handling.

● Connecting/disconnecting the conversion cable/converter
When connecting/disconnecting a peripheral device, conversion cable or converter to/from the RS-
422 interface, be sure to touch a grounding strap or grounded metal to discharge static electricity 
stored in the cable or in your body before the operation, regardless of whether electricity is being 
supplied or not. After doing this, follow the procedure below.
Turn the programmable controller CPU OFF before connecting/disconnecting a conversion cable/
converter that receives 5VDC power supply from the RS-422 interface.

Operation
1. Turn OFF the personal computer.

2. Turn OFF the conversion cable/converter. Ground the FG terminal if provided.

3. Connect/disconnect the conversion cable/converter to/from the personal computer and 
the programmable controller CPU.

4. Turn ON the conversion cable/converter.

5. Turn ON the personal computer.

6. Start up the software package.

2.1.6 Connection using function expansion boards (compatible 
with FXCPU)

The following table shows the compatibility of FXCPU with function expansion boards.

Series Function expansion board

FX3U,
FX3UC (FX3UC-32MT-LT, FX3UC-32MT-LT-2 only) FX3U-422-BD

FX3G FX3G-422-BD

FX2N FX2N-422-BD

FX1S, FX1N FX1N-422-BD
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2  SYSTEM CONFIGURATION

2.1.6  Connection using function expansion boards (compatible with FXCPU)

● PLC parameter
When "Operate Communication Setting" is selected on the <<PLC System (2)>> tab of PLC parameter, the 
corresponding port cannot communicate with the programmable controller CPU. Write the setting in which "Operate 
Communication Setting" is cleared from the built-in programming port of the programmable controller CPU.
When the programmable controller type of the project is FX3G/FX3GC or FX3U/FX3UC, the channel setting (CH1/CH2) 
combo box is displayed.
Select 'CH1' to confirm the setting.
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2.1.7  Connection using RS-232 cables and function expansion boards (special adapters) (compatible with FXCPU) 2 - 9
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2.1.7 Connection using RS-232 cables and function expansion 
boards (special adapters) (compatible with FXCPU)

The following table shows the compatibility of RS-232 cables with function expansion boards and 
special adapters according to the shape and pin configuration of the serial port of the personal 
computer.

Serial port shape of
personal computer Series Function expansion board and special adapter RS-232 cable

9-pin D-sub

FX3U, FX3UC
FX3U-232-BD*1

FX-232CAB-1
Function expansion board (FX3U-***-BD)*2 + FX3U-232ADP

FX3G, FX3GC
FX3G-232-BD*3

FX-232CAB-1
FX3G-CNV-ADP*4 + FX3U-232ADP

FX2N

FX0N-232ADP + FX2N-CNV-BD F2-232CAB-1

FX2N-232-BD
FX-232CAB-1

FX2NC-232ADP + FX2N-CNV-BD

FX1NC, FX2NC
FX0N-232ADP F2-232CAB-1

FX2NC-232ADP FX-232CAB-1

FX1S, FX1N

FX0N-232ADP + FX1N-CNV-BD F2-232CAB-1

FX1N-232-BD
FX-232CAB-1

FX2NC-232ADP + FX1N-CNV-BD

Half pitch 14-pin

FX3U, FX3UC
FX3U-232-BD*1

FX-232CAB-2
Function expansion board (FX3U-***-BD)*2 + FX3U-232ADP

FX3G, FX3GC
FX3G-232-BD*3

FX-232CAB-2
FX3G-CNV-ADP*4 + FX3U-232ADP

FX2N

FX0N-232ADP + FX2N-CNV-BD F2-232CAB-2

FX2N-232-BD
FX-232CAB-2

FX2NC-232ADP + FX2N-CNV-BD

FX1NC, FX2NC
FX0N-232ADP F2-232CAB-2

FX2NC-232ADP FX-232CAB-2

FX1S, FX1N

FX0N-232ADP + FX1N-CNV-BD F2-232CAB-2

FX1N-232-BD
FX-232CAB-2

FX2NC-232ADP + FX1N-CNV-BD

25-pin D-sub

FX3U, FX3UC
FX3U-232-BD*1

F2-232CAB-1
Function expansion board (FX3U-***-BD)*2 + FX3U-232ADP

FX3G, FX3GC
FX3G-232-BD*3

F2-232CAB-1
FX3G-CNV-ADP*4 + FX3U-232ADP

FX2N

FX0N-232ADP + FX2N-CNV-BD F2-232CAB

FX2N-232-BD
F2-232CAB-1

FX2NC-232ADP + FX2N-CNV-BD

FX1NC, FX2NC
FX0N-232ADP F2-232CAB

FX2NC-232ADP F2-232CAB-1

FX1S, FX1N

FX0N-232ADP + FX1N-CNV-BD F2-232CAB

FX1N-232-BD
F2-232CAB-1

FX2NC-232ADP + FX1N-CNV-BD

*1 : For FX3UC series, only FX3UC-32MT-LT and FX3UC-32MT-LT-2 are connectable.
*2 : '***' of function expansion boards (FX3U-***-BD) indicates 232, 485, 422, USB, CNV, or 8AV.

Function expansion board (FX3U-***-BD) is not required for FX3UC (D, DS, DSS) series.
*3 : FX3GC series are not connectable.
*4 : ADP (FX3G-CNV-ADP) for FX3U adapter connection is not required for FX3GC series.
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2  SYSTEM CONFIGURATION

2.1.7  Connection using RS-232 cables and function expansion boards (special adapters) (compatible with FXCPU)

● PLC parameter
When "Operate Communication Setting" is selected on the <<PLC System (2)>> tab of PLC parameter, the 
corresponding port cannot communicate with the programmable controller CPU. Write the setting in which "Operate 
Communication Setting" is cleared from the built-in programming port of the programmable controller CPU.
When the programmable controller type of the project is FX3G/FX3GC or FX3U/FX3UC, the channel setting (CH1/CH2) 
combo box is displayed.
• FX3U/FX3UC (FX3UC-32MT-LT, FX3UC-32MT-LT-2) series

When using the first adapter of FX3U-232ADP which is connected to FX3U-232-BD or FX3U-CNV-BD, specify 'CH1' 
and check the setting.
When using FX3U-232ADP which is connected to a board other than FX3U-CNV-BD, or when using the second 
adapter of FX3U-232ADP which is connected to FX3U-CNV-BD, specify 'CH2' and check the setting.

• FX3UC (D, DS, DSS)/FX3GC series
When using the first adapter of FX3U-232ADP which is connected to FX3UC (D, DS, DSS) or FX3GC series, specify 
'CH1' and check the setting.
When using the second adapter of FX3U-232ADP, specify 'CH2' and check the setting.

• FX3G series (14-/24-point type)
When using FX3G-232-BD, or when using the first adapter of FX3U-232ADP which is connected to FX3G-CNV-ADP, 
specify 'CH1' and check the setting.

• FX3G series (40-/60-point type)
When using FX3G-232-BD, or when using the first adapter of FX3U-232ADP which is connected to FX3G-CNV-ADP, 
specify 'CH1' and check the setting. In this case, when using the second adapter of FX3U-232ADP which is 
connected to FX3G-CNV-ADP, specify 'CH2' and check the setting.
When using FX3G-232-BD and FX3U-232ADP which is connected to FX3G-CNV-ADP, specify 'CH1' and check the 
setting of FX3U-232ADP, and specify 'CH2' and check the setting of FX3G-232-BD.



2.1  Connection from USB/Serial Port

2.1.8  Converters/cables for USB connection (compatible with FXCPU) 2 - 11
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2.1.8 Converters/cables for USB connection (compatible with 
FXCPU)

● Using a USB cable for the first time
• Install the driver from the CD-ROM included with FX-USB-AW and FX3U-USB-BD.
• GX Works2 selects data from the Connection Destination view on the Navigation window and assigns a serial COM 

port number.

● Considerations and restrictions
• For the considerations and restrictions relating to FX-USB-AW, refer to the user's manual included.

2.1.9 Connection via AJ65BT-R2N

Use an RS-232 cable complies with the RS-232 standard within 15m.
For details, refer to the following manual.
CC-Link System RS-232 Interface Module User's Manual (MELSOFT Connection Mode)

FX-USB-AW USB cable (included)
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2.1.10  Function expansion board (special adapter)

2.1.10 Function expansion board (special adapter)

Set "MODEM Initialized" on the <<PLC System (1)>> tab of PLC parameter according to the modem. 
For details, refer to Section 11.10.

2.1.11 Connection via GOT

The use of the transparent function of GOT enables the access to a programmable controller CPU via 
GOT. (Section 11.9)

Programmable controller side 
connector shape of cable 

included in modem package
Series Function expansion board and special adapter

9-pin D-sub

FX3U, FX3UC
FX3U-232-BD*1

Function expansion board (FX3U-***-BD)*2 + FX3U-232ADP

FX3G, FX3GC
FX3G-232-BD*3

FX3G-CNV-ADP*4 + FX3U-232ADP

FX2N
FX2N-232-BD

FX2NC-232ADP + FX2N-CNV-BD

FX1NC, FX2NC FX2NC-232ADP

FX1S, FX1N
FX1N-232-BD

FX2NC-232ADP + FX1N-CNV-BD

25-pin D-sub

FX2N FX0N-232ADP + FX2N-CNV-BD

FX1NC, FX2NC FX0N-232ADP

FX1S, FX1N FX0N-232ADP + FX1N-CNV-BD

*1 : For FX3UC series, only FX3UC-32MT-LT and FX3UC-32MT-LT-2 are connectable.
*2 : '***' of function expansion boards (FX3U-***-BD) indicates 232, 485, 422, USB, CNV, or 8AV.

Function expansion board (FX3U-***-BD) is not required for FX3UC (D, DS, DSS) series.
*3 : FX3GC series are not connectable.
*4 : ADP (FX3G-CNV-ADP) for FX3U adapter connection is not required for FX3GC series.
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2.2 Connection from I/F Boards

*1 : CC IE Field head module only

The following shows the system configuration for connecting to a programmable controller CPU 
using an I/F board installed on the personal computer.
For the methods for installing an I/F board and installing the driver, refer to the manual of each I/F 
board.

*1 : Section 2.2.1

Remote HeadQ CPU L CPU FX
*1

QCPU

Programmable controller
on host/another station

Driver

Driver supplied 
with commercially 
available 
Ethernet board

Driver

SW4DNF-CCLINK-B

QCPU

Programmable controller 
on another station

Driver

SW1DNC-MNETG-B

QCPU

QCPU

LCPU/
CC IE Field 
head module

Programmable controller 
on another station

CC-Link IE Controller Network board

CC-Link IE Field Network board

A80BDE-J61BT13  (Optical loop)
A80BDE-J61BT11  (Optical loop)

Driver

SW1DNC-CCIEF-J

Q81BD-J71GF11-T2

Driver

SW0DNC-MNETH-B

QCPU

Programmable controller 
on another station

MELSECNET/H board

Q80BD-J71BR11 (Coaxial loop)
Q80BD-J71LP21-25 (Optical loop)
Q80BD-J71LP21G (Optical loop)

Driver

SW1DNC-CCBD2-B

QCPU

LCPU

Programmable controller 
on another station

LCPU

LCPU

FXCPU

Programmable controller 
on another station

CC-Link Ver.1 board

A80BD-J61BT11

A80BD-J61BT13

CC-Link Ver.2 board

Q80BD-J61BT11N

Ethernet board

Ethernet board built-in a personal 
computer/commercially available

GX Works2

(SW1DNC-GXW2-E)

Programmable controller 
on another station

Programmable controller 
on another station

Programmable controller 
on another station

Programmable controller
on host/another station

Programmable controller
on host/another station

*1

*1

*1
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2.2.1  I/F boards

2.2.1 I/F boards

This section explains applications of I/F boards.
For details, refer to the manual of each I/F board.

■ MELSECNET/H board

• For accessing Process CPU, use SW0DNC-MNETH-B version E or later.
• For accessing Redundant CPU, use SW0DNC-MNETH-B version K or later.

■ CC-Link Ver.1 board

• A80BD-J61BT11 can be used as a master or local station.
• A80BD-J61BT13 can be used as a local station.
• For accessing Process CPU, use SW4DNF-CCLINK-B version C or later.
• Set the board as a local station when connecting a Redundant CPU.

Use SW4DNF-CCLINK-B version G or later.

■ CC-Link Ver.2 board

• Q80BD-J61BT11N can be used as a master or local station.
• Set the board as a local station when connecting a Redundant CPU.
• Use the communication driver SW1DNC-CCBD2-B version 1.04E or later for Windows Vista®, and 

version 1.08J or later for Windows® 7.
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2.3 Interfaces and Connectable Modules

This section explains details of the modules that can be connected from the USB port, serial port, and 
each I/F board.

■ Modules connectable from USB port

The following table shows the modules that can be connected from the USB port.
● Q series, L series

● FX series

Remote HeadQ CPU L CPU FX

Programmable controller series Module model

Q series

Q00UJ, Q00U, Q01U, Q02H, Q02PH, Q02U, Q03UD, Q03UDE, Q03UDV, 
Q04UDH, Q04UDEH, Q04UDV, Q06H, Q06PH, Q06UDH, Q06UDEH, 
Q06UDV, Q10UDH, Q10UDEH, Q12H, Q12PH, Q12PRH, Q13UDH, 
Q13UDEH, Q13UDV, Q20UDH, Q20UDEH, Q25H, Q25PH, Q25PRH, 
Q26UDH, Q26UDEH, Q26UDV, Q50UDEH, Q100UDEH

L series L02S, L02, L02-P, L06, L26, L26-BT, L26-PBT, LJ72GF15-T2, LJ72MS15

Module name Connection 
route Module model

Programmable controller 
main unit

FX-USB-AW*1 FX0, FX0S, FX0N, FX1S, FX1N, FX1NC, FX2N, FX2NC, FX3U, FX3UC

USB direct 
connection FX3G, FX3GC

USB expansion board
USB direct 
connection*1 FX3U-USB-BD

*1 : As FXCPU uses the serial ⇔ USB conversion driver software, specify the COM port number of the RS-232 in the 
connection destination setting.
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■ Modules connectable from serial port

The following table shows the modules that can be connected from the serial port.

Programmable 
controller series Module name Module model

Q series

Programmable controller CPU 
module

Q00J, Q00UJ, Q00, Q00U, Q01, Q01U, Q02(H), Q02PH, Q02U, 
Q03UD, Q04UDH, Q06H, Q06PH, Q06UDH, Q10UDH, Q12H, 
Q12PH, Q12PRH, Q13UDH, Q20UDH, Q25H, Q25PH, Q25PRH, 
Q26UDH

Serial communication module*1 QJ71C24, QJ71C24-R2, QJ71C24N, QJ71C24N-R2,
QJ71C24N-R4

MELSECNET/H network
remote I/O module QJ72LP25, QJ72BR15

G4 module AJ65BT-G4-S3, AJ65BT-R2N

L series

Programmable controller CPU 
module L02S, L02*2, L02-P*2, L06*2, L26*2, L26-BT*2, L26-PBT*2

Serial communication module*1 LJ71C24, LJ71C24-R2

G4 module AJ65BT-G4-S3, AJ65BT-R2N

FX series*3 Programmable controller main 
unit

FX0, FX0S, FX0N, FX1, FXU, FX2C, FX1S, FX1N, FX1NC, FX2N, FX2NC, 
FX3G, FX3GC, FX3U, FX3UC

*1 : When accessing the programmable controller CPU from a personal computer via serial communication modules, note that 
modules that can be connected to the personal computer are limited.
Even if a module cannot be directly connected to the personal computer, it may be usable as the nth module in multi-drop 
connection.
For details of the multi-drop connection, refer to the following manuals.
Q Corresponding Serial Communication Module User’s Manual (Basic)
MELSEC-L Serial Communication Module User’s Manual (Basic)

<Q series>
: Applicable ×: Not applicable

<L series>
: Applicable ×: Not applicable

*2 : Connectable only with an RS-232 adapter (L6ADP-R2).
*3 : Connectable only with an RS-232 ⇔ RS-422 conversion board/adapter.

Model Interface 1:1 system configuration
Multi-drop connection

1st module nth module

QJ71C24N
QJ71C24

CH1 RS-232   ×

CH2 RS-422/485 × × 

QJ71C24N-R2
QJ71C24-R2

CH1 RS-232  × ×

CH2 RS-232 

(Function version B or later) × ×

QJ71C24N-R4
CH1 RS-422/485 × × ×

CH2 RS-422/485 × × ×

Model Interface 1:1 system configuration
Multi-drop connection

1st module nth module

LJ71C24
CH1 RS-232   ×

CH2 RS-422/485 × × 

LJ71C24-R2
CH1 RS-232  × ×

CH2 RS-232  × ×
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■ Modules connectable from MELSECNET/H board

The following table shows the modules that can be connected from the MELSECNET/H board.

■ Modules connectable from CC-Link IE Controller Network board

The following table shows the modules that can be connected from the CC-Link IE Controller Network 
board.

■ Modules connectable from CC-Link IE Field Network board

The following table shows the modules that can be connected from the CC-Link IE Field Network 
board.

■ Modules connectable from CC-Link Ver.1 board

The following table shows the modules that can be connected from the CC-Link Ver.1 board.

■ Modules connectable from the CC-Link Ver.2 board

The following table shows the modules that can be connected from the CC-Link Ver.2 board.

I/F board model Programmable 
controller series Module model

Q80BD-J71LP21-25
Q80BD-J71LP21G
Q80BD-J71BR11

Q series QJ71LP21, QJ71LP21G, QJ71BR11, QJ71LP21-25,
QJ71LP21S-25

I/F board model Programmable 
controller series Module model

Q80BD-J71GP21-SX
Q80BD-J71GP21S-SX Q series QJ71GP21-SX, QJ71GP21S-SX

I/F board model Programmable 
controller series Module model

Q81BD-J71GF11-T2
Q series QJ71GF11-T2

L series LJ72GF15-T2, LJ71GF11-T2

I/F board model Programmable 
controller series Module model

A80BD-J61BT11
A80BD-J61BT13 Q series QJ61BT11, QJ61BT11N

I/F board model Programmable 
controller series Module model

Q80BD-J61BT11N
Q series QJ61BT11, QJ61BT11N

L series L26-BT, LJ61BT11
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■ Modules connectable from Ethernet board

The following table shows the modules that can be connected from the Ethernet board.

I/F board model Programmable 
controller series Module model

Ethernet board built-in a personal 
computer or commercially available

Q series

QJ71E71, QJ71E71-B2, QJ71E71-100, QJ71E71-B5, 
Q03UDE, Q03UDV, Q04UDEH, Q04UDV, Q06UDEH, 
Q06UDV, Q10UDEH, Q13UDEH, Q13UDV, Q20UDEH, 
Q26UDEH, Q26UDV, Q50UDEH, Q100UDEH

L series LJ71E71, L02, L02-P, L06, L26, L26-BT, L26-PBT

FX series FX-ENET series
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2.4 System Configuration with Memory Card on Personal Computer

This section explains the system configuration when accessing from the personal computer with the 
memory card on the personal computer.

● Installing memory card into PC card slot
When installing a Q series memory card into the PC card slot, the following adapter is required.

● Writing/reading data to/from memory card
Using the following functions, even if a memory card cannot be installed into the programmable 
controller CPU, data can be written or read by installing the memory card to personal computer.

: Applicable ×: Not applicable

Q CPU L CPU FXRemote FXHead FXFX

Product name Model manufacturer

PC card adapter Q2MEM-ADP Mitsubishi Electric Corporation

Function PLC series Memory card Windows®2000 Windows®XP Windows Vista® Reference

IC memory card 
data write/read

Q series*1

*1 : Not supported by Basic model QCPU, Q00UJ, Q00U, Q01U, and High-speed Universal model QCPU.

SRAM card*2

*2 : When using a SRAM card, set the driver to CONFIG.NT.
(For details, refer to HELP of Windows®)
When using an ATA card, Windows® recognizes it automatically.
If the ATA card cannot be recognized, select [Control Panel] ⇒ [System] to set the personal computer.
If the driver for SRAM card is set to CONFIG.NT, cancel the setting.

× × ×

Section 12.11.1
ATA card   

Flash card × × ×

Q series*3

L series*4

*3 : For High-speed Universal model QCPU only
*4 : Not supported by L02S

SD memory 
card   

IC memory card 
data write/read 
(edit and data 
copy)

L series*4 SD memory 
card    Section 12.11.2
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2.5 Supported Programming Languages

This section explains details of the programming languages supported by GX Works2.
: Supported ×: Not supported

Programming 
language Description

Simple project
Structured 

projectwithout 
labels with labels

Ladder 
Diagram (LD)

A graphic language using ladder programs composed of contacts and 
coils. Ladder diagrams are created in a similar way to existing GX 
Developer.
In projects with labels, the Inline structured text function can be used to 
edit ST programs on the ladder editor.

  *1

*1 : Not supported by FXCPU.

Structured 
Text (ST) A text language with grammatical structure similar to C language. × *1 

Sequential 
Function Chart 
(SFC)*2

*2 : For QCPU (Q mode)/LCPU, the display format of SFC can be selected from "MELSAP3", "MELSAP-L (Instruction Format)", and 
"MELSAP-L (Start Conditions Format)".

A graphic language which defines the executing order or condition of a 
program.  *1 *1

Structured 
Ladder

A graphic language using ladder programs composed of contacts and 
coils. × × 

Function 
Block 
Diagram 
(FBD)

A graphic language using ladder programs by connecting functions and/
or function blocks with lines. × × 

Q CPU L CPU FXFXRemote FXHead
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3 - 1

3 SCREEN 
CONFIGURATION AND 
BASIC OPERATIONS

This chapter explains the screen configuration and basic operations of GX Works2.

3.1 Starting and Exiting GX Works2 3 - 2

3.2 Screen Configuration and Basic Operations 3 - 3

3.3 Selecting Language 3 - 30

3.4 Help Function 3 - 32
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3.1 Starting and Exiting GX Works2

This section explains the operation methods for starting and exiting GX Works2.

■ Starting GX Works2

Start GX Works2.

Operating procedure

• Select [Start] ⇒ [All Programs] ⇒ [MELSOFT Application] ⇒ [GX Works2] ⇒ [GX 
Works2].

■ Exiting GX Works2

Exit GX Works2.

Operating procedure

• Select [Project] ⇒ [Exit].

Remote HeadQ CPU L CPU FX
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3.2 Screen Configuration and Basic Operations

This section explains the main frame (basic screen) of GX Works2 that is displayed when it is started 
up.

3.2.1 Main frame configuration

The following screen shows a main frame configuration on which a work window and docked windows 
are displayed.

Screen display

Remote HeadQ CPU L CPU FX

Title bar

Toolbar

Navigation 

window

Status bar

Work 

window

Menu bar

Docked window

Function Block
Selection window
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3.2.1  Main frame configuration

Display contents

● Focus point indication in Windows Vista® or Windows® 7
When using Windows Vista® or Windows® 7, the focus point may not be indicated on the screen.
To display the focus point, set the following setting.

1) For Windows Vista®, select [Start] ⇒ [Control Panel] ⇒ [Ease of Access] ⇒ [Ease of Access Center].
For Windows® 7, select [Start] ⇒ [Control Panel] ⇒ [Ease of Access Center].

2) Select "Make the keyboard easier to use".
3) Select "Underline keyboard shortcuts and access keys".

Name Description Reference

Title bar Display a project name. –

Menu bar Display menu options for executing each function. –

Toolbar Display tool buttons for executing each function. Section 3.2.2

Work window A main screen used for operations such as 
programming, parameter setting, and monitoring Section 3.2.3

Docking window A sub screen to support operations performed on a 
work window Section 3.2.4

Navigation Display contents of a project in tree format. Section 3.2.5

Selection Display a list of functions (such as function blocks) 
used for programming.

GX Works2 Version 1
Operating Manual

(Simple Project, Function Block)
(Structured Project)

Output Display compilation and check results (errors and 
warnings).

GX Works2 Version 1
Operating Manual
(Simple Project)

(Structured Project)

Cross Reference Display cross reference results. Section 10.1

Device List Display the device list. Section 10.2

CC-Link Device Reference Display assignments of refresh devices and link 
devices specified for the CC-Link parameter. Section 6.3.5

Watch 1 to 4 A screen used for monitoring and changing current 
device values. Section 14.6

Intelligent Function Module 
Monitor 1 to 10

Screens used for monitoring intelligent function 
modules.

GX Works2 Version 1
Operating Manual

(Intelligent Function Module)

Find/Replace A screen used for searching and replacing character 
strings in the project. Section 10.3

Debug A screen used for setting the debug which uses the 
simulation function.

Section 16.6.2
Section 16.6.3
Section 16.6.4

Status bar Display information about a project being edited. Section 3.2.6
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3.2.2 Toolbars

A toolbar is a block of on-screen buttons for executing frequently-used functions included in a menu. 
(Appendix 1)
The toolbars to be displayed and their display positions on the screen can be set by the user.

■ Displaying/hiding toolbars

Select a toolbar to be displayed.

Operating procedure

• Select [View] ⇒ [Toolbar] ⇒ [(toolbar name)].
The selected toolbar is displayed on the screen.
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3.2.2  Toolbars

■ Docking/floating toolbars

Switch the display format (docked/floating) of a toolbar.

● Floating a toolbar
Display a toolbar floating from the main frame.

Operation
• Drag a docked toolbar to the desired position for floating display.

Drag and drop
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● Docking a toolbar
Display a toolbar docked to the main frame.

Operation
• Drag the title bar of a floating toolbar and drop it in the main frame.

● Method for docking a toolbar at the original position
To dock a floating toolbar back at the original position, double-click on the title bar of the toolbar.

Drag and drop
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3.2.2  Toolbars

■ Displaying/hiding all toolbars

Display/hide all toolbars that are set to be displayed.
The display setting of toolbar can be saved by performing the following operation.

Operating procedure

• Select [View] ⇒ [Toolbar] ⇒ [Display All].
The standard toolbars and all other toolbars are displayed.*1
The changes of toolbar positions and the display setting of displaying/hiding toolbars are 
maintained.

*1 : Inactive toolbars are included. Toolbars of inapplicable functions are grayed out.

<When the [Display All] function is enabled>

When the [Display All] function is disabled while all toolbars are displayed, only the active toolbars 
are displayed.
<When the [Display All] function is disabled>
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■ Customizing toolbars

Set the types of tool buttons to be displayed on each toolbar.

Operating procedure

1. Select the Toolbar options button ( ) ⇒ [Add or Remove Buttons].
A list of tool buttons is displayed.

2. Select the check box in front of the tool button to be displayed on the screen.
The selected tool buttons are displayed on the screen.

The toolbar configuration returns to the default when [Reset Toolbar] is selected.

Restrictions

● Restrictions when customizing toolbars
The type of tool buttons for the following toolbars cannot be set.
• Monitor status
• Debug function
• Sampling trace
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3.2.2  Toolbars

■ Displaying editing screens with the toolbar

For Simple projects only, editing screens can be displayed with the toolbar.

Screen display
Select [View] ⇒ [Toolbar] ⇒ [Docking Window/Switch Project Data].

Operating procedure

1. Select a data type to be displayed.

2. Select a data name to be displayed.
The editing screen of the selected data name is displayed.

● Display icon ( )

The editing screen of the selected data type and data name can be displayed by clicking .

Data type Data name
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3.2.3 Work windows

A work window is a main screen used for operations such as programming, parameter setting, and 
monitoring in GX Works2.

Screen display

Display contents

Scroll buttonTooltipTab

Switching button

Item Description

Tab

Become active when selected.
The tab order can be changed by dragging and dropping tabs.
The window(s) can be closed from the menu displayed by right-clicking the tab. In the other way, the 
active window can be closed by clicking  on the tab.

Tooltip Display a brief explanation when the cursor is placed on the selected tab.

Scroll button Scroll the tab display to the left and right.
Display hidden tabs.

Switching button Display the list of windows being displayed.
Select a data name displayed on the list to display its corresponding window on the top.

Display windows Display screens such as the program editor, label setting editor, and monitoring screen.

Right-click
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3.2.3  Work windows

■ Maximizing/minimizing screens

Maximize/minimize the screen size on the work window.
● Maximizing the screen

Operation

• Click the Maximize button ( ).

Click
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● Minimizing the screen

Operation

• Click the Minimize button ( ).

● Restoring the screen size
Click  to return the maximized/minimized screen to its previous size.

Click

Click
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3.2.3  Work windows

■ Arranging screens

Arrange screens to display on the work window.
● Cascading screens

Operation
• Select [Window] ⇒ [Cascade].

● Tiling screens vertically

Operation
• Select [Window] ⇒ [Tile Vertically].
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● Tiling screens horizontally

Operation
• Select [Window] ⇒ [Tile Horizontally].

● Arranging icons (minimized windows) at the bottom of the work window

Operation
• Select [Window] ⇒ [Arrange Icons].
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3.2.3  Work windows

■ Arranging/displaying windows

Display a list of open windows, and also open and arrange specified windows.
This function is useful to display the desired window efficiently when multiple windows are open.

Screen display
Select [Window] ⇒ [Other Windows].



3.2  Screen Configuration and Basic Operations

3.2.4  Docking windows 3 - 17

1

O
V

E
R

V
IE

W

2

S
YS

TE
M

 
C

O
N

FI
G

U
R

A
TI

O
N

3

SC
RE

EN
 

CO
NF

IG
UR

AT
IO

N 
AN

D 
BA

SI
C 

O
PE

RA
TI

ON
S

4

P
R

O
JE

C
T 

M
A

N
A

G
E

M
E

N
T

5

ED
IT

IN
G

 
PR

O
G

R
AM

S

6

S
E

TT
IN

G
 

PA
R

A
M

E
TE

R
S

7

S
ET

TI
N

G
 D

E
V

IC
E

 
M

E
M

O
R

Y

8

S
E

TT
IN

G
 D

E
V

IC
E

 
IN

IT
IA

L 
V

A
LU

ES

3.2.4 Docking windows

This section explains the operations common to dock windows.

■ Displaying/Hiding dockable windows

Display/hide a dockable window.

Operating procedure

• Select [View] ⇒ [Docking Window] ⇒ [(target item)].

■ Docking/floating dockable windows

Switch the display format of a dockable window.
● Docked display

Display a dockable window docked to the main frame.
● Floating display

Display a dockable window floating from the main frame.

Operation
• Drag the title bar of a floating dockable window and drop it to the guidance in the main 

frame.

The docked window is floated by dragging the title bar to the desired position.

Drag and drop

Drag a dockable window to the guidance. A new tab appears after the window is docked.
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3.2.4  Docking windows

● Operation of dockable windows
Docked windows can be switched from docked to floating or vice versa by double-clicking the title bar.

● Changing the tab order
The tab order can be changed by dragging and dropping the desired tab to the left or right when multiple dockable 
windows are docked.

Floating display

Dockable display

Double-click

Double-click

The tab order is changed.Drag and drop
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■ Window minimized mode

Minimize a docked window as a tab.
The window minimized mode can be set and disabled by the following procedure.

Operating procedure

• Click the window minimized mode switching icon ( / ).

Only the tab is 

displayed in 

window 

minimized 

mode.

Normal display

Window minimized switching icon

Window minimized mode 

Docked window display in 

window minimized mode

Placing the cursor

on the tab displays

the window.

The window is displayed normally 

after disabling window minimized 

mode.
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3.2.5  Navigation window

3.2.5 Navigation window

This section explains the Navigation window that displays the contents of a project in tree format.
Operations such as creating new data and displaying editing screens can be performed on the 
Navigation window.
(Chapter 4)

Screen display
Select [View] ⇒ [Docking Window] ⇒[Navigation].

Display contents

● Color of characters on title bar when uncompiled data exist
The color of characters on the title bar becomes red when an uncompiled data exists on the Project view or User 
Library view.

Title bar

Toolbar

View 

selection 

area

Name Description Reference

Title bar Display a title of a view being displayed. –

Toolbar Display tool buttons of functions to be executed on 
each view. Appendix 1

View selection area Area for selecting a view to display. –

Project Display the Project view. Section 4.2.1

User Library Display the User Library view.
GX Works2 Version 1

Operating Manual
(Structured Project)

Connection Destination Display the Connection Destination view. Section 11.1.1

Project with uncompiled data Project without uncompiled data
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■ Sorting data

Sort data displayed in tree format.

Operating procedure

1. Open a folder on the Navigation window and select the data for sorting.

2. Right-click and select [Sort] ⇒ [(sort type)] from the shortcut menu.
The data displayed in tree format are sorted in the ascending order.
When the same operation is performed after sort execution, the sort order is switched between 
ascending and descending.
The following table shows the sort types.

Type Description

Execution Order*1

Sort data in the selected folder according to the execution order.
When a program file is selected, tasks in the program file are sorted according to 
the execution order.
When a task is selected, programs in the task are sorted according to the 
execution order.

Name Sort the data in the selected folder according to the name.

Date Sort the data in the selected folder according to the date modified.

Language*2 Sort the data in the selected folder according to the programming language type.

POU Type*3 Sort the data in the selected folder according to the POU type.

*1 : SFC programs of Simple project, and program files and tasks of Structured project only
*2 : Tasks, programs, and FB/FUN of Structured project only
*3 : FB/FUN of Structured project only
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3.2.5  Navigation window

■ Expanding all uncompiled data

Expand all uncompiled data exist on the Project view and User Library view.

Operating procedure

1. Click  on the toolbar.

2. Select [Expand All Uncompiled Data].
All uncompiled data are expanded and become selectable status.

■ Collapsing tree

Collapse tree on the Project view and User Library view.

Operating procedure

1. Click  on the toolbar.

2. Select [Collapse All].
The tree is collapsed.
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3.2.6 Status bar

The status bar displays information about the current project at the bottom of the screen.

The following shows the information to be displayed.

■ Displaying/hiding status bar

Display/hide the status bar.

Operating procedure

• Select [View] ⇒ [Statusbar].
A check mark is appended in front of the menu option and the status bar is displayed on the 
screen.

Project 

language

Connection  

time

Project 

type
Security information

Connection 

destination

Programmable 

controller type
Cursor position

Insert/

Overwrite

Caps

Lock

Num

Lock

Item Description

Connection time Display the connection duration of the phone line.

Project language Display the language set for the language selection.

Project type

Display the project type.

Security information Display the login user name when security is set for the project.

Programmable controller type Display the programmable controller type of the project.

Connection destination

Display the set content of the Transfer Setup screen.
For Redundant CPU, the set content is displayed as shown below.

Cursor position Display the cursor position in the editing screen.

Insert/Overwrite Display the current mode (insert or overwrite).

Caps Lock Display the effective status of the Caps Lock.

Num Lock Display the effective status of the Num Lock.

• Unlabeled : Simple project (without labels)
• Simple : Simple project (with labels)
• Structured : Structured project
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3.2.7 Changing colors and fonts

Change the color and font settings on program editors and label editors.

Screen display
Select [View] ⇒ [Color and Font].

Operating procedure

1. Set the items on the screen.

2. Click the  button.

Item Description

Target Select the change target work window.

Font Setting Change font settings.

Auto (Based on system settings) Select this to use the font settings in Windows®.

User settings
Select this to customize the font settings.
Click the  button to select the desired font.

Color Setting –

Color Setting Items Select the change target item and color.



3.2  Screen Configuration and Basic Operations

3.2.7  Changing colors and fonts 3 - 25

1

O
V

E
R

V
IE

W

2

S
YS

TE
M

 
C

O
N

FI
G

U
R

A
TI

O
N

3

SC
RE

EN
 

CO
NF

IG
UR

AT
IO

N 
AN

D 
BA

SI
C 

O
PE

RA
TI

ON
S

4

P
R

O
JE

C
T 

M
A

N
A

G
E

M
E

N
T

5

ED
IT

IN
G

 
PR

O
G

R
AM

S

6

S
E

TT
IN

G
 

PA
R

A
M

E
TE

R
S

7

S
ET

TI
N

G
 D

E
V

IC
E

 
M

E
M

O
R

Y

8

S
E

TT
IN

G
 D

E
V

IC
E

 
IN

IT
IA

L 
V

A
LU

ES

Screen button

●

Displays the Font screen.
The font type, style, and size can be customized.
Some font styles and sizes, however, cannot be set depending on target work windows.

●

Displays the Color screen.
The color can be customized. The created color is added as "Custom" in the color selection field of 
the Color and Font screen. Only one color can be added as "Custom".

●

Displays the Import Color and Font setting file screen.

Select "Color and Font setting file (*.gcs)" and click the  button to read the file.
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●

Displays the Export Color and Font setting file screen.
Set a save destination and a file name for the color and font setting file (*.gcs).
The content displayed on the Color and Font screen is saved on the file by clicking the  
button.

●

Resets the color and font settings to default.

●

Applies the changed color and font settings.

● Font setting
Some fonts may be displayed as garbled characters.
Change the setting to another font if this happens.
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3.2.8 Customizing shortcut keys

Customize a shortcut key of each function.
Customized shortcut keys can be registered as a template and utilized.

Screen display
Select [Tool] ⇒ [Key Customize].

■ Setting shortcut keys

This function creates/changes/deletes a shortcut key.

Operating procedure

1. Set the items on the screen.

Item Description

Shortcut Key –

Category Select a category from the group list categorized by window.

Command Select a function name whose shortcut key to be changed.

Current Key Display the shortcut key assigned to the selected command.

Press the keys to assign
Specify a new shortcut key to be assigned. Input it by pressing a key(s) on 
the keyboard.

Example) +

Current
Display the menu name to which the entered shortcut key is assigned. 
When the key is already assigned to another function, the function name is 
displayed.
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2. Click the  button.
The shortcut key is assigned.
The assigned shortcut key is displayed in "Current Key".

3. Click the  button.
The shortcut key is created/changed.

Screen button

●

Deletes the shortcut key selected in "Current Key".

●

Displays the Enter Template Name screen.
Register the assigned shortcut keys as a template with a desired name.
The registered template is displayed in "Template".

● Assigning shortcut keys
Up to three shortcut keys can be assigned to one function. The shortcut key displayed on the top in "Current Key" is 
displayed on the menu.

● Templates
The maximum file name length for a template is 24 characters.
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■ Registering templates

This function registers/deletes a template of shortcut keys.

Operating procedure

1. Set the item on the screen.

2. Click the  button.
The selected template of shortcut keys is applied.

Screen button

●

Deletes a template selected in "Template".

●

Imports a pre-saved template file (*.gks) and adds it to "Template".

●

Saves a template selected in "Template" as a template file (*.gks).

Restrictions

● Templates with "MEDOC Format Setting"
Any of the following symptoms occurs when the template with "MEDOC Format Setting" is imported to GX Works2 
Version 1.95Z or earlier.
• Shortcut keys of the tool buttons on the "Ladder" toolbar are hidden.
• When the numeric key is pressed on the Find screen displayed by the simple search function, the display on the 

element selection field is changed.
• An operation according to the set shortcut keys is performed when a number is entered on the ladder editor, the 

Enter VLine screen, the Enter HLine screen, the Delete VLine screen, or the Delete HLine screen.

Item Description

Template

Select a template of shortcut keys from .
• Default Setting

Change to the default setting.
• GPPA Format Setting

Batch change the shortcut key setting of ladder programming to the 
same setting of GPPA.

• GPPW format setting
Batch change the shortcut key setting of ladder programming and 
SFC programming to the same setting of GX Developer.

• Setting of MEDOC Format
Batch change the shortcut key setting of ladder programming to the 
same setting of MELSEC MEDOC.
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3.3 Selecting Language

This section explains how to select a language used for project data (such as device comments, 
statements, and notes).
By selecting a language of the project, data can be created in a language other than English. 
Data created in another language can be displayed without character corruption.
For restrictions when selecting a project language, refer to Appendix 18.

Screen display
Select [Tool] ⇒ [Language Selection].

Operating procedure

1. Set the items on the screen.

2. Click the  button.
The project data are displayed in the selected project language.

Remote HeadQ CPU L CPU FX

< Before creating a new project > < When editing a project >

Item Description

Project Language Select the language of the project.

Save the project (Overwrite save) Select this to save the project before changing the project language.
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● Considerations when project language change is canceled
If characters other than alphanumeric characters are used for data names and label names, the project language 
change may be canceled. In such case, change data names or label names according to the error message displayed 
on the Output window. In some cases, even after the project language is changed, characters other than the characters 
of the selected language may be used. Change the characters other than those of the selected language.
For data names which causes the cancellation of project language change when characters other than alphanumeric 
characters are used, refer to Appendix 17.1.

● Considerations when changing project language
The project language change function does not change the characters on setting menus and screens.
To display characters on setting menus and screens in another language, use the specific version of GX Works2 that 
supports the language.
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3.4 Help Function

This section explains the help function of GX Works2.

3.4.1 Displaying GX Works2 help

Use the GX Works2 help function to learn GX Works2 operations, understand functions, and check 
error codes of programmable controller CPU.
The following items can be checked with the GX Works2 help function.
• Help for operations
• Help for instructions
• Help for special relays/special registers
• Help for CPU errors
• Error codes for CPU module communication
• Changes from GX Developer
• List of shortcut keys
• FX manuals*1

*1 : For FXCPU, GX Works2 Help (for FXCPU) and Adobe® Reader® version 8 or later are required to view the help. For 
installing GX Works2 Help (for FXCPU), refer to the following section.
■ Installing GX Works2 help for FXCPU

Screen display
Select [Help] ⇒ [GX Works2 Help] ( ).

Remote HeadQ CPU L CPU FX

Tab
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● Displaying GX Works2 help
Enter a keyword in the keyword entry field on the standard toolbar of GX Works2, and press the  key to display 
the help items searched by the keyword.

The help items can also be displayed by the screen title by pressing the  key with the selected screen such as 
Navigation window, program editor, and Function Block Selection window of GX Works2. (Some screens do not 
support the  key function.)
For FXCPU, when a special relay (M) or a special register (D) is searched, the head of the section which describes the 
special relay (M) or the special register (D) in the programming manual (PDF file) is displayed.

● Instruction help
• Instructions which are supported by the instruction help function are: common instructions and application functions 

for QCPU (Q mode)/LCPU, and sequence instructions and application functions for FXCPU.
• The SFC editor is not supported by the instruction help function.
• Operators and ST control syntax are not supported by the instruction help function.
• When the selected instruction is corresponded by multiple items, the Result screen (for QCPU (Q mode)/LCPU) or 

the Help Reference screen (for FXCPU) is displayed. Double-click the item to display the help.

• When the selected instruction contains a special relay or special register, the Help References screen is displayed. 

Select a keyword displayed and click the  button.

● Error codes when communicating with CPU module
When an error whose error code is in the range between 4000H and 4C09H occurs while communicating with the CPU 
module, the following pop-up screen is displayed on the right-bottom corner of the screen.
The pop-up help function is not supported by FXCPU.

Keyword entry field
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3.4.1  Displaying GX Works2 help

● Operation of the help function for FXCPU
• The "Add to Favorites" function on the Navigation window of GX Works2 help, and the "Keyword", "Search", 

"Favorites", and "History" functions under [View] ⇒ [Navigation] are not supported by the help function for FXCPU. 
For the search function, display the programming manual (PDF) and use the search function of Adobe® Reader®.

• If another PDF reader other than Adobe® Reader® is installed, the content of the help function may not be displayed. 
In this case, reinstall Adobe® Reader®.

• When an Adobe® Reader® error occurs while using the help function, the error may be solved by restarting a 
personal computer.

■ Installing GX Works2 help for FXCPU

Double-click "setup.exe" in the "DocFX" folder on the CD-ROM (Disc 2) to install GX Works2 Help (for 
FXCPU).
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■ Setting options for GX Works2 help function

Set options for "Startup", "Window", and "Tab" items of the GX Works2 help function.

Screen display
Select the GX Works2 help menu [Operation] ⇒ [Options].

Operating procedure

• Set the items on the screen.

3.4.2 Displaying operating manuals

Display the operating manuals of GX Works2 Version 1.

Screen display
Select [Help] ⇒ [Operating Manual] ⇒ [(manual name)].

Item Description

Startup –

Restore the previous status at the start 
of Help

Select this to activate the GX Works2 help function with the state of 
previous operation.

Window –

Add help icon to the System Tray 
when window is minimized

Select this to set the GX Works2 help function in the task tray when the 
GX Works2 help window is minimized.
When this item is selected and the GX Works2 help window is 
minimized, the GX Works2 help function can be activated from the task 
tray.

Set maximum number of window
Select this to set a maximum number of windows to be displayed with 
the GX Works2 help function.
Enter a maximum number of windows.

Tab –

Switch tab by rolling mouse wheel on 
tab

Select this to switch tabs with the mouse wheel when the cursor is on 
the tab.*1

*1 : When the tab of FX manual is displayed in front, the tabs cannot be switched with the mouse wheel. Select a tab 
other than that of FX manual to switch tabs.

Specify tab size Select this to specify the tab size.
Enter a width and a height of the tab.
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3.4.3  Checking version of GX Works2

3.4.3 Checking version of GX Works2

Display information such as the software version of GX Works2.

Operating procedure

• Select [Help] ⇒ [About].
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4 PROJECT MANAGEMENT
This chapter explains basic operations and management of projects.

4.1 GX Works2 Project Management 4 - 2

4.2 Project Operations 4 - 9

4.3 Operations of Programmable Controller CPU Data 4 - 33

4.4 Operations of Intelligent Function Module Data 4 - 43

4.5 Changing Project Types 4 - 44

4.6 Managing Project Revisions 4 - 45

4.7 Utilizing Projects and Data in Other Formats 4 - 51

4.8 Saving projects in other formats 4 - 57

4.9 Starting GX Developer from GX Works2 4 - 58

4.10 Setting Security for Projects 4 - 59

4.11 Setting Security Key 4 - 69

4.12 Protecting POUs in Projects 4 - 77
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4.1.1  Workspace format

4.1 GX Works2 Project Management

This section explains the management of GX Works2 projects.
In GX Works2, created projects are saved in the workspace format or the single file format.

4.1.1 Workspace format

A workspace manages multiple projects at once.
When configuring a system containing multiple programmable controller CPUs, a project needs to be 
created for each programmable controller CPU. However, projects in the same system can be 
managed by saving projects created in a single workspace in the workspace format.
When using MELSOFT Navigator, save projects in the workspace format.

Remote HeadQ CPU L CPU FX

< ABC alarm processing >

< XYZ control >

MELSECNET/10(H)

Ethernet

Batch-manage projects in the workspace format

First stage construction for company A

< Conveyor control > < Additional processing >

ABC alarm processing

XYZ control

Additional processing

Conveyor control

First stage construction for company A

< System configuration example >

< GX Works2 project management >

Project

Workspace
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■ Configuration of workspace and project

The following explains the configuration of GX Works2 workspace and project.

Do not change or delete workspace configuration or project using an application such as Windows® 
Explorer.
If a data name is changed or deleted using an application such as Windows? Explorer and projects 
without containing actual data may remain in a project list of the function such as opening a project. 
Those faulty projects can be deleted from the project list by selecting [Project] ⇒ [Delete].

For copying GX Works2 project on Windows® Explorer, select either following operation to copy the 
project without breaking the configuration of workspace and project.
• Copy the entire save destination folder ( above).
• Copy the workspace name folder and "workspacelist.xml".

When "workspacelist.xml" ( above) or "projectlist.xml" ( above) does not exist in the folder by 
performing the copy operation other than above, the copied workspaces/projects are not displayed in 
"Workspace/Project List" on the Open screen.
However, note that the project can be opened forcibly by selecting "All Folders" for "Display" on the 
Open screen and displaying all folders.
When a file other than "workspacelist.xml" or "projectlist.xml" is missing, the project may not be 
opened.

Restrictions

● Opening a project forcibly by selecting "All Folders"
The following operations cannot be performed.
• Register, Restore, and Verify functions of project revision history
• Security user management
• Automatic project save
However, the above restrictions are invalidated by selecting [Project] ⇒ [Save As], and saving the project.

<Data in the GX Works2 data folder>

<Data in the Workspace 1 folder>

 

 

 

 

 

Save destination folder

Workspace name folder

Project name folder

workspacelist.xml

projectlist.xml

A folder specified for the save folder path when the project is saved.

A folder corresponds to the workspace name specified when the project is saved.

A folder corresponds to the project name specified when the project is saved.

A file created automatically when the project is saved.

A file created automatically when the project is saved.
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4.1.2  Single file format

4.1.2 Single file format

The single file format is a format to handle project files as a single file.
Projects are managed without being aware of the folder configuration and the file configuration by 
saving projects in the single file format. Operations such as changing project names, copying and 
pasting projects, and sending and receiving data, can easily be performed on Explorer.

● When using MELSOFT Navigator
Projects saved in the single file format cannot be used in MELSOFT Navigator.
Save projects in the workspace format.

<Single file format project (*.gxw)>
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4.1.3 Project

Project contents displayed on the Project view in tree format are as shown below.
Contents displayed on the view differs according to the types of programmable controller and project.
For (Simple), (Structured), and (Intelligent) indicated in the reference destinations, refer to the following 
manuals respectively:

The following are examples for QCPU (Q mode).

*1 : For FXCPU, this item is not displayed.
*2 : For FXCPU, execution types are not categorized. The only one category 'Execution Program' is displayed.
*3 : For FXCPU, a single execution program can be created in either Ladder Diagram or Sequential Function Chart.
*4 : Chapter 6
*5 : Chapter 9
*6 : Section 6.1.1
*7 : Chapter 7
*8 : Chapter 8

(Simple) … GX Works2 Version 1 Operating Manual (Simple Project)

(Structured) … GX Works2 Version 1 Operating Manual (Structured Project)

(Intelligent) … GX Works2 Version 1 Operating Manual (Intelligent Function Module)

<Simple project (without labels)>

*1

*1

*2

Set various parameters.

Make settings for the intelligent function modules.       (Intelligent)

Create programs.          (Simple)

Set global device comments.

Set an execution type of each program.

Make settings for device memory.

Set local device comments.

Set device initial values.

*4

*5

*6

*3

*5

*7

*8
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4.1.3  Project

*1 : For FXCPU, this item is not displayed.
*2 : For FXCPU, execution types are not categorized. The only one category 'Execution Program' is displayed.
*3 : For FXCPU, Simple project (with labels), the 'Execution Program' can be divided into multiple programs.
*4 : For FXCPU, the program is created in Ladder Diagram only.
*5 : Chapter 6
*6 : Chapter 9
*7 : Section 6.1.1
*8 : Chapter 7
*9 : Chapter 8

<Simple project (with labels)>

*1

*1

*2 *3

Set various parameters. 

Make settings for the intelligent function modules.       (Intelligent) 

Set global device comments.

Set global labels.       (Simple)

Set an execution type of each program. 

Create programs.          (Simple)

Set local device comments.

Make settings for device memory. 

Set device initial values. 

*5

*6

*7

*4

*6

*8

*9
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*1 : For FXCPU, this item is not displayed.
*2 : For FXCPU, execution types are not categorized. The only one category 'Execution Program' is displayed.
*3 : Chapter 6
*4 : Chapter 9
*5 : Section 6.1.1
*6 : Chapter 7
*7 : Chapter 8

<Structured project>

*1

*1

*2

Set various parameters.

Make settings for the intelligent function modules.       (Intelligent)

Set global device comments.

Set global labels.       (Structured) 

Set an execution type of each program.

Create programs.       (Structured)

Set local device comments.

Make settings for device memory. 

Set device initial values. 

*3

*4

*5

*4

*6

*7
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4.1.3  Project

● Program Setting
On the Project view, an execution type of a program can be set by right-clicking the name of the program whose 
execution type is to be changed and selecting [Register Program] ⇒ [Initial]/[Scan]/[Standby]/[Fixed Scan]/[Low Speed] 
from the shortcut menu, or dragging and dropping it. The execution type set on the Project view is applied to the 
program setting of the PLC parameter.
(Program setting in PLC parameter Section 6.1.1)

Example) Set the execution type of MAIN to 'Scan Program' with the drag-and-drop operation.

<Project view> <Setting screen for PLC parameter>

The setting made in the Project view is applied.

Drag & drop
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4.2 Project Operations

This section explains basic operations of GX Works2 such as creating, opening, and saving projects.

4.2.1 Creating projects

Configure the settings to create a new project.

Screen display
Select [Project] ⇒ [New] ( ).

Operating procedure

• Set the items on the screen.

Remote HeadQ CPU L CPU FX

Item Description

Project Type Select the type of the project to be created.
Select "Simple Project" or "Structured Project".

Use Label Select this to create a project using labels when "Simple Project" is selected.

PLC Series Select the programmable controller series for the project.

PLC Type

Select the programmable controller type (programmable controller CPU model) used for the 
project.
When a programmable controller type which is not supported by GX Works2 but is supported 
by GX Developer is selected, start GX Developer and create a new project. For a procedure 
to use unsupported programmable controller type, refer to Appendix 14.

Language Select the language for the program data to be created when creating a new project.
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4.2.1  Creating projects

● Considerations when using Windows Vista® or Windows® 7
A new GX Works2 project may not be able to be created when using Windows Vista® or Windows® 7.
Set the access authority for a login user to the following folders to which the access authority has not been set.
• The folder to which GX Works2 is installed.

Example) C:\Program Files\MELSOFT
• C:\Documents and Settings\(login user name)\Local Settings\Application Data\MITSUBISHI\SWnDNGPPW2
• The TEMP folder set by environment variable.

Example) C:\Documents and Settings\(login user name)\Local Settings\Temp

If the access authority cannot be changed, right-click the GX Works2 program and select [Run as administrator]. To 
activate the program from the shortcut menu, open the property of the shortcut menu and select "Run this program as 
an administrator" under "Privilege Level" on the <<Compatibility>> tab.

● Changing data such as workspace name after creating a new project
Do not change the storage location and names of folders/files of a created workspace/project using an application such 
as Windows® Explorer.
For details of workspace/project configuration, refer to Section 4.1.1.

● Common pointer number setting for projects with labels
When a project with labels is created, the last half of the device range of pointer (P) is set for "Common Pointer No." on 
the <<PLC System>> tab of the PLC parameter. This range is set as a pointer range for the "Device/Label Automatic-
Assign Setting" function.
For details of the "Device/Label Automatic-Assign Setting" function, refer to the following manuals.
GX Works2 Version 1 Operating Manual (Simple Project)
GX Works2 Version 1 Operating Manual (Structured Project)

● Connection destination
When creating a new project, the connection destination is set to the route set for "Current Connection" in the 
previously-edited project. Review the connection destination setting to change the previously-edited project and the 
connection destination.
When creating a new project after installing GX Works2 for the first time, the setting is set to access the programmable 
controller CPU directly.

● Creating a new SFC project with FXCPU
When 'SFC' is selected in "Language" with FXCPU, the Block Information Setting screen is displayed.
When an SFC project is created with FXCPU, a ladder program needs to be created using ladder blocks to start up an 
initial step of the SFC program. Select "Ladder Block" in "Block Type", and create a startup ladder program using ladder 
blocks.
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■ Creating new projects with data read from programmable controller CPU or 
intelligent function module (New project creation with data read from 
programmable controller CPU)

A new project can be created with data read from a programmable controller CPU or an intelligent 
function module when the Read from PLC function is executed without creating a new project.
When a programmable controller type which is not supported by GX Works2 but is supported by GX 
Developer is selected, start GX Developer and create a new project. For a procedure to use 
unsupported programmable controller types, refer to Appendix 14.

Operating procedure

1. Start GX Works2 and select [Online] ⇒ [Read from PLC].
The PLC Series Selection screen is displayed.

2. Set the item on the screen.

3. Click the  button.
The Transfer Setup screen is displayed.

4. Set a communication route to access to the programmable controller CPU.
For the method for setting a connection destination, refer to Chapter 11.
The Online Data Operation screen is displayed when the setting of connection destination is 
completed.

5. Execute the Read from PLC function on the Online Data Operation screen.
For the method for executing the Read from PLC function on the Online Data Operation screen, 
refer to Section 12.1.

● Considerations when creating a new project with data read from programmable controller CPU
When parameters are not read from the programmable controller CPU with data to create a new project, default 
parameters are set.
Check the parameter setting.

● Creating a new project with data read from intelligent function module
For the function to create a new project with data read from programmable controller CPU, when an intelligent function 
module is mounted on the same base unit as the connected programmable controller CPU, the project data are created 
according to the mounted module configuration. Thus, the data of intelligent function modules whose parameters are 
not written to the programmable controller CPU are also created.

● Creating a new project with data read from Redundant CPU
Data cannot be read from a Redundant CPU by specifying a system, such as "Control System", "Standby System", 
"System A", or "System B" for "Target System" of redundant operation.
When reading data from the Redundant CPU by specifying the system, read data after creating a project.

Item Description

PLC Series Select the programmable controller series from which data are read.
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4.2.2  Opening existing projects

4.2.2 Opening existing projects

Read a project saved on a hard disk of personal computer.

Screen display
Select [Project] ⇒ [Open] ( ).

Operating procedure

1. Set the items on the screen.

2. Click the  button.
The specified project is displayed.
When the GX Developer project is specified, GX Developer starts automatically and the project is 
displayed.

Remote HeadQ CPU L CPU FX

< Opening a project in the workspace format > < Opening a project in the single file format >

Item Description

Workspace Location
Enter the folder (drive/path) where the workspace is saved.
The folder can be selected on the Browse For Folder screen by clicking the 

 button.

Workspace/Project List Select the workspace or project.
The display is switched to the project list by double-clicking "Workspace".

Display

Select this to display folders for GX Works2 projects only, folders for GX 
Developer projects only, or all folders.
By selecting "All Folders" also displays workspace folders and project folders 
copied/moved by the application such as Windows® Explorer.

Workspace Name Display the selected workspace name.

Project Name Display the selected project name.

Title Display the title of the selected project.
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Screen button

●

Displays the Browse For Folder screen.

●

Switches to the Open screen in the single file format.

●

Switches to the Open screen in the workspace format.

● Changing data such as workspace name
Do not change the storage location and names of folders/files of a created workspace/project using an application such 
as Windows® Explorer.
For details of workspace/project configuration, refer to Section 4.1.1.

● Opening Structured projects
When a Structured project is opened in later version of GX Works2 
than the one used for saving the project, the Library Update 
Confirmation screen may be displayed.
To modify the project and update the new instructions and/or 
application functions, select the corresponding check box(es).

All programs need to be compiled when instructions or application 
functions are updated.
Compiling all programs changes the device assignment to labels. 
Therefore, device values set before the program change remain on the 
device-assigned labels.
Perform the following operations for a precautionary measure.
• For QCPU (Q mode)/LCPU

After writing data to the programmable controller CPU, reset the 
programmable controller CPU, clear all device memories including 
latches, clear all file registers, and switch the programmable 
controller CPU to RUN.

• For FXCPU
After writing data to the programmable controller CPU, clear device memory using the PLC memory clear function, 
and switch the programmable controller CPU to RUN.
(Section 17.4)

For the considerations for compiling all programs, refer to the following manuals.
GX Works2 Version 1 Operating Manual (Simple Project)/(Structured Project)

● Opening projects being edited by other users
The project being edited can be opened by other users as a read-only project. Note that the following functions cannot 
be used.
• Saving projects
• Project revision history
• Succeeding project revision when saving projects with a specific name
• Change PLC type function
• Security function

● Opening projects created in other languages
Characters in a project created in other languages may get garbled when it is opened.

● Open screen
• The Open screen with the initial setting opens a project in the single file format.

Switch the screen by clicking the  button to open the existing project in the workspace 
format.

• A programmable controller type and a title are not displayed on the Open screen in the single file format.
• If the file save destination path is long, the "Look in" field may be left blank when opening a project in the single file 

format. Even with the blank field, the selected folder/file can be opened normally.
● Projects saved on the network drive or the removal storage device

Do not open the project directly. Open it after saving it to the hard disk of the personal computer.
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4.2.3 Saving projects

Save a project on a personal computer or another data storage device.

■ Saving projects under the specified name

Save the open project under the specified name.

Screen display
Select [Project] ⇒ [Save As].

Operating procedure

1. Set the items on the screen.

2. Click the  button.
The project is saved in the specified folder under the specified workspace name, project name, and 
title.

Remote HeadQ CPU L CPU FX

< Saving a project in the workspace format > < Saving a project in the single file format >

Item Description

Save Location
Enter the folder (drive/path) where the workspace is saved.
The folder can be selected in the Browse For Folder screen by clicking the 

 button.

Workspace/Project List Select the workspace or project.
The display is switched to the project list by double-clicking "Workspace".

Workspace Name Enter the workspace name.

Project Name Enter the project name.

Title Enter the title of the project.

Include revisions*1 Select this to succeed and save the project revision information.
(Section 4.6)

Include security*1 Select this to succeed and save the security information of the project.
(Section 4.10)

*1 : This setting can be set only when saving the already existing project with another name.
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Screen button

●

Displays the Browse For Folder screen.

●

Switches to the Save As screen in the single file format.

●

Switches to the Save As screen in the workspace format.

● When saved workspace exists
When the saved workspace or project exists, a folder to which the workspace is saved can be specified from 
"Workspace/Project List".

● Number of characters used for workspace name, project name, and title
The total number of characters used for the path name of the folder to which the project is saved, workspace name, and 
project name should not exceed 200 characters.
A title can be entered within 128 characters.

● Saving a project contains Structured Ladder programs
If multiple Structured Ladder editors are opened, the project may not be able to be saved.
In this case, start another GX Works2 and save the project by copying all data to the newly-created project. 
(Section 4.3.2 "Copying/pasting data in projects")

● Save As screen
• The Save As screen with the initial setting saves a project in the single file format.

Switch the screen by clicking the  button to save the project in the workspace format.
• If the file save destination path is long, the "Save in" field may be left blank when saving a project in the single file 

format. Even with the blank field, the selected folder/file can be saved normally.

■ Saving projects

Overwrite and save the project being edited.

Operating procedure

• Select [Project] ⇒ [Save] ( )
The data to be saved is overwritten on the existing project data.

● Registering project revision when overwriting
By setting the option, the Revision Entry screen for registering the project revision is displayed when overwriting the 
project.
To display the Revision Entry screen when overwriting the project, select [Tool] ⇒ [Options] ⇒ "Project" and then 
select "Revision is Registered when Save Project" in "Change History". In addition, the revision title can be 
automatically set when overwriting by selecting "Automatically set revision titles".
(For details of project revision history Section 4.6)

● Compilation status is not saved by overwriting data
Performing compilation only and overwriting the project, and then opening the project again may cause the project to be 
in an uncompiled status.
In this case, overwrite the uncompiled project without performing compilation to save the compilation status normally.
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4.2.4 Saving projects with compression and decompressing 
projects

Save projects with compression, and decompress projects saved with compression.
Files can be saved with their sizes reduced by compressing the project. Files can also be saved by 
separating them in specific sizes. These functions produce easier project data passing.
These functions are not compatible with commercially available file compression and decompression 
tools.

■ Saving projects with compression

Save a desired project with compression.

Screen display
Select [Project] ⇒ [Compress/Unpack] ⇒ [Compress].

Operating procedure

1. Set the items on the screen.

Remote HeadQ CPU L CPU FX

Item Description

Choose a Workspace to Compress

Workspace Location
Enter the folder (drive/path) where the workspace is saved.
The folder can be selected in the Browse For Folder screen by clicking the 

 button.

Workspace/Project List Select the workspace and project.

Workspace Name Display the selected workspace name.

Project Name Display the selected project name.

Choose a Destination Folder

Compressed File Name

Enter the folder where the compressed file is saved, and the compressed file 
name.
The compressed file name can be specified in the Compressed File Name screen 

by clicking the  button.

Include revisions Select this to succeed and save the project revision information.
(Section 4.6)

Split into volumes of the 
following size

Select this to save data in multiple compressed files. Specify the split size in the 
range from 1 to 999MB.
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2. Click the  button.
The compressed project file (*.gwz) is saved in the specified folder.

■ Decompressing projects saved with compression

Decompress a project saved with compression.

Screen display
Select [Project] ⇒ [Compress/Unpack] ⇒ [Unpack].

Operating procedure

1. Set the items on the screen.

2. Click the  button.
The compressed project file is decompressed and saved in the specified folder.

Screen button

●

Decompresses a compressed project file and opens the project.

Item Description

Choose a File to Unpack

Compressed File Name

Enter the folder (drive/path) in which the compressed file to be decompressed is saved, 
and the compressed file name.
The compressed file name can be specified in the Compressed File Name screen by 

clicking the  button.

Choose a Destination Folder

Workspace Location
Enter the folder (drive/path) to which the project to be decompressed is saved.

The folder can be selected in the Browse For Folder screen by clicking the  
button.

Workspace/Project List Select the workspace and project.

Workspace Name Enter the name of the workspace to which the decompressed project is saved.

Project Name Enter the name of the project to which the decompressed project is saved.
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● Decompressing compressed files
A compressed file can also be decompressed on the Unpack screen which is displayed by double-clicking the 
compressed file (*.gwz) on Windows® Explorer.

● Names of divided compressed files
When a project is saved in divided compressed files, a number is automatically added after the extension in each name 
of the second or later compressed files as shown below.

● Decompressing divided compressed files
Select the first file (*.gwz) when decompressing a series of divided compressed files. To be decompressed, all of a 
series of divided files must be in the same folder.

4.2.5 Deleting projects

Delete a project saved on a personal computer or another data storage device.

Operating procedure

1. Select [Project] ⇒ [Delete].
The Delete Project screen is displayed.

2. Select the project to be deleted.

3. Click the  button.
The selected project is deleted.

● Deleting projects
• Once a project is deleted, it cannot be restored again.
• The open project cannot be deleted. Delete the project after closing it.
• Projects that can be deleted using this function are the projects saved in the workspace format only.

Delete projects saved in the single file format using Windows® Explorer.

Name of the first file
Name of the second file
Name of the third file
Name of the fourth file

Remote HeadQ CPU L CPU FX
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4.2.6 Closing projects

Close an open project.

Operating procedure

• Select [Project] ⇒ [Close].

4.2.7 Verifying project data

Verify data of an open project against data of another project.
Verification can be performed only when the programmable controller type and project type of the two 
projects are the same.
This function is used to compare the contents of two projects or to locate program changes made in 
projects.
To verify data against data on the programmable controller CPU, use the Verify with PLC function. 
(Section 12.2)
The following data can be selected as verification targets for the project verification.
• Programs
• Parameters
• Intelligent function module parameters (initial setting/auto refresh)*1

• Device comments
• Device memory data
• QD75/LD75 positioning module*1

*1 : Not supported by FXCPU.

Screen display
Select [Project] ⇒ [Verify].

Remote HeadQ CPU L CPU FX

Remote HeadQ CPU L CPU FX



4 - 20

GX Works2

4  PROJECT MANAGEMENT

4.2.7  Verifying project data

Operating procedure

1. Click the  button to set the verify destination project.

2. Set the items on the screen.

3. Click the  button.
The verification result is displayed on the Verify Result screen.
■ Checking verification result details

Screen button

●

Selects all the data displayed in the project data list.

●

Cancels the selection status of all the data selected in the project data list.

●

Updates the data displayed in the project data list.

Item Description

Verify Destination 
Project

Workspace Location Display the path to the workspace of the verify destination.

Workspace Name
Display the workspace name of the verify destination.
This field will be blank when a project in the single file format is 
specified for the verify destination project.

Project Name Display the project name of the verify destination.

Title Display the project title of the verify destination.

Item Description

<<File Selection>>
Verify Source Display project data of verify source (data being edited).

Selects the data in the project data list.

Verify 
Destination

Display project data of verify destination (saved project data).
Selects the data in the project data list.

<<SFC Block Selection>>*1,*2

Select SFC blocks in the SFC Block list.

<<Parameter>>*2

Select the parameter verification level.
■ Verifying parameters

*1 : Simple projects only
*2 : Not supported by FXCPU.
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● Verifying programs
The verification function verifies the data created by the compilation. If the program is edited after the compilation, 
compile the program again before performing the verification.

● Data names of verification target data
When multiple data are selected for verification, verification is performed between the source and destination data with 
the same name. However, device comments are verified only when their data names are same.
When only one source program is verified against one destination program, verification can be performed even with 
different names.

● Security status of project
Projects to which the security is set can be verified when both verify source data and verify destination data are not 
read-protected.

● Verifying intelligent function module parameters (initial setting/auto refresh)
Among modules without initial setting such as QD75/LD75 positioning modules, serial communication/modem interface 
modules, and AS-i master modules, only modules in which the auto refresh is set are the verification targets.

● Verifying QD75/LD75 positioning modules
One module each for verify source and verify destination can be selected.
The following data can be selected as verification targets.
• Parameter
• Servo parameter (For QD75M/MH only)
• Positioning data (Except for positioning comments and M code comments)
• Block start data
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■ Verifying parameters

The verification level can be selected when verifying parameters.

The following table shows the verification details for each setting item.

● Mismatch in the system setting area
When a mismatch is detected in the parameter area set by the system in the verification set to "All 
Area", either of the following messages is displayed.
Take corrective action according to the message.

Item Description

User Setting Area Only Verify only the parameter area set by the user.

All Area Verify all the area including the parameter area set by the system.

Message Corrective action

The header information of the 
parameter blocks is inconsistent.

A mismatch is detected in other than user setting area.
Write the parameters, having been written to the programmable controller CPU, to 
the programmable controller again.
When a mismatch is detected on the block number AFFF, perform the following 
operation to reset the area which is set by the system.
• Select Project view ⇒ Parameter ⇒ Network Parameter ⇒ Ethernet/CC IE/

MELSECNET. Click the  button on the displayed MELSECNET/CC IE/
Ethernet Module Configuration screen and write the parameters to the 
programmable controller CPU.

This parameter block can't analyze.
Versions of GX Works2, GX Developer, or GX IEC Developer used to create the 
projects differ between the verify source and the verify destination.
The programmable controller CPU operation is not affected.
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■ Checking verification result details

Details of mismatched data can be checked on the <<Verify Result List>> tab on the Verify Result 
screen.
Details of program verification result can be checked for ladder programs only.
For FXCPU, when a block password with the validated setting for "Read-protect the execution 
program" exists, matches and mismatches of the program file verification are displayed, however, a 
jump to the detailed verify result cannot be performed.

Operating procedure

1. Double-click the row of the data to display the details of the Verify Result screen.
The following are screens of project with labels.

2. Set the item on the screen.

3. Select [Find/Replace] ⇒ [Next Unmatch] ( )/[Previous Unmatch] ( ).
The cursor can only be placed on the rows with mismatches.

Item Description

Do not move cursor at [Next 
Unmatch]/[Previous Unmatch] 
when devices are within the 
automatic-assign range for the 
row shows devices 
unmatched*1

The following are the operations when searching for the result using the [Next Unmatch] 
( )/[Previous Unmatch] ( ) function.
• When this item is selected

Among the rows with mismatches, the cursor skips the rows whose mismatched 
devices are within the range of devices automatically assigned to labels.
This function excludes the rows with devices reassigned to other devices when a 
program is compiled.

• When this item is not selected
The cursor can be placed on all rows with mismatches.

*1 : For projects with labels only



4 - 24

GX Works2

4  PROJECT MANAGEMENT

4.2.7  Verifying project data

● Detail Verify Result tabs
• The tab order can be changed by drugging and dropping <<Detail Verify Result>> tabs.
• The screen returns from the <<Detail Verify Result>> tab to the <<Verify Result List>> tab by selecting [View] ⇒ 

[Return to Result List] ( ).

• The selected <<Detail Verify Result>> tab can be closed by selecting [View] ⇒ [Close Detail Result] ( )/[Close All 
Detail Result] ( ).

● Verifying device memory data
Device memory data are verified with the actual values.
Even when the display formats of data are different on the device memory editor, the verification result on the same 
value will be a match.
For FXCPU, the verification result is as follows:
• a result of internal relay (M) verification includes special device M.
• a result of data register (D) verification includes file register and special device D.

● Devices to which a value is not set on the device memory editor
Devices to which a value is not set on the device memory editor are verified as a value 0.
Therefore, if 'device memory data to which devices are not set' and 'device memory data to which devices are entered 
without setting device values' are verified, the verification result will be a match.

● Direct input (DX) and direct output (DY)
When verifying device comments or device memory data, check the verification result with input (X)/output (Y) for direct 
input (DX)/direct output (DY).

● Number of verification results displayed
If the number of mismatches exceeds 1,000, up to 1,000 mismatch results are displayed and verification is suspended 
after that.
For a ladder program of program (program file) and POU, since the function determines the difference of the number of 
lines between the verify source and the verify target in the list format as a mismatch, the verification is canceled in the 
middle of the process even before reaching 1,000 mismatches and the rest of the program is determined as a 
mismatch. The remaining part needs to be verified again after modifying the mismatched data.

● Copying verification results
Verification results can be copied and pasted to a text file. Select rows of verification result to be copied, and select 
[Edit] ⇒ [Copy].
The copied data are pasted on a text file as data separated by tabs.

● Jumping from verification result
When "Enable calling function block and using inline ST" is selected under [Tool] ⇒ [Options] ⇒ "Compile" ⇒ "Basic 
Setting", function block program items with no difference may be indicated as a mismatch on the Verify Result screen.
In this case, check the mismatch part by any of the following methods.
• Checking labels/devices set to input/output variables of function block

Open the source program from which function blocks are called, and check labels/devices.
• Checking mismatch parts with the program verification result

Select items as shown below to verify programs.

Verify

< Verification result >

< Device memory data to which devices are not set > < Device memory data without setting device values >
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● Jumping from verification result of intelligent function module parameter (initial setting/auto refresh)
When different modes are set to the verify destination and the verify source for auto refresh of temperature control 
module, jumping to verification result is not performed.
For setting the auto refresh of temperature control module, refer to the following manual.
GX Works2 Version 1 Operating Manual (Intelligent Function Module)

■ Checking method when verify source data are modified

Updated verify source data are displayed in the verification result.
Therefore, the verification result of updated verify source data can be checked without executing the 
verification function again when mismatched data is modified.
Even when a data name of verify source is changed, the changed data name is displayed in the 
verification result.

Operating procedure

1. Modify the verify source data.

2. Open the <<Verify Result List>> tab or the <<Detail Verify Result>> tab on the Verify 
Result screen.

3. Double-click the modified data on the <<Verify Result List>> tab or the <<Detail 
Verify Result>> tab.
The updated data is displayed in the verification result.
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■ Writing verification results to CSV files

Output data displayed on the Verify Result screen to a CSV file.

Operating procedure

1. Select [Edit] ⇒ [Write to CSV File] ( ).
The Write to CSV File screen is displayed.

2. Enter a file name.

3. Click the  button.
The verification results are saved on a personal computer.

● Formatting CSV file
The saved CSV file is displayed as shown below when it is opened by Excel.
<Display of the Verify Result screen>

<CSV file>
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4.2.8 Changing programmable controller type of projects

*1 : CC IE Field head module only

Change the programmable controller type of a project being edited.

Screen display
Select [Project] ⇒ [Change PLC Type].

Operating procedure

1. Set the items on the screen.

2. Click the  button.

The following confirmation message is displayed. Click the  button to execute the 
function.

HeadQ CPU L CPU FX
*1

Remote

Item Description

PLC Series Select the programmable controller series after change.

PLC Type Select the programmable controller type after change.
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● Changing programmable controller type of projects which contain intelligent function modules (For QCPU (Q 
mode)/LCPU/CC IE Field head module)
Basically intelligent function modules are deleted after the programmable controller series is changed, but certain 
intelligent modules can be changed to those which are applicable to the programmable controller series after change.
For details of the shift of models of intelligent function modules associated with change of programmable controller 
series, refer to the following section.
■ Changing intelligent function modules between programmable controller series

To change the model of an intelligent function module, select a module name in "Module Name After Change" on the 
following screen displayed at changing the programmable controller type.
To delete all intelligent function modules, select "Delete all after changing intelligent function module".

● List of modifications (For QCPU (Q mode)/LCPU/CC IE Field head module)
After the Change PLC Type function is completed, the following List of Modifications screen is displayed, and the 
changes of the program and parameters can be checked.
The items in the following screen can be copied and pasted to the text file using the + and + keys.
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● Restrictions on the Change PLC Type function execution
For the restrictions on the Change PLC Type function execution for each programmable controller series, refer to 
Appendix 10.

● Interruption of processing
If the project of change source includes the data which is neither supported nor able to be modified by any editing 
operations with the project of the programmable controller type after change, the processing is interrupted. If this 
happens, modify the data first to correspond with the programmable controller type after change, and then execute the 
Change PLC Type function.

● Execution failure of the Change PLC Type function
The Change PLC Type function cannot be executed in the following cases:
• During the execution of the monitoring function such as program monitoring and device/buffer memory batch 

monitoring.
• Security is set for the open project and the user does not belong to the 'Administrators' group.
• During the execution of the simulation function.

● Data before changing the programmable controller type
Restoring the data, after executing the Change PLC Type function, to the data before change is not possible. Execute 
the function after saving the project data. In addition, note that the project is in the unsaved status after the function 
execution.
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■ Changing intelligent function modules between programmable controller 
series

Basically intelligent function modules are deleted after changing the programmable controller series, 
but a part of intelligent modules can be changed to those which are applicable to the programmable 
controller series after change.
The following table shows modules which can be changed.

Module type
Module name

QCPU (Q mode) LCPU/CC IE Field head module

Analog

Q64AD
Q68ADV
Q68ADI
Q64ADH

L60AD4

Q62DAN
Q64DAN

Q68DAVN
Q68DAIN

L60DA4

Temperature control

Q64TCTTN L60TCTT4

Q64TCTTBWN L60TCTT4BW

Q64TCRTN L60TCRT4

Q64TCRTBWN L60TCRT4BW

Counter QD62
QD62D

LD62
LD62D

QD75/LD75 positioning

QD75P1
QD75P2
QD75P4

QD75P1N
QD75P2N
QD75P4N
QD75D1
QD75D2
QD75D4

QD75D1N
QD75D2N
QD75D4N

LD75P1
LD75P2
LD75P4
LD75D1
LD75D2
LD75D4

Serial communication/
Modem interface

QJ71C24N
QJ71C24N-R2

LJ71C24
LJ71C24-R2

AnyWireASLINK interface QJ51AW12AL LJ51AW12AL
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■ Detailed replacement method screen for changing CPU to Universal model 
QCPU

In GX Works2 with the installed QnH -> QnU Conversion Support Tool, the methods for replacing 
instructions and parameters can be displayed from the List of Modifications screen when the 
programmable controller type is changed from Basic model QCPU or High Performance model QCPU 
to Universal model QCPU.

Operating procedure

1. Click the  button.

2. Specify the project before changing the 
programmable controller type, and click 
the  button.

The overview of the replacement method regarding 
instructions and parameters which are changed by the 
PLC type change function can be checked on the 
displayed Detailed replacement method screen.
The Web browser is activated by clicking the link to 
check details of settings. Adobe® Reader® is required 
to view the detailed information.

3. Click the  button to 
search the instruction/device to be replaced.
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4. Replace the instruction/device by following the 
instruction on the <<Replacing Procedure>> 
tab.
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4.3 Operations of Programmable Controller CPU Data

This section explains how to operate each data in a project.

4.3.1 Adding new data to project

Add new data to a project.
The data that can be added differs according to the type of programmable controller or project.

Screen display
Select [Project] ⇒ [Object] ⇒ [New].

Operating procedure

1. Set the items on the screen.

Q CPU L CPU FXFXRemote FXHead

Item Description

Data Type Select the type of the data to be added.

Data Name Enter the name of the data to be created.

Program Language
Select the programming language for creating programs.
Selection is allowed only when the data type is any of the following:
• Program (program block), Function*1 or Function block*2.

Result Type*1 Set the data type of return value of the function.

Inherent Property*1
This item can be set when a function or function block is selected.
For details of check box items, refer to the following manual.
GX Works2 Version 1 Operating Manual (Structured Project)

*1 : For Structured projects only
*2 : For Simple projects (with labels) and Structured projects only
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2. Click the  button.
The editing screen for the created data is displayed.

● Number of characters for a data name
The numbers of characters shown in the following table can be used for data names according to the selectable data 
type.
However, some operators such as "-" and "*", and some instruction names such as "MOV", cannot be used. For details 
of the characters which cannot be use for data names, refer to Appendix 9.

● Maximum numbers of data types that can be created
The table below indicates the maximum numbers of data types that can be created.

● FXCPU
For FXCPU, the data of device initial values cannot be created.

Data type name Number of characters

Program (program file), local device comment, device 
memory, and device initial value 8 characters

Other data types 32 characters

Data type name Maximum number

Connection destination 128

SFC block in Simple project*1

*1 : SFC of Simple projects (with labels) is not supported by FXCPU.

320 (128 for Q00UJ/Q00U/Q01U/Q02U, 25 for FXCPU)

Program in FXCPU Simple project (with labels) 64

Other data (structures, global labels, etc.) 800
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4.3.2 Copying/pasting data in projects

Utilize data of a project being edited or other projects.

Operating procedure

1. Select a data name to be copied on the Project view.

2. Select [Project] ⇒ [Object] ⇒ [Copy].
The selected data name is copied.

3. Select a folder to paste the data name on the Project view.

4. Select [Project] ⇒ [Object] ⇒ [Paste].
If the same data name exists in the folder where the data is to 
be pasted or when the data name cannot be used for the 
project of the folder where the data is to be pasted because of 
the different project languages, the Data Paste screen is 
displayed.

5. Enter a new name in the "Data Name After Paste" field, and click the  
button.
The data name is pasted.

Remote HeadQ CPU L CPU FX

Select a folder
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● Copying/pasting data
• Data can be pasted only to the data that is of the same type as copied data. Data between different projects can be 

copied/pasted only when their project types or programmable controller types are the same.
• Multiple data can be copied by holding the  or  key and selecting the data.
• Data can be copied/pasted by right-clicking data to be copied/folder to be pasted and selecting [Copy]/[Paste] from 

the shortcut menu, or by dragging and dropping the data from the data to be copied to the folder to be pasted.
• The program is in an uncompiled status after data are pasted. Compile the program again.
• For projects with security, only users whose access level is 'Administrators' can copy/paste data.
• Copying and pasting PLC parameter or network parameter only are not possible. If they are copied individually, the 

whole parameter files are copied and the files in the folder where the data is to be pasted are overwritten.
• Pasting of global label data is canceled when the maximum number of labels described below is exceeded. Adjust 

the number of global labels in the copy destination and the copy source, and retry pasting data.
• Global label (within a project): 20480
• Global label (within a user library): 20480

● Copying/pasting tasks in Structured project
When tasks are pasted, the number of programs that can be set on the Task Setting screen may be exceeded. Compile 
the program and delete the unnecessary programs.
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4.3.3 Changing project data names

Change the data name of an open project.

Operating procedure

1. Select the data name to be changed on the Project view.

2. Select [Project] ⇒ [Object] ⇒ [Rename].

3. Change the data name.

4. Press the  key.
The selected data name is changed.

4.3.4 Deleting project data

Delete data in an open project.

Operating procedure

1. Select the data name to be deleted on the Project view.

2. Select [Project] ⇒ [Object] ⇒ [Delete].
The selected data is deleted.

● Deleting data
• Multiple data can be selected and deleted.
• When data under the POU are deleted, data under the Program Setting are deleted simultaneously.

Q CPU L CPU FXFXRemote FXHead

Q CPU L CPU FXFXRemote FXHead
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4.3.5 Merging data

Merge ladder programs or device comment data of multiple projects, and add them to a project.
When the programmable controller series of the projects are the same, data can be merged even if 
data's programmable controller types or project types are different.

Screen display
Select [Tool] ⇒ [Merge Data].

Operating procedure

1. Select the data type to be merged.

Q CPU L CPU FXFXRemote FXHead

Order of selection 

on the Merge Data 

screen.

END instruction

Remove the END instructions, 

and merge ladder programs by 

the order of selection.

END instruction 
appended

< Image of merging programs >

MAIN 1

MAIN 2

MAIN 3

MAIN 1

MAIN

MAIN 2

MAIN 3

END instruction

END instruction

Item Description

Data Type Specify the data type to be merged.

Ladder Program Select this to merge ladder programs.

Device Comment Select this to merge device comments.
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2. Set the items on the screen.

3. Click the  button.
Data of "Target Data List" are merged and added to the project.

Screen button

●

Adds data selected in "Source Data List" to "Target Data List".

●

Adds all data displayed in "Source Data List" to "Target Data List".

●

Deletes data selected in "Target Data List".

●

Deletes all data displayed in "Target Data List".

●

Displays the Set Range screen.
Set the range of programs selected in "Target Data List".
The range cannot be set when the source project or the target project is a project with labels.

Item Description

Source Data –

Source Project Click the  button, and specify the source project.

Workspace Location Display the path to the workspace of the source project.

Workspace Name
Display the workspace name of the source project.
This field will be blank when a project in the single file format is specified for the source 
project.

Project Name Display the project name of the source project.

Title Display the project title of the source project.

Source Data List

Display programs or device comments of the source project.
Select data to be merged.
Programs which contain function blocks or inline structured text programs are not 
displayed.

Target Data List Display data to be merged. Up to 128 data can be displayed.
Data are merged in the displayed order.

Data Name after Merging –

Data Name Specify a data name after merging.
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●

Displays the Options screen.
Select the processing for label/device comment duplication when merging programs or device 
comments of projects with labels.

● Data to be merged
• Data saved on a personal computer are merged. Save the project data being edited in order to merge them.
• If the merged data exceeds the program capacity, the data are merged within the program capacity.

Example) When merging three programs: MAIN1, MAIN2, and SUB3
In the setting of the following screen, the programs are merged from MAIN1. After merging MAIN1 and 
MAIN2, if the result of merging SUB3 exceeds the program capacity, only MAIN1 and MAIN2 are 
merged.

● Merging program data when the target project is a project without labels
When the target project is a project without labels, data of program with labels are merged as a program of actual 
devices. Furthermore, uncompiled programs in a project with labels of source project are not displayed in "Source Data 
List".

● Merging data during monitoring
Data cannot be merged during monitoring. Stop monitoring to merge data.

● Merging programs
When the programmable controller types of the source project and the target project are different, instructions and 
devices which cannot be used for the programmable controller type of the target project are merged as the way they 
are.
Check the merged program for errors with the program check function or the compilation.
For projects with labels, the local label settings are also merged when programs with labels are merged. However, 
since the global label settings are not merged, set labels after programs are merged, or copy the global label data from 
the source project.

< Program of project with labels > < Device comment >
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4.3.6 Displaying/editing properties

Display data properties of folders, parameters, and programs. A title and/or comment can be set to 
each data.

Screen display
● For property of project

Click  on the Project view.
● For property of each data

Select [Project] ⇒ [Object] ⇒ [Property] ( ).

Operating procedure

• Set the items on the screen.

Remote HeadQ CPU L CPU FX

<<Detail>> <<Comment>>

Item Description

Data Name Display the data name.

Title*1, *2 Set a title for the data.
(The number of applicable characters is 128 for a project and 32 for other data.)

Last Change*1 Display the date when the data was updated.

Comment*1
Set a comment for the data.
Press the  and  keys for a line feed.
(The number of applicable characters is 5,120.)

*1 : For FXCPU Simple project (with labels), "Title", "Last Change", and <<Comment>> tab are not supported by the 
property of "MAIN" under Project view ⇒ "Program Setting" ⇒ 'execution program'.

*2 : For titles of programs that are read from/written to a programmable controller CPU along with the program data, 
refer to Point in this section.
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● Titles
Set titles are displayed on each view with a corresponding data name.
For SFC project without labels, a device comment of BL device corresponds to the SFC block becomes a title. When 
the device comment of the reference target is read-protected by the security setting, the title is not displayed on the 
view.

Titles of programs that are read from/written to a programmable controller CPU along with the program data are titles of 
data created for each execution type in the program setting. Those titles are displayed on the Online Data Operation 
screen when reading/writing data from/to a programmable controller CPU.

● Properties of Structured projects
Properties of the following data can be set for Structured projects in addition to those indicated above.

For details, refer to the explanations of each function.
(GX Works2 Version 1 Operating Manual (Structured Project))

● Destinations for saving properties
The 'titles' and 'comments' set to the data properties can be saved as symbolic information.
(Section 12.1.5)
When reading data from the programmable controller CPU, the symbolic information must be written to/read from the 
programmable controller CPU in order to restore the settings of the properties.
When data are read without the symbolic information from the programmable controller CPU, the settings of the 
properties are not restored.

Data Setting

Task Priority and executing condition of a task

Function/Function block Whether to use EN/ENO, or MC/MCR for EN control

Library Path to a help file
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4.4 Operations of Intelligent Function Module Data

For the method for setting the intelligent function module data, refer to the following manual.
GX Works2 Version 1 Operating Manual (Intelligent Function Module)

Remote HeadQ CPU L CPU FXFX
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4.5 Changing Project Types

This section explains how to change the type of an open project.
Using the method explained below, the type of a Simple project is changed from 'without labels' to 
'with labels'. In addition, a Simple project 'with labels' can be changed to a Structured project.
Changing from a Simple project 'with labels' to a Simple project 'without labels' or changing a 
Structured project to a Simple project is not supported.

*1 :  Not supported by FXCPU.

Operating procedure

• Select [Project] ⇒ [Change Project Type].

● Changing project types
When a Simple project (with labels) is changed to a Structured project, project data are stored in the following folder.
• SFC: Created under the Program folder.
• Function block: Created under the FB/FUN folder.

● Operation after changing project type
When the project type is changed, programs are in the uncompiled status.
Compile all programs again after changing the project type. (Section 5.4)

Q CPU L CPU FXFXRemote FXHead

Simple project
 'without labels'

Simple project
'with labels'

Structured project

*1

<Simple project (with labels)> <Structured project>

Created under 

the Program folder

Created under 

the FB/FUN folder

Change the type of the project
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4.6 Managing Project Revisions

This section explains how to register a backup of the project with added revision information, and 
restoring the registered backup data (content of the past project).

4.6.1 Registering revision information (creating backup)

Create a backup of the project at the point of registration, and register it with the revision information.

Screen display
Select [Project] ⇒ [Project Revision] ⇒ [Revision Entry].

Operating procedure

• Set the items on the screen.

Remote HeadQ CPU L CPU FX

Item Description

Revision No. Display the revision number to be registered.

Date Display "--/--/---- --:--:--" (month/date/year hour:minute:second).

User Display the user name when using the project with security.

Title Enter a title of the revision.

Comment Enter comments for the revision.
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4.6.2  Displaying revision list

● Revision number and the allowable number of revisions that can be registered
A revision number for the registered revision is automatically assigned from 1 to 9999.
The maximum number of revisions that can be registered is 100. If the number of the registered revisions is to be 
exceeded 100, delete unnecessary revisions. The deleted revision numbers are unused.
If the revision number is to be exceeded 9999, delete all the revision data, or save the project with a different name 
without succeeding the revision information. (Section 4.2.3)

● The allowable number of characters that can be entered for a title
The maximum number of characters that can be entered for a title is 32.

● The allowable number of characters that can be entered for a comment
The maximum number of characters that can be entered for a comment is 256.
A line feed is handled as 2 characters.

● Registration of project revisions when overwriting and saving projects
By setting the option, the Revision Entry screen for the project revision is displayed when overwriting and saving the 
project.
Select [Tool] ⇒ [Options] ⇒ "Project", and then select "Revision is Registered when Save Project" in "Change History". 
In addition, the revision title can be automatically set when overwriting by selecting "Automatically set revision titles".

● Registration of project revisions for projects with security
For the projects with security, the revisions can be registered only when the user's access level is 'Administrators'.

4.6.2 Displaying revision list

Display registered revision information in the order of the revision number.
The revision list is used for registering, restoring, deleting, and verifying backups.

Screen display
Select [Project] ⇒ [Project Revision] ⇒ [Revision List].

Display contents

Item Description

No. Display the revision numbers.

Date Display the dates of revision registration.

User For the projects with security, display the user names who have registered the revisions.

Title Display the titles of the revisions.
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Screen button

●

Displays the detailed information of the revision which is selected in the list. "Title" and "Comment" 
can be edited.

●

Registers the project being edited as a revision. (Section 4.6.1)

●

Restores the backup data. (Section 4.6.3)

●

Deletes the revision information. (Section 4.6.4)

●

Verifies the revision with other revisions or the projects being edited. (Section 4.6.5)

● Revision List screen
Each column can be sorted in ascending/descending order by clicking on the column header.

4.6.3 Restoring backup projects

Restore the backup revision information.
After restoring the backup, the project is in the status at the time of registering the revision information.

Operating procedure

1. Select the revision to be restored on the Revision List screen (Section 4.6.2).
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4.6.3  Restoring backup projects

2. Click the  button.
The revision information to be restored is displayed.

3. Confirm the revision information to be restored. Click 
the  button.
The message as shown on the right is displayed.

4. Click the  button.
The backup of the selected revision information is restored.
The revision number and title of the restored project are displayed on the title bar.

● The Revision List screen after restoring a project
After project restoration,  is displayed on the row of the restored project on the Revision List screen.

● Access level to be able to use the restoring function when using the projects with security
For the projects with security, the revisions can be restored only when the user's access level is 'Administrators'.

● Revisions for the project with security
If the project being edited is the project with security, the registered security in the revision is deactivated when the 
security is deactivated. When the revision is restored in such situation, since the project is restored without security, all 
users can read the project including the revision data.
To protect the revision data after deactivating the security, delete the revision data in advance.

● Considerations for restoring projects
Register the revision of the project being edited before restoring a project.
When the other revision is restored and overwritten without registering the revision of the project being edited, the 
project before restoration is overwritten.

Revision number and title 

of the restored project.
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4.6.4 Deleting revision information

Delete the registered revision information.

Operating procedure

1. Select the revision information to be deleted on the Revision List screen 
(Section 4.6.2).

2. Click the  button.
The message on the right is displayed.

3. Click the  button.
The selected revision information is deleted.

● Revision number
The deleted revision numbers are unused.

● Revisions being restored
The revision of the project which has been restored from the revision cannot be deleted. To delete the revision, 
overwrite and save the project after restoring it.

4.6.5 Verifying revisions

Verify the revision information with other revision information or the project being edited.
The following data can be selected as verification targets for the revision verification.
• Programs
• Parameters
• Intelligent function module parameters (initial setting/auto refresh)*1

• Device comments
• Device memory data
• QD75/LD75 positioning module*1

*1 : Not supported by FXCPU.
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4.6.5  Verifying revisions

Operating procedure

1. Select the revision to be verified on the Revision List screen (Section 4.6.2).
When the verification function is performed selecting only one revision, the selected revision 
information is verified with the project being edited.
To verify two revisions, select two revisions with pressing the  key or  key.

2. Click the  button.
The message as shown on the right is displayed.
This message is displayed when verifying the selected 
revision information with the project being edited.

3. Click the  button.
The Revision Verification screen is displayed.

4. Select the data to be verified.
For details of setting items, refer to the project 
verification. (Section 4.2.7)

5. Click the  button.
The verification result is displayed on the Verify Result screen.
For details of the Verify Result screen, refer to the project verification.
(Section 4.2.7)
The following is a screen of project with labels.
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4.7 Utilizing Projects and Data in Other Formats

This section explains how to utilize projects created with GX Developer or GX IEC Developer, and files 
(ASCII files) created using the Export function of GX IEC Developer in GX Works2. Projects edited with 
GX Works2 can also be utilized in GX Developer.

■ Utilizing projects and data created with GX Developer or GX IEC Developer 
in GX Works2

Projects created with GX Developer or GX IEC Developer can be utilized in GX Works2 by using the 
'Open Other Project' function. (Section 4.7.1)

Project created with 
GX Developer

Project created with GX 
IEC Developer

Open Other Project function.

Open Other Project function.

Opened as a GX Works2 project.
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■ Utilizing files created using the Export function of GX IEC Developer

ASCII files created using the Export function of GX IEC Developer can be added as projects in GX 
Works2 by using the 'Read ASC Format File' function. (Section 4.7.2)

■ Utilizing projects and data created with GX Works2 in GX Developer

Files created/edited in Simple project with GX Works2 can be utilized in GX Developer by using the 
'Export to GX Developer Format File' function. (Section 4.8)

Read ASC
Format File

[Export to GX Developer
 Format File]
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■ Storage of utilized data in GX Works2

Each project and data created with GX Developer or GX IEC Developer are stored in the areas shown 
in the table below with GX Works2.
GX Developer projects are opened as Simple projects and GX IEC Developer projects, as Structured 
projects.

● Comparison of projects and data storage locations between GX Developer and GX Works2

● Comparison of projects and data storage locations between GX IEC Developer and GX 
Works2

■ Security level of GX IEC Developer

The security level in the GX IEC Developer project is cleared after reading the project.
When the GX IEC Developer project is read using GX Works2, the following Enter Password screen is 
displayed.

■ Compatible applications

For 'Open Other Project' and 'Export to GX Developer Format File', the supported versions differ 
according to the CPU type.
For the application compatibility, refer to Appendix 5.

GX Developer GX Works2
(Simple project)

GX Works2
(Structured project)

Parameter Parameter Parameter

Device Comment Global Device Comment Global Device Comment

Global variables Global Label Global Label

Program Program POU

FB FB_Pool FB/FUN

Structure Structured Data Types Structured Data Types

Device memory Device Memory Device Memory

Device initial value Device Initial Value Device Initial Value

GX IEC Developer GX Works2 
(Structured project)

User Library User Library

Parameter (Programmable controller parameter) Parameter

DUT_Pool (Structure) Structured Data Types

Global_Vars (Global variable) Global Label

Task_Pool POU

POU_Pool POU
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4.7.1  Opening projects in other formats

4.7.1 Opening projects in other formats

Open a project created with GX Developer or GX IEC Developer in GX Works2.

Screen display
Select [Project] ⇒ [Open Other Data] ⇒ [Open Other Project].

Operating procedure

• Specify the project, and click the  button.
Select '*.gpj' for a GX Developer project and '*.pro' for a GX IEC Developer project.
The selected project is opened.

■ Considerations for opening projects in other formats

● Status after opening a different format project with labels
When a different format project with labels is opened, the project is in the uncompiled status. Compile 
all programs in the project before executing online operations such as writing data and monitoring.
When a compilation error occurs, correct the corresponding program according to the programming 
manual.

● When a programmable controller type of project which is created in GX Developer is not 
supported by GX Works2
Open the project by starting GX Developer.

● Opening different format projects that contain SFC programs
• Block information data such as: block information devices, block titles and block statements, are 

set in the block data property.
• When a GX Developer format project in which a ladder block contains an uncompiled SFC 

program is opened in GX Works2 Version 1.87R or later using the [Open Other Project] function, a 
'Block' with a corresponding block name sequence number may be missed.

RemoteQ CPU L CPU FXHead FX



4.7  Utilizing Projects and Data in Other Formats

4.7.1  Opening projects in other formats 4 - 55

1

O
V

E
R

V
IE

W

2

S
YS

TE
M

 
C

O
N

FI
G

U
R

A
TI

O
N

3

SC
RE

EN
 

CO
NF

IG
UR

AT
IO

N 
AN

D 
BA

SI
C 

O
PE

RA
TI

ON
S

4

P
R

O
JE

C
T 

M
A

N
A

G
E

M
E

N
T

5

ED
IT

IN
G

 
PR

O
G

R
AM

S

6

S
E

TT
IN

G
 

PA
R

A
M

E
TE

R
S

7

S
ET

TI
N

G
 D

E
V

IC
E

 
M

E
M

O
R

Y

8

S
E

TT
IN

G
 D

E
V

IC
E

 
IN

IT
IA

L 
V

A
LU

ES

● Opening different format projects that contain ST programs
Since the argument type or the number of arguments in some ST instruction is different between GX 
Developer and GX Works2, an error may occur at compilation. When a compilation error occurs, 
correct the instruction according to the structured programming manuals.
Note that, however, programs can be compiled in GX Works2 by setting the following option.
• Select "Use Dedicated Instruction for GX Developer, GX IEC Developer" under [Tool] ⇒ [Options] 
⇒ "Project" ⇒ "Common Setting".

● Setting common pointer number
When the common pointer number is not set in the PLC parameter setting of GX Developer, a 
compilation error may occur at the compilation after opening the project in other format. In such case, 
change "Common Pointer No." on the <<PLC System>> tab of PLC parameter or change the pointer 
device range in the "Device/Label Automatic-Assign Setting" function.

● Utilizing detailed settings for Write to PLC function
Values set in GX Developer are utilized to the secured steps for Online program change 
(Section 12.1.1) and the writing range of device comment (Section 12.1.3) which are set 
when writing data to programmable controller CPU.
Note that "PLC comment write format (CPU Format)" which is set along with the writing range of 
device comment in GX Developer is not utilized.
For a project in which the comment capacity is restricted by setting "PLC comment write format (CPU 
Format)" in GX Developer, the comment capacity may be exceeded when data are written to a 
programmable controller CPU using GX Works2.
In such a case, set "Comment Format (PLC Format)" (Section 12.1.3) or reduce the writing 
range of device comment.

● Utilizing option settings
GX Developer option setting "Copy source/display source of reference during comment edit" is 
utilized to GX Works2 option setting "Program Editor" ⇒ "All Editors" ⇒ "Device Comment" ⇒ 
"Reference of Device Comment".

● Opening a GX IEC Developer project
When a GX IEC Developer project that contains a user library is opened, the following message may 
be displayed and the user library may not be read. If the following message is displayed, select 
[Project] ⇒ [Library] ⇒ [Install] in GX Works2 to obtain the user library.

When a GX IEC Developer project is read by selecting [Project] ⇒ [Open Other Data] ⇒ [Open Other 
Project], intelligent function module parameters are not reflected.

● When a GX Developer data name contains a character that cannot be used in GX Works2
A GX Developer project with a GX Works2 invalid character can be opened.
Note that, however, the invalid character in the data is replaced by an underscore (_).*1 Change the 
data name after opening the project.

*1 : For FXCPU, data which contains invalid characters in its data name is not read.
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4.7.2  Reading ASC format data

4.7.2 Reading ASC format data

Add ASC format data created in GX IEC Developer to a GX Works2 project being edited.
Data can be added only when a new project is created or a project is opened in Structured project.

Screen display
Select [Project] ⇒ [Open Other Data] ⇒ [Read ASC Format File].

Operating procedure

• Specify the file, and click the  button.
Select '*.asc' for the file.
The specified data is added to the project.

● Importing project data of different programmable controller type
Project data having a different programmable controller type can be imported to a project being edited.
The programmable controller type of the project being edited is not changed even when data with the different 
programmable controller type are imported.
In this case, since instructions and devices not supported by the open project are also imported, compile the programs 
to check and correct errors after importing data.

● Importing data whose name already exists in the project
A number is appended in serial order (starting from one) to the end of the data name to be imported, and then the data 
is added to the project.

● Importing global labels
When the global labels are imported, the "Device" column of the global label may be blank. If the "Device" column is 
blank, check the items on the <<Device>> tab of PLC parameter.

● Importing FBD programs of GX IEC Developer
Imported FBD programs are converted to Structured Ladder programs.

Q CPU HeadRemoteL CPU FX
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4.8 Saving projects in other formats

This section explains how to save a Simple project of GX Works2 in the GX Developer format.

Screen display
Select [Project] ⇒ [Export to GX Developer Format File].

Operating procedure

1. Select the save destination of the GX Developer format project.

2. Enter the project name, and click the  button.

● Considerations for saving projects
For the restrictions other than the ones described below, refer to Appendix 8.
• Programs are saved in the uncompiled status.
• Data cannot be saved when the security access level is set to other than 'Administrators'. Change the access level 

before saving the data. (Section 4.10.4)
• The data with a block password cannot be saved. Unlock the block password before saving the data. 

(Section 4.12.3)
• Projects in which labels are used for FXCPU cannot be saved in the GX Developer format.
• When a GX Developer format project is saved to the folder in which a GX Developer format project with the same 

name exists, the previously saved project is overwritten.
If the saving of the project failed, all data except for the data created by user will be deleted.

● Considerations for handling projects in GX Developer
• Since the program is saved uncompiled, the program needs to be compiled when it is opened in GX Developer. For 

projects with labels, the compilation results and device assignment may be different from those of GX Works2.
• For a maintenance work on the same programmable controller CPU using both GX Developer and GX Works2, 

programming with actual devices is recommended.

Q CPU L CPU FXFXRemote FXHead
*1 *2

*1 : Not supported by High-speed Universal model QCPU
*2 : Not supported by L02S, L06 and L26.
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4.9 Starting GX Developer from GX Works2

Start a new GX Developer project from GX Works2.

GX Developer needs to be installed in advance to perform this function.
For details of GX Developer installation, refer to Appendix 14.
For details of GX Developer operation, refer to the following manual.
GX Developer Version 8 Operating Manual

Operating procedure

• Select [Project] ⇒ [Start GX Developer].

RemoteQ CPU L CPU FXHead FX
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4.10 Setting Security for Projects

This section explains how to set security for projects to protect the projects themselves and the data 
in projects.

Setting security not only restricts an access to projects but also prevents the data, such as POUs, 
device comments, and parameters, that are created by the user from erroneous modification and/or 
disclosure to unauthorized users.

This function cannot restrict writing/reading of data to/from a programmable controller CPU. Use the 
online password function to protect the data on a programmable controller CPU. (Chapter 13)

■ Access levels and access authority

An access to data can be restricted by setting an access level to the individual user.
An access level is an operating authority given to a login user of the project.
There are five access levels as shown below. The data that can be edited by a user having lower 
access level can also be edited by a user who has higher access level.

Example) The data with access authority of Developers (Level 2) can be edited by a login user 
whose access level is Developers (Level 2) or higher (Administrators, Developers (Level 
3) or Developers (Level 2)).

Remote HeadQ CPU L CPU FX

Access level Operating authority

Higher

Lower

Administrators <Administrator level>
All operations are possible.

Developers (Level 3)
<Developer level>
Security setting, data access, and a part of operations are restricted.Developers (Level 2)

Developers (Level 1)

Users
<Operator level>
Only access to project data is possible.
Data cannot be read from the programmable controller CPU.



4 - 60

GX Works2

4  PROJECT MANAGEMENT

■ Access authority applicable data

The following tables show the data to which access authority can be applied.

● Simple project
: Applicable ×: Not applicable

Items on Project view Read Write

Parameter  

Intelligent Function Module*1

*1 : Not supported by FXCPU.

× ×

Intelligent function module data  

Global Device Comment  

Global Label × ×

Global label data × 

Program Setting × ×

Program file data × ×

POU × ×

Ladder program data × ×

Program  

Local Label × 

ST program data*1 × ×

Program  

Local Label × 

SFC program data × ×

SFC block × ×

Program  

Local label*1 × 

FB_Pool × ×

Program  

Local label × 

Structured Data Types × ×

Structure data × 

Local Device Comment × ×

Comment data  

Device Memory × ×

Device memory data  

Device Initial Value*1 × ×

Device initial value data × ×
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● Structured project
: Applicable ×: Not applicable

Items on Project view Read Write

Parameter  

Intelligent Function Module*1

*1 : Not supported by FXCPU.

× ×

Intelligent function module data  

Global Device Comment  

Global Label × ×

Global label data × 

Program Setting × ×

Program file data  

POU × ×

Program × ×

Ladder program data*1 × ×

Program  

Local Label × 

ST program data × ×

Program  

Local Label × 

SFC program data*1 × ×

Program  

Local Label × 

Structured Ladder/FBD program data × ×

Program  

Local Label × 

FB/FUN × ×

Program  

Local label × 

Structured Data Types × ×

Structure data × 

Local Device Comment × ×

Comment data  

Device Memory × ×

Device memory data  

Device Initial Value*1 × ×

Device initial value data × ×
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4.10.1  Setting/resetting security of projects

4.10.1 Setting/resetting security of projects

Set security for an open project and reset the security.

■ Setting security for projects

Set security for a project.
Once security is set for a project, user authentication is required when the project is opened once 
again. (Section 4.10.3)

Screen display
Select [Project] ⇒ [Security] ⇒ [User Management].

Operating procedure

1. Set the items on the screen.

2. Click the  button.
Security is set for the project.

● Setting security
When security is set for a project, the project is in the status logged in by the set user (Administrators). The current login 
user can be checked in the status bar. (Section 3.2.6)

● Loss of login password
If a user forgets the login password, logging in to the project is disabled. Remember the password securely. If the user 
whose access level is Developers (Level 3) or lower forgets the password, log in the project using the access level 
'Administrators' and set the password again.

Item Description

User Name
Enter a user name in 1 to 20 characters, using alphabets, numerals, and/or symbols 
corresponding to the ASCII codes (Appendix 3) of 20H to 26H and 28H to 7EH. (Alphabets 
are case-sensitive.)

Access Level Display 'Administrators'. (Fixed)

Password
Enter a password in 6 to 32 characters, using alphabets, numerals, and/or symbols 
corresponding to the ASCII codes (Appendix 3) of 20H to 7EH. (Alphabets are case-
sensitive.)

Re-enter Password Set the same password again for confirmation.
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■ Resetting security of projects

Reset the set security of a project by deleting all users, and returns the project to the status without 
security. (Section 4.10.2)

4.10.2 Managing (adding/deleting/changing) users

Manage the registered status of users for a project with security. This function also adds/deletes/
changes users.
This function is available only when a project is logged in by the user whose access level is 
'Administrators' or 'Developers'.

Screen display
Select [Project] ⇒ [Security] ⇒ [User Management].

Display contents

Item Description

Number of User Registrations Display the number of registered users and the maximum number of registrations.

User Name Display the registered user names.

Access Level Display the access level of each registered user.
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Screen button

●

Adds a user. ('■ Adding users')

●

Deletes a user selected in the list.
The current login user cannot be deleted. If registered users are only 'Administrators' and there are 
no other users to be deleted, deletion of the current login user is possible.
If 'Administrators' level users are deleted, security is reset.

●

Changes the information of the user selected in the list. ('■ Changing user information')

●

Changes the password of the user selected in the list. ('■ Changing passwords')
The password of the current login user cannot be changed using this function. To change it, select 
[Project] ⇒ [Security] ⇒ [Change Password].

■ Adding users

Add a user to a project with security.
A user whose access level is higher than that of the login user cannot be added.

Operating procedure

1. Click the  button on the User 
Management screen.
The User Addition screen is displayed.

2. Set the items on the screen.

3. Click the  button.
The user is added.
The added user is displayed in the User Management screen.

Item Description

User Name
Enter a user name in 1 to 20 characters, using alphabets, numerals, and/or symbols 
corresponding to the ASCII codes (Appendix 3) of 20H to 26H and 28H to 7EH. (Alphabets are 
case-sensitive.)

Access Level Select the access level.

Password
Enter a password in 6 to 32 characters, using alphabets, numerals, and/or symbols 
corresponding to the ASCII codes (Appendix 3) of 20H to 7EH. (Alphabets are case-
sensitive.)

Re-enter Password Set the same password again for confirmation.
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■ Changing user information

Change the user information (user name and access level) of registered users.
The information of the login user and the user whose access level is higher than that of login user 
cannot be changed.

Operating procedure

1. Click the  button on the User 
Management screen.
The Change User Data screen is displayed.

2. Set the items on the screen.
Setting items Section 4.10.1

3. Click the  button.
The user information is changed.

■ Changing passwords

Change the password of the user selected in the list on the User Management screen.
The password of the login user and the user whose access level is higher than that of the login user 
cannot be changed. To change the password of the login user, use the Change password function by 
selecting [Project] ⇒ [Security] ⇒ [Change Password].

Operating procedure

1. Click the  button on the User 
Management screen.
The Change Password screen is displayed.

2. Set "New Password" and "Re-enter Password".

3. Click the  button.
The password is changed.
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4.10.3  Logging in projects

4.10.3 Logging in projects

A user authentication procedure is required when opening a project with security.

Screen display
Screen display when a project with security is opened.

Operating procedure

1. Set the items on the screen.

2. Click the  button.
Login authentication is performed with the entered user name and password. The project is 
opened when the entry is confirmed to be correct.

● Checking login status
The current login user can be checked in the status bar. (Section 3.2.6)

Item Description

User Name Enter the user name registered to the project to be logged in.

Password Enter the password.
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4.10.4 Changing access authority of access level

Set an authorization of displaying/saving data for each access level.
The access authority of access levels higher than that of the login user cannot be changed.
If the access level of the current login user is 'Users', changing the access authority is not allowed.

Screen display
Select [Project] ⇒ [Security] ⇒ [Data Security Setting].

Operating procedure

1. Set the items on the screen.

2. Click the  button.

● Setting access authority
The access authority can also be set by right-clicking on a single data of which access authority is to be changed on the 
Project view and selecting [Data Security Setting] from the shortcut menu. When multiple data are selected, the 
shortcut menu is invalid.

Item Description

Access Object Select one or more data for which access authority is changed.

Access Authority Set 'enable/disable' of reading/writing data for each access level by moving the slider.*1

*1 : When multiple data are selected, the default access authority setting is displayed. Click the slider to set the 
displayed access authority as it is. The access authority will not be set by only selecting multiple data.
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4.10.5  Considerations for using the security function

4.10.5 Considerations for using the security function

1) Read protected data
A name of read protected data is displayed in gray and cannot be opened.
On the screens of project verification and programmable controller verification, a lock mark icon is 
appended.
The following figures are an example for the case that "Parameter", programs and local labels of 
"MAIN1", and programs of "MAIN2" are read protected.

2) Write protected data
The write protected data can be opened as the read only data.

3) Properties of data
The properties of the read/write protected data can be displayed, but cannot be edited.

4) Device comment display on ladder editor and the Sampling Trace screen
If the data of the device comment is set as read protected, the device comment is not displayed on 
ladder editor or the Sampling Trace screen.

5) Reading symbolic information from programmable controller CPU using project with 
security
When symbolic information*1 is read from a programmable controller CPU, the security settings 
(settings on the Data Security Setting screen) of the data, which are not included in the symbolic 
information, are set to their default.
If the settings on the Data Security Setting screen are changed, make settings again after reading 
data from the programmable controller CPU.
Note that the block password*2 is not set to default even when the symbolic information is read. 
Therefore, setting a block password to each POU is recommended.

*1 : Symbolic information (Section 12.1.5)
*2 : Block password (Section 4.12)

<Project view> <Project verification>

<Programmable controller verification>
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4.11 Setting Security Key

*1 : High-speed Universal model QCPU only

This section explains how to control the access with a security key.

■ Security key

The security key locks/unlocks projects and a programmable controller CPU. 
The lock can only be unlocked with a security key, and therefore project data and data in a 
programmable controller CPU can be protected.
● For projects

Locked project can be opened or edited only by the users who registered the security key on the 
personal computer.

● For programmable controller CPU
The following files can be written to/read from the locked programmable controller only by the users 
who registered the security key on the personal computer.
• Symbolic information
• Program
• Parameter
• Intelligent function module parameter
• Device comment

Another user can unlock the locked project data or programmable controller CPU by importing/
exporting the security key.

FXFXHeadRemoteQ CPU

*1

L CPU

Key A

Key A

Key A

Data access/

editing enabled

Unable to access/

edit data

Unable to write/read files

File writing/reading enabled

High-speed 

Universal model QCPU
Project data

Key A

Key A

Key A

Key A

Data access/

editing enabled

Data access/

editing enabled

File writing/reading enabled

File writing/reading enabled

High-speed 

Universal model QCPU
Project data

Export

Import

Unlock

Unlock

Unlock
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4.11.1 Managing security key

Create a security key, and import/export/delete the security key.

Screen display
Select [Project] ⇒ [Security] ⇒ [Soft Security Key Management].

Display contents

Item Description

Key Information Registered in the 
Personal Computer –

Name Display the name of the security key.

Creation date Display the date of creation of the security key.

Lock the project Display the lock applicability for the project.

Lock the CPU Display the lock applicability of the programmable controller CPU.

Expiration date Display the expiration date when an expiration date is set on the security key. 
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Screen button

●

Imports the security key. ("■ Importing security key")

●

Exports the security key. ("■ Exporting security key")

●

Creates a security key. ("■ Creating a security key")

●

Deletes the security key. ("■ Deleting security key")

■ Creating a security key

Create a security key.

Operating procedure

1. Click the  button.
The New screen is displayed.

2. Enter a name and click the  button.
The security key is created.

● Considerations of created security key
Created security keys can be registered only by the user who logged in the personal computer.
The maximum number of security key registrations is 128 including created security keys and imported security keys 
for each login user of personal computer.
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■ Importing security key

Import the security key which is exported previously to the personal computer.

Operating procedure

1. Click the  button.
The Import screen is displayed.

2. Select the security file to be imported, and click the  button.
The Password screen is displayed.

3. Enter the password set for the file when it was exported, and click the  
button.
The security key is imported to the personal computer.
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■ Exporting security key

Export the security key.

Operating procedure

1. Select the security key to be exported, and click the  button.
The Export screen is displayed.

2. Set the items on the screen.

Item Description

Security Key Information –

Name Display the name of the security key.

Password –

Password
Enter a password for the security file to be exported.
Set a password in 6 to 32 characters, using alphabets, numerals, and/or symbols 
corresponding to the ASCII codes (Appendix 3) of 20H to 7EH.

Re-enter password Set the same password again for confirmation.

Detailed settings –

Expiration date Set the expiration date of the security key.

Operation limit –

Lock the project Select whether to apply the security key setting to the project.

Lock the CPU Select whether to apply the security key setting to the programmable controller 
CPU.
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3. Click the  button.
The Save As screen is displayed.

4. Enter a name of the file to be saved.

5. Click the  button.
The security key file is saved.

● Considerations of exported security files
Secure the exported security files strictly.

■ Deleting security key

Delete the security key registered on the personal computer.

Operating procedure

• Select the security key to be deleted, and click the  button.
The following confirmation message is displayed.
Click the  button to delete the security key.

● Considerations when deleting security key
The project cannot be opened if the security key which is used to lock the project is deleted.
Even when the security key with the same name is recreated after deleting the security key, it will not be the same 
security key.
Take extra caution when deleting security keys.
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4.11.2 Locking project with security key

Lock the project with a security key.

Screen display
Select [Project] ⇒ [Security] ⇒ [Soft Security Key Management].

Display contents

Operating procedure

1. Select the security key to lock the project from "Key Information Registered in the 
Personal Computer".

2. Click the  button.
The project is locked with the selected security key.

Screen button

●

Unlocks the locked project.

Item Description

Key Information Registered in the 
Personal Computer Display the information of selected security key. (Section 4.11.1)

<<Project>> Display the screen to lock/unlock the project.

Project Information –

Project Name Display the name of the project.

Title Display the project title.

Security Key Information –

Name Display the name of the security key which is used to lock the project.

Creation date Display the date of creation of the security key which is used to lock the project.

Explanation Display the information when the cursor is placed on the button on the screen.
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4.11.3 Considerations of security keys

1) When GX Works2 is uninstalled
Security keys are not deleted even when GX Works2 is uninstalled.

2) Security status
When the security key is "Executable" at the point of opening the project, the security key is 
handled under the authority of "Executable" while the project is being opened.
For example, even when the security key of the opened project is deleted and the "Inexecutable" 
security key is imported, the security key is handled under the authority of "Executable" while the 
project is being opened.

3) Project locked with security key
The following operations cannot be performed.
• Write to PLC/Read from PLC/Verify with PLC function with symbolic information, programs, 

parameters, intelligent function module parameters, or device comments when "Memory Card 
(SD)" is specified for the target memory

• Online program change function when "Memory Card (SD)" is specified for the write target.
• Write to PLC function with parameters when "Memory Card (SD)" is specified for the target 

memory of "Comment File Used in a Command" on the <<PLC File>> tab of PLC parameter.
• Write IC Memory Card function

4) CPU module locked with security key
The following operations cannot be performed.
• Backup data creation function of PLC Module Change
• Data restoration function of PLC Module Change
• Write PLC User Data/Read PLC User Data function with latch data backup file created with the 

Latch Data Backup function
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4.12 Protecting POUs in Projects

This section explains how to set a block password to a POU in a project with labels.
Setting a block password to a POU disables browsing of program content. To browse program 
content, the block password must be unlocked.

The following table shows the POUs to which a block password can be set.

● Effective range of block passwords
A block password is the function that protects POUs, not execution programs.
To protect execution programs, use the security function or online password function.
For FXCPU, however, whether to protect execution programs with a block password can be selected. (Setting block 
passwords Section 4.12.2)

● Considerations of project with security
To set/unlock/delete a block password in a project with security, a user who has a security access authority to read/
write the program needs to log in. (Security Section 4.10)

● Reading symbolic information from programmable controller CPU
Even when the symbolic information is read from a programmable controller CPU, the set status of block password 
does not change.

● Considerations when using FXCPU
A memory cassette to which the execution program with a block password is written can be used on FX3U/FX3UC 
version 3.00 or later only.

Q CPU L CPU FXFXRemote FXHead

Project type POU to which a block password can be set

Simple project (without labels) None

Simple project (with labels) Function block

Structured project
Program block
Function block
Function
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4.12.1  Managing (setting/unlocking/deleting) block passwords

4.12.1 Managing (setting/unlocking/deleting) block passwords

Manage the block password setting status of a POU.
In addition, this function sets/unlocks/deletes a block password.

Screen display
Select [Tool] ⇒ [Block Password].

Display contents

Screen button

●

Sets a block password to a POU. (Section 4.12.2)

●

Unlocks the block password set to the POU. (Section 4.12.3)

●

Deletes the registered block password. The block password of the POU must be unlocked before 
deleting it.

● Selecting multiple POUs
Multiple POUs of "Function Block List" can be selected and the password can be set/disabled in batch.
The following is the consideration when the block password settings of selected POUs are different.
• POUs whose block password is different from the entered password are not unlocked.

Item Description

POU Name Display POUs.

Registration Status Display the status of block password for each POU.
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4.12.2 Setting/changing block passwords

Set a block password to a POU.

Operating procedure

1. Select a POU to set a block password on the 
Block Password screen and click the 

 button.
The Change Block Password screen is displayed.

2. Set the items on the screen.

3. Click the  button.
The block password is set to the selected POU.
Lock of the POU by the block password becomes effective when the project is opened once again.

● Display on the Project view
A POU with a block password is displayed on the Project view as shown below.

● Changing block passwords
To change a block password, simply set a new password for the POU to which a block password has already been set. 
However, the block password must be unlocked before changing it.

<QCPU (Q Mode)/LCPU>

<FXCPU>

Item Description

Password
Enter a password in 6 to 32 characters, using alphabets, numerals, and/or symbols 
corresponding to the ASCII codes (Appendix 3) of 20H to 7EH. (Alphabets are case-
sensitive.)

Re-enter Password Set the same password again for confirmation.

Read-protect the execution 
program*1

Select this to disable reading execution programs.
Whenever this item is selected or cleared, the program must be compiled.

*1 : Supported by FX3U/FX3UC version 3.00 or later only.

A lock mark is appended to the icon of 
POU to which a block password is set.
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4.12.3  Unlocking block passwords

4.12.3 Unlocking block passwords

Unlock the block password set to a POU.
Browsing of POUs is enabled by unlocking block passwords.

Operating procedure

1. Select a POU to unlock the block 
password on the Block Password 
screen and click the  
button.
The Unlock Block Password screen is 
displayed.

2. Set the item on the screen.

3. Click the  button.
The block password of the selected POU is unlocked.
The unlock of the POU by the block password is valid while the project is being opened. To lock the 
POU again, reopen the project.

Item Description

Password Enter the block password to be unlocked.
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5 - 1

5 EDITING PROGRAMS
This chapter explains the functions of the program editors used to edit sequence programs.

5.1 Programming 5 - 2

5.2 Label Programming 5 - 2

5.3 Considerations for Using Label Projects 5 - 4

5.4 Converting/Compiling Projects 5 - 9
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5.1 Programming

For programming in each project, refer to the following manuals:
GX Works2 Version 1 Operating Manual (Simple Project)
GX Works2 Version 1 Operating Manual (Structured Project)

5.2 Label Programming

Programs can be standardized by using the label programming.
This function is available when a new program is created with the selection of "Use Label".
For projects without labels, the programming can be changed to the label programming by changing 
the project type. (Section 4.5)

■ Features of label programming

● Since device assignment can be changed according to the equipment configuration by 
creating general-purpose programs with the label programming, the programs with labels can 
simply be utilized for other programs.

● Programs can be created using labels without knowing the equipment configuration.
● Labels and actual devices are associated as the equipment configuration is determined. This 

function allows easier creation of execution programs.
● By simply specifying a label assignment method, devices are assigned automatically with the 

program compilation function without being aware of device names/device numbers.
● Debugging can be performed effectively by monitoring/debugging programs without 

changing label names.

Q CPU L CPU FXFXRemote FXHead

Q CPU L CPU FXFXRemote FXHead
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■ Terms used in label programming

The following are the terms used in the label programming.

The following is an image of writing/reading label project data to/from a programmable controller CPU 
in GX Works2.

Project view Term Description

Label project New projects created with the selection of "Use Label" on the New 
Project screen. (Section 4.2.1)

Symbolic information

Data of information such as programs, global labels, and local labels, 
required for label programming. (Section 12.1.5) 
These data are restored by writing/reading symbolic information to/
from a programmable controller CPU.

Program
Program data written with applicable programming languages. 
For label projects, these are data included in symbolic information even 
when a program is created using devices only.

Execution program
Programs executed on programmable controller CPUs. 
Devices are assigned to labels with compilation, and execution 
programs are created.

Actual device Devices assigned to labels after compilation, or devices not written with 
labels.

Global label Labels available for all program data when multiple program data are 
created in a project.

Local label Labels available for each program data only. 
Labels and each program data are set one to one.

Device/label automatic-
assign setting

A setting of types and ranges of devices assigned to labels.
GX Works2 Version 1 Operating Manual (Simple Project)
GX Works2 Version 1 Operating Manual (Structured Project)

Compilation An operation in which programs are converted to execution programs.

GX Works2 (Label project)

Execution program Execution program

Symbolic information

Global label

Local label

Program

Local label

Program

Write to PLC
Write to PLC Write to PLC

Symbolic information

GX Works2 (Label project)

Symbolic information

Global label

Local label

Program

Local label

Program

Read from PLC
< Reading data from programmable controller CPU >

< Writing data to programmable controller CPU >

Programmable 

controller CPU
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5.3.1  Editing programs

5.3 Considerations for Using Label Projects

This section explains the considerations for using label projects.

5.3.1 Editing programs

1) Label comments set on the label setting editor are displayed as comments to labels. 
Comments created on the device comment editor are not displayed.
Up to 1024 characters can be set for label comments, however, the number of characters that can 
be displayed is 32.

2) When the same label is set for global label/local label, the label comment set for local label 
setting is displayed.

3) The index setting cannot be set when labels are used. Use actual devices to set the index 
setting.

■ Considerations when editing programs

1) When an instruction in which data are stored to multiple word devices is used as shown 
below, specify an array for the label in the storage destination of operation result.
• Division (Storing values such as quotient and remainder of division)
• Instructions such as the block data transfer instruction (BMOV)

Q CPU L CPU FXFXRemote FXHead

Label name : Value_A

Device type : Array (word)

Number of elements : 2

Program : [/ D0 D1 Value_A]

2 words required

b Operation result

a Setting

[ Storage example when division is specified with array ]

Value_A[0] Value_A[1]

(Quotient) (Remainder)Operation result of [/ D0 D1 Value_A]
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2) When setting arrays, be aware of device types and the number of elements in the data 
storage destination.
If the setting is incorrect, the content of devices assigned to other labels may be overwritten.

For the above example, assign 4 words to the label (Value_A) in the storage destination of 
operation result.
To assign 4 words, set the following setting on the label setting editor. 
Device type: Array (double word) Number of elements: 2 
After compilation, the consecutive device ranges for 4 words are secured.

3) Do not overlap the device ranges which are stored as execution result of instruction when 
assigning devices with global labels.
If the setting is incorrect, the content of devices assigned to other labels may be overwritten.

For the above example, assign the device of label (Value_B) to D104.

Device range for storing operation result
Device range assigned 

to Value_A

Data register

Label name

Device type : Double word

: [D* D0 D2 Value_A]

4 words required

Operation result

Setting

[ Example of incorrect device type setting ]

Overwritten device range
Device range used 

by other labels

[1]

Program

: Value_A

a

b

d

[2]d

[3]d

[4]d

[5]d

Label name

: Value_B

Device type

Label name

Device type

Number of elements

Device

Program

Device

Program

D100

D101

D102

D103

D104

Device range for storing operation result

Device set for 

Value_A

Device set for 

Value_B

Data register

Overwritten device range

2 words required

Setting

: Double word

: D102

: [* D10 D11 Value_B]

Operation result

[ Example of incorrect device setting ]

a

b

: Value_A

: Array (Double word)

: 2

: D100

4 words required

: [D* D0 D2 Value_A]
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5.3.2  Writing programs to programmable controller CPU (Write to PLC/Online program change)

5.3.2 Writing programs to programmable controller CPU (Write to 
PLC/Online program change)

■ Writing symbolic information

1) In order to restore programs by reading symbolic information from the programmable 
controller CPU, write symbolic information.
Symbolic information can be written by selecting the following item on the execution screen of 
Write to PLC/Online program change.
• Write to PLC: Symbolic Information
• Online program change: Write Symbolic Information to PLC
Note that symbolic information and execution programs can be written to separate memories. 
Specify the write destination memory for "Target Memory". The default setting of write destination 
memory for symbolic information can be changed in the option setting. Set "Setting for Save 
Destination of Symbolic Information to PLC" under [Tool] ⇒ [Options] ⇒ "Symbolic Information".

When the Write to PLC/Online program change operation is performed on execution programs 
only, program inconsistency occurs. This operation must be performed on both symbolic 
information and execution programs.

2) When writing data to a programmable controller CPU, the confirmation message asking "Do 
you want to overwrite?" may be displayed as corresponding to the execution programs. 
The symbolic information will not be written normally if "No" was selected. Perform the data 
write operation again, and complete the operation normally.

■ Writing execution programs only

1) When an area to store symbolic information cannot be secured on the programmable 
controller CPU, write execution programs only.
Projects contain symbolic information must be kept securely on a personal computer.

2) Write execution programs without selecting the following item.
• Write to PLC: Symbolic Information
• Online program change: Write Symbolic Information to PLC

< Write to PLC >

Symbolic information and all execution programs 

are selected when "Symbolic Information" is selected. 

The program which is consistent with the symbolic 

information can be written to the programmable 

controller CPU.

< Online program change >

GX Works2

Programmable 

controller CPU

Execution program 1 Execution program 2

Symbolic information

Local label

Program 1

Local label

Program 2

Symbolic information

Perform the Write to 
PLC/Online program 
change operation on 
label program
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5.3.3 Reading programs from programmable controller CPU (Read 
from PLC)

■ Reading symbolic information

1) Execute the Read from PLC operation with a label project.

2) When reading data from a programmable controller CPU, specify the memory to which the 
symbolic information is stored for "Target Memory" of symbolic information.

3) Do not perform the Read from PLC operation on the symbolic information when the 
symbolic information and the execution programs on the programmable controller CPU are 
not consistent.
When the symbolic information is read with program inconsistency, the execution programs which 
are running on the programmable controller CPU cannot be restored. Check the date of the Write 
to PLC operation which was performed on the symbolic information and the execution programs, 
and prevent from performing the Read from PLC operation with program inconsistency. Date of the 
data write operation can be checked with the column of "Last Change" on the Online Data 
Operation screen for "Delete PLC Data".

The following are the considerations when symbolic information needs to be read with program 
inconsistency.
• Create backup data of symbolic information on a personal computer before performing the Read 

from PLC operation.
Symbolic information on a personal computer will be overwritten with symbolic information on a 
programmable controller CPU. To prevent from erasing the latest symbolic information, save the 
project and create backup data of symbolic information.

• The following message is displayed when the Read from PLC operation is performed with 
program inconsistency.
Follow the instruction described in the message.
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5.3.4  Verifying programs

■ Reading execution programs only

1) Do not read execution programs only.
When only the execution programs needs to be read, read them with a project without labels.
The following warning message is displayed when the execution programs created from the 
symbolic information are read with a project without labels.

5.3.4 Verifying programs

Symbolic information cannot be verified. The program verification operation can be performed on 
execution programs only.

5.3.5 Monitoring programs

Programs created with labels can be monitored.
Programs with labels registered to the Watch window can be monitored.
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5.4 Converting/Compiling Projects

This section explains how to convert/compile an edited project to convert it into the code executable 
on the programmable controller CPU.

The type of conversion/compilation differs according to the project type as shown in the table below.

For details, refer to the following manuals:
Section 12.9 "Online Program Change"
GX Works2 Version 1 Operating Manual (Simple Project)
GX Works2 Version 1 Operating Manual (Structured Project)

Q CPU L CPU FXFXRemote FXHead

Project type Conversion/compilation type Description

Simple project
(without labels)

Build Fix changes.

Online Program Change
Fix changes, and simultaneously, write the difference between the fixed 
programs and the programs stored on the programmable controller CPU 
to the programmable controller CPU.

Rebuild All Convert all programs.

Simple project
(with labels)/
Structured project

Build Convert and compile uncompiled data (programs, structures, labels and 
functions/function blocks).

Online Program Change
Convert and compile data, and simultaneously, write the difference 
between the fixed programs and the programs stored on the 
programmable controller CPU to the programmable controller CPU.

Rebuild All Convert and compile all data (programs, structures, labels and functions/
function blocks).
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6 - 1

6 SETTING PARAMETERS
This chapter explains the setting items, operations on the setting screens, and common notes on 
parameter settings.
For necessary information and details of settings, refer to the manuals of each module to be used.

6.1 Setting PLC Parameters 6 - 2

6.2 Setting Redundant Parameters 6 - 18

6.3 Setting Network Parameters 6 - 19

6.4 Setting Remote Password 6 - 57

6.5 Checking Parameters 6 - 59

6.6 Outputting Parameters to CSV Files 6 - 60

6.7 Setting default parameters 6 - 62
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6.1 Setting PLC Parameters

This section explains how to set PLC parameters.

Screen display
Select Project view ⇒ "Parameter" ⇒ "PLC Parameter".

Display contents

Remote HeadQ CPU L CPU FX

Item Description

Tab

The setting items are categorized under tabs according to their purpose.
• The parameter setting status is displayed by different font colors of the tab names.

• Details of the setting items Section 6.1.1

Font color Setting status

Red Status that data is not set under the tab
(Data must be set under the tab for operation.)

Blue Status that data is set under the tab
(A red tab name changes to blue after data is set.)

Magenta Default values
(The user settings are not set under the tab.)

Dark blue Values other than default values
(A magenta tab name changes to dark blue after data is set.)



6.1  Setting PLC Parameters

6 - 3

1

O
V

E
R

V
IE

W

2

S
YS

TE
M

 
C

O
N

FI
G

U
R

A
TI

O
N

3

SC
RE

EN
 

CO
NF

IG
UR

AT
IO

N 
AN

D 
BA

SI
C 

O
PE

RA
TI

ON
S

4

P
R

O
JE

C
T 

M
A

N
A

G
E

M
E

N
T

5

ED
IT

IN
G

 
PR

O
G

R
AM

S

6

S
E

TT
IN

G
 

PA
R

A
M

E
TE

R
S

7

S
ET

TI
N

G
 D

E
V

IC
E

 
M

E
M

O
R

Y

8

S
E

TT
IN

G
 D

E
V

IC
E

 
IN

IT
IA

L 
V

A
LU

ES

Screen button

●

Executes printing. (Section 20.7)

●

Executes print preview. (Section 20.9)

●  (Not supported by FXCPU)
Checks the X/Y setting made on the <<I/O Assignment>> tab of PLC parameter or in the network 
parameter.

●

Resets all setting items on the screen being open to their defaults.

●

Checks whether the user-set parameters on the screen being open are correct.

● Considerations when changing PLC parameters
For QCPU (Q mode)/LCPU, all programs need to be compiled when the following PLC parameters are changed.
• "Common Pointer No." and "Timer Limit Setting" on the <<PLC System>> tab
• "File Register" and "File for Local Device" on the <<PLC File>> tab
• Settings on the <<Device>> tab
Compiling all programs changes the device assignment to labels. Therefore, device values set before the program 
change remain on the device-assigned labels.
Perform the following operations for a precautionary measure.
• For QCPU (Q mode)/LCPU

After writing data to the programmable controller CPU, reset the programmable controller CPU, clear all device 
memories including latches, clear all file registers, and switch the programmable controller CPU to RUN.

• For FXCPU
After writing data to the programmable controller CPU, clear device memory using the PLC memory clear function, 
and switch the programmable controller CPU to RUN.

(Section 17.4)
For the considerations for compiling all programs, refer to the following manuals.
GX Works2 Version 1 Operating Manual (Simple Project)/(Structured Project)

● Function to apply the parameters of MELSOFT Navigator
• When GX Works2 is started up from MELSOFT Navigator, parameters that can be set by MELSOFT Navigator are 

displayed with green background.
• A parameter set by the function to apply the parameters of MELSOFT Navigator cannot be edited.

To edit it, select [Tool] ⇒ [Options] ⇒ "iQ Works Interaction" and select "Enable an editing of parameters set in 
MELSOFT Navigator".
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6.1.1  PLC parameter item list

6.1.1 PLC parameter item list

The following table shows the applicable PLC parameter items for each programmable controller type.
For details of each item, refer to the following manuals.
(User's manuals and programming manuals of each CPU)

: Applicable   –: Not applicable

Setting tab name

Q series L series FX series

Basic model 
QCPU

High Performance model QCPU/
Universal model QCPU/

Process CPU

Redund
ant CPU

Remote 
I/O 

module
LCPU Communication 

head module FXCPU

Communication Head 
Setting – – – – –  –

PLC Name    –   

PLC System*1       

PLC File    –  – –

PLC RAS       –

Boot File  *2  – *3 – –

Program –   –  – –

SFC    –  – –

Device    –  – 

I/O Assignment       –

Multiple CPU Setting *4 *4 – – – – –

Built-in Ethernet Port 
Setting – *5 – – *3 – –

Ethernet Port Setting – – – – – – *6

Built-in I/O Function 
Setting – – – –  – –

Serial Communication *7 *8 – – *9 – –

Memory Capacity – – – – – – 

Special Function Block – – – – – – 

Positioning – – – – – – 

Operation Setting – – –  –  –

*1 : For FXCPU, PLC System is separated into PLC System (1) and PLC System (2).
*2 : Not supported by Q00UJ/Q00U/Q01U.
*3 : Not supported by L02S.
*4 : Not supported by Q00J/Q00UJ.
*5 : For Built-in Ethernet port QCPU only
*6 : For FX3G, FX3GC, FX3U, and FX3UC only
*7 : For Q00/Q01 only
*8 : For Q00UJ/Q00U/Q01U/Q02U/QnUD(H)CPU only
*9 : For L02S only
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■ PLC parameter setting items for QCPU (Q mode)/LCPU

1) PLC Name

2) PLC System

Item Description Remarks

Label Set a label (name and application) of the programmable controller 
CPU. –

Comment Set a comment for the label of the programmable controller CPU. –

Item Description Remarks

Timer Limit Setting Set the time limit of the low-speed/high-speed timer. –

RUN-PAUSE Contacts

Set the contacts for controlling RUN/PAUSE of the programmable 
controller CPU.
PAUSE contact only setting is not available. (RUN contact only or 
RUN contact + PAUSE contact setting is available.)

–

Latch Data Backup 
Operation Valid Contact

Set the contact device for executing a latch data backup operation. Universal model QCPU/
LCPU only

Set whether to back up all files on the standard RAM when executing 
a latch data backup operation.

High-speed Universal 
model QCPU only

Remote Reset Set whether to allow a remote reset operation from GX Works2. –

Output Mode at STOP to 
RUN

Set the status of output (Y) when the programmable controller is 
switched from STOP to RUN. –

Floating Point Arithmetic 
Processing Set whether to perform floating-point processing in double precision. High Performance 

model QCPU only

Intelligent Function
Module Setting

Set the interrupt pointer assignment of the module.
Set the start I/O number and start SI number of the module. –

Module Synchronization Set whether to synchronize the start-up of the programmable 
controller CPU with that of the intelligent function module. –

Built-in CC-Link Setting Set whether to set the built-in CC-Link. L26-BT/L26-PBT only

Common Pointer No. Set the start number of the common pointers used in the program. Not applicable to Basic 
model QCPU

Points Occupied by 
Empty Slot

Set the number of points occupied by empty slots for the main base 
unit/extension base unit/block. –

System Interrupt 
Settings

Set the start number of the interrupt counters.
Set the execution interval for the interrupt pointers. –

Set the fixed scan interval for high-speed interrupt pointers, high-
speed I/O refresh, and high-speed buffer transfer.

High Performance 
model QCPU/High-

speed Universal model 
QCPU only

Interrupt Program/Fixed 
Scan Program Setting Set whether to perform high-speed execution of an interrupt program. –

A-PLC Compatibility 
Setting

Set whether to use the MELSEC-A series special relays/special 
registers (SM1000/SD1000 to SM1299/SD1299).

Not applicable to Basic 
model QCPU/

Redundant CPU

Service Processing 
Setting

Set the processing time and the number of times of service 
processing.

Universal model QCPU/
LCPU only

PLC Module Change 
Setting Set this to replace the CPU module using a memory card.

Universal model QCPU/
LCPU (except for L02S) 

only
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3) PLC File

4) PLC RAS

5) Boot File

Item Description Remarks

File Register

Set the file register file to be used in the program. –

Set whether to transfer data to the standard ROM when executing a 
latch data backup operation.

Universal model QCPU 
(except for High-speed 

Universal model 
QCPU)/LCPU only

Comment File Used in a 
Command Set the device comment file to be used in the program. Not applicable to Basic 

model QCPU

Initial Device Value Set the device initial value file to be used on the programmable 
controller CPU. –

File for Local Device Set the local device file to be used in the program. Not applicable to Basic 
model QCPU

File used for SP.DEVST/
S.DEVLD Instruction

Set the device data ROM write/read instruction file to be used in the 
program.

Universal model QCPU/
LCPU only

Item Description Remarks

WDT (Watchdog Timer) 
Setting

Set the WDT of the programmable controller CPU. –

Set the WDT for an initial execution type program. –

Set the WDT for a low-speed execution type program. High Performance 
model QCPU only

Error Check Set whether to detect specified errors. –

Operating Mode When 
There is an Error

Set the programmable controller CPU operation mode when an error 
is detected. –

Constant Scanning Set the constant scan time. –

Error History Set the storage destination for error histories of the programmable 
controller CPU.

High Performance 
model QCPU only

Low Speed Program 
Execution Time Set the execution time of a low-speed program in every scan. High Performance 

model QCPU only

Module Error History 
Collection (Intelligent 
Function Module)

Set whether to collect the error history of the intelligent function 
module.

Universal model QCPU/
LCPU only

Memory Check Set whether to check the memory of the program. Process CPU/
Redundant CPU only

Item Description Remarks

Boot Option
Set whether to clear the program memory when booting up. Not applicable to Basic 

model QCPU

Set whether to write data in the memory card automatically to the 
standard ROM when booting up.

Not applicable to Basic 
model QCPU

Boot File Setting

Set the type, data name, transfer source drive, and transfer 
destination drive of the boot file.

Not applicable to Basic 
model QCPU

Set whether to boot up with the standard ROM. Basic model QCPU 
only
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6) Program

7) SFC

8) Device

9) I/O Assignment

Item Description Remarks

Program

Set the file name and execution type (executing condition) for 
programs when several programs are written to the programmable 
controller CPU.
Set the fixed scan interval (the execution interval of a fixed scan 
execution type program).

Not applicable to Basic 
model QCPU

File Usability Setting 
button Display the File Usability Setting screen. Not applicable to Basic 

model QCPU

I/O Refresh Setting 
button Display the I/O Refresh Setting screen. High Performance 

model QCPU only

Item Description Remarks

SFC Program Start 
Mode Set the start-up mode of an SFC program. –

Start Conditions Set the start-up condition of an SFC program. –

Output Mode When the 
Block is Stopped Set the SFC program output mode at block stop. –

Item Description Remarks

Device Points Set the number of points used for each device of the programmable 
controller CPU. –

Latch (1) Start/End
Set the latch range (start device number/end device number) 
clearable with the RESET/L.CLR switch or a remote latch clear 
operation.

–

Latch (2) Start/End
Set the latch range (start device number/end device number) not 
clearable with the RESET/L.CLR switch or a remote latch clear 
operation.

–

Local Device Start/End Set the range (start device number/end device number) of devices 
used as a local device. –

File Register Extended 
Setting Set the extended data register and extended link register. Universal model QCPU/

LCPU only

Indexing setting for 
devices*1

Set the start number of Z to be 32-bit indexed, or use the index 
register ZZ for 32-bit index setting.

Universal model QCPU/
LCPU only

Latch interval Set the device latch interval to be performed by the set interval or by 
each scan. 

High-speed Universal 
model QCPU only

*1 : "Indexing Setting for ZR Device" is displayed for the programmable controller CPU other than High-speed Universal 
model QCPU.

Item Description Remarks

I/O Assignment

Set the type, model, number of occupied I/O points, and start I/O 
number of each module mounted on the base unit/block. –

Set the switch settings of the programmable controller CPU. Universal model QCPU/
LCPU only

Set the switch settings of the intelligent function module. –

Base Setting Set the model and the number of slots of the base unit, the model of 
the power supply module, and the model of the extension cable. Not applicable to LCPU
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10) Multiple CPU Setting

11) Built-in Ethernet Port Setting

12) Built-in I/O Function Setting

Item Description Remarks

No. of PLC Set the number of programmable controller CPUs used in the 
multiple CPU system.

–
Operation Mode

Set the operation mode of the multiple CPU system when a stop 
error occurs in any of the programmable controller CPU No. 2 to No. 
4.
The multiple CPU system stops when a stop error occurs in the CPU 
No. 1.

Host Station Set the CPU number for the host CPU. Universal model QCPU 
(excluding Q00UJ/
Q00U/Q01U/Q02U) 

only

Multiple CPU 
Synchronous Startup 
Setting

Select the CPU modules to be started up synchronously.

Online Module Change Set whether to allow Online module change in the multiple CPU 
system.

Not applicable to Q00U/
Q01U/Q02U

I/O Sharing When Using 
Multiple CPUs

Set whether to retrieve the I/O status of the I/O module or intelligent 
function module controlled by other programmable controller CPUs. –

Communication Area 
Setting (Refresh Setting)

Set the CPU shared memory to enable data sharing among multiple 
CPUs.
(Usable devices: B, M, Y, D, W, R, and ZR)

–

Multiple CPU High 
Speed Transmission 
Area Setting

Set the user setting area, auto refresh, assignment confirmation, and 
system area.

Universal model QCPU 
(excluding Q00U/Q01U/

Q02U) only

Item Description Remarks

IP Address Setting Set the IP address and the input format of the IP address.

Built-in Ethernet type 
CPU only

Communication Data 
Code Select the Binary code or ASCII code for communication.

Open Setting button Set the protocol, open system, and host station port number.

FTP Setting button Select whether to use the FTP function.

Time Setting button Set whether to use the SNTP function, and set the timing of setting 
the time.

Simple PLC 
Communication Setting Set the communication pattern and the communication settings. LCPU only

IP Packet Transfer 
Setting Set whether to use the IP Packet Transfer function.

Universal model QCPU 
(except for Q00UJ/

Q00U/Q01U/Q02U)/
LCPU (except for L02S) 

only

Item Description Remarks

Positioning Set the parameters of the positioning axis 1 setting and positioning 
axis 2 setting.

LCPU only
High-speed Counter Set the operation mode of high-speed counter CH1 setting and high-

speed counter CH2 setting.

Input Signal Set the input signal function, input response time, and interrupt 
processing condition.

Output Signal Select the output signal function and error time output mode.
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13) Serial Communication

Item Description Remarks

Transmission Speed Set the transmission speed.

–
Sum Check Set the sum check.

Transmission Wait Time Set the transmission wait time.

Online Change Set whether to allow Online program change.
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■ PLC parameter setting items for communication head module

1) Communication Head Setting

2) PLC Name

3) PLC System

4) PLC RAS

5) Operation Setting

6) I/O Assignment

Item Description Remarks

CC-Link IE Field 
Network Setting

Set the operation mode of the network.

CC IE Field head 
module only

Set the network number of the module.

Set the station number of the module.

Set whether to hold (store) the error history and system error history 
on a flash ROM at power OFF or reset.

SSCNET III/H Network 
Setting

Set the operation mode of the network.
SSCNET III/H head 

module onlySet whether to hold (store) the error history and system error history 
on a flash ROM at power OFF or reset.

Item Description Remarks

Label Set a label (name and application) of the programmable controller 
CPU. –

Comment Set a comment for the label of the programmable controller CPU.

Item Description Remarks

Remote Reset Set whether to allow a remote reset operation from GX Works2. –

Item Description Remarks

Module Error History
Collection (Intelligent 
Function Module)

Set whether to collect the error history of the intelligent function 
module. –

Item Description Remarks

Assignment Method Select the assignment method of devices to be transferred.
–Forwarding Parameter

between Devices
Set transmission source devices and transmission destination 
devices.

Item Description Remarks

I/O Assignment

Set the type, model, number of occupied I/O points, and start I/O 
number of each module mounted on the base unit.

–Set the switch settings of the programmable controller CPU.

Set the switch settings of the intelligent function module.
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■ PLC parameter setting items for remote I/O module

1) PLC system

2) PLC RAS

3) Operation Setting

4) I/O Assignment

Item Description Remarks

Module Synchronization Set whether to synchronize the start-up of the programmable 
controller CPU with that of the intelligent function module. –

Points Occupied by 
Empty Slot

Set the number of points occupied by empty slots for the main base 
unit/extension base unit. –

Item Description Remarks

Error Check Set whether to detect specified errors. –

Operating Mode When 
There is an Error

Set the programmable controller CPU operation mode when an error 
is detected. –

Item Description Remarks

Assignment Method Select the assignment method of devices to be transferred.
–Forwarding Parameter

between Devices
Set transmission source devices and transmission destination 
devices.

Item Description Remarks

I/O Assignment

Set the type, model, number of occupied I/O points, and start I/O 
number of each module mounted on the base unit.

–Set the switch settings of the programmable controller CPU.

Set the switch settings of the intelligent function module.

Base Setting Set the model and the number of slots of the base unit, the model of 
the power supply module, and the model of the extension cable. –
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● Utilizing existing data to set parameters of multiple CPU
Parameters for multiple CPU can be set by utilizing existing data by clicking the  button on the 
<<I/O Assignment>>/<<Multiple CPU Setting>> tab.
Specify the project to be utilized, read the message, and then execute the function.

● Reading mounting status of programmable controller CPU
The mounting status of the programmable controller CPU can be read and overwritten to the current parameters by 
clicking the  button on the <<I/O Assignment>> tab. Read the message and execute the 
function.

● "Index Setting for ZR Device" on the <<Device>> tab.
When "Use ZZ" is set for the 32-bit index setting, the ZZ device cannot be used or monitored independently in the 
program.

To confirm the current value of the ZZ device, specify Z and set the display format to 32-bit integer, on the Device/
Buffer Memory Batch Monitor screen.

● Program settings
Executing conditions set in the program setting of the PLC parameter are applied to "Program Setting" on the Project 
view. Program settings can also be set on the Project view.
For details of program setting on the Project view, refer to Section 4.2.1

X0

[DMOV   K0     ZR10ZZ0   ]

Usable

X1

[DMOV   K0     ZZ0           ]

Not usable

<Setting screen for PLC parameter> <Project view>

Execution types set in the Program 

can be confirmed.
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■ PLC parameter setting items for FXCPU

For FXCPU, PLC parameter setting items differ according to the programmable controller type.

1) PLC Name

2) PLC System (1)

3) PLC System (2)

Item Description Remarks

Title Set a program title to be stored on the programmable controller CPU.

FX1, FX0N, FX1S, FX1N, 
FXU, FX2N, FX3G, FX3U, 
FX1NC, FX2C, FX2NC, 
FX3GC, and FX3UC only

Item Description Remarks

Battery Less Mode Set this to operate the programmable controller CPU without the 
memory backup battery.

FX2N, FX3U, FX2NC, 
and FX3UC only

Battery Mode Set this to operate the programmable controller CPU with the memory 
backup battery. FX3G and FX3GC only

MODEM Initialized Select the modem initialization command for the remote access to the 
programmable controller CPU.

FX1S, FX1N, FX2N, 
FX3G, FX3U, FX1NC,  
FX2NC, FX3GC, and FX3UC 
only

RUN Terminal Input Select the input number to use the input (X) of the programmable 
controller CPU as the external RUN/STOP terminal.

FX1S, FX1N, FX2N, 
FX3G, FX3U, FX1NC,  
FX2NC, FX3GC, and FX3UC 
only

Item Description Remarks

Channel selection Select a channel to be the connection target.
Applicable to FX3G, FX3GC, FX3U, and FX3UC only.

FX1S, FX1N, FX2N, 
FX3G, FX3GC, FX3U, 
FX1NC, FX2NC, and FX3UC 
only

Operate 
Communication 
Setting

Set whether to enable the communication setting.

Protocol*1 Select the communication protocol.

Data Length*1 Select the data length.

Parity*1 Select the parity.

Stop Bit*1 Select the stop bit.

Transmission 
Speed*1 Select the transmission speed.

Header*1 Set the header.

Terminator*1 Set this to enable the terminator.

Control Line*1 Set this to enable the control line.

H/W Type*1 Select the cable type used in the communication.

Control Mode Display the control mode.

Sum Check*1 Set this to add the sum check.

Transmission 
Control Procedure*1 Select the transmission control procedure.

Station Number 
Setting*1 Set the station number.

Time Out Judge 
Time*1 Set the timeout period.

*1 : Not applicable when "Operate Communication Setting" is OFF.
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4) Device

5) Memory Capacity

6) Special Function Memory Capacity

Item Description Remarks

Device Set the latch range.
FX1, FXU, FX2N, FX3U, 
FX2C, FX2NC, and FX3UC 
only

Item Description Remarks

Memory Capacity*1 Select the memory capacity of the programmable controller CPU.
Not applicable to FX0, FX0S, FX0N, and FX1S.

FX0S, FX0, FX1, FX0N, 
FX1S, FX1N, FXU, FX2N, 
FX3G, FX3U, FX1NC, 
FX2C, FX2NC, FX3GC, and 
FX3UC only

Symbolic 
Information 
Capacity*2

• Display the symbolic information capacity of a built-in memory based 
on the setting value of the memory capacity.

• Display the symbolic information capacity of a memory cassette by 

clicking the  button.

FX3U and FX3UC only

Comments Capacity Set the comment capacity.
Not applicable to FX0 and FX0S.

FX0S, FX0, FX1, FX0N, 
FX1S, FX1N, FXU, FX2N, 
FX3G, FX3U, FX1NC, 
FX2C, FX2NC, FX3GC, and 
FX3UC only

File Register 
Capacity

Set the file register capacity.
Not applicable to FX0, FX0S, and FX1.

Program Capacity Set the capacity for sequence programs.

Special Function 
Memory Capacity

Set whether to use the Special Function Block Settings, Positioning 
Instruction Settings, and Built-in CC-Link/LT.
Applicable to FX3G, FX3GC, FX3U, and FX3UC only.

*1 : When the symbolic information is saved in a built-in memory or a memory cassette, the symbolic information is 
deleted by changing the memory capacity and writing the parameters. In this case, write the symbolic information 
again.

*2 : This item is not printed with the batch print function or the print window function.

Item Description Remarks

Special Function 
Block

Set the initial value of special extension modules/blocks.
Set the Built-in CC-Link/LT Setting. FX3U and FX3UC only
Special Function Block Settings Set the initial value of BFM.

Positioning

• Set the bias speed, max. speed, creep speed, zero return speed, 
acceleration time, deceleration time, and interruption input of DVIT 
instruction for each axis.

• Set the details of the positioning table for each axis.

FX3G, FX3U, FX3GC, and 
FX3UC only
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7) Ethernet Port Setting

Item Description Remarks

Channel Select whether to connect the Ethernet port, and if the port is 
connected, select a channel.

FX3G, FX3U, FX3GC, and 
FX3UC only

IP Address Setting Set the IP address and the input format of the IP address.

Communication 
Data Code Select the Binary code or ASCII code for communication.

Disable direct 
connection to 
MELSOFT

Select whether to disable the direct connection with MELSOFT.

Do not respond to 
search for CPU on 
network

Select whether to respond to the CPU search on the network.

Open Setting button Set the protocol, open system, and host station port number.

Time Setting button Set whether to use the SNTP function, and set the timing of setting the 
time.

Log Record Setting 
button

Set the storage location for error logs on the Log Record Setting 
screen.
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6.1.2  Checking duplications of X/Y assignment among parameters

6.1.2 Checking duplications of X/Y assignment among parameters

Check duplications of X/Y assignment among parameters.

Screen display

Select Project view ⇒ "Parameter" ⇒ "PLC Parameter" ⇒ .

Display contents

Item Description

XY No. Display the I/O number.

Type

Network

Display the content set in the network parameter.
n: Slot number of the module (excluding Ethernet)

I/O 
Assignment

Display whether the I/O assignment setting is set in the PLC parameter.

Slot Display the slot, module type, number of occupied I/O points, and model name when the I/O 
assignment setting is set in the PLC parameter.
Display the I/O assignment status as shown in the table below when the I/O assignment setting in 
the PLC parameter is not set and X/Y devices are assigned in the network parameter.

Module Type

Points

Model Name

Duplication

Display the module in which the first duplication is detected by parameter check.

Display on Network column Description

PLC network/CC IE (Slot n) MELSECNET, CC-Link IE

Remote I/O Net (Slot n) MELSECNET/H (Remote Master)

CC-Link (Slot n) CC-Link

Blank Not set.

Display on I/O Assignment column Description

I/O Assignment I/O assignment is set.

Blank I/O assignment is not set.

Item Description

"Slot" to "Points" Assignment of X devices

"Model Name" Assignment of Y devices

Display on Duplication column Description

MNET/CC IE (Slot 1) 
to 

MNET/CC IE (Slot 16)

Network parameter of MELSECNET or CC-
Link IE (slot 1 to slot 16)

CC-Link CC-Link remote I/O
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Screen button

●

Writes data on the Acknowledge XY Assignment screen to a CSV file. (Section 6.6)

● When a setting screen other than PLC parameter setting screen is being opened
When the MELSECNET/CC IE/Ethernet Module Configuration screen or the CC-Link Module Configuration screen is 
displayed, since the setting is not completed, set data of the previous setting are checked for duplications.

● Priority in the parameter check
The following table shows the priority in when GX Works2 checks the parameter settings.

Priority Display

1 I/O assignment

2 MELSECNET or CC-Link IE Controller Network (slot 16) network refresh parameter

3 MELSECNET or CC-Link IE Controller Network (slot 15) network refresh parameter

·
·
·

·
·
·

17 MELSECNET or CC-Link IE Controller Network (slot 1) network refresh parameter

18 CC-Link remote I/O
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6.2 Setting Redundant Parameters

*1 : Redundant CPU only

This section explains how to set redundant parameters.

Screen display
Select Project view ⇒ "Parameter" ⇒ "Redundant Parameters".

Screen button
For the screen buttons, refer to Section 6.1.

■ Redundant parameter setting items

1) Operation mode setting

2) Tracking setting

FXFXHeadRemoteQ CPU

*1

L CPU

Item Description

Start Mode Setting Set the device status when the system is powered ON or reset.

Standby System Watch Setting Set whether to check errors on the standby system.
If an error occurs, the error can be checked with the PLC diagnostics function.

Debug Mode Setting Set whether to start an operation in the debug mode.

Backup Mode Setting Set whether to check the operating status consistency.

Item Description

Tracking Device Setting Select a setting method for the tracking device.

Tracking Characteristics Setting Set the tracking transfer mode.
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6.3 Setting Network Parameters

This section explains how to set the network parameters.
Only the parameter settings of the following network are supported for LCPU and FXCPU.
LCPU   : CC-Link IE Field Network, Ethernet, and CC-Link
FXCPU: CC-Link

■ Ethernet/CC-Link IE/MELSECNET parameter setting

Screen display
Select Project view ⇒ "Parameter" ⇒ "Network Parameter" ⇒ "Ethernet/CC IE/MELSECNET"/
"CC IE Field" .
The screen below is a screen for MELSECNET/CC-Link IE/Ethernet module configuration.

Screen button

●  (Not supported by LCPU)
Displays the Interlink Transmission Parameters screen.

●

Checks the I/O assignment setting set in the PLC parameter and the status of X/Y devices assigned 
in the network parameter. (Section 6.1.2)

●

Displays the Routing Information screen.

●

Displays the Assignment Image screen of the refresh parameters.
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●  (Redundant CPU only)
Displays the Group Setting screen.

●

Displays the Help - Network Setting screen for network range assignment.

●

Deletes the set parameters.

●

Checks whether the set parameters are correct.

●

Executes printing. (Section 20.7)

●

Executes print preview. (Section 20.9)
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■ CC-Link parameter setting

Screen display
Select Project view ⇒ "Parameter" ⇒ "Network Parameter" ⇒ "CC-Link".
The following is an example of setting screen when QCPU (Q mode) is selected.

Screen button

●

Executes printing. (Section 20.7)

●

Executes print preview. (Section 20.9)

●  (Not supported by FXCPU)
Displays the details of the I/O assignment settings. (Section 6.1)

●

Deletes the set parameters.

●

Checks whether the set parameters are correct.

● Function to apply the parameters of MELSOFT Navigator
• Parameter items which can be set from MELSOFT Navigator are displayed in green when GX Works2 is started from 

MELSOFT Navigator.
• Parameters which are set by the function to apply the parameters of MELSOFT Navigator cannot be edited. To edit, 

select "Enable an editing of parameters set in MELSOFT Navigator" under [Tool] ⇒ [Options] ⇒ "iQ Works 
Interaction".

● Number of columns displayed on the CC-Link Module Configuration screen (QCPU (Q mode)/LCPU only)
A number of columns can be changed by selecting 4 or 2 columns for "Display number of columns for CC-Link list 
setting" under [Tool] ⇒ [Options] ⇒ "Parameter".
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6.3.1  Network parameter item list

6.3.1 Network parameter item list

*1 : CC IE Field head module only

The following table shows the applicable network parameter types for each programmable controller 
type.
For details of each item, refer to the following manuals.
(User's manuals and reference manuals of each module)

: Applicable −: Not applicable

Remote HeadQ CPU L CPU FX
*1

Network type

Q series L series FX series

Basic model 
QCPU

High Performance 
model QCPU/
Process CPU/

Redundant CPU

Universal 
model 
QCPU

Remote I/O 
module LCPU CC IE Field head 

module FXCPU

CC-Link IE Controller 
Network*1    – – – –

CC-Link IE Field Network – –  –  – –

MELSECNET/10    – – – –

MELSECNET/H    – – – –

MELSECNET/H 
Remote I/O –   – – – –

Ethernet      – –

CC-Link       *2

*1 : CC-Link IE Controller Network modules with the function version D and a serial number whose first 5 digits are '10041' or higher are 
supported.
For Process CPU and Redundant CPU, CC-Link IE Controller Network modules with a serial number whose first five digits are '10042' or 
higher is required.

*2 : Supported by FX3G, FX3GC, FX3U, and FX3UC only.



6.3  Setting Network Parameters

6.3.1  Network parameter item list 6 - 23

1

O
V

E
R

V
IE

W

2

S
YS

TE
M

 
C

O
N

FI
G

U
R

A
TI

O
N

3

SC
RE

EN
 

CO
NF

IG
UR

AT
IO

N 
AN

D 
BA

SI
C 

O
PE

RA
TI

ON
S

4

P
R

O
JE

C
T 

M
A

N
A

G
E

M
E

N
T

5

ED
IT

IN
G

 
PR

O
G

R
AM

S

6

S
E

TT
IN

G
 

PA
R

A
M

E
TE

R
S

7

S
ET

TI
N

G
 D

E
V

IC
E

 
M

E
M

O
R

Y

8

S
E

TT
IN

G
 D

E
V

IC
E

 
IN

IT
IA

L 
V

A
LU

ES

■ CC-Link IE setting

Item Description

Network Type Specify the network type (CC-Link IE) whose parameters are to be set.

Start I/O No. Set the start I/O number.

Network No. Set the network number.

Total Stations Set the total number of (slave) stations.

Group No.*1 Set the group number.

Station No. Set the station number of a module.

Mode Set the mode.

Network Range 
Assignment/
Network 
Configuration 
Settings 
(Common 
parameters)

Specify I/O 
Master Station*1 Set the I/O master station.

Specify Reserved 
Station*1 Specify the reserved station.

Equal Assignment Assign the number of link device points of all stations equally.

Identical Point 
Assignment Assign the equal number of link device points based on the total number of set stations.

Shared Group 
Setting*2 Set the shared group of the group cyclic function.

Supplementary 
Setting

Set the link scan mode setting, loopback function setting, block data assurance per 
station, and operation setting for returning.

Network Operation Settings*3 Set the parameter name, data link faulty station setting, output setting during CPU 
STOP, IP address setting, and other settings.

Refresh Parameters Set refresh parameters.

Interrupt Settings Set the device code, detection method, interrupt condition, interrupt (SI) number, and 
other settings.

Specification method for station 
number

Set whether to set a station number by program or by parameter.
The station number can be specified by program only when the normal station or the 
local station is selected in a project for Universal model QCPU/LCPU.

Operate with parameter of host/
master station*4

Set whether to operate link device points and assignments of the slave station with the 
parameter set on the host station or the parameter set on the master station.
This item can be set for sub-master station only.

Redundant Setting Set the system B mode.

*1 : For CC-Link IE Controller Network only
*2 : For CC-Link IE Controller Network of Universal model QCPU only
*3 : For CC-Link IE Controller Network of Universal model QCPU (except for Q00UJ/Q00U/Q01U/Q02U), IP address setting 

only
*4 : For CC-Link IE Field Network only
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6.3.1  Network parameter item list

■ MELSECNET/10 and MELSECNET/H setting

Item Description

Network Type Specify the network type (MELSECNET/10 mode or MELSECNET/H mode) whose 
parameters are to be set.

Start I/O No. Set the start I/O number.

Network No. Set the network number.

Total Stations Set the total number of (slave) stations.

Group No. Set the group number.

Mode Set the mode.

Network Range 
Assignment 
(Common 
parameters)

Specify I/O 
Master Station Set the I/O master station.

Specify Reserved 
Station Specify the reserved station.

Equal Assignment Assign the number of link device points of all stations equally.

Identical Point 
Assignment Assign the equal number of link device points based on the total number of set stations.

Supplementary 
Setting Set the transient setting, low-speed cyclic setting, and other settings.

Station Inherent 
Parameters Set station inherent parameters.

Refresh Parameters Set refresh parameters.

Interrupt Settings Set the device code, detection method, interrupt condition, interrupt (SI) number, and 
other settings.

Operation at reconnection*1 Set whether to operate the station as a control station or a normal station when the line 
is reconnected.

Baud Rate Setting*1 Set the baud rate on modules that support the twist bus.

Redundant Setting Set the system B mode.

*1 : For MELSECNET/H (control station) and MELSECNET/H extended mode (control station) only
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■ MELSECNET/H Remote I/O setting

■ Ethernet setting

Item Description

Network Type Set "MELSECNET/H (remote master)".

Start I/O No. Set the start I/O number.

Network No. Set the network number.

Total Stations Set the total number of (slave) stations.

Mode Set the mode.

Network Range 
Assignment 
(Common 
parameters)

Specify Reserved 
Station Specify the reserved station.

Equal Assignment Assign the number of link device points of all stations equally.

Supplementary 
Setting Set the constant scan time and the maximum number of return stations in one link scan.

Refresh Parameters Set refresh parameters.

Interrupt Settings Set the device code, detection method, interrupt condition, interrupt (SI) number, and 
other settings.

Redundant Setting Set the system B mode.

Item Description

Network Type Specify "Ethernet".

Start I/O No. Set the start I/O number.

Network No. Set the network number.

Group No. Set the group number.

Station No. Set the station number.

Mode Set the mode.

Operation Setting Set the common items for the module.

Initial Setting
• Set data communication timer values.
• Set IP addresses for DNS servers.

Open Setting Set parameters required for the open processing.

Router Relay Parameter Set parameters for the router relay function of Ethernet.

Station No.  IP Information
Set information to link network number and station number with IP address for 
communication target station or relay station when communicating with another station 
programmable controller CPU via Ethernet.

FTP Parameters*1 Set FTP parameters such as the login name, password, command input monitoring 
timer, and PLC monitoring timer.

E-mail Setting*1

General Setting Set the password, e-mail address, and inquiry interval for receiving mails.

Mail Server Name Set the SMTP server, POP server, and IP addresses for both servers.

Send Mail 
Address Setting Set addresses of send mail.

News Setting Set the notifying condition.

Interrupt Settings*1 Set the device code, detection method, interrupt condition, interrupt (SI) number, and 
other settings.

Redundant Setting*2 Set the system B, system switching settings when communication error occurs, and 
other settings.

*1 : Not supported by remote I/O module.
*2 : The redundant setting cannot be set when "Ethernet (Extension Base)" is selected. (Different IP addresses cannot be 

assigned to each system.)
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6.3.1  Network parameter item list

● Connecting MELSOFT products via Ethernet
When connecting a MELSOFT product (such as GX Works2) via Ethernet, select "MELSOFT Connection" for "Open 
System" on the Ethernet Open Setting screen. For details of the setting, refer to Ethernet Interface Module User's 
Manual.
'MELSOFT Connection' is supported by Q series-compatible E71 function version B modules with a serial number 
whose first 5 digits are '02122' or higher.
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■ QCPU (Q mode)/LCPU CC-Link setting

Item Description

Number of Modules Set the number of CC-Link master/local modules.

Set the station information in the CC-
Link configuration window Select this to set station information on the CC-Link configuration window.

Start I/O No. Set the start I/O number.

Operation Setting
Set the Parameter Name, Data Link Disorder Station, Case of CPU Stop Setting, 
Number of Exclusive Station, Expanded Cyclic Setting, Block Data Assurance per 
Station, and Auto Detect Setting of the Connected Device.

Type Set the station type such as a master/local/standby master station.

Station No.*1 Set the station number.

Master Station Data Link Type The setting is fixed to "PLC Parameter Auto Start" for the master station.

Mode Set the mode.

Transmission Speed*1 Set the transmission speed.

Total Module Connected Set the total number of remote stations, local stations, intelligent device stations, and/or 
standby master stations connected to the master station.

Remote Input (RX)

Set the devices to refresh the data of RX, RY, RWr, and RWw.
Remote Output (RY)

Remote Register (RWr)

Remote Register (RWw)

Ver.2 Remote Input (RX)

Set the devices to refresh the data of RX, RY, RWr, and RWw for the remote network 
additional mode.

Ver.2 Remote Output (RY)

Ver.2 Remote Register (RWr)

Ver.2 Remote Register (RWw)

Special Relay (SB)
Set the devices to refresh the data of SB and SW.

Special Register (SW)

Retry Count Set the number of retries in case a communication error occurs.

Automatic Reconnection Station 
Count

Set the number of remote stations, local stations, intelligent device stations, and/or 
standby master stations that can be returned to the system in one link scan.

Standby Master Station No. Specify the station number of the standby master station.

PLC Down Select Specify the data link status when an error occurs on the programmable controller CPU 
on the master station.

Scan Mode Setting Specify whether to synchronize the link scan with the sequence scan.

Delay Time Setting Set the link scan interval delay time.

Station Information Setting*2

The setting screen and the setting items differ according to the selected/cleared status 
of "Set the station information in the CC-Link configuration window".
• Cleared

Set station information on the CC-Link Station Information screen. Set the settings 
such as the station type and the number of occupied stations.
A number of rows can be changed by selecting 16 or 8 rows for "Display number of 
rows for CC-Link station information" under [Tool] ⇒ [Options] ⇒ "Parameter".

• Selected
Set station information on the CC-Link configuration window. In addition to the setting 
items on the CC-Link Station Information screen, settings such as the module type 
are set. The equipment configuration is displayed graphically.

Remote Device Station Initial Setting Set the target station number and procedure registration (such as operating condition 
and executing condition).

Interrupt Settings*3 Set the device code, detection method, interrupt condition, interrupt (SI) number, and 
other settings.

*1 : For LCPU and CC IE Field head module only.
*2 : With the station information set on the CC-Link configuration window, only the corresponding setting items on the CC-Link 

Station Information screen are printed when executing the batch print or print window function. The equipment 
configuration on the CC-Link configuration window is not printed.

*3 : Not supported by CC IE Field head module and remote I/O module.
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6.3.1  Network parameter item list

■ FXCPU CC-Link setting

This parameter setting is supported by FX3G, FX3GC, FX3U, and FX3UC only.

Item Description

Connection Block Select "Set" to set a CC-Link master block.

Special Function Block No. Specify the special function block number (0 to 7).

Operation Setting Set the Parameter Name, Data Link Disorder Station, and Case of CPU Stop Setting.

Type This setting is fixed to "Master Station" when "Set" is selected for "Connection Block".

Master Station Data Link Type This setting is fixed to "PLC Parameter Auto Start" when "Set" is selected for 
"Connection Block".

Mode Set the mode.

Total Module Connected Set the total number of remote I/O stations, remote device stations, and/or intelligent 
device stations (including reserve stations) connected to the master station.

Retry Count Set the number of retries in case a communication error occurs.

Automatic Reconnection Station 
Count

Set the number of remote I/O stations, remote device stations, and/or intelligent device 
stations that can be returned to the system in one link scan.

PLC Down Select Specify the data link status when an error occurs on the programmable controller CPU 
on the master station.

Station Information Setting
Set the station type, exclusive counts, and other settings.
A number of rows can be changed by selecting 16 or 8 rows for "Display number of 
rows for CC-Link station information" under [Tool] ⇒ [Options] ⇒ "Parameter".

Remote Device Station Initial Setting Set the target station number and procedure registration (such as operating condition 
and executing condition).
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6.3.2 Setting station information on CC IE Field configuration 
window

Network configuration and equipment configuration of CC-Link IE Field Network can be set when "CC 
IE Field (Master Station)" or "CC IE Field (Sub-Master Station)" is set in the CC-Link IE Field Network 
parameter.
Select "Set the network configuration setting in the CC IE Field configuration window" on the 
MELSECNET/CC-Link IE/Ethernet Module Configuration screen in advance.

Screen display

Click the  button on the MELSECNET/CC-Link IE/Ethernet Module 
Configuration screen.

Operating procedure

1. Select the module from the module list, and drag and drop it to the 'list of stations' 
or 'equipment configuration'.
The slave station is added to the 'list of stations'.
The added module is displayed on the 'equipment configuration'.

Q CPU L CPU FXRemote FXHead FXFX

List of 

stations

Equipment 

configuration

Drag and drop



6 - 30

GX Works2

6  SETTING PARAMETERS

6.3.2  Setting station information on CC IE Field configuration window

2. Set the items on the screen.

3. Select [CC IE Field Configuration] ⇒ [Close with Reflecting the Setting].
Exit the settings of the CC-Link configuration window.

Screen button

● /
Moves the position of the module selected in the 'list of stations' up/down. The station number does 
not change even when the position of the module is moved.

Item Description

Mode Setting Select the mode by clicking .

Assignment Method Specify the assignment method by clicking .

Link Scan Time (Approx.) Display the approximate value of link scan time.

List of stations Display the list of stations which configure CC-Link IE Field Network.

Module No. "0" is displayed for master station, and 'slave station number' is displayed for slave station.

Model Name
Display the module type of master station/slave station.
When the module information does not exist, "Module without profile" is displayed.
Set this item after registering the profile.

Station No. Set the station number of the master station/slave station in the range from 1 to 120.

Station Type
Display the station type of master station/slave station.
Click the cell and select the station type displayed by clicking .

RX/RY Setting Set the RX/RY assignment for each slave station.
Set RX/RY in 16-point unit.

RWw/RWr Setting Set the RWw/RWr assignment for each slave station.
Set RWw/RWr in 4-point unit.

Refresh Device
Display devices of the CPU module to which link devices of master/local module are link-
refreshed.
This item is displayed only when the refresh parameter is set.

Reserved/Error Invalid 
Station

Display the setting status of reserved station/error invalid station for slave station.
Click the cell and select the reserved station/error invalid station displayed by clicking .

Alias Display the device name.

Comment Display the information set to comment 1 on the Property screen.

Station-specific mode 
setting Display the station-specific mode of the module.

Equipment configuration Display the equipment configuration of CC-Link IE Field Network graphically.
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● Considerations when the selected status of "Set the network configuration setting in the CC IE Field 
configuration window" is changed
The following are the considerations when editing the network configuration by changing selected/cleared status.
• Selecting the item

The network configuration of "CC IE Field (Master Station)" or "CC IE Field (Sub-Master Station)" set on the 
MELSECNET/CC-Link IE/Ethernet Module Configuration screen is set on the CC IE Field configuration window 
automatically.
Note that, all modules of the network configuration are changed to general-purpose CC IE Field modules. The file 
size of parameter to be written to the programmable controller CPU increases.

• Clearing the item
The network configuration set on the CC IE Field configuration window is set on the MELSECNET/CC-Link IE/
Ethernet Module Configuration screen automatically.

● Setting general-purpose CC IE Field modules
When a non-Mitsubishi module or a module which is not displayed on the module list is used, drag and drop a general-
purpose CC IE Field module.
A general-purpose CC IE Field module can be replaced with a specific module.
(■ Replacing general-purpose CC IE Field module)

● Display of module name on the 'equipment configuration'
"Object Name" on the Properties screen is displayed for each module name on the 'equipment configuration'.
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6.3.2  Setting station information on CC IE Field configuration window

■ Replacing general-purpose CC IE Field module

Replace a general-purpose CC IE Field module of slave station with a specific module.

Operating procedure

1. Select the general-purpose CC IE Field module to be replaced in the 'list of stations' 
on the CC IE Field configuration window.

2. Select [CC IE Field Configuration] ⇒ [Change Module] ⇒ [Replace General CC IE 
Field Module].
The Replace General CC IE Field Module screen is displayed.

3. Set the items on the screen.

4. Click the  button.
The general-purpose CC IE Field module in the list of stations is replaced with the module selected 
for "Replacement Candidate".
The general-purpose CC IE Field module displayed on the 'equipment configuration' is replaced 
with the module selected for "Replacement Candidate".

Item Description

Replacement Target –

Station Type Display the station type selected on the CC IE Field configuration window.

List of modules to be 
replaced

Display modules with the same condition as the one selected for "Replacement Target".
Select the check box(es) on the "Station Number" column of the module to be replaced. 
Two or more modules can be selected.

Replacement Candidate Select the module to be replaced with.

List of modules 
to be replaced

The general-purpose 

module is replaced with 

the selected module.
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Screen button

●

Selects all modules displayed on "Replacement Target".

●

Cancels the selected status of all modules selected for "Replacement Target".

■ Replacing to general-purpose CC IE Field module

Replace a module of slave station to a general-purpose CC IE Field module.

Operating procedure

1. Select a module to be replaced in the 'list of stations' on the CC IE Field 
configuration window.

2. Select [CC IE Field Configuration] ⇒ [Change Module] ⇒ [Change to General CC IE 
Field Module].
The module is replaced to the corresponding general-purpose CC IE Field module.

■ Changing transmission path method

Change the transmission path method to line/star or ring.

Operating procedure

• Select [CC IE Field Configuration] ⇒ [Change Transmission Path Method] ⇒ [Line/
Star]/[Ring].
The transmission path method is changed to the selected transmission path method.

● Transmission path method and loopback function setting
The change of transmission path method and the loopback function setting on the CC IE Field Supplementary Setting 
screen are linked.
When line/star is selected, the loopback function setting is disabled.
When ring is selected, the loopback function setting is enabled.
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6.3.2  Setting station information on CC IE Field configuration window

■ Setting supplementary functions

Set the link scan mode setting, loopback function setting, block data assurance per station, and 
operation setting for returning.

Operating procedure

1. Select [CC-IE Field Configuration] ⇒ [Supplementary Setting].
The CC IE Field Supplementary Setting screen is displayed.

2. Set the items on the screen.

3. Click the  button.
The settings are applied to the CC IE Field configuration window.

● Transmission path method and loopback function setting
The change of transmission path method and the loopback function setting on the CC IE Field Supplementary Setting 
screen are linked.
When "Use" is cleared for the loopback function setting, line/start is selected for the setting under [CC IE Field 
Configuration] ⇒ [Change Transmission Path Method].
When "Use" is selected for the loopback function setting, ring is selected for the setting under [CC IE Field 
Configuration] ⇒ [Change Transmission Path Method].

Item Description

Link Scan Mode Setting Set the link scan mode.

Loopback Function Setting Set whether to use the loopback function.
Select this item when the transmission path method is ring.

Block Data Assurance per 
Station

Set whether to assure block data per station for link refreshes between the CPU module 
and the master/local module.
Select this when including a remote device station in the network configuration.

Operation Setting for Returning Set whether to operate the station as a master station or a sub-master station when the 
station is reconnected.



6.3  Setting Network Parameters

6.3.2  Setting station information on CC IE Field configuration window 6 - 35

1

O
V

E
R

V
IE

W

2

S
YS

TE
M

 
C

O
N

FI
G

U
R

A
TI

O
N

3

SC
RE

EN
 

CO
NF

IG
UR

AT
IO

N 
AN

D 
BA

SI
C 

O
PE

RA
TI

ON
S

4

P
R

O
JE

C
T 

M
A

N
A

G
E

M
E

N
T

5

ED
IT

IN
G

 
PR

O
G

R
AM

S

6

S
E

TT
IN

G
 

PA
R

A
M

E
TE

R
S

7

S
ET

TI
N

G
 D

E
V

IC
E

 
M

E
M

O
R

Y

8

S
E

TT
IN

G
 D

E
V

IC
E

 
IN

IT
IA

L 
V

A
LU

ES

■ Assigning link devices equally

Assign link device points of all stations equally.

Operating procedure

1. Select [CC IE Field Configuration] ⇒ [Equal Assignment].
The Equal Assignment screen is displayed.

2. Set the items on the screen.

3. Click the  button.
Link devices are assigned equally to the slave stations within the set range.

Item Description

RX/RY Equal Assignment

Start Station Set the start station number to be assigned equally.

End Station Set the last station number to be assigned equally.

Start No. Set the start number of the link device to be assigned equally.

Total Points Assigned Set the total number of link device points to be assigned equally.

RWw/RWr Equal Assignment

Start Station Set the start station number to be assigned equally.

End Station Set the last station number to be assigned equally.

Start No. Set the start number of the link device to be assigned equally.

Total Points Assigned Set the total number of link device points to be assigned equally.



6 - 36

GX Works2

6  SETTING PARAMETERS

6.3.2  Setting station information on CC IE Field configuration window

■ Assign the equal number of link device points

Assign the equal number of link device points based on the total number of set stations.

Operating procedure

1. Select [CC IE Field Configuration] ⇒ [Identical Point Assignment].
The Identical Point Assignment screen is displayed.

2. Enter the number of points to be assigned.

3. Click the  button.
The equal number of points is assigned per stations.

■ Checking system configuration of CC-Link IE Field Network

Check whether the equipment configuration of CC IE Field is correct after setting the network 
configuration on the CC IE Field configuration window.

Operating procedure

• Select [CC IE Field Configuration] ⇒ [Check] ⇒ [System Configuration].
The system configuration of CC-Link IE Field Network is checked.
Check the result of the system configuration check on the Output window.
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■ Performing parameter processing of slave station

Perform the processing relates to parameters of slave stations.
The applicable parameter processing differs according to the target slave station.
The setting status and setting values of the Parameter Processing of Slave Station screen can be 
saved in the CSV file format.

● Considerations when performing parameter processing
Check the following before performing the parameter processing.
• The programmable controller CPU set as a connection target is in STOP status.
• The network parameter of master station matches with the start I/O number of PLC parameter.
• The network parameter of programmable controller CPU matches with the actual CC IE Field configuration.

Operating procedure

1. Select a module to which parameters are applied from the 'list of stations' on the 
CC IE Field configuration window.

2. Select [CC IE Field Configuration] ⇒ [Parameter Processing of Slave Station].
The Parameter Processing of Slave Station screen is displayed.
The following is a screen of NZ2GF2B1-16D.
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6.3.2  Setting station information on CC IE Field configuration window

3. Set the items on the screen.

4. Click the  button.
The parameter processing is performed.

Screen button

●

Selects all parameters of "Parameter Information".

●

Cancels the selected status of all the parameters selected for "Parameter Information".

●

Imports the selected status and writing values of "Parameter Information" saved in the CSV file 
format in advance.

●

Saves the selected status and writing values of "Parameter Information" in the CSV file format.

Item Description

Target Module Information Display the slave stations on which the parameter processing is performed.

Method selection Select a processing to be performed from the list displayed by clicking .

Parameter Information Display the parameters of the slave station.
The selected parameters are the targets of the selected process to be executed.

Process Option Set this for the processing selected for "Method selection".
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■ Performing commands for slave stations

Perform commands for slave stations.
Applicable commands differ according to the target slave station.

Operating procedure

1. Select a module on which a command is performed from the 'list of stations' on the 
CC IE Field configuration window.

2. Select [CC IE Field Configuration] ⇒ [Command Execution of Slave Station].
The Command Execution of Slave Station screen is displayed.
The following is a screen of NZ2GF2B1-16D.

3. Set the items on the screen.

4. Select the  button.
The command processing is performed.
The result of the processing is displayed on "Execution Result".

Item Description

Target Module Information Display the information of target module on which the command is performed.

Method selection Select a processing to be performed from the list displayed by clicking .

Command Setting Set the writing values set for the processing selected for "Method selection".
For details, refer to the manual of the slave station being used.
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■ Copying/pasting modules

Copy/paste a selected module.

Operating procedure

1. Select "Module No." or "Model Name" of the CC-Link module to be copied from the 
'list of stations'.
The corresponding row is selected.

2. Select [Edit] ⇒ [Copy].
The selected module is copied.

3. Select [Edit] ⇒ [Paste].
The copied module is added to the last row of the 'list of stations'.

● Selected status of modules
All cells on the 'list of stations' can be selected by selecting [Edit] ⇒ [Select All].

■ Deleting modules

Delete a selected module.

Operating procedure

1. Select "Module No." or "Model Name" of the module to be deleted from the 'list of 
stations'.
The corresponding row is selected.

2. Select [Edit] ⇒ [Delete].
The selected module is deleted.

Select "Module No." 

or "Model Name".

Select "Module No." 

or "Model Name".
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■ Displaying/hiding Module List/Output/Supplementary Information window

Display/hide the Module List/Output/Supplementary Information window.

Operating procedure

• Select [View] ⇒ [Docking Window] ⇒ [Module List]/[Output]/[Supplementary 
Information].

● Displaying Module List/Output/Supplementary Information window
The Module List/Output/Supplementary Information window can be displayed as a docked display/floating display.
(Section 3.2.4 "Docking windows")



6 - 42

GX Works2

6  SETTING PARAMETERS
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6.3.3 Setting station information on CC-Link configuration 
window

Station information and equipment configuration of CC-Link can be set when master station or master 
station (duplex function) is set in the CC-Link network parameter.
Select "Set the station information in the CC-Link configuration window" on the CC-Link network 
parameter screen in advance.

Screen display

Click  on the network parameter screen of CC-Link.

Operating procedure

1. Select a module from the module list, and drag and drop it to the 'list of stations' or 
'equipment configuration'.
A slave station is added to the 'list of stations'.
The added module is displayed on the 'equipment configuration'.

Q CPU L CPU FXRemote FXHead FXFX

List of stations

Equipment

 configuration

Drag and drop



6.3  Setting Network Parameters

6.3.3  Setting station information on CC-Link configuration window 6 - 43

1

O
V

E
R

V
IE

W

2

S
YS

TE
M

 
C

O
N

FI
G

U
R

A
TI

O
N

3

SC
RE

EN
 

CO
NF

IG
UR

AT
IO

N 
AN

D 
BA

SI
C 

O
PE

RA
TI

ON
S

4

P
R

O
JE

C
T 

M
A

N
A

G
E

M
E

N
T

5

ED
IT

IN
G

 
PR

O
G

R
AM

S

6

S
E

TT
IN

G
 

PA
R

A
M

E
TE

R
S

7

S
ET

TI
N

G
 D

E
V

IC
E

 
M

E
M

O
R

Y

8

S
E

TT
IN

G
 D

E
V

IC
E

 
IN

IT
IA

L 
V

A
LU

ES

2. Set the items on the screen.

3. Select [Close with Reflecting the Setting].
Exit the settings of the CC-Link configuration window.

Screen button

●  (LCPU only)
Acquires the station information and equipment configuration from the actual system configuration 
and displays them on the CC-Link configuration window. 
For operations and considerations of setting station information and equipment configuration with the 
Detect Now, refer to the following manual.
 iQ Sensor Solution Reference Manual

● /
Moves the position of the module selected in the 'list of stations' up/down.

Item Description

Mode Setting Select the mode by clicking .

TX Speed Set the transmission speed by clicking .

Link Scan Time (Approx.) Display the approximate value of link scan time.

List of stations Display the list of stations which configure CC-Link network.

Module No./Station No.

Display the number of slave stations and station numbers set to the master station.
"0/0" is displayed for master station, and 'slave station number/station number' is 
displayed for slave station.
Example: For a module set as the 3rd module of the slave station and its station 
number is 6: 3/6

Model Name Display the module type of master station/slave station.
When the module information does not exist, "Module without profile" is displayed.

Station Type
Display the station type of master station/slave station.
Click the cell and select the station type displayed by clicking .

Version
Display the module version of slave station.
Click the cell and select the version displayed by clicking .

# of STA Occupied
Display the number of occupied stations of slave station.
Click the cell and select the number of occupied stations displayed by clicking .

Expanded Cyclic Setting Display the expanded cyclic setting of slave station.

Remote Station Points Display the number of remote station points of slave station.

Reserved/Err Invalid STA
Display the setting status of reserved station/error invalid station for slave station.
Click the cell and select the reserved station/error invalid station displayed by clicking 

.

Intelligent Buffer Size (word)
Display buffer memory for Send/Receive/Auto when the salve station is an intelligent 
device station.
Click the cell and enter the value.

Station-specific mode 
setting

Display the setting when the station-specific mode setting is supported by the slave 
station.
Click the cell and select the station-specific mode displayed by clicking .

Equipment configuration Display the equipment configuration of CC-Link network graphically.
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● Considerations when the selected status of "Set the station information in the CC-Link configuration window" 
is changed
The following are the considerations when editing the station information by changing selected/cleared status.
• Selecting the item

The station information set on the CC-Link Station Information screen is set on the CC-Link configuration window 
automatically.
Note that, all modules of the station information are changed to general-purpose CC-Link modules. The file size of 
parameter to be written to the programmable controller CPU increases.

• Clearing the item
The station information set on the CC-Link configuration window is set on the CC-Link Station Information screen 
automatically.

● Setting general-purpose CC-Link modules
When a non-Mitsubishi module or a module which is not displayed on the module list is used, drag and drop a general-
purpose CC-Link module.
A general-purpose CC-Link module can be replaced with a specific module.
(■ Replacing general-purpose CC-Link module)

● Display of module name on the 'equipment configuration'
"Object Name" on the Properties screen is displayed for each module name on the 'equipment configuration'.
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■ Replacing general-purpose CC-Link module

Replace a general-purpose CC-Link module of slave station with a specific module.
A description of link device is displayed on the CC-Link Device Reference window by replacing a 
general-purpose CC-Link module with a specific module.

Operating procedure

1. Select a general-purpose CC-Link module to be replaced in the 'list of stations' on 
the CC-Link configuration window.

2. Select [CC-Link Configuration] ⇒ [Change Module] ⇒ [Replace General CC-Link 
Module].
The Replace General CC-Link Module screen is displayed.

3. Set the items on the screen.

Item Description

Replacement Target Display the version, the number of occupied stations, station type, and expanded cyclic 
setting of the module selected on the CC-Link configuration window.

List of modules to be 
replaced

Display modules with the same condition as the module selected for "Replacement 
Target".
Select the check box(es) on the "Station Number" column of the module to be replaced. 
Two or more modules can be selected.

Replacement Candidate Select a module to be replaced with.

List of modules 

to be replaced
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4. Click the  button.
The general-purpose CC-Link module in the list of stations is replaced with the module selected for 
"Replacement Candidate". The general-purpose CC-Link module displayed on the 'equipment 
configuration' is replaced with the selected module.

Screen button

●

Selects all modules displayed on "Replacement Target".

●

Cancels the selected status of all modules selected for "Replacement Target".

■ Changing to general-purpose CC-Link module

Change a module of slave station to a general-purpose CC-Link module.

Operating procedure

1. Select a module to be changed in the 'list of stations' on the CC-Link configuration 
window.

2. Select [CC-Link Configuration] ⇒ [Change Module] ⇒ [Change to General CC-Link 
Module].
The module is changed to the corresponding general-purpose CC-Link module.

■ Checking system configuration of CC-Link

Check whether the equipment configuration of CC-Link is correct after setting the station information on 
the CC-Link configuration window.

Operating procedure

• Select [CC-Link Configuration] ⇒ [Check] ⇒ [System Configuration].
The system configuration of CC-Link is checked.
Check the result of the system configuration check on the Output window.

The general-purpose 

module is replaced with 

the selected module.
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■ Performing parameter processing of slave station

Perform the processing relates to parameters of slave stations.
The applicable parameter processing differs according to the target slave station.
The setting status and setting values of the Parameter Processing of Slave Station screen can be 
saved in the CSV file format.

● Considerations when performing parameter processing
Check the following before performing the parameter processing.
• The programmable controller CPU set as a connection target is in STOP status.
• The network parameter of master station matches with the start I/O number of PLC parameter.
• The network parameter of programmable controller CPU matches with the actual CC-Link configuration.
• A refresh device is set on the CC-Link parameter of programmable controller CPU.

Operating procedure

1. Select a module to which parameters are applied from the 'list of stations' on the 
CC-Link configuration window.

2. Select [CC-Link Configuration] ⇒ [Online] ⇒ [Parameter Processing of Slave 
Station].
The Parameter Processing of Slave Station screen is displayed.
The following is a screen of FR-A720-0.4K.
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6.3.3  Setting station information on CC-Link configuration window

3. Set the items on the screen.

4. Click the  button.
The parameter processing is performed.

Screen button

●

Selects all parameters of "Parameter Information".

●

Cancels the selected status of all the parameters selected for "Parameter Information".

●

Imports the selected status and writing values of "Parameter Information" saved in the CSV file 
format in advance.

●

Saves the selected status and writing values of "Parameter Information" in the CSV file format.

Item Description

Target Module Information Display the information of target equipment on which the parameter processing is 
performed.

Method selection Select a processing to be performed from the list displayed by clicking .

Parameter Information Select the parameter(s) to perform the processing and enter settings such as a 
writing value.

Display only selectable 
parameters

Select this to display only parameters to which the processing selected for 
"Method selection" can be performed.

Process Option Set this for the processing selected for "Method selection".
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■ Performing commands for slave stations

Perform commands for slave stations.
Applicable commands differ according to the target slave station.

● Considerations when performing commands
Check the following before performing commands.
• The programmable controller CPU set as a connection target is in STOP status.
• The network parameter of master station matches with the start I/O number of PLC parameter.
• The network parameter of programmable controller CPU matches with the actual CC-Link configuration.
• A refresh device is set on the CC-Link parameter of programmable controller CPU.

Operating procedure

1. Select a module on which a command is performed from the 'list of stations' on the 
CC-Link configuration window.

2. Select [CC-Link Configuration] ⇒ [Online] ⇒ [Command Execution of Slave 
Station].
The Command Execution of Slave Station screen is displayed.
The following is a screen of FR-A720-0.4K.

3. Set the items on the screen.

4. Click the  button.
The command processing is performed.
The result of the processing is displayed on "Execution Result".

Item Description

Target Module Information Display the information of target module on which the command is performed.

Method selection Select a processing to be performed from the list displayed by clicking .

Command Setting Set the writing values for the processing selected for "Method selection".



6 - 50

GX Works2

6  SETTING PARAMETERS

6.3.3  Setting station information on CC-Link configuration window

■ Copying/pasting modules

Copy/paste a selected module.

Operating procedure

1. Select "Module No./Station No." or "Model Name" of the module to be copied from 
the 'list of stations'.
The corresponding row is selected.

2. Select [Edit] ⇒ [Copy].
The selected module is copied.

3. Select [Edit] ⇒ [Paste].
The copied module is added to the last row of the 'list of stations'.

■ Deleting modules

Delete a selected module.

Operating procedure

1. Select "Module No./Station No." or "Model Name" of the module to be deleted from 
the 'list of stations'.
The corresponding row is selected.

2. Select [Edit] ⇒ [Delete].
The selected module is deleted.

● Selected status of modules
All cells on the 'list of stations' can be selected by selecting [Edit] ⇒ [Select All].

Select "Module No.

/Station No." or 

"Model Name".

Select "Module No.

/Station No." or 

"Model Name".
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■ Displaying/hiding Module List/Output window

Display/hide the Module List/Output window.

Operating procedure

• Select [View] ⇒ [Docking Window] ⇒ [Module List]/[Output].

● Displaying Module List/Output window
The Module List/Output window can be displayed as a docked display/floating display.
(Section 3.2.4 "Docking windows")
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6.3.4  Registering profiles

6.3.4 Registering profiles

Register profiles in GX Works2.
Profiles are data in which equipment information (module models, number of occupied stations, station 
types, etc.) of CC IE Field modules and CC-Link modules is stored.
CC IE Field modules or CC-Link modules of slave stations are added to the module list on the CC IE 
Field configuration window or the CC-Link configuration window by registering profiles. The previously 
registered module information is also updated.
Close the project in advance when registering profiles.

Screen display
Select [Tool] ⇒ [Register Profile].

Operating procedure

• Select the profile, and click the  button.
The profile is registered.
The added module can be found in the module list on the CC IE Field configuration window or the 
CC-Link configuration window when the project is opened next time.
The following is the display of the CC-Link configuration window.

Q CPU L CPU FXRemote FXHead FXFX

A CC-Link module 

is added.
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● Managing profiles
Profiles are managed by each personal computer, and shared within GX Works2 and MELSOFT Navigator. Therefore, 
profiles registered in GX Works2 are applied to MELSOFT Navigator.

6.3.5 Checking devices assigned to CC-Link modules

Display a list of refresh devices assigned to CC-Link modules.
Set the CC-Link parameters in advance.

Screen display
Select [View]  ⇒ [Docking Window] ⇒ [CC-Link Device Reference] ( ).
● List of slave stations

● List of link devices

Q CPU L CPU FXRemote FXHead FXFX

< When "Display Detailed Configuration Information" is cleared >

< When "Display Detailed Configuration Information" is selected >

List of 

slave stations

< When "Display Detailed Configuration Information" is cleared >

< When "Display Detailed Configuration Information" is selected >

List of 

link devices
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6.3.5  Checking devices assigned to CC-Link modules

Operating procedure

• Set the items on the screen.

Display contents

Screen button

●

Opens the screen to set the display options.
Select the item displayed by clicking  for "Module Name/Object Name" and "Buffer Memory 
Display Format", and click the  button.

Item Description

Master/Local Start I/O No.
Select the start I/O number of master station or local station from the list displayed by 
clicking  to display the list of slave stations or link devices.

Slave Station List
Switch the display between the list of slave stations and the list of link device stations.

Link Device List

Display Detailed Configuration 
Information

Select this to display the detailed information of the list of slave stations or list of link 
devices.

Item Description

Slave Station List This item is displayed when 'list of slave stations' is selected.

List of slave stations

Display the information of the slave stations and the range of the refresh devices 
assigned to the host station.
When "Display Detailed Configuration Information" is selected, the range of the buffer 
memory is also displayed.
When refresh devices are not assigned, the cells of the refresh device range will be 
blank.

Link Device List This item is displayed when 'list of link device stations' is selected.

List of link device stations

Display the assignment status of refresh devices on the host station and link devices on 
the target station.
When "Display Detailed Configuration Information" is selected, link devices and buffer 
memory are also displayed on the host station side.
When profiles are not registered, the "Explanation" cells will be blank.
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●

Opens the screen to set the purpose and the output format of CSV file output.
Set "Use", "Select Data Range", and "Label Output Format", and click the  button.

When "Output CSV file for global label" is selected for "Use", the output CSV file can be imported on 
the Global Label Setting screen.
(GX Works2 Version 1 Operating Manual (Simple Project))
(GX Works2 Version 1 Operating Manual (Structured Project))
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6.3.5  Checking devices assigned to CC-Link modules

● Display content of CC-Link Device Reference window
All items are displayed on the CC-Link Device Reference window when the station information is set on the CC-Link 
configuration window.
When the station information is set on the CC-Link Station Information screen, the model name or object name of the 
target module is not displayed. When a local station, master station (duplex function), or standby master station is set 
for the type, the assignment status of refresh devices is not displayed.

● Checking refresh devices supported by master station and local station
With a CC-Link configuration containing a local station, when checking refresh devices supported by refresh devices 
which are set on the master station, open the project of the local station and check them on the CC-Link Device 
Reference window.
Example: When checking refresh devices of local station which supports refresh device D2008 of the master station

● Displaying list of link devices
• The selected slave station can be displayed on top of the cell by right-clicking 'list of link devices' and selecting 

[Select Slave Station] from the shortcut menu.

• The Device/Buffer Memory Batch Monitor screen is displayed by right-clicking a refresh device or buffer memory 
selected from the 'list of link devices' and selecting [Device/Buffer Memory Batch] from the shortcut menu. For details 
of the device/buffer memory batch monitoring, refer to Section 14.3.

< Project of master station >

The value of RWw3 is refreshed by the value of D2008.

< Project of local station >

The value of D3008 is refreshed by the value of RWr3.

When a value is stored to D2008 

on the master station, a value is 

stored to D3008 on the local station.

The station number 7 

is displayed at the top.
Select the station number 7 

of the slave station.
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6.4 Setting Remote Password

*1 : CC IE Field head module only

This section explains how to set a password to prevent illegal access from remote users to the QCPU 
(Q mode)/LCPU via a Q series-compatible E71 module, C24 module, or Built-in Ethernet type CPU.

Screen display
Select Project view ⇒ "Parameter" ⇒ "Remote Password".
The following is an example of setting screen when QCPU (Q mode) is selected.

Operating procedure

1. Set the items on the screen.

2. Click the  button.
The Password Confirmation screen is displayed.

3. Enter the set password again.

Remote HeadQ CPU L CPU
*1

FX

Item Description

Password Set the password.

Password Active 
Module Setting

Model Name Set the model of the routing programmable controller CPU or module.
For the programmable controller CPU, select "Built-in Ethernet type CPU".

Start XY Set the start I/O number.

Condition

Set the details when selecting Built-in Ethernet type CPU or QJ71E71.
● User connection No. valid setting

Set whether to enable the remote password for the user connection No. 1 to No. 
16.

● System connection valid setting
Set whether to enable the remote password for the system connections.
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4. Click the  button.
The remote password setting ends.
To set the password on the programmable controller CPU, write the parameter to the 
programmable controller CPU using the Write to PLC function.
(Section 12.1)

● Modules that support remote password setting
For the modules that support the remote password setting and the details of the remote password setting, refer to the 
user's manual of the programmable controller CPU, Q series-compatible E71 module or C24 module to be used.

● Characters for password
Enter the password in 4 characters, using alphabets, numerals, and symbols corresponding to ASCII codes 20H to 7EH 
(Appendix 3).
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6.5 Checking Parameters

This section explains how to check errors in the PLC parameter and the network parameter which are 
set in the project.
The result of the parameter check is displayed on the Output window.

Screen display
Select [Tool] ⇒ [Check Parameter].

Operating procedure

1. Set the items on the screen.

2. Click the  button.
The check parameter is performed, and the result is displayed on the Output window.

Remote HeadQ CPU L CPU FX

<FXCPU><QCPU (Q mode)/LCPU>

Item Description

Check Target Select the items for the check parameter.
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6.6 Outputting Parameters to CSV Files

The following parameters can be written to CSV files.
● I/O assignment setting

Project view ⇒ "Parameter" ⇒ "PLC Parameter" ⇒ <<I/O Assignment>>
● Acknowledge XY assignment

Project view ⇒ "Parameter" ⇒ "PLC Parameter" ⇒ 

Project view ⇒ "Parameter" ⇒ "Network Parameter" ⇒ "(network parameter)" ⇒ 

Operating procedure

1. Click the  button.
The confirmation message for writing data is displayed.

2. Click the  button.
The Write to CSV file screen is displayed.

3. Enter a file name of the data to be saved.

4. Click the  button.
Parameters are saved to a CSV file.

Remote HeadQ CPU L CPU FXFX

< I/O assignment setting >
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■ CSV file format

The following is an image of the saved CSV file opened with Excel.
• Example of CSV file for I/O assignment setting

• Example of CSV file for acknowledge XY assignment

● Details of CSV file
The following explains the details of CSV file format.
• The file format is Unicode (including UTF-16, Little Endian, and BOM).
• The delimiter of items is a tab (\t).
• Each item is enclosed in double quotation marks (").
• If the item contains double quotation marks ("), the double quotation marks in the item are 

expressed as two double quotation marks ("").
• A line feed is set at the end of the line. 

The line feed code is LF.

< I/O Assignment setting >

< CSV file >

I/O assignment Detailed setting Switch setting Basic setting

< Acknowledge XY Assignment screen >

< CSV file >
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6.7 Setting default parameters

This section explains how to set default parameters to the PLC parameter or the network parameter in 
batch.

Screen display
Select [Tool] ⇒ [Clear All Parameters].
The following is an example of setting screen when QCPU (Q mode) is selected.

Operating procedure

1. Set the item on the screen.

2. Click the  button.
Default parameters are set to the selected parameter.

Remote HeadQ CPU L CPU FX

Item Description

Select Data Select the parameter to which default parameters are set.
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7 - 1

7 SETTING DEVICE 
MEMORY

This chapter explains the settings of the device memory.

7.1 Device Memory 7 - 2

7.2 Setting Device Memory 7 - 5

7.3 Searching Devices 7 - 15

7.4 Writing/Reading Device Memory Data 7 - 16
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7.1.1  Features of device memory

7.1 Device Memory

This section explains the features of the device memory.

7.1.1 Features of device memory

Device memory is the function that reads/writes data from/to the device memory on a programmable 
controller CPU.
● Read

The function batch-reads device memory data from a programmable controller CPU to GX Works2.
The read data can be used to check the status of the device memory on a programmable controller 
CPU as well as for offline debugging.

● Write
The function batch-writes device memory data from GX Works2 to a programmable controller CPU.
The current values of the device memory on a programmable controller CPU can be batch changed.

Q CPU L CPU FXFXRemote FXHead
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7.1.2 List of devices selectable on the Input Devices screen

■ QCPU (Q mode)/LCPU

: Can be edited : Display only –: Not supported

Category Device type Symbol Display/edit

Internal user device

Input X 

Output Y 

Internal relay M 

Latch relay L 

Annunciator F 

Edge relay V 

Step relay S 

Link relay B 

Link special relay SB 

Timer

Current value T 

Contact TS –

Coil TC –

Counter

Current value C 

Contact CS –

Coil CC –

Retentive timer

Current value ST 

Contact STS –

Coil STC –

Data register D 

Link register W 

Link special register SW 

Direct input DX –

Direct output DY –

Internal system device
Special relay SM 

Special register SD 

Link direct device

Link input J\X 

Link output J\Y 

Link register J\W 

Link special register J\SW 

Link relay J\B 

Link special relay J\SB 

File register File register
R*1 –

ZR*1,*2 

Index register Index register Z 

Intelligent function module 
device Intelligent function module device U\G 

*1 : Not supported by Q00J/Q00UJ.
*2 : For Universal model QCPU/LCPU, the device cannot be used when '0k' is set for "Device points" of file register 

(ZR(R)) under "File Register Extended Setting" on the <<Device>> tab of PLC parameter.



7 - 4

GX Works2

7  SETTING DEVICE MEMORY

7.1.2  List of devices selectable on the Input Devices screen

■ FXCPU

: Can be edited : Display only –: Not supported

Category Device type Symbol
Display/edit

FX0
FX0S

FX0N FX1 FX1S
FX1N

FX1NC
FXU
FX2C

FX2N
FX2NC

FX3G
FX3GC

FX3U
FX3UC

Internal
user 
device

Input X         

Output Y         

Internal relay M         

State S         

Timer T         

Counter*1 C         

Data register D         

File register D –  –      

Internal 
system 
device

Special relay M         

Special data register D         

Extended register R – – – – – – –  

Extended file register ER – – – – – – –  

*1 : 32-bit counter (C200 and later) is not supported.
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7.2 Setting Device Memory

This section explains how to set a device and device value.

Screen display
Select Project view ⇒ "Device Memory" ⇒ "(data name)".

Q CPU L CPU FXFXRemote FXHead

Device number

display area

Device value

display area
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● Inserting rows
Select [Edit] ⇒ [Insert Row] to insert a blank row at the cursor position.

● Cutting/copying/pasting character strings in units of rows
To paste a character string in units of rows, select the desired cell(s) and paste the character string. If a row is selected, 
pasting is not possible.

● Cutting/copying/pasting character strings in units of cells
To paste a character string in units of cells, if the selected cell(s) is in the row where a device is not entered, pasting is 
not possible.

● Copying device memory
Device memory data of the selected range can be copied and pasted to Excel. Data can also be copied and pasted to 
device memory from Excel.
When a value other than 0 is pasted as a bit device, it is replaced to 1.

● Deleting devices
If a deletion is executed after selecting a cell, the device value clears to '0'.
If a deletion is executed after selecting a row, the selected row (device) is deleted.

<Deletion in units of cells>

<Deletion in units of rows>

[Edit] ⇒ [Insert Row]

[Edit] ⇒ [Delete]

The device values are set to “0”.

[Edit] ⇒ [Delete]

The selected rows are deleted.
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7.2.1 Setting device values in units of points

Set a device and device value in units of points.
Create a new device memory in advance. (Section 4.3.1)

Example) Set the following values.
'Device: D0, Device value: 12'

Operating procedure

1. Select the cell to which a device value is set.

2. Enter 'D0' for a device.

3. Press the  key.
The entered device is set in the device number display area.
In this example, 'D0' is set in the device number display area and 
the value is displayed in the device value display area.

4. Enter '12' for a device value.
'12' is set as the device value of device 'D0'.
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7.2.2  Setting device values by specifying device range

7.2.2 Setting device values by specifying device range

■ Setting device values by specifying a device range on the Input Device 
screen

Set device values by specifying a device range on the Input Device screen.
Example) Set the following values.

'Device: D, range: 0 to 50, display format: decimal number'

Operating procedure

1. Select the cell to which a device value is set.

2. Select [Edit] ⇒ [Input Device] ( ).
The Input Device screen is displayed.

3. Set the items on the screen.

Item Description

Device Select the device name.
For devices that can be edited, refer to Section 7.1.2.

Module Start*1 Display when U\G or J\ is selected in the "Device" field.
Enter the start XY address or network number.Network No.*1

Range Select the range of devices to be set.

All Select this to target all of the selected devices.

Address Select this to target the devices in the specified range.

Display Mode Select the display format of device values.

BIN Select this to display device values in binary numbers.

OCT Select this to display device values in octal numbers.

DEC Select this to display device values in decimal numbers.

HEX Select this to display device values in hexadecimal numbers.

FLOAT Select this to display device values in real numbers.

String Select this to display device values in character strings.

String (ASCII only) Select this to display device values in ASCII strings.
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4. Click the  button.
Devices in the range from D0 to D50 are registered to cells and the values are displayed.

5. Enter a device value to each cell.
The entered values are set.

Register Select the display size of device values.

16-bit Select this to display the display size of device values in words.

32-bit Select this to display the display size of device values in double words.
Specify the device range in multiples of two.

64-bit
Select this to display the display size of device values in double-precision real 
numbers.
Specify the device range in multiples of four.

Device Value Enter a value to set device values simultaneously.

*1 : Not supported by FXCPU.

Item Description
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7.2.2  Setting device values by specifying device range

■ Setting device values by specifying a device range on the cell

Set device values by specifying a device range on the cell.
Example) Set the following values.

'Device: D, range: 20 to 40, display format: decimal number'

Operating procedure

1. Select a cell to which the device value is set.

2. Enter the device range.

3. Click the  button.
Devices from D20 to D140 are registered to the cells and the values are displayed.

● Display format of bit device and word device
The following table shows the display format of bit device and word device when the device range is specified on the 
cell.

● Device registration when only the start address or the end address is specified
A device range can be specified by specifying the start address or the end address only.
• When only the start address is specified (Example: Specify 'D0-' for the device range)

Devices from 'D0' to the last valid address are registered to the cells.
• When only the end address is specified (Example: Specify '-D100' for the device range)

Devices from 'D0 to D100' are registered to the cells.

● Abbreviating device name
When specifying a device range on the cell, only the end address can be abbreviated.
For example, when a device range is specified with 'D0-100', the devices in the range of 'D0-D100' are registered.

● Specifying R devices (This function is not supported by FXCPU.)
When R device is specified, it is changed to ZR device and registered.

Device Value Display format Display size

Bit device 0 Binary –

Word device 0 Decimal 16 bits
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7.2.3 Setting character strings

Set a character string to a device.
Set "Display Mode" to 'String' in advance. (Section 7.2.5)

Operating procedure

1. Select a range of cells to which a character string is set.

2. Select [Edit] ⇒ [Paste Text].
The Paste Text screen is displayed.

3. Enter a character string, and click the  button.
The entered character string is set to the selected cells or row.

● Entering character strings
When "Register" is '16-bit', '32-bit', or '64-bit', the maximum number of characters that can be entered to one cell is 2, 4, 
or 8 respectively.
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7.2.4  Setting same value simultaneously

7.2.4 Setting same value simultaneously

Set the same value to continuous devices.

Operating procedure

1. Select devices to which a value is to be set.

2. Select [Edit] ⇒ [Fill] ( ).
The FILL screen is displayed.

3. Set the items on the screen.

4. Click the  button.
The specified device value is set to devices simultaneously.

● Setting the same value simultaneously
Device values can also be set simultaneously by selecting a range, right-clicking it on the device memory editor, and 
selecting [FILL] from the shortcut menu.

Item Description

Data Format Select the data format of device values.

BIN Select this to set device values in binary numbers.

OCT Select this to set device values in octal numbers.

DEC Select this to set device values in decimal numbers.

HEX Select this to set device values in hexadecimal numbers.

Device Value Enter a value set to devices simultaneously.
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7.2.5 Changing display format

■ Switching display format

Switch the device value display format for each cell on the device memory editor.

Operating procedure

• Select [View] ⇒ [Display Mode] ⇒ [Binary/Octal/Decimal/Hexadecimal/Float/String/
String (ASCII)].
Device values are displayed in the selected display format.

■ Switching display size in 16-bit/32-bit/64-bit

Switch the device value display size in 16-bit/32-bit/64-bit for each cell on the device memory editor.

Operating procedure

• Select [View] ⇒ [Register] ⇒ [16-bit/32-bit/64-bit].
Device values are displayed in the selected display size (16 bits, 32 bits, or 64 bits).
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7.2.6  Changing the number of rows/columns on device memory editor

7.2.6 Changing the number of rows/columns on device memory 
editor

Change the number of rows/columns on the device memory editor.

Screen display
Select [View] ⇒ [Setup].

Operating procedure

1. Set the items on the screen.

2. Click the  button.
The set number of rows/columns are displayed.

● Number of columns
When "Number of Columns" is set to "Auto", the device values are displayed in 10 columns or 16 columns according to 
the specified devices.
For FXCPU, the device values of X and Y are displayed in 8 columns.

● Considerations for changing rows and columns
When a value smaller than the current value is set for "Number of Columns" or "Row", a confirmation message is 
displayed and the data on the device memory editor is discarded.
When a value larger than the current value is set for "Number of Columns", the sequence of devices registered to the 
device memory editor do not change by the setting of "Number of Columns".

Item Description

Number of Columns Set the number of columns on the editor.

Auto Select this to set the number of columns to 16.

Specify the number of 
columns (1 - 255)

Select this to set the desired number of columns on the editor.
Setting range: 1 to 255

Row Set the number of rows on the editor.

4096 Rows Select this to set the number of rows to 4096.

Specify the number of 
rows (16 - 655360)

Select this to set the desired number of rows on the editor.
Setting range: 16 to 655360

Additional Safety Inquiry Select this to display the confirmation message when device deletion is executed.
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7.3 Searching Devices

This section explains how to search for a device set in the device memory.

Screen display
Select [Find/Replace] ⇒ [Find Device Cell].

Operating procedure

1. Set the items on the screen.

2. Click the  button.
The cursor moves to the found device.

Q CPU L CPU FXFXRemote FXHead

Item Description

Find what Enter the device to be searched for.

Direction
Up Select this to perform searching in the upward direction from the cursor position.

Down Select this to perform searching in the downward direction from the cursor position.
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7.4.1  Writing/reading data to/from programmable controller CPUs

7.4 Writing/Reading Device Memory Data

This section explains how to write/read device memory data being edited to/from a programmable 
controller CPU or Excel file.

7.4.1 Writing/reading data to/from programmable controller CPUs

Write/read device memory data to/from a programmable controller CPU.
To write/read device memory data in units of files, refer to the online Write to PLC/Read from PLC 
function. (Section 12.1)

Screen display
Select [Tool] ⇒ [Write Device Memory to PLC]/[Read Device Memory from PLC].

Operating procedure

• Set the item on the screen.

Q CPU L CPU FXFXRemote FXHead

<Writing device memory> <Reading device memory>

Item Description

Range Select the write/read range.

Selected Devices Select this to write/read data in the specified range to/from a programmable controller 
CPU.

All Devices Select this to write/read all data in the device memory being edited to/from a programmable 
controller CPU.



7.4  Writing/Reading Device Memory Data

7.4.2  Writing/reading data to/from Excel files 7 - 17

1

O
V

E
R

V
IE

W

2

S
YS

TE
M

 
C

O
N

FI
G

U
R

A
TI

O
N

3

SC
RE

EN
 

CO
NF

IG
UR

AT
IO

N 
AN

D 
BA

SI
C 

O
PE

RA
TI

ON
S

4

P
R

O
JE

C
T 

M
A

N
A

G
E

M
E

N
T

5

ED
IT

IN
G

 
PR

O
G

R
AM

S

6

S
E

TT
IN

G
 

PA
R

A
M

E
TE

R
S

7

S
ET

TI
N

G
 D

E
V

IC
E

 
M

E
M

O
R

Y

8

S
E

TT
IN

G
 D

E
V

IC
E

 
IN

IT
IA

L 
V

A
LU

ES

7.4.2 Writing/reading data to/from Excel files

Write/read device memory data to/from an Excel file.

Screen display
Select [Tool] ⇒ [Write to Excel File]/[Read from Excel File].

Operating procedure

1. Enter a file name or select the file to be opened.
The Save As screen or Open screen is displayed.

2. Click the  or  button.
Data are saved to the specified destination, or the file is opened from the specified location.

● Compatible Excel version
Microsoft Office Excel 97 or later version is compatible with the data write/read operations.

● Reading data
When data are read from an Excel file, they are read with the saved setting of "Number of Columns".
The following are regarded as errors and processed as explained.
• Unsupported devices ⇒ Deleted
• Invalid value ⇒ Set to '0'.
• Invalid display format ⇒ Displayed in decimal numbers.



7 - 18

GX Works2

7  SETTING DEVICE MEMORY

MEMO



1

O
V

E
R

V
IE

W

2

S
YS

TE
M

 
C

O
N

FI
G

U
R

A
TI

O
N

3

SC
RE

EN
 

CO
NF

IG
UR

AT
IO

N 
AN

D 
BA

SI
C 

O
PE

RA
TI

ON
S

4

P
R

O
JE

C
T 

M
A

N
A

G
E

M
E

N
T

5

ED
IT

IN
G

 
PR

O
G

R
AM

S

6

S
E

TT
IN

G
 

PA
R

A
M

E
TE

R
S

7

S
ET

TI
N

G
 D

E
V

IC
E

 
M

E
M

O
R

Y

8

S
E

TT
IN

G
 D

E
V

IC
E

 
IN

IT
IA

L 
V

A
LU

ES

8 - 1

8 SETTING DEVICE INITIAL 
VALUES

This chapter explains how to set, edit, and delete device initial values.

8.1 Device Initial Values 8 - 2

8.2 Setting Device Initial Values 8 - 5
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8.1.1  Feature of device initial values

8.1 Device Initial Values

This section explains the device initial values.

8.1.1 Feature of device initial values

The device initial values are device values used for the sequence program operation when the 
programmable controller turns RUN.
When the device initial values are set, the initial setting program is unnecessary.

● When device initial values are not set
The initial setting program is necessary.

Example)

● When device initial values are set
Example)

The initial setting program is unnecessary.

Q CPU L CPU FXRemote FXHead FXFX
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8.1.2 List of applicable devices for device initial values

The following table shows the list of devices which can be used as device initial values.

Category Device name Device

Internal user device

Timer T

Retentive timer ST

Counter C

Data register D

Link register W

Link special register SW

Internal system device Special register SD

File register File register R*1,*2, ZR*2

Intelligent function module 
device Intelligent function module device U\G

Link direct device
Link register J\W

Link special register J\SW

*1 : When the R device is specified to utilize the device memory data, the ZR device value is utilized for the R device.
*2 : Not applicable to Q00UJ.
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8.1.3  Procedure for setting device initial values

8.1.3 Procedure for setting device initial values

The following flow chart shows the procedure for setting the device initial values.

Start

Operations on the Device Initial Value screen
Perform settings on the <<PLC File>>

 tab of PLC parameter to use the 
device initial values.

Select [Online]      [Write to PLC] 
to write the device initial values and the 

parameter to the programmable controller CPU.

Completed

Click the                          button 
to set the device values 
of the device memory as 

device initial values.

Select [Project]      [Object]      [New] to 
create the device memory data.

Set the device values within the 
range of the device initial value.

Select [Project]      [Object]      [New] to add
 the device initial value data.

Set the device range to be 
used for device initial values.

Operations on the Device Memory screen
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8.2 Setting Device Initial Values

This section explains how to set device values set in the device memory as device initial values. 
Create a new device initial value data in advance. (Section 4.3.1)

Screen display
Select Project view ⇒ "Device Initial Value" ⇒ "(data name)".

Operating procedure

1. Set the items on the screen.

2. Select the data name to be utilized from  in "Device Memory Diversion", and click 
the  button.
The device value in the set range is set as a device initial value.

3. Click the  button.

Q CPU L CPU FXRemote FXHead FXFX

Range setting

Item Description

Range setting Set the range for device initial values.

Points Set the number of points of each device. Up to 8,000 points of devices can be set 
within a range.

Start Specify the start device of the range to be set.

End Specify the end device of the range to be set.

Comment Enter a comment in the set device range. (Up to 32 characters)

Setting 
Method

Start/End Select this to set the range for device initial values by start or end device.

Points/Start Select this to set the range for device initial values by device points or start device.
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Screen button

●

Executes printing. (Section 20.7)

●

Executes print preview. (Section 20.9)

●

Displays the Print Setting (Device Initial Value) screen. (Section 20.8.2)

● Using device initial values
If the device values with set ranges are used as the initial values when activating the programmable controller CPU, 
specify the file name to be used for the initial values on the <<PLC File>> tab of PLC parameter.

● Device range
The device range that can be set for device initial values is the range set on the <<Device>> tab of PLC parameter.
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9 - 1

9 SETTING DEVICE 
COMMENTS

This chapter explains the operation methods for setting, editing, and deleting device comments.

9.1 Device Comments 9 - 2

9.2 Creating Device Comments 9 - 10

9.3 Deleting Device Comments 9 - 14

9.4 Extending Number of Points of Device Comment 9 - 15

9.5 Utilizing Sample Comments 9 - 16

9.6 Writing/Reading Device Comments to CSV Files 9 - 18
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9.1.1  Global device comments/local device comments

9.1 Device Comments

This section explains the general concept of device comments and the setting availability.

9.1.1 Global device comments/local device comments

Device comment is categorized into global device comment and local device comment.

■ Global device comments

A global device comment is a device comment created automatically when a new project is created.
Global device comments are set to use common device comment data among multiple programs.
Global device comments can be set even when there is only one program.

<Image that is created with only global device comments>

Q CPU L CPU FXFXRemote FXHead

A global device comment name 

is fixed to COMMENT.

Global device comments can 

be changed to local device 

comments.

Sequence program SUB1

Sequence program MAIN

Sequence program SUB2

COMMENT Global device comment
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■ Local device comments

A local device comment is a device comment created by the user.
No local device comment exists when a new project is created.
Create a local device comment if necessary. (Section 4.3.1)
Local device comments are used in association with each program.
Device comments are set under the same name as sequence programs.
For Structured projects, device comments are set under the same data name as the program file name.

<Image of a project created with only local device comments>

Display example when local device comments are set.

Sequence program SUB1SUB1 Local device comment

Sequence program MAINMAIN Local device comment

Sequence program SUB2SUB2 Local device comment
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9.1.1  Global device comments/local device comments

● Writing device comments to a programmable controller CPU
Up to the following number of device comments can be written to the programmable controller CPU.
Per device: 32k points
Total number of device comments: 64k points
When the number of set device comments exceeds the number of points that can be written to the programmable 
controller CPU, set the range when writing device comments to the programmable controller CPU. (Section 12.1.3)

● Data name of global device comments
A global device comment is displayed as "COMMENT" in the screen for Write to PLC/Read from PLC.

● Setting local device comments with data names different from the sequence program name
Multiple local device comments can be created with data names different from the sequence program name. In this 
case, however, the comments are not related to the sequence program.
To make the comments relate to the sequence program, the comments should have the same data names as the 
program name.
This is useful for cases, such as when switching comments between Japanese and English in the same program.

● Global device comments/local device comments
Global device comments/local device comments correspond respectively to common comments/comments by program 
in GX Developer.

● Device comments for Basic model QCPU
Global device comments are not supported by Basic model QCPU.
A local device comment for Basic model QCPU is fixed to "MAIN".
When an SFC program is created, the SFC program "MAIN-SFC" also refers to a local device comment "MAIN".

<Image of an SFC program for Basic model QCPU>

● Local device comments for FXCPU
For FXCPU, local device comments cannot be written to a programmable controller CPU. If local device comments 
needs to be written, create comments as global device comments, or change local device comments to global device 
comments. When changing a local device comment to a global device comment, change its data name to 
"COMMENT". (Section 4.3.3)

● Difference between device comment and label comment
A device comment is a comment appended to a device, and it is 'data' to be read from/write to a programmable 
controller CPU.
A label comment is a comment appended to a defined label. A label comment is not applied to a device comment even 
when a program is compiled.

MAIN-J Local device comment

Sequence program MAINMAIN Local device comment

MAIN-E Local device comment Not related to the sequence program.

If data names are changed to 'MAIN', 

comments are applied.

MAIN-SFC program

MAIN program

MAIN Local device comment
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■ Displaying device comments on program editors

Device comments can be displayed on program editors.
The following are the settings to display device comments.
● Displaying device comments on the program editor (ladder editor and Zoom editor only)

Select [View] ⇒ [Comment].
Device comments are displayed on the ladder editor or the Zoom editor.

● Displaying device comments on tooltips
Select "Device Comment" under [Tool] ⇒ [Options] ⇒ "Program Editor" ⇒ "Ladder/SFC"/"Structured 
Ladder/FBD/ST"*1 ⇒ "Tool hint display items".
Device comments are displayed on tooltips.

*1 : For Simple project (with labels), select "ST" instead of "Ladder/SFC"/"Structured Ladder/FBD/ST".
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9.1.1  Global device comments/local device comments

■ Specifying device comments to be displayed in program

When both global and local device comments are set, specify the comment to be displayed by the 
following method.

Operation
• Set the device comment to be referenced by selecting [Tool] ⇒ [Options] ⇒ "Program 

Editor" ⇒ "All Editors" ⇒ "Device Comment".
Example) When different device comments are set for the same device (M)

 

Global device comment (COMMENT) Local device comment (MAIN)

The display differs as shown below according to 

the option setting.

When the reference of the device M in the sequence program MAIN is set to the PLC parameter setting

<Option>

<Sequence program MAIN>

<Device>

The local device comment, 'Stop Device 1', is displayed 

for local device M1, and the global device comment, 

'Initial Start 2', is displayed for global device M2. 

When the reference of the device M in the sequence 

program MAIN is set to the global device comment

<Sequence program MAIN> <Sequence program MAIN>

<Option> <Option>

When the reference of the device M in the sequence 

program MAIN is set to the global device comment

The global device comment, 'Initial Start 1', is 

displayed as a device comment for M1.
The local device comment, 'Stop Device 1', is 

displayed as a device comment for M1.
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● Specifying device comments for "Specify the reference/reflection" in batch
The following operations can be performed to set "Specify the reference/reflection".

By clicking the / / button, the "Reference/Reflection Target" settings of 
all device comments of program selected for "Program/Program File Name" are set to "Global"/"Local"/"PLC Parameter 
Setting.*1

By clicking the  button, the setting of "Specify the reference/reflection" of the selected program is 
applied to all programs.

*1 : Only devices with which the range of local devices can be specified on the <<Device>> tab of PLC parameter can be set.

● Device comment to be referenced is not set
If a comment does not exist in the device comment set for "Specify the reference/reflection", the other device comment 
can be displayed by setting the option.*1
Select [Tool] ⇒ [Options] ⇒ "All Editors" ⇒ "Device Comment", and select "Reference/reflect the other, when device 
comment is not set.".

*1 : Except for when 'PLC Parameter Setting' is set for "Specify the reference/reflection".
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9.1.2  List of device comment applicable devices

9.1.2 List of device comment applicable devices

The following table shows device types and comment setting availability.
: Applicable / ×: Not applicable

Category Device name Symbol Bit
specification*1

QCPU (Q mode)/
LCPU FXCPU

Internal user device

Input X ×  

Output Y ×  

Internal relay M ×  

Latch relay L ×  –

Annunciator F ×  –

Edge relay V ×  –

Step relay S × × –

Link relay B ×  –

Link special relay SB ×  –

State S × – 

Timer T ×  

Retentive timer ST ×  –

Counter C ×  

Data register D   

Link register W   –

Link special register SW   –

Direct input DX ×  –

Direct output DY ×  –

Internal system device

Special relay
SM ×  –

M × – 

Special register
SD   –

D × – 

Link direct device

Link input J\X ×  –

Link output J\Y ×  –

Link register J\W   –

Link special register J\SW   –

Link relay J\B ×  –

Link special relay J\SB ×  –

File register
File register

R  *2 *3

ZR  *2 –

(RAM) File register D × – 

Index register Index register Z, ZZ × × –

Intelligent function 
module device

Intelligent function 
module device U\G   *4

Nesting Nesting N × × ×

Pointer
Pointer P ×  

Interrupt pointer I ×  
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● Device comment creation supported range in the multiple CPU system configuration for QCPU (Q mode)
Device comments can be created in the following ranges, corresponding to the buffer memory of the programmable 
controller CPU (3E00H to 3E30H) in a multiple CPU system.

● Screen to display bit-specified comments
Bit-specified word device comments can be displayed only on device comment editors, ladder editors, the Cross 
Reference window, the Watch window, and the Sampling Trace screen.

Other

Network number 
specified device J ×  –

SFC block device BL*5 ×  –

Step relay
(Step relay with a 
block specification)

BL\S ×  –

SFC transition device BL\TR ×  –

I/O number specified 
device U ×  *4

*1 : Bit-specified word device comment is applicable to Universal model QCPU/LCPU only.
*2 : Not applicable to Q00J/Q00UJ.
*3 : R (extended register) is applicable to FX3G/FX3GC or FX3U/FX3UC only
*4 : Applicable to FX3U/FX3UC only
*5 : For projects with labels, comments of the BL device are not applied to the block titles.

Category Device name Symbol Bit
specification*1

QCPU (Q mode)/
LCPU FXCPU

Supported range Unsupported range

U0(\G0) to U1FF(\G65535)
U200(\G0) to U3DF(\G65535)

U3E0(\G0) to U3FF(\G65535)
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9.2.1  Creating comments on the device comment editor

9.2 Creating Device Comments

This section explains how to create device comments, which make it easy to understand content of 
program processing.

9.2.1 Creating comments on the device comment editor

Create device comments for each device on the same screen.
When creating local device comments, create a new device comment in advance. (Section 4.3.1)

Screen display
● Creating global device comments

Select Project view ⇒ "Global Device Comment".
● Creating local device comments

Select Project view ⇒ "Local Device Comment" ⇒ "(data name)".

Operating procedure

• Set the items on the screen.

Q CPU L CPU FXFXRemote FXHead

Item Description

Device Name Specify the device to be edited.

Comment*1

*1 : For Universal model QCPU/LCPU, the entry field for bit-specified word device comment can be expanded/
collapsed by clicking a column of "Device Name".

Enter a device comment for each device.
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Screen button

●  (Universal model QCPU/LCPU only)
Displays all entry fields for bit-specified word device comment.

●  (Universal model QCPU/LCPU only)
Hides all entry fields for bit-specified word device comment.

● Limit for the number of characters to be entered
Enter each device comment within 32 characters.
The limit for the number of characters to be entered can be switched between 16 characters and 32 characters. 
(Section 21.2)

● Cutting/copying/pasting device comments for word devices which support bit-specified word device 
comments
For Universal model QCPU/LCPU, select the following menu when cutting/copying/pasting device comments including 
bit-specified word device comments.
• [Edit] ⇒ [Cut The Range including Hidden Bit Specification Information]
• [Edit] ⇒ [Copy The Range including Hidden Bit Specification Information]
• [Edit] ⇒ [Paste The Range including Hidden Bit Specification Information]

Restrictions

● Range selection of entry fields for bit-specified word device comment
When a range is selected with entry fields for bit-specified word device comment are collapsed, the last entry field for 
bit-specified word device comment becomes out of the range selection.
To select the last entry field for bit-specified word device comment, expand the entry fields and select the range.
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9.2.2 Creating comments on the ladder editor

Modify and add device comments.

■ Creating device comments in device comment editing mode

Example: Set 'Result of module A' to D1 and 'Initial setting is completed' to D2.

Operating procedure

1. Select [Edit] ⇒ [Documentation] ⇒ [Device Comment] ( ).
The mode changes to the device comment editing mode.

2. Move the cursor to the device comment 
entry position.

3. Press the  key.
The Input Device Comment screen is displayed.

4. Enter a device comment.
The line wrapping of the device comment for display 
can be checked when the comment is entered.

5. Click the  button.
The entered device comment is displayed as shown 
at the right.

● Limit for the number of characters to be entered
Enter each device comment within 32 characters.
The limit for the number of characters to be entered can be switched between 16 characters and 32 characters. 
(Section 21.2)

● Disabling the device comment editing mode
Select the same menu option again and clear the check box from the item displayed on the screen.

● Target of applying device comment change
Device comments changed or added on the ladder editor are applied to global device comments.
To apply changes to local device comments, specify the reflection target for "Reference/Reflection Target for Device 
Comment" under [Tool] ⇒ [Options] ⇒ "Program Editor" ⇒ "All Editors" ⇒ "Device Comment".
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■ Creating device comments in the ladder editing mode

Device comments can be added/modified on the created ladder program on the ladder editing screen.
Example: Set the comment 'Indication of initial start.' for X1.

Operating procedure

• Enter ';;X1=Indication of initial start' on the 
ladder editor.
The entered comment is added as a device 
comment.

● Entering comments following element entry
Using the method explained below, a comment can be entered following an element entry in ladder editing mode.
Click  in the Enter Symbol screen, or select [Tool] ⇒ [Options] ⇒ "Program Editor" ⇒ "Ladder/SFC" ⇒ "Enter 
ladder" and select "Enter label comment and device comment".

● Target of applying device comment change
Device comments changed or added on the ladder editor are applied to global device comments.
To apply changes to local device comments, specify the reflection target for "Reference/Reflection Target for Device 
Comment" under [Tool] ⇒ [Options] ⇒ "Program Editor" ⇒ "All Editors" ⇒ "Device Comment".

● Considerations when entering device comments in the ladder editing mode
When entering device comments in the ladder editing mode, do not enter device comments to devices which are out of 
the range of device points set on the <<Device>> tab of PLC parameter because they cannot be deleted.
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9.3 Deleting Device Comments

This section explains how to delete device comments.

9.3.1 Deleting comments of all devices

Delete comments of all devices on the device comment editor being displayed.

Operating procedure

• Select the device comment editor ⇒ [Edit] ⇒ [Clear All (All Devices)].
All device comments set on the device comment editor are deleted.

9.3.2 Deleting comments of devices being displayed

Delete comments of devices being displayed on the device comment editor.

Operating procedure

• Select the device comment editor ⇒ [Edit] ⇒ [Clear All (All Displayed Devices)].
All comments of devices being displayed on the device comment editor are deleted.

Q CPU L CPU FXFXRemote FXHead
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9.4 Extending Number of Points of Device Comment

The number of points of device comment can be extended by changing the mode from the standard 
mode to the extended mode.
Device comment can be set within the extended number of points in the project.

The following table shows the number of points of device comment that can be set in the standard 
mode and the extended mode.

Operating procedure

• Select "Extended mode" under [Tool] ⇒ [Options] ⇒ "Device Comment Editor".

● Writing/reading device comments to/from a programmable controller CPU
Regardless of the standard mode or the extended mode, up to the following number of device comments can be written 
to the programmable controller CPU.
Per device: 32k points
Total number of device comments: 64k points
When the number of set device comments exceeds the number of points that can be written to the programmable 
controller CPU, set the range when writing device comments to the programmable controller CPU. (Section 12.1.3)
Note that when 32k or more points of device comments are set for a single device in the extended mode and device 
comments are read from a programmable controller CPU, the device comments that exceed 32k points are not deleted.

● When changing the mode from the extended mode to the standard mode
Select "Standard mode" under [Tool] ⇒ [Options] ⇒ "Device Comment Editor" to change the mode from the extended 
mode to the standard mode.
Note that, however, when the number of points which exceeds the number of points that can be set in the standard 
mode is set, the mode cannot be changed. Delete the exceeded device comments and change the mode.

● Considerations for saving GX Developer format project
[Export to GX Developer Format File] under [Project] cannot be performed when the extended mode is set.
Save the GX Developer format project after changing the mode to the standard mode.

Item Standard mode Extended mode

Number of points of device comment per device 32k points 192k points

Number of points of device comment per file 1024k points 2048k points

Q CPU L CPU FXRemote FXHead FXFX
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9.5.1  Utilizing sample comments of special relays/special registers

9.5 Utilizing Sample Comments

This section explains how to set a sample comment of special relays/special registers and intelligent 
function modules automatically.
Open the device comment editor in advance.

9.5.1 Utilizing sample comments of special relays/special 
registers

Utilize sample comments of special relays/special registers.

Operating procedure

• Select [Edit] ⇒ [Import from Sample Comment] ⇒ [Special Relay/Special Register].
The sample comments of special relays/special registers are set on the device comment editor 
being edited.

● Project language and sample comments to be utilized
When the project language is changed, sample comments with the language selected for the project language are 
utilized.

Q CPU L CPU FXFXRemote FXHead
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9.5.2 Utilizing sample comments of intelligent function modules

Utilize sample comments of intelligent function module devices and input/output signals.

Operating procedure

1. Select [Edit] ⇒ [Import from Sample 
Comment] ⇒ [Intelligent Function 
Module].

2. Select modules whose sample comments are utilized.

3. Click the  button.
The sample comments of intelligent function module devices are set on the device comment editor 
being edited.
For Universal model QCPU/LCPU, bit-specified word device comments can also be utilized.

● Utilizing sample comments
• Sample comments can also be utilized by right-clicking any position on the device comment editor, and selecting 

[Import from Sample Comment] from the shortcut menu.
• For data protected by security, device comments cannot be utilized.
• When the project language is changed, sample comments of the selected project language are utilized.

● Number of characters displayed on device comment editor
The sample comments are displayed with the number of characters set in "Device Comment Editor" under [Tool] ⇒ 
[Options].

● Considerations when utilizing sample comments
When utilizing sample comments of intelligent function module, the data size may exceed the memory capacity of the 
programmable controller CPU and data may not be written to a programmable controller CPU. In this case, delete 
unnecessary sample comments.

Q CPU L CPU FXRemote FXHead FXFX
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9.6 Writing/Reading Device Comments to CSV Files

This section explains how to write/read device comment data to a CSV file.

■ Writing device comment data

Write device comment data to a CSV file.

Operating procedure

1. Select [Edit] ⇒ [Write to CSV File].
The confirmation message for writing data is displayed.

2. Click the  button.
The Write to CSV File screen is displayed.

3. Enter a file name of the data to be saved.

4. Click the  button.
Device comment data is saved in the CSV file.

Q CPU L CPU FXFXRemote FXHead
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■ Reading device comment data

Read device comment data from a CSV file.

Operating procedure

1. Select [Edit] ⇒ [Read from CSV File].
The Read from CSV File screen is displayed.

2. Select a file to be read.

3. Click the  button.
The confirmation message for reading data is displayed.

4. Click the  button.
Device comment data is read from the CSV file.

● Device comment data for which an error message is displayed when reading data
An error message is displayed on the Output window if the following data is included when reading device comment 
data.
Reading of device comment data is suspended when the number of error messages exceeds 100.
• Device comment data of devices which are not supported by the programmable controller type of the project.
• Bit-specified device comments (For programmable controller type whose project does not support bit-specified 

comments.)
● Reading device comment data whose number of characters exceeds the applicable amount

When a device comment whose number of characters exceeds applicable amount is set on the device comment editor, 
a warning message is displayed on the Output window and characters exceeded the applicable amount are deleted.
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■ Setting extended settings

Set settings such as selecting target devices for writing/reading device comment data.

Screen display

Select the  button on the confirmation message for writing/reading data.

Operating procedure

1. Set the items on the screen.

2. Click the  button.
Return to the confirmation message for writing/reading data.

Screen button

●

Moves devices selected for "Non-target" to "Target".

●

Moves all devices displayed on "Non-target" to "Target".

●

Moves devices selected for "Target" to "Non-target".

●

Moves all devices displayed on "Target" to "Non-target".

●

Sets the setting items to the default.

< When reading device comment data >

Item Description

Target Device Selection Display all devices to which device comments can be set in a program.

Non-target Display devices which are not to be written/read.

Target Display devices which are to be written/read.

Read after deleting comment data 
of target device type*1

*1 : This item can be selected only when reading data.

Select this to read devices after deleting set device comments.
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■ CSV file format

A title name of device comment editor and a title name of CSV file are linked.
• Data of the column whose title matches with the title of the device comment editor are read to the 

device comment editor.
• Data of the column whose title does not match with the title of the device comment editor are not 

read.
• Data can be read even when the sorted order of CSV file does not match with the sorted order of the 

device comment editor.
The following is an image of the saved CSV file opened with Excel.

● Details of CSV file
The following indicates the details of CSV file format.
• The file format is Unicode (including UTF-16, Little Endian, and BOM).
• The delimiter of items is a tab (\t).
• Each item is enclosed in double quotation marks (").
• If the item contains double quotation marks ("), the double quotation marks in the item are 

expressed as two double quotation marks ("").
• A line feed is set at the end of the line.

The line feed code is CR+LF.
• A blank space is handled as a regular character.

< Device comment editor >

< CSV file >

< Image of device comments in CSV file >
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10 - 1

10 SEARCH/REPLACE
This chapter explains the operation methods for searching for/replacing the character strings used in 
programs.

10.1 Cross Reference 10 - 2

10.2 Displaying Device List 10 - 13

10.3 Search/Replacement 10 - 16
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10.1.1  Creating/displaying cross reference information

10.1 Cross Reference

This section explains how to create and display the cross reference information, which shows a list of 
locations where devices/labels selected on the program editor/label setting editor are used.
The Cross Reference window is displayed horizontally when it is docked on top or bottom of the main 
frame, and displayed vertically when it is docked on left or right of the main frame.

■ Target data for creating cross reference information

Cross reference information is created based on devices used in the following editors/parameters.
• Ladder
• SFC
• ST
• Structured Ladder/FBD
• Global label
• Local label
• Structure
• Multiple CPU refresh setting of PLC parameter
• Simple PLC communication setting of PLC parameter
• Refresh parameters of network parameter
• Auto refresh setting of intelligent function module parameter
• Block information of SFC program

10.1.1 Creating/displaying cross reference information

Create and display cross reference information of the label/device selected on the program editor/label 
setting editor.

Screen display
Select [View] ⇒ [Docking Window] ⇒ [Cross Reference] ( ).

<<Cross Reference Information>>

Remote HeadQ CPU L CPU FX
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Operating procedure

1. Specify the conditions to create cross reference information as necessary.
By setting the conditions, the operation such as: searching for a label definition on the label setting 
editor, displaying hierarchy of structure/array/FB, and displaying a start device and end device of 
the instruction such as the DMOV instruction which uses two or more points of device, can be 
performed. (Section 10.1.2)

2. Select a device/label on the program editor/label setting editor.

3. To specify the range to be searched, select a search location by clicking the 
 button of "Find in".

Two or more search locations can be selected.
Click  to select a location from the list of previously searched locations. The location cannot be 
entered directly.
This function is not supported by FXCPU.

4. Click the  button.
The cross reference information is created and the result is displayed.
When the range to be searched is specified and "Include label definition" on the <<Condition 
Setting>> tab is selected, the cross reference information of global labels, FBs, and structures is 
also created other than the information of specified search location.
By pressing the  key after selecting a row in the result list, or by double-clicking or right-
clicking the selected row and selecting [Jump] from the shortcut menu, the editor in which the 
device/label is used opens and the corresponding device/label becomes in the selected status.
The following screen is a result of a Structured project in which "Display all items" and "Display 
hierarchically" are selected on the <<Condition Setting>> tab.

Attributes
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Display contents

Item Description

Attributes Display icons which indicate attributes of devices/labels.
('■ Icons to indicate attribute' in this section)

Device/Label Display the device/label name.

Class*1,*2 Display the class of the device/label.

Label Data Type*1,*2 Display the data type of the device/label.

Constant*1,*2 Display the constant value set for VAR_GLOBAL_CONSTANT or VAR_CONSTANT.

Device*1 Display the device assigned to the label (automatically assigned device).

Address*2,*3 Display the address of the device/label.

Read/Write Display whether Read or Write the device/label is.

Instruction*2,*4 Display the name of the instruction in which the device/label is used.

Ladder Symbol For ladder programs, display elements of instruction in which devices are used.

Position Display the position which identifies the location of the device/label.
('■ Position information' on the next page)

Project*3 Display the project name or the library name in which the device/label is used.

Program File Name*3 Display the program file name in which the device/label is used.

Task*3 Display the task name of the program registration destination in which the device/label is 
used.

Data Type Display the type of data in which the device/label is used.

Data Name
Display the program or the data name registered in the program in which the device/label is 
used.
Display the block name for SFC program.

Comment*2 Display the comments of the device/label.

System Label Name*1,*2 Display the system label name which corresponds to the global label.
For devices/labels set for SFC block information, this column will be blank.

*1 : These items are not displayed in Simple project (without labels).
*2 : Only when "Display all items" is selected on the <<Condition Setting>> tab.
*3 : For Structured projects only
*4 : For ladder programs and SFC (Zoom) programs only
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Screen button

●

Prints the selected row. (Section 20.7)
Prints all lists when a row is not selected.

●

Displays a print preview of the selected row. (Section 20.9)
Displays a print preview of all lists when a row is not selected.

● Creating cross reference information
• Cross reference information can also be created by right-clicking a device/label on the program editor, and selecting 

[Cross Reference] from the shortcut menu.

Cross reference information can also be created based on all devices/labels by clicking the  button 
without specifying devices/labels after the Cross Reference window is displayed.

• The maximum number of creation results of the cross reference information is 80,000. However, since the internal 
data that are not displayed are included to the results, the number of results to be displayed in the cross reference 
information may not reach 80,000.
When "Auto-tracking" is selected on the <<Condition Setting>> tab, the maximum number of creation results of the 
cross reference information is 500.

● When a search location is selected from the list
When a program file name or an execution type is changed, the target program file may not be listed in "Find in". In this 
case, cross reference information of the program files whose name matches is created.

● Jump function
The jump function cannot be used for the cross reference information of parameters, block information, and block start 
steps.

● Moving the focus
•  (+) moves the focus between the editor and the Cross Reference window.
•  (+)/+ (++) moves the cursor to the previous/next row.

● Displaying comments
In a ladder/SFC project, comments specified in [Tool] ⇒ [Options] ⇒ "Program Editor" ⇒ "All Editors" ⇒ "Device 
Comment" ⇒ "Reference/Reflection Target for Device Comment" are displayed as device comments.
(Section 9.1.1)

● Searching cross reference information with label definitions
The time to display the creation results of the cross reference information becomes longer when the number of results 
exceeds 80,000 substantially.
When labels contain array elements exist, this symptom can be avoided by clearing the check box of "Display 
hierarchically" on the <<Condition Setting>> tab.

Restrictions

● When "Create cross reference information after completion compile" is selected in the option setting
• When timer device (T) is specified as a search condition, devices of contact (TS), coil (TC), and current value (TN) 

also become search targets. When any of the timer devices: contact (TS), coil (TC), or current value (TN), is 
specified, timer device (T) is also searched along with the specified device.
The same operation as above applies when specifying retentive timer device or counter device.

• When device/label which is not indexed is specified as a search condition, only devices/labels which are not indexed 
are searched.
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■ Icons to indicate attribute

The following table shows icons displayed according to the attribute of device/label.
When the attribute is label, an icon is displayed with a combination of class and data type as shown in 
the display example.

■ Position information

The following position information is displayed according to the editor.

Attribute Icon Description Display 
example

Device Displayed when the attribute is device.

Label – – –

Class

Displayed when the label class is VAR_GLOBAL.

Displayed when the label class is VAR_INPUT.

Displayed when the label class is VAR_OUTPUT.

Displayed when the label class is VAR_IN_OUT.

Data type

Displayed when the label data type is simple data type.

Displayed when the label data type is function block.

Displayed when the label data type is structure.

Label usage Displayed when labels are used in a program.

Type Description Example

Ladder editor Step number Step No. 5

ST editor Number of lines Row No. 2

SFC editor*1

*1 : For the SFC block number, check the property of block (program) displayed in "Data Name". (For details of properties 
Section 4.3.6)

SFC symbol and step number SFC Step No. 3, Step No. 4

Structured Ladder/FBD editor Ladder block number and grid position 2. (10. 2)

Label Setting screen, Structure 
Setting screen Row number 1

Parameter Name of parameter item to which devices are 
set Auto Refresh

Block information of SFC program Name of block information to which devices/
labels are set Block START/END Bit

Inline structured text STB step (number of lines) STB 3 (Row No.2)
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■ Displaying cross reference information

● Displaying cross reference information in uncompiled state
For a project with labels, cross reference information can be created based on the compilation result, 
and it can be displayed even in an uncompiled state.
To display cross reference information in an uncompiled state, perform one of the following 
operations.
• Select "Fast Find" on the <<Condition Setting>> tab.

This item can be set for Simple projects (with labels) only.
For details of "Fast Find", refer to Section 10.1.2.

• Select [Tool] ⇒ [Options] ⇒ "Compile" ⇒ "Basic Setting", select "Create cross reference 
information after completion compile", and execute the compilation.
By setting this item, the cross reference information can be displayed quicker while the compilation 
time gets longer.

● Display after creation of cross reference information is completed
The icon on the bottom left of the screen changes according to the status of the displayed cross 
reference information.

• The data protected by security cannot be displayed.
• If the program or the option setting is changed, the cross reference information does not 

correspond with the program. In order to update the cross reference information, create it again.
• Each column can be sorted in ascending/descending order by clicking on the column header. 

However, the sort cannot be performed if the structure/array/FB is displayed in the tree. To cancel 
the display in the tree, clear "Display hierarchically" and "Display the last device of multiple points 
device" on the <<Condition Setting>> tab.

● Deleting data after compiling a program
When data is deleted after the program is compiled, the deleted data may be displayed as a search 
result.
To display the most recent cross reference information, compile the program and create cross 
reference information again.

● Searching for multiple word (such as DMOV instruction) in a ladder program
When a negative constant (example: K-1) is specified for device/label, an incorrect search result may 
be displayed.
In this case, perform the search function by specifying all devices/labels, and check the search result.

● Searching for refresh device of CC-Link parameter
For refresh devices (RX/RY) set in a local station or standby station of the CC-Link parameter, the 
target of search is only the first 16 points of devices.

● When the same name is used for label and device
The Auto-tracking function of cross reference gives devices a priority to be searched.
To display cross reference information of label whose name is the same as that of device, search for 
"All Device/Label" in "Device/Label". Then, enter a label name in the "Device/Label" column of 
filtering condition, and execute the filtering display.

Icon Status of cross reference information

Indicate the cross reference information is updated.

Indicate the project has been changed after the cross reference information is created.

Indicate the cross reference information cannot be used. For instance, cross reference 
information has not been created.

Indicate the cross reference information created in past is displayed. (Only when "Fast Find" is 
selected.)
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● Searching for BL devices
When BLn is specified for the device to be searched, the block start steps for n block start are also 
searched.
"BLOCK" (with END check) or "BLOCK-S" (without END check) is displayed in the "Instruction" 
column on the Cross Reference window.

■ Displaying/hiding columns

Columns in the screen can be displayed or hidden by right-clicking a column header of the cross 
reference information and selecting the items to be displayed or hidden from the shortcut menu.

■ Displaying devices/labels that use FB instance

To create the cross reference information from the devices/labels used in the function block, select the 
FB instance to create the cross reference information.
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10.1.2 Setting conditions

Conditions are set on the <<Condition Setting>> tab on the Cross Reference window.
Whenever the condition is changed, the cross reference information needs to be recreated.

Screen display
Select the <<Condition Setting>> tab on the Cross Reference window.

Operating procedure

• Set the items on the screen.

Item Description

Find Condition –

Include label definition Select this to search each label setting editor.

Set device other than head as 
find target

Select this to search devices following the start device of digit-specified device/
multiple word device.

Specify find order*1

*1 : For QCPU (Q mode) excluding Basic model QCPU and LCPU only

Specify the search order.

Display Condition –

Display all items Select this to display all items that can be created in the cross reference 
information.

Display hierarchically Select this to display a structure/array/FB hierarchically.

Display the last device of 
multiple points device*2

*2 : For ladder programs and SFC (Zoom) programs only

Select this to display the start and last devices when a device which uses two or 
more points in a instruction is specified.

Find Mode –

Auto-tracking*3

*3 : For projects with labels, this item can be selected when "Create cross reference information after completion 
compile" is selected under [Tool] ⇒ [Options] ⇒ [Compile] ⇒ [Basic Setting], or when "Find Mode" is selected on 
the <<Condition Setting>> tab.

Select this to create cross reference information of devices/labels selected on the 
editor automatically.

Auto-Tracking Only in 
Click/Key Operation

Select this to update cross reference information only when the cursor is moved 
by clicking the mouse or pressing the key.
When this item is selected, the Auto-tracking function does not apply to the 
operations with the mouse wheel and the scroll bar.

Fast Find*4

*4 : For Simple projects (with labels) only

Select this to display cross reference information more quickly.
Only "Device/Label", "Device", "Instruction", "Ladder Symbol", "Position", and 
"Data Name" are displayed.
ST programs, inline structured text programs, and the second hierarchy of 
function block in ladder programs are not searched.
By selecting this item, the setting of "Create cross reference information after 
completion compile" under [Tool] ⇒ [Options] ⇒ [Compile] ⇒ "Basic Setting" is 
disabled.

Explanation Display the explanation of the condition item.
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10.1.2  Setting conditions

● "Specify find order" on the <<Condition Setting>> tab
The search order of the "Specify find order" function and the display order of search result are as follows.
• When "Do not specify" is selected, data are searched in the order of data name.

The search result is displayed in the order of parameters, programs, and labels.
• When "Program Setting" is selected, data are searched in the order of program files set on the <<Program>> tab of 

PLC parameter.
The search result is displayed in the order of local label and program, global labels, and parameters.

Note that when "Fast Find" on the <<Condition Setting>> tab is selected or "Create cross reference information after 
completion compile" in the option setting is selected, "Do not specify" is set for "Specify find order".

● "Display the last device of multiple points device" on the <<Condition Setting>> tab
The last device of the device which uses multiple device points in an instruction or refresh parameter can be displayed. 
Select "Display the last device of multiple points device" on the <<Condition Setting>> tab to display the last device.
The start and last devices are displayed in a tree format as shown below.

● "Auto-tracking" on the <<Condition Setting>> tab
For ladder program, devices/labels of second and the following arguments of the instruction are also automatically 
tracked.
To display cross reference information of second and the following arguments of the instruction during the Auto-
tracking mode, perform the following operations.
• For a project without labels, select from the "Device/Label" input column.
• To search devices in a project with labels, select from the "Device" column of filtering condition.
• To search labels, select from the "Device/Label" column of filtering condition.

● "Find Mode" on the <<Condition Setting>> tab
If "Find Mode" is selected, cross reference information is automatically created when the following operation is 
performed.
• Changing a ladder or SFC (Zoom) program
• Compiling a program
• Adding/deleting program data
• Reading data from a programmable controller CPU
• Changing a programmable controller type

Search order when 

"Program Setting" 

is selected.
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10.1.3 Filtering display

Filter the created cross reference information.
Elements cannot be filtered.
The following is an example of display by filtering devices/labels with the condition 'D*'.

Operating procedure

1. Enter 'D*' in the filtering condition column under "Device/Label".

2. Press the  key.
The data matching with the set filtering condition are displayed on the Cross Reference window.
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10.1.3  Filtering display

● Filtering condition
Clicking  enables to select a keyword from the list of previously entered keywords.
For "Data Name" and "Program File Name", search results can also be selected from the list as well as previously 
entered keywords.

● Tree display of filtering condition
Only data whose components match with the filtering conditions are displayed in the tree format when filtering display is 
executed for the structure data names or the instance names of the function block.

● Deleting filtering condition
Filtering display of the column can be canceled by deleting keywords entered in each filtering condition column.

● Keywords for filtering condition
The wild card characters can be used in a filtering condition shown as below.

Example) When the filtering condition is set for the device/label column.

Wild card Search target Example Search Result

* Specifies any character string. *30* ready301, K4X30, K1Y30, K4Y30

? Specifies any one character. K4?30 K4X30, K4Y30

[ ] Specifies any one of those characters. [XY]8 X8, Y8

[! ] Specifies any one of characters except for the 
characters in the bracket. K4X[!3]0 K4X40, K4Y50

[ - ] Specifies character strings within the range in the 
bracket. D[0-2] D0, D1, D2

# Specifies any one-digit number. Local200# Local2001, Local2003
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10.2 Displaying Device List

This section explains how to display the usage of the specified devices.

Screen display
Select [Find/Replace] ⇒ [Device List].

Operating procedure

1. Set the items on the screen.

2. Click the  button.
Search result is displayed.

Remote HeadQ CPU L CPU FX

Item Description

Device
Enter a device to be searched for.
Click  to select a device from the list of previously searched devices.

Find In

Select a location to search for.

Click  to select a location to search for. Two or more search 
locations can be selected.
After selecting the search location, click the  button to save the search 
location.
Click  to select a location from the list of previously searched locations.
The location cannot be entered directly.

Display Option

All devices Display all devices.

Used devices Display devices used in the program.
Selected items are searched.

Unused devices Display devices not used in the program.

Number of Find 
Points

65536 Points Select this to set device points to be searched to 65536 points.

512 Points Select this to set device points to be searched to 512 points.
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Display contents

Screen button

●

Prints the selected row. (Section 20.7)
Prints all lists when a row is not selected.

●

Displays a print preview of the selected row. (Section 20.9)
Displays a print preview of all lists when a row is not selected.

●

Deletes device comments which are not used in a program.
Device comments can be deleted when a program is specified for "Find In".

■ Displaying/hiding columns

Columns can be displayed or hidden by right-clicking a column header of the search result and 
selecting the items to be displayed or hidden from the shortcut menu.

Item Description

Find Range
Display the range of the devices searched.

The display can be switched by clicking the /  button.

Device Display the device name.

Contact Display '*' when the device is used as a contact.

Coil (counts) Display '*' and the number of uses when the device is used as a coil.

Parameter*1
Display '*' when the device is used as a parameter or an intelligent function module 
parameter.

Comment
Display the device comment set for reference/reflection target in the option setting.
(Section 9.1.1 "■ Specifying device comments to be displayed in program")
Specify a program for "Find In" to enter device comments.

*1 : Not supported by FXCPU.
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■ Considerations of search in device list

The following shows the considerations of search in the device list.
● Handling of coil instructions

As output instructions, the following application instructions can also be the target of search.
SET, RST, PLS, PLF, FF, SFT, SFTP, and MC

● Searching for R devices and ZR devices
R devices and ZR devices are distinguished in the device list. Specify them separately when 
searching for R devices or ZR devices.

● Saved search locations
When the name of the program specified in the search location is changed, the program is not searched. In order to 
search the program with the changed name, specify the program in the search location.
Note that, however, when the program name is changed to the original name, the program is searched.

● Confirming locations of devices
The Cross Reference window can be opened from a used device displayed in the device list, and the location of the 
device can be confirmed.
To open the Cross Reference window, select a desired row in the device list and follow any of the following operations.
• Press the + keys or press the  key.
• Double-click the row.
• Right-click the row and select [Cross Reference] from the shortcut menu.
For the cross reference function, refer to Section 10.1.

● Displaying comments
• When searching for data with a selection of one program, device comments specified for "Reference/Reflection 

Target for Device Comment" under [Tool] ⇒ [Options] ⇒ "Program Editor" ⇒ "All Editors" ⇒ "Device Comment" are 
displayed. (Section 9.1.1)

• When searching for data with a selection of two or more programs, global device comments are displayed.
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10.3 Search/Replacement

This section explains how to search for and replacing character strings, devices, labels, instructions, 
etc. in project data.
If the All Find/All Replace function is executed, the details of the execution result are displayed.

● Purposes of each search/replacement
The following table shows the purposes of each search/replacement.

● Displaying the Find/Replace screen
The Find/Replace screen can also be displayed by selecting [View] ⇒ [Docking Window] ⇒ [Find/Replace].

● Replace function
• The programs are in the uncompiled status after the Replace function is executed. Compile all the programs again.
• The Replace function cannot be executed during monitoring. Execute the function after monitoring is finished.
• The Replace function cannot be executed when a program is opened with the read-only mode. Execute the function 

after setting the data in editable mode by the setting such as resetting the security.
● Searching/replacing labels

One point of device can be replaced when searching/replacing labels.
● Searching/replacing data in inline structured text box

The search starts from the top of the program in the inline structured text box regardless of the cursor position.
● Replacement of items corresponding to system labels

The following items that correspond to system labels cannot be replaced.
• Relation with system label
• System label name
• Attribute

Q CPU L CPU FXFXRemote FXHead

Function Purpose

Find Device/Replace 
Device Used for searching for/replacing a device or label in a program.

Find Instruction/Replace 
Instruction Used for searching for/replacing an instruction in a program.

Find String/Replace String Used for searching for/replacing a character string used in a program, label, and device 
comment.

Change Open/Close 
Contact

Used for switching the contact type of a specified device in a program from normal to negation, 
or from negation to normal.

Device Batch Replace Used for searching for/replacing devices or labels in a program in batch.
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10.3.1 Searching/replacing devices/labels

Search/replace devices/labels in the program.

Screen display
Select [Find/Replace] ⇒ [Find Device]/[Replace Device] ( ).

Operating procedure

1. Set the items on the screen.

Item Description

Find In

Click the  button to select a location to search for. Two or more 
search locations can be selected.
Click  to select a location from the list of previously searched locations.
The location cannot be entered directly.

Find Device Enter a device/label to be searched for or a replacing device/label.
Click  to select from the list of devices or labels entered previously.Replace Device

Device Point

Enter the number of points to be searched/replaced, counted from the device 
entered in the "Find Device" field. When a label is entered for "Find Device" or 
"Replace Device", enter 1.
Click  to select either hexadecimal or decimal for the value to be used.

Example) When X50 for "Find Device", X100 for "Replace Device", 3 for "Device 
Point", and "DEC" for entered value are set, the devices are replaced 
as shown below.
X50→X100, X51→X101, X52→X102

Find Direction

From Top Select this to execute a search in the downward direction from the start of the 
program.

Down Select this to execute a search in the downward direction from the cursor position.

Up Select this to execute a search in the upward direction from the cursor position.

Option

Digit*1
Select this to execute a search for the entered device and digit-specified bit devices 
that include the entered device.

Multiple 
word*2

Select this to execute a search for the entered device and the double-word format 
(double word/real number/indirect specification) word devices that include the 
entered device.

Consecutive 
search with 
enter key

Select this not to move the focus to the editor after the search/replace function.
The searched/replaced position may not be highlighted.

Device Comment*2
Move Select this to move a device comment of "Find Device" to "Replace Device".

Do not move Select this not to move a device comment of "Find Device" to "Replace Device".

*1 : For ladder programs and Structured Ladder/FBD programs only
*2 : For ladder programs only
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10.3.1  Searching/replacing devices/labels

2. Click the  button.
The cursor moves to the searched device.

Screen button

●

Searches for the character string entered in "Find String".

●

Batch searches for the character string entered in "Find String".
The search result is also displayed. (Section 10.3.6)

●

Replaces the character string entered in "Find String" with the character string entered in "Replace 
String".

●

Batch replaces the character string entered in "Find String" with the character string entered in 
"Replace String".
The replace result is also displayed. (Section 10.3.6)
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■ Examples of device search

The following tables show examples of specification for device search operations.

● Example of device search (Option: None)

● Example of device search (Option: Digit)

● Example of device search (Option: Multiple word)

Device specification Search result

M0 M0, K4M0, M0Z0, K4M0Z0

K4M0 K4M0, K4M0Z0

D0 D0, D0Z0, D0.1

D0.1 D0.1

J1\B0*1

*1 : Not supported by FXCPU.

J1\B0, J1\B0Z0, J1Z0\B0, J1Z0\B0Z0, J1\K4B0, J1\K4B0Z0, J1Z0\K4B0, 
J1Z0\K4B0Z0

Device specification Search result

X0 to X3 K1X0

X0 to X0F K4X0

X0 to X1F K8X0

X0Z0 X0Z0, K1X0Z0, K4X0Z0, K8X0Z0

Device specification Search result

D0 to D1 DMOV K1 D0, EMOV E1 D0, MOV K1 @D0

D0 to D9 BMOV D0 D100 K10

D0Z0 to D1Z0 DMOV K1 D0Z0

ZR0ZZ0 to ZR1ZZ0*1

*1 : Not supported by FXCPU.

DMOV K1 ZR0ZZ0

J1\W0 to J1\W1*1 DMOV K1 J1\W0

@D0 to @D1*1 DMOV K1 @D0

T0 to T1 DMOV K1 T0

T0Z0 to T1Z0 DMOV K1 T0Z0
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■ Devices/labels that can be replaced or batch replaced

The following table shows the devices/labels that can be replaced or batch replaced.
: Replaceable ×: Not replaceable

New device/label

Device 
(X0, D0)

Bit-specified 
word device 

(D0.1*1)

*1 : Supported by FX3U and FX3UC only.

Word device 
indirect 

specification*2 
(@D0)

*2 : Not supported by FXCPU.

Digit-specified 
bit device 

(K1X1)

Index 
setting 
(X0Z0)

Digit-specified 
bit device

+
Index setting 

(K4X0Z0)

Index setting
+

Bit-specified 
word device 
(J1Z0\W0.1*2)

Label/
String 

(g_bool1)

Old 
device/
label

Device (X0, D0)      × × 

Bit-specified 
word device 

(D0.1*1)
  × × × × × 

Word device 
indirect 

specification*2 
(@D0)

× × × × × × × 

Digit-specified 
bit device 

(K1X1)
× × × × × × × 

Index setting 
(X0Z0) × × × × × × × 

Digit-specified 
bit device

+
Index setting 

(K4X0Z0)

× × × × × × × 

Index setting
+

Bit-specified 
word device 

(J1Z0\W0.1*2)

× × × × × × × 

Label/String 
(g_bool1)        
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■ Searching/replacing devices/labels in inline structured text program

The following explains the considerations when searching/replacing devices/labels in the inline 
structured text program.

● Searching/replacing devices
Devices in the range specified for the parameter are searched. Devices out of the specified range are 
not searched.

● Searching/replacing labels
Both registered and unregistered labels are searched. All unregistered labels which are used at the 
label positions in the inline structured text program are searched.
The following table shows the examples of label positions.

● Comments in inline structured text program
Strings which are recognized as comments are not searched.
The following table shows the examples of comments.

● Device/label names
Device/label names are not case-sensitive.

Label position Example Description

Applicable label position
label1 Labels exist independently.

MOV (label1, D0, D1); Labels used at label positions in functions.

Inapplicable label position label1 (m1, m2) Labels used at instruction positions.

String Example Description

String recognized as comment
(* D1 *) Strings between the comment start symbol and the end 

symbol.

(* D1... Strings following the comment start symbol when the comment 
does not end with the end symbol.

String not recognized as 
comment D1 *) Strings in front of the comment end symbol when the comment 

start symbol is not used.
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10.3.2  Searching/replacing instructions

10.3.2 Searching/replacing instructions

Search/replace instructions.

Screen display
Select [Find/Replace] ⇒ [Find Instruction] ( )/[Replace Instruction]/[Find Contact or Coil] ( ).

Operating procedure

1. Set the items on the screen.

2. Click the  button.
The cursor moves to the searched instruction.

Screen button
For the screen buttons, refer to Section 10.3.1.

Element selection 

area

Device instruction 

input area

Item Description

Find In

Click the  button to select a location to search for. Two or more 
search locations can be selected.
Click  to select a location from the list of previously searched locations.
The location cannot be entered directly.

Find 
Instruction

Element selection area Click  to select an element to be searched for from the list.

Device instruction 
input area

Enter an instruction, device, or label to be searched for.
Click  to select from the list of instructions, devices, or labels entered previously.

Replace 
With

Element selection area Click  to select a replacing element from the list.

Device instruction 
input area

Enter a replacing instruction, device, or label.
Click  to select from the list of instructions, devices, or labels entered previously.

Find 
Direction

From Top Select this to execute a search in the downward direction from the start of the 
program.

Down Select this to execute a search in the downward direction from the cursor position.

Up Select this to execute a search in the upward direction from the cursor position.

Option Consecutive search 
with enter key

Select this not to move the focus to the editor after the search/replace function.
The searched/replaced position may not be highlighted.
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■ Examples of instruction search

The following table shows the examples of instruction search.

■ Considerations for searching for/replacing instructions

The following explains the considerations for searching for/replacing instructions.
● Instruction search specifying a coil instruction

As output instructions, the following application instructions can also be the target of search.
SET, RST, PLS, PLF, FF, SFT, SFTP, and MC

● Instruction replacement between a 16-bit (word) instruction and a 32-bit (double word) 
instruction
When a 16-bit (word) instruction is replaced with a 32-bit (double word) instruction, and if a constant 
is set for the device, the constant value is not sign-extended to a value in 32 bits.

When a 32-bit instruction is replaced with a 16-bit instruction, and if a constant is set for the device, 
upper 16 bits are discarded.

● Searching for NOP instructions and TRAN instructions
The NOP instructions used in the ladder programs and the TRAN instructions used in the transition condition of SFC 
programs cannot be searched.

Instruction specification Search result

MOV MOV, MOVP

MOVP MOVP

MOV D0 K4Y0 MOV D0 K4Y0, MOVP D0Z1 K4Y0, 
MOV D0 K4Y0Z1, MOVP D0Z1 K4Y0Z1

MOVP D0 J1\W0*1

*1 : Not supported by FXCPU.

MOVP D0 J1\W0, MOVP D0Z1 J1\W0, 
MOVP D0 J1Z1\W0Z1, MOVP D0Z1 J1Z1\W0Z1

The value is not sign-extended 

to -1(H0FFFFFFFF).

Example

(-1)

[MOV H0FFFF D0] Replace MOV to DMOV

(+32767)

[MOV H0FFFF D0]

Example

Replace DMOV to MOV
[DMOV K150000 D0]

[DMOV H0FFFFFFFF D0]

[MOV K18928 D0]

[MOV H0FFFF D0]



10 - 24

GX Works2

10  SEARCH/REPLACE

10.3.3  Searching/replacing character strings

10.3.3 Searching/replacing character strings

Search/replace character strings.

Screen display
Select [Find/Replace] ⇒ [Find String]/[Replace String].

Operating procedure

1. Set the items on the screen.

2. Click the  button.
The cursor moves to the searched character string.

Screen button
For the screen buttons, refer to Section 10.3.1.

Item Description

Find In

Click the  button to select a location to search for. Two or 
more search locations can be selected.
Click  to select a location from the list of previously searched locations.
The location cannot be entered directly.

Find String Enter a character string to be searched for or a replacing character string.
Click  to select a character string from the list of character strings entered 
previously.Replace String

Find 
Direction

From Top Select this to execute a search in the downward direction from the start of 
the program.

Down Select this to execute a search in the downward direction from the cursor 
position.

Up Select this to execute a search in the upward direction from the cursor 
position.

Option

Match case Select this to execute a case-sensitive search.

Match whole word only Select this to execute a search by matching whole word only.
For details of the whole word, refer to Point in this section.

Do not search comments in 
program

Select this to exclude line statements, PI statements, notes, and comments 
in programs from the search target.

Consecutive search with enter 
key

Select this not to move the focus to the editor after the search/replace 
function.
The searched/replaced position may not be highlighted.
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● Searching for NOP instructions and TRAN instructions
The NOP instructions used in the ladder programs and the TRAN instructions used in the transition condition of SFC 
programs cannot be searched.

● Searching/replacing data by matching whole word only
The whole word means a string separated by the break characters. The search/replace by matching whole word 
searches for only the character strings which are completely match with the character string entered in "Find String". 
Break characters are shown as below.
• Space, tab, line feed

Example) Searching for a device comment 'abc ; def' by the following character strings.

String to be 
searched for

Search result

Not selected Selected

a abc ; def Nothing is found.

abc abc ; def abc ; def

bc abc ; def Nothing is found.

abc ; def abc ; def abc ; def
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10.3.4 Changing contacts between open contact and closed 
contact

Change contact types from open contact to closed contact, and conversely, from closed contact to 
open contact.

Screen display
Select [Find/Replace] ⇒ [Change Open/Close Contact].

Operating procedure

1. Set the items on the screen.

Item Description

Find In

Click the  button to select a location to search for. Two or more 
search locations can be selected.
Click  to select a location from the list of previously searched locations.
The location cannot be entered directly.

Replace Device
Enter a device/label of which the contact type is to be changed between open 
contact and closed contact.
Click  to select from the list of devices/labels entered previously.

Device Point

Enter the number of points to be searched/replaced, counted from the device 
entered in the "Replace Device" field. When a label is entered for "Replace 
Device", enter 1.
Click  Click to select either decimal or hexadecimal for the value to be entered.

Example) When X100 for "Replace Device", 3 for "Device Point" and "DEC" for 
entered value are set, the contact type is replaced between open 
contact and closed contact at X100, X101 and X102.

Find 
Direction

From Top Select this to execute a search in the downward direction from the start of the 
program.

Down Select this to execute a search in the downward direction from the cursor position.

Up Select this to execute a search in the upward direction from the cursor position.

Option Consecutive search 
with enter key

Select this not to move the focus to the editor after the search/replace function.
The searched/replaced position may not be highlighted.
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2. Click the  button.
The cursor moves to the searched device.

3. Click the  or  button to change the contact type.
The contact types are changed from open to closed contact and from close to open contact, and 
the search for the next target devices continues.
If the  button is clicked, all contact types of searched devices are batch changed from 
open to closed contact and from close to open contact.

● Change open/closed contact function
For the ladder editor, the contact type at the cursor position can also be changed by selecting [Edit] ⇒ [Easy Edit] ⇒ 
[Switch Open/Close Contact] or pressing the + keys. Convert the program when this function is performed as 
the program becomes unconverted status.

● Operation applicability of the change open/closed contact function
The following table shows the contacts whose contact types can be changed.

Replace Example



10 - 28

GX Works2

10  SEARCH/REPLACE

10.3.5  Batch replacing devices

10.3.5 Batch replacing devices

Batch replace devices with the specified device/label.

Screen display
Select [Find/Replace] ⇒ [Device Batch Replace].

Operating procedure

1. Set the items on the screen.

2. Click the  button.
The devices/labels entered in "Find Device" are batch replaced with the devices/labels entered in 
"Replace Device".

Item Description

Find In

Click the  button to select a location to search for. Two or more 
search locations can be selected.
Click  to select a location from the list of previously searched locations.
The location cannot be entered directly.

Find Device Enter a device/label to be replaced.

Replace Device Enter a replacing device/label.

Points

Example) When X0 for "Find Device", X10 for "Replace Device", 5 for 
"Points", and "DEC" for "Point Format" are set, the devices are 
replaced as shown below:
X0→X10, X1→X11, X2→X12, X3→X13, X4→X14

Point Format

Device Comment*1
Move Select this to move a device comment of "Find Device" to "Replace Device".

Do not move Select this not to move a device comment of "Find Device" to "Replace Device".

*1 : For ladder programs only

Points: Enter the number of points to be replaced, counted from the 
device specified for "Find Device". When a label is entered for 
"Find Device" or "Replace Device", enter 1.

Point format:Click  to select either decimal or hexadecimal for the value 
entered for "Points".
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Screen button

●

Resets all setting items to default.

● Registering devices/labels in batch
Multiple devices can also be registered at once by selecting a range and dragging and dropping it from the ladder 
editor.

● Replacing devices in batch
Batch replacement between 16-bit counter devices and 32-bit counter devices is not supported by FXCPU.

● Devices that can be batch replaced
For devices that can be replaced in batch, refer to Section 10.3.1.
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10.3.6 Displaying results and error logs

After the All Find/All Replace function is executed, results and error logs are displayed.

■ Displaying results

Screen display

Click the /  button in the respective Find/Replace windows ⇒ <<Result>>.

Display contents

Search/replace 

results

Status

Sub status bar

Item Description

Search/replace results Display the character strings, locations, and positions which have been searched for or replaced.

Target List Display the character strings which match with the one in "Find/Replace String".

Place Display the locations where the search/replace function is executed.

Position Display the position information to specify the location where the search/replace function is 
executed. ('● Position information' on the next page)

Status Display the details of the search/replace results.

Find/Replace 
Result Display the number of character strings which have been searched for or replaced.

Error Logs Display the number of error logs.

Find String Display the character strings specified in "Find String".

Replace String Display the character strings specified in "Replace String".

Find In Display the location specified on the relevant Find/Replace window.

Sub status bar Display the search/replace results.
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● Position information
The following position information is displayed according to the editor.

Type Description Example

Ladder editor Step number 2 Step*1

ST editor Number of lines (6)

SFC editor SFC symbol and step number Transition No. 0

Structured Ladder/FBD editor Ladder block number and grid position 2. (10. 2)

Device comment editor Device name, start position X1, 0 Column

Label Setting screen,
Structure Setting screen,
Device memory editor

Row, column 8 Row 1 Column

*1 : For project with labels and SFC (Zoom), parentheses are appended to the step number.
(Example: (2) Step)
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■ Displaying error logs

Screen display

Click the /  button in the respective Find/Replace windows ⇒ <<Error 
Log>>.

Display contents

● Jump function
The jump function is used to jump from any row of search/replace results or logs to the corresponding character strings.
To execute a jump, right-click on the selected row and select [Jump] from the shortcut menu, or double-click the 
selected line.

Error logs

Status

Item Description

Status Display the number of error logs, and the search location.

Error logs Display the errors in search/replace results.
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11 - 1

11 SETTING PROGRAMMABLE 
CONTROLLER CPU CONNECTION 
DESTINATION

This chapter explains how to set a connection destination for accessing a programmable controller 
CPU from GX Works2.

11.1 Setting Connection Destinations 11 - 2

11.2 Accessing Programmable Controller CPU Directly 11 - 7

11.3 Accessing Programmable Controller CPU Via 
Networks 11 - 13

11.4 Accessing Programmable Controller CPU in Multiple 
CPU System 11 - 20

11.5 Accessing Redundant CPUs 11 - 23

11.6 Accessing Programmable Controller CPU via 
Ethernet Board 11 - 31

11.7 Accessing Programmable Controller CPU via G4 
Module 11 - 33

11.8 Setting for Access via Serial Communication Module 11 - 34

11.9 Setting for Access via GOT (GOT Transparent 
Function) 11 - 38

11.10 Accessing Programmable Controller CPU via Phone 
Line 11 - 44

11.11 Considerations of Communication with 
Programmable Controller CPU 11 - 66
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11.1 Setting Connection Destinations

This section explains how to set communication routes, including the interfaces both on the personal 
computer and programmable controller CPU and the routing networks, for accessing a programmable 
controller CPU.
Multiple connection destinations can be set in GX Works2. To set multiple connection destinations, 
create data for each connection destination on the New Data screen. (Section 11.1.2)
The programmable controller type of the project should be the same as that of the programmable 
controller CPU to be accessed.

Screen display
Select Navigation window ⇒ Connection Destination view ⇒ "(connection destination data 
name)".

Remote HeadQ CPU L CPU FX
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11.1.1 Transfer setup screen

Interfaces are displayed on the Transfer Setup screen as shown below and detailed settings of each 
interface can be configured.

Detailed settings can be set for underlined items on the screen. Double-click these items to set the 
details. The items whose icons are displayed in yellow are items that have been already set.
● PC side I/F

Set the interface of the personal computer.
● PLC side I/F

Set the interface of the programmable controller CPU connected to the personal computer.
● Other Station Setting

Item Description

No Specification Specify this to access the programmable controller CPU directly connected to a 
personal computer.

Other Station (Single 
Network)*1

Specify this to access the programmable controller CPU on another station via only 
one kind of network (including a multi-tier system) such as CC-Link only, 
MELSECNET/10(H) only, CC-Link IE only, C24 module only and Ethernet only.
Since Ethernet is regarded as equivalent to CC-Link IE and MELSECNET/10(H), 
specify "Single Network" for a mixed system in which Ethernet, CC-Link IE, and 
MELSECNET/10(H) are configured.

Other Station (Co-existence 
Network)*1,*2

*1 : When the host station is specified, select "No Specification".
*2 : Not supported by FXCPU.

Specify this to access the programmable controller CPU on another station via two 
kinds of network.
This means the system that is configured with two different networks, such that from 
MELSECNET/10(H) to CC-Link master/local module or from Q series C24 module to 
MELSECNET/10(H).

Detailed setting display fields

PC side I/F

PLC side I/F

MELSECNET/10(H)

Network route
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11.1.1  Transfer setup screen

● Network Communication Route
Select the network type, network number, station number, and start I/O number of the network that is 
routed for accessing the programmable controller CPU on another station. The setting items differ 
according to the selected network type.

● Co-existence Network Route*1

Select the network type, network number, station number, and start I/O number of the network to 
access. The setting items differ according to the selected network type.

● Target system*1,*2

Specify the access target in the multiple CPU system or the redundant system.
*1 : Not supported by FXCPU.
*2 : Not supported by LCPU.

Screen button

●

Displays the Connection Channel List screen.
The connection destination can be set while checking network routes on the Connection Channel List 
screen.
Since the route selected in the Connection Channel List screen is set automatically on the Transfer 
Setup screen, the setting is easy even for a complex system.
The following is an example of setting screen when QCPU (Q mode) is selected.

Operation
1. Select a route on the Connection Channel 

List screen.

2. Click the /  button.
The selected route is displayed on the Transfer 
Setup screen. Set the network number, station 
number, and other settings depending on the 
access target.
• "List mode"

●

Changes the connection destination setting for the setting that connects a personal computer directly 
to the programmable controller CPU to be accessed.
This function is useful to change the station specification from another station to host station.

List mode Description

Display All Routes Display all routes supported by GX 
Works2.

Display Selected 
Routes

Specify the interfaces for "PC side I/F" 
and "PLC side I/F" on the Transfer 
Setup screen and select "Display 
Selected Routes" to display only 
accessible routes for "Other Station 
Setting" and "Network Communication 
Route" setting.
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●

Tests if the target programmable controller CPU set on the Transfer Setup screen can be accessed 
normally.
If accessed normally, the model of the target programmable controller CPU module is displayed on 
the "PLC Type" field, one of the detailed setting display fields. In addition, for the multiple CPU 
system, the CPU number of the connection destination is displayed on the "Detail" field.

●

Shows the set connection channel in an illustration.

● /
Displays the Line Connection screen.
The screen is used to set the communication using a phone line.
For details of the Line Connection screen setting, refer to Section 11.10.2.

11.1.2 Creating connections

Create a new connection.
Select Navigation window ⇒ Connection Destination view, and perform the following operation.

Screen display
Select [Project] ⇒ [Object] ⇒ [New] ( ).

Operating procedure

1. Set the items on the screen.

2. Click the  button.
The created connection destination is added to "All Connections" on the Connection Destination 
view.

Item Description

Data Name Enter the name of the connection to be created.

Set as Default 
Connection Select this to specify the connection destination to be created for regular use.
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11.1.3  Specifying connection destination for regular use

11.1.3 Specifying connection destination for regular use

Specify a connection destination for regular use when multiple connection destinations are set.

Operating procedure

1. Select the connection destination data to be specified as for regular use from "All 
Connections" on the Connection Destination view.

2. Select [Project] ⇒ [Object] ⇒ [Set as Default Connection].
The name of the selected connection destination data is set as the connection destination for 
regular use, and displayed on "Current Connection".

● Connection destination setting
The connection destination data can also be specified for regular use by dragging and dropping it from "All 
Connections" to "Current Connection".

     is appended to the icon of data  

specified as the connection destination  

for regular use.
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11.2 Accessing Programmable Controller CPU Directly

This section explains the setting method for accessing the programmable controller CPU directly 
connected to a personal computer.

11.2.1 Connecting with serial/USB cable

The following explains the setting for accessing the host programmable controller CPU from GX 
Works2 with serial/USB cable.

HeadQ CPU L CPU FXFXRemote

Host programmable controller CPU

When connecting 

directly to the 

programmable 

controller CPU.
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11  SETTING PROGRAMMABLE CONTROLLER CPU CONNECTION DESTINATION

11.2.1  Connecting with serial/USB cable

■ Connecting to QCPU (Q mode)/LCPU

The following explains the setting for accessing the QCPU (Q mode)/LCPU on the host station.

Operation
1. Set "PC side I/F".

Section 11.1.1

2. Set "PLC side I/F".
Select the series of the programmable controller CPU to 
be connected.

3. Set "No Specification" for "Other Station Setting".
Set "Check at communication time" and "Retry times" as 
necessary.

■ Connecting to FXCPU

The following explains the setting for accessing the FXCPU on the host station.

Operation
1. Set "PC side I/F".

Section 11.1.1

2. Set "PLC side I/F".
This setting is not required for the series other than 
FX3G, FX3GC, FX3U, and FX3UC.
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3. Set "No Specification" for "Other Station Setting".
Set "Check at communication time" and "Retry times" as 
necessary.

● "PC side I/F" of FXCPU
For FXCPU, select the RS-232/USB with considering the description indicated in the table below.

● Communication speed with FXCPU
The following table shows communication speed that FXCPU support.

For connecting to FX3G, FX3GC, FX3U, or FX3UC and communicating at 38.4kbps/57.6kbps/115.2kbps, the following 
adapter is required.
FX3G, FX3GC: FX-232AWC-H
FX3U, FX3UC: FX-232AWC-H or FX-USB-AW

Item Description

RS-232 C
(Including FX-USB-AW and FX3U-USB-BD)

Select this item when connecting using the RS-232 of a personal computer 
or when connecting to the USB of a personal computer with FX-USB-AW/
FX3U-USB-BD.

USB
Select this item when connecting the GOT1000 series USB to the USB of 
a personal computer directly using the transparent function or when 
connecting to the USB of a personal computer directly.

Communication 
speed

FX0
FX0S

FX0N FX1
FXU
FX2C

FX1S
FX1N

FX1NC
FX2N

FX2NC
FX3G

FX3GC
FX3U

FX3UC

9.6kbps         

19.2kbps – – – – –    

38.4kbps – – – – – – –  

57.6kbps – – – – – – –  

115.2kbps – – – – – – –  
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11.2.2  Accessing by Ethernet

11.2.2 Accessing by Ethernet

Access the Built-in Ethernet type CPU or the FXCPU with Ethernet adapter from GX Works2 by 
Ethernet.

*1 : For details of the system consists of FXCPU and an Ethernet adapter, refer to the following manual.
FX3U-ENET-ADP User's Manual

Operation
• Set the connection destination setting.

HeadRemoteL CPUQ CPU
*1

FX
*2

*1: Built-in Ethernet port QCPU only
*2: FX3G, FX3GC, FX3U, and FX3UC only

Built-in Ethernet type CPU

(192.168.0.2)

*1

Item Description

PC side I/F
Select a protocol.
Since network number and station number are not used, the settings of network 
number and station number are not required.

PLC side I/F Select the access method. (■ Detailed settings of PLC side I/F)
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■ Detailed settings of PLC side I/F

The following is a setting example when searching for a Built-in Ethernet type CPU or an FXCPU with 
Ethernet adapter on the same network connected via hub and utilizing the IP address.
The following is a screen of QCPU (Q mode)/LCPU.

Operation
1. Select a programmable controller type connected to a personal computer in "PLC Mode".

For FXCPU, the programmable controller type is fixed to FXCPU.

2. Select "Connection via HUB".

3. For QCPU (Q mode)/LCPU, click the , and for FXCPU, click 

the  button.
The IP addresses, CPU types, labels, and comments of the Built-in Ethernet type CPU or the 
FXCPUs with Ethernet adapter on the same network are displayed in the 'connection destination 
CPU information list'.

4. Select a Built-in Ethernet type CPU or an FXCPU with Ethernet adapter to be connected in 
the 'connection destination CPU information list', and click the  
button.
The selected IP address is displayed in "IP Address".

Connection destination 

CPU information list
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11.2.2  Accessing by Ethernet

● Considerations when using Windows Vista® or Windows® 7
On Windows Vista® or Windows® 7, the following message may be displayed when the 

 button is clicked.

Click the  button for Windows Vista® and click the  button for Windows® 7 to unblock 
the program (permit the access) and continue the operation. (The screen shown below is from Windows Vista®.)

● When the same IP addresses are displayed
If the same IP address is displayed in the 'connection destination CPU information list' when the 

 button is clicked, multiple IP addresses may be set in the Windows® Network 
Connections setting.
In such case, reset the IP addresses not to duplicate on the Internet Protocol (TCP/IP) Properties screen.
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11.3 Accessing Programmable Controller CPU Via Networks

This section explains how to access the programmable controller CPU on another station from a 
personal computer via networks.

Operation
1. Set "PC side I/F".

Section 11.1.1

2. Set "PLC side I/F".
Section 11.1.1

3. Set "Other Station Setting"
Section 11.1.1

4. Set "Network Communication Route" / "Co-existence Network Route".
Select the network type, network number, station number, and start I/O number of the network 
that is routed for accessing the programmable controller CPU on another station. The setting 
items differ according to the selected network type.

Q CPU L CPU FXFXRemote FXHead

MELSECNET/10(H)

When accessing other 

stations via co-existence 

networks.

When accessing other 

stations via a single 

network.
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■ Setting example of "Other Station (Single Network)"

The following is the setting example for accessing the programmable controller CPU via single network.
● Screen settings for the mixed system in which MELSECNET/10(H), CC-Link IE, and Ethernet 

are configured (single network)
For the mixed system in which MELSECNET/10(H), CC-Link IE, and Ethernet are configured, specify 
"Single Network" when accessing the programmable controller CPU on another station. (Since 
Ethernet is regarded as equivalent to CC-Link IE and MELSECNET/10(H), specify "Single Network".)
The following shows the connection destination detail setting screen example for the mixed system 
configuration (Q series only).

MELSECNET/10(H) 

Network number 1

Ethernet 

Network number 2

Ethernet 

Network number 3

Request target (Station number 1)
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● Accessing programmable controller CPUs on another station
Routing parameters need to be set when accessing a programmable controller CPU on another station with a different 
network number, or when accessing a programmable controller CPU on another station via network system mixed with 
MELSECNET/10(H), CC-Link IE and Ethernet.
Accessing a programmable controller CPU on another station is possible within the network system specifications by 
setting routing parameters.
For details of routing parameters, refer to the manual of each network module.

● Mixed system consisting of MELSECNET/10(H), CC-Link IE, and Ethernet
Ethernet parameter "Station No. ⇔ IP Information" must be set. For details, refer to the following manual.
Q Corresponding Ethernet Interface Module User's Manual (Application)
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● Screen settings for CC-Link system with QCPU (Q mode)/LCPU (single network)
The following shows the connection destination detail setting screen example for the CC-Link system 
configuration.

● Accessible station numbers when accessing the programmable controller CPU on another station via CC-Link
When the programmable controller CPU is connected directly or via a serial communication module, accessible station 
numbers when accessing the programmable controller CPU on another station via CC-Link are 0 (master) to 63.

Master station Station number 1 Station number 2
Request target 

(Station number 3)

Start I/O number of route 

source CC-Link master/local 

module (    )

Station number of route 

target CC-Link master/local 

module (     )
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● Screen settings for CC-Link system with FXCPU (single network)
• When FXCPU is a master station

The following shows the example of connection destination detail setting screen for the CC-Link 
system configuration.
For details of CC-Link system with FXCPU, refer to the following manuals.
CC-Link user's manuals for FXCPU

● Considerations when accessing other stations via CC-Link
• When accessing other stations via CC-Link, FXCPUs other than the master station can be accessed only when an 

FXCPU master station (2 in above figure) is relayed.
• Specify the special block number (0 to 7) of CC-Link master station which is connected to the master station for "Start 

I/O No." in the Network Communication Route Detailed Setting of CC-Link screen.
• The following are the accessible station numbers according to the FXCPU model of the master station.

FX3U, FX3UC: 1 to 16
FX3G, FX3GC: 1 to 12

Master station

CC-Link

Request target

(Station number 3)Station number 1 Station number 2

*1: FX3G/FX3GC version 2.00 or later

     FX3U/FX3UC version 3.10 or later

*2: FX3G/FX3GC/FX3U/FX3UC

     For FX3UC, supported by version 2.20 or later

*3: CC-Link master station

*4: CC-Link intelligent device station

FXCPU
*2 *4

FXCPU
*2 *4

FXCPU
*2 *4

FXCPU
*1 *3

Special block number of route 

source CC-Link master station (   )

Station number of request target 

CC-Link intelligent device station 

(   )
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• When QCPU (Q mode) is a master station
The following shows the example of connection destination detail setting screen for accessing 
FXCPU via QCPU (Q mode).
For details of CC-Link system with FXCPU, refer to the following manuals.
CC-Link user's manuals for FXCPU

● Accessible station numbers when accessing other stations via CC-Link
Accessible station numbers are 1 to 63.

CC-Link

Request target

(Station number 3)

QCPU 
(Q mode)

FXCPU

*1

*2 *3
*1: Master station

*2: FX3G/FX3GC/FX3U/FX3UC

     For FX3UC, supported by version 2.20 or later

*3: CC-Link intelligent device station 

Start I/O number of route source 

CC-Link master/local module (   )

Station number of request target 

CC-Link intelligent device station (   )
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■ Setting example of "Other Station (Co-existence Network)"

The following is the setting example for accessing the programmable controller CPU via co-existence 
network.
This setting is not supported by LCPU and FXCPU.
● Screen settings for the mixed system in which MELSECNET/10(H) and Q series C24 modules 

are configured (co-existence network)
The following shows the connection destination detail setting screen example for the mixed system 
configuration (Q series only).

MELSECNET/10 (H) 

Network number 1

C
P

U

C
2

4

M
N

E
T

/
1

0
(H

)

C
P

U

C
2

4

C
P

U

M
N

E
T

/
1

0
(H

)

M
N

E
T

/
1

0
(H

)

MELSECNET/10 (H) 

Network number 2

C
P

U

M
N

E
T

/
1

0
(H

)

C
2

4

Set the routing parameters.

Multi-drop connection

Station No.0

Station number 22 Request target (Station number 2)

Start I/O number of 

route source C24 module (   )

Station number of 

route target C24 module (   )
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11.4 Accessing Programmable Controller CPU in Multiple CPU System

*1 : Not supported by Q00J/Q00UJ and Redundant CPU.

This section explains the setting method for accessing the programmable controller CPU (host CPU) 
directly connected to the personal computer or other programmable controller CPUs (other CPUs) in 
the multiple CPU system. The setting method for accessing the multiple CPU system on another 
station via a network is also explained.

■ Accessing host CPU

The setting for accessing the host CPU is the same as that for accessing the programmable controller 
CPU on the host station. (Section 11.2)

■ Accessing other CPUs

In the multiple CPU system, specify the CPU number of the access target at "Multiple CPU Setting" 
when accessing a programmable controller CPU that is not directly connected to the personal 
computer.
For Basic model QCPU and Universal model QCPU (Q00U/Q01U/Q02U), the CPU No. 1 to 3 can be 
specified.
For High Performance model QCPU, Process CPU, and Universal model QCPU (except for Q00U/ 
Q01U/Q02U), the CPU No. 1 to 4 can be specified.

The following shows a setting example when accessing the CPU No. 4 by connecting the personal 
computer to the CPU No. 1.

Operation
1. Set the settings from "PC side I/F" to 

"Co-existence Network Route"
Section 11.1.1

2. Set the access target CPU number with 
"Multiple CPU Setting" for "Target 
System".

FXFXHeadRemoteQ CPU

*1

L CPU

CPU No. 1 (connected to the personal computer)

CPU No. 2

CPU No. 3

CPU No. 4 (access target)

Specify the

CPU No. 4.
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■ Accessing the programmable controller CPU via network in multiple CPU 
system

The following explains the setting method for accessing the programmable controller CPU in a multiple 
CPU system on another station via a network.
● Relay station

Set the parameters so that the network module mounted on the relay station is controlled by the 
same programmable controller CPU. (In the figure below, CPU No. 2 is the control CPU.)

● Access target station
Set the CPU number in "Multiple CPU Setting" on the Transfer Setup screen if the access target 
station has the multiple CPU system.

The following shows a setting example when accessing the CPU No. 4 in the multiple CPU system on 
the access target station via a network.

*1 : Section 11.1.1

Set the network modules of the relay station to be 

controlled by the same control CPU. (         ) 

MELSECNET/H

MELSECNET/H

QCPU No. 1
QCPU No. 2

QCPU No. 3

QCPU No. 4

Module controlled by the QCPU No. 1
(MELSECNET/10(H), CC-Link IE)

Module controlled by the QCPU No. 2
(MELSECNET/10(H), CC-Link IE)

2

Module controlled by the QCPU No. 2
(MELSECNET/10(H), CC-Link IE)

Personal computer

1

2

3

4

1 2 3 4

1 2 3 4

1

1

2

1 2 3 4

2'

2

2'

Set the connection destination setting.

When accessing one of the CPUs No. 1 to 4 

on the access target station, change the CPU 

number to be accessed in "Multiple CPU 

Setting" on the Transfer Setup screen.

2 2'

Use modules with function version B or later for all modules on 

the host station, relay station, and access target station.

The CPU No. 4 (    ) on the access target station is 

accessed via the network module      by connecting a 

cable to the CPU No. 1 (    ). Note that the cable shall 

be connected to the programmable controller CPU that 

controls the routed network module.

Host station

Network number 1

Relay station

Network number 2

Access target station

1

4

1

Specify the CPU number.

*1
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● Access range by network module function versions
To access programmable controller CPUs which are not controlling the network module of the access target station, 
use the network module with function version B or later.
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11.5 Accessing Redundant CPUs

*1 : Redundant CPU only

This section explains how to access Redundant CPUs.

Operation
1. Set the settings from "PC side I/F" to "Co-existence Network Route". (Section 11.1.1)

2. Specify the system with "Target System".

FXFXHeadRemoteQ CPU

*1

L CPU

Connective system 

(Access target) Target system

Tracking cable

Specify the system.

Item Description

Not Specified

• When connecting a CPU directly
A programmable controller CPU directly connected to a personal computer

• When routing a module mounted on a main base unit
A programmable controller CPU of the station on which a network module 
whose station number is specified for the network communication route is 
mounted

• When routing a module mounted on an extension base unit
A programmable controller CPU whose system is set as a control system

Control System A programmable controller CPU whose system is a control system

Standby System A programmable controller CPU whose system is a standby system

System A A programmable controller CPU with an A side connector of tracking cable

System B A programmable controller CPU with a B side connector of tracking cable
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● "Target System" setting when performing the monitoring function
When performing the monitoring function on a Redundant CPU, set "Not Specified", "System A", or "System B" for 
"Target System".
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11.5.1 Considerations for routing intelligent function module on 
extension base unit

The following table shows the applicability of functions according to the "Target System" setting when 
accessing a Redundant CPU via an intelligent function module on the extension base unit.

: Applicable : Applicable with restrictions ×: Not applicable

Function

Target System

RestrictionsSystem A/
System B

Not specified/
Control system/
Standby system

Change TC setting × ×

Online program change × ×

Read from PLC  ×

Write to PLC × ×

Verify with PLC  ×

Redundant Operation  
System switching and change operation mode 
functions are not applicable.

Password

New  ×

Delete  ×

Disable  ×

Clear PLC memory  
Clear all file registers function is not 
applicable.

Arrange PLC memory × ×

Delete PLC data  ×

Read PLC user data  ×

Write PLC user data × ×

Delete PLC user data  ×

Export to ROM format × ×

Monitor mode   Monitoring SFC programs is not applicable.

Monitor (write mode)  
Monitoring and verifying SFC programs are 
not applicable.

Start monitoring (all windows)   Monitoring SFC programs is not applicable.

Stop monitoring (all windows)   Monitoring SFC programs is not applicable.

Start monitoring   Monitoring SFC programs is not applicable.

Stop monitoring   Monitoring SFC programs is not applicable.

Local device monitoring  ×

Monitoring program list  ×

Interrupt program list  ×

Monitoring condition setting × ×

SFC all block batch monitoring  ×

SFC auto scroll  ×

Sampling trace × ×

Scan time measurement  ×

MELSECNET diagnostics  ×
Network test, loop test, setting verification test, 
station order check test, and communication 
test are not applicable.

Online module change  ×

Confirm memory size   Online mode is not applicable.
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11.5.2  Operation when system switching occurs on Redundant CPU

11.5.2 Operation when system switching occurs on Redundant 
CPU

When a system switching occurs while accessing a Redundant CPU, the access is continued as 
described below.
This function is valid when "Control System" or "Standby System" is set for "Target System" on the 
Transfer Setup screen.

When "Control System" is set for "Target System".

The system is switched.

Control system

CPU1 CPU2

CPU1 CPU2

Standby system

Standby system Control system

Connect to control 
system via standby 

system.
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11.5.3 Operation when communication error occurs during 
monitoring

If a communication error occurs on the route of communication with Redundant CPU, the 
communication route is automatically switched to continue the monitoring of the system specified on 
the Transfer Setup screen.
When the following conditions 1 to 3 are satisfied, the access to the Redundant CPU is continued by 
route switching.

1) Monitoring functions of route switch target
• Ladder program monitoring (including Entry Ladder Monitor function, and monitoring programs 

of Zoom editor and inline structured text)*1

• ST program monitoring
• Structured Ladder/FBD monitoring
• Local device monitoring*2

• Device/buffer memory batch monitoring*3

• Watch
• Monitoring condition setting*4

• Monitoring stop condition setting*4

• Remote operation
• Redundant operation
• PLC diagnostics
• Monitoring of intelligent function module

*1 : Not supported by SFC diagram.
*2 : When a communication error occurs and the local device monitoring target program is switched, the monitoring 

stops.
*3 : When a communication error occurs at a timing of display format change, or when a communication error occurs 

during scrolling, the monitoring stops.
*4 : When a communication error occurs, conditions cannot be registered/canceled.

2) Operation modes and connection targets in which a route switch can be performed

3) Communication routes in which a route switch can be performed

– Operation mode/connection target in which a monitoring can be continued

Operation mode Backup mode, separate mode

Connection target Control system, standby system, system A, system B
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11.5.3  Operation when communication error occurs during monitoring

PC side I/F PLC side I/F Other Station Setting Network 
Communication Route

Co-existence Network 
Route

Serial/USB

PLC Module

Other Station
(Single Network)

CC IE Cont, NET/10(H) –

CC IE Field –

Ethernet –

Other Station
(Co-existence Network)

C24
CC IE Cont, NET/10(H)

Ethernet

CC-Link
CC IE Cont, NET/10(H)

Ethernet

GOT

Other Station
(Single Network)

CC IE Cont, NET/10(H) –

CC IE Field –

Ethernet –

Other Station
(Co-existence Network)

C24
CC IE Cont, NET/10(H)

Ethernet

CC-Link
CC IE Cont, NET/10(H)

Ethernet

Serial/USB

Communication 
Head Module

Other Station
(Single Network) CC IE Field –

Other Station
(Co-existence Network)

C24
CC IE Cont, NET/10(H)

Ethernet

CC-Link
CC IE Cont, NET/10(H)

Ethernet

C24

Other Station
(Single Network)

CC IE Cont, NET/10(H) –

CC IE Field –

Ethernet –

Other Station
(Co-existence Network)

C24
CC IE Cont, NET/10(H)

Ethernet

CC-Link
CC IE Cont, NET/10(H)

Ethernet

NET/10(H) Remote

Other Station
(Single Network)

CC IE Cont, NET/10(H) –

Ethernet –

Other Station
(Co-existence Network)

C24
CC IE Cont, NET/10(H)

Ethernet

CC-Link
CC IE Cont, NET/10(H)

Ethernet

G4 Module Other Station
(Co-existence Network) CC-Link

CC IE Cont, NET/10(H)

Ethernet

CC IE Cont NET/
10(H) Board

CC IE Cont NET/
10(H) Module

Other Station
(Single Network) CC IE Cont, NET/10(H) –

CC IE Field 
Board

CC IE Field Master/
Local Module

Other Station
(Single Network) CC IE Field –

Communication 
Head Module

Other Station
(Single Network) CC IE Field –

CC IE Field Ethernet 
Adapter

Other Station
(Single Network) CC IE Field –

CC-Link Board CC-Link Module Other Station
(Co-existence Network) CC-Link

CC IE Cont, NET/10(H)

Ethernet
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Ethernet Board

CPU module

Other Station
(Single Network)

CC IE Cont, NET/10(H) –

CC IE Field –

Ethernet –

Other Station
(Co-existence Network)

C24
CC IE Cont, NET/10(H)

Ethernet

CC-Link
CC IE Cont, NET/10(H)

Ethernet

GOT

Other Station
(Single Network)

CC IE Cont, NET/10(H) –

CC IE Field –

Ethernet –

Other Station
(Co-existence Network)

C24
CC IE Cont, NET/10(H)

Ethernet

CC-Link
CC IE Cont, NET/10(H)

Ethernet

Ethernet Module Other Station
(Single Network) Ethernet –

CC IE Field Ethernet 
Adapter

Other Station
(Single Network) CC IE Field –

PC side I/F PLC side I/F Other Station Setting Network 
Communication Route

Co-existence Network 
Route
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11.5.3  Operation when communication error occurs during monitoring

● Operation of monitoring functions when a route switch occurs
When the target monitoring functions for route switch and other monitoring functions are mixed in an operation, the 
target monitoring functions for route switch continues operation and other monitoring functions stop operation.

● Situations when a route cannot be switched
A route switch which is triggered by a communication error cannot be performed when any of the following situations 
occurs at a monitoring start.
• An error occurs on the first communication to the connective system.
• One of the Redundant CPUs is powered OFF or reset.
• A tracking error occurs and a communication cannot be established between the redundant CPUs.

● Messages indicating a system switch request from network module and a tracking cable communication error 
detection
If a message indicating a system switch request from network module or a tracking cable communication error 
detection is displayed during monitoring, the system may have been switched.
Check the corresponding location by following the instruction described on the message, and remove the error factor of 
route switch.
In order to display the above message(s) when communicating via Ethernet, select the following item(s) in the 
redundant setting of the Ethernet parameter.
If the item is not selected, the message will not be displayed even when a route switch is performed.
• Issue system switch in Cable disconnection timeout
• Issue system switch in communication error
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11.6 Accessing Programmable Controller CPU via Ethernet Board

*1 : CC IE Field head module only

This section explains the setting method for accessing the programmable controller CPU via an 
Ethernet board of a personal computer.
The following shows a setting example when accessing the programmable controller CPU from GX 
Works2 via Q series-compatible E71 modules.
For the setting to access FXCPU, refer to the manual of the Ethernet module or the manual of the 
setting software.

Remote HeadQ CPU L CPU
*1

FX

CPU 2

CPU 1

Network number 1
(192.167.0.2)

Station number 2

Q series-compatible E71 module (192.167.0.1)

Station number 1

Network number 2

Q series-compatible E71 module (192.168.0.3)

Station number 3

Q series-compatible E71 module (192.168.0.2)

Station number 2



11 - 32

GX Works2

11  SETTING PROGRAMMABLE CONTROLLER CPU CONNECTION DESTINATION

Operation
• Set the connection destination setting.

● Communication when multiple GX Works2 are connected
Perform communication using TCP/IP or UDP/IP. (Section 6.3.1)

● Multiple network systems
For a multiple network system, routing parameters must be set.
Q Corresponding Ethernet Interface Module User's Manual (Application)

Item Description

PC side I/F Set the network number, station number*1, and protocol.

PLC side I/F

Set the model, station number, IP address and other items for the module to be connected to 
the personal computer.
For "Station No. ⇔ IP Information", set the method corresponding to the setting for "Station 
No. ⇔ IP Information" of Ethernet parameter.

Network Communication 
Route Set the network number and station number of the access target station.

*1 : Set the station number avoiding the same station number already assigned to the existing system or another 
Ethernet module.
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11.7 Accessing Programmable Controller CPU via G4 Module

*1 : CC IE Field head module only

This section explains the setting method for accessing the programmable controller CPU via a G4 
module.
For details of AJ65BT-R2N, refer to the following manual.
CC-Link System RS-232 Interface Module User's Manual (MELSOFT Connection Mode)

The following shows a setting example when accessing the programmable controller CPU via 
AJ65BT-G4-S3 module from GX Works2.
Data link must be correctly established by setting the switch settings and parameters for the AJ65BT-
G4-S3 module and the CC-Link master module.

Operation
• Set the connection destination setting.

Remote HeadQ CPU L CPU
*1

FX

AJ65BT-G4-S3

Station number 1

QJ61BT11N

Station number 0

Item Description

PC side I/F Set the COM port and transmission speed.

PLC side I/F Set the model of the G4 module to be connected.

Other Station Setting Set "Other Station (Single Network)".

Network Communication 
Route Set the station number of the access target station.
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11.8.1  Connection on a 1:1 basis

11.8 Setting for Access via Serial Communication Module

*1 : CC IE Field head module only

This section explains the setting method for accessing the programmable controller CPU on host 
station or on another station via a C24 module.

11.8.1 Connection on a 1:1 basis

The following shows a setting example when accessing a programmable controller CPU by connecting 
a personal computer and a Q series C24 module.

Operation
• Set the connection destination setting.

The following shows a setting example on a screen when accessing a programmable controller 
CPU from GX Works2 via a C24 module.
The image below is an example for Q series C24 module.

Remote HeadQ CPU L CPU
*1

FX

Q series C24 module
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11.8.2 Connection on a 1:n basis

Access the programmable controller CPU in another station from GX Works2 in a system composed of 
multiple programmable controller CPU stations.

■ Access via a serial communication module

The following shows a setting example when accessing the programmable controller CPU in another 
station via Q series C24 modules.

Operation
• Set the connection destination setting.

The following shows a setting example of a screen for accessing C24 modules from GX Works2.
The image below is an example for Q series C24 module.

Item Description

PC side I/F Set the COM port and transmission speed.

PLC side I/F*1

*1 : If a number other than '0' is set in the station number setting of the C24 module, set the same 
number for its station number.
The station number setting can be set in "Switch 5" (station number setting) in the switch setting of 
the PLC parameter.

Set the model and station number of the C24 module to be 
connected.

Other Station Setting Set "No Specification".

Station number 0 Station number 1
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11.8.2  Connection on a 1:n basis

Item Description

PC side I/F Set the COM port and transmission speed.

PLC side I/F Set the model and station number of the C24 module to be connected.

Other Station Setting Set "Other Station (Single Network)".

Network Communication Route Specify the start I/O number of the C24 module connected to GX Works2 and the 
station number of access target.
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■ Direct connection of a programmable controller CPU

The following shows a setting example when accessing the programmable controller CPU in another 
station via Q series C24 modules by directly connecting the personal computer to the programmable 
controller CPU.

Operation
• Set the connection destination setting.

The following shows a setting example of a screen for accessing a programmable controller 
CPU from GX Works2 via C24 modules.
The image below is an example for Q series C24 module.

Station number 0 Station number 1

Item Description

PC side I/F Set the interface of the personal computer. (Section 11.1.1)

PLC side I/F Select the series of the programmable controller CPU to be connected.

Other Station Setting Set "Other Station (Single Network)".

Network Communication Route Specify the start I/O number of the C24 module connected to GX Works2 and the 
station number of access target.
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11.9 Setting for Access via GOT (GOT Transparent Function)

This section explains how to access the programmable controller CPU from GX Works2 via GOT 
using the GOT transparent function.

● Considerations on executing online operations from GX Works2
Do not execute online operations from GT Designer2 to GOT (such as downloading project data) when online 
operations are being executed from GX Works2 to the programmable controller CPU using the GOT transparent 
function.

● When GOT does not monitor normally
The GOT transparent function cannot be used in the following cases.
• When GOT does not monitor normally due to programmable controller CPU errors or communication errors between 

the programmable controller CPU and GOT
• During the period of time between turning ON or resetting the programmable controller CPU or GOT and the start of 

GOT monitoring

Check the following items if GOT does not monitor normally.

Item Description

Does the programmable controller CPU 
operates normally? Refer to the user's manual of the programmable controller CPU used.

Is the programmable controller CPU 
connected to GOT normally?

Refer to the user's manual of the GOT to be used.
• GOT1000 Series Connection Manual
• GOT-A900 Series User's Manual (Connection System Manual)
• GOT-F900 SERIES GRAPHIC OPERATION TERMINAL HARDWARE 

Manual [Connection]
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11.9.1 Accessing programmable controller CPU via GOT

Access the programmable controller CPU via GOT.

*1 : The following table shows the connection between the personal computer and GOT.
: Connectable

*2 : For cables connecting GOT with the programmable controller CPU, GOT settings, and considerations, refer to the manual
of the GOT connected.
• GOT1000 Series Connection Manual
• GOT-A900 Series User's Manual (Connection System Manual)
• GOT-F900 SERIES GRAPHIC OPERATION TERMINAL HARDWARE Manual [Connection]

Connection
GOT

GOT1000 series GOT-A900 series GOT-F900 series

RS-232 connection   

USB connection  – –

Ethernet connection  – –

Q CPU L CPU FXFXRemote FXHead

Personal computer (GX Works2)

GOT Programmable controller CPU

*1 *2
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11.9.1  Accessing programmable controller CPU via GOT

■ Connecting personal computer and GOT with RS-232 or USB

The following shows the settings for connecting a personal computer and a GOT with RS-232 or USB.

Operation
1. Set "PC side I/F".

Section 11.1.1

2. For QCPU (Q mode), LCPU, FX3G, FX3GC, FX3U, or FX3UC, double-click "GOT" on "PLC 
side I/F".
The PLC side I/F Detailed Setting of GOT screen is displayed.

For CPUs other than FX3G, FX3GC, FX3U, or FX3UC, click "GOT" on "PLC side I/F". The screen 
will not be displayed in this situation.

3. For QCPU (Q mode), LCPU, FX3G, FX3GC, FX3U, or FX3UC, set the following setting on the 
PLC side I/F Detailed Setting of GOT screen.

4. Set "Other Station Setting" depending on a route to the connection destination.
Section 11.1.1

< FXCPU >< QCPU (Q mode)/LCPU >

Item Description

Detail setting for GOT and PLC 
connection Select "PLC Module/CC IE Field Ethernet Adapter"

Setup

Select "QCPU (Q mode)", "LCPU", or "FXCPU" for "PLC Mode".

Setting method Description

Bus connection Select "via GOT (Bus) transparent mode". (For QCPU (Q mode) 
only)

Direct 
connection Select "via GOT (direct connection) transparent mode".

Ethernet 
connection

Select "via GOT (Ethernet) transparent mode", and set the GOT 

(Ethernet) transparent setting from the  button.

GOT-F900
Select "via GOT-F900 transparent mode". Note that if the detailed 
setting for PC side I/F is USB, this item cannot be selected. 
(FXCPU only)
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■ Connecting personal computer and GOT with Ethernet

The following shows the settings for connecting a personal computer and a GOT with Ethernet.

Operation
1. Set "PC side I/F".

Section 11.1.1

2. Double-click "GOT" on "PLC side I/F".
The PLC side I/F Detailed Setting of GOT screen is displayed.

3. Set the following setting on the PLC side I/F Detailed Setting of GOT screen.

4. Set "Other Station Setting" depending on a route to the connection destination.
For FXCPU, only "No Specification" can be set.
Section 11.1.1

● Connecting modules via Ethernet adapter module (For QCPU (Q mode)/LCPU)
Modules can be connected via Ethernet adapter module using an Ethernet adapter module with the GOT (Ethernet) 
transparent function.
• Select "via GOT (Ethernet) transparent mode" in the detailed setting and select "NZ2GF-ETB" in the field next to the 

 button.

< Detailed setting screen when using the Ethernet

 connection between personal computer and GOT>

<GOT (Ethernet) Transparent Setting screen>

Item Description

Ethernet Detail setting for PC 
and GOT connection

Set settings such as an IP address and a host name when using the Ethernet 
connection between a personal computer and a GOT.

Detail setting for GOT and PLC 
connection Select "PLC Module/CC IE Field Ethernet Adapter"

Setup

Set the following setting according to the setting method between a GOT and a 
programmable controller CPU.
For details, refer to "■ Connecting personal computer and GOT with RS-232 or 
USB".
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11.9.2  Accessing programmable controller CPU via serial communication module

11.9.2 Accessing programmable controller CPU via serial 
communication module

The following explains the GX Works2 setting method for accessing the programmable controller CPU 
via a GOT and a serial communication module.

*1 : The following table shows the connection between the personal computer and GOT.
: Applicable

*2 : For details of cables connecting GOT with the serial communication module, GOT settings, and considerations, refer to the
manual of the GOT to be connected.
· GOT1000 series Connection Manual

Connection
GOT

GOT1000 series GOT-A900 series GOT-F900 series

RS-232 connection  – –

USB connection  – –

Ethernet connection  – –

Q CPU L CPU FXRemote FXHead FXFX

Personal computer (GX Works2)

QCPU

GOT

*1 *2

Serial communication module
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■ Connecting to QCPU (Q mode)/LCPU

The following shows the settings for accessing QCPU (Q mode)/LCPU.

Operation
1. Set "PC side I/F".

Section 11.1.1

2. Double-click "GOT" on "PLC side I/F".
The PLC side I/F Detailed Setting of GOT screen is displayed.

3. Set the following setting on the PLC side I/F Detailed Setting of GOT screen.

4. Set "Other Station Setting" depending on a route to the connection destination.
Section 11.1.1

<Detailed setting screen when using

the Ethernet connection

between personal computer and GOT>

Item Description

Ethernet Detail setting for PC 
and GOT connection

Set settings such as an IP address and a host name when using the Ethernet 
connection between a personal computer and a GOT.

Detail setting for GOT and PLC 
connection Select "C24".

Setup Select "QJ71C24", "QJ71CMO", or "LJ71C24" for "Module Name".
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11.10 Accessing Programmable Controller CPU via Phone Line

*1 : CC IE Field head module only

This section explains how to set functions to access a programmable controller CPU via phone line, 
and how to connect/disconnect the line.
Modems described in the system configuration below include an external type, built-in PC modem, PC 
card modem (PIMCIA), and TA (terminal adapter).

■ When accessing a serial communication module from a personal computer

*1 : Only modules with RS-232C interface can be used.

Select [Tool] ⇒ [Set TEL Data/Connect via Modem] ⇒ [Line Connection] to access the serial 
communication module from the personal computer.
For details of setting items on the Line Connection screen, refer to the following section.
Section 11.10.2 "■ Connecting a line automatically"

The setting of the modem function of serial communication module can be set with the parameter 
setting of intelligent function module.
For details of the modem function, refer to the following manual.
MELSEC-Q/L Serial Communication Module User's Manual (Application)

1) Switch settings of serial communication module

Remote HeadQ CPU L CPU FX
*1

Item Description

Transmission 
setting

Operation setting Independent

Data bit 8

Parity bit None

Even/odd parity Odd

Stop bit 1

Sum check code Exist

Online change Enable

Setting modifications Disable/Enable

Communication rate (transmission speed) setting According to modem specification

Communication protocol (mode setting) 5

Public line

Serial communication 
module *1

Modem

Modem

QCPU (Q mode)
/LCPU
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2) Initial settings for buffer memories
The initial settings are required for the following buffer memories.

■ When accessing an FXCPU from a personal computer

Access an FX1S, FX1N, FX1NC, FX2N, FX2NC, FX3G, FX3GC, FX3U, or FX3UC through a modem with a 
phone line, and remotely-operate the functions such as monitoring, testing, and writing/reading 
programs.

*1 : For the combinations of an FXCPU and a function expansion board (special adapter), refer to the Section 2.1.10.

Buffer memory address Name Setting

2EH (46) Modem connection channel 
specification

0: None
1: CH1
2: CH2

34H (52)*1
Data number for initialization 
specification

0H: Specified initialization data send in user 
registration frame area for transmission
From 7D0H: Data number for initialization

36H (54) MELSOFT connection 
specification

0: Not connected
1: Connected

*1 : The following initialization data are registered as a factory setting for serial communication module.
Q/L series C24: 7D0H (2000) to 7DDH (2013)
If a modem to be used is registered to the initialization data, specify the registration number.
When using an unregistered modem, a user can register initialization data to the following registration numbers.
· 9C4H (2500) to 9E1H (2529)
· 8001H (-32767) to 801FH (-32737)

FXCPU

Modem

Modem

Public line

*1
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1) Operation flow

*1 : Section 11.10.2
*2 : Section 11.10.1

● Power supply procedure
Power should be supplied to the modem first, then to the programmable controller CPU.
If the programmable controller CPU is turned ON before the modem, the initialization command which is sent to the 
modem at the power ON of programmable controller CPU is invalidated, and a communication error occurs when 
operating the system remotely.
Furthermore, if only the modem is turned OFF after the power supply, the initialization command is cleared and the 
same communication error occurs.

Start

Open the sequence program to be written 

to the programmable controller CPU which 

is accessed remotely.

Set the PLC parameter settings and the 

type of the modem to be connected to the 

programmable controller CPU.

Write the set parameters and the program 

to the FXCPU.

Turn OFF the power of the programmable 

controller CPU.

Connect the programmable controller CPU 

and the modem, and connect the modem 

and the phone line.

Turn ON the power of the programmable 

controller CPU.

(A modem initialization command is 

automatically sent.)

The programmable controller CPU (modem) 

becomes in a standby status as it waits for 

data transmission.

Operating procedure on programmable 

controller CPU side

Set the type of the modem to be connected 
to the personal computer.

Register the data to the telephone directory.

Set the modem on the personal computer 

side.

Connect the phone line.

Perform the operation such as monitoring 

in GX Works2.

Disconnect the phone line.

Start GX Works2.

End

*1

*2

*1

*1

*1

Start

Operating procedure on GX Works2 side
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2) Setting PLC parameters
Set the PLC parameters which are required to access an FXCPU through the phone line.

Operating procedure

• Set the items on the screen.

< <<PLC System (1) >> tab > < <<PLC System (2) >> tab >

Channel selection

Item Description

<<PLC System (1)>> -

MODEM Initialized Set the initialization command of the modem on the programmable controller side, 
which is used for the remote access of the programmable controller CPU.

User Register Mode

Select this when using a modem other than "AIWA (PV-AF288)" or "OMRON 
(ME3314B)".
The following are the communication specifications for this mode.
• Start bit: 1 bit
• Data length: 7 bits
• Parity: EVEN
• Stop bit: 1 bit

AIWA (PV-AF288) Select this when using "AIWA (PV-AF288)".

OMRON (ME3314B)*1 Select this when using "OMRON (ME3314B)".

PP Modem Mode (CH1) Select this when using a modem other than "AIWA (PV-AF288)" or "OMRON 
(ME3314B)", or when using a modem which cannot set the communication 
specification for the user registration mode.
For details, refer to Point in this section.
This item is supported by FX3G, FX3GC, FX3U, and FX3UC only.
The following are the communication specifications for this mode.
• Start bit: 1 bit
• Data length: 8 bits
• Parity: None
• Stop bit: 1 bit

PP Modem Mode (CH2)

<<PLC System (2)>> -

Channel selection
Specify the channel of programmable controller side to communicate with a 
personal computer.
This item is supported by FX3G, FX3GC, FX3U, and FX3UC only.

Operate Communication Setting Clear this item when setting the programmable controller CPU which is operated 
remotely.

*1 : When selecting OMRON (ME3314B) for FX2N, use the module with the version 2.01 or later (manufacturing number 
78**** or later).
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● Setting PP modem mode (CH1) and PP modem mode (CH2)
• <FX3U/FX3UC (FX3UC-32MT-LT, FX3UC-32MT-LT-2) series>

When using the first adapter of FX3U-232ADP which is connected to FX3U-232-BD or FX3U-CNV-BD, specify "PP 
Modem Mode (CH1)".
When using FX3U-232ADP which is connected to a board other than FX3U-CNV-BD, specify "PP Modem Mode 
(CH2)".

• <FX3UC (D, DS, DSS)/FX3GC series>
When using the first adapter of FX3U-232ADP which is connected to FX3UC (D, DS, DSS) or FX3GC series, specify 
"PP Modem Mode (CH1)".
When using the second adapter of FX3U-232ADP, specify "PP Modem Mode (CH2)".

• <FX3G series (14-/24-point type)>
When using FX3G-232-BD, or when using the first adapter of FX3U-232ADP which is connected to FX3G-CNV-ADP, 
specify "PP Modem Mode (CH1)".

• <FX3G series (40-/60-point type)>
When using FX3G-232-BD, or when using the first adapter of FX3U-232ADP which is connected to FX3G-CNV-ADP, 
specify "PP Modem Mode (CH1)".
When using FX3G-232-BD and FX3U-232ADP which is connected to FX3G-CNV-ADP, specify "PP Modem Mode 
(CH1)" for FX3U-232ADP, and specify "PP Modem Mode (CH2)" for FX3G-232-BD.

● Considerations for creating sequence programs
To perform a remote access, the special data register D8120 (communication format) of the programmable controller 
CPU needs to be "0".
D8120 can be cleared to 0 by clearing "Operate Communication Setting" on the <<PLC System (2)>> tab.
Note that if a value other than "0" is specified for D8120 in the sequence program, the remote access cannot be 
performed.
Create a sequence program without specifying a specific value for D8120.
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3) Setting AT commands
When "User Register Mode", "PP Modem Mode (CH1)", or "PP Modem Mode (CH2)" is selected 
for "MODEM Initialized" on the <<PLC System (1)>> tab, set AT commands according to the 
following operations.
• Register AT commands to programmable controller CPU

Send the following data register data to the modem as a modem initialization command following 
the "AT&F" (initialization to the factory setting) command when the programmable controller 
CPU is turned ON.
• D1000 to D1059 (For FX1N, FX1NC, FX2N, FX2NC, FX3G, FX3GC, FX3U, or FX3UC)
• D200 to D255 (For FX1S)
Write a user-registered modem initialization command to above data register in advance using 
the Modify Value function or a sequence program.

Example) When the initialization command is "ATE0S0=2Q1&D0&M4\Q0\J0&W"

A user-registered initialization command ends the transmission at the point when "0" is read.
As a precaution, create a sequence program in which the input area of initialization command for 
modem and the data register area used by the general sequence program do not overlap.

Register No. ASCII Hexadecimal Register No. ASCII Hexadecimal

D1000 A 41 D1013 & 26

D1001 T 54 D1014 M 4D

D1002 E 45 D1015 4 34

D1003 0 30 D1016 \ 5C

D1004 S 53 D1017 Q 51

D1005 0 30 D1018 0 30

D1006 = 3D D1019 \ 5C

D1007 2 32 D1020 J 4A

D1008 Q 51 D1021 0 30

D1009 1 31 D1022 & 26

D1010 & 26 D1023 W 57

D1011 D 44 D1024 CR 0D

D1012 0 30 D1025 LF 0A
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• Setting content of registered modem
The following table shows the setting items of AT command for the modem registered to the 
programmable controller CPU in advance.
The setting items differ according to the modem to be used. For details of the actual setting 
items, refer to the manual of the modem.

■ Modem specifications

Select a modem which satisfies the following specifications.
Communication data can be transferred from a built-in modem personal computer or a PC card modem 
(PCMCIA) used by connecting it to a personal computer.

1) When using a subscriber/in-plant phone line
• AT commands are supported. (Initialization command)
• DR terminal can be turned ON (High) independently.

(Example: A modem, whose CD terminal turns ON as the DR terminal turns ON, cannot be 
used.)

• Communication standard
• ITU-T V.90/V.34/V.32bis/V.32/V.22bis/V.22/V.21/V.FC
• Bell 212A/103

2) Manual line connection (when connecting a line through an operator)
• Addition to the above specification 1), "ANS mode" and "ORG mode" can be switched.

(The above mode switches are available on the specific AIWA modem.)

The communication may not be established with the above specification depending on a line 
condition.

● Performing communication using a PC internal modem or PC card (PCMCIA)
The COM port setting is required on the Transfer Setup screen to perform communication using a PC internal modem 
or PC card (PCMCIA). For the COM port number for the PC internal modem or PC card (PCMCIA), refer to the manual 
of the PC internal modem or PC card (PCMCIA).

● Performing communication via a modem
When performing communication from GX Works2 via a modem, the standard AT commands cannot be used for some 
specific modems. If a line cannot be connected by selecting standard AT commands, a user needs to specify the AT 
commands.
For details of specifying AT commands, refer to the following section.
Section 11.10.2 "■ Connecting a line automatically"

Setting item AIWA (PV-AF288)
ATE0S0=2Q1&D0&M5\Q0\JO&W

OMRON (ME3314B)
ATE0S0=2Q1&D0&H0&R1S15=8&W

Command echo setting E0 (None) E0 (None)

Number of automatic 
incoming calls S0=2 (Twice) S0=2 (Twice)

Result code display Q1 (None) Q1 (None)

DTR control &D0 (Always ON) &D0 (Always ON)

Communication mode &M5 (V.42bis) S15=8 (V.42bis)

Terminal flow control \Q0 (None) &R1 (None)

Transmission data flow 
control – &H0 (None)

Terminal speed fixed mode \JO (Fixed) –

Write to non-volatile memory &W &W
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■ Connection cables

Use an RS-232 cable included in a modem package, or a specified cable to connect a personal 
computer and a modem.
Since the connectors may differ depending on a personal computer, check the specification of the 
connector when purchasing a modem.

■ Restrictions on phone line

1) Do not use a line with the call-waiting feature enabled.
Data may be corrupted or the line is disconnected by the incoming call when the line is enabled 
with the call-waiting feature.

2) Do not use an extension phone.
The phone line may be disconnected when the receiver is picked up during the phone line 
connection.

3) An analog two-wire circuit can be used for the phone line.
For a digital line, the line can be connected by using a TA (terminal adapter).

● Phone line with a four-wire circuit
A phone line with a four-wire circuit may not be used depending on the modular connector type.
For a phone line with a four-wire circuit, perform a connection test in advance.

4) Modems for wireless communication using a cellular phone
Select a model according to the cellular phone to be used.
For details, contact the company of the cellular phone to be used.

5) Coexistence with other applications when performing modem communication
When performing modem communication, applications such as GX Works2 and MX Component 
cannot perform modem communication simultaneously.
When performing modem communication in GX Works2, set the other applications not to perform 
modem communication.
If modem communication is performed simultaneously with GX Works2 and other applications, a 
phenomenon such as a communication error and a line disconnection occurs.
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11.10.1  Setting TEL data

11.10.1 Setting TEL data

A personal computer can be connected with a programmable controller CPU using a phone line.
Use a serial communication module for QCPU (Q mode)/LCPU, and use a function expansion board 
(special adapter) for FXCPU, to perform communication using a phone line.

● Managing telephone directory and AT commands
The registered telephone directory and AT commands are managed under each user of Windows® operating system. 
The telephone directory and AT commands registered by another user cannot be used even when the same personal 
computer is used.
To use the telephone directory and AT commands registered by another user, use the import/export function.

■ Creating a telephone directory

Register phone numbers.

Screen display
Select [Tool] ⇒ [Set TEL Data/Connect via Modem] ⇒ [Phone Book].

Display contents

List of registered 

phone numbers

Item Description

List of registered phone numbers Display group names and user names of phone numbers.

Details Display the registered information of the data selected on the list of registered phone 
numbers.
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Operating procedure

1. Select a group for which the phone number to be registered on the list of registered 
phone numbers.

2. Click the  button.
The Phone Number Setting screen is displayed.

3. Set the items on the screen.

4. Click the  button.
The phone number is registered.

Screen button

●

Creates a new group.
The Group Setting screen is displayed by clicking the  button. Enter a group name. 
The maximum number of characters that can be set is 50.

●

Opens the screen to edit the registered data.
Select a registered data to be edited on the list of registered phone numbers.
The Phone Number Setting screen is displayed by clicking the  button. Edit the data.

Item Description

Group Name Display the group name to which the information is registered.

Destination Name Enter the name of the phone number to be set.
The maximum number of characters that can be set is 50.

Phone Number Enter the phone number.
The maximum number of characters that can be set is 50.

Outside Line Number Set the outside line number.
The maximum number of characters that can be set is 10.

For only Line Connection
When a password is set for Q/L series-compatible C24, this setting 
enables to process the password authorization automatically to 
connect the line.

Comments Enter notes on the registered information.
The maximum number of characters that can be set is 60.
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11.10.1  Setting TEL data

●

Copies a registered phone number to another group.
Select the registered data to be copied on the list of registered phone numbers.
The Group screen is displayed by clicking the  button.

Select the group to which data is copied, and click the  button.

●

Moves a registered phone number to another group.
Select the registered data to be moved on the list of registered phone numbers.
The Group screen is displayed by clicking the  button.

Select the group to which data is moved, and click the  button.

●

Deletes a registered group and phone number.
Data cannot be batch deleted in group unit.

●

Deletes all registered groups and phone numbers.

●

Searches for a registered phone number. The search condition is a partial match.
Target data is searched from all registered data.
When entering search conditions to both "Destination Name" and "Phone Number", the data which 
satisfies the both search conditions is searched.

●

Performs a selection processing of phone number setting when referring from the Line Connection 
screen.

●

Imports phone number data from the specified file and adds it to the directory.
Execute the file import after deleting all groups and phone numbers to replace the data with the 
imported phone number data.

●

Writes the data set on the Phone Book screen to the specified file.
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■ Registering AT commands

Register AT commands.

Screen display
Select [Tool] ⇒ [Set TEL Data/Connect via Modem] ⇒ [AT Command Registration].

Display contents

List of registered 

AT commands

Item Description

List of registered AT commands Display titles of AT commands.

Details Display the registered information of the data selected on the list of registered AT 
commands.
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Operating procedure

1. Select "MELSOFT Application Side Connection Modem" or "TEL Side Connection 
Modem" on the list of registered AT commands.

2. Click the  button.
The AT Command Registration screen is displayed.

3. Set the items on the screen.

4. Click the  button.
The AT command is registered.

Item Description

Group Name Display the group name of data to which AT command is registered.

Title Enter a title for the AT command to be registered.

AT Command
Set the command for modem initialization.
The maximum number of characters that can be entered is 70 in ASCII 
code.
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Screen button

●

Opens the screen to edit the registered data.
Select the registered data to be edited on the list of registered AT commands.

The AT Command Registration screen is displayed by clicking the  button.
Edit the data.

●

Copies a registered AT command to another group.
Select the registered data to be copied on the list of registered AT commands.
The Group screen is displayed by clicking the  button.

Select the group (to which data is copied), and click the  button.

●

Moves a registered AT command to another group.
Select the registered data to be moved on the list of registered AT commands.
The Group screen is displayed by clicking the  button.

Select the group (to which data is moved), and click the  button.

●

Deletes a registered AT command.

●

Deletes all registered AT commands.

●

Performs a selection processing of AT command when referring from the Line Connection screen.

●

Imports AT command from the specified file and adds it to the directory.
Execute the file import after deleting all AT commands to replace the commands with the imported 
commands.

●

Writes data set on the AT Command Registration screen to the specified file.
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11.10.2  Connecting/disconnecting line

11.10.2 Connecting/disconnecting line

Connect/disconnect a line.

■ Connecting a line automatically

Connect a personal computer to a programmable controller CPU (with the following method: automatic/
callback/manual) for remote access.

Screen display
Select [Tool] ⇒ [Set TEL Data/Connect via Modem] ⇒ [Line Connection].

Display contents

< FXCPU >< QCPU (Q mode)/LCPU >

Item Description

Connect

Display a line connection status.
The device which is being accessed is displayed flashing.
Devices will be displayed after the connection is established successfully.
When an error occurs during the connection attempt, the failed location is displayed with , and devices are 
displayed in gray.
Check the failed location with a displayed message regarding the cause of the failure.
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Operating procedure

1. Set the items on the screen.

2. Click the  button.
When the line was not connected, perform the modem initialization.

For the considerations for connecting a line using the callback function, refer to the following manual.
MELSEC-Q/L Serial Communication Module User's Manual (Application)

Screen button

●

Stops the line connection.

●

Displays the Options screen. (Section 11.10.3)

Item Description

Connection Method

Select a method: Automatic, Callback, or Manual (connecting a line through an operator).
The phone number is set when specifying a phone number of the callback target.
For a connection using the callback function, refer to "■ Connecting a line using the 
callback function".
For a manual connection, refer to "■ Connecting a line through an operator (manual 
connection)".

Line –

Line Type Select a line type: Tone, Pulse, or ISDN.

Outside Line Number Set the number as necessary when calling through the outside line.

Port Select the COM port number which is connected to the modem.

Connection Destination
Set the phone number of the target.
The previously-registered phone numbers in the telephone directory can be specified by 

clicking the  button.

AT Command –

Modem standard Use the AT command set on the modem.

AT Command Setting
When a difficulty of line connection arises using the standard AT command, create an AT 
command with reference to the manual of the modem and the content displayed by clicking 

the  button.

Record the logging data

Line connected time, line disconnected time, connection duration, destination, target phone 
number, callback, error status, or normal connection can be checked in log files.
The log file at the line connection is saved in the following log file.
<Save location>
• For Windows® 2000 and Windows® XP

User folder\Application Data\MITSUBISHI\MELSOFT\TEL\Log
• For Windows Vista® and Windows® 7

User folder\AppData\Roaming\MITSUBISHI\MELSOFT\TEL\Log
<Log file name>
year, month, day.dat (Example: 110615.dat)

User mode (8bits NP)

This item is supported by FX3G, FX3GC, FX3U, and FX3UC only.
Select this when "PP Modem Mode (CH1)" or "PP Modem Mode (CH2)" is selected in the 
PLC parameter.
Do not select this item when the setting other than "PP Modem Mode (CH1)" or "PP 
Modem Mode (CH2)" is selected.
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●

Performs a modem initialization when the modem did not respond at the line connection.
The following confirmation message is displayed by clicking the  button.

A modem initialization starts by clicking the  button. "AT&F" is set as a default command 
for the modem initialization.
The command for the modem initialization can be changed by "Modem Initialization AT Command" 
under [Tool] ⇒ [Set TEL Data/Connect via Modem] ⇒ [Options].
Change the initialization command according to the modem used.
When a failure occurs to the modem initialization, the Options screen is displayed.
Only the settings of items which may become a problem at the line connection can be changed. 
For details of the Options screen, refer to Section 11.10.3.

● Phone line connection
The phone line connection can also be performed on the Transfer Setup screen.

● When the line is disconnected by disturbance
If the line is disconnected by disturbance during the line connection, a confirmation message will be displayed to select 
whether to reconnect or disconnect the line.

● Connection duration
The connection duration is displayed on the status bar when the line is connected.

● When the connection destination is changed during the phone line connection
Even when the connection destination is changed to another COM port or a communication board (such as 
MELSECNET/10) on the Transfer Setup screen during the phone line connection, the communication can be 
performed using the communication routes while the phone line is being connected.

● When two or more error messages are displayed
Two or more communication error messages are displayed when the modem is turned OFF during the phone line 
connection. In this case, set a longer time check period for "Other Station Setting" on the Transfer Setup screen.

● Using a serial communication module to communicate through a phone line
The following table shows the items to be set on a programmable controller CPU and GX Works2 when performing 
communication using a serial communication module (for Q/L series) through a phone line.

Setting target Setting item Reference

Programmable controller 
CPU

• Switch setting
Set the following items in the sequence program.
• Write the initialization command (ATS0=1).
• Set the initialization request.

Section 11.10

GX Works2
• AT command registration
• Phone number registration

Section 11.10.1
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■ Connecting a line using the callback function

The callback function is a function which enables access from GX Works2 to QCPU (Q mode)/LCPU 
with the line re-connection (callback) operation performed on the Q/L series C24 module side, after the 
line connection operation is performed in GX Works2.
The callback function is not supported by FXCPU.

For 1 to 3, and 9, telephone usage is charged on a personal computer side.
For 4 to 8, telephone usage is charged on a Q/L series C24 module side.
For details, refer to the following manual.
MELSEC-Q/L Serial Communication Module User's Manual (Application)

1) Automatic
Select "Automatic" when the callback function is not set on a Q/L series C24 module.

2) Automatic (Callback Fixation)
Connect a line without using the callback function when the callback function is set on a Q/L series 
C24 module.
A connection operation can be performed on a personal computer whose phone number is 
registered to the buffer memory (2101H).

3) Automatic (Callback Number Specification)
Connect a line without using the callback function when the callback function is set on a Q/L series 
C24 module.
A connection operation can be performed on a specific personal computer.

4) Callback Connect (Fixation)
A callback operation is performed on a personal computer whose phone number is registered to 
the buffer memory (2101H) of a Q/L series C24 module.

5) Callback Connect (Number Specification)
A callback operation is performed on a specified personal computer.

6) Callback Request (Fixation)
Send a callback request from a specified personal computer, and perform a callback operation on 
a personal computer whose phone number is registered to the buffer memory (2101H) of a Q/L 
series C24 module. (A callback operation is not performed on the personal computer which is 
connected first.)

7) Callback Request (Number Specification)
Send a callback request from a specified personal computer, and perform a call back operation on 
a specified personal computer. (A callback operation is not performed on GX Works2 which is 
connected first.)

8) Callback Reception Waiting
When connecting a line with Callback Request (Fixation or Number Specification), select "Callback 
Reception Waiting" for the personal computer on which a callback is to be performed.

9) Manual
This setting is not for the callback function.
Select this item when connecting a line through an operator.
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A line connection with the GX Works2 connection method described in the following table can be 
performed when "Callback function specification" is set for the modem function of the intelligent 
function module parameter of a Q/L series C24 module.
The following table shows the setting items of "Callback function specification" of the modem function 
and corresponding setting items of GX Works2 connection method.

: Connectable

The following is an example of line connection with "Callback Request (Number Specification)".

Q/L series C24 side
callback function specification

Connection method on GX Works2 side

1) 2) 3) 4) 5) 6) 7) 8) 9)

Auto  

Setting 1: Auto/Callback Connection (at Fixation)    

Setting 2: Auto/Callback Connection (at Number Specified)       

Setting 3: Callback Connection (at Number Specified Max 10)    

Setting 4: Callback Connection (at Fixation)   

Setting 5: Callback Connection (at Number Specified)     

Setting 6: Callback Connection (at Number Specified Max 10)   

Connect from the personal computer with phone number     .

Connect to the personal computer with phone number     .

Phone number

Phone number

Modem

Modem

Public line

Set one of the following: Setting 2, 

Setting 3, Setting 5, or Setting 6, for 

the callback function specification.

Set "Callback Reception Waiting" 

on the  Line Connection screen.

Set "ATS0=1" for the modem 

initialization command.

Set "Callback Request 

(Number Specification)" on 

the Line Connection screen.

:

:
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■ Connecting a line through an operator (manual connection)

Connect to the in-plant phone line through an operator.
A manual line connection cannot be performed on modems without the ANS/ORG/TEL switch.
● System configuration

Operation
1. Select [Tool] ⇒ [Set TEL Data/Connect via Modem] ⇒ [Line Connection].

(Select "Manual" for the line connection method on the Line Connection screen. For details of 
operating procedure, refer to "■ Connecting a line automatically".)

2. Set the mode on Modem 1 on Phone 1 side to the ORG mode, and Modem 2 on Phone 3 
side to the ANS mode.

3. Call Phone 2 (operator) from Phone 1.

4. Phone 1 and Phone 3 are connected through Phone 2 (operator).

5. While Phone 1 and Phone 3 are connected, connect C24.

6. Turn ON the DATA switch on Modem 2 on Phone 3 side.

7. After the modem tone on Modem 1 on Phone 1 side is confirmed, turn the DATA switch 
ON.

8. When the modem tone on Modem 1 on Phone 1 side is faded, click the  
button in GX Works2.
When the line is connected normally, the message "Line connected" is displayed.

● Considerations
• If the connection cannot be established in step 6 and step 7, repeat the operations and adjust the 

timing.
• The ANS - ORG switch is required on the modem to connect a line manually.

Phone line

Modem 1

Modem 2

Phone 1

Phone 2

(Operator)

Phone 3
Programmable controller

C24
Peripheral device
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■ Disconnecting a line

Disconnect a phone line being connected.

Operating procedure

• Select [Tool] ⇒ [Set TEL Data/Connect via Modem] ⇒ [Line Disconnection].
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11.10.3 Setting options

Set options for a line connection.

Screen display
Select [Tool] ⇒ [Set TEL Data/Connect via Modem] ⇒ [Options].

Operating procedure

• Set the items on the screen.

Item Description

Line Connection CD Signal Wait Time
Extend the set period when the CD signal does not turn ON within the 
set period depending on the area (example: overseas) to be 
connected.

Line Connection Modem Report Wait 
Time Extend the set period when the response speed of the modem is slow.

Line Disconnection CD Signal Wait 
Time

Extend the set period when the CD signal does not turn OFF within the 
set period depending on the area (example: overseas) to be 
connected.

Line Disconnection Delay Time

Extend the set period when the response speed of the modem is slow.Data Transmission Delay Time

AT Command Response Wait Time

Password Cancellation Response Wait 
Time Extend the set period when the quality of line connection is poor.

AT Command/Password Cancellation 
Retry Times Increase the number of settings.

Line Callback Cancel Wait Time
Extend the set period when the line of the target (Q/L series C24) is not 
disconnected within the set period depending on the area (example: 
overseas) to be connected.

Callback Delay Time
Extend the set period when a specific period is required for the device 
which relays a connection (example: modem) between the line 
disconnection and the reconnection.

Modem Initialization AT Command
Set a command at the modem initialization.
The maximum number of characters that can be entered is 70 in ASCII 
code.

Communication Initialization Time-out 
period Set the timeout period at the communication initialization.
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11.11 Considerations of Communication with Programmable Controller CPU

This section explains the considerations of communication with the programmable controller CPU.
Refer to POINT and Restrictions described in each section as well as the descriptions in this section.

■ Considerations of communication via multiple network systems

When accessing QCPU (Q mode)/LCPU via multiple network systems, connected station*1 and relay 
stations*2 must all be QCPU (Q mode)/LCPU.

*1 : Station directly connected from GX Works2
*2 : Stations to be routed on network system

■ Considerations of communication with the programmable controller CPU 
using a USB cable

1) Connecting and disconnecting a USB cable, resetting the programmable controller CPU, 
and turning the power ON/OFF
A communication error may occur and operation may not be recovered if connecting and 
disconnecting a USB cable, resetting the programmable controller CPU, or turning the power ON/
OFF is performed frequently during communication with the programmable controller CPU.
Be sure to set GX Works2 to offline*1 as much as possible during these operations.
When operation is not recovered from an error, remove the USB cable. Then, connect it again after 
five or more seconds. (Even after this operation, an error may occur at initial communication. 
However, communication will be successful after that.)

*1 : The offline indicates the status other than indicated below.
• Write to PLC, Read from PLC, Monitor, and PLC diagnostics

The following screen appears on the personal computer using Windows® 2000 Professional 
Operating System.
If the screen appears, click the  button and remove a USB cable from the personal 
computer.

2) Combination of personal computers and USB cables
A communication error may occur depending on the combination of personal computers and USB 
cables.
If an error occurs, take appropriate actions according to the message displayed on the screen.

Remote HeadQ CPU L CPU FX
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■ Other considerations

1) High-speed communication using an RS-232 cable
Communication may fail depending on the performance of the personal computer when high-
speed communication is attempted by changing the transmission speed at the serial port of the 
personal computer (personal computer side interface). Communication speed may also slow down 
due to communication retries. Decrease the transmission speed if high-speed communication is 
not performed normally.

2) Resume function, suspend setting, power saving function, and standby mode of the 
personal computer
A communication error may occur during communication with the programmable controller CPU 
when the resume function, suspend function, power saving function, or standby mode is set to the 
personal computer. Disable these settings for communication with the programmable controller 
CPU.

3) Switching the connection to GX Works2 during communication through the serial 
communication function
When using Q00, Q01, Q00UJ, Q00U, Q01U, Q02U, or QnUD(H)CPU, the connection can be 
switched to GX Works2 during communication to a personal computer, indicator, etc. through the 
serial communication function.
If unable to connect to GX Works2, adjust the transmission speed to that specified on the <<Serial 
Communication>> tab of PLC parameter.

<PLC parameter setting screen> <PC side I/F Serial Setting screen>

Select the same transmission speed.
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12 - 1

12 WRITING/READING DATA
This chapter explains operations to write or read data to/from the programmable controller CPU or a 
memory card.

12.1 Writing or Reading Data to/from Programmable 
Controller CPU 12 - 2

12.2 Verifying Data on Programmable Controller CPU 
against Data on Personal Computer 12 - 24

12.3 Deleting Programmable Controller CPU Data 12 - 29

12.4 Copying Program Memory Data to ROM 12 - 30

12.5 Writing/Reading/Deleting PLC User Data 12 - 31

12.6 Transferring Data to Program Memory in Batch 12 - 33

12.7 Latch Data Backup 12 - 35

12.8 Backing up/Restoring Data 12 - 37

12.9 Online Program Change 12 - 40

12.10 Calculating Memory Size 12 - 61

12.11 Writing/Reading Data to/from Memory Cards 12 - 67

12.12 Reading Data of Local Devices 12 - 73
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12.1 Writing or Reading Data to/from Programmable Controller CPU

This function writes project data to the programmable controller CPU or a memory card, or reads data 
from the programmable controller CPU or a memory card to the project.
Data for intelligent function module also can be written/read. (Section 12.1.4)
For reading data from a programmable controller CPU without a project being opened, refer to '■ 
Creating new projects with data read from programmable controller CPU or intelligent function 
module (New project creation with data read from programmable controller CPU)'.

For FXCPU projects with labels, created project data can be read from FX3U/FX3UC version 3.00 or 
later only.

To boot QCPU (Q mode) using a standard ROM or Flash card, it is recommended to firstly write 
necessary data to the program memory using the Write to PLC function and then write the data to the 
standard ROM or Flash card using the Export to ROM Format function. (Section 12.4)

Screen display
Select [Online] ⇒ [Write to PLC] ( )/[Read from PLC] ( ).

The following explains the settings for writing data to a programmable controller CPU. Settings 
for reading data from a programmable controller CPU can be made in the same manner.
<Write to PLC screen for the projects without labels.>

Target module tab

File list

Memory capacity
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<Write to PLC screen for the projects with labels>
For QCPU (Q mode)/LCPU/FXCPU (FX3U/FX3UC version 3.00 or later), the symbolic information 
is displayed in the file list.

Operating procedure

1. Set the items on the screen.

Target module tab

File list

Memory capacity

Item Description

Connection Channel List Display the information of the connection destination setting.

Target module tab Switch the setting target module.
Characters on the tab are displayed in blue when data to be written/read exist.

PLC Module Set the settings to write data to the programmable controller CPU.

Intelligent Function 
Module*1

Set the settings to write intelligent function module data to the buffer memory or flash ROM of 
the intelligent function module.
Section 12.1.4

Title*1 Display the title of the target memory by clicking the  button.

Option*2 –

Display Size Select this to display the "Size" column in the file list and the memory capacity.

File list –

Target Select the data to be written/read.

Target Memory*1

Select the memory from the list ( ) by clicking the cell under "Target Memory".
For details of the memory card application, refer to the following manuals.
QCPU User's Manual (Hardware Design, Maintenance and Inspection)
MELSEC-L CPU Module User's Manual (Hardware Design, Maintenance and Inspection)

Memory capacity*3 –

Writing Size Display the total size of written data selected in "Target".

Free Volume Display the free space volume of the target memory.

Use Volume Display the used space volume of the target memory.

*1 : Not supported by FXCPU.
*2 : Displayed only when a project with labels is written to the programmable controller CPU.
*3 : For FXCPU, the program size and the symbolic information size are displayed when the project is written to the 

programmable controller CPU. Symbolic information size is displayed on the screen for projects with labels of FX3U/
FX3UC version 3.00 or later only.
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When a program (program file), device comment, device memory, or file register is selected, the 
range can be set by clicking the /  button.
When reading data from the programmable controller CPU, and the device memory is selected, 
the detailed settings are required.
For details, refer to the following sections.
Section 12.1.1 "Setting write/read range of program (program file)"
Section 12.1.2 "Setting write/read range of device data"
Section 12.1.3 "Setting range of device comment to be written/read"

2. Click the  button.
When the Write to PLC function is executed, the specified data are written to the target memory.
When the Read from PLC function is executed, the specified data are read from the target 
memory.

Screen button

●

Displays the illustration of the connection channel.

●

Selects the parameters and all the programs displayed in the list.

●

Selects all data displayed in the list.

●

Cancels the selection status of all data selected in the list.

● /
Switches display/hide of the Related functions button.
For details of the related functions, refer to the following sections.
• Remote Operation Section 17.1 "Remote Operation of Programmable Controller CPU"
• Set Clock Section 17.6 "Setting Clock on Programmable Controller CPU"
• PLC User Data Section 12.5 "Writing/Reading/Deleting PLC User Data"
• Write Title: Sets a title to the target memory.
• Format PLC Memory Section 17.3 "Formatting Programmable Controller CPU Memory"
• Clear PLC Memory Section 17.4 "Clearing Programmable Controller Memory"
• Arrange PLC Memory Section 17.5 "Arranging Programmable Controller Memory"

●  (Read from PLC and Delete PLC Data only)
Displays the project name of the symbolic information in the Title/Project Name column.
It is not displayed for projects without labels or by FXCPU.

●

Updates the file list on the Online Data Operation screen.
For QCPU (Q mode)/LCPU, the writing size, free volume, and used volume are also updated.
When multiple personal computers are connected to the programmable controller CPU, update the 
target memory before reading data from the programmable controller CPU.
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■ Unlocking a remote password

The confirmation message for unlocking the remote password is displayed when the programmable 
controller CPU for which the remote password is set is accessed via C24 modules or Q series-
compatible E71 modules. Unlock the password by following the message.
(Setting a remote password Section 6.4)

When the number of permissible incorrect remote password entries or the cumulative number of 
permissible incorrect password entries has been set and the number of incorrect entries exceeds the 
set number, the programmable controller CPU will be in the status as shown in the following table. For 
corrective action, refer to MELSEC-Q/L Serial Communication Module User's Manual (Application).

● Target memory
The following table shows the relations between the target memory on the Online Data Operation screen and the drive 
of the programmable controller CPU.

● Memory capacity
When a project is written to the programmable controller CPU, the target memory capacity may be displayed smaller 
than the actual file size.

● Writing multiple programs to programmable controller CPU
When more than one program is written to the programmable controller CPU, programs categorized as “No Execution 
Type” will never be executed on the programmable controller CPU.
For saving the memory capacity of the programmable controller CPU, it is recommended to remove them from the 
target data of the Write to PLC function.

● Reading device memory data from programmable controller CPU
Device memory data are read in the condition in which "Number of Columns" is set to "Auto" on the device memory 
editor.

● Saving the selection status of the files for the Write to PLC/Read from PLC function
The selection status of the files for the Write to PLC/Read from PLC function can be saved.
To save the file selection status, select [Tool] ⇒ [Options] ⇒ "PLC Read/Write" and set "Operational Setting".
However, the file selection status is canceled by any of the following operations.
• Changing the connection destination setting
• Changing the target memory
• Changing the PLC type
• Ending the project

Item Status

When the number of 
permissible entries is 
exceeded

The line is disconnected automatically.

When the cumulative number 
of permissible entries is 
exceeded

Turn ON the ERR. LED on the module.

PLC type Drive No. Target memory on the Online Data 
Operation screen PLC parameter

QCPU (Q mode)/LCPU 0 Program memory/Device memory Program memory (Drive 0)

QCPU (Q mode)
(except for High-speed 

Universal model QCPU)

1 Memory card (SRAM) Memory card (RAM) (Drive 1)

2

Memory card (Flash): Q2MEM-2MBF

Memory card (ROM) (Drive 2)Memory card (Flash): Q2MEM-4MBF

Memory card (ATA)

High-speed Universal model 
QCPU/LCPU Memory card (SD) Memory card (SD) (Drive 2)

QCPU (Q mode)/LCPU
3 Standard RAM Standard RAM (Drive 3)

4 Standard ROM Standard ROM (Drive 4)

<Option setting>
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12.1.1  Setting write/read range of program (program file)

12.1.1 Setting write/read range of program (program file)

Set the range of a program (program file) to be written/read when the program (program file) is selected 
on the Online Data Operation screen.

Screen display
Select the program (program file) and click the  button.

Operating procedure

• Set the items on the screen.

Screen button

●  (Read from PLC only)
Displays the remaining steps for Online program change.

Q CPU L CPU FXRemote FXHead FXFX

Item Description

Selected Program (Program File) Display the program name selected in the 'File list'.

Range Display write/read range of each program.

Allocate Memory for 'Online Change' (Write to 
PLC only) Enter the number of steps secured for Online program change.

Option –

Specify Same Step Count for Online 
Change to All Files
(Write to PLC only)

Select this to specify the equal number of secured steps for Online 
program change to all files.

Reading Left Capacity at the Same Time 
(Read from PLC only)

Select this to read the remaining secured steps for Online program 
change of the files written on the programmable controller CPU.

Merge Peripheral Statement/Note (Read 
from PLC only)

Select this to use an Peripheral statement/note.
If a program is read without selecting this item, the Peripheral statement/
note is lost.
GX Works2 Version 1 Operating Manual (Simple Project)
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12.1.2 Setting write/read range of device data

Set the type and range of device memory and the range of file register to be written/read when any or 
both of them are selected on the Online Data Operation screen.

■ Setting type and range of device memory to be written/read

Set the type and range of device memory to be written to/read from a programmable controller CPU.
The following tables show devices that can be written/read.

● QCPU (Q mode)/LCPU
: Applicable ×: Not applicable

● FXCPU
: Applicable ×: Not applicable

Screen display
Select the device data and click the /  button.
<QCPU (Q mode)/LCPU>

Q CPU L CPU FXFXRemote FXHead

Device Writing Reading

M, L, B, F, SB, V, S*1, T*2, ST*2, C*2, D, W, SW, FX, FY, FD, Z  

X, Y, SM, SD, intelligent function module device, link direct device × 

*1 : Not supported by Basic model QCPU.
*2 : Three types of data (contact, coil, and current value) can be written/read.

Device Writing Reading

M, S, T, C, D, R*1, ER*1  

X, Y, D (Special register), M (Special relay) × 

*1 : Supported by FX3G, FX3GC, FX3U, and FX3UC only.

Device range

list
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12.1.2  Setting write/read range of device data

Operating procedure

• Set the items on the screen.

Screen button

●

Changes the device range to the default.

Item Description

Device Data Name (Read from PLC only) Enter the data name for data created when the device memory data are 
read.

Device Selection –

Internal Device 
Memory

Select this to write/read device data.
For FXCPU, this setting is fixed as selected status.

Input Column Set the method for specifying the device range to be written/read.

Points + Start Select this to specify the range with the number of device points and the 
start device number.

Start + End Select this to specify the range with the start and end device numbers.

Device range list

Set the device to be written/read and the device range.
The default device range is a range set on the <<Device>> tab of PLC 
parameter. Devices to which 0 point is set cannot be set without selecting 
the check box.

Link Memory*1

(Read from PLC only)

Select this to read the link memory of the data link module or the network 
module to the link direct device.*2, *3

Setting range: Slots 1 to 4

Buffer Memory Head I/O No.*1
(last 1 digit is not required)
(Read from PLC only)

Select this to read the intelligent function module buffer memory to the 
intelligent function module device.*3
Setting range: 0 to 1FF

*1 : Not supported by FXCPU.
*2 : For the method to number the module to be set, refer to Point in Section 17.1.
*3 : For specifying devices, refer to MELSEC-Q/L Programming Manual (Common Instructions).
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■ Setting range of file register to be written/read

Set the range of file register to be written to/read from a programmable controller CPU.
For Q00JCPU/FXCPU, the range of file register to be written/read cannot be set.

Screen display
Select a file register and click the /  button.
<QCPU (Q mode)/LCPU>

Operating procedure

• Set the item on the screen.

Screen button
For the buttons on the screen, refer to ■ Setting type and range of device memory to be written/
read.

● Specifying file registers
• For QCPU (Q mode)/LCPU, "Whole Range" cannot be selected.
• For Universal model QCPU/LCPU, specify the range of file register assigned on the <<Device>> tab of PLC 

parameter when using extended data registers or extended link registers.

Item Description

Specified Range
Specify the range of file register to be written/read.
If multiple file registers are selected, each file register value is written/read in the same 
range.
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12.1.3  Setting range of device comment to be written/read

12.1.3 Setting range of device comment to be written/read

Set the device and range of global device comment/local device comment to be written or read when 
the global device comment/local device comment is selected on the Online Data Operation screen.
Set this setting to limit the writing range of device comments in cases such as when the programmable 
controller CPU has small free capacity. When the range of device comments is not set, all device 
comments are written/read.
For FXCPU, this function only supports global device comments being written to the programmable 
controller CPU.

Screen display
Select a global device comment/local device comment and click the  button.

Operating procedure

• Set the items on the screen.

Q CPU L CPU FXFXRemote FXHead

Item Description

Device Comment Name Display the selected device comment name.

Device Range –

Device Name Set the device name whose write/read range is to be specified.

Start Set the start device number.

End Set the end device number.

Bit Specification Information –

Bit specification information 
included*1

*1 : For Universal model QCPU/LCPU only

Select this to specify whether bit-specified word device comments are 
included as write target.

Comment Format (PLC Format) –

Number of characters per 1 
comment*2

*2 : Not supported by FXCPU.

Set the number of characters for a comment to be written to a 
programmable controller CPU.
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● When the setting of "Number of characters per 1 comment" is changed
When the number of characters set for "Number of characters per 1 comment" is less than the number of characters of 
device comment set for the project, the device comment with less number of characters is written to a programmable 
controller CPU. Therefore, mismatched data may be detected when verifying project data.

Restrictions

● Specifying bit-specified word device comments as write target
Device comments cannot be read in GX Developer.
When a device comment contains a bit-specified comment of LCPU is read in GX Works2 Version 1.62Q or earlier, the 
bit-specified comment is deleted.
When a device comment contains a bit-specified comment of Universal model QCPU is read in GX Works2 Version 
1.31H or earlier, the bit-specified comment is deleted.
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12.1.4  Writing/reading intelligent function module data

12.1.4 Writing/reading intelligent function module data

Write the intelligent function module data to a programmable controller CPU or intelligent function 
module buffer memory/flash ROM.
Intelligent function module data includes intelligent function module parameters to be written to a 
programmable controller CPU as a parameter file, and data whose values are written directly to 
intelligent function module buffer memory/flash ROM.
For details of data to be written as intelligent function module parameters and data to be written to 
intelligent function module buffer memory/flash ROM, refer to the following manuals.
GX Works2 Version 1 Operating Manual (Intelligent Function Module)
User’s Manual to be used

■ Writing/reading intelligent function module parameters to/from 
programmable controller CPU

Write intelligent function module parameters to a programmable controller CPU, and read the data from 
the programmable controller CPU to a project.

Screen display
Select [Online] ⇒ [Write to PLC] ( )/[Read from PLC] ( ) ⇒ <<PLC Module>>.
The settings for writing/reading data to/from a programmable controller CPU are explained 
together as they are similar operations.
<Write to PLC screen>

Operating procedure

1. Select "Intelligent Function Module (Initial Setting/Auto Refresh)" from the file list.
For the items on the screen, refer to Section 12.1.

Remote HeadQ CPU L CPU FXFX

File list

Memory capacity
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2. Click the  button.
In the Write to PLC operation, the intelligent function module parameters are written to the target 
memory.
In the Read from PLC operation, the intelligent function module parameters on the programmable 
controller CPU are read from the target memory.

■ Writing/reading data to/from intelligent function module buffer memory/
flash ROM

Write the set intelligent function module data to the buffer memory/flash ROM of the intelligent function 
module via a programmable controller CPU, and read the intelligent function module data to a project.
Use the operation for changing the data temporarily during debugging.
If a module does not have initial settings for intelligent function module parameters, this function can 
directly write data such as initial values to the intelligent function module buffer memory/flash ROM.

Screen display
Select [Online] ⇒ [Write to PLC] ( )/[Read from PLC] ( ) ⇒ <<Intelligent Function Module>>.
The following explains the settings for writing data to a programmable controller CPU.
Settings for reading data from a programmable controller CPU can be made in the same 
manner.
<Write to PLC screen>

The items in  may differ depending on the module.
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12.1.4  Writing/reading intelligent function module data

Operating procedure

1. Select "Valid" for write/read target module and "Target" for each item.
Set details such as a write/read range and write target by clicking the  button of each item.

2. Click the  button.
In the Write to PLC operation, the set data are written to the intelligent function module buffer 
memory/flash ROM, and in the Read from PLC operation, the data are read from the intelligent 
function module buffer memory/flash ROM.

Screen button
For the buttons on the screen, refer to Section 12.1.
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● Writing data to programmable controller CPU
When writing the intelligent function module parameters, match the configuration of the intelligent function module on 
the project with the configuration in the intelligent function module parameters stored on the programmable controller 
CPU.
Data cannot be written to the programmable controller CPU unless the start XY address and the module name for the 
write target match.

● Reading data from programmable controller CPU
• When the intelligent function module parameter does not exist on the programmable controller CPU, read the data 

from the programmable controller CPU after adding the intelligent function module according to the actual module 
configuration to the Navigation window.
For the method for adding the intelligent function module, refer to the following manual.
GX Works2 Version 1 Operating Manual (Intelligent Function Module)

• If the configuration of the intelligent function module on the project does not match with the mounted status, the 
intelligent function module on the project is overwritten with the actual module configuration. The following screen is 
displayed when the mounted status is different or a specific intelligent function module*1 is used. Double-click the cell 
indicated with "Select model name" under "Model Name" of intelligent function module parameter, select a module, 
and read data from the programmable controller CPU.

*1 : The specific intelligent modules are listed below.
Analog module: Q62DAN, Q64DAN, Q68DAVN, Q68DAIN, Q62DA, Q64DA, Q68DAV, Q68DAI
Temperature control module: Q64TCTT, Q64TCTTBW, Q64TCRT, Q64TCRTBW, Q64TCTTN, Q64TCTTBWN, Q64TCRTN, 
Q64TCRTBWN
QD75 positioning module: QD75P1/P2/P4, QD75P1N/P2N/P4N, QD75D1/D2/D4, QD75D1N/D2N/D4N
Serial communication/modem interface module: QJ71C24N, QJ71C24N-R2, QJ71C24N-R4, QJ71C24, QJ71C24-R2
For QD75 positioning modules and serial communication/modem interface modules, the screen to select a module is displayed when 
the auto refresh is set.

● Writing data when the QD75 ready signal (X0) is ON (positioning data only)
Data cannot be written when the QD75 ready signal (X0) of the target intelligent function module is ON.
When the QD75 ready signal (X0) is OFF, the availability of operation differs according to the option setting*1.

: Applicable ×: Not applicable

*1 : Select [Tool] ⇒ [Options] ⇒ "Intelligent Function Module" ⇒ "QD75/LD75 Type Positioning".

● Displaying the confirmation message when writing data to a flash ROM (positioning data only)
The confirmation message can be displayed when data are written to a flash ROM by the following setting.
Select [Tool] ⇒ [Options] ⇒ "Intelligent Function Module" ⇒ "QD75/LD75 Type Positioning" and select "Display a 
confirmation message when writing to flash ROM".

Select a module.

-
"Confirm PC operation status when writing a data"

Selected Cleared

Programmable controller 
CPU operating status

STOP  

Other than STOP × 
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12.1.5  Symbolic information

12.1.5 Symbolic information

*1 : FX3U/FX3UC (version 3.00 or later) only

Symbolic information is data that store the program configuration such as structures and labels.
To restore these data included in the symbolic information when reading a program from the 
programmable controller CPU, write/read the symbolic information to/from the programmable controller 
CPU.
Data such as structures and labels included in the symbolic information cannot be restored if only 
sequence programs are read. (In case of a Structured project, the programming language is treated as 
Ladder Diagram.)
The following table shows the program data included in the symbolic information.

Project type Data included in symbolic information

Simple project

Structures

Global labels

Local labels

Programs

Function blocks

Structured project

User libraries

Structures

Global labels

Program Setting

Tasks

POU

Local labels

Programs

Function blocks

Functions

Q CPU L CPU FXFXRemote FXHead

*1
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● Write target of symbolic information
Symbolic information can also be written to drives other than the program memory (drive 0).
For details of writable drives, refer to the following manual.
User’s Manual (Function Explanation, Program Fundamentals) of the CPU module to be used

● Compile status when the symbolic information is read
• When the symbolic information and parameters are read simultaneously, and the data in the symbolic information 

match with parameters and programs (program files) on the programmable controller CPU, the read data are in 
compiled status.

• When only the symbolic information is read, the read data are in uncompiled status.
• When the symbolic information of GX Developer or GX IEC Developer is read, the read data are in uncompiled 

status. Compile the program again after executing the Read from PLC function.
● Considerations for reading symbolic information

For the considerations for reading label programs (symbolic information) of the existing application using GX Works2, 
or reading label programs (symbolic information) of GX Works2 using the existing application, refer to the following 
section. (Appendix 6.2 "Data compatibility")

● FXCPU
When a memory cassette to which the symbolic information has been written is used on an FXCPU other than FX3U/
FX3UC version 3.00 or later, the memory cassette can be used, however, the symbolic information cannot be read from 
the memory cassette.
When the symbolic information is written to a memory cassette on an FXCPU other than FX3U/FX3UC version 3.00 or 
later, the symbolic information may be corrupted.

● Automatic project save after writing to programmable controller CPU
By setting the option, the project can be saved automatically after writing to the programmable controller CPU.
Select [Tool] ⇒ [Options] ⇒ "Project" ⇒ "Automatic Save" and select "Save project after writing to PLC".
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■ High speed mode and Compatible mode

'High speed mode' and 'Compatible mode' are added as modes to write symbolic information to a 
programmable controller CPU in GX Works2 Version 1.48A.
Use 'High speed mode' when using GX Works2 for the first time.
For FXCPU, only 'High speed mode' is supported.

'High speed mode' or 'Compatible mode' can be selected by "Setting for Writing Symbolic Information 
to PLC" under [Tool] ⇒ [Options] ⇒ "Symbolic Information". 'High speed mode' is set as a default 
setting.

● High speed mode
• Higher speed of writing/reading symbolic information compare to 'Compatible mode'.
• Smaller symbolic information data size increases a free space on a programmable controller CPU.
• The number of files for the symbolic information is counted as two files. Check the number of files 

that can be stored on a programmable controller CPU.

<Considerations>
• Symbolic information written to a programmable controller CPU with 'High speed mode' cannot be 

read in GX Works2 Version 1.43V or earlier.

● Compatible mode
• Symbolic information which does not support 'High speed mode', and it is the same as the one in 

GX Works2 Version 1.43V or earlier.
• Larger symbolic information data size decreases a free space on a programmable controller CPU.

● 'High speed mode' and 'Compatible mode'
'High speed mode' and 'Compatible mode' can be changed any time.
Symbolic information on a programmable controller CPU is always the one written most recently. Thus, the 
management of symbolic information is not complicated.

● Symbolic information on programmable controller CPU
Symbolic information written to a programmable controller CPU with 'High speed mode' cannot be displayed on the 
screen for Read from PLC in GX Works2 Version 1.43V or earlier.

● Write to PLC function when symbolic information is set on the <<Boot File>> tab of PLC parameter.
When symbolic information is set on the <<Boot File>> tab of PLC parameter, performing the Write to PLC function with 
changing the mode between 'High speed mode' and 'Compatible mode' may cause an improper boot operation.
When the mode is changed, write symbolic information to a programmable controller CPU after performing the 
following operation.

• Check if symbolic information is set on the <<Boot File>> tab of PLC parameter, click the  button and 
update the boot file setting.

• Select symbolic information and parameters on the screen for Write to PLC and write symbolic information to a 
programmable controller CPU. Confirm the target memory of symbolic information is the same as that of the transfer 
destination set on the <<Boot File>> tab of PLC parameter.
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12.1.6 Specifying target to write device comments to 
programmable controller CPU

Specify a target memory to write device comments to a programmable controller CPU.
In order to store device comments to the storage destination which is different from the target memory 
of the current programmable controller data, select "Set save destination of device comment to the 
target memory of PLC data" under [Tool] ⇒ [Options] ⇒ "Save Destination of Device Comment", and 
set a target for "Save Destination of Device Comment" in advance.

Screen display
Select device comments (global device comments, local device comments) on the Online Data 
Operation screen.

Operating procedure

1. The following message is displayed.

2. Click the  button.
The target set for "Target Memory" is changed to the target specified for "Save Destination of 
Device Comment" in the option setting.

Q CPU L CPU FXRemote FXHead FXFX
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12.1.7 Considerations for writing/reading data to/from 
programmable controller CPU

The following explains the considerations for writing/reading data to/from the programmable controller 
CPU.

1) Writing or reading programs with a Peripheral statement/note to or from the programmable 
controller CPU
The information of the lines with Peripheral statement/note is written to the programmable 
controller CPU, but the content of the statement/note are not written to the programmable 
controller CPU.
If a program with the same name as that of the program set with a Peripheral statement/note is 
read from the programmable controller CPU, the former overwrites the latter (the one in GX 
Works2), so the Peripheral statements/notes of the latter is discarded. To keep the Peripheral 
statement/note in GX Works2 when reading data from the programmable controller CPU, merge 
the Peripheral statement/note.
(Merging statements/notes GX Works2 Version 1 Operating Manual (Simple Project))

2) An uncompiled program exists when writing data to the programmable controller CPU
If the following message is displayed when writing data to the programmable controller CPU, click 
the  button and stop writing data. Then, execute [Compile] ⇒ [Build] again on the 
uncompiled program.

3) Writing programs to programmable controller CPU after compiling all programs
Compiling all programs changes the device assignment to labels. Therefore, device values set 
before the program change remain on the device-assigned labels.
By setting the following option, device values in the range set with the "Device/Label Automatic-
Assign Setting" function can be automatically cleared to 0 after writing programs to the 
programmable controller CPU.
• [Tool] ⇒ [Options] ⇒ "When writing to PLC after a Rebuild All operation, clear the device ranges 

set in the Device/Label Auto-Assign setting to 0."
Perform the following operations for a precautionary measure when the above option setting is not 
set.
• For QCPU (Q mode)/LCPU

After writing data to the programmable controller CPU, reset the programmable controller CPU, 
clear all device memories including latches, clear all file registers, and switch the programmable 
controller CPU to RUN.

• For FXCPU
After writing data to the programmable controller CPU, clear device memory using the PLC 
memory clear function, and switch the programmable controller CPU to RUN.

(Section 17.4)

Remote HeadQ CPU L CPU FX
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4) Editing programs after writing symbolic information to the programmable controller CPU
Edit programs in the same project type as the symbolic information if editing them after writing 
symbolic information to the programmable controller CPU.
In addition, be sure to write the latest symbolic information to the programmable controller CPU if 
writing only execution programs to it using such as Online program change.
If execution programs are read out and edited in GX Works2 projects without labels or GX 
Developer and rewritten to the programmable controller CPU, the programs being edited may be 
inconsistent with the execution programs on the programmable controller CPU when symbolic 
information is read out using GX Works2.
If inconsistency occurs by the operation mentioned above, check the mismatch parts using the 
Verify with PLC function and correct them.

5) Performing the Write to PLC function when symbolic information is not written to the 
programmable controller CPU
Program data are not displayed on the screen for Read from PLC in a project with labels.
When reading programs in a project with labels, select symbolic information.
When symbolic information is not written to the programmable controller CPU, create a new project 
without labels, and read the programs.
When reading programs in a project without labels, the read programs are displayed as a ladder 
program. However, as there are cases where programs cannot be displayed correctly as a ladder 
program, be sure to check the program after the symbolic information has been read from the 
programmable controller CPU.
The background color of the ladder block in which the program cannot be displayed correctly in a 
program is displayed in yellow.
The program can be edited by deleting the ladder block or adding new ladder block before or after 
it, even when the background color is displayed in yellow.
Be sure to write/read the symbolic information to/from the programmable controller CPU in order to 
restore the program to its original state.

6) Writing data after the device range in PLC parameter is changed
When the device range of PLC parameter has been changed, write the parameter to the 
programmable controller CPU.
Programs cannot be written to the programmable controller CPU unless the parameter is written to 
the programmable controller CPU.

7) When the date on the personal computer is February 29
When the date on the personal computer is February 29, the following message is displayed if the 
Write to PLC, Online program change, or Change TC setting function is performed on a Basic 
model QCPU function version A.
The file will be written with the date 'February 28' by clicking  button.

8) Basic model QCPU function version A
Basic model QCPU function version A does not support SFC programs, device initial values, and 
remote passwords.
For the Write to PLC function, these files cannot be written even though their names are displayed.
For the Read from PLC function, files of SFC programs and device initial values are not displayed 
in the file list. Files of remote passwords cannot be read out even though their file names are 
displayed.
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9) Writing data to a Redundant CPU in the backup mode
When a Redundant CPU is operating in the backup mode, the write to PLC function is performed 
on both systems (control system and standby system).
However, in any of the following states, the write to PLC function is performed on the connective 
system only.
• The target system power is OFF.
• The target system is reset.
• The tracking cable failed.

10) Writing data to a Redundant CPU in the separate mode/debug mode
When a Redundant CPU is operating in the separate mode or debug mode, the write to PLC 
function is only performed on the Redundant CPU which is specified for "Target System" on the 
Transfer Setup screen.

11) FXCPU
• For projects with labels, data can be read from a programmable controller CPU, and symbolic 

information can be read from/write to a programmable controller CPU in a project of FX3U/FX3UC 
version 3.00 or later only. Since these functions cannot be performed on the other FXCPU 
projects with labels, store the projects in a safe place.

• When a project in which a block password with the validated setting for "Read-protect the 
execution program" exists is written, the execution program cannot be read. Write the symbolic 
information to recover the program.

• When a program with an Peripheral statement/note is written to the programmable controller 
CPU, the Peripheral statement/note cannot be written to it. (The information of the lines with 
Peripheral statement/note also cannot be written to the programmable controller CPU.)

12) Writing data to FXCPU in batch
Set the programmable controller CPU to STOP status.

When it is in RUN status, the message shown below is displayed. Select the  button.

13) When the program memory of FXCPU is the EPROM cassette
Write programs with the ROM writer. For the EEPROM or flash memory cassette, turn the 
PROTECT switch OFF first and write programs.

14) Writing/reading ER device with FX3U/FX3UC
Writing/reading data cannot be executed with FX3U/FX3UC unless the memory cassette is installed 
to the programmable controller main unit.

15) Writing data to FX1S version earlier than 2.00
Data of project with labels cannot be written.
Use data of project without labels.
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16) Reading the symbolic information, which has been written to the programmable controller 
CPU using the Japanese version of GX Works2, using the English version of GX Works2
The symbolic information, which has been created and written to the programmable controller CPU 
using the Japanese version of GX Works2, cannot be read from the programmable controller CPU 
using the English version of GX Works2.
In this case, save again the project created with the Japanese version of GX Works2 using the 
English version of GX Works2, and write the symbolic information to the programmable controller 
CPU.
By following the operation described above, the symbolic information can be read from the 
programmable controller CPU using the English version of GX Works2.

17) Reading projects created in English version of GX Works2 from programmable controller 
CPU
When reading projects created in the English version of GX Works2 Version 1.31H or earlier from 
the programmable controller CPU, select "Japanese" for the language selection.

18) Reading data from SD memory card
The following are the considerations when reading data from the SD memory card.
• Program files/intelligent function module parameters created on the programmable controller 

CPU whose series is different from the connected programmable controller CPU cannot be read.
• Parameters/symbolic information on the programmable controller CPU whose type is different 

from the connected programmable controller CPU cannot be read.
Example) When the program file created on the LCPU is stored on the SD memory card

The program file created on the LCPU cannot be read from the SD memory card on 
the  High-speed Universal model QCPU.
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12.2 Verifying Data on Programmable Controller CPU against Data on Personal Computer

This section explains how to verify the open project against the data on the programmable controller 
CPU.
The verification function is used to compare the content of two projects or to locate program 
changes.
To verify data between two projects, use the Verify function. (Section 4.2.7)
The following data can be selected as verification targets for the Verify with PLC function.
• Programs
• Parameters
• Intelligent function module parameters (initial setting/auto refresh)*1

• Device comments
• Device memory data
• File registers
• QD75/LD75 positioning module*1

*1 : Not supported by FXCPU.

Screen display
Select [Online] ⇒ [Verify with PLC].
<CPU module>

Remote HeadQ CPU L CPU FX

File list

Memory capacity

Comment 

verify type
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<Intelligent function module>

Operating procedure

1. Select data to verify from the file list.

2. Click the  button.
The verification results are displayed on the Verify Result screen.
Section 4.2.7 "■ Checking verification result details"

File list

Item Description

Connection Channel List Display the information of the connection destination setting.

Target module tab Switch the setting target module.
Characters on the tab are displayed in blue when data to be verified exist.

PLC Module Set the settings to verify data with data on the programmable controller CPU.

Intelligent Function Module*1 Set the settings to verify data with data on the intelligent function module. 
Section 12.1.4

Title*1 Display the title of the target memory by clicking the  button.

File list –

Target Select the data to be verified.

Target Memory*1

Select the memory from the list ( ) by clicking the cell under "Target Memory".
For details of the memory card application, refer to the following manuals.
QCPU User's Manual (Hardware Design, Maintenance and Inspection)
MELSEC-L CPU Module User's Manual (Hardware Design, Maintenance 
and Inspection)

Comment Verify Type Set a basis either; data being edited or module data, when verifying device 
comments. ("■ Comment verify type")

Memory capacity*1 –

Writing Size Display the total size of written data selected in "Target".

Free Volume Display the free space volume of the target memory.

Use Volume Display the used space volume of the target memory.

*1 : Not supported by FXCPU.
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Screen button
For the buttons on the screen, refer to Section 12.1.

●  (Not supported by FXCPU)
Opens the screen to select the SFC block to be verified.

● Verification result when CC-Link configuration window is created
When the same profile is not registered to the verify destination and the verify source, the verification result may be a 
mismatch.
(Section 6.3.4)

● Project security status
Projects to which the security is set can be verified when both verify source data and verify destination data are not 
read-protected.

● Verifying intelligent function module parameters (initial setting/auto refresh)
Among modules without initial setting such as QD75/LD75 positioning modules, serial communication/modem interface 
modules, and AS-i master modules, only modules in which the auto refresh is set are the verification targets.

● Verifying QD75/LD75 positioning modules
One module each for verify source and verify destination can be selected.
The following data can be selected as verification targets.
• Parameter
• Servo parameter (For QD75M/MH only)
• Positioning data (Except for positioning comments and M code comments)
• Block start data

● Verifying device memory data for FXCPU
Special registers (M) and special data registers (D) cannot be selected as verification targets.
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■ Parameter verification

Verification levels can be selected for verifying parameters.
This function is not supported by FXCPU.

Screen display
Select the parameter and click the  button.

The following table shows the setting items for parameter verification.

● Mismatched point in system area
If a mismatched point is detected in the system area by the "All Areas" verification, either of the 
following messages is displayed.
Take corrective action according to the message.

Item Description

User Setting Area Only Verify only the parameter area set by the user.

All Areas Verify all area including the parameter area set by the system.

Message Corrective action

The header information of the 
parameter block is inconsistent.

A mismatch exists in area other than the user setting area.*1
Rewrite the parameters having been written to the programmable controller CPU.

This parameter block can't analyze.

Versions of GX Works2, GX Developer, or GX IEC Developer used to create the 
project differ between the programmable controller CPU and GX Works2.
The operation of the programmable controller CPU is not affected.
To match the "All Areas" verification, install the latest version of GX Works2, read the 
parameters from the programmable controller CPU, and write them again to the 
programmable controller CPU.

*1 : Data in areas other than the user setting area may be erroneous due to such as noise.
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■ Comment verify type

A basis of the range, either 'data being edited' or 'module data', can be set in the Verify with PLC 
function of device comment.
The comment verify type can be set when global device comments or local device comments of both 
'data being edited' and 'module data' are selected.

The following table shows the items of the comment verify type and their descriptions.

● Verification result differences of comment verification method
The following shows an example of the Verify with PLC function performed on the following device 
comments.

Item Description

Comment Verify Type –

GX Works2 Data
Verify data with the range of device comments in the project as a basis.
When this item is selected, detail setting of the selected device comments can 
be set by clicking the  button. (Section 12.1.3)

PLC Data Verify data with the range of device comments written to the programmable 
controller CPU as a basis.

Device Device comments in project Device comments on programmable controller CPU

M0 Global device comment 1 Global device comment 1

M1 Global device comment 2 Global device comment 2

M2 Device comment of M2 Global device comment 3

M3 Programmable controller CPU only

M4 Project only

M5

M6 Programmable controller CPU only

< When "GX Works2 Data" is selected for verification >

< When "PLC Data" is selected for verification >
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12.3 Deleting Programmable Controller CPU Data

This section explains how to delete data on the programmable controller CPU such as programs and 
parameters.

Screen display
Select [Online] ⇒ [Delete PLC Data].

Operating procedure

1. Select the data to delete from the file list.
For the items on the screen, refer to Section 12.1.

2. Click the  button.
The specified data are deleted.

Screen button
For the buttons on the screen, refer to Section 12.1.

● Deleting symbolic information
If the symbolic information is deleted, information such as labels cannot be restored.

● Deleting programs (program files) only
The content of the symbolic information are not updated, even if a program (program file) is deleted. When the symbolic 
information is read, the deleted program is restored.

Remote HeadQ CPU L CPU FXFX

File list

Memory capacity
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12.4 Copying Program Memory Data to ROM

This section explains how to copy the program memory data on the programmable controller CPU to 
a standard ROM on the programmable controller CPU or a Flash card in batch.
This function is used to boot up using a standard ROM or a Flash card, or save program memory data 
in a standard ROM or a Flash card without a battery backup.
Since the program memory of Universal model QCPU and LCPU is a flash ROM, program memory 
data can be saved without a battery backup for those CPUs.

Screen display
Select [Online] ⇒ [Export to ROM Format].

Operating procedure

1. Set the items on the screen.

2. Click the  button.
The message is displayed.

3. Click the  button.
The program memory data are exported in 
ROM format and the data are written to the memory set in "Target".

● Considerations for writing
All the write target data are deleted.

● Reading data written in ROM format
Use the Read from PLC function to read the data written in ROM format.

● Exporting device memory in ROM format
The device memory cannot be written using the Export to ROM format function.

Q CPU FXFXHeadRemoteL CPU

Item Description

Target Select the memory in which the program memory data are to be written.



12.5  Writing/Reading/Deleting PLC User Data

12 - 31

9

SE
TT

IN
G

 D
E

VI
C

E
 

C
O

M
M

EN
TS

10

S
EA

R
C

H
/R

EP
LA

C
E

11

SE
TT

IN
G 

PR
OG

RA
MM

AB
LE

 
CO

NT
RO

LL
ER

 C
PU

 
CO

NN
EC

TIO
N 

DE
ST

IN
AT

IO
N

12

W
R

IT
IN

G
/R

EA
D

IN
G

 
D

A
TA

13

PR
O

TE
C

TI
N

G
 

D
AT

A

14

M
O

N
IT

O
R

IN
G

15

S
IM

U
LA

TI
N

G
 

P
R

O
G

R
A

M
S

16

D
E

B
U

G
G

IN
G

 
P

R
O

G
R

A
M

S

12.5 Writing/Reading/Deleting PLC User Data

*1 : Not supported by Basic model QCPU, Q00UJ, Q00U, and Q01U.

This section explains how to write/read/delete PLC user data (CSV format file/binary format file) to/
from an ATA card/SD memory card/standard ROM.
PLC user data written to an ATA card/SD memory card/standard ROM can be used in sequence 
programs.
For the method for handling the PLC user data in sequence programs, refer to the following manual.
MELSEC-Q/L Programming Manual (Common Instructions)

● Formatting ATA cards
Format the ATA card to be used on the programmable controller CPU by selecting [Online] ⇒ [PLC Memory Operation] 
⇒ [Format PLC Memory] in GX Works2.
If a card is formatted using the function such as Windows® format functions, it may not be used on the programmable 
controller CPU.

● Project file attributes
The file attributes (read only, hidden file) set by the application such as Windows® Explorer are ignored.

● Memory capacity
When PLC user data are written to the programmable controller CPU, the target memory capacity may be displayed 
smaller than it really is.

● Folders in memory card
When reading/deleting PLC user data, data such as logging data contained in folders are not displayed in "PLC Side 
File".

● Writing data to an SD memory card
When PLC user data is written to an SD memory card, the characters of the file names become upper-case characters.

Screen display
Select [Online] ⇒ [PLC User Data] ⇒ [Write]/[Read]/[Delete].
The following explains the settings for writing PLC user data. The settings for reading/deleting 
PLC user data can be made in the same manner.
<Writing PLC User Data>

FXFXHeadRemoteL CPUQ CPU

*1
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Operating procedure

1. Use the  button to set the storage source for the PLC user data to be 
written.
When reading PLC user data, set the save destination for the PLC user data to be read.

2. Set the items on the screen.

3. Click the  button.
When writing PLC User Data, the selected PLC user data are written.
When reading PLC User Data, the selected PLC user data are read.
When deleting PLC User Data, the selected PLC user data are deleted.

Screen button
For the explanation of the buttons on the screen, refer to Section 12.1.

Item Description

Connection Channel List Display the information of the connection destination setting.

Target Memory

Select the memory to which the PLC user data are to be written.
For details of the memory card application, refer to the following manuals.
QCPU User's Manual (Hardware Design, Maintenance and Inspection)
MELSEC-L CPU Module User's Manual (Hardware Design, Maintenance 
and Inspection)

Title Display the title of the target memory by clicking the  
button.

Local File
(Write only)

Select the PLC user data to be written.
The maximum file size is 32MB per file.

PLC Side File
(Read/Delete only)

Select the PLC user data to be read.
Select the PLC user data to be deleted.
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12.6 Transferring Data to Program Memory in Batch

*1 : Universal model QCPU only

This section explains how to transfer the content of program cache memory to program memory in 
batch using Universal model QCPU/LCPU.
Use this function to transfer data at desired timing, for example, when option setting is made so that a 
program is not transferred to the program memory at Online program change.

Operating procedure

1. Select [Online] ⇒ [Program Memory Batch Download].
Either of the following screens is displayed according to the programmable controller CPU and its 
version.

<Universal model QCPU with a serial number whose first five digits are '10012' or higher, LCPU>

<Universal model QCPU with a serial number whose first five digits are '10011' or lower>

2. Click the  button.
The content in the program cache memory is transferred to program memory in batch.

FXFXHeadRemoteL CPUQ CPU

*1
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● Considerations of program memory batch transfer
The following functions cannot be executed during program memory batch transfer.
Execute these functions only after completing program memory batch transfer.
• Online program change (ladder program, Structured Ladder/FBD program, ST program, function block)*1

• Change TC Setting (when "Write changed program to PLC" is selected)*1

• Write to PLC function (when program memory is the target memory)*1

• Program memory batch transfer (this function)
• Set as default connection
• Change PLC Type function
• Check Parameter

*1 : For Universal model QCPU with a serial number whose first five digits are '12012' or higher, the following message is displayed and the 

process of the program memory batch transfer can be canceled. To cancel the transfer, click the  button.

● When the program cache memory and the program memory match
The batch transfer of the program memory data is not executed.
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12.7 Latch Data Backup

*1 : Universal model QCPU only

This section explains how to back up data such as device memory, file register, and error history to 
the standard ROM using Universal model QCPU/LCPU.
The backup content stored using this function is automatically restored to the program memory or 
other area when the programmable controller CPU is turned from OFF to ON or when it is reset.
This function allows the system to create backups of the data such as device data and error history 
data for those times when the system needs to be shut down for a prolonged time without use of 
battery.
For details of backup target data, refer to the User’s Manual (Function Explanation, Program 
Fundamentals) of the CPU module to be used.

12.7.1 Backing up latch data

Back up device memory/file register/error history data.

Operating procedure

1. Select [Online] ⇒ [Latch Data Backup] ⇒ [Backup].

2. Click the  button.
Device memory/file register/error history data are backed up.

● Devices
The latch data backup function is available for the following devices.
M, L, B, F, V, T, ST, C, D, W, Z, ZR, R
To back up ZR and R, select "Transfer to Standard ROM at Latch data backup operation" on the <<PLC File>> tab of 
PLC parameter.

FXFXHeadRemoteL CPUQ CPU

*1
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12.7.2  Deleting backup data

12.7.2 Deleting backup data

Delete the backup data on programmable controller CPU.

Operating procedure

1. Select [Online] ⇒ [Latch Data Backup] ⇒ [Delete Backup Data].

2. Click the  button.
Backup data are deleted.

● Considerations for deleting backup data
Backup data cannot be deleted when the programmable controller CPU is in RUN status.
To delete the backup data, set the programmable controller CPU to STOP status.
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12.8 Backing up/Restoring Data

This section explains how to back up data on the programmable controller CPU to a memory card, 
and restoring it to another programmable controller CPU using Universal model QCPU/LCPU.

12.8.1 Backing up data to memory card

Back up data on the programmable controller CPU to a memory card.

Screen display
Select [Online] ⇒ [PLC Module Change] ⇒ [Create Backup Data].
The following is an example of setting screen when QCPU (Q mode) is selected.

Operating procedure

1. Set the items on the screen.

Q CPU L CPU FXRemote FXHead
*1 *2

*2: Not supported by L02S.
*1: Universal model QCPU (except for Q00UJ, Q00U, Q01U) only

Item Description

Connection Channel List Display information of the connection channel being set.

Status Display the execution status of backup.

Setting
Select data to be backed up from "Backup Target Data".
"Default Backup Data" settings are fixed as selected status. They cannot be 
changed.
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12.8.1  Backing up data to memory card

2. Click the  button.
Data backup starts.
When data backup is completed normally, the image as shown below is displayed in "Status".

3. Remove the memory card.
Turn the programmable controller CPU from OFF to ON, or reset it.

Screen button

●

Refreshes and displays the execution status of backup when the power is turned OFF or reset.

●

Displays a total size of data selected in "Backup Target Data".

●

Opens the screen to set options for creating backup data.

● Deleting backup data
Backup data can be deleted by selecting [Online] ⇒ [Delete PLC Data]. However, backup data in a Flash card cannot 
be deleted.
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12.8.2 Restoring backup data

Restore the registration from backup data for the programmable controller CPU replacement.

Screen display
Select [Online] ⇒ [PLC Module Change] ⇒ [Restore].
The following is an example of setting screen when QCPU (Q mode) is selected.

Operating procedure

• Click the  button.
Data restoration starts.
When data restoration is completed normally, the image as shown below is displayed in "Status".
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12.9 Online Program Change

This section explains the operations for changing programs or data while the programmable 
controller CPU is in RUN (Online program change).
The Online program change operations include Online program change performed during conversion/
compilation and performed from the Write to PLC screen in units of files.
Be sure to fully understand the descriptions below and in Section 12.9.4 to Section 12.9.6 for 
operating with care.

 WARNING
● When data change, program change, or status control is performed from a personal computer to a running programmable 

controller, create an interlock circuit outside the programmable controller to ensure that the whole system always operates 
safely.
Furthermore, for the online operations performed from a personal computer to a programmable controller CPU, the 
corrective actions against a communication error due to such as a cable connection fault should be predetermined as a 
system.

 CAUTION
● The online operations performed from a personal computer to a running programmable controller CPU (Program change 

when a programmable controller CPU is RUN, operating status change such as RUN-STOP switching, and remote control 
operation) have to be executed after the manual has been carefully read and the safety has been ensured.
When changing a program while a programmable controller CPU is RUN, it may cause a program corruption in some 
operating conditions. Fully understand the precautions described in this section.
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12.9.1 Performing Online program change during conversion/
compile

Perform Online program change during conversion/compilation after program change.
Before changing a program, check that the program matches the one on the programmable controller 
CPU using the Verify with PLC function. Online program change cannot be performed if the programs 
do not match.

■ Projects without labels

Operating procedure

1. Verify a program against a program on the programmable controller CPU to ensure 
that they match.

2. Change or modify the program.

3. Select [Compile] ⇒ [Online Program Change] to perform Online program change.
The message is displayed.
Fully understand the message before performing Online program change.

4. Click the  button.

Q CPU L CPU FXFXRemote FXHead

RUN

Writes data to programmable 

controller CPU  in units of 

changed ladder blocks.

<When not writing/deleting SFC blocks>  <When writing/deleting SFC blocks>
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12.9.1  Performing Online program change during conversion/compile

● When target memory to write data is booting up
When updating the changes to the boot source while "Under booting, reflect changes to boot source during online 
program change" is selected under [Tool] ⇒ [Options] ⇒ "Online Change", and the target memory is booting up, click 

the  button on the message shown below.*1
*1 : For Universal model QCPU (except for Q00UJ/Q00U/Q01UCPU) and LCPU only
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■ Projects with labels

Operating procedure

1. Verify a program against a program on the programmable controller CPU to ensure 
that they match.

2. Change or modify the program.

3. Select [Compile] ⇒ [Online Program Change].
The Confirm Build Method for Online Program Change screen is displayed.

4. Select "Execute compile and online change after conversion" and click the 
 button.

The program is converted and compiled simultaneously, and Online program change is performed.
The following message is displayed.

<When not writing/deleting SFC blocks> <When writing/deleting SFC blocks>
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12.9.1  Performing Online program change during conversion/compile

5. Click the  button.
The following message is displayed.
Be sure to read and fully understand the message, and click the  button.

6. Set the items on the screen.

7. Click the  button.
Online program change is completed.

<When not writing/deleting SFC blocks> <When writing SFC blocks>

 <When deleting SFC blocks>

Item Description

Online Change

Write Symbolic Information to PLC*1
Select this to write the symbolic information to the programmable controller 
CPU.
Select "Target Memory".

Reflect Changes to Boot Source*2,*3 Select this to apply the change to the boot source while the target memory is 
booting.

*1 : For FXCPU, this item is supported by FX3U/FX3UC version 3.00 or later only.
*2 : Not supported by FXCPU.
*3 : This item can be selected when "Under booting, reflect changes to boot source during online program change" is 

selected under [Tool] ⇒ [Options] ⇒ "Online Change", and the target memory is booting up. (For Universal model 
QCPU (except for Q00UJ/Q00U/Q01UCPU) and LCPU only)
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■ Writing range for Online program change

Perform Online program change with the following writing range which depends on the editing mode.
When a new ladder block is inserted, the inserted program is written together with two steps (one 
before and the other after the program) to the programmable controller CPU.
Therefore, the Online program change may not be completed at a time depending on the number of 
program steps added and the two steps before and after the program. In this case, reduce the number 
of steps written at a time and perform Online program change in several times.
The following table shows the number of steps that can be written at once.

Example)

● Editing separate ladder blocks
For QCPU (Q mode), when the programmable controller CPU has "Online change area of multiple 
blocks" in its memory, multiple blocks can be written in units of blocks.
For High Performance model QCPU, "Online change area of multiple blocks" can be created using 
the memory format function. (Section 17.3)

CPU type Number of steps that 
can be written at once

QCPU, LCPU 512

FX3G, FX3GC, FX3U, FX3UC 256

FX0N, FXU, FX2C, FX1S, FX1N, FX1NC, FX2N, FX2NC 127

Newly inserted 

program

Range of the program 

written at Online 

program change 

(including previous 

and next steps)
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12.9.1  Performing Online program change during conversion/compile

● Editing Structured Ladder/FBD or ST programs
Structured Ladder/FBD or ST programs are compiled in program block unit.
Even with a partial program change, the whole program block becomes a write target of Online 
program change. For this reason, the number of steps that can be written is exceeded and an error 
may occur in Online program change.

When an error occurs, update the program with the Write to PLC function.
For QCPU (Q mode)/LCPU, Online program change can be performed in file unit.
(Section 12.9.2)

Example) Online program change target after compiling a program with a line change
As shown in the following figures, delete the line in the ladder block 1 and change the 
labels to M_TEST, and compile the program.
Since the temporary variable (1) used for the line in the ladder block 1 is released and 
reused as a temporary variable of the line in the ladder block 2, a change is also applied 
to the ladder block 2 to which any changes has not been applied by a user, and the 
ladder block 2 becomes the Online program change target.

Task

Program block

Program block

Program block

Online program 

change

Sequence program

Program block

Program block

Program block

Modified program

Compilation target

The number of steps 

that can be written is 

exceeded and an error 

may occur in the online 

program change function 

because the whole program 

block becomes a compilation 

target even with a partial 

program change.

Temporary variable (2)

Temporary variable (1)

Delete the line and change 

the labels to M_TEST.

Target of online 

program change

Temporary variable (1)



12.9  Online Program Change

12.9.1  Performing Online program change during conversion/compile 12 - 47

9

SE
TT

IN
G

 D
E

VI
C

E
 

C
O

M
M

EN
TS

10

S
EA

R
C

H
/R

EP
LA

C
E

11

SE
TT

IN
G 

PR
OG

RA
MM

AB
LE

 
CO

NT
RO

LL
ER

 C
PU

 
CO

NN
EC

TIO
N 

DE
ST

IN
AT

IO
N

12

W
R

IT
IN

G
/R

EA
D

IN
G

 
D

A
TA

13

PR
O

TE
C

TI
N

G
 

D
AT

A

14

M
O

N
IT

O
R

IN
G

15

S
IM

U
LA

TI
N

G
 

P
R

O
G

R
A

M
S

16

D
E

B
U

G
G

IN
G

 
P

R
O

G
R

A
M

S

● When performing Online program change to a programmable controller CPU for the first time, or an error 
occurs during Online program change
Make sure that the program before writing matches the program on the programmable controller CPU with the Verify 
with PLC function.

● When the program part to be written does not match
If the program part to be written does not match with the program on the programmable controller CPU, Online program 
change cannot be performed.
Perform Online program change in units of files. (Section 12.9.2)

● When Online program change of multiple blocks cannot be performed
The message is displayed in the following cases when Online program change is performed. Select whether to perform 
Online program change in units of files.
• There are no "Online change area of multiple blocks".
• The number of blocks exceeds the limit of Online program change of multiple blocks.
• The programmable controller CPU does not support the Online program change of multiple blocks.

● When performing Online program change to a programmable controller CPU in which the symbolic 
information has been written
Symbolic information, which contain the program configuration data such as structures and labels, are the data 
necessary only for restoring the data such as structures and labels after reading a program from the programmable 
controller CPU. (Section 12.1.1) Therefore, the write of symbolic information does not affect the operation of the 
programmable controller CPU, however, when performing Online program change to a programmable controller CPU 
in which the symbolic information has been written, be sure to write the execution program together with the symbolic 
information.
Note that since programs (program files) are written in batch along with source information, writing only source 
information is not applicable.
However, it may take a few or more minutes to write symbolic information, therefore, the following action is 
recommended.
When performing Online program change repeatedly, do not write symbolic information every Online program change 
but perform Online program change in units of files, and perform the Write to PLC operation to write symbolic 
information after all processes of Online program change are completed. (Section 12.9.2)

● Online program change after compiling all programs
All programs need to be compiled when the following operations are performed. Therefore the [Online Program 
Change] function cannot be performed.
Write programs to programmable controller CPU after compiling all programs. (Section 12.1, Section 12.9.2)
• Changing the following PLC parameters (QCPU (Q mode)/LCPU only)

• "Common Pointer No." and "Timer Limit Setting" on the <<PLC System>> tab
• "File Register" and "File for Local Device" on the <<PLC File>> tab
• Settings on the <<Device>> tab

• Changing the following option settings
• "Default Length of String Data Type" in "Label Setting Editor"
• Settings in "Compile"

• Changing automatically assigned devices
• Updating instructions and application functions when opening Structured project.
• Changing PLC type
• Changing project type
• Executing the Write to PLC function when a new project is not created, or a project is not opened

● Automatic project save after Online program change
By setting the option, the project can be saved automatically after Online program change. Select [Tool] ⇒ [Options] ⇒ 
"Project" ⇒ "Automatic Save" and select "Save project after online change".

● Editing separate ladder blocks with FXCPU
For FXCPU, ladder blocks between the edited ladder blocks are also written to the programmable controller CPU.

● Performing Online program change with FXCPU
• Symbolic information can be written to a programmable controller CPU with the Online program change function for 

projects of FX3U/FX3UC version 3.00 or later only.
• The Online program change function does not support SFC programs.
• When selecting [Compile] ⇒ [Online Program Change], Online program change may not be able to be performed if a 

restriction of the programmable controller CPU is applied to the compilation result. (Section 12.9.6)
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12.9.2 Performing Online program change in units of files

*1 : Not supported by Basic model QCPU.

Write programs or data in units of files while the programmable controller CPU is in RUN.

Operating procedure

• Select [Online] ⇒ [Write to PLC] 
for Online program change.
The message is displayed.
Fully understand the message before 
performing Online program change.
(Writing to programmable controller 
CPU Section 12.1)

FXFXHeadRemoteL CPUQ CPU

*1

Writes data to 

programmable 

controller CPU in 

units of files.

RUN
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● Data that can be written in units of files with Online program change
Data such as sequence programs and device comments can be written with Online program change.
The data that can be written with Online program change differs depending on the write target memory.
For details, refer to the following manual.
• User's Manual (Function Explanation, Program Fundamentals) of the CPU module to be used

● Online program change after compiling all programs
The Online program change cannot be performed after compiling all programs. When the Online program change 
function is executed after compiling all programs, the programmable controller CPU is remotely stopped and programs 
are written to the programmable controller CPU.
Compiling all programs changes the device assignment to labels. Therefore, device values set before the program 
change remain on the device-assigned labels.
By setting the following option, device values in the range set with the "Device/Label Automatic-Assign Setting" function 
can be automatically cleared to 0 after writing programs to the programmable controller CPU.
• [Tool] ⇒ [Options] ⇒ "When writing to PLC after a Rebuild All operation, clear the device ranges set in the Device/

Label Auto-Assign setting to 0."
For not configuring the above setting, as a precautionary measure, after writing programs to the programmable 
controller CPU, reset the programmable controller CPU, clear all device memories including latches, clear all file 
registers, then switch the programmable controller CPU to RUN. (Section 17.4)
For the considerations for compiling all programs, refer to the following manuals.
• GX Works2 Version 1 Operating Manual (Simple Project)/(Structured Project)

● Memory shortage of the programmable controller CPU
Increase the free space of the programmable controller CPU with the Memory arrangement function. 
(Section 17.5)
If the capacity is still insufficient after the operation, switch the programmable controller CPU to STOP and delete 
unnecessary programs in it. Then, write the programs using the Write to PLC function.
(Delete PLC Data Section 12.3, Write to PLC Section 12.1)

● When performing Online program change to a programmable controller CPU in which the symbolic 
information has been written
Symbolic information, which contains the program configuration data such as structures and labels, is data necessary 
for restoring the data such as structures and labels after reading a program from the programmable controller CPU. 
(Section 12.1.1)
Therefore, the symbolic information does not affect the operation of the programmable controller CPU, however, write 
the symbolic information when performing Online program change to a programmable controller CPU to which the 
symbolic information has been written.
However, note that since it may take a few minutes to write symbolic information, it is recommended not to write 
symbolic information every Online program change but to write symbolic information after all Online program changes 
are completed.

● When performing Online program change to Universal model QCPU
For Universal model QCPU, the following Online program change cannot be performed.
• Online program change performed on a program which does not exist on a programmable controller CPU.
• Online program change performed on a program which is not registered on the <<Program>> tab of PLC parameter.
• Online program change on an SFC program in unit of file.
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12.9.3 Online program change starting from pointer

*1 : Not supported by Basic model QCPU function version A.

Write data to one file with two or more GX Works2s while the programmable controller CPU is in RUN, 
using relative step numbers starting from a pointer.
A pointer for Online program change needs to be set in advance.

Example)

Screen display
Select [Tool] ⇒ [Options] ⇒ "Online Change".

Operating procedure

• Select "Execute online change based on relative step No.".
When Online program change is performed, data are written with relative step numbers starting 
from the pointer.

● Ladder blocks including a pointer
When performing Online program change based on relative step numbers starting from the pointer, do not add any line 
statements to a ladder block including the pointer.
If Online program change of a program with line statements is performed, program mismatching may occur. In this 
case, perform Read from PLC, and executes normal Online program change.

FXFXHeadRemoteL CPUQ CPU

*1

Online program 

change

Add a program

GX Works2 side CPU side

A program added with 

another GX Works2

Based on relative step numbers starting from the pointer P2, 

program mismatching does not occur even if there is 

misalignment of step numbers, and Online program change 

can be performed successfully.
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12.9.4 Considerations for Online program change of rise, fall, or 
SCJ instruction

The following explains the considerations for Online program change of programs containing the rise, 
fall, or SCJ instruction.

■ QCPU (Q Mode)/LCPU

● Fall instruction
The fall instruction may be executed even if the executing condition (ON→OFF) in the online-
changed ladder programs is not satisfied.
For the types and functions of the fall instructions, refer to the Programming Manual for each CPU.
<Fall instruction examples> PLF, LDF, ANDF, ORF, MEF, FCALLP, and EFCALLP

● Rise instruction
The rise instruction is not executed even if the executing condition (OFF→ON) in the online-changed 
ladder programs is satisfied.
The rise instruction is executed when the executing condition turns OFF→ON again.
For the types and functions of the rise instructions, refer to the programming manual of each CPU.
<Rise instruction examples> PLS, LDP, ANDP, ORP, and MEP

● SCJ instruction
When the executing condition for the SCJ instruction is ON after writing, the instruction jumps to the 
specified pointer without waiting for one scan.

Q CPU L CPU FXFXRemote FXHead

ON/OFF status of a contact
(conduction state at Online program change) Fall instruction

OFF→OFF Executed*1

*1 : For details of disabling the fall instruction execution, refer to the following section.
(■ Disabling the fall instruction in Online program change for QCPU (Q mode)/LCPU)

OFF→ON Not executed

ON→OFF Executed*1

ON→ON Not executed

ON/OFF status of a contact
(conduction state at Online program change) Rise instruction

OFF→OFF Not executed

OFF→ON Not executed

ON→OFF Not executed

ON→ON Not executed
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■ Disabling the fall instruction in Online program change for QCPU (Q mode)/
LCPU

The following explains methods for avoiding the fall instruction execution when the executing condition 
(ON→OFF) of the fall instruction for the online-changed program is not satisfied.

● Using the option setting (not supported by Basic model QCPU)
The fall instruction execution can be disabled by selecting [Tool] ⇒ [Options] ⇒ "Online Change" and 
setting "Execute fall instruction". However, the fall instruction is not executed even if the executing 
condition (ON→ OFF) is satisfied in the online-changed ladder programs. The fall instruction is 
executed when the execution condition turns ON→ OFF again.

For information on the QCPU versions that support this function, refer to the User's Manual (Function 
Explanation, Program Fundamentals) of the CPU module to be used.

Example) The following example shows the difference in the executing status depending on the 
option setting.

<Program example>

● Universal model QCPU/LCPU
In option setting for Universal model QCPU/LCPU, the item is not selected at default.

● Replacing the instruction with the EGF instruction
The fall instruction execution can be disabled with the EGF instruction, which converts the operation 
result into a pulse.
For details, refer to the following manual.
MELSEC-Q/L Programming Manual (Common Instructions)

M0

INC D0 is executed immediately 

after Online program change.

Online program 

change execution

Online program 

change execution

LDF M0 execution

1 scan

Contact 

input M0

Contact 

input M0

Falling pulse 

instruction 

output 

(LDF M0)

Falling pulse 

instruction 

output 

(LDF M0)
LDF M0 execution No LDF M0 execution LDF M0 execution

1 scan

INC D0 is not executed immediately

after Online program change.

[INC D0]

"Execute fall instruction" is not selected in the [Options]."Execute fall instruction" is selected in the [Options].
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■ FXCPU

● Fall instruction
When Online program change of ladder programs which include fall instructions (LDF/ANDF/ORF) is 
completed, the fall instructions are not executed regardless of the ON/OFF status of their target 
devices.
Fall instructions (PLF) are also not executed regardless of the ON/OFF status of their operating 
condition devices.
To execute a fall instruction, turn the status of its target device/operating condition device ON → OFF 
again.

● Rise instruction
When Online program change of ladder programs which include rise instructions is completed, the 
rise instructions are executed if their target devices/operating condition devices are ON.

• Target rise instructions: LDP, ANDP, ORP, and Pulse operation type application instructions (such 
as MOVP)

Performing Online program change of a ladder block including fall instructions (LDF/ANDF/ORF)

Target devices are ON Target devices are OFF

Contacts of the LDF/ANDF/ORF instructions in the ladder block remain OFF.

Performing Online program change of a ladder block including the PLF instruction

Operating condition is ON Operating condition is OFF

Target devices of the PLF instruction in the ladder block do not operate.*1

*1 : Operate if the operating condition changes ON → OFF before/after Online program change.

Performing Online program change of a ladder block including rise instructions (LDP/ANDP/ORP)

Target devices are ON Target devices are OFF

Contacts of the LDP/ANDP/ORP instructions in the ladder 
block turn ON for one scan.

Contacts of the LDP/ANDP/ORP instructions in the ladder 
block remain OFF.

Performing Online program change of a ladder block including pulse operation type
application instructions (such as MOVP)

Operating condition is ON Operating condition is OFF

The relevant pulse operation type application instruction in 
the ladder block operates for one scan.

The relevant pulse operation type application instruction in 
the ladder block does not operate.

Performing Online program change of a ladder block including the PLS instruction

Operating condition is ON Operating condition is OFF

Target devices of the PLS instruction in the ladder block do not operate.*1

*1 : Operate if the operating condition changes OFF → ON before/after Online program change.
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12.9.5  Considerations of Online program change of SFC programs

● Operation result falling pulse instruction
When Online program change of ladder programs which include operation result falling pulse 
instructions (MEF) is completed, the operation result falling pulse instructions are not executed 
regardless of the satisfied/not satisfied status of their executing condition.
To execute an operation result falling pulse instruction, turn the operation result up to it once ON, and 
then OFF.

● Operation result rising pulse instruction
When Online program change of ladder programs which include operation result rising pulse 
instructions (MEP) is completed, the operation result of the operation result rising pulse instruction is 
ON if the operation result up to it is ON.

12.9.5 Considerations of Online program change of SFC programs

The following explains the considerations of Online program change of SFC programs.
For LCPU/FXCPU, the Online program change function does not support SFC programs.

● Online program change for operation outputs/transition conditions
Online program change cannot be performed after changing programs of multiple operation outputs/
transition conditions.
After correcting the program, perform Online program change for each unit of operation output or 
transition condition.

● Online program change of SFC diagrams (For CPU modules which do not support Online 
program change of SFC blocks)
When a SFC diagram is edited, perform Online program change in unit of file by selecting [Online] ⇒ 
[Write to PLC] (Section 12.9.2).

● Online program change of SFC diagrams (For CPU modules which support Online program 
change of SFC blocks)
When a SFC diagram is edited, Online program change can be performed in unit of SFC block by 
selecting [Compile] ⇒ [Online Program Change].

Restrictions

● Online program change of SFC blocks
For details of CPU modules which support Online program change of SFC blocks, and restrictions regarding Online 
program change of SFC blocks, refer to the following manual.
MELSEC-Q/L/QnA Programming Manual (SFC)

Performing Online program change of a ladder block including the MEF instruction

Executing condition is satisfied Executing condition is not satisfied

The operation result of the MEF instruction is OFF.

Performing Online program change of a ladder block including the MEP instruction

Operation result up to the MEP instruction is ON Operation result up to the MEP instruction is OFF

The operation result of the MEP instruction is ON. The operation result of the MEP instruction is OFF.

Q CPU FXFXHeadRemoteL CPU
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12.9.6 Considerations of each programmable controller series

The following explains the considerations of Online program change for each programmable controller 
series.

■ QCPU (Q mode)/LCPU

Q CPU L CPU FXFXRemote FXHead

Item Description

Online program change to another 
station

Online program change to another station can be performed within the accessible range 
set in the connection destination setting.
Take extra caution when performing Online program change to another station.

During boot operation

Online program change on 
Redundant CPU

• When the online program change function is performed during a boot operation in the 
backup mode, the function is performed on the program memory and transfer source 
drive of both systems (connective system and target system).

• When the online program change function is performed during a boot operation in the 
separate/debug mode, the function is performed on the program memory and transfer 
source drive of connective system.

• When a memory card (ROM) or standard ROM is used, all files on the transfer source 
drive are deleted and changed to files on the program memory.
Set the setting on the <<Boot File>> tab of PLC parameter to transfer all files on the 
transfer source drive to the program memory.

Deleting a corresponding device 
from a program

When an instruction is deleted during the OUT instruction execution, or when the device 
number has been changed and the corresponding device cannot be found in the 
program, the output status is retained. Perform Online program change after ensuring 
that sequence programs containing unnecessary coil outputs are OFF.

Online program change while a low-
speed execution type program is 
executed

While a low-speed execution type program is executed, Online program change starts 
after the program execution. The program execution is suspended during Online program 
change.
However, if "PRG TIME OVER(5010)" keeps occurring while a low-speed execution type 
program is executed, Online program change cannot be performed.
In this case, set the programmable controller CPU to STOP, and increase the constant 
scan time and low-speed program execution time in PLC parameter, then execute Online 
program change again.
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Allocating memory for Online 
program change

• When the number of secured steps exceeds the currently set number during Online 
program change, the following message is displayed. In this case, set a new number of 
secured steps.

• If '0' is set for the number of secured steps on the following message screen, the area 
for the exceeding amount from the secured steps is reserved and a sequence program 
is written.

• The number of secured steps newly set on the following message screen is not 
displayed on the Program Detail Setting screen of the Write to PLC function.

• The message above is not displayed with Basic model QCPU function version A.
• When re-securing the secured steps for Online program change in the backup mode of 

Redundant CPU, the steps are secured on the basis of the smaller remaining program 
memory capacity of either control system or standby system.

Example) When the remaining capacity (step) of the control system is 100 steps 
and that of the standby system is 50 steps
The maximum number of re-secured steps for Online program change is 
50.

Error during Online program change

The following message may be displayed during Online program change. Take corrective 
action by following the message.

If the above error message is displayed, the program in GX Works2 changes back to the 
uncompiled status. However, the program on the programmable controller CPU may 
have been changed.
In this case, compile the GX Works2 program and verify it against the program on the 
programmable controller CPU to confirm that these programs match. If the programs do 
not match, write the program to the programmable controller CPU using the Write to PLC 
function to match them.

Online program change of a 
program for which a password is set

When Online program change is performed to a sequence program for which a password 
is set, the Disable Password screen is displayed. Unlock the password to perform Online 
program change.
Online program change is not possible if a password cannot be unlocked.

When system is configured with Redundant CPU

Backup mode

• Online program change is performed on both systems (connective system and target 
system).
However, if the target system fails (communication cannot be established with the 
target system), Online program change is not performed on both systems.

• Online program change cannot be performed in units of files to the program file which 
does not exist on the programmable controller CPU.
Perform Online program change in units of files after changing the operation mode of 
the programmable controller CPU to the separate mode or write data to the 
programmable controller CPU after switching the programmable controller CPU to 
STOP.

Separate mode/debug 
mode

Online program change is only performed on the programmable controller CPU specified 
for "Target System" on the Transfer Setup screen.

Item Description
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Online program change to Universal 
model QCPU

• Universal model QCPU has option setting of "Transfer program cache memory to 
program memory" that allows selection whether to transfer the data of program cache 
memory to program memory after Online program change.
(For option setting,Section 21.2)

• For Universal model QCPU, when a password is registered/changed while the 
programmable controller CPU is running, the program memory batch transfer is 
executed. (Section 12.6)

• While program memory is being transferred in Universal model QCPU after Online 
program change, the following functions cannot be executed.
• Online program change (ladder program, SFC program, Structured Ladder/FBD 

program, ST program, function block)*1

• Change TC Setting (when "Write changed program to PLC" is selected)*1

• Write to PLC (when the target memory is program memory)*1

• Program memory batch transfer
• Set as default connection
• Change PLC Type
• Check Parameter

*1 : For Universal model QCPU with a serial number whose first five digits are '12012' or higher, the process of the program 
memory batch transfer can be canceled. (Section 12.6)

Item Description
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■ FXCPU

Item Description

Programmable controller CPUs that support Online program change

Model name
FX2C/FXU series (Version No. V2.1 or later)

FX0N series (Version No.V1.10 or later) and 
FX1S/FX1N/FX2N/FX3G/FX3GC/FX3U/FX1NC/FX2NC/FX3UC series

Memory type

FX3U/FX3UC series Built-in RAM or optional FLASH cassette
(PROTECT switch OFF)

FX3G series Built-in EEPROM or optional EEPROM memory cassette
(PROTECT switch OFF)

FX3GC series Built-in EEPROM

FX2N series Built-in RAM, optional RAM cassette or optional EEPROM 
cassette (PROTECT switch OFF)

FX2NC series Built-in RAM or optional memory board
(PROTECT switch OFF)

FX1NC series Built-in EEPROM

FX1S/FX1N series Built-in EEPROM or optional memory cassette
(PROTECT switch OFF)

FXU/FX2C series Built-in RAM or optional RAM cassette

FX0N series Built-in EEPROM

When using FX0N, FX1S, FX1N, 
FXU, FX2N, FX1NC, FX2C or FX2NC

• A modified ladder program must not contain added/deleted/changed P and I labels.
• A target range for Online program change must not contain I labels

• If a ladder program before or after modification contains the C235 to C255 high-speed 
counter output instruction (OUT instruction) and the application instructions (MNET, 
ANRD, ANWR, RMST, RMWR, BLK, and MCDE), the ladder program cannot be 
changed.

• A new 1ms retentive timer must not be inserted.

• If the number of program steps decrease due to deletion of contacts, coils, application 
instructions, etc., the number of NOPs equivalent to the number of steps removed are 
added.

• For the application instruction (EXTR) for FX2N and FX2NC, do not perform Online 
program change during communication (while the instruction is being activated). 
Communication may stop if Online program change is performed during 
communication.
If the communication stops, switch the programmable controller CPU from STOP to 
RUN.

When using FX1S, FX1N, FX1NC, 
FX2N or FX2NC

Do not perform Online program change on a function block which contains pulse output 
instructions (PLSY, PLSR, PWM) or positioning instructions (ZRN, PLSV, DRVI, DRVA) 
after performing any of the following operations.
• Changing a program of a ladder block which contains instructions described above.
• Changing a program of a ladder block in front or back of a ladder block which contains 

instructions described above.
• Deleting a ladder block in front/back of a ladder block, or adding a ladder block to front/

back of a ladder block, which contains instructions described above.
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When using FX3G, FX3U, FX3GC or 
FX3UC

• A modified ladder program must not contain added/deleted/changed P and I labels.
• A target range for Online program change must not contain I labels.

• If a ladder program before or after modification contains the C235 to C255 high-speed 
counter output instruction (OUT instruction) and the application instructions (SORT2, 
TBL, RBFM, WBFM), the ladder program cannot be changed.

• A new 1ms retentive timer must not be inserted.

• If the number of program steps decrease due to deletion of contacts, coils, application 
instructions, etc., the number of NOPs equivalent to the number of steps removed are 
added.

• Do not perform Online program change for positioning instructions (DSZR, DVIT, ZRN, 
PLSV, DRVI, DRVA) while the pulse output instruction is being executed. The pulse 
output stops if the ladder program is online-changed during the pulse output instruction 
execution.
PLSV instruction [without acceleration or deceleration] stops immediately.
DSZR, DVIT, ZRN, PLSV [with acceleration and deceleration] DRVI and DRVA 
instructions stop after decreasing the speed.
When these instructions are stopped as a result of Online program change, deactivate 
the instructions (OFF) and activate them again (ON).

• For the IVMC, IVCK, IVDR, IVRD, IVWR, and IVBWR inverter communication 
instructions, do not perform Online program change during communication (while the 
instruction is being activated). Communication may stop if Online program change is 
performed during inverter communication.
If communication stops, switch the programmable controller CPU from STOP to RUN.

When using FXU (V3.07 or later) or 
FX2C*1

• A substitute instruction for a new instruction cannot be inserted or replaced in the 
program.

• Even a substitute instruction is already written in a program, the function is disabled 
due to Online program change.

• The operations of the CMP, ZCP, MOV, ADD, SUB, MUL, DIV, INC, and DEC 
instructions can be processed at a high speed when word devices specified by digit or 
index modification are not set to the data.
However, the high-speed processing function is disabled when Online program change 
or insertion is performed.

• The OFF execution time of the application instructions for FXU (V3.07 or later) and 
FX2C can be processed at a high speed.
However, the high-speed processing function is disabled when Online program change 
or insertion is performed. The processing time is approximately 60% of that for FXU 
(V2.30 or earlier).

When using FXU
(V2.1 to V2.30)

• The application instructions and element numbers added to FXU (V3.07 or later) are 
written to the programmable controller CPU program memory. The programmable 
controller CPU assumes that these instructions are non-processing instructions and 
continues its operation.
However, when the programmable controller CPU operating status is changed from 
STOP to RUN, a program is checked and, as the result, the 'PROG-E LED' indicator 
flashes. If this happens, correct application instructions and element numbers not 
supported and batch-transfer the correct program.

• If an element number specified as an operand of application instructions is not 
supported by FXU (V2.1 to V2.30), the instruction is written to the programmable 
controller CPU program memory as it is. In this case, an element number range over 
operation error occurs. The programmable controller CPU assumes that these 
instructions are non-processing instructions and continues its operation.
However, when the programmable controller CPU operating status is changed from 
STOP to RUN, a program is checked and, as the result, the "PROG-E LED" indicator 
flashes. If this happens, batch-transfer the program with the correct operand set to 
application instructions.

When using FX0N (V1.10 or later)

• If a written element number is not supported by FX0N, the message "The changed 
program contains an instruction or device not supported for Online program change. 
Online program change operation is disabled for this program" is displayed, and the 
program change is stopped.

• The pulse executing type application instruction is not available for FX0N. If this 
instruction is written, the message "Write failure" is displayed, and the program change 
is stopped.

Item Description
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When using FX0N, FX1S, FX1N, 
FXU, FX2N, FX3U, FX1NC, FX2C, 
FX2NC or FX3UC (earlier than V2.00)

• Ladder program change is possible for one ladder block at a time and the number of 
program steps after editing (adding/deleting) must be within 127 (including an NOP 
immediately after the ladder block and excluding the end circuit).
To change programs with more than 127 steps, use the Batch-transfer function.

When using FX3G, FX3U, FX3GC or 
FX3UC (V2.00 or later)

• Ladder program change of multiple ladder blocks at a time is possible and the changes 
can be written with Online program change. However, the number of the program steps 
from the start ladder block to the end circuit after editing must be within 256 steps 
(including unchanged ladder programs). To change programs with more than 256 
steps, use the Batch-transfer function.

When using FX3U/FX3UC (V3.00 or 
later)

• Online program change can be performed only when the protection status (validated or 
invalidated) of the block password setting for "Read-protect the execution program" is 
the same as the programmable controller CPU of the online change target.

*1 : Each deteriorated function can be recovered by switching the programmable controller CPU from STOP to RUN after 
Online program change.

Item Description
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12.10 Calculating Memory Size

This section explains how to calculate a memory size required when data in a user-created project is 
written to the programmable controller CPU.

12.10.1 Offline calculation and Online calculation

There are two ways to calculate the memory size: the offline calculation and the online calculation. 
(Section 12.10.3)
For FXCPU, only the offline calculation is supported.
(Section 12.10.4)
● Offline calculation

Displays the size of available memory if data are written to the programmable controller CPU after its 
memory is initialized by such as the PLC memory format function.
In the system file memory size entry field, enter the system file size acquired by the online 
calculation.

● Online calculation
Displays the size of available memory if selected files are actually written to the programmable 
controller CPU.
Regarding data written on the programmable controller CPU, the exact size of available memory can 
be confirmed.
This function is available when GX Works2 is capable of communicating with the programmable 
controller CPU.

12.10.2 Setting target data for memory size calculation 
(QCPU (Q mode)/LCPU)

Set the target data for memory size calculation.

Screen display
Select [Tool] ⇒ [Confirm Memory Size].

Q CPU L CPU FXFXRemote FXHead

File list
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12.10.3  Confirming result of memory size calculation (QCPU (Q mode)/LCPU)

Operating procedure

1. Set the items on the screen.

2. Click the  button.
The result of memory size calculation is displayed. (Section 12.10.3)

Screen button
For the buttons on the screen, refer to Section 12.1.

12.10.3 Confirming result of memory size calculation 
(QCPU (Q mode)/LCPU)

Display the result of memory size calculation. Additionally, the offline calculation and online calculation 
can be switched each other.

Screen display

Select [Tool] ⇒ [Confirm Memory Size] ⇒ .
<Offline calculation>

Item Description

Target Memory/IC Card Type*1

*1 : For High-speed Universal model QCPU, when the standard RAM is selected for "Target Memory", "Extended 
SRAM cassette type" is displayed.

Set the memory of which the size is to be calculated, and memory card 
type.
For details of the memory card application, refer to the following 
manuals.
QCPU User's Manual (Hardware Design, Maintenance and 
Inspection)
MELSEC-L CPU Module User's Manual (Hardware Design, 
Maintenance and Inspection)

File list –

Target Select data of which the size is to be calculated.

Calculation 

result section

Target section

Sum total section

Memory status 

graph section

System file memory 

size entry field
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<Online calculation>

Display contents

Screen button
For the buttons on the screen, refer to Section 12.1.

Target section

Sum total section

Memory status 

graph section

Calculation 

result section

Item Description

Target Memory Display the target memory and IC card type selected on the Confirm 
Memory Size screen.

Display Option Select the unit (Byte/Step/%) used for displaying the file size and memory 
size.

<<Offline>>/<<Online>>

Switch the result display between the offline calculation and online 
calculation.
The result of the offline calculation is displayed just after the execution of 
the memory size calculation.
For High Performance model QCPU, the <<Online>> tab is not displayed 
when "Target Memory" is 'Memory Card (Flash)’/’Standard ROM'.
For Universal model CPU, the <<Online>> tab is not displayed when 
"Target Memory" is 'Memory Card (Flash)'.

Calculation result section –

Target section Display the size of the data selected on the Confirm Memory Size screen in 
units of files.

System file memory size 
entry field (Offline 
calculation only)

Enter the memory size of system files.
The default value is "0" at the offline calculation.
Enter the memory size when using system files.
When the exact memory size is required, it can be confirmed by the online 
calculation.
The memory size of system files may differ depending on target memory.

Sum total section Display the calculation result according to conditions of the target memory, 
IC card type, and files specified in the Confirm Memory Size screen.

Memory status graph section Display the calculation result in a circle graph.
It is displayed in red when there is no available memory.

Detail Display the detailed information of the result of the memory size calculation.
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● File size of symbolic information
The symbolic information in a project (with labels) is compressed every compilation. Since date information is added 
every time, the memory size may vary even though the symbolic information itself is not changed.

● File size units for programmable controller CPUs
Memory of a programmable controller CPU is occupied by file size units. Therefore, the required memory size may be 
larger than the actual file size.
For details of file size units, refer to the following manuals.
User's Manual (Function Explanation, Program Fundamentals) of the CPU module to be used

● Memory size required for parameters and system files
Parameters/system files consist of multiple files.
The memory size required to store parameters/system files is the total of memory areas occupied by each files.

Display example of "System File" (for Q12HCPU with a serial number whose first file digits are "04122")

The following table shows files included in parameters and system files.

● Memory capacity
The memory capacity may be displayed smaller than it really is.

<Sampling trace>
File size : 2422 bytes
Memory size : 3072 bytes
<Error history data>
File size : 5472 bytes
Memory size : 6144 bytes

↓
<Display of "System File">
File size : 7894 bytes
Memory size : 9216 bytes

File Parameter

Parameters

Parameter file PLC parameter, network parameter, and redundant parameter

Boot file Created when the boot file setting is configured.

Remote password Created when the remote password setting is configured.

System files

Sampling trace file For details of each file, refer to the following manuals.
User’s Manual (Function Explanation, Program Fundamentals) of the 
CPU module to be used

Error history file

Local device

User setting system 
area

An area specified when the programmable controller CPU memory is 
formatted.
(For formatting programmable controller CPU memory, Section 17.3)

PLC user data User-optional data

Graphic data for PX 
Developer User-created graphic data
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12.10.4 Confirming result of memory size calculation (FXCPU)

Display sizes and capacities of program and symbolic information calculated offline.
Displayed values are values when the program and parameters are written to the programmable 
controller CPU.

Screen display
Select [Tool] ⇒ [Confirm Memory Size].

Display contents

● File size of symbolic information
For projects with labels, the symbolic information is compressed each time the memory capacity is calculated or data is 
written to the programmable controller CPU. Since date information is included when the symbolic information is 
compressed, its memory capacity may change even though the symbolic information has not been changed.

Item Description

Status Display compilation status.
"---" is displayed for Simple projects (without labels).

Program Size Display the number of current program steps.
"---" is displayed when the program is uncompiled.

Program Capacity Display the value set for "Program Capacity" on the <<Memory Capacity>> tab 
of PLC parameter of the project.

Error Information Display error information regarding the program size and capacity.

Confirm Symbolic Information*1

*1 : This item is displayed only for FX3U and FX3UC projects with labels.

Select this to calculate the symbolic information size and capacity.

Memory Type
Select a memory type used on the programmable controller CPU.
The symbolic information capacity increases/decreases according to the 
memory type.

Symbolic Information Size Display the current symbolic information size in byte unit.
"---" is displayed when the program is uncompiled.

Symbolic Information 
Capacity

Display the symbolic information capacity in byte unit.
The symbolic information capacity increases/decreases according to the 
memory type used on the programmable controller CPU or the memory 
capacity set in the PLC parameter.

Error Information Display error information regarding the symbolic information size and capacity.
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12.10.5 Considerations of calculating memory size

The following explains the considerations of calculating memory size.

1) Memory size calculation using the offline calculation
A memory size of system files may differ depending on the target memory.
Confirm a memory size of system files using the online calculation and enter the value in the 
system file memory size entry field.
Without using the value calculated by the online calculation, an accurate result may not be 
ensured.

2) Memory size calculation using the online calculation
When lower-case characters are used for data names in a project, the memory size may not be 
calculated correctly.
To calculate the memory size correctly, change the characters of data names to upper-case 
characters to match the data names on the programmable controller CPU.

3) Limit of the number of files
The number of files that can be stored on the programmable controller CPU is limited, however, 
the memory size calculation ignores the limit.
Set target data so that the number of files including those stored on the programmable controller 
CPU is less or equal to the limit.
For the number of files which can be stored on a programmable controller CPU, refer to the 
following manuals.
QCPU User's Manual (Hardware Design, Maintenance and Inspection)
MELSEC-L CPU Module User's Manual (Hardware Design, Maintenance and Inspection)

4) Specifying a range of file registers
At the online calculation, when a range smaller than that of file registers written on the 
programmable controller CPU is specified for the target data of the memory size calculation, the 
difference from the written file registers is displayed as "Use Volume".

5) Calculating a memory size of a Flash card/standard ROM
For High Performance model QCPU, a memory size of a Flash card/standard ROM can be 
confirmed only using the offline calculation.
For Universal model QCPU, a memory size of a Flash card can be confirmed only using the offline 
calculation. A memory size of a standard ROM can also be confirmed using the online calculation.
To confirm a memory size required when writing data using the export to ROM function, select 
'Program Memory' for "Target Memory".

6) When data cannot be written to the programmable controller CPU
When data cannot be written to the programmable controller CPU despite enough available 
memory, perform Arrange PLC Memory to secure consecutive free memory areas. (Arrange PLC 
Memory Section 17.5)

7) Calculating a memory size of an ATA card
For Q2MEM-8/16/32MBA, confirm an accurate drive capacity using the online calculation.
Depending on the versions of the Q2MEM-8/16/32MBA and CPU module, the offline calculation 
may be based on a drive capacity smaller than it really is.

8) Calculating a memory size of an SD memory card
The calculation of the memory size of an SD memory card is different between the online 
calculation and the offline calculation.
For the offline calculation, the memory size is calculated based on the size of the SD memory card 
selected for "Memory Type".
For the online calculation, the memory size is calculated based on the size of the SD memory card 
inserted on the programmable controller CPU.
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12.11 Writing/Reading Data to/from Memory Cards

This section explains the functions for writing/reading data to/from a memory card installed on a 
personal computer.
If a memory card cannot be installed to a programmable controller CPU, the data can be written to/
read from the memory card on a personal computer by using this function.

For the system configuration and other information to use a memory card on a personal computer, 
refer to Section 2.4.

For writing/reading data when the memory card is installed to a programmable controller CPU, refer to 
Section 12.1.

● Formatting memory cards
Format the memory card to be used on the programmable controller CPU by selecting [Online] ⇒ [PLC Memory 
Operation] ⇒ [Format PLC Memory] in GX Works2.
If a memory card is formatted using the function such as Windows® format function it may not be used on the 
programmable controller CPU.

● PLC user data
The PLC user data in the memory card installed on a personal computer cannot write/read to/from GX Works2 directly.
Write/read the data using the application such as Windows® Explorer.
For writing/reading the PLC user data in the memory card installed to a programmable controller CPU, refer to 
Section 12.5.

● Reading intelligent function module data
To read intelligent function module data, create the intelligent function module data in the project in advance.
If the intelligent function module data that match the data in the memory card or the image data do not exist, the data 
are read as data of an unsupported module.
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12.11.1 Writing/reading data to/from ATA/SRAM/SD memory cards

Write/read data in a memory card (ATA card, SRAM card or SD memory card) installed on a personal 
computer to/from GX Works2.

Screen display
Select [Tool] ⇒ [IC Memory Card] ⇒ [Write IC Memory Card]/[Read IC Memory Card].
<Screen for writing IC memory card>

Operating procedure

1. Set the items on the screen.

Q CPU L CPU FXRemote FXHead
*1 *2

*2: Not supported by L02S.
*1: Universal model QCPU (except for Q00UJ, Q00U, Q01U) only

MELSEC

MITSUBISHI

Insert to card reader or card slot

Writing/reading data

GX Works2

Write/Read IC Memory Card

Item Description

Drive/Path Click the  button and select a drive on the Browse for Folder screen.
If a folder is selected, it cannot be used on a programmable controller CPU.

Title Enter title of the target memory when writing data to the IC memory card.
Display the title of the target memory when reading data from the IC memory card.

Edit Data
(Write IC Memory Card only)

Select data to be written from the data list.
Display the data list of the open project.
(Section 12.1)

IC Memory Data
(Read IC Memory Card only)

Select data to be read from the data list.
Display the data list of the project in the memory card.
(Section 12.1)
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2. Click the  button.
For the Write IC Memory Card function, the specified data are written to the memory card.
For the Read IC Memory Card function, the specified data are read from the memory card.

Screen button

●

Opens the screen to set a password to a specified data when writing data to an IC memory card.
The set password is validated after data are written to the IC memory card.
For details of setting a password, refer to the following sections.
For QCPU (Q mode) (except for High-speed Universal model QCPU) Section 13.2.1
For High-speed Universal model QCPU and LCPU Section 13.3.1

●

Opens the screen to cancel a set password when writing data to an IC memory card.
The set password is canceled after data are written to the IC memory card.
For details of canceling a password, refer to the following sections.
For QCPU (Q mode) (except for High-speed Universal model QCPU) Section 13.2.2
For High-speed Universal model QCPU and LCPU Section 13.3.2

● Canceling a password
The password cancellation on the Delete Password screen can only be performed while the project is opened after the 
password is set.
To cancel the password after the project is reopened, overwrite the data by writing data to the IC memory card without 
setting a password.

< Create/Change Password (Target Project Data) screen (For QCPU (Q mode)) >

< Delete Password (Target Project Data) screen (For QCPU (Q mode)) >
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■ Considerations when reading program files with the Read IC Memory Card 
function

Perform the following operations when reading program files with the Read IC Memory Card function.
● When parameters are written to the IC memory card along with the program files

Read parameters along with the program files.
● When parameters are not written to the IC memory card along with the program files

Before reading the program files, open the project at the time of writing data to the IC memory card.
Import the parameters used to write data to the IC memory card from the programmable controller 
CPU.
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12.11.2 Writing/reading data to/from SD memory cards (batch save/
batch load function)

*1 : Not supported by L02S.

Read project data saved on an SD memory card with the batch save function of programmable 
controller CPU, or copy all data to a personal computer.
Write project data to an SD memory card in the format which can be used for the batch load function of 
programmable controller CPU.
For the batch save/batch load function, refer to the following manual.
MELSEC-L CPU Module User's Manual (Function Explanation, Program Fundamentals)

Screen display
Select [Tool] ⇒ [IC Memory Card] ⇒ [Write to IC Memory Card (Edit and Data Copy)]/[Read from 
IC Memory Card (Edit and Data Copy)].
<For writing IC memory card (edit and data copy)>

Q CPU L CPU FXRemote FXHead
*1

Insert to card reader 

or card slot

Writing/reading 

data

Batch save/load 

function of programmable 

controller CPU

Insert to card slot

GX Works2 

Write to/Read from IC Memory Card 

(Edit and Data Copy)
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12.11.2  Writing/reading data to/from SD memory cards (batch save/batch load function)

Operating procedure

1. Set the items on the screen.

2. Click the  button.
For the write to IC memory card (edit and data copy) function, the specified data are written to the 
memory card.
For the read from IC memory card (edit and data copy) function, the specified data are read from 
the memory card.

Screen button
For the buttons on the screen, refer to Section 12.1 and Section 12.11.1.

●

Copies all data saved with the batch save function of programmable controller CPU on the IC 
memory card to the copy destination specified for "Source drive/path to".

● Considerations for writing data to SD memory card
Data are written after all files in the target folder are deleted.

Item Description

Drive Select a drive to write/read data.

Folder name A folder in the "SaveLoad" folder on the specified drive is displayed.
Select a folder to write/read data.

Title

For the write to IC memory card (edit and data copy) function, enter a title of the folder 
selected for "Folder name".
For the read from IC memory card (edit and data copy) function, the title of the folder 
selected for "Folder name" is displayed.

Edit Data
(for Write to IC Memory Card (Edit 
and Data copy))

Display the data list of the open project.
Select data to be written from the data list.

IC Memory Data
(for Read from IC Memory Card 
(Edit and Data Copy))

Display the data list of the project in the memory card.
Select data to be read from the data list.

PLC user data save destination –

Save PLC user data

For the write to IC memory card (edit and data copy) function, select this to write PLC 
user data.
For the read from IC memory card (edit and data copy) function, select this to copy PLC 
user data to a personal computer.]

Source drive/path to write
(for Write to IC Memory Card 
(Edit and Data Copy))

Click the  button and select a drive/path on which PLC user data to be 
written on the IC memory card are saved.

Source drive/path to read
(for Read from IC Memory 
Card (Edit and Data Copy))

Click the  button and select a drive/path to save user data.

Target memory
(for Write to IC Memory Card 
(Edit and Data Copy))

Specify a save destination for PLC user data selected for "Source drive/path to write".
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12.12 Reading Data of Local Devices

*1 : Universal model QCPU (except for Q00UJ) with a serial number whose first five digits are "12012" or higher only

This section explains how to read local device data from the programmable controller CPU and save 
the data on a personal computer in CSV format.

Operating procedure

1. Select [Online] ⇒ [Local Device Batch Read + Save CSV].
The Local Device Batch Read + Save CSV screen is displayed.

2. Enter a name of the file to be saved.

3. Click the  button.
The data of local devices are saved on the personal computer.

FXFXHeadRemoteQ CPU

*1

L CPU
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■ Formatting CSV files

Saved CSV files are displayed as shown below when they are opened by Excel.

Example) The following tables show the settings of this example.
• Setting for programs and file usability

• Setting for local devices

<CSV file>

Program name File usability setting

MAIN Based on PLC file settings

SUB Not used

SUB2 Based on PLC file settings

Device name Device range

M 0 to 49

T 0 to 29

D 100 to 149

Local devices of 
program MAIN

Program name
File usability setting

Device names and 
local device values

Program name
File usability setting

Device names and 
local device values

Local devices of 
program SUB

Program name
File usability setting

Local devices of 
program SUB2

For T, ST, and C, contacts, 
coils, and current values 
are read respectively.
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13 - 1

13 PROTECTING DATA
This chapter explains the function for protecting the project data and the programmable controller 
CPU data against such as falsification and leak.

13.1 Functions to Protect Data 13 - 2

13.2 Registering/Changing Password (QCPU (Q mode)) 13 - 3

13.3 Registering/Changing Password (File Password 32) 13 - 8

13.4 Registering/Changing Keyword (FXCPU) 13 - 14

13.5 Locking with Security Key 13 - 18
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13.1 Functions to Protect Data

The function to protect data differs according to the target data or target CPU.
The following table shows the list of functions for protecting data.
For "(Structured)" indicated in the Reference column, refer to the following manual.
 GX Works2 Version 1 Operating Manual (Structured Project)

: Supported    ×: Not supported

■ Differences of functions

The following table shows the differences of functions for protecting data.
: Applicable    ×: Not applicable

Remote HeadQ CPU L CPU FX

Target data

Target CPU

Function ReferenceQCPU 
(Q mode) LCPU

Remote
I/O 

module

Communication 
head module FXCPU

Project data
     Security Section 4.10

*1 × × × × Soft Security Key Management Section 4.11

POU   × ×  Block password setting Section 4.12

User library   × ×  Library password setting (Structured)

Programmable 
controller CPU data

   *2 × Remote password setting Section 6.4

*3 × × × ×
Password

Section 13.2

*1  × × × Section 13.3

× × × ×  Keyword Section 13.4

*1 × × × × Soft Security Key Management Section 13.5

× × × × *4 Execution program protection
(block password setting) Section 4.12

*1 : For High-speed Universal model QCPU only
*2 : Supported by CC IE Field head module only.
*3 : Not supported by High-speed Universal model QCPU.
*4 : For FX3U/FX3UC version 3.00 or later only

Item

Function

Security
Soft Security 

Key 
Management

Block 
password 

setting

Library 
password 

setting

Remote 
password 

setting

Password/
Keyword

Protect project data    × × ×

Protect programmable 
controller CPU ×  × ×  

Protect library data × × ×  × ×

Limit users who can disable 
the protection function    ×  

Limit personal computers that 
can disable the protection 
function

×  × × × ×

Transfer the security setting to 
another personal computer ×  × × × ×
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13.2 Registering/Changing Password (QCPU (Q mode))

*1 : Not supported by Universal model high-speed type QCPU.

This section explains how to register a password to protect data in QCPU (Q mode).
For registering/changing passwords on Universal model high-speed type QCPU, refer to Section 13.3.

To register a password, connect GX Works2 to a programmable controller CPU in advance.
Project data cannot be protected by using this function. Use the project security function to protect 
the project data. (Section 4.10)

● Password management
Keep passwords in a secure place.
If a registered password is lost, initialize the programmable controller CPU using the PLC memory format function 
(Section 17.3) and write the project to the programmable controller CPU.

● Registering a password
• Set a password with 4 characters. For usable characters, refer to "Explanation of Registration Conditions" on the 

Input Password screen.
• A password can be set for the following items.

• Program
• Device comment
• Device initial value

● Registering/changing/canceling passwords when writing data to an IC memory card
When the Create/Change Password screen or the Delete Password screen is opened from the IC Memory Card 
Operation screen, passwords of data in the project are registered/changed/canceled. Therefore, "Target Memory" is 
not displayed.

● Unlocking password
When files with the same name exist on the different drives (such as program memory and standard RAM), the 
password which is unlocked first is applied to the other file.
• With the same password

When one file is unlocked, the other file with the same name is also unlocked.
• With the different password

Enter the password to unlock the file with the same name.

FXFXHeadRemoteQ CPU

*1

L CPU
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13.2.1  Registering/changing password

13.2.1 Registering/changing password

Register a password to project data on a programmable controller CPU.

Screen display
Select [Online] ⇒ [Password/Keyword] ⇒ [New].
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Operating procedure

1. Select the target memory.

2. Select the target data for registering/changing a password in the data list.

3. Click the  button.
The Input Password screen is displayed.

4. Set the items on the screen.

5. Click the  button.
The screen returns to the Create/Change Password screen.
Symbol  is appended to the data for which a password is registered.

6. Click the  button.
The password is registered or changed for the data on the programmable controller CPU.

● Registering a password
• A password can be set to multiple data by holding the  or  key and selecting the data in the data list.
• A password set to data in the transfer source memory of boot operation remains set in the transfer destination 

memory.

● Universal model QCPU
For Universal model QCPU, when a password is registered/changed while the programmable controller CPU is 
running, the program memory batch transfer is executed. (Section 12.6)

● Changing a password
If a password has been already set for the selected data, the Disable Password screen is displayed. Enter the old 
password to unlock the password.

Item Description

Registration Condition Select a condition for password check.

Read/Write Protection Select this to check a password when data are read in addition to "Write Protection".

Write Protection Select this to check a password when data are written to the programmable controller 
CPU.

New Password Enter a new password or a password after change.

Re-enter Password Enter the new password again for confirmation.
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13.2.2  Canceling password

13.2.2 Canceling password

Cancel the password set to the data on the programmable controller CPU.

Screen display
Select [Online] ⇒ [Password/Keyword] ⇒ [Delete].

Operating procedure

1. Select data whose password is to be canceled in the data list.

2. Click the  button.
The Input Disable Password screen is displayed.
This screen is not displayed when the password has 
already been canceled.

3. Enter the password set to the data.

4. Click the  button.
The screen returns to the Delete Password screen.

5. Click the  button.
The password set to the data on the programmable 
controller CPU is canceled.
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13.2.3 Unlocking password temporarily

Unlock a password temporarily, set to the data on the programmable controller CPU, by authenticating 
it.
When the password is unlocked, the corresponding data on the programmable controller CPU can be 
accessed freely until the project is closed.
This function does not cancel the password set for the data on the programmable controller CPU.

Screen display
Select [Online] ⇒ [Password/Keyword] ⇒ [Disable].

Operating procedure

1. Select data whose password is to be temporarily unlocked in the data list.

2. Click the  button.
The Input Disable Password screen is displayed.

3. Enter the password set to the data.

4. Click the  button.
The screen returns to the Disable Password screen.

5. Click the  button.
The password set to the data on the programmable 
controller CPU is temporarily unlocked.
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13.3 Registering/Changing Password (File Password 32)

*1 : High-speed Universal model QCPU only

This section explains how to register a password to protect data in High-speed Universal model 
QCPU/LCPU.
To register a password, connect GX Works2 to a programmable controller CPU in advance.
Project data cannot be protected by using this function. Use the project security function to protect 
the project data. (Section 4.10)

● Password management
Keep passwords in a secure place.
If a registered password is lost, initialize the programmable controller CPU using the PLC memory format function 
(Section 17.3) and write the project to the programmable controller CPU.

● Registering a password
• Set a password with the number of characters between 4 and 32. For usable characters, refer to "Explanation of 

Registration Conditions" on the Input Password screen.
• A password can be set for the following items.

• Symbolic information
• Program
• PLC parameter, network parameter
• Device comment
• Device initial value

● Registering/changing/canceling passwords when writing data to an IC memory card
When the Create/Change Password screen or the Delete Password screen is opened from the IC Memory Card 
Operation screen, passwords of data in the project are registered/changed/canceled. Therefore, "Target Memory" is 
not displayed.

● Unlocking password
When files with the same name exist on the different drives (such as program memory and standard RAM), the 
password which is unlocked first is applied to the other file.
• With the same password

When one file is unlocked, the other file with the same name is also unlocked.
• With the different password

Enter the password to unlock the file with the same name.

FXFXRemoteQ CPU

*1

HeadL CPU
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13.3.1 Registering/changing password

Register a password to project data on a programmable controller CPU.

Screen display
Select [Online] ⇒ [Password/Keyword] ⇒ [New].

Operating procedure

1. Select the target memory.

2. Select the target data for registering/changing a password in the data list.

3. Click the  button.
The Input Password screen is displayed.
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13.3.1  Registering/changing password

4. Set the items on the screen.

5. Click the  button.
The screen returns to the Create/Change Password screen.
Symbol  is appended to the data for which a password is registered.

6. Click the  button.
The password is registered or changed for the data on the programmable controller CPU.

● Registering a password
• A password can be set to multiple data by holding the  or  key and selecting the data in the data list.
• A password set to data in the transfer source memory of boot operation remains set in the transfer destination 

memory.
● Changing a password

If a password has been already set for the selected data, the Disable Password screen is displayed. Enter the old 
password to unlock the password.

Item Description

Registration Condition Select a condition for password check.

Read protection Select this to check a password when data are read from the programmable controller 
CPU.

Write protection Select this to check a password when data are written to the programmable controller 
CPU.

Read protection/Write 
protection Select this to check a password when data are written in addition to "Read protection".

Use the same password for read 
protection/write protection

Select this to use the same password for the read protection and write protection when 
‘Read protection/Write protection’ is selected in "Registration Condition".

New Password
(Read Protection)

Enter a new password or a password after change.
The password enables the read protection.

Re-enter Password
(Read Protection) Enter the new password again for confirmation.

New Password
(Write Protection)

Enter a new password or a password after change.
The password enables the write protection.
This item cannot be set when "Use the same password for read protection/write 
protection" is selected.

Re-enter Password
(Write Protection)

Enter the new password again for confirmation.
This item cannot be set when "Use the same password for read protection/write 
protection" is selected.



13.3  Registering/Changing Password (File Password 32)

13.3.2  Canceling password 13 - 11

9

SE
TT

IN
G

 D
E

VI
C

E
 

C
O

M
M

EN
TS

10

S
EA

R
C

H
/R

EP
LA

C
E

11

SE
TT

IN
G 

PR
OG

RA
MM

AB
LE

 
CO

NT
RO

LL
ER

 C
PU

 
CO

NN
EC

TIO
N 

DE
ST

IN
AT

IO
N

12

W
R

IT
IN

G
/R

EA
D

IN
G

 
D

A
TA

13

PR
O

TE
C

TI
N

G
 

D
AT

A

14

M
O

N
IT

O
R

IN
G

15

S
IM

U
LA

TI
N

G
 

P
R

O
G

R
A

M
S

16

D
E

B
U

G
G

IN
G

 
P

R
O

G
R

A
M

S

13.3.2 Canceling password

Cancel the password set to the data on the programmable controller CPU.

Screen display
Select [Online] ⇒ [Password/Keyword] ⇒ [Delete].

Operating procedure

1. Select data whose password is to be canceled in the data list.

2. Click the  button.
The Input Disable Password screen is displayed.
This screen is not displayed when the password has already been 
canceled.

3. Set the items on the screen.

4. Click the  button.
The screen returns to the Delete Password screen.

5. Click the  button.
The password set to the data on the programmable controller 
CPU is canceled.

Item Description

Delete Condition Select the condition for password cancellation when the password registration 
condition of the data selected is "Read Protection/Write Protection".

Disable Password
(Read Protection)

Enter the password set to the data.
Disable Password
(Write Protection)
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13.3.3  Unlocking password temporarily

13.3.3 Unlocking password temporarily

Unlock a password temporarily, set to the data on the programmable controller CPU, by authenticating 
it.
When the password is unlocked, the corresponding data on the programmable controller CPU can be 
accessed freely until the project is closed.
This function does not cancel the password set for the data on the programmable controller CPU.

Screen display
Select [Online] ⇒ [Password/Keyword] ⇒ [Disable].

Operating procedure

1. Select data whose password is to be temporarily unlocked in the data list.

2. Click the  button.
The Input Disable Password screen is displayed.

3. Set the items on the screen.

Item Description

Disable Condition Select the condition for password unlock when the password registration condition of 
the data selected is "Read Protection/Write Protection".

Disable Password
(Read Protection)

Enter the password set to the data.
Disable Password
(Write Protection)
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4. Click the  button.
The screen returns to the Disable Password screen.

5. Click the  button.
The password set to the data on the programmable controller 
CPU is temporarily unlocked.
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13.4.1  Registering/changing keyword

13.4 Registering/Changing Keyword (FXCPU)

This section explains how to register a keyword to protect data in FX series programmable controller 
CPU.
To register a keyword, connect GX Works2 to a programmable controller CPU in advance.
Project data cannot be protected using this function. Use the project security function to protect the 
project data. (Section 4.10)
For the FX series versions which support this function, refer to the user's manual of the 
programmable controller CPU to be used.

● Keyword management
Do not lose the keywords.
If a registered keyword is lost, initialize the programmable controller CPU using the PLC memory clear function 
(Section 17.4) and write the project to the programmable controller CPU.

13.4.1 Registering/changing keyword

Screen display
Select [Online] ⇒ [Password/Keyword] ⇒ [New].

HeadRemoteQ CPU FXL CPU
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Operating procedure

1. Select the function. (FX3G, FX3GC, FX3U, and FX3UC only)
Select either the terminable limitation or permanent limitation.

2. For "Keyword Protection", set "Keyword Input".
For FX3G, FX3GC, FX3U and FX3UC, select '16 digits' or '8 digits'.

3. Select the protection level.
For the programmable controller CPU other than FX3G, FX3GC, FX3U and FX3UC, "Protection 
Level" is fixed to 'Read/Write Protection'.

4. Click the  button.

Item Description

Keyword Protection Set the keyword for the limitation.
Limitation can be canceled.

Permanent PLC Lock Setting the keyword is unnecessary.
Limitation cannot be canceled.

Item Description

Keyword (8 digits)
Set 8 digits using characters 0-9 and/or A-F.
This item can be set when "Keyword Protection" is selected and '8 digits' is selected.
The Read/Write Protection is available.

Keyword (16 digits)

Set 16 digits using characters 0-9 and/or A-F.
This item can be set when "Keyword Protection" is selected and '16 digits' is selected.
This item is supported only by FX3G, FX3GC, FX3U, and FX3UC.
The protection level can be selected from "Read/Write Protection", "Write Protection", and 
"All Online Operation Protection".

Customer 
Keyword*1

*1 : Set this item combining with "Keyword (16 digits)" as necessary. The customer keyword can be disabled temporarily 
but it cannot be changed or canceled.

Set 16 digits using characters 0-9 and/or A-F.
This item can be set when "Keyword (16 digits)" is set and "Customer keyword is used (16 
digits)" is selected.
This item is supported only by FX3G, FX3GC, FX3U, and FX3UC.
The protection level is the same as that for "Keyword (16 digits)".

Item Description

Read/Write Protection Limit the read, write, and verify operations.

Write Protection Limit the write operation.

All Online Operation Protection Limit the read, write, verify, and device monitor operations.
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13.4.2  Canceling keyword

13.4.2 Canceling keyword

Cancel the keyword set to the data on the programmable controller CPU.

Screen display
Select [Online] ⇒ [Password/Keyword] ⇒ [Delete].

Operating procedure

1. Enter the keyword being registered.
Enter only the first 8 digits when 'Keyword Protection (8 digits)' is registered. The customer 
keyword cannot be canceled.

2. Click the  button.
The keyword registered on the programmable controller CPU is canceled.
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13.4.3 Unlocking keyword temporarily

Unlock a password temporarily, set to the data on the programmable controller CPU, by authenticating 
it.
When the keyword is unlocked, the corresponding data on the programmable controller CPU can be 
accessed freely until the project is closed.
This function does not cancel the keyword set for the data on the programmable controller CPU.

Screen display
Select [Online] ⇒ [Password/Keyword] ⇒ [Disable].

Operating procedure

1. Set the items on the screen.

2. Click the  button.
The selected operation (Keyword Disable/Keyword Protect) is executed.

Item Description

Keyword Disable Select this to unlock the keyword temporarily.

Keyword

Enter the keyword registered to the programmable controller CPU. Enter only 
the first 8 digits when 'Keyword Protection (8 digits)' is registered.
When the customer keyword is registered, the keyword can be disabled by 
entering the customer keyword.*1

Keyword Protect*1

*1 : FX3G, FX3GC, FX3U, and FX3UC only

Select this to get the keyword unlocked status to the locked status.
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13.5 Locking with Security Key

*1 : High-speed Universal model QCPU only

This section explains how to lock the programmable controller CPU with a security key and limit the 
access.
For creating, importing/exporting, or deleting security keys, refer to Section 4.11.

Screen display
Select [Online] ⇒ [Soft Security Key Management]

Display contents

FXFXHeadRemoteQ CPU

*1

L CPU

Item Description

Key Information Registered in the 
Personal Computer Display the information of selected security key. (Section 4.11.1)

<<CPU>> Display the screen to lock/unlock the programmable controller CPU.

Connection Channel List –

Connection Interface Display the interface on the personal computer and the interface on the programmable 
controller CPU connected to the personal computer.

Network No. Display the network number of the connection destination.

Station No. Display the station number of the connection destination.

PLC Type Display the programmable controller type of the connection destination.

Security Key Information –

Name Display the name of the security key which is used to lock the programmable controller 
CPU.

Creation date Display the date of creation of the security key which is used to lock the programmable 
controller CPU.

Explanation Display the information when the cursor is placed on the button on the screen.
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Operating procedure

1. Select the security key to lock the programmable controller CPU from "Key 
Information Registered in the Personal Computer".

2. Click the  button.
The programmable controller CPU is locked with the selected security key.

Screen button

●

Acquires the security key information of the programmable controller CPU in the connection 
destination and displays it.

●

Unlocks the locked programmable controller CPU.

● Considerations when locking programmable controller CPU
The programmable controller CPU cannot be locked with the security key when it is in RUN status. Set the 
programmable controller CPU to STOP status to lock it with the security key.
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14 - 1

14 MONITORING
This chapter explains how to monitor the execution status of the programmable controller CPU 
connected to the personal computer.

14.1 Monitoring Function 14 - 2

14.2 Monitoring Programs 14 - 7

14.3 Batch Monitoring Devices/Buffer Memory 14 - 8

14.4 Monitoring Program List 14 - 12

14.5 Monitoring Interrupt Program List 14 - 15

14.6 Registering and Monitoring Devices 14 - 16

14.7 Monitoring Intelligent Function Modules 14 - 23

14.8 Starting/Stopping Monitoring All Windows 14 - 23
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14.1.1  Starting/stopping monitoring

14.1 Monitoring Function

This section explains how to monitor programs.
The monitoring function is a function used to check operating status of a programmable controller 
CPU by connecting a personal computer and a programmable controller CPU.

14.1.1 Starting/stopping monitoring

The monitoring function can be started/stopped by any of the following menus.
• [Online] ⇒ [Monitor] ⇒ [Start Monitoring (All Windows)]/[Stop Monitoring (All Windows)]
• [Online] ⇒ [Monitor] ⇒ [Start Monitoring]/[Stop Monitoring]
• [Online] ⇒ [Watch] ⇒ [Start Watching]/[Stop Watching]
The menu to start/stop monitoring differs according to the monitoring type.
The following table shows the monitoring type to which the execution is applied by each menu.
For (Simple), (Structured), and (Intelligent) indicated in the Reference column, refer to the following 
manuals respectively:

: Applicable ×: Not applicable

Remote HeadQ CPU L CPU FX

(Simple) … GX Works2 Version 1 Operating Manual (Simple Project)

(Structured) … GX Works2 Version 1 Operating Manual (Structured Project)

(Intelligent) … GX Works2 Version 1 Operating Manual (Intelligent Function Module)

Monitoring type

Menu

ReferenceStart/Stop 
monitoring (All 

windows)

Start/stop 
monitoring*1 Start/stop watching*1

Program monitoring   ×
Section 14.2

(Simple)
(Structured)

Device/buffer memory batch 
monitoring   × Section 14.3

Program list monitoring  ×*2 × Section 14.4

Interrupt program monitoring  ×*2 × Section 14.5

SFC all block batch monitoring   × (Simple)

Watch  ×  Section 14.6

Intelligent function module monitoring  ×  (Intelligent)

*1 : Applied to active windows.
*2 : The monitoring can be started/stopped by the buttons on the screen.
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● When monitoring multiple projects using a single personal computer
• When monitoring multiple projects using a single personal computer, and if an communication error occurs in one of 

the projects, the monitoring speed of the other projects may become slow.
The operation will be back to normal when the error message displayed in the project in which the communication 
error occurred is closed.

• When monitoring multiple projects using a single personal computer, the following functions may not be performed 
normally.
• Program list monitoring
• Interrupt program list monitoring
• Monitoring condition setting
• Monitoring stop condition setting
• Scan time measurement

● Monitoring devices that cannot be monitored
When devices that cannot be monitored are specified in a program monitoring, watch, or device/buffer memory batch 
monitoring execution, the monitoring result is displayed as "FFFFH(-1)".
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14.1.2  Monitoring status

14.1.2 Monitoring status

Monitoring status is displayed during monitoring on the work window.
Monitoring status is hidden when monitoring all items is stopped.

Screen display
At the start of monitoring
● When connected to a programmable controller CPU

Items displayed on the screen differ according to the programmable controller type. The following are 
the examples of the Monitor Status screen for High Performance model QCPU and Redundant CPU.

<High Performance model QCPU>

<Redundant CPU>

● During simulation
Items displayed on the screen differ according to the programmable controller type. The following is 
the example of the Monitor Status screen for High Performance model QCPU.

<High Performance model QCPU>

Scan time status

USER status

ERR. status

RUN/STOP status

Connection status

Local device monitoring target selection field

Scan time status

USER status

ERR. status

RUN/STOP status
Connection status

Local device monitoring target 

selection field

Control system/standby system status 

System A/system B status

Scan time status

USER status

ERR. status

RUN/STOP status

Connection status

Local device monitoring target selection field

Unsupported instructions
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Display contents

Item Description

Connection status Display the connection status between a programmable controller CPU and 
personal computer in which the simulation function is started.

 ↔ When connected to a programmable controller CPU During simulation

RUN/STOP status Display the programmable controller CPU status operated by the key switch on the 
programmable controller CPU or the remote operation from GX Works2.

RUN

STOP

*1 STEP-RUN

ERR. status
Display the ERR. LED status of the programmable controller CPU.
The PLC Diagnostics screen is displayed when the icon is clicked.
PLC diagnostics screen (Section 18.1)

ERR. is OFF.

ERR. is ON.

 ↔ ERR. is flashing.

USER status*1,*2
Display the USER LED status of the programmable controller CPU.
The PLC Diagnostics screen is displayed when the icon is clicked.
PLC diagnostics screen (Section 18.1)

USER is OFF.

USER is ON.

 ↔ USER is flashing.

Control system/standby system status Display the control system/standby system status of Redundant CPU.

Control system

Standby system

Unknown

System A/system B status Display the system A/system B status of Redundant CPU.

System A

System B

Unknown

Status of device test with execution 
condition*1 Display the status of the device test with execution condition.

Flash when data on the programmable controller CPU and one being edited are not 
identical. The registered information on the programmable controller CPU is read 
out when the monitor is restarted.
Return to ON when the both data are identical.

Execution program status*3 RAM, EPROM, EEPROM (FX3UC : FLROM)

Scan time status Display the maximum scan time of the monitor target programmable controller CPU.
For QCPU (Q mode), the display is given in units of 0.1ms.

Local device monitoring target selection 
field*1,*2

Select the name of the program for which local device monitoring is performed.
If "Auto setting" is selected, the local devices in the program on the active screen 
are automatically monitored.
Not displayed by Q00UJ.
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14.1.2  Monitoring status

● Operation of the PLC Memory Clear function during the monitoring of local devices
When the "Clear Device's whole Memory" operation is executed during the monitoring of local devices, local devices 
are cleared in the programs selected in the 'local device monitoring target selection field'.

Unsupported instructions

Display whether an unsupported instruction exists or not when the simulation 
function is executed.
The Instructions Unsupported by Simulation screen is displayed when the icon is 
clicked.
Checking unsupported instruction/device (Section 15.3)

Unsupported instruction exists.

Unsupported instruction does not exist.

*1 : Not supported by FXCPU.
*2 : Not supported by communication head module and remote I/O module.
*3 : Not supported by QCPU (Q mode)/LCPU.

Item Description
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14.2 Monitoring Programs

This section explains how to monitor the execution status of the programmable controller CPU.
The monitored items differ according to the programming language used.
For details, refer to the following manuals.
GX Works2 Version 1 Operating Manual (Simple Project)
GX Works2 Version 1 Operating Manual (Structured Project)

Screen display
Select [Online] ⇒ [Monitor] ⇒ [Start Monitoring] ( ).

Q CPU L CPU FXFXRemote FXHead
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14.3 Batch Monitoring Devices/Buffer Memory

This section explains how to monitor devices/buffer memory in batch.

For device batch monitoring, specify the target devices.
For buffer memory batch monitoring, specify the address of the intelligent function module.

Screen display
Select [Online] ⇒ [Monitor] ⇒ [Device/Buffer Memory Batch] ( ).

Operating procedure

• Set the items on the screen.

Remote HeadQ CPU L CPU FX

Decimal/Hexadecimal selection

Device comment display

Item Description

Device Select this to monitor devices in batch.

Device Name Select this to enter the name of a device to be monitored in batch.

T/C Set Value 
Reference Program*1

Specify the program whose setting value is to be displayed when monitoring timer 
(T) or counter (C) in batch.

Buffer Memory Select this to monitor buffer memory in batch.

Module Start

Enter the start I/O number of the intelligent function module in hexadecimal 
number.
• For FXCPU

Enter the block number of the special extension device. (0 to 7)
FX0N-3A, FX2N-2AD and FX2N-2DA cannot be the target of the buffer memory 
monitor.

• For Multiple CPU system configuration
Specify the programmable controller CPU to be monitored.
CPU No. 1: 3E00, CPU No. 2: 3E10, CPU No. 3: 3E20, CPU No. 4: 3E30

Address Enter the address of buffer memory to be monitored in decimal or hexadecimal.

Decimal/Hexadecimal 
selection Select the address input format (decimal or hexadecimal).

Display format Switch the display format of the monitoring values.
Save and read batch monitor display format files.

Device comment display
Select whether to display device comments.
When displaying device comments, device comments referred in the selected 
program are displayed.

*1 : Not supported by communication head module and remote I/O module.
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Screen button

●  (Not supported by remote I/O module)
Displays the T/C Set Value Reference Program screen.

Operation
• Set the items on the screen.

●

Displays the Modify Value screen. (Section 16.1)

Item Description

Program Reference Selection/POU 
Reference Selection

Set the reference of POU.
In Simple project, selection is fixed at "Project".

Project Select this to reference a program in the project.

User Library Select this to reference a POU in the user library by clicking .

Program/POU_Pool

Select the POU to be referenced.
Projects selected by "POU Reference Selection" or POU in "User Library" is 
displayed.
Items to be displayed are as shown below.

Simple project : Program file
Structured project : POU
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●

Displays the Display Format screen.
Set the monitor display format.
The screen displays the settings as an example. Setting is possible while confirming the display.

Operation
• Set the items on the screen.

Item Description

Monitor Format Select the monitor format.

Bit Select this to monitor bits in unit of one point.

Bit and Word Select this to monitor both bits and words in unit of one point.

Bit Multi-point Select this to monitor bits in unit of multiple points.

Word Multi-point Select this to monitor words in unit of multiple points.

Display Select the data type of the value stored in word device/buffer memory when "Bit 
and Word" or "Word Multi-point" is selected for "Monitor Format".

16bit Integer Select this to monitor in 16-bit integer.

32bit Integer Select this to monitor in 32-bit double word (signed) integer.

Real Number (32Bit) Select this to monitor in 32-bit (single-precision real number).

Real Number (64Bit) Select this to monitor in 64-bit (double-precision real number).

ASCII Select this to monitor in character string.

Value Select either decimal or hexadecimal display format for 16-bit or 32-bit integer.

DEC Select this to monitor in decimal number.

HEX Select this to monitor in hexadecimal number.

Bit Order Select the alignment sequence of bits to be monitored when "Bit and Word" or "Bit 
Multi-point" is selected for "Bit".

0-F Select this to monitor bit information from the left to the right on the screen.
This method is appropriate for monitoring bit devices.

F-0 Select this to monitor bit information from the right to the left on the screen.
This method is appropriate for monitoring word devices or buffer memory.

Switch No. of Points*1 Select the number of points to be monitored per row.

16 Points (8 Points) Select this to monitor 8 points of word device or 16 points of bit device per row.

10 Points (10 Points) Select this to monitor 10 points per row.

*1 : For FXCPU, the display can be switched between 8 points and 16 points when an X/Y device is selected.
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●

Utilizes the saved display formats.

●

Saves the current display format in the file.

● Opening multiple Device/Buffer Memory Batch Monitor screens
The maximum number of Device/Buffer Memory Batch Monitor screens that can be opened is 64. A screen number is 
appended at the end of the screen title.

● Monitoring time when multiple Device/Buffer Memory Batch Monitor screens are opened
When the multiple Device/Buffer Memory Batch Monitor screens are opened, lead time to start monitoring and 
monitoring intervals may become longer.

● Accessing multiple CPU shared memory
Multiple CPU shared memory of multiple CPU system can be monitored only by the Device/Buffer Memory Batch 
Monitor function.

Restrictions

● FXCPU that support the buffer memory batch monitor function
FX1N, FX1NC, FX2N, FX2NC, FX3G, FX3GC, FX3U, and FX3UC support the buffer memory batch monitor function.
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14.4 Monitoring Program List

This section explains how to monitor the processing time of programs being executed.

Screen display
Select [Online] ⇒ [Monitor] ⇒ [Program List].

Display contents

Screen button

●

Displays the Start Program screen. (■ Starting programs)

●

Displays the Stop Program screen. (■ Stopping programs)

Q CPU L CPU FXRemote FXHead FXFX

Item Description

Entire Scan Time Display the time set in the WDT setting of PLC RAS setting of PLC parameter.

Monitoring Time Display each monitoring time of the scan program, initial program, and low-speed program. 
When the scan time exceeds these time, a programmable controller CPU error occurs.

Total Scan Time Display the total time of each item of "Detail of Scan Time for Scan Execution".

Detail of Scan Time for Scan 
Execution

Display the processing time of each item. "Constant Wait" displays the waiting time of the 
constant scan when the constant scan is set. When the low-speed program execution time 
is also set, however, it displays '0.000' ms.

Execution Status of Programs Display the execution status of programs specified in the program setting of PLC 
parameter.

Program Display the program names in the input order in PLC parameter.

Execution Display the execution type of the programs specified in PLC parameter.

Scan Time Display the actual scan time (current value). Display '0.000' ms in the program stop 
(standby) status.

Execution Count
Display the number of executions, counted from 0 at the point of turning the programmable 
controller CPU to the RUN status. After reaching 65536, it returns to 0. It is stored even 
after the program stops.
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● Program list monitor
In a simulation, only "Execution Count" in "Execution Status of Programs" is monitored.

■ Starting programs

Screen display

Select Program List screen ⇒ 

Operating procedure

1. Set the items on the screen.

2. Click the  button.
The selected program is started.

● Starting programs
This function is supported only by High Performance model QCPU, Process CPU, and Redundant CPU.

Item Description

Program Name Select the name of a program to be started from .

Start Mode Select the execution type.

Scan execution Set the execution type to the scan execution.

Low speed execution Set the execution type to the low-speed execution.

Fixed scan execution
Set the execution type to the fixed scan execution. The time input area in "Fixed scan 
execution" displays the value set in "Fixed Scan Interval" on the <<Program>> tab of PLC 
parameter. Change it as necessary.
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■ Stopping programs

Screen display

Select Program List screen ⇒ 

Operating procedure

1. Set the items on the screen.

2. Click the  button.
The selected program turns in the stopped status.

● Stopping programs
• This function is supported only by High Performance model QCPU, Process CPU, and Redundant CPU.
• When "Stop output after stop" is selected, outputs may not turn OFF depending on instructions. For details, refer to 

the section explains the POFF instruction in the following manuals.
MELSEC-Q/L Programming Manual (Common Instructions)
MELSEC-Q/L Structured Programming Manual (Common Instructions)

Item Description

Program Name Select the name of a program to be stopped from  .

Stop Mode Select the stop mode.

Stop output after stop

• For the scan execution type program, turn outputs OFF (Non-execution processing) at 
the next scan. The program is set as the standby status after the subsequent scan. (The 
same behavior as the POFF instruction)

• For the low-speed execution type program, stop its execution, and turn outputs OFF at 
the next scan. The program is set as the standby status after the subsequent scan.

Hold output after stop Place the scan execution type program in the standby status, and store the output of the 
OUT instruction.
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14.5 Monitoring Interrupt Program List

This section explains how to display the number of executions of interrupt programs used in a 
program.

Screen display
Select [Online] ⇒ [Monitor] ⇒ [Interrupt Program List].

Operating procedure

• Input the interrupt pointer number whose execution counts are to be displayed in 
"Interrupt Pointer".

Display contents

Q CPU L CPU FXRemote FXHead FXFX

Interrupt pointer

monitor list

Item Description

Interrupt pointer monitor list –

Interrupt Pointer Display the interrupt pointer entered in "Interrupt Pointer" on the top.

Execution Count Start counting when the programmable controller CPU turns to the RUN status and display 
the execution counts. When reaching 65536, returns to 0.

Comment Display the device comment.
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14.6.1  Registering and monitoring devices

14.6 Registering and Monitoring Devices

This section explains how to monitor devices.

14.6.1 Registering and monitoring devices

Register multiple devices/labels in single screen and monitor them simultaneously.

Screen display
Select [View] ⇒ [Docking Window] ⇒ [Watch 1] to [Watch 4].

Display contents

Remote HeadQ CPU L CPU FX

Item Description

Device/Label Display the device/label name.

Current Value

Display the current value of the device/label.
The display format (decimal/hexadecimal) of the current value can be switched. 
(Section 14.6.3)
The display format (numerical display (1/0)/ ON/OFF display/ symbol display (/)) of the 
current value of bit device can be switched.

Data Type Display the data type of the device/label.

Class Display the class of the label.
Nothing is displayed for the devices.

Device
Display the device, or device assigned to the label.
For the labels with the class of VAR_CONSTANT or VAR_GLOBAL_CONSTANT, the 
initial value set on the label editor is displayed.

Address*1 Display the address of the device/label.

Comment Display the comments of the device/label.

*1 : For Structured projects only
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Operating procedure

1. Select a row to be edited, and then click its "Device/Label" column.
The cell becomes the editing status.

2. Enter a device/label to be registered.
For local labels, enter as 'program (program block) name/label name'.

Example) POU_01/counter

3. Press the  key.
The entered device/label is registered.
When the device/label is registered, its relevant information such as data type and class is 
registered automatically.

4. Select [Online] ⇒ [Monitor] ⇒ [Start Watching].
The current value of the registered device/label is displayed.

● Registered devices/labels on Watch windows
Once devices/labels are registered and the project is saved, registered devices/labels are displayed in registered status 
when the project is opened again.

● Deleting registered devices/labels
A device/label can be deleted by right-clicking the specified cell and selecting [Delete] from the shortcut menu or 
pressing the  key.

● Sorting items on Watch window
Items in the columns can be sorted in the ascending/descending order by clicking each column header. 
To sort the items by the "Current Value" column, display all registered devices. When the items are sorted without 
displaying the registered devices, scroll the screen.
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14.6.2  Registering devices

14.6.2 Registering devices

Register devices to the Watch window.

■ Registering devices/labels from program editor/label editor using shortcut 
menu

Register devices/labels from the program editor/label editor using a shortcut menu.
Multiple devices/labels can be registered in batch by selecting a range.

Operation
1. Select devices/labels to be registered to the Watch window.

2. Right-click and select [Register to Watch] from the shortcut menu.
The devices/labels are registered to the Watch window.

● Registering devices/labels from the label editor
When registering devices/labels to the Watch window from the label editor, right-click a target row and select [Register 
to Watch] from the shortcut menu.

● Registering device/labels with shortcut menu
With the shortcut menu, devices/labels are registered to the foreground Watch window.
When two or more Watch windows are displayed in the foreground, devices/labels are registered to the Watch window 
with the younger Watch window number.
When the Watch window is not displayed, the Watch window 1 is opened and devices/labels are registered to it.
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■ Registering devices/labels from program editor/label editor with drag-and-
drop operation

Register devices/labels from the program editor/label editor with the drag-and-drop operation.
Multiple devices/labels can be registered in batch by selecting a range.

Operation
• Select devices/labels to be registered to the Watch window, and drag and drop them on to 

the Watch window.

● Drag-and-drop operation of devices/labels to Watch window
The drag-and-drop operation of devices/labels to the Watch window can be performed only from the program editor or 
the label editor.

● Drag-and-drop operation of devices/labels from ladder editor
The drag-and-drop operation of devices/labels from the ladder editor can be performed when the cursor is changed to 

 as it is moved to within the selected range.

Drag and drop
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14.6.2  Registering devices

■ Registering devices/labels at cursor position automatically

Register devices/labels in the ladder block at the cursor position to the Watch window automatically by 
setting the option.
When this option is set, "(Ladder/SFC Automatic Registration)" is displayed on the title bar of Watch 
window.
The automatic registration to the Watch window can be executed when the program is written in Ladder 
Diagram or Sequential Function Chart.

Operation
1. Specify the automatic registration destination for "Setting for Automatic Registration to 

Watch Window" under [Tool] ⇒ [Options] ⇒ "Monitor" ⇒ "Ladder/SFC".

2. Open the Watch window which is specified as an automatic registration destination.

3. Select [Online] ⇒ [Watch] ⇒ [Start Watching].

4. Move the cursor to the ladder block which is to be registered to the Watch window.
Devices/labels in the ladder block at the cursor position are displayed on the Watch window 
which is specified as an automatic registration destination. The displayed devices/labels are 
overwritten with the devices/labels in the ladder block to which the cursor is moved.
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14.6.3 Changing display format (decimal/hexadecimal) of current 
values

Change the display format (decimal/hexadecimal) of the current values.

Operating procedure

• Right-click on the Watch window, and select [Change Value Format (Decimal)]/
[Change Value Format (Hexadecimal)] from the shortcut menu.

● Changing current values
The current value can be changed by entering a value directly in the "Current Value" column during monitoring. For bit 
devices, select a row and press the  and  keys or press the  key and double-click the row to change the 
current value.

● Displaying Watch window
If a registered device/label is a structure/function block/array label, the detail of the device/label is displayed in tree 
format.

Switch to the hexadecimal display Switch to the decimal display
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14.6.4  Writing/reading data to/from CSV file

14.6.4 Writing/reading data to/from CSV file

Write/read devices/labels registered to the Watch window to/from the CSV file.

Screen display
Right-click and select [Write to CSV File]/[Read from CSV File] from the shortcut menu.

Operating procedure

1. Enter a file name, or select a file to be opened.

2. Click the  button, or the  button.
The devices/labels are saved to the specified save destination, or the devices/labels are read from 
the specified location to the Watch window.
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14.7 Monitoring Intelligent Function Modules

For the method how to monitor input/output signals and buffer memory of intelligent function 
modules, refer to the following manual.
GX Works2 Version 1 Operating Manual (Intelligent Function Module)

14.8 Starting/Stopping Monitoring All Windows

This section explains how to start/stop monitoring all open windows.

Operating procedure

• Select [Online] ⇒ [Monitor] ⇒ [Start Monitoring (All Windows)]/[Stop Monitoring 
(All Windows)].

Remote HeadQ CPU L CPU FXFX

Remote HeadQ CPU L CPU FX
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15 - 1

15 SIMULATING 
PROGRAMS

This chapter explains how to debug programs offline using the simulation function.

15.1 Simulation Function 15 - 2

15.2 Starting/Stopping Simulation 15 - 4

15.3 Checking unsupported instructions/devices 15 - 9
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15.1.1  Safety and handling considerations of the simulation function

15.1 Simulation Function

*1 : Not supported by High-speed Universal model QCPU.

This section explains how to debug a sequence program offline using the virtual programmable 
controller, without connecting to the programmable controller CPU.
This function is useful to test programs before operating them actually on the programmable 
controller CPU.
For the considerations and restrictions on the simulation function, refer to Appendix 2.

15.1.1 Safety and handling considerations of the simulation 
function

The following explains the considerations of safety and handling of the simulation function.

1) The simulation function simulates the actual programmable controller CPU to debug a 
sequence program. However, this function does not guarantee the operation of the 
debugged sequence program.

2) The simulation function uses the memory for simulation to input and output data to/from 
the I/O module and intelligent function module. Some instructions/functions and device 
memory are not supported. Therefore, the operation results obtained with the virtual 
programmable controller may differ from those obtained using the actual programmable 
controller CPU.

After debugging programs using the simulation function, those programs must be debugged online before operating them 
actually on the programmable controller CPU.

15.1.2 Functions available for simulation function

The following table shows the GX Works2 functions that are available for the simulation function.

L CPU FXFXRemote FXHeadQ CPU

*1

Function Description Reference

Write to PLC Write parameter files and program files to the virtual programmable 
controller. Section 12.1

Online program change*1,*2 Write programs to a virtual programmable controller in RUN status. Section 12.9

Verify with PLC Verify data in the virtual programmable controller against project data. Section 12.2

Delete PLC Data For QCPU (Q mode)/LCPU, delete data in the virtual programmable 
controller. Section 12.3

Monitor Monitor the status of operation processing. Section 14.2

Monitor status Display the monitoring status of the virtual programmable controller. Section 14.1.2

Device memory/Buffer memory 
batch monitor

Batch-monitor the device memory/buffer memory of the virtual 
programmable controller. Section 14.3

Program list monitor For QCPU (Q mode)/LCPU, monitor the processing time of programs being 
executed on the virtual programmable controller. Section 14.4

Entry Ladder Monitor Register ladder blocks on the Entry Ladder Monitor screen, and monitor 
them. (Simple)
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Watch Register and monitors data such as virtual programmable controller devices. Section 14.6

Local Device Batch Read + 
Save CSV Read local device data and save them on a personal computer. Section 12.12

Device memory backup in 
simulation

Save and read device memory/buffer memory of the virtual programmable 
controller.

Section 15.2.1
Section 15.2.2

Modify value Modify the current value of the virtual programmable controller. Section 16.1

Forced input output registration/
cancellation

For QCPU (Q mode)/LCPU, register/cancel the forced input/output of X/Y 
devices of the virtual programmable controller. Section 16.2

Device Test with Execution 
Condition

For QCPU (Q mode)/LCPU, register devices of the virtual programmable 
controller to the device test with execution condition. Section 16.3

Sampling trace For QCPU (Q mode)/LCPU, trace the device value of the virtual 
programmable controller. Section 16.4

Step Execution*3 Debug the program by executing it partially. Section 16.6

Remote Operation Switch the execution status of the virtual programmable controller, such as 
STOP and PAUSE. Section 17.1

PLC Memory Operation Perform memory format, memory clear, memory arrangement for the virtual 
programmable controller.

Section 17.3
Section 17.4
Section 17.5

PLC Diagnostics Check the virtual programmable controller status and errors. Section 18.1

I/O System Setting Simulate operations of external devices using the virtual programmable 
controller. Chapter 19

*1 : The simulation function is not supported by FXCPU.
*2 : Online program change of SFC blocks is not supported.
*3 : Not supported by FXCPU.

Function Description Reference
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15.2 Starting/Stopping Simulation

*1 : Not supported by High-speed Universal model QCPU.

This section explains how to start/stop simulation.

Operating procedure

• Select [Debug] ⇒ [Start/Stop Simulation] ( ).
The GX Simulator2 screen is displayed, and the simulation starts.
To end the simulation function, select [Debug] ⇒ [Start/Stop Simulation] again.

<Simulating a single project>

<Simulating multiple projects>

Display contents

L CPU FXFXRemote FXHeadQ CPU

*1

QCPU(Q mode)/LCPU FXCPU

Item Description

Switch Display the operating status of the virtual programmable controller.

RESET*1

Select this to switch the operating status of the virtual programmable controller.STOP

RUN

LED

Display the operating status of the virtual programmable controller.
For details of the LED, refer to the following manuals.
● For QCPU (Q mode)/LCPU

User's Manual (Hardware Design, Maintenance and Inspection) of each CPU module
● For FXCPU

User's Manual - Hardware Edition of each FXCPU
HARDWARE MANUAL of each FXCPU
For the operating status error, the icon on the upper left corner of the screen is displayed in red.

*1 : Not supported by FXCPU.



15.2  Starting/Stopping Simulation

15 - 5

9

SE
TT

IN
G

 D
E

VI
C

E
 

C
O

M
M

EN
TS

10

S
EA

R
C

H
/R

EP
LA

C
E

11

SE
TT

IN
G 

PR
OG

RA
MM

AB
LE

 
CO

NT
RO

LL
ER

 C
PU

 
CO

NN
EC

TIO
N 

DE
ST

IN
AT

IO
N

12

W
R

IT
IN

G
/R

EA
D

IN
G

 
D

A
TA

13

PR
O

TE
C

TI
N

G
 

D
AT

A

14

M
O

N
IT

O
R

IN
G

15

S
IM

U
LA

TI
N

G
 

P
R

O
G

R
A

M
S

16

D
E

B
U

G
G

IN
G

 
P

R
O

G
R

A
M

S

Screen button
● /

Switches between display/hide of all project names during the simulation.

● Simulations of multiple projects
The maximum of 4 projects can be simulated simultaneously by starting the simulation of other project during the 
simulation.

● Simulation of FXCPU
For FXCPU, more than one project cannot be simulated simultaneously.

● Considerations when changing project names
If a project name is changed during the simulation, the project name on the GX Simulator2 screen is not changed. To 
display the changed project name on the GX Simulator2 screen, exit the simulation, and then start the simulation again.

● Minimized display at start up of simulation
By setting the option, the GX Simulator2 screen can be started up in minimized mode when the simulation is activated.
To start up the GX Simulator2 screen in minimized mode, select "Start in minimized status" from [Options] on the  GX 
Simulator2 screen. From the next start up, the  GX Simulator2 screen is not displayed but becomes in taskbar icon 
mode.

● Stopping the simulation
The simulation function may not be stopped by the GX Works2 simulation stop operation when another application 
such as MX Component is being connected to GX Simulator2. (GX Works2 is disconnected from GX Simulator2.)
The simulation function stops when another application is disconnected.
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15.2.1  Saving device memory/buffer memory

15.2.1 Saving device memory/buffer memory

Save device memory/buffer memory of the virtual programmable controller temporarily.

Operating procedure

1. Switch the operating status of the GX Simulator2 screen to STOP.

2. Select [Tool] ⇒ [Backup Device Memory in Simulation] ⇒ [Save] on the GX 
Simulator2 screen.

● Saving device memory/buffer memory when stopping simulation
By setting the option, device memory/buffer memory in the virtual programmable controller can be saved when the 
simulation is stopped.
To save device memory/buffer memory when the virtual programmable controller is stopped, select "Save device 
memory at stop" from [Options] on the GX Simulator2 screen.

15.2.2 Reading device memory/buffer memory

Read out the temporarily saved device memory/buffer memory to the virtual programmable controller.

Operating procedure

1. Switch the operating status of the GX Simulator2 screen to STOP.

2. Select [Tool] ⇒ [Backup Device Memory in Simulation] ⇒ [Read] on the GX 
Simulator2 screen.
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15.2.3 List of device memory/buffer memory that can be saved/read

This section explains device memory/buffer memory that can be saved and read with the virtual 
programmable controller.

■ Device memory that can be saved/read

The following table shows the list of device memory that can be saved/read.
● QCPU (Q mode)/LCPU

Category Type Device

Internal user device

Bit

X (DX)

Y (DY)

M

L

F

V

S

B

SB

T (contact)

ST (contact)

C (contact)

Word

T (current value)

ST (current value)

C (current value)

D (including Extended D)

W (including Extended W)

SW

Internal system device

Bit

FX

FY

SM

Word
FD

SD

Index register Word Z (including ZZ)

File register Word
R

ZR
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15.2.3  List of device memory/buffer memory that can be saved/read

● FXCPU

■ Buffer memory that can be saved/read

Buffer memory that can be saved and read is an memory area of modules to which the I/O assignment 
settings are configured in the PLC parameter.
For QCPU (Q mode), the buffer memory [U3E0 to U3E3\G0 to 4095] and the multiple CPU high-speed 
transfer area [U3E0 to U3E3\G10000 to 65535] on the programmable controller CPU cannot be saved/
read.
For LCPU/FXCPU, all buffer memory can be saved/read.

Category Type Device

Device

Bit

X

Y

M

S

T (contact)

C (contact)*1

*1 : High-speed counters (C235 and later) are not supported.

Word

T (current value)

C (current value)*1

D

Special device
Bit M (special M)

Word D (special D)

Index register Word
V

Z

Extended register Word R*2

*2 : Supported by FX3G, FX3GC, FX3U, and FX3UC only.
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15.3 Checking unsupported instructions/devices

*1 : Not supported by High-speed Universal model QCPU.

The following explains how to display a list of instructions and devices used in a program and not 
supported by the simulation function.

Screen display
Select [Debug] ⇒ [Instructions Unsupported by Simulation].

● Display of unsupported instructions
Unsupported instructions are not displayed when the programmable controller does not become in RUN status 
because of the CPU module error at the start of the simulation.
A status without a CPU module error is required for unsupported instructions to be displayed.

L CPU FXFXRemote FXHeadQ CPU

*1
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16 - 1

16 DEBUGGING PROGRAMS
This chapter explains how to debug sequence programs.

16.1 Changing Current Values 16 - 2

16.2 Registering/Canceling Forced Input/Output 16 - 6

16.3 Device Test with Execution Condition 16 - 9

16.4 Sampling Trace 16 - 13

16.5 Measuring Scan Time 16 - 32

16.6 Debugging Programs with Simulation Function 16 - 33

16.7 Using QnUDVCPU & LCPU Logging Configuration 
Tool 16 - 49
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16.1.1  Changing current value of devices/labels

16.1 Changing Current Values

This section explains how to change current device values of the programmable controller CPU in 
ladder and SFC (Zoom) programs.

The following explains how to turn ON/OFF forcibly the bit device on the programmable controller 
CPU from the monitoring screen and also changing the current value of the word device and buffer 
memory.

16.1.1 Changing current value of devices/labels

Screen display
Select [Debug] ⇒ [Modify Value] ( ).

Q CPU L CPU FXFXRemote FXHead

<For bit device> <For word device>
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Operating procedure

1. Set the items on the screen.

2. For bit devices, click the / /  button.
For word devices, click the  button.
The current value of the programmable controller CPU is changed, and the result is displayed in 
"Execution Result".

Restrictions

● Devices whose current values cannot be changed
The current values of indirectly specified devices (@D0) cannot be changed.

Item Description

Device/Label Display the device or label selected on the monitoring screen.
Also enter the device or label.

Data Type
Display the data type of the device or label.
Also select the data type from .

Value
(For word device)

Enter a new value according to the data type as shown below:

*1 : Not supported by FXCPU.

Data Type Entry

Word [Signed],
Double Word [Signed], 
Word [Unsigned]/Bit String [16-bit],
Double Word [Unsigned]/
Bit String [32-bit]

Enter a value in decimal or hexadecimal format.

FLOAT (Single Precision)

Enter a value in decimal or exponential form.
Example:
• Decimal form: -1.23456
• Exponential form: -1.23456E + 01

FLOAT (Double Precision)*1 Enter a value in decimal form.

String Enter a character string.
(Quotation marks (" ") are not necessary.)

Time
Enter a value in the time format.
• T#0s
(Applicable to Structured projects only)
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16.1.2  Changing current value of buffer memory

16.1.2 Changing current value of buffer memory

Screen display
Select [Debug] ⇒ [Modify Value] ( ).

Operating procedure

1. Set the items on the screen.

2. Click the  button.
The current value of the buffer memory is changed, and the result is displayed in "Execution 
Result".

Item Description

Module Start (HEX) Enter the start I/O number of the intelligent function module.

Address Enter the address of the intelligent function module.

Data Type
Display the data type of the buffer memory.
Also select the data type from .

Value

Enter a new value according to the data type as shown below.

*1 : Not supported by FXCPU.

Data Type Entry

Word [Signed],
Double Word [Signed],
Word [Unsigned]/Bit String [16-bit], 
Double Word [Unsigned]/Bit String [32-bit]

Enter a value in decimal or hexadecimal format.

FLOAT (Single Precision)

Enter a value in decimal or exponential form.
Example:
• Decimal form: -1.23456
• Exponential form: -1.23456E + 01

FLOAT (Double Precision)*1 Enter a value in decimal form.

String Enter a character string.
(Quotation marks (" ") are not necessary.)

Time
Enter a value in the time format.
• T#0s
(Applicable to Structured projects only)
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● Modify Value screen
• When the Modify Value screen is open, a device/label is displayed on the Modify Value screen if it is selected on the 

editor.
• The Modify Value screen of device/label and buffer memory can be switched by clicking tabs.

● Execution result of current value change
Display/hide of the execution result of current value change can be switched by / .
A device/label can be displayed in "Device/Label" area by selecting the device/label and clicking the 

 button or double-clicking it in "Execution Result".
● Selecting devices/labels used in instructions that handle multiple devices

When an instruction that uses multiple devices (such as FROM/TO instruction) is selected, all devices/labels used in 
the instruction are displayed in the "Device/Label" combo box.
Select a device from the combo box and then execute the Modify Value function.

● Forcibly turning contacts ON/OFF during the program monitoring
A contact can be forcibly switched ON/OFF by double-clicking the contact (or press the  key) while pressing the 
 key during the program monitoring.
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16.2.1  Registering/canceling forced input to/output from QCPU (Q mode)/LCPU

16.2 Registering/Canceling Forced Input/Output

*1 : Not supported by Basic model QCPU.

This section explains how to register/cancel the forced input/output of devices.
X/Y device can be forcibly turned ON/OFF without the effect of the input/output to/from external 
devices while the programmable controller CPU is in RUN status. This enables program debugs 
without external devices.

16.2.1 Registering/canceling forced input to/output from QCPU (Q 
mode)/LCPU

Screen display
Select [Debug] ⇒ [Forced Input Output Registration/Cancellation].

Operating procedure

1. Enter a device to be turned ON/OFF forcibly.
Clicking  enables to select a device from the list of previously entered ones.

2. Click the /  button.
The forced ON/OFF is registered to the programmable controller CPU.
The current registration status of the forced ON/OFF is displayed in the 'registration status display 
area'.

Remote HeadL CPU FXFXQ CPU

*1

Registration status 

display area
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Screen button

●

Cancels the forced ON/OFF of a device registered to the programmable controller CPU.

●

Reads the registration status from the programmable controller CPU.

●

Cancels all forced input/output registered to the programmable controller CPU.

● Canceling registration
The device registration can be canceled by placing the cursor on the device area in the registration status display area 
and pressing the  key.

● Device forced input/output registration
The status of the device forced input/output registration may be changed by GX Works2 or external devices that can 
register/cancel such as forced input/output, for the exclusion control is not executed on the programmable controller 
CPU side.

● Forced ON/OFF status
The ON/OFF status can be inverted by double-clicking the ON/OFF cell.

● Closing the Forced Input Output Registration/Cancellation screen
The following message is displayed when the  button is clicked on the Forced Input Output Registration/
Cancellation screen.

Click the  button to cancel all forced input/output registrations.

Double-click
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16.2.2  Registering/canceling forced input to/output from remote I/O module

16.2.2 Registering/canceling forced input to/output from remote I/O 
module

Screen display
Select [Debug] ⇒ [Forced Input Output Registration/Cancellation].

Operating procedure

• Click the /  button.
A disabled/enabled refresh of X/Y device is registered to the remote I/O module.
The current registration status of disabled/enabled refresh is displayed in the 'registration status 
display area'.

Screen button

●

Reads the current registration status of the remote I/O module.

●

Cancels all disabled refreshes registered to the remote I/O module.

● Connection route in which forced input/output registration/cancellation can be performed
In order to use this function on remote I/O module, the connection route must be set to "Serial Port NET/10(H) Remote 
Module Connection".

Registration status 

display area
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16.3 Device Test with Execution Condition

*1 : Universal model QCPU only.

This section explains how to change device value at the execution of programs and steps specified in 
advance.
This enables debugs of specific ladder blocks without changing programs.
This function can be executed only in a ladder program of Simple project.

16.3.1 Registering device test with execution condition

Register the device test with execution condition.

Screen display
Select [Debug] ⇒ [Device Test with Execution Condition] ⇒ [Register].

FXFXHeadRemoteQ CPU

*1

L CPU

<For bit device> <For word device>
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16.3.1  Registering device test with execution condition

Operating procedure

1. Set the items on the screen.

2. For bit devices, click the /  button.
For word devices, click the  button.
The device/label is registered to the device test with execution condition.

● Registering devices
• Up to 32 devices can be registered.
• The registration of the device test with execution condition is canceled by performing the following operations.

• Online program change of the program in the range which includes the specified step
• Write to PLC

• A box with the specified color appears at the instruction of the specified step.
(Changing colorSection 3.2.7)

• The device value is changed at the specified step regardless of whether the instruction of the specified step is 
executed.

Item Description

Device/Label Display the device or label selected on the monitoring screen.
Also enter the device or label.

Data Type
Display the data type of the device or label.
Also select the data type from .

Value (For word device)

Enter a new value according to the data type as shown below.

Execute 
Condition

Program Name Specify the program name for the timing of the forced ON/OFF and current value 
change.

Step No. Specify the step number in the program for the timing of the forced ON/OFF and 
current value change.

Execution 
Timing

Select 'before' or 'after' the instruction in the step number in the program for the timing 
of the forced ON/OFF and current value change.

Data Type Entry

Word [Signed],
Double Word [Signed],
Word [Unsigned]/Bit String [16-bit],
Double Word [Unsigned]/Bit String [32-bit]

Enter a value in decimal or hexadecimal 
format.

FLOAT (Single Precision)

Enter a value in decimal or exponential 
form.
Example:
• Decimal form: -1.23456
• Exponential form: -1.23456E + 01

FLOAT (Double Precision) Enter a value in decimal form.

String
Enter a value as a character string. 
(Quotation marks (" ") are not 
necessary.)

Time
Enter a value in the time format.
• T#0s
(Applicable to Structured projects only)
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16.3.2 Checking/disabling registration of device test with execution 
condition

Check the registration of the device test with execution condition, write it to a file, read it out from a file, 
and disable it.

Screen display
Select [Debug] ⇒ [Device Test with Execution Condition] ⇒ [Registration Check/Disable].

Display contents

Screen button

●

Reads the registration information from the programmable controller CPU.

●

Disables the registration selected in 'registration information list'.

●

Registers the registration information data to the programmable controller CPU in batch.

●

Disables the registration information data on the programmable controller CPU in batch.

●

Reads the registration information list from a file.

●

Saves the registration information data being displayed in 'registration information list' to a file.

Registration

information

list

Item Description

Status of Displayed Data Display whether the data being displayed is read from the programmable 
controller CPU or from a file.

Registration information list Display the registration of the device test with execution condition. Display up to 
32 records.
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16.3.3  Batch disabling device test with execution condition

● Checking/disabling the device test with execution condition
• The registration of devices specified in the device test with execution condition can be checked/disabled on the 

monitor screen of the ladder editor. Right-click on a device and select [Debug] ⇒ [Check Register Device Test with 
Execution Condition]/[Disable Register Device Test with Execution Condition] from the shortcut menu.

• Other than the above operation, registrations of device test with execution condition are canceled by the following 
operations.
• Reset or turn from OFF to ON the programmable controller CPU.
• Perform the Online program change including the specified step.
• Write the program file to the program memory of the programmable controller CPU while the programmable 

controller CPU is in STOP status.
• Delete the program file in the program memory of the programmable controller CPU while the programmable 

controller CPU is in STOP status.
• Format the program memory of the programmable controller CPU while the programmable controller CPU is in 

STOP status.

16.3.3 Batch disabling device test with execution condition

Batch disable the registered device test with execution condition.

Operating procedure

• Select [Debug] ⇒ [Device Test with Execution Condition] ⇒ [Batch Disable].
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16.4 Sampling Trace

*1 : Not supported by Basic model QCPU and Q00UJ.

This section explains the operation of the sampling trace function.
The sampling trace function acquires the data at the preset timing to find how device values change 
during program operation and traces the changes by displaying them in time series.
For details of the sampling trace function, refer to the manual of each CPU module.

16.4.1 Opening sampling trace screen

Operating procedure

• Select [Debug] ⇒ [Sampling Trace] ⇒ [Open Sampling Trace].

● Devices displayed with red background
When devices or data types which cannot be used in a new programmable controller CPU type are contained in the 
sampling trace data after the Change PLC Type operation, they are displayed with red background.
Modify them to devices appropriate for the new programmable controller CPU type, and execute the sampling trace 
again.

FXFXHeadRemoteL CPUQ CPU

*1
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16.4.2  Setting executing condition of sampling trace

16.4.2 Setting executing condition of sampling trace

The following explains the settings required for executing sampling trace and the execution method.

■ Setting sampling trace execution method and data storage destination

Set the sampling trace execution method and the storage destination of the trace data.

Screen display
Select [Debug] ⇒ [Sampling Trace] ⇒ [Trace Setting] ( ) ⇒ <<Setting of Executing and 
Saving>>.

Operating procedure

• Set the items on the screen.

Item Description

Trace Execution Method Set the trace execution method.

Execute after overwriting current trace 
settings in the PLC

Select this to execute sampling trace after overwriting the current trace 
setting to the programmable controller CPU.

Execute using existing trace settings 
in the PLC

Select this to execute sampling trace using the trace setting stored on the 
programmable controller CPU.

Trace Data (setting+result) Storage Set the memory and the file name where the trace data set on the 
<<Condition Setting>> tab and the trace result after execution are stored.

Trace Auto Startup Setting
Select this to perform the sampling trace automatically when the 
programmable controller CPU is in RUN. (Universal model QCPU/LCPU 
only*1)

*1 : For the versions of Universal model QCPU that support this function, refer to the User's Manual (Function 
Explanation, Program Fundamentals) of the CPU module to be used.
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■ Setting sampling trace conditions

Set the sampling trace conditions such as the number of traces and the trigger condition.

Screen display
Select [Debug] ⇒ [Sampling Trace] ⇒ [Trace Setting] ( ) ⇒ <<Condition Setting>>.
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Operating procedure

• Set the items on the screen.

Item Description

Trace Count Setting
Set the number of data acquisitions (samplings) before and after the trigger.
Select a value using the combo box or enter a value directly.
Setting range: Count Before Trigger < Total Count <= 8192

Additional Information Set the information to be added to the trace result.

Time Add the time of the trace start.

Program Name Add the name of the program in which the sampling trace is executed.

Data Acquisition Timing Setting Set the trace data acquisition timing.

Each Scan Select this to acquire the data every scan.

Specified Interval Select this to acquire the data in the set intervals. The setting unit is 1ms.

Each Multiple CPU
High Speed Transfer 
Cycle*1

*1 : For Universal model QCPU only

Select this to acquire the data in the Each multiple CPU high-speed transfer cycle.

Detail Setting
Select this to set the data acquisition timing depending on the device condition.

Use the  button to set the conditional expression.

Trigger Condition Setting Set the trigger (condition) that is taken as the start point (0 point) of sampling trace 
execution.

At the Time of Trace 
Instruction Execution

Select this to generate a trigger when the TRACE instruction in the program is 
executed.
For the TRACE instruction, refer to the following manual.
(MELSEC-Q/L Programming Manual (Common Instructions)

At the Time of Manual 
Trigger Execution

Select this to generate a trigger manually with GX Works2. Select [Debug] ⇒ [Sampling 
Trace] ⇒ [Execute Manual Trigger] to generate a trigger.

Detail Setting

Select this to set a trigger timing depending on the device condition. A trigger is 
generated when the conditional expression is satisfied.

Use the  button to set the conditional expression.
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Screen button

●

Displays the Detail Setting screen.
Setting of the conditional expression can be changed in the Data Get Timing screen or the Trigger 
Condition screen.

Operation
• Set the items on the screen.

<Trigger Condition><Data Get Timing>

Item Description

Device /Label Enter a device, address or label. Section 16.4.6

Device Display the device corresponds to "Device /Label".

Address*1 Display the address corresponds to "Device /Label".

Comment Display the device comment of "Device /Label".

Condition

Select the timing condition.
• For the data get timing setting

The data are collected at the end processing of one scan or when the condition of the specified 
device/label is satisfied.

• For the trigger condition setting
Satisfaction of the condition of the specified device/label becomes a trigger.

Radix Select the radix of the condition value. (Word device only)

Values Set the condition value. (Word device only)

*1 : For Structured projects only
*2 : For Universal model QCPU/LCPU only

Device Condition Description

Bit device
↑ Collect data at the rising of the specified device/label.

↓ Collect data at the falling of the specified device/label.

Word device
= Collect data when the current value of the specified device becomes 

the specified condition value.

Change*2 Collect data when the current value of the specified device changes.

Device Condition Description

Bit device
↑ Consider the rising of the specified device/label as a trigger.

↓ Consider the falling of the specified device/label as a trigger.

Word device
= Consider the time when the current value of the specified device 

becomes the specified condition value as a trigger.

Write data*2 Consider the time when data are written to the specified device/
label as a trigger.
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16.4.3 Registering devices/labels

Register the devices/labels on the Sampling Trace screen.

Operating procedure

• Register the devices/labels to which the sampling trace is performed.
Devices/labels can be registered by entering them directly or copying them from the program editor 
or label editor by the drag-and-drop operation.

Display contents

● Editing with a selection of two or more rows
Two or more rows can be selected by pressing the  key or the  key to copy or delete.
When non-consecutive rows are selected by pressing the  key and copied, blank rows are deleted when the 
selected rows are pasted.
Multiple rows cannot be selected during the sampling trace execution.

Display title

Item Description

Display title -

Device/Label
Set the device, address, label, structure, array, and function block to which the sampling trace 
is performed.
50 bit devices and 50 word devices can be registered.

Device*1

*1 : Items can be displayed by selecting [View] ⇒ [Switching Display Items].

Display the device corresponds to "Device /Label".

Address*1, *2

*2 : For Structured projects only

Display the address corresponds to "Device /Label".

Comment*1
Display the device comment for the address or device/label which are entered in "Device/
Label".

Data Type*1 Display the data type of "Device/Label".
The data type of the word device can be changed after registration.

Radix*1

If the device entered in "Device/Label" is the bit device, the radix is fixed as "Binary". If the 
device entered in "Device/Label" is the word device, the radix can be selected from "Binary", 
"Decimal", "Hexadecimal" or "ASCII". If the device entered in "Device/Label" is the single-
precision/double-precision real number, the radix is fixed as "FLOAT".

Vertical Axis Display the time axis data of the selected cell as displaying the trace result.
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■ Changing data types of word devices

For word devices, data type can be changed after registration.
When the data type of a device/label that uses the multiple devices is changed, the necessary devices 
are displayed in the tree format.
Example:
Changing data type of D10 from "Word [Signed]" to "Double Word [Signed]"

Restrictions

● When 'Double Word'/'FLOAT (Single Precision)'/'FLOAT (Double Precision)' is set to "Data Type"
The data acquired by the sampling trace function may become inconsistent.

Change to double
word (signed)
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■ Registering devices/labels from program editor/label editor with drag-and-
drop operation

Register a device/label from the program editor/label editor with the drag-and-drop operation. Multiple 
devices/labels can be registered in batch by selecting a range.

● Drag-and-drop operation of data from ladder editor

The drag-and-drop operation of data from the ladder editor can be performed when the cursor is changed to  as it is 
moved to within the selected range.

<Ladder editor>

Select the device, instruction 
and ladder block.

<Structured Ladder/FBD editor>

Select the device and
ladder block.

<ST editor>

Select the device and line.

<Label editor>

Select the device by a unit of row.

The device is registered at the cursor position.

Activate the window by placing the cursor on the Sampling Trace tab while dragging 
the data, and drop the data on the Sampling Trace screen.

Drag & drop
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16.4.4 Executing sampling trace

Operating procedure

• Select [Debug] ⇒ [Sampling Trace] ⇒ [Start Trace] ( ).
Sampling trace starts.
The Trace Data Storage Status screen is displayed when the sampling trace is started.

After the stop or completion of sampling trace, the trace result is displayed on the Sampling Trace 
screen.

Trance data file name

Item Description

Total Data

Display the current status of data acquisition (sampling) after the start of sampling trace in 
percentage in reference to the number of times set for "Trace Setting".
Even after this status reaches 100%, sampling trace is continuously executed and the 
data are overwritten from the oldest data.

Data After Trigger
Display the current status of data acquisition (sampling) after the generation of trigger in 
percentage in reference to the number of times set for "Trace Setting".
When this status reaches 100%, sampling trace stops.

Trace data file name Display the trace data file name that is registered for the sampling trace on the 
programmable controller CPU.

Display title
Timing chart scale Trigger position

Trend graph

Trend graph registration target
Vertical axis
information 
line

Chart

Currently selected number of data acquisitions
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Display contents

● Starting sampling trace from sequence program
Select [Debug] ⇒ [Sampling Trace] ⇒ [Register Trace].
To start sampling trace, execute the Trace start command (SM801) in a program.

● Displaying only the trace result stored on the programmable controller CPU without executing sampling trace
Select [Debug] ⇒ [Sampling Trace] ⇒ [Read from PLC]. (Section 16.4.5)

● Word devices whose data types can be changed after sampling trace results are displayed
The type of a word device can be changed to the double word type or the real type, only when the consecutive devices 
with the required points are registered as the trace data.

Example) If the sampling trace is performed to D0, D1, D2, and D3, the data type of D0 can be changed to the 
double word type.
If the data type of D2 is changed to the data type that uses multiple devices, such as the double word and 
single-precision real number, the data type of D0 cannot be changed as it has no consecutive 4-words 
devices.

● Performing sampling trace from other peripherals during performing sampling trace
For Universal model QCPU/LCPU, the sampling trace currently being performed can be stopped by other peripherals 
and perform another sampling trace. When the sampling trace is performed by other peripherals, select [Debug] ⇒ 
[Sampling Trace] ⇒ [Forced Execution Registration Effective] to activate the forced registration.

● Trace ready status (SM800) after sampling trace is completed
In GX Developer, the trace ready status (SM800=1) is held until the trace results are read, even if the sampling trace is 
completed. In GX Works2, the trace results are automatically read and displayed when the sampling trace is 
completed, and then the trace ready status (SM800=0) is canceled.

Item Description

Display title -

Vertical Axis Display the device value of the selected cell position, on the 'vertical axis information line'.

Currently selected 
number of data 
acquisitions

Indicate the number of data acquisitions on the column selected with the vertical axis 
information line.
The line can be moved to the selected number of data acquisitions by entering a value.

Chart Display the acquired data in chart.

Timing chart scale

One block corresponds to one data acquisition. The number of scale indicates the number of 
data acquisitions.
To change the display width, select [View] ⇒ [Timing Chart Scale] ⇒ [-: Narrow Scale] ( )/[+: 
Wide Scale] ( ), or move a scroll wheel on a mouse while pressing the  key.

Trigger position A red mark is displayed at the position corresponding to the trigger generated timing on the 
timing chart scale when a trigger is generated.

Vertical axis information line

This line is displayed at the position where a cell is selected on the chart in yellow.
The device value on the vertical axis information line is displayed in cells under "Vertical Axis".
When the vertical axis information line is double-clicked, the data at the right side of the line 
are displayed on the sampling trace (detailed data) screen.
■ Switching screen to the sampling trace (detailed data) screen

Trend graph registration target

Register the selected word device to the trend graph.
Deregister them by clearing the check box.
When the selected status is changed while two or more rows are selected, the change applies 
to the selected status of all the selected rows.

Trend graph Display the changes of the word device values on the trend graph.
■ Displaying trace results on trend graphs
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■ Switching screen to the sampling trace (detailed data) screen

Display the device/label value change in numeric values.

Screen display
● Click the tool button  (Switch Chart/Detail).

The sampling trace (detailed data) screen is displayed.
Click the tool button  (Switch Chart/Detail) again to switch to the chart.

Display contents

Detailed data

Additional information

Item Description

Additional information
Display the additional information set for "Additional Information" on the <<Condition Setting>> 
tab on the Trace Setting screen.
Select [View] ⇒ [Additional Information] ⇒ [Past Time]/[Program Name].

Detailed data

Confirm the device values.
In the case of a bit device, '*' is displayed for ON, nothing is displayed (blank) for OFF.
In the case of a word device, numeric values are displayed.
The registered "Device /Label" are linked with the Sampling Trace screen (chart).
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■ Displaying trace results on trend graphs

Display the changes of the word device values on the trend graph.

Operating procedure

• Select the check box(es) of the 'trend graph registration target' on the Sampling 
Trace screen.
The selected word device is registered on the trend graph.
Clear the check box to cancel the registration on the trend graph.

Display contents

● Wide/narrow scales of trend graphs
Place the cursor at the base point to widen/narrow, and select [View] ⇒ [Trend Graph Scale] ⇒ [-: Narrow Scale] ( )/
[+: Wide Scale] ( ) or move a scroll wheel on a mouse while pressing thekey. The widened/narrowed graph with 
the specified base point as the center is displayed.
Select [View] ⇒ [Trend Graph Scale] ⇒ [Initial Display] to recover the display to the initial state.

● Moving trend graphs
Double-click the trend graph to move the graph up or down with the double-clicked point as the center.

Trend graph registration target

Trend graph line color

Item Description

Trend graph line color

Change the background color of cell under 'trend graph line color' to the line color of the trend 
graph.
Double-click the cell, and the Color screen is displayed to allow changing of the trend graph 
line color.

Narrow scale

Wide scale
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16.4.5 Saving trace data

Save the trace data of sampling trace (sampling trace target devices/labels, trace setting, and trace 
results) on a personal computer or a programmable controller CPU.

■ Saving trace data on personal computer

Save the trace data on a personal computer in the CSV file format.
The menu item of the function cannot be selected when a trace result does not exist.

Operating procedure

1. Select [Debug] ⇒ [Sampling Trace] ⇒ [Export CSV Data].
The Export CSV Data screen is displayed.

2. Enter the file name to be saved.

3. Select the file type.
For checking the trace setting or the trace result using Excel, select "GX Works2 format CSV file".
For checking the trace result read by using GX LogViewer, select "GX LogViewer format CSV file".

4. Click the  button.
The trace data is saved on the personal computer.
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● Checking triggers in CSV file
For the trace numbers of the sampling trace when the trace data are output to the file selected for "GX Works2 format 
CSV file", the number at the time of the trigger execution is set to 0, and the numbers are displayed with the negative 
values for the numbers before the trigger execution and positive values for the numbers after the trigger execution.

Example) If M0, which was obtained at the fifth time after the trigger execution, is ON, M0 with the trace number '4' is 
displayed as 'ON' in the CSV file.

When the trace data are output to the file selected for "GX LogViewer format CSV file", "*" is displayed on the data rows 
at the time of the trigger execution.

● Display of CSV files opened in Excel
To display the file selected for "GX Works2 format CSV file" in Excel similar to the display of the sampling trace result, 
copy the devices and the range of the result, select "Transpose" in "Paste Special", and then paste them on to Excel.

● Display of Counter (C), Timer (T), and Retentive timer (ST)
When the file selected for "GX LogViewer format CSV file" is read in GX LogViewer, device names are displayed in the 
format displayed on the Sampling Trace screen. Therefore, as shown in the following table, the display of device names 
differs between the file selected for "GX LogViewer format CSV file" and the CSV file output using the logging 
configuration tool.

File selected for "GX LogViewer 
format CSV file"

CSV file output using the logging 
configuration tool

T (Current value) T

T (Contact) TS

T (Coil) TC

C (Current value) C

C (Contact) CS

C (Coil) CC

ST (Current value) ST

ST (Contact) SS

ST (Coil) SC

Before trigger execution

After trigger execution
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■ Formatting CSV files

Saved CSV files are displayed as shown below when they are opened by Excel.
● Example of "GX Works2 format CSV file"

● Example of "GX LogViewer format CSV file"
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■ Writing/reading trace data to/from programmable controller CPU

Write/read the trace data to/from a programmable controller CPU.

Operating procedure

• Select [Debug] ⇒ [Sampling Trace] ⇒ [Read from PLC]/[Write to PLC].
The Write to PLC function writes the trace data to the target memory set on the <<Setting of 
Executing and Saving>> tab on the Trace Setting screen.

● Reading trace data to programmable controller CPU
The word data, which was read by the Read from PLC function, is read as the word (signed) type regardless of the data 
type settings at the time of writing the data.
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16.4.6 Applicable devices/labels for sampling trace

■ List of applicable devices for sampling trace

: Applicable ×: Not applicable

Category Device type Device Sampling 
trace screen

Data 
acquisition 

timing

Trigger 
condition

Internal user device

Input X *1 *1 

Output Y *1 *1 

Internal relay M *1 *1 

Latch relay L *1 *1 

Annunciator F *1 *1 

Edge relay V *1 *1 

Step relay S × × ×

Link relay B *1 *1 

Link special relay SB *1 *1 

Timer

Current value T   

Contact TS *2 *2 *2

Coil TC *2 × ×

Counter

Current value C   

Contact CS *2 *2 *2

Coil CC *2 × ×

Retentive 
timer

Current value ST   

Contact STS *2 *2 *2

Coil STC *2 × ×

Data register D *1 *1 *1

Link register W *1 *1 *1

Link special register SW *1 *1 *1

Internal system device

Function input FX   

Function output FY   

Special relay SM *1 *1 

Function register FD *1 *1 *1

Special register SD *1 *1 *1

Link direct device

Link input J\X *1 *1 ×

Link output J\Y *1 *1 ×

Link register J\W *1 *1 ×

Link special register J\SW *1 *1 ×

Link relay J\B *1 *1 ×

Link special relay J\SB *1 *1 ×

File register File register
R *1 *1 *1

ZR *1 *1 *1

Index register Index register
Z   ×

ZZ × × ×

Intelligent function 
module device

Intelligent function module device U\G *1 *1 ×

Cyclic transmission area device U3E\G *1 *1 ×

Nesting Nesting N × × ×
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16.4.6  Applicable devices/labels for sampling trace

■ Applicable label types for sampling trace

Pointer
Pointer P × × ×

Interrupt pointer I × × ×

Others

SFC block device BL × × ×

SFC transition device TR × × ×

Network number specified device J × × ×

I/O number specified device U × × ×

Macro instruction argument 
device VD × × ×

Constant

Decimal constant K × × ×

Hexadecimal Constant H × × ×

Real constant

Single-precision 
floating-point data E × × ×

Double-precision 
floating-point data E × × ×

String constant "" × × ×

*1 : Following modification settings are applicable.
• Digit-specified bit device (K1 to K8 and K1 to K4 can be used for the Sampling Trace screen and data acquisition 

timing respectively.)
• Bit-specified word device
• Index setting (not available under the trigger condition)

*2 : For Structured projects only

Category Device type Device Sampling 
trace screen

Data 
acquisition 

timing

Trigger 
condition

Label type Description Example

Global label*1

*1 : The following data types are applicable.
Bit, Word [Signed], Word [Unsigned], Word [Unsigned]/Bit String [16-bit], Double Word [Signed], Double Word 
[Unsigned]/Bit String [32-bit], FLOAT (Single Precision), FLOAT (Double Precision), Timer, Counter, Retentive 
Timer

Register and display as 'label name'. Label1

Local label*1 Register and display as 'program/label name'. POU_01/
Label1

Structure*1 Register and display as 'label name.member name'.
Register all members when the whole structure labels are registered. G_data.AAA

Function block*1
Register and display as 'instance name.label name in function block'.
Register all labels in the function block when the whole instances 
(function blocks) are registered.

FB_01.IN01

Array*1

Register and display as 'label name [one-dimensional element number] 
[two-dimensional element number] [three-dimensional element 
number]'.
Register all elements/all members when the whole array labels are 
registered.

Array[0,0,0]

Structure array*1

Register and display as 'label [one-dimensional element number] [two-
dimensional element number] [three-dimensional element number]. 
member name'.
Register and display arrays when the structure contains member labels 
of arrays.
Register all elements/all members when the whole structure array labels 
are registered.

Array2[0,0,0].
AAA

Nested function block*1

Register and display as 'instance name.label name in function 
block.label in nested function block'.
Register and display structures when the nest function block contains 
structure labels.
Register all labels in the instance when the whole instances (nested 
function blocks) are registered.

FB1_01.FB2_ 
01.Label1
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16.4.7 Considerations when performing sampling trace

The following explains the considerations when performing the sampling trace.

● When files for both local device and trace data exist in standard RAM
Perform the following operation to change the local device when the files for both the local device and 
trace data exist in the standard RAM.
If the following operation is not performed, the files for the trace data may be deleted.

Operation
1. Select [Debug] ⇒ [Sampling Trace] ⇒ [Read from PLC].

Read the file for trace data from the standard RAM.

2. Change the settings for the local device, and write the changes to the programmable 
controller CPU.

3. Select [Debug] ⇒ [Sampling Trace] ⇒ [Write to PLC].
Write the file for the trace data, which was read in the procedure 1, to the standard RAM.

16.4.8 Compatibility with sampling trace data in GX Developer

The sampling trace data which are saved by "Trace settings file operation" using GX Developer cannot 
be read in GX Works2.
The sampling trace data which are set in GX Works2 cannot be saved as the format that can be read in 
GX Developer.

Perform the following operation when utilizing the sampling trace data.

● Utilizing GX Developer sampling trace data in GX Works2

Operation
1. Write the sampling trace data, which are set in GX Developer, to the programmable 

controller CPU.
Perform the "Write to PLC" function of "Trace settings PLC operation" in GX Developer.

2. Read the sampling trace data from the programmable controller CPU in GX Works2.
Select [Debug] ⇒ [Sampling Trace] ⇒ [Read from PLC] in GX Works2.

● Utilizing GX Works2 sampling trace data in GX Developer

Operation
1. Write the sampling trace data, which are set in GX Works2, to the programmable 

controller CPU.
Select [Debug] ⇒ [Sampling Trace] ⇒ [Write to PLC] in GX Works2.

2. Read the sampling trace data from the programmable controller CPU in GX Developer.
Perform the "Read from PLC" function of "Trace settings PLC operation" in GX Developer.
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16.5 Measuring Scan Time

*1 : Not supported by Basic model QCPU.

This section explains how to measure the initial, current, maximum, and minimum scan time for a 
user-defined section of a ladder or SFC program.
The processing time can be measured even in subroutines and interrupt programs.
This function can be performed in Simple projects only.

Screen display
Select [Debug] ⇒ [Scan Time Measurement].

Operating procedure

1. Set the items on the screen.

2. Click the  button.
The first value, current value, maximum value, and minimum value are measured.
0.000ms is displayed when the measured time is shorter than 0.100ms.
For Universal model QCPU, the scan time 0.001ms or longer can be measured.

● Scan time measurement range
• By selecting a range on the ladder editor/SFC diagram editor and selecting [Debug] ⇒ [Scan Time Measurement], 

the selected range can be set to "Start Step" and "End Step".
• For a ladder program, when a step specified as "Start Step" or "End Step" exists in the ladder program, the 

measurement range is set in units of ladder blocks which include the selected range.

FXFXHeadRemoteL CPUQ CPU

*1

Item Description

Measurement Limit Set the measurement range.

Program Name Display the name of the program being opened.

Block No.*1

*1 : SFC programs only

Display the SFC block number.

Block Name*1 Display the SFC block name.

Start Step Set the start step.
For SFC program, set the SFC step number.

End Step Set the end step.
For SFC program, set the SFC step number.



16.6  Debugging Programs with Simulation Function

16 - 33

9

SE
TT

IN
G

 D
E

VI
C

E
 

C
O

M
M

EN
TS

10

S
EA

R
C

H
/R

EP
LA

C
E

11

SE
TT

IN
G 

PR
OG

RA
MM

AB
LE

 
CO

NT
RO

LL
ER

 C
PU

 
CO

NN
EC

TIO
N 

DE
ST

IN
AT

IO
N

12

W
R

IT
IN

G
/R

EA
D

IN
G

 
D

A
TA

13

PR
O

TE
C

TI
N

G
 

D
AT

A

14

M
O

N
IT

O
R

IN
G

15

S
IM

U
LA

TI
N

G
 

P
R

O
G

R
A

M
S

16

D
E

B
U

G
G

IN
G

 
P

R
O

G
R

A
M

S

16.6 Debugging Programs with Simulation Function

This section explains how to debug programs with the simulation function.
This function is supported only by ladder and ST programs of Simple project.
The following table shows the main step execution functions.

The following are program editors in a debugging process with the step execution functions.

Q CPU L CPU FXRemote FXHead FXFX

Item Description

Break execution Execute a program until set break conditions are satisfied.
Break conditions are set with break points or break devices.

Step execution Execute a program one step at a time.

Partial execution Execute a program partially from the specified point.
A partial execution is executed by executing a break execution with set break points and break devices.

<Example of step execution in ladder program>

<Example of step execution in ST program>
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● Online functions which can be performed during step execution
The RUN/STOP status of monitor status becomes STEP-RUN ( ) when the step execution is executed.
The following are the Online functions which can be performed when the monitor status is STEP-RUN.
• Write to PLC function (SFC file batch online program change is not supported.)
• Verify with PLC function
• Remote operation
• Delete PLC Data function

● Editing programs during step execution
For ladder programs, programs can be edited even when the step execution is being executed.
Note that, however, when the step execution is executed in the status in which the program in GX Works2 and the 
program in the virtual programmable controller do not match, then the step execution function is executed on the 
program in the virtual programmable controller as the basis. Therefore, the cursor position of canceled position may be 
displayed at a different position.

● Ladder blocks with yellow background
In a ladder program, the step execution may not be executed normally in ladder blocks with yellow background which 
indicates a program cannot be displayed as a ladder program.

● Programs with "Standby" execution type
The step execution cannot be executed on programs in which "Standby" is set for execution type in the program 
setting.
However, the step execution can be executed on a program in which the execution start position is set for "From 
current cursor position" in the execution option setup (Section 16.6.8), and the cursor is positioned in a program in 
which "Standby" is set.
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Restrictions

● Restrictions after setting break conditions and skip range
All settings of break condition and skip range are canceled when a data name or a library name is changed/deleted in a 
project.

● Break in ST control syntax
The following are the considerations when executing the step execution on an ST program contains ST control syntax.
• A break execution may be executed in a line of control syntax which is not calculated.

When the step execution is executed on the following program in which W10=0 is set for the break condition, the 
break execution is executed in the 6th line. Note that, however, since a calculation is not processed in the line where 
the break execution is executed, this break does not affect the calculation result.

• In step execution, a break execution is not executed in a RETURN syntax and an EXIT syntax.
When the step execution is executed on the following program, the break execution is not executed in the 3rd and 4th 
lines even if the break condition is satisfied.

● Step execution on successive function blocks
When function blocks are used successively in the ST program, even if a step execution is canceled in the process of 
the function blocks, the canceled-position cursor may be placed at one step before the next function block instruction.
The following program is an example when a step execution is canceled in the process of the successive function 
blocks.

● When using the same function blocks multiple times
When the step execution is executed, a break position may move to the first instance at the timing of entering the 
second and the following instances. This phenomenon occurs when the instance created from the same function block 
in the program file is used multiple times.

ST line number ST program Operation

1 FOR W10 := 0 TO 3 DO –

2   CASE W10 OF –

3     0: –

4       D0 := D0 + 1; –

5     1..3: –

6       D1 :=D1 +1; When W10=0, this line is not processed but the break execution is 
executed.

7   END_CASE; –

8 END_FOR; –

ST line number ST program Operation

1 W0 := 0; –

2 IF X0 THEN –

3   RETURN;
The break execution is not executed in the RETURN syntax when 
X0=ON in the step execution. (The break execution is executed in 
the first line.)

4 END_IF; –

5 –

6 FOR W0 := 0 TO 4 DO –

7   IF X1 THEN –

8     EXIT;
The break execution is not executed in the EXIT syntax when 
X1=ON in the step execution. (The break execution is executed in 
the 11th line.)

9   END_IF; –

10 END_FOR; –

11 W0 := 0; –
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16.6.1  Debugging procedure

16.6.1 Debugging procedure

The following flow chart explains the procedure to debug programs.

*1 : Section 15.2
*2 : Section 16.6.2
*3 : Section 16.6.3
*4 : Section 16.6.4
*5 : Section 16.6.6
*6 : Section 16.6.7
*7 : Section 16.6.5
*8 : Section 16.6.9

No

Yes

Yes

No

Yes

No

Is break condition satisfied?

Start

Cancel the program execution at 
a specified timing. 
Check the settings of break points 
and break devices.

End

Was the problem solved?

Start the simulation. *1)(

Set break devices.

*3)(

Execute the break execution.

*5)(

Stop the step execution.

*8)(

Execute the step execution.

*7)(

End the simulation.

*1)(

Set break points.

*2)(

Set a skip range.

*4)(

Is the setting of the break 
condition completed?

*6)(
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16.6.2 Setting break points

By setting a break point, a step execution can be canceled at a specific position in a program.
Break points are set in: step unit for ladder program, and line unit for ST program.
Break points can be set up to 64 points in an entire project.

■ Setting/canceling break points

Set/cancel break points.

Operating procedure

1. Move the cursor to the position to set a break point or cancel the set break point.

2. Select [Debug] ⇒ [Break Setting] ⇒ [Set/Cancel Break Point] ( ).
A break point is set at the cursor position. When the break point is already set, it is canceled.
Set break points are registered on the Break Point window.

● When break point overlaps with other indications
When a break point overlaps with a canceled-position cursor on the ladder editor, the canceled-position cursor is 
displayed as a priority. When a break point overlaps with other indications such as a skip range and mixed color is 
displayed at the overlapped position.
The following program is an example of overlapped indications.

<Example of break points (for ladder)>

<Example of break points (for ST)>

A break point which overlaps with a canceled-position cursor

A break point which overlaps with a skip range
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16.6.2  Setting break points

■ Enabling/disabling break points

Enable/disable set break points.
The break point function is executed at the position with enabled break point.
The break point function is not executed when the break point is disabled.

Operating procedure

1. Move the cursor to the break point to be enabled/disabled.

2. Select [Debug] ⇒ [Break Setting] ⇒ [Enable/Disable Break Point] ( ).
The break point at the cursor position is enabled/disabled.

■ Canceling all break points

Cancel all break points.

Operating procedure

• Select [Debug] ⇒ [Break Setting] ⇒ [Cancel All Break Points] ( ).
All break points are canceled.

<Example of disabled break point (for ladder program)>

Disabled break point

<Example of disabled break point (for ST)>

Disabled break point
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■ Setting break conditions on Break Point window

Display a list of set break points.
Set break conditions and the number of execution counts for break points.

Screen display

Select [View] ⇒ [Docking Window] ⇒ [Debug] ⇒ [Break Point] ( ).

Operating procedure

• Set the items on the screen.

Item Description

Enable/Disable
Display enabled/disabled status of break points.

: Enabled
: Disabled

Data Name Display program names to which break point is set.

Position
Display positions of set break points in a program.
For ladder program: Step numbers displayed on the editor.
For ST program: Line numbers

Program Content

Display program content of set break points.
For ladder program: Instructions (list format), pointers (P), or interrupt 
pointers (I)
For ST program: Text

Break Condition Set break conditions.
This item can be set for ladder programs only.

Always Execute the break execution when scans are completed for a set number of 
times.

ON Execute the break execution when the specified step/pointer is ON after 
scans are completed for a set number of times.

OFF Execute the break executions when the specified step/pointer is OFF after 
scans are completed for a set number of times.

Rising Execute the break execution when the specified step/pointer turns ON from 
OFF after scans are completed for a set number of times.

Falling Execute the break execution when the specified step/pointer turns OFF from 
ON after scans are completed for a set number of times.

Execution Count Set the number of scans until break execution is executed.
This item can be set for ladder programs only.
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16.6.2  Setting break points

Screen button

●

Jumps to the selected break point.

●

Enables/disables the selected break point.

●

Cancels the selected break point.

●

Cancels all break points.

● Counting and resetting number of execution counts
The number of execution counts is counted/reset according to the following rules.
• When two or more break points are passed in one scan, the passed number of times is counted as the number of 

execution counts.
• Break points which are not passed by an instruction such as the jump instruction are not counted as the number of 

execution counts.
• The execution count of all break points is reset for each break.
• When changing the number of execution counts, the corresponding execution count of break point is reset.
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16.6.3 Setting break devices

By setting a break device, a step execution can be canceled when the value of device/label satisfies the 
specific condition.
Break devices can be set up to 16 points in total of bit devices and word devices.
When a break device is set, a break execution is executed at the instruction which is the one after the 
execution of the calculation to satisfy the break condition.
In order to execute the break execution after the break condition is satisfied, disable or cancel the break 
devices.

■ Setting/canceling break devices

Set/cancel break devices, or enable/disable set break devices.
The break device function is executed at the position with enabled break device.
The break device function is not executed when the break device is disabled.

Screen display

Select [View] ⇒ [Docking Window] ⇒ [Debug] ⇒ [Break Device] ( ).

Break device information list
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16.6.3  Setting break devices

Operating procedure

1. Click the  button.
A blank row is added to the last row of the break device information list.

2. Set the items on the screen.

Screen button

●

Cancels the selected break device.

●

Cancels all break points.

■ Canceling all break devices

Cancel all break devices.

Operating procedure

• Select [Debug] ⇒ [Break Setting] ⇒ [Cancel All Break Devices] ( ).
All break devices are canceled.

Item Description

Combination –

Judge each break device (OR 
condition)

Select this to execute the break execution when any condition of break 
devices is satisfied.

Judge all break devices (AND 
condition)

Select this to execute the break execution when conditions of all break 
devices are satisfied.

Enable/Disable
Enable/disable the break device.
Selected: Enabled
Cleared: Disabled

Comparative Source (Device/Label) Enter the comparative source device/label.
For a local label, enter data in a 'program name/label name' format.

Condition
Select the comparative condition.
The condition selection changes according to the comparative source device/
label.

Rising Execute the break execution when the comparative device/label rises.

Falling Execute the break execution when the comparative device/label falls.

= Execute the break execution when the value of comparative source device/
label matches with the value of comparative target device/label.

< Execute the break execution when the value of comparative source device/
label is smaller than the value of comparative target device/label.

> Execute the break execution when the value of comparative source device/
label is larger than the value of comparative target device/label.

<= Execute the break execution when the value of comparative source device/
label is the same as or less than the value of comparative target device/label.

>=
Execute the break execution when the value of comparative source device/
label is the same as or more than the value of comparative target device/
label.

<> Execute the break execution when the value of comparative source device/
label does not match with the value of comparative target device/label.

Comparative Target (Value/Device/Label) Enter a comparative target device/label.

Comparative Type Set the data type to compare comparative source and comparative target.
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16.6.4 Setting skip ranges

A skip range is a range in which a program will not be executed during the step execution. A range can 
be set in ladder block unit for ladder programs.
Up to 16 ranges can be set in a project.

■ Setting/canceling skip ranges

Set a skip range, or cancel the set skip range.

Operating procedure

1. Select a ladder block to set a skip range.
Multiple ladder blocks can be selected by selecting a range.

2. Select [Debug] ⇒ [Skip Setting] ⇒ [Set/Cancel Skip Range] ( ).
The skip range is set. When the skip range is already set, it is canceled.
Multiple skip ranges set within the selected ladder blocks are all canceled.
Set skip ranges are registered on the Skip Range window.

● Skip range setting in ST programs
Skip ranges cannot be set in ST programs.

● When skip range overlaps with other indications
When a skip range overlaps with other indications such as a break point and mixed color is displayed at the overlapped 
position.

■ Enabling/disabling skip ranges

Enable/disable the skip range at the cursor position.
The program of the ladder block with enabled skip range is not executed.
When the skip range is disabled, the program of the ladder block with set skip range is also executed.

Operating procedure

1. Move the cursor to the skip range to be enabled/disabled.

2. Select [Debug] ⇒ [Skip Setting] ⇒ [Enable/Disable Skip Range] ( ).
The skip range at the cursor position is enabled/disabled.

<Example of skip range>

<Example of disabled skip range>
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16.6.4  Setting skip ranges

■ Canceling all skip ranges

Cancel all skip ranges.

Operating procedure

• Select [Debug] ⇒ [Skip Setting] ⇒ [Cancel All Skip Ranges] ( ).
All skip ranges are canceled.

■ Displaying Skip Range window

Display a list of set skip ranges.

Screen display

Select [View] ⇒ [Docking Window] ⇒ [Debug] ⇒ [Skip Range] ( ).

Display contents

Screen button

●

Jumps to the start position of the selected skip range.

●

Enables/disables the selected skip range.

●

Cancels the selected skip range.

●

Cancels all skip ranges.

Item Description

Enable/Disable
Enable/disable the skip range.

: Enabled
: Disabled

Data Name Display the program name to which the skip range is set.

Start Display the start position of the skip range with a step number.

End Display the end position of the skip range with a step number.
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16.6.5 Executing program one step at a time

Execute programs one step at a time.

Operating procedure

• Select [Debug] ⇒ [Step Execution] ⇒ [Step Execution] ( ).
One instruction of a program is executed for ladder program, and one line of a program is executed 
for ST program.
When the step execution is executed on a function block in the program, the step execution is 
executed on the program in the function block.
The canceled-position cursor is displayed on the function block while the step execution is being 
executed on the program in the function block.

16.6.6 Executing program until condition is satisfied

Execute a program until the condition is satisfied.

Operating procedure

• Select [Debug] ⇒ [Step Execution] ⇒ [Break Execution] ( ).
When the break condition is satisfied, the break execution is stopped.

● When multiple break conditions are satisfied simultaneously
When the conditions of break point and break device are satisfied simultaneously, the Break Point window is activated 
and the cursor moves to the break point where the condition is satisfied.
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16.6.7  Canceling step execution

16.6.7 Canceling step execution

Cancel the step execution.

Operating procedure

• Select [Debug] ⇒ [Step Execution] ⇒ [Cancel] ( ).
The step execution is canceled.
The canceled-position cursor is displayed at the canceled position.

● Canceled-position cursor
The canceled-position cursor is displayed on the program editor in which the step execution is executed as described 
below.
• The step execution is canceled.
• The step execution completed without satisfying the break condition.
• The break condition is satisfied and the step execution is canceled.

<Example of canceled-position cursor (for ladder program)>

Canceled-position cursor

<Example of canceled-position cursor (for ST)>

Canceled-position cursor
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16.6.8 Setting options for step execution

Set options for the step execution function.
Set the start position of the step execution and the setting for the automatic step execution.

Screen display

Select [Debug] ⇒ [Step Execution] ⇒ [Execution Option] ( ).

Operating procedure

1. Set the items on the screen.

2. Click the  button.

Item Description

Execution Start Position
Set the execution position of the step execution.
The setting will be changed depending on the last operation that is 
performed. For details, refer to Point in this section.

From start Execute the step execution from the start of the program according to the 
setting set on the <<Program>> tab of PLC parameter.

From canceled position Execute the step execution from the canceled position.

From current cursor position

Execute the step execution from the current cursor position on the active 
program editor.
When the program editor is not active, the operation is the same as that of 
"From start".

Automatic Step Execution –

Execute step execution automatically
Select this to execute the step execution automatically.
The automatic step execution is executed by executing the step execution 
after setting this item.

Repetition Count

Set the number of times the step execution is executed automatically.
When this item is blank, the step execution is executed repeatedly until the 
break condition is satisfied or the step execution is canceled.
This item is applicable when "Execute Step execution automatically" is 
selected.

Execution Interval
Set the cycle of automatic step execution in 100ms unit.
This item is applicable when "Execute Step execution automatically" is 
selected.
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16.6.9  Stopping step execution

● Setting execution start position
The setting of the execution start position will be changed depending on the last operation that is performed.
The following table shows the execution start position corresponding to the operation that is performed.

16.6.9 Stopping step execution

Stop the step execution.

Operating procedure

• Select [Debug] ⇒ [Step Execution] ⇒ [Stop] ( ).
The step execution is stopped.
The canceled-position cursor on the program editor is hidden.

Last-performed operation Execution Start Position

Simulation start, step execution stop From start

Cancellation, break execution, step execution From canceled position
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16.7 Using QnUDVCPU & LCPU Logging Configuration Tool

This section explains how to start QnUDVCPU & LCPU Logging Configuration Tool from the menu of 
GX Works2.
To start QnUDVCPU & LCPU Logging Configuration Tool, install the logging configuration tool in 
advance.
For the installation and operation methods, refer to the following manual.
QnUDVCPU/LCPU User's Manual (Data Logging Function)

Screen display
Select [Tool] ⇒ [Logging Configuration Tool].

● Supported versions of logging configuration tool
Install the logging configuration tool version 1.26C or later for High-speed Universal model QCPU.

Q CPU L CPU FXRemote FXHead
*1 *2

*2 : Not supported by L02S.
*1 : High-speed Universal model QCPU only
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17 - 1

17 OPERATING 
PROGRAMMABLE 
CONTROLLER CPU

This chapter explains how to change the execution status and setting the clock of the programmable 
controller CPU from GX Works2.

17.1 Remote Operation of Programmable Controller CPU 17 - 2

17.2 Operating Redundant CPUs 17 - 6

17.3 Formatting Programmable Controller CPU Memory 17 - 8

17.4 Clearing Programmable Controller Memory 17 - 10

17.5 Arranging Programmable Controller Memory 17 - 13

17.6 Setting Clock on Programmable Controller CPU 17 - 14

17.7 Registering/Canceling Display Module Menu 17 - 16

17.8 Start Ethernet Adapter Module Configuration Tool 17 - 18
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17.1 Remote Operation of Programmable Controller CPU

This section explains how to switch the RUN/STOP status of the programmable controller CPU and 
allowing the memory card removal from GX Works2.

Screen display
Select [Online] ⇒ [Remote Operation].

HeadQ CPU L CPU FXFXRemote

<High Performance model QCPU>

<Redundant CPU>

<FXCPU>
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Operating procedure

1. Set the items on the screen.

2. Click the  button.
The operating status of the programmable controller CPU is changed.

Item Description

Connection Channel List Display the information of the connection destination.

Specify Execution 
Target*1,*2 Set the target station of remote operation.

Currently Specified 
Station

Select this to perform the remote operation only on the station specified in the connection 
destination setting.

All Stations
Select this to perform the remote operation on the station specified in the connection 
destination setting and all the stations on the same network.
Set a target network with "Specify Module No."*3 or "Specify Network No.".

Specified Group

Select this to perform the remote operation on the station specified in the connection 
destination setting and each station of the specific group on the specified network.
Set a target network with "Specify Module No." or "Specify Network No.", and set a group 
number with "Specify Group No.".

Specify both systems
Select this to perform the remote operation on the both systems (control system and standby 
system) with the route specified on the Transfer Setup screen. This item is applicable to 
Redundant CPU only.

Operation Select the operation details.

RUN

Select this to switch the operating status of the programmable controller CPU.

STOP

PAUSE*2

Latch Clear*2

RESET*2

Remove Memory 
Card*2, *3 Select this to remove the memory card while the programmable controller CPU is ON.

Operation during RUN*2 Set the status of the device memory and signal flow when the programmable controller CPU 
is switched to RUN.

Device Memory Select whether to clear the device memory.

Signal Flow Select whether to retain the signal flow.

Redundant status*2,*3 Display the operation mode and system status of Redundant CPU. This item is applicable to 
Redundant CPU only.

*1 : When the target network is CC-Link IE Field Network, the target station can be specified with "Currently Specified 
Station" and "All Stations".

*2 : Not supported by FXCPU.
*3 : Not supported by LCPU.
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● Remote operation and RUN/STOP switch for QCPU (Q mode)/LCPU
When operation to the programmable controller CPU differs among controls by the remote operation, RUN/STOP 
switch, and remote RUN/PAUSE contact, the programmable controller CPU operates according to the priority shown 
below:

The following table shows the operating status after RUN/STOP switching on the programmable controller CPU or 
remote RUN/PAUSE contact operation.

● Remote reset operation on Redundant CPU
A remote reset operation on Redundant CPU may not be performed depending on the status of the control system or 
the standby system.
The following table shows the CPU status at a remote reset operation and the operation results.

: Applicable
×: Not applicable

● Considerations for removing a memory card
Turn OFF SM605 to allow the memory card removal.
If the memory card is removed when not allowed, the programmable controller CPU becomes in an error status.

Operation to the programmable controller CPU Priority

STOP 1

PAUSE 2

RUN 3

-
Programmable controller CPU switch Remote RUN/STOP contact is ON.

(The programmable controller CPU is in STOP.)RUN STOP

Remote 
operation

RUN RUN STOP STOP

STOP STOP STOP STOP

PAUSE PAUSE STOP STOP

Latch clear Inoperable*1

*1 : Operable when the programmable controller CPU is switched to STOP by remote operation.

Latch clear Latch clear

RESET*2

*2 : The remote reset operation must be enabled on the <<PLC System>> tab of PLC parameter.

Inoperable*1 RESET RESET

Current redundant CPU status Remote reset operation result

Control system status Standby system status Control system Standby system

RUN/PAUSE
RUN/PAUSE

×
×

STOP*1/Stop error 

STOP*1/Stop error
RUN*2/PAUSE


×

STOP*1/Stop error 

*1 : A remote reset operation cannot be performed when a remote operation is performed on a Redundant CPU from other 
GX Works2.

*2 : A system switch occurs and the system is activated.
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● Counting modules to set "Specify Module No."
Physically count the module from the programmable controller side, and specify the number.
However, note that the target modules to be counted are MELSECNET/H network modules and CC-Link IE Controller 
Network modules only. Do not include other modules such as Ethernet modules, CC-Link master/local modules, and 
CC-Link IE Field Network modules.
The following figure shows an example of counting modules.

● Remote operation of FXCPU
M8035 (forced RUN mode), M8036 (forced RUN command), and M8037 (forced STOP command) are controlled.
The remote operation is possible regardless of the status of the programmable controller CPU side RUN/STOP switch.
Programmable controller CPUs that support the remote operation are as follows:
FX1S, FX1N, FX2N, FX1NC, FX2NC, FX3G, FX3GC, FX3U, and FX3UC

Restrictions

● Performing remote operation on other stations
When performing the remote operation on other stations with "All Stations" or "Specified Group", the remote operation 
cannot be performed on the following modules.
• ACPU/QnACPU
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: Q series-compatible E71

: MELSECNET/H network module

: CC-Link IE Controller Network module

: CC-Link IE Field Network module

Ethernet   

MNET/10(H)   

CC IE Field   

CC IE Control

<Terms on the figure>
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17.2 Operating Redundant CPUs

*1 : Redundant CPU only

This section explains how to switch the system, change the operation mode, and copy memory data 
from the control system to the standby system from GX Works2.
This function cannot be performed in the debug mode.

Screen display
Select [Online] ⇒ [Redundant Operation].

Operating procedure

1. Set the items on the screen.

2. Click the  button.

FXFXHeadRemoteQ CPU

*1

L CPU

Item Description

Connection channel list Display the information of the specified connection target.

Redundant operation Select a redundant operation to be performed.

System switching Change the system of the current connection target from the control system to the standby 
system.

Change operation 
mode

Change the operation mode on the current connection target.
The mode can be changed from backup mode to separate mode, and vice versa.

Copy memory Copy data of standard RAM, standard ROM, and program memory from the control system 
to the standby system.

Memory copy progress 
status

Display memory copy progress.
"Memory copy failed" is displayed when the memory copy fails.

Redundant status Display the operation mode and the system status of Redundant CPU.
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● Considerations of memory copy function
The following functions cannot be performed on the control system while the memory copy function is being performed.
• Writing data to a running CPU.
• Writing data to a programmable controller CPU (flash ROM)
• Switching systems
• Changing operation mode
• Copying memory data in a redundant operation
• Formatting programmable controller CPU memory
• Copying program memory data to ROM
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17.3 Formatting Programmable Controller CPU Memory

This section explains how to format the programmable controller CPU memory or the memory card.
The function is used when using the programmable controller CPU and the memory card for the first 
time or clearing all data stored in them.
However, the Flash card cannot be formatted using this function. (Flash cards do not require 
formatting.)

Screen display
Select [Online] ⇒ [PLC Memory Operation] ⇒ [Format PLC Memory].

Operating procedure

1. Set the items on the screen.

2. Click the  button.
The target memory is formatted.

HeadQ CPU L CPU FXRemote FXFX

Item Description

Connection Channel List Display the information of the connection destination setting.

Target Memory Set the memory to be formatted.

Format Type Select the format type.

Do not create a user setting system area (the 
required system area only) Select this to create the necessary system area only.

Create a user setting system area
Select this to create the necessary system area, the area for high-
speed monitoring from another station, and the area for enabling 
Online program change of multiple blocks.
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■ Format types

The system area is an area created on the programmable controller CPU memory. The system area 
consists of the 'Necessary system area' automatically created upon formatting the programmable 
controller CPU memory and 'User setting system area' created by the user.
In the necessary system area, data such as local devices are stored.

The user setting system areas are set for the following purposes:

● Area for enabling high-speed monitoring from another station
The area is set to accelerate monitoring from peripheral such as GX Works2 connected to a serial 
communication module and other communication module.
Change the capacity according to the number of device points (capacity) to be monitored through a 
serial communication module or other communication module and the volume of other user data to 
be stored in the program memory.
The setting range for Basic model QCPU, and Universal model QCPU (Q00UJ/Q00U/Q01U) is 0 to 
3k steps.
The setting range for High Performance model QCPU, Process CPU, Redundant CPU, Universal 
model QCPU (except for Q00UJ/Q00U/Q01U), and LCPU is 0 to 15k steps.

● Area for enabling Online program change of multiple blocks
This area is set to enable Online program change of multiple locations (multiple blocks) 
simultaneously.
The following table shows the restrictions on Online program change of multiple blocks according to 
the capacity.
Since 4k steps are secured automatically other than for the program memory, this setting is not 
required for Universal model QCPU and LCPU.

● Device memory
The device memory values cannot be cleared with the Memory format function.
To clear the device memory values, execute [Online] ⇒ [PLC Memory Operation] ⇒ [Format PLC Memory]. 
(Section 17.4)

● Formatting a memory card
To format an SRAM card, ATA card or SD memory card to be used on the programmable controller CPU, select 
[Online] ⇒ [PLC Memory Operation] ⇒ [Format PLC Memory].
If it is formatted using other functions such as the Windows®, the card may not be usable when it is installed to a 
programmable controller CPU.

● Memory in which user setting system areas can be created
The areas can be created only in the program memory.

Description

Secured system area capacity for Online program change of multiple blocks

Basic model QCPU
High Performance model QCPU/

Process CPU/Redundant CPUFunction 
version A Function version B or later

– 0k steps 1.25k steps 2.5k steps 0k steps 2k steps 4k steps

The number of blocks for 
simultaneous writing

Online program 
change of 
multiple blocks 
is not possible.

Online 
program 
change of 
multiple 
blocks is 
not 
possible.

Max. 32 
blocks

Max. 64 
blocks

Online 
program 
change of 
multiple 
blocks is 
not 
possible.

Max. 32 
blocks

Max. 64 
blocks

The number of steps per 
block for writing

Max. 512 
steps

Max. 1024 
steps

Max. 512 
steps

Max. 1024 
steps

The number of used 
pointers (P, I) per block 
for writing

Not limited Max. 50 Max. 100
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17.4 Clearing Programmable Controller Memory

This section explains how to initialize device memory data on the programmable controller CPU and 
file registers stored in the memory card and setting them to '0'.

■ QCPU (Q mode)/LCPU

Initialize device memory data on the programmable controller CPU and file registers stored in the 
memory card and set them to '0'.
However, the memory clear function is not available for standard ROM/Flash cards/SD memory cards.

Screen display
Select [Online] ⇒ [PLC Memory Operation] ⇒ [Clear PLC Memory].

Operating procedure

1. Set the items on the screen.

2. Click the  button.
The target memory data is cleared.

Q CPU L CPU FXFXRemote FXHead

Item Description

Connection Channel List Display the information of the connection destination setting.

Clear Device's whole Memory Select this to clear the device memory data.

Include Latch Select this to clear device data in the latch range also.
The device data for which latch clear is disabled is also cleared.

Clear all File Registers Select this to clear the file register data.

Target Memory*1 Select the memory in which file registers are stored.

All Files*1 Select this to clear all file registers in the target memory.

Specific File*1 Select this to clear the selected file register memory.
Select a file name of the file register.

*1 : For QCPU (Q mode) only



17.4  Clearing Programmable Controller Memory

17 - 11

17

O
P

E
R

A
TI

N
G

 
PR

O
G

R
A

M
M

AB
LE

 
C

O
N

TR
O

LL
E

R
 C

P
U

18

DI
AG

NO
SI

NG
 

PR
OG

RA
M

M
AB

LE
 

CO
NT

RO
LL

ER
 S

TA
TU

S

19

SI
M

U
LA

TI
N

G
 

O
PE

R
AT

IO
N

S 
O

F 
EX

TE
R

N
AL

 D
EV

IC
ES

20

P
R

IN
TI

N
G

21

S
E

TT
IN

G
 O

P
TI

O
N

S

22

U
S

IN
G

 L
IB

R
A

R
IE

S

A

A
PP

E
N

D
IX

I

IN
D

EX

● Operation of the PLC Memory Clear function during the monitoring of local devices
When the "Clear Device's whole Memory" operation is executed during the monitoring of local devices, local devices 
are cleared in the programs selected in the 'local device monitoring target selection field'.

■ FXCPU

Initialize device memory data in FXCPU and resetting them to '0'.

Screen display
Select [Online] ⇒ [PLC Memory Operation] ⇒ [Clear PLC Memory].

Operating procedure

1. Set the items on the screen.

2. Click the  button.
The target data is cleared.

Item Description

Connection Channel List Display the information of the connection destination setting.

Target Data Select the device memory to be cleared.

PLC Memory
Select this to clear all data.
(Programs, comments, parameters, file registers, device memory, and extended file 
registers)

Data Device
Select this to clear all registers.
(Data registers, file registers, RAM file registers, special registers, extended registers, 
and extended file registers)

Bit Device
Select this to clear all bit devices.
(X, Y, M, S, T, and C)
Additionally, the current values of 'T' and 'C' are reset to '0'.
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● Executing condition of the memory clear for FXCPU

● Considerations when using FXCPU
• Execute this function when the programmable controller CPU is in STOP status. Memory data cannot be cleared in 

RUN status.
• When the status of the programmable controller CPU is changed to STOP by the remote operation, bit devices 

cannot be cleared. Execute the PLC memory clear function after switching the status of the programmable controller 
CPU to STOP.

• When the PLC memory clear function is executed while an FX3G/FX3GC programmable controller CPU and an 
Ethernet port are connected directly, a communication error caused by Windows Firewall may occur.
In this case, open the Control Panel and specify GX Works2 as an 'allowed program' or 'exception' in the Windows 
Firewall setting.

Item Memory

PLC memory

Available for the built-in memory, and RAM/EEPROM (PROTECT switch OFF)/FLASH memory 
(PROTECT switch OFF) cassette.
Not available for the EEPROM (PROTECT switch ON)/FLASH memory (PROTECT switch ON) and 
EPROM cassette.

Data device Equivalent to executing condition to PLC memory

Bit device Available for all the memory.
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17.5 Arranging Programmable Controller Memory

This section explains how to secure consecutive free memory areas by arranging the data stored in 
program memory/standard RAM of the programmable controller CPU or memory card.
Use this function to rearrange files whose arrangement became discontinuous by operations such as 
Delete PLC Data.
However, the Memory arrangement function is not available for standard ROM/Flash cards/SD 
memory cards.

The following figure shows how consecutive free areas are created with the Memory arrangement 
function after Delete PLC Data.

Screen display
Select [Online] ⇒ [PLC Memory Operation] ⇒ [Arrange PLC Memory].

Operating procedure

1. Set the items on the screen.

2. Click the  button.
The target memory is arranged.

Q CPU L CPU FXRemote FXHead FXFX

Program A

8K

Program B

6K

Program C

6K

Free area

8K

28K
Delete PLC data

(Delete program B.)

Total free space

Maximum consecutive 

free space

8K

8K

Program A

8K

Free area

6K

Program C

6K

Free area

8K

Memory format

Total free space

Maximum consecutive 

free space

14K

 8K

Program A

8K

Program C

6K

Free area

14K

Total free space

Maximum consecutive 
free space

14K
14K

Item Description

Connection Channel List Display the information of the connection destination setting.

Target Memory Set the memory to be arranged.
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17.6 Setting Clock on Programmable Controller CPU

This section explains how to set the clock on a programmable controller CPU.
The clock setting function is not supported by FX0S, FX0, and FX1.

Screen display
Select [Online] ⇒ [Set Clock].

Operating procedure

1. Set the items on the screen.

2. Click the  button.
The programmable controller CPU clock is set.

Screen button

●

Applies the time of personal computer to the 'date and time' boxes.

Q CPU L CPU FXFXRemote FXHead

Date and time

Item Description

Date and time Set the date and time.

Specify Execution 
Target*1,*2 Set the target station whose clock is to be set.

Currently Specified 
Station Select this to set the clock only upon the station specified in the connection destination setting.

All Stations
Select this to perform the remote operation to the station specified in the connection destination 
setting and all the stations on the specified network.
Set a target network with "Specify Module No."*3 or "Specify Network No.".

Specified Group

Select this to perform the remote operation to the station specified in the connection destination 
setting and each station of the specific group on the specified network.
Set a target network with module mounted on the station specified in the connection 
destination setting for "Specify Module No." or "Specify Network No.", and set a group number 
with "Specify Group No.".

*1 : Not supported by FXCPU.
*2 : The target station can be specified with "Currently Specified Station" or "All Stations" when the target network is CC-

Link IE Field Network.
*3 : Not supported by LCPU.
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● Clock setting for QCPU (Q mode)/LCPU
For QCPU (Q mode)/LCPU, the clock setting can be set regardless of the ON/OFF status of the clock setting device 
'SM1028'.
Note that the ON/OFF status of 'SM1028' does not change upon clock setting.

● Considerations of the clock setting
In the clock setting, a time-lag error may appear due to the span of transfer.

● Counting modules to set "Specify Module No."
Refer to Point in Section 17.1.

Restrictions

● Performing clock setting to other stations
When performing the clock setting to other stations with "All Stations" or "Specified Group", the clock setting cannot be 
performed to the following modules.
• ACPU/QnACPU
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17.7 Registering/Canceling Display Module Menu

*1 : Not supported by L02S.

This section explains how to register/cancel menu items to/from a standard ROM or SD memory card 
to operate the intelligent function modules using the LCPU display module.
Use this function to confirm or change each setting of intelligent function module by operating the 
display module.
For details of functions and operations of display module, refer to the following manual.
MELSEC-L CPU Module User’s Manual (Function Explanation, Program Fundamentals)

For details of intelligent function modules which support registration/cancellation of display module 
menu, and functions which can be performed on each intelligent function module, refer to the 
following manual.
Manual of the intelligent function module to be used

Screen display
Select [Online] ⇒ [Register/Cancel Display Module Menu].

Operating procedure

1. Set the items on the screen.

2. Click the  button.
The display module menu items are registered/canceled.

Q CPU L CPU FXRemote FXHead
*1

Item Description

Target Memory Select the target memory to which the display module menu items are to be 
registered/canceled.

Register/Cancel Menu Select registration/cancellation of the menus.

Target Module Select the target module of the menu items to be registered.

Menu Language Select the language of the menu items.
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● Modules and corresponding GX Works2 versions
The following table shows the modules and corresponding GX Works2 versions for registering/canceling the display 
module menu.

Module type Module name Version

Analog L60AD4
L60DA4 GX Works2 Version 1.24A

Temperature control

L60TCTT4
L60TCTT4BW
L60TCRT4
L60TCRT4BW

GX Works2 Version 1.62Q

Counter LD62
LD62D GX Works2 Version 1.31H

Serial communication LJ71C24
LJ71C24-R2 GX Works2 Version 1.24A

CC-Link LJ61BT11
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17.8 Start Ethernet Adapter Module Configuration Tool

This section explains how to start the Ethernet adapter module configuration tool.
For details of Ethernet adapter module configuration tool, refer to the following manual.
CC-Link IE Field Network Ethernet Adapter Module User’s Manual

Operating procedure

1. Select [Tool] ⇒ [Ethernet Adapter Module Configuration Tool].
The Ethernet Adapter Module Configuration Tool screen is displayed.

2. Enter the IP address or domain name of the Ethernet adapter module to 
"Connection Destination", and click the  button.
A default web browser is activated and a start screen of the Ethernet adapter module configuration 
tool is displayed.

Q CPU L CPU FXRemote FXHead FXFX
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18 - 1

18 DIAGNOSING 
PROGRAMMABLE 
CONTROLLER STATUS

This chapter explains how to display system status and error codes of the programmable controller 
CPU.

18.1 Diagnosing Programmable Controller CPU 18 - 2

18.2 Diagnosing MELSECNET 18 - 12

18.3 Diagnosing CC-Link IE Controller Network 18 - 26

18.4 Diagnosing CC-Link IE Field Network 18 - 36

18.5 Diagnosing CC-Link and CC-Link/LT 18 - 49

18.6 Diagnosing Ethernet 18 - 62

18.7 Executing Sensor/Device Monitor 18 - 84

18.8 System Monitor 18 - 85

18.9 Changing Modules Online 18 - 100

18.10 Built-in I/O Module Tools 18 - 102
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18.1.1  Diagnosing QCPU (Q mode), LCPU, communication head module, and remote I/O module

18.1 Diagnosing Programmable Controller CPU

This section explains how to display system status and error codes of the programmable controller 
CPU.

18.1.1 Diagnosing QCPU (Q mode), LCPU, communication head 
module, and remote I/O module

Display the programmable controller CPU status.

Screen display
Select [Diagnostics] ⇒ [PLC Diagnostics]. 

Remote HeadQ CPU L CPU FXFX

<QCPU (Q mode)>

<LCPU>

CPU operating status

Image of programmable 

controller CPU

CPU operating status

Image of programmable 

controller CPU
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CPU operating status

Image of programmable 
controller CPU

CPU operating status

Image of programmable 
controller CPU

<Communication head module>

<Remote I/O module>
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18.1.1  Diagnosing QCPU (Q mode), LCPU, communication head module, and remote I/O module

Display contents

Item Description

Monitor Status Display the current monitor status.

Connection Channel List Display the connection route which has been set.

CPU operating status

● Single CPU system
Display the operating status and switch status of the programmable controller CPU.
For Redundant CPU, an enable/disable state of manual switching and a tracking 
communication status are also displayed.

● Multiple CPU system (QCPU (Q mode) only)
Display the operating status and the switch status of CPU No. 1 to No. 4.

• "Uninstallable/Blank" is displayed for a slot with no module mounted.

Image of programmable controller CPU Perform online operations of the programmable controller CPU.
(For details, Section 18.1.4 "Online operations")

Error Information Select this to display the current error information of the programmable controller 
CPU.

Continuation Error Information*1

*1 : For High-speed Universal model QCPU and LCPU only

Select this to clear user specified errors and minor errors.

To clear errors, select the errors and click the  button.

PLC Status Information

Select this to display the status information of the programmable controller CPU.
Display contents differ according to the programmable controller CPU.
QCPU (Q mode)/LCPU

Communication head module/Remote I/O module

Serial Communication Error*2

*2 : For Q00UJ/Q00U/Q01U/Q02U/QnUD(H)CPU only

Monitor the programmable controller CPU when the serial communication function is 
set.
Error information is cleared by clicking the  button.

Change the window size and position 
after error jump

Select this to downsize the PLC Diagnostics screen and move it to the upper left of the 
entire screen when the error jump is executed.

Error History Display the latest error history by clicking the  button.

Occurrence Order Display Sorts error history in ascending/descending order.

Status Icon Legend Display the status icons on the screen.
(Section 18.1.3 "Error icons")
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Screen button

●

Displays the illustration of the connection route which has been set.

● /  (Not supported by communication head module and remote I/O 
module)
Jumps the screen display to the sequence program step number corresponding to the selected error 
item/error history item.
However, jump is not applicable in the following cases.
• The error is not a program error.
• The error step information does not exist.
• The information of the program number and SFC step number of SFC block or the transition 

number does not exist.
• SFC program error of FXCPU.
• The label program is not compiled.

●

Clears the current error information.

● /
Displays the explanation screen corresponding to the error number of the selected error item/error 
history item.

●

Displays the latest error history.

●

Saves the currently displayed error history in a file in the CSV file format.
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18.1.1  Diagnosing QCPU (Q mode), LCPU, communication head module, and remote I/O module

● Displaying the Error Details screen
The following Error Details screen is displayed by double-clicking the Present Error column or the error item in the Error 
History display column.
SD5 to 15 (Common Error Information) and SD16 to 26 (Individual Error Information) of the programmable controller 
CPU are displayed on the Error Details screen.
For details, refer to the manual of the programmable controller CPU module.

● "Change the window size and position after error jump" check box
When "Change the window size and position after error jump" is selected and the error jump is executed, the PLC 
Diagnostics screen is downsized as shown below. This function applies when executing the error jump on either 
Present Error column or Error History display column.

The screen returns to the original size by clicking the  button.

● When error is not found at error jump destination
In the following conditions, an error may not be found at the error jump destination.
• When the program of the open project does not match with the program on the programmable controller CPU.
• When diagnosing programmable controller other than the one set as a connection destination in the project.

Example) When a module is selected from the CC IE Control Diagnostics and the System Monitor is activated, 
and the PLC Diagnostics is activated from the activated System Monitor.

● Confirming operation mode of Redundant CPU
The operation mode of Redundant CPU can be confirmed with the 'BACKUP' LED displayed on the 'image of 
programmable controller CPU'.

For details of CPU module LED, refer to the following manual.
QCPU User's Manual (Hardware Design, Maintenance and Inspection)

'BACKUP" LED status Operation mode

ON (green) Backup mode

ON (red) Backup mode (In a state in which the control (RUN) cannot be continued by the 
system switching.)

ON (orange) Separate mode

OFF Debug mode

Double-click
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18.1.2 Diagnosing FXCPU

Display the programmable controller CPU status.

Screen display
Select [Diagnostics] ⇒ [PLC Diagnostics].

Display contents

HeadRemoteQ CPU FXL CPU

Item Description

Connection Channel List Display the connection route which has been set.

Error Information

Display errors being occurring.
The corresponding error help is displayed by double-clicking the row of error 
information.

(It is also displayed by clicking the  button.)

PLC Panel Display the status of the connection destination CPU module.

PLC Information Display the memory type and version of the connection destination CPU 
module.

Monitor Status Display the current monitor status.
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18.1.3  Error icons

Screen button
For the screen buttons, refer to Section 18.1.1.

●

Switches the execution status of the programmable controller CPU to RUN.
Not supported by FX0, FX0S, FX1, FXU, and FX2C.

●

Switches the execution status of the programmable controller CPU to STOP.
Not supported by FX0, FX0S, FX1, FXU, and FX2C.

●

Displays the Clear PLC Memory screen.

●

Displays the Set Clock screen.
Not supported by FX0S, FX0, and FX1.

18.1.3 Error icons

The following table shows the details of the error information icons of the programmable controller 
CPU.

Icon Programmable controller CPU status

 Serious error RESET and others

 Moderate error STOP due to error in parameter or instruction codes

 User specified error*1

*1 : Not supported by FXCPU.

The error that allow "STOP"/"Continue" to be specified as an "Operating Mode When 
There is an Error" on the <<PLC RAS>> tab of PLC parameter.

 Minor error Errors that allow RUN status such as battery low and annunciator ON

Remote HeadQ CPU L CPU FX
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18.1.4 Online operations

The PLC Memory Operation function and the Remote Operation function can be executed from the 
figure of programmable controller CPU.
When the cursor is moved to the figure of programmable controller CPU, the function menu is 
expanded. Click the figure of programmable controller CPU to display the items to be set.

Screen display
<QCPU (Q mode) (For Universal model CPU)>

<QCPU (Q mode) (For Redundant CPU)>

Remote HeadQ CPU L CPU FXFX

<Ethernet Diagnostics>

<PLC Memory Operation> 

<Remote Operation>

<Set Clock/Write Title>

<Redundant Operation><PLC Memory Operation>

<Remote Operation> <Set Clock/Write Title>
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18.1.4  Online operations

<LCPU>

<Communication head module (CC IE Field head module)>

<Ethernet Diagnostics>

<PLC Memory Operation>
<Remote Operation/ 

PLC Module Change>

<Set Clock/Write Title>

<CC-Link Diagnostics>

<CC IE Field Diagnostics>

<Remote Operation>

<Write Title/Memory Format>
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<Remote I/O module>

Display contents

<MELSEC Diagnostics> 

Item Reference

PLC Memory Operation (Type of memory 
operation)

Memory format Section 17.3
Section 17.4
Section 17.5

Memory clear

Memory arrangement

Remote Operation/PLC Module 
Change

Remote operation Section 17.1

Backup data creation Section 12.8.1

Data restoration Section 12.8.2

Redundant Operation Section 17.2

Ethernet Diagnostics Section 18.6

Set Clock/Write Title
Set clock Section 17.6

Write title Section 12.1

CC-Link Diagnostics Section 18.5.1

CC-Link IE Field Diagnostics Section 18.4

MELSECNET Diagnostics Section 18.2
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18.2 Diagnosing MELSECNET

This section explains how to check the MELSECNET/10(H) status connected to the selected module.

Screen display
Select [Diagnostics] ⇒ [MELSECNET Diagnostics].

Display contents

Screen button

●

Displays the Network Test screen. (Section 18.2.1)

●

Displays the Loop Test screen. (Section 18.2.2)

●

Displays the Setting Confirmation Test screen. (Section 18.2.3)

●

Displays the Station Order Check Test screen. (Section 18.2.4)

●

Displays the Communication Test screen. (Section 18.2.5)

●

Displays the Error History Monitor screen. (Section 18.2.6)

●

Displays the Network Monitor Details screen. (Section 18.2.7)

Q CPU FXFXHeadL CPU Remote

Link module 
selection tab

Item Description

Link module selection tab Switch the MELSECNET diagnostics result display screen for each link modules from 1 to 4. 
The information whether a link module is mounted or not is acquired from the mounted status.

Network Information Display the network information of the selected module.

Link Information Display the network status.

Communication Information Display the communication status of the target network.



18.2  Diagnosing MELSECNET

18 - 13

17

O
P

E
R

A
TI

N
G

 
PR

O
G

R
A

M
M

AB
LE

 
C

O
N

TR
O

LL
E

R
 C

P
U

18

DI
AG

NO
SI

NG
 

PR
OG

RA
M

M
AB

LE
 

CO
NT

RO
LL

ER
 S

TA
TU

S

19

SI
M

U
LA

TI
N

G
 

O
PE

R
AT

IO
N

S 
O

F 
EX

TE
R

N
AL

 D
EV

IC
ES

20

P
R

IN
TI

N
G

21

S
E

TT
IN

G
 O

P
TI

O
N

S

22

U
S

IN
G

 L
IB

R
A

R
IE

S

A

A
PP

E
N

D
IX

I

IN
D

EX

●

Displays the Other Station Information screen. (Section 18.2.8)

● Network to be diagnosed
To change a network to be diagnosed, change the target station in the connection destination setting.

● When another station is set in the connection destination setting
Test functions such as network test cannot be executed when the connection destination setting is set to other than "No 
Specification".

● MELSECNET/H (bus) connection
• The loop test and station order test cannot be executed with the MELSECNET/H (bus) connection with the coaxial 

cable.
• The loop test, setting verification test, and station order test cannot be executed with the MELSECNET/H (bus) 

connection with the twisted pair cable.
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18.2.1  Network test

18.2.1 Network test

Perform link start/stop (cyclic transmission stop/restart) on the host station, specified station, and all 
stations in MELSECNET/10(H).
Use this function to avoid receiving data from another stations or to avoid sending data from host 
station when starting up (debugging) the system.

Screen display

Click the  button on the MELSECNET Diagnostics screen.

Display contents

Operating procedure

1. Set the items on the screen.

Item Description

Network Information Display the network information on the host station of the selected module.

Monitor Status Display the current monitor status.

Host Status Display the operating status of the host station for the selected module.

Operation Status of All 
Stations Display the link status of all stations on the tested network.

Item Description

Link Start/Stop Set the items to execute the test.

Operation

Link Start
• Select this to start the station that was stopped by the host station.
• The station that was stopped by another station cannot be started.

Link Stop Select this to stop a station from the host/another station.

Forced 
Link
Start

• Select this to forcibly perform the link start on a station stopped by the host station or 
another station, or to forcibly perform the link start on a station to which the link stop is 
performed by special relay/special register. However, forced start in units of stations is 
not possible while all stations are stopped.

• To check whether the station is stopped by stop specification of all stations, check 
SW0000.

• This function can be executed when "PLC side I/F" in the connection destination setting 
is set to "C24".

• This function cannot be executed when the MELSECNET/10(H) board is used.
• This function cannot be executed via the A series-compatible E71/QE71 module. (The 

route via A series-compatible E71/QE71 is not supported by GX Works2.)

Designate Object 
Station Specify the object station of the network test.

Object Module Select the object module of the network test.
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2. Click the  button.
The network test is executed according to the settings.

● When another station is set in the connection destination setting
The network test function cannot be executed when the connection destination setting is set to other than "No 
Specification".
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18.2.2  Loop test

18.2.2 Loop test

Check the loop status of MELSECNET/10(H).
Use this function to perform the loop test in the forward loop/reverse loop status with the completion of 
the optical loop system wiring.
Wiring status of data link cables (IN/OUT) can be checked.

Screen display

Click the  button on the MELSECNET Diagnostics screen.

Display contents

Operating procedure

1. Set the items on the screen.

2. Click the  button.
The loop test is executed according to the settings.

● When another station is set in the connection destination setting
The loop test function cannot be executed when the connection destination setting is set to other than "No 
Specification".

Item Description

Network Information Display the network information on the host station of the selected module.

Execute Results Display the number of stations and the result (normal/invalid, reserved station: R) of loop test.

Item Description

Loop Test Set the items to execute the test.

Test 
Method

Parameter 
Designation

Select this to test all the (slave) stations specified by the network parameter 
(except for reserved stations).
All stations are tested, if network parameter does not exist.

All Stations 
Designation Select this to test all stations.

Object Module Select the module for which loop test is executed.
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18.2.3 Setting verification test

Check the status of the station number, network number, and group number set for each station.
Use this function to check duplicates of control stations or station numbers, or whether the network 
number set to the station to which GX Works2 is connected matches with the network number set in the 
network parameter of host station.

Screen display

Click the  button on the MELSECNET Diagnostics screen.

Display contents

Item Description

Network Information Display the network information on the host station of the selected module.

Execute Results Display the test result.

Station No. Display the station number of the stations for which the setting verification test was executed.
Up to 64 stations are displayed.

Control Station No. Display "" symbol at the target station if control station is set at two or more places.

Duplicated Station No. Display "" symbol at the target station if the same station number is set at two or more 
places.

Network No. Display the network number of the stations for which the setting verification test was executed.
If the network number differs from that of the host station, it is identified by red.

Group No. Display the group number of the stations for which the setting verification test was executed.
For the remote I/O network, the station in error is blank.

Reserved Station Display "" symbol for the station reserved by parameter setting.
(When "Parameter Designation" is set in the test execution method.)

Error Station Display "" symbol for the station when it is reserved by parameter setting or if a module is 
faulty in all station specification.

Network Type Error 
Station

Display "" symbol for the station where the parameter setting and the actual connection type 
disagree.

Duplex R Sub M Station 
Duplication

Display "" symbol for the station where multiple sub-master stations exist on the same 
network.

Parallel R Sub M Station 
Duplication

Display "" symbol for the station where multiple sub-master stations exist on the same 
network.
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18.2.3  Setting verification test

Operating procedure

1. Set the items on the screen.

2. Click the  button.
The setting verification test is executed according to the settings.

● Considerations for executing the test
The test cannot be executed to multiple stations simultaneously.
If executed, cyclic transmission stops.

● When another station is set in the connection destination setting
The setting verification test cannot be executed when the connection destination setting is set to other than "No 
Specification".

Item Description

Setting Check Test Set the items to execute the test.

Test 
Method

Parameter 
Designation

Select this to test all the (slave) stations specified by the network parameter 
(except for reserved stations).
All stations are tested, if network parameter does not exist.

All Stations 
Designation Select this to test all stations.

Object Module Select the module for which setting verification test is executed.
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18.2.4 Station order check test

Check the station number of the connected stations in the optical loop system of MELSECNET/10(H).

Screen display

Click the  button on the MELSECNET Diagnostics screen.

Display contents

Operating procedure

1. Set the items on the screen.

2. Click the  button.
The station order check test is executed according to the settings.

● Considerations for executing the test
The test cannot be executed to multiple stations simultaneously.
If executed, cyclic transmission stops.

● When another station is set in the connection destination setting
The station order check test cannot be executed when the connection destination setting is set to other than "No 
Specification".

Item Description

Network Information

Display the network information on the host station of the selected module.
The loop status indicates the forward/reverse loop, forward loop, reverse loop or loopback 
status.
"No. of Stations" indicates the number of stations that have been checked, including the 
reserved station.

Execute Results

Display the station number in "Forward Loop Direction from Host Station" and "Reverse Loop 
Destination from Host Station".
In the loopback status, the test is executed only in "Forward Loop Direction from Host Station".
The number for the reserved station is not displayed.

Item Description

Station Order Check Test Set the items to execute the test.

Test 
Method

Parameter 
Designation

Select this to test all the (slave) stations specified by the network parameter 
(except for reserved stations).
All stations are tested, if network parameter does not exist.

All Stations 
Designation Select this to test all stations.

Object Module Select the module for which station order check test is executed.
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18.2.5  Communication test

18.2.5 Communication test

Perform the communication test between networks on MELSECNET/10(H).
Use this function to check whether communication can be performed between the host station and the 
communication target.
Especially, when the communication target is located on another network, the routing parameter setting 
can be checked by the relayed network numbers and station numbers displayed on the screen.

Screen display

Click the  button on the MELSECNET Diagnostics screen.

Display contents

Operating procedure

1. Set the items on the screen.

2. Click the  button.
The communication test is executed according to the settings.

● When another station is set in the connection destination setting
The communication test cannot be executed when the connection destination setting is set to other than "No 
Specification".

Item Description

Execute Results Display the result of communication test executed between networks.

Item Description

Communication Test Set the items to execute the test.

Destination Set the network number and station number.

Communication Data Set the data length (1 to 900 bytes), number of communications (1 to 100 
times), and monitoring time (1 to 100 seconds) to execute the test.
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■ Example of communication test

The following shows an example of the communication test between the host station (network number 
1, station number 1) and the communication target (network number 3, station number 2) with the 
network configuration described below.

GX Works2

Host station Communication target

Station
number 4

Station
umber 3

Station
number 2

Station
number 2

Station
number 3

(Relay station 1)

Station
number 2

Station
number 1

(Relay station 2)

Station
number 1

Network number 1 Network number 3

Network number 2

Station
number 1

Relay station number of network No. 1: 4

Relay station number of network No. 2: 3

Direction from host station 

to communication target

Return direction from 

communication target 
to host station
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18.2.6  Error history monitoring

18.2.6 Error history monitoring

Display the error history of MELSECNET/10(H).

Screen display

Click the  button on the MELSECNET Diagnostics screen.

Display contents

Screen button

●

Displays the Error History Detail Monitoring screen that lists the details of loop switching and 
transient transmission error.

Item Description

Network Information Display the network information of the selected host station.

Loop Switching Display the number of times that the loop is switched.

Transient Transmission Errors Display the number of occurrences of transient transmission error.

F.Loop/R.Loop Display the items during monitoring.
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●

Displays the Clear of Error History screen. Select the items to be cleared and click the  
button.

18.2.7 Network monitor details

Display the network line status of MELSECNET/10(H).

Screen display

Click the  button on the MELSECNET Diagnostics screen.

Display contents

Item Description

Network Information Display the network information of the selected host station.

Control Station Information
Display the control station information.
For the remote I/O master station, the information is displayed only for PLC to PLC network.*1
LX/LY assignment is displayed only for the remote I/O network.*1

Data Link Information Display the data link information.

Status of Self Station Display the host station status.
Parameter setting is displayed only for PLC to PLC network.

*1 : Not supported by remote I/O module.
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18.2.8  Monitoring other station information

18.2.8 Monitoring other station information

Monitor other station connected to MELSECNET/10(H).

Screen display

Click the  button on the MELSECNET Diagnostics screen.

Display contents

Error details 

display field

Item Description

Network Information Display the network information of the selected host station.

Other Station Information

Display detailed information on the error details display field when an item button is clicked.
• "ERR" is displayed on the error information display field if a faulty station or a stop station is 

detected.
• "RSV" is displayed on the error information display field if a reserved station exists.
• "PWR" is displayed on the error information display field if a power is supplied to a module 

with external power supply.

Error details display field Display the status of each station for the items selected in "Other Station Information".
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The table below shows the items that can be selected in "Other Station Information" of QCPU (Q 
mode).

: Applicable ×: Not applicable (grayed out)

MELSECNET/10(H)

PLC to PLC network Remote I/O network

Control station Normal station Master station

Loop Bus Loop Bus Loop Bus

Communication Status of each Station      

Data-Link Status of each Station      

Parameter Status of each Station*1   × ×  

CPU Operation Status of each Station      

CPU RUN Status of each Station*1     × ×

Loop Status of each Station  ×  ×  ×

Reserved Station Designation of each Station      

Power Operation Status of each Station External*1  ×  ×  ×

Search Status of Local Station Error*1 × × × × × ×

Each Station PLC Operation Mode Status*1,*2     × ×

Each Station Pairing Status*1,*2     × ×

Each Station PLC System Status*1,*2     × ×

Each Station Network Type Status*1,*2     × ×

*1 : Not supported by remote I/O module.
*2 : For MELSECNET/H network module only
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18.3 Diagnosing CC-Link IE Controller Network

This section explains how to check the CC-Link IE Controller Network status of a selected module.

● When another station is set in the connection destination setting
When another station is set in the connection destination setting, the function cannot be executed.

● Details of CC-Link IE Controller Network diagnostics
Refer to CC-Link IE Controller Network Reference Manual.

■ Selecting the diagnostics target

When two or more CC-Link IE Controller Network modules are connected to the connected station, the 
Select Diagnostics Destination screen as shown below is displayed before starting diagnostics.
Select a network to be diagnosed and click the  button.

■ Diagnostics screen

Screen display
Select [Diagnostics] ⇒ [CC IE Control Diagnostics].

Q CPU FXFXHeadRemoteL CPU

Network information
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Display contents

Screen button

●

Displays the Select Diagnostics Destination screen. The diagnostic target module can be changed.

●

Changes the selected station to the station to which the station number specified in "Select Station" 
is assigned. The status of the selected station is displayed in "Selected Station’s Network Equipment 
Status".

● /
Switches the screen display of the network information when the total number of station is 61 or 
more.

●

Displays the Communication Test screen. The communication route from the connected station to 
the specified destination station can be confirmed. (Section 18.3.1)

●  (Universal model QCPU (except for Q00UJ/Q00U/Q01U/Q02U) only)
Displays the IP Communication Test screen. The IP communication route from the connected station 
to the communication destination station can be confirmed. (Section 18.3.2)

●

Displays the Link Start/Stop screen. The data link start/stop can be performed to the specified 
station. (Section 18.3.3)

Item Description

Network information

Display the network information of the selected module. The status is displayed by icons shown 
below.

Clicking an icon sets the corresponding station as the selected station and displays the details 
in "Selected Station's Network Equipment Status". The selected station can also be determined 
by moving the focus with the right and left arrow keys and pressing the  or  key.
Double-clicking an icon displays the System Monitor screen (Section 18.8) of the 
corresponding station.

Selected Station's Network 
Equipment Status

Display the status of the CC-Link IE Controller Network module in the station selected in the 
network information display field and the status of the connecting cable.

Icon
Station status

Module Board

Normally operating station

Focusing (icon enclosed by dotted line)

Selected station

Error (cyclic transmission stopped)

Warning (Although cyclic transmission is executed, an error 
occurred with a module and/or a cable)

Module whose shared group is different

– Reserved station (gray)

– Disconnected station (black)

– Current connected station, specified in the connection 
destination setting

–
Number unspecified station (Although "Specify Station No. 
by Program" is selected in parameter (normal station only), a 
station number is not set in the program.)
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●

Displays the Logging screen. The communication route switch information and the transient 
transmission error of the connected station can be monitored. The monitor information can be saved 
in a file. (Section 18.3.4)

●

Displays the System Monitor screen. The system status of the selected station can be confirmed.
(Section 18.8)

●

Displays the Remote Operation screen. The remote operation can be performed to the 
programmable controller CPU of the selected station. (Section 17.1)

● Connection destination for executing CC-Link IE Controller Network diagnostics
The communication test and the link start/stop can be executed only when the connected station is selected.

● When an unsupported CPU module is specified as the selected station, or a CC-Link IE Controller Network 
interface board is specified as the selected station
The system monitor or remote operation cannot be performed when an unsupported CPU module is specified as the 
selected station. The system monitor cannot be performed when a CC-Link IE Controller Network interface board is 
specified as the selected station.

● When the total number of stations is set to 65 or more
In a case where the total number of stations is set to 65 or more and High Performance model QCPU is specified as the 
connected station, an error occurs when a station whose station number is 65 or more is selected. The error, however, 
does not occur where Universal model QCPU is connected with a cable in a multiple CPU configuration.

Restrictions

● Communication test and link start/stop
To execute the communication test or link start/stop, a target station must be connected using a USB/RS-232 cable.
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■ Display on the "Selected Station's Network Equipment Status" field when 
an error occurs

When an error occurs on a CC-Link IE Controller Network module or connection cable, the button is 
displayed on the "Selected Station's Network Equipment Status" field as shown below. The detailed 
information, error factor, and troubleshooting can be displayed by clicking the button.

The icon ( ) is displayed as shown below when a destination station is disconnected.

Click the button.
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18.3.1  Communication test

18.3.1 Communication test

Perform the communication test on CC-Link IE Controller Network.

Screen display

Click the  button on the CC IE Control Network Diagnostics screen.

Operating procedure

1. Set the items on the screen.

2. Click the  button.
The communication test is executed according to the settings.

Display contents

Item Description

Communication Test 
Parameters Set the items to execute the test.

Target Station Set the network number and station number.

Communication Data 
Setting

Set the data length (1 to 900 bytes), the number of communications (1 to 100 times), 
and monitoring time (1 to 100 seconds) to execute the test.

Item Description

Communication Test Result

Display the result of inter-network communication test.
Networks and stations routed from the own station (connected station) to the target station are 
displayed on the <<Outward>> tab and those routed from the target station to the own station 
(connected station) are displayed on the <<Inward>> tab.
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18.3.2 IP communication test

Perform the IP communication test on CC-Link IE Controller Network.

Screen display

Click the  button on the CC IE Control Network Diagnostics screen.

Operating procedure

1. Set the items on the screen.

2. Click the  button.
The IP communication test is performed according to the set information.

Display contents

Item Description

IP Communication Test 
Parameters Set the information for the test.

IP Address Input Format Select the input format (decimal/hexadecimal) of the IP address.

Connected Station (Own) Display the IP address of the Built-in Ethernet type CPU.

Communication Target Set the IP address of the target station.

Item Description

IP Communication Test Result

Display the result of the IP communication test between the networks.
Network numbers and station numbers routed from the own station to the target station are 
displayed on the <<Outward>> tab.
Network numbers and station numbers routed from the target station to the own station are 
displayed on the <<Inward>> tab.
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18.3.3  Link start/stop

18.3.3 Link start/stop

Start/stop the data link of individual stations on CC-Link IE Controller Network.

Screen display

Click the  button on the CC IE Control Network Diagnostics screen.

Operating procedure

1. Set the items on the screen.

2. Click the  button.
The link start/stop is executed for all selected stations at once.

Item Description

Network Information Display the network information of the connected station.

All Station Status
Display the link status of all stations on the same network which are performing the data link 
with the connected station. Target stations of the link start/stop operation can be selected in 
"Selective Status".

Link Start/Stop −

Link Start Select this to start the data link.

Link Stop Select this to stop the data link.

Forced Link Start Select this to forcibly start the data link of a station which has been stopped by another 
station or a special relay/special register.
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● Selection of link start/stop
The target stations of the link start/stop operation can also be selected by the following methods.

Selection Operating procedure

Group Selection

Right-click on the "Group" column of a station and select "Group 
Selection" from the shortcut menu.
Stations which have the same group number as the selected line 
become selected.
When the "Group" column whose value is 0 is right-clicked, this 
shortcut menu cannot be selected.

Select All

Right-click the "Station No." column of a station and select "Select 
All" from the shortcut menu.
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18.3.4  Logging

18.3.4 Logging

Display the communication route switch information and transient transmission error information of the 
selected station.

Screen display

Select the  button on the CC IE Control Network Diagnostics screen.

Display contents

■ Displaying the communication route switch information and transient 
transmission error information

The <<Monitor Details>> tab displays the communication route switch information and transient 
transmission error information.
Maximum 100 logs can be displayed. If the number of logs exceeds 100, the logs are deleted from the 
oldest one.

Display contents

Item Description

Display Station Display the network information of the currently selected station.

Item Description

Switch Transmission Path Display the loop status of communication route, the number of station where loopback 
occurred, and the date when communication route switching occurred.

Transient Transmission Errors Display the error code, network number and station number of the transient request target, and 
the date of error occurrence if transient transmission error occurs.
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Screen button

●

Displays the Save Error Log screen and the contents displayed on the <<Monitor Details>> tab can 
be saved in a CSV file.

■ Clearing errors

Clear the errors of the currently selected station using the <<Error Clear>> tab.

Screen display

Operating procedure

1. Select the item to be cleared.

2. Click the  button.
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18.4 Diagnosing CC-Link IE Field Network

This section explains how to check the CC-Link IE Field Network status of a selected module.

● When another station is set in the connection destination setting
When another station is set in the connection destination setting, the function cannot be executed.

● Details of CC-Link IE Field Network diagnostics
Refer to the User’s Manual of each module.

■ Selecting the diagnostics target

When two or more CC-Link IE Field Network modules are connected to the connected station, the 
Select Diagnostics Destination screen as shown below is displayed before starting diagnostics.
Select a network to be diagnosed and click the  button.

HeadQ CPU L CPU
*2

Remote FX
*1

*2 : CC IE Field head module only
*1 : Universal model QCPU only
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■ Diagnostics screen

Screen display
Select [Diagnostics] ⇒ [CC IE Field Diagnostics].
The following is an example of setting screen when QCPU (Q mode) is selected.

Display contents

Network configuration

Data link

unexecuted

stations

Network information

Item Description

Select Diagnostics 
Destination −

Module Display the module and network number of the diagnostics target.

Select Station Display the station number of the station selected in the network information.
When the connected station is CC IE Field head module, this item is fixed to the own station.

Network Status*1

*1 : Not displayed when the connected station is a CC IE Field head module.

−

Network information Display the total number of slave stations, the link scan time (in units of ms), and the number of 
error-detected stations on the network being displayed.

Network configuration

Display the state of the network. The status of each station is displayed with icons.
Descriptions of displayed icons can be checked by clicking the  button.
Clicking an icon sets the corresponding station as the selected station and displays the details 
on the "Selected Station Communication Status Monitor" field. The selected station can also be 
determined by moving the focus with the right and left arrow keys and pressing the  or 
 key.

Data link unexecuted 
stations

Display stations on which the data link is not established among the stations set to the 
parameter.
The disconnected stations which are deleted by the "Hide Disconnected Station" function are 
also displayed.

Selected Station 
Communication Status 
Monitor*2

*2 : When the master station is duplicated, the icon for QJ71GF11-T2 is displayed even if the selected station is QD77GF16.

Display the communication status of the own station.
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Screen button

●  (Not supported by CC IE Field head module)
Displays the Select Diagnostics Destination screen. The diagnostic target module can be changed.
(■ Selecting the diagnostics target)

●

Deletes the disconnected station from the network configuration.

●

Displays the explanation for icons displayed on the diagnostics screen.

●

Displays the Communication Test screen. The communication route from the connected station to 
the specified destination station can be confirmed. (Section 18.4.1)

●

Displays the IP Communication Test screen. The IP communication route from the connected station 
to the communication target station can be confirmed. (Section 18.4.2)

●

Displays the Cable Test screen. The cable connection status can be tested.
(Section 18.4.3)

●  (Not supported by CC IE Field head module)
Displays the Link Start/Stop screen. The data link start/stop can be performed to the specified 
station. (Section 18.4.4)

●  (Not supported by CC IE Field head module)
Displays the Network Event History screen. Displays the history of events that have occurred on the 
own station and the network, and the various network information. (Section 18.4.5)

●  (Not supported by CC IE Field head module)

Displays the Reserved Station Function Enable screen. The reserved stations can temporarily be 
disabled, and the temporarily disabled reserved stations can be enabled. (Section 18.4.6)

●  (Not supported by CC IE Field head module)

Displays the Enable/Disable Ignore Station Errors screen. The temporary error invalid stations can 
be set, and the registered temporary error invalid stations can be canceled. (Section 18.4.7)
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●  (Not supported by Ethernet adapter module/CC-Link IE Field Network 
board/CC-Link IE Field Network communication unit)
Displays the System Monitor screen. The system status of the selected station can be confirmed. 
(Section 18.8)

●  (Supported by Ethernet adapter module/CC-Link IE Field Network CC-
Link bridge module only)
Displays the Error History screen. The system status of the selected station can be confirmed.
(Section 18.8)

●  (Not supported by Ethernet adapter module/CC-Link IE Field Network 
board/CC-Link IE Field Network communication unit)
Displays the Remote Operation screen. The remote operation can be performed to the 
programmable controller CPU of the selected station. (Section 17.1)

● Connection destination for executing CC-Link IE Field Network diagnostics
The communication test and the link start/stop can be executed only when the connected station is selected.

● When an unsupported CPU module is specified as the selected station
The IP communication test, system monitor, or remote operation cannot be performed when an unsupported CPU 
module is specified as the selected station.

● When the selected station is a remote device station
• The system monitor cannot be performed.
• For the remote operation, only remote reset operations can be performed on the selected station.
• Extension modules are displayed on the "Selected Station Communication Status Monitor" field only when a CC-Link 

IE Field Network master/local module is connected.
For the versions (serial numbers) of master/local modules which can display the extension modules, refer to the 
following manuals.
MELSEC-Q CC-Link IE Field Network Master/Local Module User's Manual
MELSEC-L CC-Link IE Field Network Master/Local Module User's Manual

● Considerations of sub-master station display
When a sub-master station is specified in the network parameter of the master station, a slave station whose station 
number is the same as that of the sub-master station is indicated as "Sub-Master".
In this case, review the network parameter and the system configuration.

Restrictions

● Communication test and link start/stop
To execute the communication test or link start/stop, a target station must be connected using a USB/RS-232 cable.
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■ Display on the "Selected Station Communication Status Monitor" field

The button as shown below is displayed on the "Selected Station Communication Status Monitor" field 
for any of the following situations:
• an error occurs on a CC-Link IE Field Network master/local module, CC IE Field head module, or 

Ethernet adapter module;
• an error occurs on a connection cable; or
• a station number is not specified.
The detailed information, error factor, and troubleshooting can be displayed by clicking the button.

The icon ( ) is displayed as shown below when a destination station is disconnected.

● Setting a station number of CC IE Field head module
A station number of CC IE Field head module can be set or changed when connecting a CC IE Field head module 
whose station number is not set.
Specify "CC IE Field Head Module" for "Select Station" on the CC IE Field Diagnostics screen for the master station, 

and click the  button displayed on the "Selected Station Communication Status Monitor" field.
Station numbers of the following modules used in the master station can be reset.
• QJ71GF11-T2 (With a serial number whose first five digits are "12072" or higher)
• LJ71GF11-T2
For details of setting station numbers, refer to the following manual.
MELSEC-L CC-Link IE Field Network Head Module User's Manual

Click the button
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18.4.1 Communication test

Perform the communication test on CC-Link IE Field Network.

Screen display

Click the  button on the CC IE Field Diagnostics screen.

Operating procedure

1. Set the items on the screen.

2. Click the  button.
The communication test is performed according to the settings.

Display contents

Presence or absence of errors 

on the communication test

Item Description

Communication Test 
Parameters Set the items to execute the test.

Connected Station (Own) Display the network number and station number of the connected station.

Target Station Set the network number and station number.

Communication Data 
Setting

Set the data length (1 to 900 bytes), the number of communications (1 to 100 times), 
and monitoring time (1 to 100 seconds) to execute the test.

Item Description

Communication Test Result

Display the result of inter-network communication test. Also in 'Presence or absence of errors 
on the communication test', display whether the communication test has been executed 
normally.
Networks and stations routed from the own station (connected station) to the target station are 
displayed on the <<Outward>> tab and those routed from the target station to the own station 
(connected station) are displayed on the <<Inward>> tab.
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18.4.2  IP communication test

18.4.2 IP communication test

Perform the IP communication test on CC-Link IE Field Network.

Screen display

Click the  button on the CC IE Field Diagnostics screen.

Operating procedure

1. Set the items on the screen.

2. Click the  button.
The IP communication test is performed according to the set information.*1

*1 : A maximum of two minutes may be required for the cancellation processing when the module is not connected with 
the serial/USB cable.

Display contents

Item Description

IP Communication Test 
Parameters Set the information for the test.

IP Address Input Select the input format (decimal/hexadecimal) of the IP address.

Connected Station (Own) Display the IP address of the Built-in Ethernet type CPU.

Communication Target Set the IP address of the target station.

Item Description

IP Communication Test 
Result

Display the result of the IP communication test between the networks.
Network numbers and station numbers routed from the own station to the target station are 
displayed on the <<Outward>> tab.
Network numbers and station numbers routed from the target station to the own station are 
displayed on the <<Inward>> tab.
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18.4.3 Cable test

Test the status of the cable connections between the testing station and the devices connected to the 
ports of the testing station.

Screen display

Click the  button on the CC IE Field Diagnostics screen.

Operating procedure

1. Set the items on the screen.

2. Click the  button.
The cable test is executed on the testing station.

Display contents

Item Description

Cable Test Contents –

Testing Station Setting Set the network number and station number of the station which executes the cable 
test.

Item Description

Cable Test Result Display the cable test result, error factor, and troubleshooting of each port.
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18.4.4  Link start/stop

18.4.4 Link start/stop

Start/stop the data link of a specified station. This function can be used for debugging purposes to stop 
the station from receiving data from other stations and sending its own data.
The data link cannot be started/stopped to the stations other than the own station when the connected 
station is the master station operating as a sub-master station.

Screen display

Click the  button on the CC IE Field Diagnostics screen.

Operating procedure

1. Set the items on the screen.

2. Click the  button.
The link start/stop is executed for all selected stations at once.
When the process is completed, "Selected Status" are cleared and the contents of "Link Status" 
are updated.

Item Description

Network Information –

Connected Station 
Information Display the network information of the connected station.

Link Start/Stop Setting Contents –

All Stations Information
Display the link status of all stations on the same network which are performing the data 
link with the connected station. Target stations of the link start/stop operation can be 
selected in "Selected Status".

Link Start/Stop Executing 
Contents

Select "Link Start"/"Link Stop".
To forcibly start the data link of a station which has been stopped by another station or a 
special relay/special register, select "Forced Link Start".
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Screen button

●

Selects all stations displayed in the list.

●

Cancels the selection status of all stations selected in the list.

18.4.5 Network event history

Display the list of event history occurred on the own station and on the network.

Screen display

Click the  button on the CC IE Field Diagnostics screen.

Display contents

Item Description

Network Event History List Display the list of network event history.
Each column can be sorted in ascending/descending order by clicking on the column header.

Detailed Information Display the detailed information of an event selected in "Network Event History List".
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18.4.5  Network event history

Screen button

●

Clears the network event history exists on the programmable controller CPU.

●

Displays the History Acquisition Setting screen.
Select events to be acquired.

• All events displayed in the list are selected by clicking the  button.

• The selection status of all events selected in the list are canceled by clicking the  button.

●

Saves the network event history in CSV file format.

●

Updates "Network Event History List".
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18.4.6 Reserved station function enable

Disable the reserved stations temporarily, and enable the temporarily disabled reserved station.
This function cannot be performed when the connected station is a local station or the master station 
operating as a sub-master station.

Screen display

Click the  button on the CC-Link IE Field Diagnostics screen.

Operating procedure

1. Select reserved stations to be disabled temporarily/enabled from "Reserved Station 
List".

2. Click the  button.
The selected reserved stations are disabled temporarily/enabled.
When the process is completed, the contents of "Reserved Station List" are updated.
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18.4.7  Temporary error invalid station setting/restore

18.4.7 Temporary error invalid station setting/restore

Set/cancel temporary error invalid stations.
This function cannot be performed when the connected station is a local station or the master station 
operating as a sub-master station.

Screen display

Click the  button on the CC-Link IE Field Diagnostics screen.

Operating procedure

1. Select stations to be set/canceled as temporary error invalid stations from "Ignore 
Station Error List".

2. Click the  button.
The temporary error invalid stations are set/canceled.
When the process is completed, the contents of "Ignore Station Error List" are updated.
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18.5 Diagnosing CC-Link and CC-Link/LT

This section explains how to monitor the network information of each station, diagnosing the network 
status, and testing.

18.5.1 Monitoring line (host station/other stations)

*1 : CC IE Field head module only

Monitor host station line/another station line in CC-Link or CC-Link/LT.

Screen display
Select [Diagnostics] ⇒ [CC-Link Diagnostics].
The following is an example of setting screen when QCPU (Q mode) is selected.

Remote HeadQ CPU L CPU FX
*1

Station list

Module list/ 

diagnostic

target selection
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18.5.1  Monitoring line (host station/other stations)

Display contents

Screen button

●

Updates the module list/diagnostic target selection.
● /  (Not supported by FXCPU)

Switches modules to be displayed in units of eight modules.

●

Reset the icon layout in the station list to the station number order.
For the layout edit of the station list, refer to Point in this section.

● /  (Not supported by FXCPU)
Switches the screen of the station list.
When an error or warning exists on each screen, the icon indicating the error information is displayed 
on the button.

● /  (Not supported by FXCPU)
Switches the all-station display and detail display.

Item Description

Diagnostics Result Display the number of all errors/warnings being occurring in the modules.

Module list/diagnostic target 
selection

Display CC-Link and CC-Link/LT modules exist in the connected station. The number of errors 
(errors and warnings) is also displayed.
The diagnostic target can be changed by clicking a desired module.

Station list

Display the icons of stations configuring the CC-Link network.
In the detail display, the 33rd station and later are displayed by clicking the 

 button.

The display can be switched by the /  button. The information of all 
stations are displayed on the screen at once in the all-station display.

Click the  button to check the description of each icon.

<<Connecting Station 
Information>> Display such as the data link status of the connecting station (host station).

<<Selected Station 
Information>>

Display such as the data link status of the station (another station) selected in the station list.

<<Selected Station Error 
Information>>

Display the error information of the station selected in the station list.
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● /
Displays/hides the related function buttons.
For details of related functions, refer to the following sections.
• Loop Test*1 Section 18.5.2 "Loop test/transmission speed test"
• Status Logging*2 Section 18.5.3 "Displaying logs of station information (status logging)"
• Create Check Sheet Section 18.5.4 "Creating check sheets"
• Start Data Link/Stop Data Link*1Section 18.5.5 "Starting/stopping data link"

*1 : Not supported by remote I/O module.
*2 : Not supported by FXCPU.

●

Displays the explanation for icons displayed on the diagnostics screen.
The following is an example of setting screen when QCPU (Q mode) is selected.

● Update of the number of errors and warnings displayed in "Diagnostics Result"
During the monitoring, the number of errors/warnings being occurring on the network of a module selected in "Module 
list/diagnostic target selection" is only updated.

To also update the number of errors/warnings on other modules, update the module list using .
● Editing layout of station list

Icons in the station list can be moved and allocated freely with the drag-and-drop operation.

● Diagnostic target
• For QCPU (Q mode)/LCPU, only QJ61BT11, QJ61BT11N, and LJ61BT11 are diagnosed in the CC-Link system 

configuration, and only QJ61CL12 and LJ61CL12 are diagnosed in the CC-Link/LT system configuration.
• For FXCPU, the diagnostic target is CC-Link system only. Remote I/O, remote device stations, and intelligent device 

stations are diagnosed.

Move icons by drug 

and drop.
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18.5.1  Monitoring line (host station/other stations)

● Diagnosing CC-Link bridge modules (Not supported by FXCPU)
When a CC-Link bridge module is selected in the station list, the bridge diagnostics can be executed by right-clicking it 
and selecting [Bridge Diagnostics] from the shortcut menu.

To return to the CC-Link Diagnostics screen, click the  button.
● Considerations for executing each function

Do not execute the following functions by a sequence program and peripheral at the same time. If executed, they may 
not be executed correctly.
• Start data link/stop data link
• Set/cancel temporary error invalid station
• Loop test
• Obtain transmission speed setting (including the acquisition of the transmission speed setting in the Check Sheet 

Creation Wizard)

Restrictions

● Restrictions on bridge diagnostics, loop test, and check sheet creation
Bridge diagnostics, loop test, and check sheet creation can be performed only when the connected station is a master 
station.
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■ Setting/canceling temporary error invalid station

Replacing a module in online is possible without detecting an error in the corresponding remote station.
To set the temporary error invalid station, select the desired station in the station list and right-click it, 
and select [Enable/Disable Ignore Station Errors] from the shortcut menu.
If multiple stations are set as occupied stations, specify the start station number of each occupied 
station for the temporary error invalid station. If setting is set for a station that is not the start station in 
actual assignment, invalid setting is ignored.
In addition, do not set the temporary error invalid station by a sequence program or peripheral at the 
same time. If set, the temporary error invalid station may not be set correctly.
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18.5.1  Monitoring line (host station/other stations)

■ Company names in other station information

1) The field displays the company name or manufacturer code of the device connected in CC-
Link.

2) The field displays the manufacturer code if company name is not entered in the 
manufacturer code list.

3) The manufacturer code list (partner_English.dat) is saved in the following folder and can be 
edited using text editor available in market.
C:/Program Files/MELSOFT/DnaviZero/DnaviSatellite/CCLink

4) The company names can be edited on the diagnostics screen, however, changes are not 
applied to partner_English.dat.

For some manufacturers, manufacturer codes are not listed. Edit the file according to the following file 
format specifications.

The following is an example of partner_English.dat displayed using a text editor.

If the manufacturer code list does not exist in the install destination of GX Works2 or if it is corrupted, 
the following message is displayed.

Manufacturer 
code Company name

Max. number of 
characters 5 255

Usable characters*1 0 to 9
• Alphanumeric characters
• Symbols

Remarks
Manufacturer code 
other than 5 digits 
is ignored.

Display differs depending on the screen width.
With small fonts, up to 75 characters are displayed, characters exceeding the 
limit are not displayed.

*1 : If "," is used in a company name, enclose the company name by double quotations (" ").
Example: "xxxxx Co., Ltd"
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18.5.2 Loop test/transmission speed test

*1 : CC IE Field head module only

Check operating status of lines for all stations or specified stations, and checking the transmission 
speed settings of all stations.

Screen display

Double-click  on the CC-Link Diagnostics screen.

The following is an example of setting screen when QCPU (Q mode) is selected.

Remote HeadQ CPU L CPU FX
*1

Test result
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18.5.2  Loop test/transmission speed test

Operating procedure

1. Set the items on the screen.

2. Click the  button.
The loop test/acquisition of the transmission speed setting is executed and the result is displayed 
in the 'Test result'.
Check 'Legends' for the descriptions of the icons displayed in the 'Test result'.

● Considerations for executing the test
Do not execute the loop test/acquisition of the transmission speed setting by a sequence program or peripheral at the 
same time. If executed, the loop test/acquisition of the transmission speed setting may not be executed correctly.
In addition, when executing the acquisition of the transmission speed setting, do not execute the acquisition of the 
transmission speed setting in the Check Sheet Creation Wizard at the same time.

Item Description

Loop Test

Execute the loop test according to the specification of "All Stations" or "Selected Station 
No.".
Setting is not possible when CC-Link/LT is selected.

Example) When four occupied stations and two occupied stations are connected

If 2, 3, 4, or 6 is specified, the station becomes faulty station.

Obtain transmission speed 
setting Obtain the transmission speed settings of all stations.

All Stations: Select this to execute the test for all stations.
QCPU (Q mode)/LCPU: 64 stations
FXCPU : 16 stations

Selected Station No.: Select this to execute the test for the specified stations.
To specify a station, specify the start address of an occupied 
station.

"1" is specified "5" is specified

4 stations occupied 2 stations occupied
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18.5.3 Displaying logs of station information (status logging)

*1 : CC IE Field head module only

Collect logs of the station information (the data link status of other stations, date of acquisition).

Screen display

Double-click  on the CC-Link Diagnostics screen.

Remote HeadQ CPU L CPU FX
*1

<Q series CC-Link module whose serial number is lower than 12032>

<Q series CC-Link module whose serial number is 12032 or higher/LCPU> 

Log data 

display area

Log data 

display area
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18.5.3  Displaying logs of station information (status logging)

Operating procedure

1. Set the items on the screen.

2. Click the  button.
The log is collected during the specified log acquisition time and displayed in "Log List".
The log displayed in "Log List" is read out from the RAM.
The log collection stops when the number of log records reaches 5000.
When '0' is specified, the log collection continues until the  button is clicked or the 
number of log records reaches 5000.
The status as of the date selected in "Log List" is displayed in the 'Log data display area'.
Check "Legends" for the descriptions of the icons displayed in the 'Log data display area'.

Screen button

●

Clears the log in the module.
Also clears the log stored on a flash ROM when "RAM + Flash ROM" is selected.

● /
Saves information of the log list in CSV format. Also reads out a log file saved in CSV format and 
displays in "Log List".

● Log collection when "RAM + Flash ROM" is selected
When "RAM + Flash ROM" is selected, the first 45 records of the log are stored on a flash ROM and the following 
records are stored on a RAM.

● Checking the log stored on a flash ROM
The log stored on a flash ROM is transferred to a RAM when the programmable controller CPU is turned from OFF to 
ON or reset. The log stored on the flash ROM can be displayed in "Log List" by reopening the Status Logging screen.

● Log collection
In the case where GX Works2 cannot always be connected, select "RAM + Flash ROM". 
The log (up to 45 records) stored on a flash ROM can be displayed when GX Works2 is reconnected after the logging.
In the case where GX Works2 can always be connected, up to 5000 records of the log can be collected whichever 
"RAM" or "RAM + Flash ROM" is selected.

Item Description

Time of Logging Acquisition
Specify the period of time to collect the log on the second time scale.
The log is collected during the time of period between when the logging starts and when 
the specified time elapses.

Log Storage Area in CC-Link 
Module

Specify the logging storage destination.
Since the log which is stored on a RAM is deleted when the programmable controller CPU 
is turned from OFF to ON or reset, select "RAM + Flash ROM" to keep the log stored.
The log on a flash ROM can remain stored on the flash ROM of the CC-Link master/local 
module even if the programmable controller CPU is turned from OFF to ON or reset.
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18.5.4 Creating check sheets

*1 : CC IE Field head module only

Create a check sheet for troubleshooting by the wizard.

Operating procedure

1. Double-click  on the CC-Link Diagnostics screen.

2. Set the items according to the terms on the screens.
For details of setting items, refer to the following guide.
Open Field Network CC-Link Troubleshooting Guide
The created check sheet is saved in Excel format.

● Considerations for checking the transmission speed
Do not execute the check (acquisition) of the transmission speed setting by a sequence program or peripheral at the 
same time. If executed, the check (acquisition) of the transmission speed setting may not be executed correctly.

● Check sheets
"System Configuration" can be output when Excel 2000 or later is installed.

Remote HeadQ CPU L CPU FX
*1
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18.5.4  Creating check sheets

Example of a check sheet:
The following shows an example of a check sheet in case where Excel 2000 or later is installed.



18.5  Diagnosing CC-Link and CC-Link/LT

18.5.5  Starting/stopping data link 18 - 61

17

O
P

E
R

A
TI

N
G

 
PR

O
G

R
A

M
M

AB
LE

 
C

O
N

TR
O

LL
E

R
 C

P
U

18

DI
AG

NO
SI

NG
 

PR
OG

RA
M

M
AB

LE
 

CO
NT

RO
LL

ER
 S

TA
TU

S

19

SI
M

U
LA

TI
N

G
 

O
PE

R
AT

IO
N

S 
O

F 
EX

TE
R

N
AL

 D
EV

IC
ES

20

P
R

IN
TI

N
G

21

S
E

TT
IN

G
 O

P
TI

O
N

S

22

U
S

IN
G

 L
IB

R
A

R
IE

S

A

A
PP

E
N

D
IX

I

IN
D

EX

18.5.5 Starting/stopping data link

*1 : CC IE Field head module only

Start/stop the data link.
The following operating procedure is explained with icons of QCPU (Q mode) as an example.

Operating procedure

• Double-click  on the CC-Link Diagnostics screen.

The data link is stopped. The icon is switched to .

To start the data link, click .

■ Considerations of data link stop

Performing 'data link stop' disables data transmission from GX Works2 when the personal computer is 
connected to a master station via CC-Link as shown in the system configuration below.
To re-establish the connection to send data from GX Works2, reset the programmable controller CPU 
to which the data link stop is performed and restart the data link.

Remote HeadQ CPU L CPU FX
*1

Reset this programmable

controller CPU.

CC-Link

GX Works2

Local station, 
station number 1

Master station, 
station number 0
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18.6.1  Q series-compatible E71/L series-compatible E71 module

18.6 Diagnosing Ethernet

This section explains how to check various setting status of Ethernet module, Built-in Ethernet type 
CPU, and FXCPU with Ethernet adapter.

18.6.1 Q series-compatible E71/L series-compatible E71 module

Check Q series-compatible E71/L series-compatible E71 module parameter status, error history, status 
of each connection, status of each protocol, LED status, received e-mail information, and send e-mail 
information.
For details of each displayed item, refer to the following manuals.
Q Corresponding Ethernet Interface Module User's Manual (Basic)
MELSEC-L Ethernet Interface Module User's Manual (Basic)
The screens of QCPU (Q mode) are used in this section.

Screen display
Select [Diagnostics] ⇒ [Ethernet Diagnostics].

RemoteQ CPU L CPU FXHead FX

Monitoring Information
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Display contents

Screen button

●

Displays the PING Test screen. (Section 18.6.3)

●  (Supported by QCPU (Q mode) only)
Displays the Loopback Test screen. (Section 18.6.4)

●  (Supported by QCPU (Q mode) only)
Turns OFF the [COM ERR] LED.

■ Monitoring the parameter status

Monitor the Ethernet module parameter status.

Screen display
Select the <<Parameter Status>> tab on the Ethernet Diagnostics screen.

Item Description

Target Module Setting

Select "Module No.", and specify an Ethernet module to be monitored. The following is the 
setting range.
QCPU: 1 to 4
LCPU: 1 to 2

Change IP Address Display Switch decimal/hexadecimal notation of IP address display.

Monitoring information

The following Ethernet module information can be monitored.
• Parameter status (■ Monitoring the parameter status)
• Error history (■ Monitoring the error history)
• Status of each connection (■ Monitoring the status of each connection)
• Status of each protocol (■ Monitoring the status of each protocol)
• LED status (■ Monitoring the LED status)
• Received e-mail information (■ Monitoring the received e-mail information)
• Send e-mail information (■ Monitoring the send e-mail information)
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■ Monitoring the error history

Monitor the error history area.

Screen display
Select the <<Error History>> tab on the Ethernet Diagnostics screen.

Screen button

●

Clears the error history.

■ Monitoring the status of each connection

Monitor the status of each connection.

Screen display
Select the <<Status of Each Connection>> tab on the Ethernet Diagnostics screen.
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■ Monitoring the status of each protocol

Monitor the status of each protocol.

Screen display
Select the <<Status of Each Protocol>> tab on the Ethernet Diagnostics screen.

■ Monitoring the LED status

Monitor the status of LED on the front of the Ethernet module.

Screen display
Select the <<LED Status>> tab on the Ethernet Diagnostics screen.

● Considerations for monitoring
If RAM test or ROM test is set with the switch setting of an Ethernet module, programmable controller communication 
error occurs.
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■ Monitoring the received e-mail information

Monitor the received e-mail information.

Screen display
Select the <<Received E-mail Information>> tab on the Ethernet Diagnostics screen.

Screen button

●

Clears the number of times set in each item by '0'.

●

Clears "Number of Error Log Writes" by '0' and the contents of "Error Log".
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■ Monitoring the send e-mail information

Monitor the send e-mail information.

Screen display
Select the <<Send E-mail Information>> tab on the Ethernet Diagnostics screen.

Screen button

●

Clears the number of times set in each item by '0'.

●

Clears "Number of Error Log Writes" by '0' and the contents of "Error Log".
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18.6.2 Built-in Ethernet type CPU, FXCPU with Ethernet adapter 
connection

Check parameter status, error history, status of each connection, connection status, and time status 
setting of Built-in Ethernet type CPU or FXCPU with Ethernet adapter. 
For details of displayed items, refer to the following manuals.
QCPU User's Manual (Hardware Design, Maintenance and Inspection)
QnUCPU User's Manual (Communication via Built-in Ethernet Port)
MELSEC-L CPU Module User's Manual (Hardware Design, Maintenance and Inspection)
MELSEC-L CPU Module User's Manual (Built-in Ethernet Function)
FX3U-ENET-ADP User's Manual

Screen display
Select [Diagnostics] ⇒ [Ethernet Diagnostics].
The following is a screen of LCPU.

Display contents

Screen button
For the buttons on the screen, refer to Section 18.6.

Monitoring
information

Item Description

Target Module Setting*1 Select "CPU", and specify the CPU to be monitored.
Setting range is CPU number 1 to 4.

Change IP Address Display Switch decimal/hexadecimal notation of IP address display.

Monitoring information

The following built-in Ethernet port information can be monitored.
• Parameter status (■ Monitoring the parameter status)
• Error history (■ Monitoring the error history)
• Status of each connection (■ Monitoring the status of each connection)
• Access history*2 (■ Monitoring the status of each connection)
• Connection status (■ Monitoring the connection status)
• Time status setting (■ Monitoring the time setting status)
• Simple PLC communication status*3 (■ Monitoring the simple PLC communication 

status)
• Protocol status*2 (■ Monitoring the protocol status)

*1 : For QCPU (Q mode) only
*2 : For FXCPU only
*3 : For LCPU only
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■ Monitoring the parameter status

Monitor the parameter status of Built-in Ethernet type CPU or FXCPU with Ethernet adapter.

Screen display
Select the <<Parameter Status>> tab on the Ethernet Diagnostics screen.
The following is a screen of LCPU.

■ Monitoring the error history

Monitor the error history area.

Screen display
Select the <<Error History>> tab on the Ethernet Diagnostics screen.
The following is a screen of LCPU.

Screen button

●

Clears the error history.
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18.6.2  Built-in Ethernet type CPU, FXCPU with Ethernet adapter connection

■ Monitoring the status of each connection

Monitor the status of each connection.
For FXCPU, the status of each connection can be monitored by the access history function.

Screen display
Select the <<Status of Each Connection>> tab on the Ethernet Diagnostics screen.
<QCPU (Q mode)/LCPU>

<FXCPU>

Screen button

●

Clears the error codes.

●  (QCPU (Q mode)/LCPU only)
Clears "Unlock Error Count".

●

Allows the connection of the selected row.

●

Cancels the connection of the selected row.

●  (FXCPU only)
Clears the access history.
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■ Monitoring the connection status

Monitor the connection status.
For FXCPU, the broadcast information is not monitored.

Screen display
Select the <<Connection Status>> tab on the Ethernet Diagnostics screen.
The following is a screen of LCPU.

Screen button

●  (QCPU (Q mode)/LCPU only)
Clears the number of receive buffer overflows and broadcast information.
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■ Monitoring the time setting status

Monitor the time setting status.

Screen display
Select the <<Time Setting Status>> tab on the Ethernet Diagnostics screen.
The following is a screen of Built-in Ethernet port QCPU.

Screen button

●

Sets the time according to the time setting on the <<Built-in Ethernet Port Setting>> tab of PLC 
parameter written to the programmable controller CPU.

● Setting time
For Built-in Ethernet type CPU and FXCPU with Ethernet adapter, the time on a programmable controller CPU can be 
set automatically by collecting the time information from the time information server (SNTP server) connected to the 
LAN according to the time setting on the <<Built-in Ethernet Port Setting>> tab of PLC parameter.
For details of the time setting, refer to the following manuals.
QnUCPU User's Manual (Communication via Built-in Ethernet Port)
MELSEC-L CPU Module User's Manual (Built-in Ethernet Function)
FX3U-ENET-ADP User's Manual



18.6  Diagnosing Ethernet

18.6.2  Built-in Ethernet type CPU, FXCPU with Ethernet adapter connection 18 - 73

17

O
P

E
R

A
TI

N
G

 
PR

O
G

R
A

M
M

AB
LE

 
C

O
N

TR
O

LL
E

R
 C

P
U

18

DI
AG

NO
SI

NG
 

PR
OG

RA
M

M
AB

LE
 

CO
NT

RO
LL

ER
 S

TA
TU

S

19

SI
M

U
LA

TI
N

G
 

O
PE

R
AT

IO
N

S 
O

F 
EX

TE
R

N
AL

 D
EV

IC
ES

20

P
R

IN
TI

N
G

21

S
E

TT
IN

G
 O

P
TI

O
N

S

22

U
S

IN
G

 L
IB

R
A

R
IE

S

A

A
PP

E
N

D
IX

I

IN
D

EX

■ Monitoring the simple PLC communication status

Monitor the simple PLC communication status.
This function can be executed only when using LCPU with a serial number whose first five digits are 
'13042' or higher.

Screen display
Select the <<Simple PLC Communication Status>> tab on the Ethernet Diagnostics screen.

Screen button

●

Displays the Details screen which shows detailed information of each setting.

● Displaying simple PLC communication status
Since the simple PLC communication status indicates the current status, the error history may not be confirmed. 
Confirm errors on the <<Error History>> tab.
(■ Monitoring the error history)
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■ Monitoring the protocol status

Monitor the total number of communication packets.
This function can be executed only when using FXCPU with Ethernet adapter.

Screen display
Select the <<Protocol Status>> tab on the Ethernet Diagnostics screen.

Screen button

●

Clears the protocol status.
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18.6.3 PING test

A PING test is a test to check the existence of Ethernet modules to which the initial processing has 
been completed, or devices with specified IP address on the same Ethernet line.

The following checks are performed when the PING test is executed on Ethernet module, Built-in 
Ethernet type CPU, or FXCPU with Ethernet adapter.
• Whether the line is connected correctly between the host station and the target device.
• Whether the parameters are set correctly for the Ethernet module on host station.
• Whether the initial processing has been completed correctly for the Ethernet module on host station. 

(For Ethernet module only)

● Required setting items
Make sure to check the following before executing the PING test when using an Ethernet module.
• "Station No. ⇔ IP Information" of Ethernet parameter is set.
• RUN LED and INT LED on the Ethernet module are ON.

● System configuration where the PING test can be executed
• A PING test is valid for the system configured with Ethernet, MELSECNET/10(H), and CC-Link IE Controller 

Network. It cannot be executed via CC-Link, CC-Link IE Field Network, and serial communication.
• A PING test can only be executed to the Ethernet module on the same segment as the target station. However, it 

cannot be executed to a host station.
● Administrator authority required to execute the PING test

To execute the PING test, the user must log on Windows® as the user having the administrator authority.

■ PING test overview

The following are the two methods to execute a PING test.
• Sending a ping from an Ethernet module*1

Execute a PING test on a device (PING test target station) exists on the same network as the 
Ethernet module (PING test execution station) which sends a ping.
When "Ethernet Module" is selected for "PLC side I/F" on the Transfer Setup screen, specify a PING 
test target station only.
When "PLC Module" is selected for "PLC side I/F" on the Transfer Setup screen, specify a PING test 
execution station and a PING test target station.

*1 : Not supported by FXCPU with Ethernet adapter.

• Sending a ping from an Ethernet board on a personal computer
The same operation as a PING test executed by the command prompt of Windows®. A PING test is 
executed on a device on the network via Ethernet from a personal computer.
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● Sending a ping from an Ethernet module (when "Ethernet Module" is selected for 
"PLC side I/F")
A PING test is executed on a device on the same network from the access station when accessing 
the programmable controller CPU via Ethernet module.
This function is not supported by FXCPU with Ethernet adapter.
PING test execution station: Access target station (A station does not need to be specified.)
PING test target station: Specify a device on the same network as the access target station.

Select "Module No." for "Target Module Setting" on the Ethernet Diagnostics screen.
For the settings on the Transfer Setup screen, refer to the following example.
For the system configuration described in the following figure, configure the settings of the 
connection destination as shown below to execute a PING test for station number 1 from the station 
number 2.

Station number: 2
(192.168.0.4)

Ethernet
module

Station number: 1
(192.168.0.3)

Ethernet
module

(PING test target station)(PING test execution station)

Network number 1 Ethernet

Station number: 3

Access target station Send a ping.
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● Sending a ping from an Ethernet module (when "PLC Module" is selected for "PLC side I/F")
A PING test is executed on a device on the same network from an Ethernet module which exists on 
the same base unit as the connected station when accessing the programmable controller CPU with 
a serial/USB/Ethernet port direct connection or a connection via Ethernet hub.
This function is not supported by the programmable controller CPU accessed via a built-in Ethernet 
port of Built-in Ethernet type CPU or FXCPU with Ethernet adapter.
PING test execution station: Specify an Ethernet module which exists on the same base unit as the 
connected station.
PING test target station: Specify a device on the same network as the PING test execution station.

Select "Module No." for "Target Module Setting" on the Ethernet Diagnostics screen.
For the settings on the Transfer Setup screen, refer to the following example.
For the system configuration described in the following figure, configure the settings of the 
connection destination as shown below to execute a PING test for the station number 2 on the 
network number 2.

When the Ethernet module (station number 1 on network number 1 in the system shown below) is Q 
series-compatible E71 module, a PING test can be executed with the function version B or later only.

Station number: 1

Station number: 1

Station number: 2

Ethernet 
module

Station number: 2
(192.168.0.3)

Ethernet 
module

Ethernet

Ethernet

Ethernet 
module

Ethernet 
module

(PING test target station)

Network number 1

Network number 2

Serial/USB/Ethernet port direct connection 
or connection via Ethernet hub

Connective station

(PING test execution station)

Send a ping.
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● Sending a ping from an Ethernet board on a personal computer
Select "CPU" for "Target Module Setting" on the Ethernet Diagnostics screen.
Settings on the Transfer Setup screen is not necessary. The already-set connection destination 
settings do not affect the execution of PING test.
For FXCPU with Ethernet adapter, the specification of target module is not necessary.

Screen display
Perform any of the following operations.
Click the  button on the Ethernet Diagnostics screen.
Click the  button the Ethernet Diagnostics screen and click the  button on 
the Loop Test screen.
● Sending a ping from an Ethernet module (when "Module No." is selected for "Target Module 

Setting")

● Sending a ping from an Ethernet board on a personal computer (when "CPU" is selected for 
"Target Module Setting")

PING test 
information

Sub status bar

<<"PLC Module" is selected for "PLC side I/F">><<"Ethernet Module" is selected for "PLC side I/F">>

PING test 
information

Sub status bar
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Operating procedure

1. Set the items on the screen.

2. Click the  button.
The PING test is executed according to the settings.

Display contents

Screen button

●

Resets the setting items of option setting to their defaults.

Item Description

Input Item –

Address 
Specification Set the IP address of the target Ethernet module for PING test.

Transfer Setup Specify the connection destination of the PING test.

Execution 
Station of PING

Set the network number and station number of the Ethernet module which executes the PING 
test.

Target of PING Set the IP address of the Ethernet module which is a target of the PING test.

Setting Options

Set whether to display a host name in the result. Also set data size (For Q series-compatible E71 
and FXCPU with Ethernet adapter: 1 to 8,192 bytes, for Built-in Ethernet type CPU: 1 to 1,460 
bytes), communication time check (1 to 30 seconds), number of transmissions (1 to 50 times, or 
until interrupted).

Item Description

PING test information Display the IP address and data size to which the PING test is executed.

When "Module No." is selected for "Target Module Setting" ("Ethernet Module" is selected for "PLC side I/F")*1
When "CPU" is selected for "Target Module Setting*1

● Transmitting data
• When successful

IP address (example: Reply from 10.97.29.75): Data size (example: bytes=32)
Communication speed (example: time<1ms TTL=128)

• When unsuccessful
Request timed out.

● Completion of data transmission
Packets transmitted
Received
Lost
Minimum packet round-trip time (ms)
Maximum packet round-trip time (ms)
Average packet round-trip time (ms)
"Packets transmitted" and "Received" are updated each time a packet is sent.

When "Module No." is selected for "Target Module Setting" ("PLC Module" is selected for "PLC side I/F")*1

● Transmitting data
• When successful

Success
• When unsuccessful

Time Out
● Completion of data transmission

Packets transmitted
Received
Lost
"Packets transmitted" and "Received" are updated each time a packet is sent.

Sub status bar Display the number of send successes and total number of packet transmissions.

*1 : Not supported by FXCPU.
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18.6.4 Loopback test

A loopback test is a test to check whether the initial processing of each module has been completed by 
sending a loopback test message to the Q series-compatible E71 modules (function version B or later) 
of the specified network number or station number.

The following checks are performed when the loopback test is executed.
• Whether the line is connected correctly between the host station and the target device.
• Whether the parameters are set correctly for the Ethernet module on host station.
• Whether the initial processing has been completed correctly for the Ethernet module on host station.

● Required setting items
Make sure to check the following before executing the loopback test when using an Ethernet module.
• "Station No. ⇔ IP Information" of Ethernet parameter is set.
• RUN LED and INT LED on the Ethernet module are ON.

● System configuration where the loopback test can be executed
• A loopback test is available only with Q series-compatible E71 modules (function version B or later). Ethernet 

modules (function version A) are treated as "No Response" even if connected.
A loopback test is valid for the system configured only with Ethernet.

• A loopback test can only be executed to the Ethernet module on the same segment as the target station.
● Considerations for executing the loopback test

In a multiple network system, to execute the loopback test by specifying a station number in another network number, 
setting the routing parameters is necessary.
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■ Loopback test overview

For a loopback test, a target station differs according to the connection destination setting described 
below.
• When "Ethernet Module" is selected for "PLC side I/F" on the Transfer Setup screen.
• When "PLC Module" is selected for "PLC side I/F" on the Transfer Setup screen.

● When "Ethernet Module" is selected for "PLC side I/F"

A loopback test is executed to the network number specified on the Loopback Test screen when 
accessing the programmable controller CPU via Ethernet module.
In the system as shown below, when the loopback test is executed for station numbers 2 to 4 in 
network number 2, the response from the station number 2 (loopback test execution station) is 
treated as "No Response".

Station number 1 Station number 3 Station number 5

Station number 2 Station number 4 Station number 6 Station number 8

Station number 7 Station number 9

Set the confirmation 
station numbers from 1 
to 5 on the Loopback 
Test screen.

Network number 1

Network number 2

Station number 4

Station number 3

The response is 
treated as "No 
Response".
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● When "PLC Module" is selected for "PLC side I/F"

A loopback test is executed to the network number specified on the Loopback Test screen when 
accessing the programmable controller CPU with a serial/USB/Ethernet port direct connection or a 
connection via Ethernet hub.
For the system configuration described in the following figure, configure the settings of the 
connection destination as shown below to execute a loopback test for the Ethernet module on the 
network number 2.

Station number 1 Station number 3 Station number 5 Station number 7 Station number 9

Station number 2 Station number 4 Station number 6 Station number 8

Set the confirmation 
station numbers from 1 
to 5 on the Loopback 
Test screen.

Serial/USB/Ethernet port direct connection 
or connection via Ethernet hub

Network number 1

Network number 2

Target station
Station number 3

Target station
Station number 2

Target station
Station number 1

Station number 2
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Screen display

Click the  button on the Ethernet Diagnostics screen.

Display contents

Item Description

Network No. Set the network number for which the loopback test is executed.
Setting range: 1 to 239

Number of Confirmation 
Nodes

Set the station number to be checked.
Setting range: 1 to 64

Check at 
Communication Time

Setting range: 1 to 99 seconds.

 of Ethernet parameter includes TCP Resend Timer. The 
communication time check value of loopback test must be larger than the value set for TCP Resend 
Timer. If not, the tested Ethernet module may be judged inexistent even if it is connected correctly.

Result

The loopback test is executed in order from the start station number and whether or not the response 
is returned within the set communication time check value is displayed in the order of station 
numbers.
If an IP address is duplicated, such IP address is displayed in red.

IP Address Input Style Switch decimal/hexadecimal notation of IP address display.
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18.7 Executing Sensor/Device Monitor

Check the status of the equipment connected with AnyWireASLINK or CC-Link.
For details of monitoring equipment connected with AnyWireASLINK or CC-Link, refer to the following 
manual.
iQ Sensor Solution Reference Manual

Q CPU L CPU FXRemote FXHead FXFX
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18.8 System Monitor

This section explains how to display the system status of the programmable controller CPU.

Screen display
Select [Diagnostics] ⇒ [System Monitor].
Some terms and module images are different but the screen configurations are same between 
the screens of QCPU (Q mode) and LCPU. The screens of QCPU (Q mode) are used in this 
section.

<QCPU (Q mode) (without extension base unit)>

<QCPU (Q mode) (with extension base unit)>

Remote HeadQ CPU L CPU FXFX
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<Redundant CPU>

<Remote I/O module>
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Display contents

Item Description

Monitor Status Display the current monitor status.

Connection Channel List Display the information of the route to the connection destination.

Mode*1 Select this to perform either system monitor or online module change function.

System Monitor Execute the system monitor.

Online Module Change Execute the online module change. (For details, refer to Section 18.9)

Main Base*2 Display the operating status of the module and I/O address.

Redundant system (Target 
system)*3

Display the information of the target system.

Operation to Selected 
Module

Display the name, slot number, and model name of the base unit/block to which the selected 
module is mounted.*4

Extension Base*2
This item is displayed when the extension base unit/block is connected. Switch the display by 
pressing the arrow button on the right. The base unit/block, operating status of the module, and 
I/O address are displayed.

Base Information List*2 Display the status of each base unit/block.

Base*2 Display the status of the base unit/block.

Module Display the error status of each module mounted to the base unit/block.

Base Model Name*2 Display the base name set to the parameter on the programmable controller CPU.
If the parameter is not set, "Main Base", "Extension Base 1" to "Extension Base 7" are displayed.

Power Supply Display whether there is power supply.

Base Type*5,*6 Display the type of the base unit (Q or QA).

Slots*5 Display the slot number.

Installed Modules*5 Display the number of modules mounted to the base unit.

Number Of Total Modules 
Occupations*7 Display the total number of modules counted for all mounted modules.*8

Module Information List Display the information of modules on the base unit/block where the selected module is mounted.

Status Display the status of each module.

Base-Slot*2 Display the slot number of each module.

Series*4 Display the series of each module.

Model Name*4 Display the model name of each module.

Point*4 Display the number of occupied I/O points of each module.

Parameter
Type Display the type/points of each module set to the parameter on the programmable controller CPU.

If the parameter is not set, type/points of the mounted module is displayed.Point*4

I/O Address*4 Display the I/O address of each module set to the parameter on the programmable controller CPU.

Network No. Station No.*4 Display the network number and the station number set to each module.

Master PLC*5
Display the programmable controller CPU number that controls each module in a multiple CPU 
configuration.
"-" is displayed for the programmable controller CPU or the blank slot.

Number Of Module 
Occupied*7,*8 Display the number of modules counted for each module.

Legend Display the legend of the icon displayed on the screen.

*1 : For Process CPU, Redundant CPU, and remote I/O module only.
*2 : Each item is displayed as shown below according to the programmable controller series.

QCPU (Q mode) LCPU

Main Base Main Block

Extension base Extension block

Base Information List Block Information List

Base Block

Base Model Name Block Name

Base-Slot Block-Slot
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● Connection Channel List
In "Connection Channel List", the route information of the connection destination setting is displayed at all times.

● QA extension base unit
The following are the considerations when using a QA extension base unit.
• High Performance model QCPU and Universal model QCPU with a serial number whose first digits are '12102' or 

higher support QA extension base unit, and for those programmable controller CPUs which do not support it, QA 
extension base unit is not displayed on the System Monitor screen.

• When it is mounted on A series module or QnA series module, the images are common on the system monitor of 
both A series and QnA series modules. Furthermore, a module type is displayed for Model Name of Module 
Information List.

• When A series or QnA series module is selected, the functions under "Operation to Selected Module" cannot be 
performed.

● System monitor when a GOT is connected via bus
When a GOT is connected via bus, a single row of extension base unit (16 points x 10 slots) is displayed on the System 
Monitor screen, and the GOT is displayed as an intelligent function module with 16 I/O points.
The displayed slot position is the position set on the GOT side.
For details of GOT bus connection, refer to the following manuals.
GOT1000 Series Connection Manual
GOT-A900 Series User's Manual (Connection System Manual)

*3 : For Redundant CPU only
*4 : "*****", "-", and "**" are displayed if the module is not mounted or the parameter is different with the mounting status.
*5 : For QCPU (Q mode) only
*6 : "QA" is displayed for QA extension base unit. "Q" is displayed for other base units.
*7 : For LCPU only
*8 : A module with width exceeding 28.5mm logically counts as two modules. 

Be sure that "Number Of Total Modules Occupations" does not exceed the number of modules that can be mounted.
MELSEC-L CPU Module User's Manual (Hardware Design, Maintenance and Inspection)
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Screen button

●

Displays the illustration of the connection route.
(Section 11.1.1)

●

Displays the module information of the selected module.
The following is an example of the Module's Detailed Information screen when QJ71LP21-25 is 
selected.
(Section 18.8.1)
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●

Displays the hardware LED information and the hardware switch information.
The display contents of the H/W Information differ according to module version.
For details, refer to the User's Manual of each module.

●

Displays the diagnostic information of the selected module.
The following is an example of the PLC Diagnostics screen when the programmable controller CPU 
module is selected.
(Section 18.1)
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●

Displays error history logs of the module selected on the System Monitor screen.
This button is available when GX Works2 is connected to the programmable controller CPU that 
supports the module error history collection function.
(Section 18.8.2)

●

Prints the figure of the system configuration.
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●

Displays the product information of each module mounted to the base unit/block.

• Clicking the  button saves the product information data in CSV file format.

●

Displays all error history logs of the programmable controller and modules.
This button is available when GX Works2 is connected to the programmable controller CPU that 
supports the module error history collection function.
(Section 18.8.2)
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● Operation to selected module
The functions of "Operation to Selected Module" can also be executed from the shortcut menu by selecting modules 
from "Main Base" or "Extension Base" ("Main Block" or "Extension Block" for LCPU).

● Displaying module status
The following screen is displayed if the mounting status of the module cannot be obtained due to the incorrect 
parameter settings.
Execute the system monitor function again after adjusting the parameter to the mounting status.
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■ Error icons

The following table shows the details of the error status icons of the programmable controller CPU and 
the modules.

■ Display when mounted modules do not match with the I/O assignment 
setting on PLC parameter

The following shows "Module Information List" on the System monitor function according to the I/O 
assignment on PLC parameter. If module mounting status does not match with the I/O assignment, 
change "I/O Assignment" of the I/O assignment setting to match with the mounting status. "*****", "-", 
and "**" are displayed if the module is not mounted, or the parameter is different with the mounting 
status.

Module Icon Error Programmable controller CPU status

Programmable 
controller CPU

 Serious error MAIN CPU down RESET and others

 Moderate error Stop error STOP due to error in parameter or instruction codes

 Minor error Error allowing operation Errors that allow RUN status such as battery low and 
annunciator ON

 Assignment error Assignment error Assignment errors such as multiple CPU setting is not 
set.

Module

 Error H/W error H/W errors in the base or the power supply

 Serious error*1 Module system error H/W errors in modules

 Moderate error Module error No appropriate environment for executing the functions 
of modules

 Minor error*1 Module warning Impropriety in programs or user's operations

 Assignment error Assignment error

The assigning status of the module is different with the 
mounting status of the module.
(The status that the module type and points cannot be 
obtained.)

 Illegal assignment Illegal assignment

The assigning status of the module is different with the 
mounting status of the module.
(The status that the module type and points can be 
obtained.)

*1 : This item is not displayed for remote I/O module.
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18.8.1 Checking module's detailed information

Display the module information of the selected module.

■ Modules of QCPU (Q mode)/LCPU

Screen display

Select a module on the System Monitor screen and click the  button.
The following is an example of the Module's Detailed Information screen when QJ71LP21-25 is 
selected.

Screen button

●

Displays the hardware LED information and the hardware switch information. (Section 18.8)

●

Updates the error history of the module.

●  (Supported by LCPU only)
Deletes the error history of the module.

●

Clears the error displayed in "Latest Error Code".
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18.8.1  Checking module's detailed information

■ Built-in I/O module

Screen display

Select a built-in I/O module on the System Monitor screen and click the  button.

Screen button
For the buttons on the screen, refer to ■ Modules of QCPU (Q mode)/LCPU.

● /
Displays/hides the built-in function buttons.
For details of the built-in function buttons, refer to the following sections.
• Positioning monitor Section 18.10.1
• High-speed counter monitor Section 18.10.2
• I/O monitor Section 18.10.3
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■ Built-in CC-Link module

Screen display

Select a built-in CC-Link module on the System Monitor screen and click the  
button.

Screen button
For the buttons on the screen, refer to ■ Modules of QCPU (Q mode)/LCPU.
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18.8.2  Checking details of error history

18.8.2 Checking details of error history

Check error history of the programmable controller CPU and modules.
Error history of a specified module can be displayed by using the refine search function.

Screen display

Select [Diagnostics] ⇒ [System Monitor] ⇒ / .
<Error history (when programmable controller CPU is selected>

<System error history>
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Display contents

Screen button
For the buttons on the screen, refer to Section 18.8.

●

Clears all refinement criteria.

●

Displays the Enter Refine Criteria screen.
To start refining the search, click the  button.

●

Clears the error history saved on the programmable controller CPU.

●

Updates information displayed in the error history list.

●

Exports information displayed in the error history list to a file in CSV format.

● Programmable controller CPUs and modules that support the function to display detailed error history
Detailed error history can be displayed when a programmable controller CPU and intelligent function module that 
support the module error history collection function are used.
For versions of modules that support the function, refer to the User’s Manual of each module.

Item Description

Monitor Status Display the current monitor status.

Connection Channel List Display the information of the connection destination setting.

Refine Search Display the refinement criteria for the error history list.
Not displayed when no refinement criterion is specified.

Error History List –

Error Code Notation Select the display format of error codes (DEC/HEX).

No. Display the error history number. Errors are numbered in order of occurring.

Error Code Display the error code that indicates details of the error.

Date and Time Display date and time of the error occurrence.

Model Name Display the model name of the module on which the error occurs.

Start I/O Display the start I/O number of the module on which the error occurs.

Error Details –

Model Name Display the model name of the module selected in the error history list.

Start I/O Display the start I/O number of the module selected in the error history list.
For the module that uses multiple slots, the starting slot is only displayed.

Mount Position Display the mount position of the module selected in the error history list.

<<Error and Solution>> Display the explanation and solution of the error on the module being selected in the error 
history list.

<<Intelligent Module 
Information>>

Display the module information at the error occurrence of the intelligent function module 
being selected in the error history list.
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18.9 Changing Modules Online

*1 : Process CPU and Redundant CPU only

This section explains how to change modules online.

Screen display
Select [Diagnostics] ⇒ [Online Module Change].
<Remote I/O module>

Operating procedure

1. Double-click the module to be exchanged on the System Monitor screen.
The Online Module Change screen is displayed.

2. Change the module by following the instruction of "Status/Guidance".

FXFXHeadRemoteL CPUQ CPU
*1
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● Remote I/O module versions compatible with Online module change
Use the function version D or later to perform the Online module change function on a remote I/O module.
For the method for checking the function version, refer to the following manual.
Q Corresponding MELSECNET/H Network System Reference Manual (Remote I/O network)

● Canceling Online module change

• Online module change can be suspended by clicking the  button during the process of Online module 
change to check the system status with monitoring or current value change.

• Online module change can be continued from the suspended status by selecting [Diagnostics] ⇒ [Online Module 
Change].

• Online module change can also be continued when GX Works2 is terminated during the process of Online module 
change by restarting GX Works2 and performing the same operation above.

● Executing Online module change on a single programmable controller CPU from two personal computers
The authority to execute Online module change can be transferred to the personal computer which executed the 
function later.

● Online module change during monitoring
Stop monitoring before executing Online module change.
Online module change can be executed without stopping the monitoring, however, the following message will be 
displayed.

Restrictions

● Restrictions on Online module change
• Online module change cannot be performed to multiple modules simultaneously.
• Online module change cannot be continued when the programmable controller CPU is reset, or the power is turned 

OFF during the process of Online module change.
• Online module change cannot be performed when a Process CPU or Redundant CPU is in the following state.

• The RESET/L.CLR switch of the programmable controller CPU is reset.
• A stop error occurred and the programmable controller CPU is stopped.
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18.10.1  Positioning monitor

18.10 Built-in I/O Module Tools

This section explains how to monitor the operating status of the positioning function, high-speed 
counter function, and I/O signals using the built-in I/O module tools.
For the monitoring items and setting values, refer to MELSEC-L CPU Module User’s Manual (Built-in I/
O Function).

18.10.1 Positioning monitor

Monitor the operating status of the positioning function.
The methods for executing the error reset and OPR OFF are also explained.

Screen display
Select [Tool] ⇒ [Built-In I/O Module Tool] ⇒ [Positioning Monitor].

Display contents

Screen button

●

Executes the error reset of the selected axis.

●

Executes the OPR OFF of the selected axis.

FXFXHeadRemoteL CPUQ CPU

Item Description

Monitor Display the current status.

Test –

Error Reset Click  to select an axis to execute the error reset.

OPR OFF Click  to select an axis to execute the OPR OFF.
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18.10.2 High-speed counter monitor

Monitor the operating status of the high-speed counter function.
The methods for executing the current value preset and error reset are also explained.

Screen display
Select [Tool] ⇒ [Built-In I/O Module Tool] ⇒ [High-Speed Counter Monitor].

Display contents

Screen button

●

Applies the preset value of the selected channel to the programmable controller CPU.

●

Executes the error reset of the selected channel.

Item Description

Monitor Display the current status.

Test –

Current Value Preset Click  to select a channel.
After selecting the channel, enter the preset value.

Error Reset Click  to select a channel to execute the error reset.
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18.10.3  I/O monitor

18.10.3 I/O monitor

Monitor the I/O signals.

Screen display
Select [Tool] ⇒ [Built-In I/O Module Tool] ⇒ [I/O Monitor].

Display contents

Item Description

Input Signal Display the status of each input signal.

Output Signal Display the status of each output signal.
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19 - 1

19 SIMULATING 
OPERATIONS OF 
EXTERNAL DEVICES

This chapter explains debugging operations using the I/O system setting function.

19.1 I/O System Setting Function 19 - 2

19.2 Operating Procedure of I/O System Setting Function 19 - 7

19.3 Screen Configuration of I/O System Setting Function 19 - 8

19.4 Setting by Inputting Device Values 19 - 10

19.5 Setting Using Timing Charts 19 - 15

19.6 Performing I/O System Setting Function 19 - 27

19.7 Monitoring I/O System Setting 19 - 28

19.8 Operating I/O System Setting Files 19 - 30
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19.1.1  Differences between conventional debugging and debugging with I/O system setting function

19.1 I/O System Setting Function

The I/O system setting function simulates operations of external devices.
Using the I/O system setting function, operations of external devices can be simulated without a 
special debugging sequence program. Since input devices (X) can also be turned ON/OFF, devices in 
programs do not need to be rewritten during the simulation.

19.1.1 Differences between conventional debugging and 
debugging with I/O system setting function

This section explains differences between conventional debugging and debugging with the I/O system 
setting function.

■ Conventional debugging

1) Devices need to be rewritten
As input devices (X) can be turned ON/OFF only with an external device connected to the I/O 
module, the program needs to be modified by changing X0 → M0, X1 → M1, etc. to conduct 
debugging without an external device.

2) A sequence program for debugging is required
A debugging sequence program needs to be added to simulate operations of external devices.

■ Debugging with the I/O system setting function

1) Devices do not need to be rewritten
It is not necessary to rewrite devices (X0 → M0) as input devices (X) can be turned ON/OFF with 
the I/O system setting function.

2) A sequence program for debugging is not required
For sequence actions for debugging can be set/changed easily from the setting screen, a 
sequence program for debugging is not required.

Q CPU L CPU FXFXRemote FXHead
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Example: Simulating operations of program when Y0 is turned ON, and 5 seconds later X1 is turned 
ON to stop running

<Conventional debugging> <Debugging using the I/O system setting function>

<Setting on the I/O System Setting screen>

1) Devices need to be rewritten 1) Devices do not need to be rewritten

2) A sequence program for debugging 

    is required

2) A sequence program for debugging 

    is not required

Settings set in the I/O system setting screen are saved 

in a file as a sequence program shown below.

Y0

T0

M1

X0-M0

Start

Y0

Y0 K50

T0

Stop

X1-M1

Run

Y0

X0

Start

Y0

Y0

5 sec. timer 
setting

5 sec. timer

SET X1

Stop

X1

Run

<Image of operation>*1

*1: The program is an image of operation.
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19.1.2  Conditions and sequence actions for simulation

19.1.2 Conditions and sequence actions for simulation

The I/O system setting function simulates operations of external devices according to specified 
conditions and sequence actions for debugging.
In "Condition", set a condition for starting up a sequence action for debugging. For settings of 
conditions, refer to Table 19.1.2-1.
In "Sequence Action", set devices of which values are to be changed or a timing chart which is to be 
started up at timing when the condition is true, using either of two kinds of setting methods: device 
value input and timing chat input. For details, refer to Section 19.1.3.
Sequence actions for debugging can be switched easily by selecting/clearing "Enable" on the I/O 
system setting screen.

Example) Settings on the I/O system setting screen using the device value input

By selecting/clearing "Enable", 

sequence actions for debugging can be 

switched easily.
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● Combinations of conditions and examples of settings on the I/O system setting screen

Table 19.1.2-1 Combination of conditions and setting examples
Combination of conditions Condition setting on the I/O system setting screen

1

2

3

4

5

6

7
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19.1.3  Timing chart input and device value input

19.1.3 Timing chart input and device value input

There are two methods to set sequence actions in the I/O system setting function: one is the device 
value input to change value of a desired device after a specified amount of time has elapsed when a 
condition has been satisfied; the other is the time chart input to execute a timing chart when a condition 
has been satisfied.
● Device value input

A value of a specified device can be changed after the specified condition is satisfied and the time 
specified for the timer is elapsed.
This enables actions such as the following.

● Sequence action after timer activation
After the timer is activated, the timer will not be suspended even when the condition changes to unsatisfied status, and 
the sequence action is performed to change the value of the specified device.

● Timing chart input
When a specified condition has been satisfied, device variation defined in timing chart format can be 
performed.
This enables complicated actions such as the following.

<Setting of device value input>

Example: "When Y0 is turned ON, 5 seconds later X0 and X3 are turned ON"

Condition Timer Sequence action

<Setting of timing chart input>

Example: "When Y0 is turned ON, D0 is counted up, Y0 is turned OFF when X0 is turned ON"

Condition Timing chart format
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19.2 Operating Procedure of I/O System Setting Function

The following shows the operating procedure of the I/O system setting function.

*1 : Section 15.2
*2 : Section 19.3
*3 : Section 19.4
*4 : Section 19.5
*5 : Section 19.8.3
*6 : Section 19.6
*7 : Section 19.7

Q CPU L CPU FXFXRemote FXHead

Do you want to set 

the I/O system

by inputting device

values?

YES

NO

YES

NO

YES

NO

Do you want to set 

the I/O system

using timing

charts?

Save the I/O system setting

Do you want to start 

monitoring with 

the I/O system

setting?

Start simulation

Enter device values

Use timing charts

Start monitoring

Execute the I/O system setting

End simulation

Start the I/O system setting 

from the GX Simulator2 screen

*1

*1

*2

*5

*3

*4

*7

*6
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19.3 Screen Configuration of I/O System Setting Function

This section explains the screen configuration of the I/O system setting function.

Screen display
Select the GX Simulator2 screen ⇒ [Tool] ⇒ [I/O System Setting].

Display contents

Q CPU L CPU FXFXRemote FXHead

Menu bar

I/O system 

setting tree

Status bar

Toolbar

Edit/monitor 

screen

Item Description Reference

Menu bar Display menu options for executing each function. Section 1.3.12

Toolbar Display tool buttons for executing each function. Appendix 1.8

File under Editing Display the name of a file being edited. –

File under Execution Display the name of a file being executed. –

I/O system setting tree

Select a setting method for the I/O system setting.
● Timing Chart Input

To set the I/O system setting in timing chart format, double-click the 
number to be set.

● Device Value Input
To set the I/O system setting by setting device values, double-click the 
number to be set.*1

Section 19.4
Section 19.5

Edit/monitor screen

Edit/monitor the I/O system setting.
● At timing chart input

● At device value input

Section 19.4
Section 19.5

Status bar Display information about a project being edited. –

*1 : For FXCPU, the setting range is No. 1 to No. 100.
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● Target Simulator Setting screen (QCPU (Q mode)/LCPU)
If simulation has been started from multiple projects at startup of the I/O system setting function, the Target Simulator 
Setting screen is displayed to specify a simulator (virtual programmable controller) on which the I/O system setting is 
performed.

Restrictions

● Startup of the I/O system setting
The I/O system setting of GX Simulator Version 7 and the I/O system setting of GX Works2 cannot be started up 
simultaneously.
Startup the I/O system setting of GX Works2 after disabling the I/O system setting of GX Simulator Version 7.
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19.4 Setting by Inputting Device Values

This section explains how to configure the I/O system setting by inputting device values.

Operating procedure

1. Double-click a desired setting number from "Device Value Input" in the I/O system 
setting tree.

2. Set the items on the screen.

Q CPU L CPU FXFXRemote FXHead

Double-

click

Item Description

No. Setting number in the I/O System Setting screen.

Condition

Specify the input condition from the virtual programmable controller.

The Device Specification screen is displayed by clicking .
(Section 19.4.1)
Bit devices and word devices can be specified for the input condition. Labels cannot be 
specified.
For a bit device, ON/OFF can be set in a designated condition; for a word device, 
comparison (=,<>,<,>,<=,>=) with a constant or another word device can be set in a 
designated condition.
In addition, a relational condition can be set by specifying AND/OR operation.

With an And operation, the condition is satisfied if both designated conditions on the left 
and right are achieved. Otherwise, the condition is not satisfied.
With an OR operation, the condition is satisfied if either or both of designated conditions in 
upper and lower columns are achieved.

Timer ms
Set a period of time from when the specified condition is satisfied until the sequence action 
is issued.
The setting range is 1 to 1000 (10 to 10000ms).

Sequence Action Set a bit device to be turned ON/OFF or a word device of which the value is to be changed 
after the specified condition is satisfied. Labels cannot be set.

Setting Set whether each setting is to be enabled/disabled. Select this to enable the setting.

AND operation

OR operation
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19.4.1 Setting conditions

Conditions can be entered directly, or set on the Device Specification screen.
For devices that can be entered for conditions, refer to Appendix 2.2.
Note that there are devices which are not supported by the I/O system setting. For unsupported 
devices, refer to Restrictions in this section.
● Data entry method (direct data entry)

Operation
• Enter conditional expressions directly.

Example) For bit devices: X0=ON, M10=OFF
For word devices: D0=20, D5<20, D15<>5, D25>=10, D0=D50

● Data entry method (set on the Device Specification screen)

Operation
• Set the items on the screen.

<When a bit device is selected> <When a word device is selected>

Item Description

Compare Source –

<<Device>> –

Device Set a device.

<<Buffer Memory>>*1 –

Module Start (HEX) Enter a start I/O number of the intelligent function module in hexadecimal.

Address Enter a buffer memory address in decimal/hexadecimal.

Decimal/Hexadecimal Select an input form (decimal/hexadecimal) of the buffer memory address.

Condition Select a comparison condition when the compare source is other than a bit 
device.

Compare Destination –

<<Value>> –

Select ON/OFF Specify ON/OFF when the compare source is a bit device.

Value Enter a value when the compare source is a word device.

<<Device>> –

Device Set a device.

<<Buffer Memory>>*1 –

Module Start (HEX) Enter a start I/O number of the intelligent function module in hexadecimal.

Address Enter a buffer memory address in decimal/hexadecimal.

Decimal/Hexadecimal Select an input form (decimal/hexadecimal) of the buffer memory address.

*1 : For FXCPU, these items are supported by FX3U and FX3UC only.
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19.4.1  Setting conditions

Restrictions

● Unsupported devices
The following special relays are not supported by the I/O system setting.
Use other supported devices to set conditions.
• SM402 (After RUN, ON for only 1 scan)
• SM403 (After RUN, OFF for only 1 scan)
• SM404 (Low speed execution type program After RUN, ON for 1 scan only)
• SM405 (Low speed execution type program After RUN, OFF for 1 scan only)
• SM1038 (After RUN, ON for only 1 scan)
• SM1039 (After RUN, OFF for only 1 scan)
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19.4.2 Setting sequence actions

Sequence actions can be entered directly, or set on the Bit Device Setting screen or the Word Device 
Setting screen.
For devices that can be entered for conditions, refer to the following section.
(Appendix 2.2)
● Data entry method (direct data entry)

Operation
• Enter devices directly.

Example) For bit devices: X2-4, M5, M7
For word devices: D12=234, D20=10

● Data entry method (set on the Bit Device Setting screen)

Operation
• Set the items on the screen.

Item Description

Bit Device List Display the list of bit devices being set.

Bit Device Setting –

Device (from) Set a bit device.

Device No. (to) Set an end bit device number for the range specification.
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19.4.2  Setting sequence actions

● Data entry method (set on the Word Device Setting screen)

Operation
• Set the items on the screen.

■ Data entry method for direct data entry

Enter a device of which a value is to be changed when the specified condition is satisfied.

For setting multiple devices, separate each device with ",".
For setting consecutive devices, connect the start device number and end device number with "-".

Example) X0, X2, M10-20
D0=100, W0=100

● Number of device points that can be executed simultaneously
Up to 25000 device points can be executed simultaneously in the device input of the I/O system setting.

● Setting conditions and sequence operation
• Index settings (Example: D0Z0), bit-specified word device (Example: D0.0), and digit-specified bit device (Example: 

K4X0) cannot be set in the conditions and sequence operation.
• The I/O system setting does not support local devices. When local devices are set, the I/O system setting may not 

perform properly.

● Cutting/copying/pasting I/O system setting by unit of setting number
The I/O system setting can be cut/copied/pasted by unit of setting number.
To cut/copy/paste the I/O system setting, click a setting number of the I/O system setting and select [Edit] ⇒ [Cut]/
[Copy]/[Paste].

Item Description

Word Device List Display the list of word devices being set.

<<Device>> –

Device Set a word device.

Setting Value/Device Set a device value or device.

<<Buffer memory>>*1 –

Module Start (HEX) Enter a start number of the module in hexadecimal.

Address Enter a buffer memory address in decimal/hexadecimal.

Decimal/Hexadecimal Select an input form (decimal/hexadecimal) of the buffer memory address.

*1 : For FXCPU, these items are supported by FX3U and FX3UC only.
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19.5 Setting Using Timing Charts

This section explains how to set the I/O system setting using timing charts.

Operating procedure

1. Double-click a desired setting number from "Timing Chart Input" in the I/O system 
setting tree.

2. Set the items on the screen.

● Cutting/copying/pasting I/O system setting by unit of setting number
The I/O system setting can be cut/copied/pasted by unit of setting number.
To cut/copy/paste the I/O system setting, click a setting number of the I/O system setting and select [Edit] ⇒ [Cut]/
[Copy]/[Paste].

Q CPU L CPU FXFXRemote FXHead

Double-

click

Item Description

No. Setting number in the I/O System Setting screen.

Condition Specify the input condition from the simulation. (Section 19.4.1)

Timing Chart Format
The Edit Timing Chart Format screen is displayed by clicking the 

 button.

Keep Select this to execute the timing specified in the timing chart repeatedly.

Setting Set whether each setting is to be enabled/disabled. Select this to enable the 
setting.
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19.5.1  Setting in timing chart format

19.5.1 Setting in timing chart format

The following shows the setting procedure on the Edit Timing Chart Format screen.

*1 : Section 19.5.6
*2 : Section 19.5.3
*3 : Section 19.5.4
*4 : Section 19.5.5

Do you want to read

a timing chart data file saved

with GX Simulator?

YES

NO

YES

NO

Do you want to repeat

scans for the specified

number of times?

Register devices

Read a timing chart data file

Start setting

Set the number of scans

Set/edit timing

End setting

*1

*2

*3

*4
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19.5.2 Screen configuration of Edit Timing Chart Format screen

The following explains the screen configuration of the Edit Timing Chart Format screen.

Screen display

Select the Timing Chart Input screen ⇒ .

Display contents

Device name/
device value

Menu bar

Number 
of scans

Status

Toolbar

Item Description Reference

Menu bar Display menu options for executing each function. –

Toolbar Display tool buttons for executing each function. –

Device name/device 
value

Display devices specified in the Enter Device screen.
● Bit device

The device name is displayed in yellow when the device is ON at the timing of the 
cursor position.

● Word device
The device value at timing of the cursor position is displayed in a text box on the 
right of the device name.
When a word device is specified as 32-bit integer, (D) is added at the end of the 
device name, and when a word device is specified as single precision real 
number, (E) is added at the end of the device name.

Example) D0(D), W6(D), D10(E), W60(E)

–

Number of scans

Display the number of scans at the timing.
To repeat a scan for the specified number of times, set the number of scans. 
(Section 19.5.5)

When "Keep" below the  button is selected, enabled 
scans can be repeated while the condition is satisfied.
(Example: Keep scanning for 6 scans, which is the specified number of scans)

–

Status

Display status of the timing chart being set.

–

Repeat scan 0 to 5 while 

the condition is satisfied.

6 scans of from scan 

0 to 5 are only enabled.

*1: The target device is turned OFF     ON.

*2: The target device is turned ON     OFF.

*3: There is no change in the device value.

*4: There is a change in the device value.

*1

*4 *3

*2
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19.5.3  Registering devices

19.5.3 Registering devices

Register devices for setting timing.

Operating procedure

1. Select [Device] ⇒ [Enter Device] from the Edit Timing Chart Format screen.

2. Set the items on the screen.

● Deleting registered devices
To delete a registered device, select the device displayed in device name/device value on the Edit Timing Chart Format 
screen, and select [Device] ⇒ [Delete Device].

<Bit device>

<Buffer memory>

<Word device>

Item Description

<<Device>> Select this tab to register devices.

Device Set a device to be registered.

Initial Value
Set the initial value of the device.
For a bit device, select ON/OFF of the bit.
For a word device, set the initial value.

<<Buffer Memory>>*1 Select this tab to register buffer memory.

Module Start (HEX) Set a start address of a module to be registered.

Address Set the address of the buffer memory to be registered.

Decimal/Hexadecimal Select the input form of the buffer memory address.

Initial Value Set the initial value of the buffer memory to be registered.

Display Format –

Value Select the display format of the value.

View Select the display format of the device.

*1 : For FXCPU, this item is supported by FX3U and FX3UC only.
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19.5.4 Setting timing

Set/edit the timing.
Move the cursor to the timing to be set, and perform an operation using any of tool buttons, menus, and 
shortcut keys.

Operation Toolbar Menu Shortcut key

Device ON
• Select [Edit] ⇒ [Bit Device] ⇒ [Device ON].
• Right-click and select [Device ON] from the shortcut menu.
• Double-click at the cursor position



Device OFF
• Select [Edit] ⇒ [Bit Device] ⇒ [Device OFF].
• Right-click and select [Device OFF] from the shortcut menu.
• Double-click at the cursor position.



Progressive OFF
• Select [Edit] ⇒ [Bit Device] ⇒ [Progressive OFF].
• Right-click and select [Progressive OFF] from the shortcut menu.



Progressive ON
• Select [Edit] ⇒ [Bit Device] ⇒ [Progressive ON].
• Right-click and select [Progressive ON] from the shortcut menu.



All OFF
• Select [Edit] ⇒ [Bit Device] ⇒ [All OFF].
• Right-click and select [All OFF] from the shortcut menu.



All ON
• Select [Edit] ⇒ [Bit Device] ⇒ [All ON].
• Right-click and select [All ON] from the shortcut menu.



Change
• Select [Edit] ⇒ [Word Device] ⇒ [Change].
• Right-click and select [Change] from the shortcut menu.
• Double-click the cursor position.



No Change
• Select [Edit] ⇒ [Word Device] ⇒ [No Change].
• Right-click and select [No Change] from the shortcut menu.



Insert
• Select [Edit] ⇒ [Insert].
• Right-click and select [Insert] from the shortcut menu.



Delete
• Select [Edit] ⇒ [Delete].
• Right-click and select [Delete] from the shortcut menu.


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19.5.4  Setting timing

■ Setting timing of bit devices

● Setting the ON/OFF cycle
Set continuous ON/OFF repeated for the specified period after the specified timing.

Example) Set the following value to scan 1 (cursor position).
Cycle: 2

Operation
1. Select a cell corresponding to a scan of a bit device to be changed.

2. Select [Edit] ⇒ [Timing Setting].

3. Set an ON/OFF cycle of the bit device.

4. Click the  button.
ON/OFF of the bit device is cyclically set.
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■ Setting timing of word devices

● Changing the value at the specified timing
Change the value of the specified device at the specified timing.

Example) Set the following value to scan 3 (cursor position).
Setting Value: 10, Continue, Number of Scans: 4, Increase and Decrease: Increase, 
Increase and Decrease Value: 20

Operation
1. Select a cell corresponding to a word device to be changed.

2. Select [Edit] ⇒ [Word Device] ⇒ [Change] ( ).

3. Set the items on the screen.

Item Description

Value Setting Select this to set a value.

Setting Value Enter a setting value for the word device.

Continue Select this to set the setting value continuously.

Number of Scans Enter the number of scans to be continued.

Increase and Decrease Set this to increase/decrease the value.

Increase and Decrease Value Set the increase/decrease value.

Trigonometric Function Select this to change the value using trigonometric functions.

SIN curve Select this to change the value with a SIN curve.

COS curve Select this to change the value with a COS curve.

Maximum Value Enter the maximum value.

Cycle Scan Select the number of scans corresponding to one period of SIN/COS curves.
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19.5.5  Setting number of scans of timing chart

4. Click the  button.
The value of the word device is set.

19.5.5 Setting number of scans of timing chart

Set the number of scans of a timing chart input from an external device.

Screen display
Select the Edit Timing Chart Format screen ⇒ [Scan] ⇒ [Scan Setting].

Operating procedure

1. Enter the value for "No. of Scans".

2. Click the  button.
Columns of disabled scans are shaded on the timing chart.
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19.5.6 Utilizing timing chart data of existing applications

Read and utilize a timing chart data file (*.DAT) saved with the timing chart of GX Simulator.
Since devices and timing are automatically registered after reading, there is no need to register them 
again.

Screen display
Select the Edit Timing Chart Format screen ⇒ [File] ⇒ [Open File].

Restrictions

● Number of device points that can be read from a timing chart data file
Timing chart data for 16 device points from the top in the screen can only be saved with the timing chart function.
Therefore, move necessary devices to within 16 points from the top in the screen and save the data when creating a 
timing chart data file.

● Number of scans that can be read from a timing chart data file
Scan 0 to 99 are available in the Edit Time Chart Format screen of the I/O system setting function.
When a timing chart data file includes scan 100 and later, they are discarded.

● When a double-precision real number is used in a timing chart data file
When a double-precision real number is contained in a timing chart data file created with GX Simulator, the file cannot 
be read.
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19.5.7  Displaying list of registered devices

19.5.7 Displaying list of registered devices

Display a list of registered devices.

Screen display
Select the Edit Timing Chart Format screen ⇒ [Device] ⇒ [Device List].

Display contents

Screen button

●

Displays the Enter Device screen, and adds a device to the Edit Timing Chart Format screen.

●

Deletes the device being selected from the Edit Timing Chart Format screen.

●

Displays the device being selected on the Edit Timing Chart Format screen.

● /
Moves the display position of a device being selected up/down on the Edit Timing Chart Format 
screen.

Item Description

Device List Display devices registered on the Edit Timing Chart Format screen.
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19.5.8 Exchanging display positions of devices

Exchange the display positions of devices by dragging and dropping a device name.

Operating procedure

1. Drag a device name on the Edit Timing Chart Format screen.

2. Place the square frame over a device to be exchanged.

Drag

Place the square frame over
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19.5.9  Changing display format of devices

19.5.9 Changing display format of devices

Change the display format of devices registered in the Edit Timing Chart Format screen.
This function is not applicable to bit devices.

Operating procedure

1. Select the Edit Timing Chart Format screen ⇒ [Device] ⇒ [Property].

2. Set the items on the screen.

3. Click the  button.

Item Description

Display Format –

Value Select the display format of values.

View Select the display format of devices.
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19.6 Performing I/O System Setting Function

This section explains the operations of simulation using the I/O system setting function.

19.6.1 Executing simulation

Execute simulation with settings configured using the I/O system setting function.

Operating procedure

1. Select the I/O System Setting screen ⇒ [File] ⇒ [Open] ( ), and open an I/O system 
setting file (*.IOS).

2. Select the I/O System Setting screen ⇒ [File] ⇒ [Execute I/O System Setting] ( ).
The confirmation message is displayed.

3. Click the  button.

● I/O system setting files
When the I/O system setting function is executed after an I/O system setting file is changed, the changes are 
automatically overwritten to the file.

● Simulation with the I/O system setting
Make sure that the simulator (virtual programmable controller) specified as execution target is in the RUN status at 
"LED" on the GX Simulator2 screen.
When it is in the STOP status, sequence actions and timing charts are not performed even though conditions of the 
device value input or timing chart input are satisfied.

19.6.2 Disabling simulation

Stop simulation of the I/O system setting being executed by disabling the I/O system setting.

Operating procedure

• Select the I/O System Setting screen ⇒ [File] ⇒ [Disable I/O System Setting] ( ).

Q CPU L CPU FXFXRemote FXHead
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19.7.1  Starting/stopping monitoring

19.7 Monitoring I/O System Setting

This section explains how to monitor devices on the I/O System Setting screen.
Using this function, status of registered conditions can be confirmed, and values of devices 
registered in conditions can be changed.

19.7.1 Starting/stopping monitoring

Start/stop monitoring on the I/O System Setting screen.

■ Start monitoring

Start monitoring on the I/O System Setting screen.

Operating procedure

• Select [Online] ⇒ [Start Monitoring] ( ) on the I/O System Setting screen.
Monitoring starts.

■ Stop monitoring

Stop monitoring on the I/O System Setting screen.

Operating procedure

• Select [Online] ⇒ [Stop Monitoring] ( ) on the I/O System Setting screen.

Q CPU L CPU FXFXRemote FXHead
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■ Screen display during monitoring

When monitoring starts, the I/O System Setting screen is displayed as shown below.
Conditions that are satisfied are displayed in yellow.

Screen button

●

Displays the Edit Timing Chart Format screen to confirm the monitoring status.

19.7.2 Changing current value of devices

Change current device value during monitoring.

Operating procedure

• Set the items on the screen.

Screen button
For the button on the screen, refer to Section 19.7.1.

Item Description

For a bit device Click a bit device to invert its status.

For a word device

Click a word device to display the Change Device Value screen below and change its 
value.



19 - 30

GX Works2

19  SIMULATING OPERATIONS OF EXTERNAL DEVICES

19.8.1  Creating I/O system setting files

19.8 Operating I/O System Setting Files

This section explains how to operate an I/O system setting file (*.IOS).

19.8.1 Creating I/O system setting files

Create a new I/O system setting file.

Operating procedure

• Select [File] ⇒ [New] ( ).

19.8.2 Opening existing I/O system setting files

Open a saved I/O system setting file.

Operating procedure

1. Select [File] ⇒ [Open] ( ).

2. Select a file to be opened and click the  button.

● Supported existing applications
I/O system setting files created with GX Simulator Version 6 or later can also be opened.

Restrictions

● 'Push Button'/’Always ON' set with existing GX Simulator
When an I/O system setting file in which a `Push Button'/'Always ON' is set with GX simulator is read with GX Works2, 
a 'Push Button' is converted to a '(blank)' and a 'Always ON' is converted to a 'SM400=ON' by QCPU (Q mode). A 'Push 
Button' is converted to a '(blank)' and an 'Always ON' is converted to an 'M8000=ON' by FXCPU.

19.8.3 Saving I/O system setting files

Save an I/O system setting file being open under a specified name.

Operating procedure

1. Select [File] ⇒ [Save As].

2. Enter a name of the file to be saved and click the  button.

Q CPU L CPU FXFXRemote FXHead
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20 - 1

20 PRINTING
This chapter explains how to print data such as sequence programs and devices created with GX 
Works2.

20.1 Print Function 20 - 2

20.2 Setting Printer 20 - 4

20.3 Batch Printing Project Data 20 - 5

20.4 Page Set Up for Batch Print 20 - 8

20.5 Setting Details of Batch Print 20 - 10

20.6 Displaying Batch Print Preview 20 - 37

20.7 Printing Data Displayed on Screen 20 - 38

20.8 Setting Print Details for Data Displayed on Screen 20 - 39

20.9 Previewing Print Images 20 - 42

20.10 Printing Examples 20 - 43

20.11 Considerations for Printing 20 - 51
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20.1 Print Function

This section explains the overview of print function and printable data.

■ Batch print and print window functions

The print functions are batch print function and print window function.

● Batch print function
A function to batch print multiple data in a project.

● Print window function
A function to print data displayed on the active window.

■ Printable and non-printable data

The following table shows the printable and non-printable data.
: Printable ×: Non-printable

Remote HeadQ CPU L CPU FX

Data Batch print Print window

Cover  ×

PLC parameter  

Redundant parameter  

Network parameter  

Intelligent function module*1 × 

Program setting*2  

Ladder  

SFC (MELSAP3)  

SFC (MELSAP-L)*1  

ST*3  

Structured Ladder/FBD*3  

Function/Function block program*3  

Label*3  

Device comment  

Device memory  

Device initial value*1  

Change TC Setting  ×

Device list  

Cross reference  

Statement/Note  ×

Project content list  ×

User library content list  ×

Product information list  ×

System monitor*1 × 

Verification result × 

*1 : Not supported by FXCPU.
*2 : For FXCPU, this function is supported by Structured project only.
*3 : User library data can be printed.
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● Print items on the batch print screen
Data supported by the batch print function are displayed on the batch print screen in the order shown in the table on the 
previous page, and changed data are saved in the project. Therefore, when a project created in the old version of GX 
Works2 is opened in the new version, the listed order of the print items may be changed.
Change the order of the print items with "Set Print Order".
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20.2 Setting Printer

This section explains how to set a printer.
Print job output can be selected on the Printer Setup screen for batch print. For details, refer to 
Section 20.3.1.

Screen display
Select [Project] ⇒ [Printer Setup].

Operating procedure

1. Set the items on the screen.

2. Click the  button.

● Printer settings
Printer settings changed in GX Works2 are not saved.

Restrictions

● Printing data using equipment such as other companies' PDF printers
Some lines of a table may not be printed correctly.

Remote HeadQ CPU L CPU FX

Item Description

Name Select the printer to be used.

Paper Set the paper size and paper feed method of the printer.

Size Select the size of paper.

Source Select the paper feed method.

Orientation Set the page orientation.

Portrait Select this to print the page in portrait mode.

Landscape Select this to print the page in landscape mode.
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20.3 Batch Printing Project Data

This section explains how to batch print project data.
A print preview can be displayed before printing data. For displaying a print preview, refer to 
Section 20.6.

Screen display
Select [Project] ⇒ [Print].

Operating procedure

1. Set the items on the screen.

2. Click the  button.
Data of items selected under "Print Item" are printed in the order from the top.

Remote HeadQ CPU L CPU FX

Item Description

Print Item

Select the data to be printed.
 is displayed for items without data to be printed or items whose data is read-

protected by the security setting.
 is displayed for print items to which read-protected is set in the security setting.

Setting by Item Set details of print settings for each data. (Section 20.5)
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Screen button

● /
Moves the selected item up/down under "Print Item".

●

Displays the Print Setup screen. (Section 20.3.1)

●

Displays the Page Setup screen. (Section 20.4)
Set a header/footer of the paper on which data is printed.

●

Displays a print preview of the item selected under "Print Item". (Section 20.6)

● Using a function to print multiple pages on a single page
When using the function to print multiple pages on a single page, data are printed in a group of print item.
When data ends in the middle of the page, the next data will not be printed on the same page but will be printed on the 
new page.
The following figure shows the example of printing two pages on a single page.

First page

Ladder program MAIN 1 Ladder program SUB 1

Second page Third page
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20.3.1 Setting printer for batch print

For batch print, the printer can also be set on the Print screen.
Print job output can be selected in the printer setting for batch print.
For notes and restrictions on printer setting, refer to Section 20.2.

Screen display

Select the  button on the Print screen.

Operating procedure

1. Set the items on the screen.

2. Click the  button.

● Printing with a PDF output printer
For a PDF output printer which outputs print results to files, files are created for each print job. The size of the files to be 
created is depending on the printer driver.

Item Description

Name Select the printer to be used.

Paper Set the paper size and paper feed method of the printer.

Size Select the size of paper.

Source Select the paper feed method.

Orientation Set the page orientation.

Portrait Select this to print the page in portrait mode.

Landscape Select this to print the page in landscape mode.

Print Job Select a method for print job output.

Output Method Select whether to print all print items as one print job or to print each print item separately.
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20.4 Page Set Up for Batch Print

This section explains how to set the page setup for batch print.

Screen display

Select the Print Screen ⇒ .

Operating procedure

1. Set the items on the screen.

2. Click the  button.

Remote HeadQ CPU L CPU FX

Item Description

Paper –

Size Select the paper size.

Source Select the paper feed method.

Orientation Set the page orientation.

Margins (Unit: mm) Set spaces for top/bottom/right/left of the paper.

Headers/Footers –

Page Number Format Select "Continue from previous page" or "Include chapter number" for the page 
numbers printed in header/footer.

Start at: Set a page number for the first page to be printed when "Continue from Previous 
Page" is selected.

Header Enter character strings to be printed in header or footer.
Up to 512 characters including string patterns and line feeds can be entered in the 
header/footer. Note that a line feed is handled as two characters.

Click  to display a list of string pattern.

Selected string pattern is entered at the cursor position.

Footer
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Screen button

●

Restores the default setting of header/footer.

● Printing chapter numbers
By selecting "Include chapter number", page numbers are displayed with: the numbered item in "Print Item", the 
numbered item in "Print", and the page number of each data. Even when there is no actual data to be printed in "Print 
Item" or "Print", the numbers with the chapter number format will be assigned in order.
The following figure shows an example of page number assignment with the chapter number format.

● When characters which exceed the maximum number of characters are entered to header/footer
When the project is opened in GX Works2 with a language different from the opened project data, characters which 
exceed 512 characters may be displayed.
When characters which exceed 512 characters are entered to the header/footer, characters cannot be entered or 
pasted; however, they can be deleted or cut.

● Header and footer
String patterns of header/footer may not function when a project created in GX Works2 in other language is opened, or 
a project created in GX Works2 Version 1.64S or later is opened in GX Works2 Version 1.62Q or earlier.
When the string pattern of header and footer do not function, set the setting again.

Numbered item in "Print Item" Numbered item in "Print"

3-2-1

Page number of each data

1

2

3

1

2

3

<When a project created in GX Works2 Version 1.64S or later is opened in GX Works2 Version 1.62Q or earlier>
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20.5.1  Setting common items (batch-print setting for user library data)

20.5 Setting Details of Batch Print

This section explains how to set items for the batch print function.

20.5.1 Setting common items (batch-print setting for user library 
data)

Set items to print user library data.
Selected user library data names can be printed under the following print items.
• ST
• Structured Ladder/FBD
• FB/FUN program
• Label

Screen display
Select "Print all (Common setting)" in "Print Item" on the Print screen.

Operating procedure

• Set the items on the screen.

Remote HeadQ CPU L CPU FX

Item Description

User library –

Print user library*1 Select this to print user library data.

Do not print Display data names which will not be printed

Print Display data names to be printed. Data are printed in the order from the top.

Select data name display 
format –

Display format Select a display format of data name when ST, Structured Ladder/FBD, FB/FUN 
program, or label is selected.

*1 : This item cannot be selected for Simple project.
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Screen button

●

Moves data selected in "Do not print" to "Print".

●

Moves all data in "Do not print" to "Print".

●

Moves data selected in "Print" to "Do not print".

●

Moves all data in "Print" to "Do not print".

● /
Moves data selected in "Print" up/down.

● Printing read protected data
When printing read protected data displayed on the field of "Do not print", enable the editing status of the user library for 
editing.
For details of editing user library, refer to the following manual.
GX Works2 Version 1 Operating Manual (Structured Project)
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20.5.2  Setting batch print for cover

20.5.2 Setting batch print for cover

Set items to print a cover.

Screen display
Select "Cover" in "Print Item" on the Print screen.

Operating procedure

• Set the items on the screen.

Screen button

●

Prints items selected in "Print Item".

●

Displays a print preview of items selected in "Print Item".

Item Description

Print Selection Select the item(s) to be printed.

Layout Display print area of the item(s) selected for "Print Selection".

Text

Enter text for each item to be printed.
Text can be entered when "Title", "Comment", "Prepared By", and/or "Date" are selected 
for "Print Selection".
A maximum of 200 characters can be set for each item. Note that a line feed is handled as 
two characters.
The numbers of characters and lines that can be printed differ according to the size or font 
setting of print paper. Check the print image with the print preview function.

Font
Set fonts for each item to be printed.
Fonts can be set when "Title", "Comment", "Prepared By", and/or "Date" are selected for 
"Print Selection".

Font Select a font.

Size Select a font size.

Font Style Select a font style.
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20.5.3 Setting batch print for PLC parameter

Set items to print PLC parameter.

Screen display
Select "PLC Parameter" in "Print Item" on the Print screen.
The following is an example of setting screen when QCPU (Q mode) is selected.

Operating procedure

• Set the item on the screen.

Screen button
For the screen buttons, refer to Section 20.5.2.

●

Selects all items.

●

Clears the selection of all items.

Item Description

Print What Select the item(s) of PLC parameter to be printed.
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20.5.4  Setting batch print for redundant parameters

20.5.4 Setting batch print for redundant parameters

Set items to print redundant parameters.

Screen display
Select "Redundant Parameter" in "Print Item" on the Print screen.

Operating procedure

• Set the item on the screen.

Screen button
For the screen buttons, refer to Section 20.5.2.

Item Description

Print what Select the item(s) of redundant parameters to be printed.
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20.5.5 Setting batch print for network parameter

Set items to print the network parameter.

Screen display
Select "Network Parameter" in "Print Item" on the Print screen.
The following is an example of setting screen when QCPU (Q mode) is selected.

Operating procedure

• Set the item on the screen.

Screen button
For the screen buttons, refer to Section 20.5.2.

Item Description

Print What Select the item(s) of network parameter to be printed.
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20.5.6  Setting batch print for program settings

20.5.6 Setting batch print for program settings

Set items to print program settings on the Navigation window.
For FXCPU, this function is supported by Structured project only.

Screen display
Select "Program setting" in "Print Item" on the Print screen.

Operating procedure

• Set the items on the screen.

Screen button
For the screen buttons, refer to Section 20.5.1 and Section 20.5.2.

Item Description

Print selection –

Program setting Select this to print the list of program setting content.

Additional information Select this to print the titles of the list of program setting content.

Task setting*1 Select this to print tasks registered in the program setting.

Execution type Select the execution types to be printed. Data are printed in the order from the top.

Program list Select the programs to be printed. Data are printed in the order from the top.

Select data name Items selected for "Execution type" and "Program list" are displayed.

Do not print Display data names which will not be printed

Print Display data names to be printed. Data are printed in the order from the top.

Additional information Append selected items to the task setting.

Print conditions Set the conditions for printing.

Print title only for 
the task with no 
program registered

Select this to print only titles even when programs are not registered to the task.
When this item is selected, only header, footer, and/or title are printed for each data on one 
page.

*1 : This item cannot be selected for Simple project.
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20.5.7 Setting batch print for ladder programs

Set items to print ladder programs.

Screen display
Select "Ladder" in "Print Item" on the Print screen.

Operating procedure

• Set the items on the screen.

Item Description

Select Program Display all data names of ladder program.

Do Not Print Display data names which will not be printed.

Print Display data names to be printed. Data are printed in the order from the top.

Display Mode of Program*1 Select whether to print data in label display or device display.

Additional Information Append selected items to the ladder program.

Device Comment
Select this to append device comments.
For labels, label comments are appended.
Set the number of comment rows and columns to be printed.

Statement/Note Select this to append statements and notes.

Contact
Select this to append contact usage destination. Set the print position and print range.

To specify the print range, click the  button, and set the device range on 
the Device Range Setting (Contact) screen.

Coil
Select this to append coil usage destination. Set a print range.

To specify the print range, click the  button, and set the device range on 
the Device Range Setting (Coil) screen.
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20.5.7  Setting batch print for ladder programs

Screen button
For the screen For the screen buttons, refer to Section 20.5.1 and Section 20.5.2.

●

Displays the Device Range Setting screen.

Print Conditions Set the conditions for printing ladder programs.

Ladder Contact Set the number of contacts to be printed.

Print NOPLF*2
Select this to print the NOPLF instructions.
(Data will be printed on the new page at the NOPLF instruction in the program with or 
without this item is selected.)

Delete blank rows of 
contacts and specify the 
number of column

Select this to print programs with blank rows of contact usage destination closed up. When 
this item is selected, the number of columns of contact usage destination can be selected.

Delete blank rows above 
and under coil Select this to print programs with blank rows of coil usage destination closed up.

Page break by ladder 
block

Select this to print data on the new page in ladder block unit.
When this item is cleared, data is printed on the new page in ladder row unit.

Print ladder blocks 
include hidden ones*3 Select this to print hidden ladder blocks.

Print blank rows with no 
device comment Select this to print blank rows which do not contain device comments.

Print lines in bold Select this to print programs with bold lines.

Specify Print Range –

Print Range Set the ladder program print range.
To specify the print range, select "Specify Range" and set a start step and an end step.

*1 : For FXCPU Simple projects (with labels), when a block password with the validated setting for "Read-protect the 
execution program" exists, , , , and  cannot be 
used with the device display.

*2 : Not supported by FXCPU.
*3 : For projects with labels, this item can be selected only when "Print in Label Display" is selected for "Display Mode of 

Program".

Item Description
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■ Contact/coil usage destination

Contact usage destination and coil usage destination are output as shown below.

The following shows an example of contact usage destination.
Example) Contact usage destination of Y0

● Printing examples with a setting of "Delete blank rows of contacts and specify the number of 
column"
The following examples show the difference of printing contact usage destination according to the 
setting of "Delete blank rows of contacts and specify the number of column".

Indicates the number of steps of coil usage destination

Indicates the number of steps of

contact usage destination

The number of steps of

Y0 used for destination

Destination

Source

Open contact

Closed contact

The number of steps of

Y0 used for source

< Without the item selected (5 columns) > < With the item selected (5 columns) >



20 - 20

GX Works2

20  PRINTING

20.5.8  Setting batch print for MELSAP3 programs

20.5.8 Setting batch print for MELSAP3 programs

Set items to print SFC (MELSAP3) programs.

Screen display
Select "MELSAP3" in "Print Item" on the Print screen.

Operating procedure

• Set the items on the screen.

Item Description

Select Program Display data names of SFC (MELSAP3) program.

Select print units*1 Select either "Program block" or "Program file".

Do Not Print Display data names which will not be printed.

Print Display data names to be printed. Data are printed in the order from the top.

Display Mode of Block List/
Action/Transition*2

Select whether to print data in label display or device display.
This item can be selected only when "Block List" or "Action/Transition" is selected in 
"SFC Diagram Print Item".

SFC Diagram Print Item Select the item(s) to be printed in SFC diagram.

SFC Diagram

Select the item(s) to be printed.

Block List*3

Comment List

Action/Transition

Property (SFC Program)*3,*4

Note List



20.5  Setting Details of Batch Print

20.5.8  Setting batch print for MELSAP3 programs 20 - 21

17

O
P

E
R

A
TI

N
G

 
PR

O
G

R
A

M
M

AB
LE

 
C

O
N

TR
O

LL
E

R
 C

P
U

18

DI
AG

NO
SI

NG
 

PR
OG

RA
M

M
AB

LE
 

CO
NT

RO
LL

ER
 S

TA
TU

S

19

SI
M

U
LA

TI
N

G
 

O
PE

R
AT

IO
N

S 
O

F 
EX

TE
R

N
AL

 D
EV

IC
ES

20

P
R

IN
TI

N
G

21

S
E

TT
IN

G
 O

P
TI

O
N

S

22

U
S

IN
G

 L
IB

R
A

R
IE

S

A

A
PP

E
N

D
IX

I

IN
D

EX

Screen button
For the screen buttons, refer to Section 20.5.1 and Section 20.5.2.

Additional Information Append selected item(s) to "SFC Diagram Print Item".

SFC Diagram –

SFC Step/Transition 
Comment Select this to append SFC steps/transition comments to the SFC diagram.

Action Select this to append operation outputs to the SFC diagram.

Transition Select this to append transition conditions to the SFC diagram.

Block List*4 –

SFC Block List Comment Select this to append SFC block list comments to the block list.

Start Destination Block Select this to append start destination block to the block list.

Action/Transition –

Device Comment
Select this to append device comments to Action/Transition.
For labels, label comments are appended.
Set the numbers of rows and columns for comments to be printed.

Print Conditions Set conditions for printing programs.

Number of Print Column of 
SFC Diagram

Specify the number of columns of SFC diagram to be printed on a single page.
The program is printed with reducing the size to fit the specified number of columns on a 
single page.

Number of Action/Transition 
Contacts Set the number of contacts to be printed.

Specify Print Range –

Print Range*3
Set the SFC (MELSAP3) program print range.
To specify the print range, select "Specify Range" and set a start block and an end 
block.

*1 : This item cannot be selected for Simple project.
*2 : For Simple projects (without labels), this item is fixed to "Print in Device Display".
*3 : For Structured projects, this item cannot be selected when "Program block" is selected for "Select print units".
*4 : Not supported by FXCPU.

Item Description
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20.5.9  Setting batch print for MELSAP-L programs

20.5.9 Setting batch print for MELSAP-L programs

Set items to print SFC (MELSAP-L) programs.
This setting is not supported by FXCPU.

Screen display
Select "MELSAP-L" in "Print Item" on the Print screen.
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Operating procedure

• Set the items on the screen.

Screen button
For the screen buttons, refer to Section 20.5.1 and Section 20.5.2.

Item Description

Select Program Display all data names of SFC (MELSAP-L) program.

Select print units*1 Select either "Program block" or "Program file".

Do Not Print Display data names which will not be printed.

Print Display data names to be printed. Data are printed in the order from the top.

SFC Diagram Print Item Select the item(s) to be printed in SFC diagram.

SFC Diagram

Select the item(s) to be printed.
Block List

Comment List

Property (SFC Program)

Additional Information Append selected item(s) to "SFC Diagram Print Item".

SFC Diagram –

SFC Step/Transition 
Comment Select this to append SFC steps/transition comments to the SFC diagram.

Program Select this to append programs to the SFC diagram.

Block List –

SFC Block List Comment Select this to append SFC block list comments to the block list.

Start Destination Block Select this to append start destination block to the block list.

Print Conditions Set conditions for printing programs.

Number of Print Column of 
SFC Diagram

Specify the number of columns of SFC diagram to be printed on a single page.
The program is printed with reducing the size to fit the specified number of columns on a 
single page.

Specify Print Range –

Print Range Set the SFC (MELSAP-L) program print range.
To specify the print range, select "Specify Range" and set a start step and an end step.

*1 : This item cannot be selected for Simple project.
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20.5.10 Setting batch print for ST programs

Set items to print ST programs.

Screen display
Select "ST" in "Print Item" on the Print screen.

Operating procedure

• Set the items on the screen.

Screen button
For the screen buttons, refer to Section 20.5.1 and Section 20.5.2.

Item Description

Select Program Display all data names of ST program.

Do Not Print Display data names which will not be printed.

Print Display data names to be printed. Data are printed in the order from the top.

Specify Print Range –

Print Range Set the ST program print range.
To specify the print range, select "Specify Range" and set a start line and an end line.
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20.5.11 Setting batch print for Structured Ladder/FBD programs

Set items to print Structured Ladder/FBD programs.

Screen display
Select "Structured Ladder/FBD" in "Print Item" on the Print screen.

Operating procedure

• Set the items on the screen.

Screen button
For the screen buttons, refer to Section 20.5.1 and Section 20.5.2.

Item Description

Select Program Display all data names of Structured Ladder/FBD program.

Do Not Print Display data names which will not be printed.

Print Display data names to be printed. Data are printed in the order from the top.
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20.5.12 Setting batch print for FB/FUN programs

Set items to print function and function block programs.

Screen display
Select "FB/FUN Program" in "Print Item" on the Print screen.

Operating procedure

• Set the items on the screen.

Item Description

Print Selection –

Function/FB Label Select this to print function/function block labels.

Select Program Display all data names of function/function block program.

Do Not Print Display data names which will not be printed.

Print Display data names to be printed. Data are printed in the order from the top.

Additional Information Append selected items to the ladder program.

Device comment
Select this to append device comments.
For labels, label comments are appended.
Set the number of comment rows and columns to be printed.

Statement/Note Select this to append statements and notes.

Contact
Select this to append contact usage destination. Set the print position and print range.

To specify the print range, click the  button, and set the device range on 
the Device Range Setting (Contact) screen.

Coil
Select this to append coil usage destination. Set a print range.

To specify the print range, click the  button, and set the device range on 
the Device Range Setting (Coil) screen.
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Screen button
For the screen buttons, refer to Section 20.5.1, Section 20.5.2, and Section 20.5.7.

● Data to be printed in FB/FUN programs
Data to be printed in FB/FUN programs are function blocks created in ladder programs and functions/function blocks 
created in ST programs or Structured Ladder/FBD programs.
Display-prohibited programs are not displayed in "Select Program".

Item Description

Print Conditions Set the conditions for printing ladder programs.

Ladder Contact Set the number of contacts to be printed.

Print NOPLF*1
Select this to print the NOPLF instructions.
(Data will be printed on the new page at the NOPLF instruction in the program with or 
without this item is selected.)

Delete blank rows of 
contacts and specify the 
number of column

Select this to print programs with blank rows of contact usage destination closed up. When 
this item is selected, the number of columns to be printed can be selected.

Delete blank rows above 
and under coil Select this to print programs with blank rows of coil usage destination closed up.

Page break by ladder 
block

Select this to print data on the new page in ladder block unit.
When this item is cleared, data is printed on the new page in ladder row unit.

Print ladder blocks 
include hidden ones*2 Select this to print hidden ladder blocks.

Print blank rows with no 
device comment Select this to print blank rows which do not contain device comments.

Print lines in bold Select this to print programs with bold lines.

Specify Print Range –

Print Range Set the ladder program print range.
To specify the print range, select "Specify Range" and set a start step and an end step.

*1 : Not supported by FXCPU.
*2 : For projects with labels, this item can be selected only when "Print in Label Display" is selected for "Display Mode of 

Program".
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20.5.13 Setting batch print for labels

Set items to print label data.

Screen display
Select "Label" in "Print Item" on the Print screen.

Operating procedure

• Set the items on the screen.

Screen button
For the screen buttons, refer to Section 20.5.1 and Section 20.5.2.

Item Description

Print Selection Display all data names of label.

Label List Select the label type(s) to be printed. Data are printed in the order from the top.
The item is displayed in gray when data to be printed do not exist.

Select Data Name Display items selected in "Label List".

Do Not Print Display data names which will not be printed.

Print Display data names to be printed. Data are printed in the order from the top.
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20.5.14 Setting batch print for device comments

Set items to print device comment data.

Screen display
Select "Device Comment" in "Print Item" on the Print screen.

Operating procedure

• Set the items on the screen.

Screen button
For the screen buttons, refer to Section 20.5.1, Section 20.5.2, and Section 20.5.7.

Item Description

Print Selection Display all data names of device comment.

Device Comment List
Select the device comment to be printed. Data are printed in the order from the top.
The item is displayed in gray when data to be printed do not exist, or all data are read 
protected.

Select Data Name Display items selected in "Device Comment List".

Do Not Print Display data names which will not be printed.

Print Display data names to be printed. Data are printed in the order from the top.

Print Conditions –

Print include the device 
with no comment. 
*Available only when 
selecting print range in 
Specify Print Range 
option.

Select this to print data including devices to which device comments are not registered.

Print title only for the 
device comment with no 
comment.

Select this to print only titles of data to which device comments are not registered.
When this item is selected, only header, footer, and/or title are printed for each data on one 
page.

Specify Print Range

Set the device comment print range.
To specify the print range, select "Specify Range" and set the device range by clicking the 

 button.
Since direct inputs (DX) and direct outputs (DY) are device comments as same as inputs 
(X) and outputs (Y), they are not printed when "Whole Range" is selected.
When printing direct inputs (DX) or direct outputs (DY), select "Specify Print Range", and 
set the device range.
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20.5.15 Setting batch print for device memory data

Set items to print device memory data.

Screen display
Select "Device Memory" in "Print Item" on the Print screen.

Operating procedure

• Set the items on the screen.

Screen button
For the screen buttons, refer to Section 20.5.1 and Section 20.5.2.

Item Description

Device Memory Selection Display all data names of device memory.

Do Not Print Display data names which will not be printed.

Print Display data names to be printed. Data are printed in the order from the top.

Print Conditions –

Print rows that all device 
value are 0. Select this to print rows in which device values are all 0.

Print blank rows with no 
device set. Select this to print rows in which devices are not set.

Print title only for the 
device memory with no 
device set.

Select this to print only titles of device memory data in which devices to be printed are not 
set.
When this item is selected, only header/footer/titles are printed on a single page per data.
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20.5.16 Setting batch print for device initial values

Set items to print device initial values.
This setting is not supported by FXCPU.

Screen display
Select "Device Initial Value" in "Print Item" on the Print screen.

Operating procedure

• Set the items on the screen.

Screen button
For the screen buttons, refer to Section 20.5.1, Section 20.5.2, and Section 20.5.7.

Item Description

Device Initial Value Selection Display all data names of device initial values.

Do Not Print Display data names which will not be printed.

Print Display data names to be printed. Data are printed in the order from the top.

Print Selection –

Device Initial Value Range Select this to print specified range of device initial values.

Device Initial Value Select this to print device initial values (device values).

Print Type Select a bit unit for handling device initial values for printing.

Print Form Select a data format of device initial value for printing.

Print Conditions –

Print device that value is 0. Select this to print devices whose value is 0.

Print title only for the data 
that is not set device initial 
value and range.

Select this to print only titles of data to which the device initial value range is not set, or 
data which do not contain devices to be printed.
When this item is selected, only header/footer/titles are printed on a single page per data.

Specify Print Range
Set the device initial value print range.
To specify the print range, select "Specify Range" and set the device range by clicking the 

 button.
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20.5.17 Setting batch print for TC setting values

Set items to print TC setting values.

Screen display
Select "TC Setting" in "Print Item" on the Print screen.

Operating procedure

• Set the items on the screen.

Screen button
For the screen buttons, refer to Section 20.5.1 and Section 20.5.2.

Item Description

Select Program Display all data names of ladder/MELSAP3/MELSAP-L programs.

Do Not Print Display data names which will not be printed.

Print Display data names to be printed. Data are printed in the order from the top.

Print Target Device Select the item to be printed.

Timer setting value Select this to print timer setting values. Labels to which timer is set as a data type are also 
printed.

Retentive timer setting 
value*1

Select this to print retentive timer setting values. Labels to which retentive timer is set as a 
data type are also printed.

Counter setting value Select this to print counter setting values. Labels to which counter is set as a data type are 
also printed.

Additional Information Append the selected item to the devices to be printed.

Device comment Select this to append device comments.
For labels, label comments are appended.

Print Conditions –

Print title only for the 
program with no TC 
setting.

Select this to print only titles of programs which do not contain TC setting values.
When this item is selected, only header/footer/titles are printed on a single page per data.

*1 : Not supported by FXCPU.
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20.5.18 Setting batch print for device list

Set items to print the device list.

Screen display
Select "Device List" in "Print Item" on the Print screen.

Operating procedure

• Set the items on the screen.

Screen button
For the screen buttons, refer to Section 20.5.1, Section 20.5.2, and Section 20.5.7.

Item Description

Find In
Set a search location of data to be printed.

Click the  button to select a search location.
A search location cannot be entered directly.

Find What Set a search target for devices to be printed.

All devices Select this to search all devices.

Used devices Select this to search devices used for contacts, coils, and parameters.
Selected items are searched.

Unused devices Select this to search devices which are not used.

Additional Information Append the selected item(s) to the device list.

Device Comment Select this to append device comments.

Print Conditions –

Print title only when no 
find result returns.

Select this to print only titles even when the program does not contain any devices.
When this item is selected, only header/footer/titles are printed on a single page.

Specify Print Range
Set the device comment print range.
To specify the print range, select "Specify Range" and set the device range for "Conditions 
for Range Specification".

Conditions for Whole 
Range Specification –

Include ZR device Select this to include ZR devices in the print target when "Whole Range" is specified for 
"Specify Print Range".

Include extension 
device (e.g. U0\G0, 
J1\X0)

Select this to include extended devices in the print target when "Whole Range" is specified 
for "Specify Print Range".
(BLm\Sn and BLm\TRn devices are printed with or without this item is selected.)

Conditions for Range 
Specification Set a range of devices to be printed.
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20.5.19 Setting batch print for cross reference information

Set items to print cross reference information created on the Cross Reference window.

Screen display
Select "Cross Reference" in "Print Item" on the Print screen.

Operating procedure

• Set the items on the screen.

Screen button
For the screen buttons, refer to Section 20.5.2.

Item Description

Specify Print Range –

All Select this to print all rows.

Selected Rows Select this to print selected row(s).
Select the row(s) to be printed on the Cross Reference window in advance.

Print Conditions –

Print title only when a 
cross reference 
information is not 
created.

Select this to print only titles when the cross reference information is not created.
When this item is selected, only header/footer/table titles are printed on a single page.
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20.5.20 Setting batch print for statements/notes

Set items to print statement/note data.

Screen display
Select "Statement/Note" in "Print Item" on the Print screen.

Operating procedure

• Set the items on the screen.

Screen button
For the screen buttons, refer to Section 20.5.1 and Section 20.5.2.

Item Description

Select Program Display all program names of ladder program.

Do Not Print Display data names which will not be printed.

Print Display data names to be printed. Data are printed in the order from the top.

Statement/Note Print Item Selected items are printed.

Line Statement List

Select the item(s) to be printed.
Note List

P Statement List

I Statement List

Print Conditions –

Print title only for the 
program with no 
Statement/Note.

Select this to print only titles of data in which statements/notes do not exist.
When this item is selected, only header, footer, and/or title are printed for each data 
on one page.
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20.5.21 Setting batch print for product information list

Set items to print the product information list created on the System Monitor screen.
This setting is not supported by FXCPU.

Screen display
Select "Product Information List" in "Print Item" on the Print screen.

Operating procedure

• Set the item on the screen.

Screen button
For the screen buttons, refer to Section 20.5.2.

● Printable product information list files
Only the product information list files created on the System Monitor screen in GX Works2 can be printed.
Product information list files created in GX Developer cannot be printed.

Item Description

Setting for Product Information 
List –

File Name
Set a product information list file to be printed.

Click the  button to select a product information list file.
A product information list file cannot be entered directly.
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20.6 Displaying Batch Print Preview

This section explains how to check the print image of each data.

Operating procedure

1. Select [Project] ⇒ [Print Preview].
The Print screen is displayed. (Section 20.3)

2. Click the  button.
The Print Preview screen is displayed.

3. Select items in "Print Item" and "Data Name" to change the data and check the print 
image.

4. Click the  button.
The print image of the selected data is displayed.

Screen button

●

Prints data.

● /
Displays the previous page/next page.

● /
Changes the display size of print image.

● Displaying previous/next page in print preview
The range in which previous/next pages can be displayed by clicking the /  button is within one 
data.
Use the "Jump Preview to" function to switch from the displayed preview data to another data.

● Page numbers displayed in footer
When "Continue form previous page" is selected in the page setting, "[Insert page number here]" is displayed at the 
position where a page number is to be printed in the print preview.

Remote HeadQ CPU L CPU FX
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20.7 Printing Data Displayed on Screen

This section explains how to print data displayed on the screen.
The print image can be checked prior to the printing. For checking print images, refer to Section 20.9.

Screen display
Select [Project] ⇒ [Print Window].

The Print Window function cannot be executed from the menu for the following data.
Execute the Print Window function as described below for each data.
● Parameters

Click the  button on the PLC parameter setting screen or the network parameter setting 
screen.

● Device initial value
Click the  button on the Device Initial Value screen.

● Device list or cross reference
Select rows to be printed, and click the  button on each screen.

Operating procedure

1. Set the items on the screen.

2. Click the /  button.
Printing starts.

● Printer settings
Click the  or  button to make detailed settings for the printer.

● Printing ladder program screens
When printing a ladder program screen, the Print Window (Ladder) screen is displayed. For SFC (Zoom) programs, the 
Print Window (Ladder) screen is not displayed.
For details, refer to Section 20.8.1.

Remote HeadQ CPU L CPU FX

<Data other than intelligent function module> <Intelligent function module>
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20.8 Setting Print Details for Data Displayed on Screen

This section explains how to set print details.
Print details can be set using ladder program and device initial setting.

20.8.1 Setting print details for ladder programs

Set print details such as print range and additional information of ladder program.

Screen display
Select [Project] ⇒ [Print Window]/[Print Window Preview].
The following explains a setting operation for the Print Window function. Apply the same 
operation for the Print Window Preview function.
<Option setting screen for Print Window>

Operating procedure

1. Set the items on the screen.

Q CPU L CPU FXFXRemote FXHead

Item Description

Additional Information Append selected items to the ladder program.

Device comment
Select this to append device comments.
Set the number of comment columns to be printed.
The number of comment rows is fixed.

Statement/Note Select this to append statements and notes.

Contact
Select this to append contact usage destination. Set the print position and print range.

To specify the print range, click the  button, and set the device range 
on the Device Range Setting (Contact) screen.

Coil
Select this to append coil usage destination. Set the print range.

To specify the print range, click the  button, and set the device range 
on the Device Range Setting (Coil) screen.

Specified Print Range –

Print Range
Set the print range of ladder program.
To specify the print range, select "Specified Range" and set a start step and an end 
step.
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20.8.1  Setting print details for ladder programs

2. Click the  button.
For the Print Window function, the Print Window screen is displayed. (Section 20.7)
For the Print Window Preview function, the Print Window Preview screen is displayed. 
(Section 20.9)

Screen button
For the screen buttons, refer to Section 20.5.7.

●

Displays a print preview.

■ Contact/coil usage destination

For details of contact/coil usage destination, refer to Section 20.5.7.
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20.8.2 Setting print details for device initial values

Set print details such as print items and print range of device initial values.

Screen display

Click the  button on the Device Initial Value screen.

Operating procedure

1. Set the items on the screen.

2. Click  the button.

Item Description

Print Item –

Device Initial Value Range Select this to print specified range of device initial values.

Device Initial Value Select this to print device initial values (device values).

Device Initial Value Output Setting Set the items to print device initial values (device values).

Print Range –

Whole Range Select this to print all devices registered as device values

Specified Range
Select this to specify a the print range.
The method to specify a range is the same as that of device initial value 
setting. (Section 8.2)

Print Type Select a bit unit for handling device initial values at printing.

Print Form Select a data format of device initial value at printing.

Print Condition –

Print device with value of 
zero Select this to print devices whose value is 0.
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20.9 Previewing Print Images

This section explains how to check print images of data displayed on the screen.

Screen display
Select [Project] ⇒ [Print Window Preview].

The Print Window Preview function cannot be executed from the menu for the following data.
Execute the Print Window Preview function as described below for each data.
● Parameters

Click the  button on the PLC parameter setting screen or the network parameter setting 
screen.

● Device initial value
Click the  button on the Device Initial Value screen.

● Device list or cross reference
Select rows to be printed, and click the  button on each screen.

<For Structured Ladder/FBD>

Remote HeadQ CPU L CPU FX
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20.10 Printing Examples

The following shows examples of printing.

■ Cover

■ PLC parameters

■ Redundant parameters

Remote HeadQ CPU L CPU FX
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■ Network parameters

■ Intelligent function modules

■ Program setting

● Program setting

● Task setting
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■ Programs

● Ladder

● SFC diagram (MELSAP3)

● SFC block list

● ST
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● Structured Ladder/FBD

■ Labels

● Global labels

● Local labels

● Function/function block labels
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● Structures

■ Structure devices

● Structure devices
(Devices are printed automatically after printing labels.)

■ Device comments

■ Device memory data
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■ Device initial values

● Device initial value ranges

● Device initial values

■ TC setting values

■ Device list
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■ Cross reference

■ Statements/Notes

■ Project content list

■ User library content list
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■ Product information list

■ Verification result

● Verify result list

● Detailed verify result
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20.11 Considerations for Printing

The following explains the considerations for printing.

■ Common considerations of Batch Print and Print Window functions

● Displaying print previews and printing data
Print preview display and printing cannot be executed in the following situations.
• The print target data do not exist.
• The print target screen is being monitored.

(Start printing after stopping the monitoring.)

● Considerations of printing large volume data
Large volume data may not be printed at all or printed half way due to the limitations of printer driver 
or Windows® print spooler.
In this case, print data by following the instructions described below.
• Separate the data by setting a print range with "Specify Print Range".
• Select [start] ⇒ [Control Panel] ⇒ [Printers and Faxes], open the property of the printer being 

used, and select "Print directly to the printer" in the Advanced tab on the property screen.
• Set "Output by Item" for the print job output on the Print Setup screen (Section 20.3.1). (For 

batch print only)
• Set "Output by Item" for the print job output on the Print screen displayed by clicking the 

 button or the  button. (For batch print only)

● Printing SFC diagrams
When an SFC diagram is printed, the printout may be divided into multiple pages depending on the 
number of the branches and couplings, and the number of steps. A number that indicates the position 
is printed at top right of each page.

Remote HeadQ CPU L CPU FX

(n,m)

1/20/2010

Data Name : 000 : Block

SFC Block

(n,m)

1/20/2010

Data Name : 000 : Block

SFC Block

(n,m)

1/20/2010

Data Name : 000 : Block

SFC Block

(n,m)

1/20/2010

Data Name : 000 : Block

SFC Block

m

n
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● Printing hierarchically-displayed cross reference information
Cross reference information is printed as shown below when "Display hierarchically" is selected on 
the <<Condition Setting>> tab.
• "+" and "-" are not printed.
• Each hierarchy of device/label is displayed with indentation.
• When only the lower hierarchy of device/label is selected, the hierarchy above the selected 

hierarchy is also printed.
• Data in the collapsed rows are not printed.

● Considerations for using the print function with 64-bit edition Windows® operating system
• When the print result is output with the Print or Print Window function, the Save As screen may not 

be displayed in the foreground.
Use + keys or + keys to bring the screen in the foreground.

• GX Works2 does not respond when the GX Works2 operation is performed while the Save As 
screen is displayed.
When the following screen is displayed, select "Wait for the program to respond".
Do not select "Close the program". Unsaved data will be lost.

<Cross reference information displayed on screen>

<Printed cross reference information>



20.11  Considerations for Printing

20 - 53

17

O
P

E
R

A
TI

N
G

 
PR

O
G

R
A

M
M

AB
LE

 
C

O
N

TR
O

LL
E

R
 C

P
U

18

DI
AG

NO
SI

NG
 

PR
OG

RA
M

M
AB

LE
 

CO
NT

RO
LL

ER
 S

TA
TU

S

19

SI
M

U
LA

TI
N

G
 

O
PE

R
AT

IO
N

S 
O

F 
EX

TE
R

N
AL

 D
EV

IC
ES

20

P
R

IN
TI

N
G

21

S
E

TT
IN

G
 O

P
TI

O
N

S

22

U
S

IN
G

 L
IB

R
A

R
IE

S

A

A
PP

E
N

D
IX

I

IN
D

EX

■ Considerations of Batch Print function

● Uncompiled programs
Uncompiled program are not printed or applied to the print preview.
Print data or display the print preview after converting the program.

● NOPLF instruction
The NOPLF instruction is not supported by SFC (Zoom) programs.

● Changing setting of "Ladder Contact"
When the setting of "Ladder Contact", which is set for "Ladder" and "FB/FUN" selected in "Print 
Item", is changed to the amount less than the one set at the program creation, the program may not 
be displayed normally, the same phenomenon as when changing the setting of "Display Connection 
of Ladder Diagram" in the option setting.
For details, refer to the following manual.
GX Works2 Version 1 Operating Manual (Simple Project)

● Number of printable rows
The number of printable rows is limited for the following data. The rows that exceeded the limitation 
will not be printed.
• For device comments and device list, 100,000 rows can be printed per data.
• For device memory data and device initial values, 20,000 rows can be printed per data.
• For TC setting values, 20,480 rows can be printed per data.

● When character strings in header/footer overlap
Overlapped character strings in header/footer are printed on top of each other in order of priority: 
right, center, left. The overlapped character string is overwritten by the character string which is given 
the priority.
The following shows an example of overlapped character strings.

● Specifying device comment print range for FXCPU
For FXCPU, an error occurs when the Device Range Setting screen is opened in GX Works2 Version 
1.64S or later with a project created in GX Works2 Version 1.62Q or earlier, in which nesting (N)/
index register (V)/index register (Z) is specified for device comment print range.
In this case, delete the device range setting for nesting (N)/index register (V)/index register (Z).

<Setting example of overlapped character strings in header>

<Printing example of overlapped character strings in header>
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■ Considerations of Print Window function

● Uncompiled programs
Uncompiled program are not printed or reflected to the print preview.
Print data or display the print preview after converting the program.

● NOPLF instruction
The NOPLF instruction is not supported.

● Structured Ladder/FBD
If a bend point is created in a Structured Ladder/FBD program, it will be printed as shown below. If 
the bend point is unnecessary to be printed, delete it on the Structured Ladder/FBD editor.
For details of bend points GX Works2 Version 1 Operating Manual (Structured Project)

● Page feed in ladder program
If a ladder block or function block does not fit in one page, the page is automatically fed and the 
ladder block or function block is printed from the top of the next page.

● Printing structure/label setting editor
Since the screen width is adjusted automatically to fit the page size when the structure/label setting 
editor is printed, the printing may be difficult to read depending on the column width of the screen.
In order to improve the printing quality, adjust the column width of the structure/label setting editor. 
The visibility of the printing is increased by adjusting the column width to narrow. However, if the 
words input into the Remark/Comment column are too long, or one cell is divided into multiple pages, 
the content in that cell cannot be printed completely.

● Printing intelligent function module data
When the print function is performed on the Print Window Preview screen while the positioning data 
of intelligent function module are displayed, the font size and the display position of the header may 
be different from the normal display. Perform the print function on the Print Window screen.

Bend point

<First page> <Second page>

<Print result>
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21 - 1

21 SETTING OPTIONS
Option settings such as screen display format setting and detailed operation settings of each function 
are available.

21.1 Basic Operations 21 - 2

21.2 Option Setting List 21 - 4
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21.1 Basic Operations

This section explains how to set options.

Screen display
Select [Tool] ⇒ [Options].

Operating procedure

• Set the items on the screen.
When the cursor is placed on a setting item, an explanation of the item is displayed on the 
"Explanation" field.

Screen button

●

Restores the initial settings.

●

Restores the user default settings.

●

Stores the current settings as the user default and applies them to a new project.

Remote HeadQ CPU L CPU FX
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● Considerations when changing option settings
All programs need to be compiled when the following option settings are changed.
• "Default Length of String Data Type" in "Label Setting Editor"
• Settings in "Compile"
Compiling all programs changes the device assignment to labels. Therefore, device values set before the program 
change remain on the device-assigned labels.
Perform the following operations for a precautionary measure.
• For QCPU (Q mode)/LCPU

After writing data to the programmable controller CPU, reset the programmable controller CPU, clear all device 
memories including latches, clear all file registers, and switch the programmable controller CPU to RUN.

• For FXCPU
After writing data to the programmable controller CPU, clear device memory using the PLC memory clear function, 
and switch the programmable controller CPU to RUN.

(Section 17.4)
For the considerations for compiling all programs, refer to the following manuals.
GX Works2 Version 1 Operating Manual (Simple Project)/(Structured Project)
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21.2 Option Setting List

The following table shows the option setting items.
For (Simple), (Structured) and (Intelligent) indicated in the Reference column, refer to the following 
manuals respectively.

(Simple) … GX Works2 Version 1 Operating Manual (Simple Project)
(FB) … GX Works2 Version 1 Operating Manual (Simple Project, Function Block)
(Structured) … GX Works2 Version 1 Operating Manual (Structured Project)
(Intelligent) … GX Works2 Version 1 Operating Manual (Intelligent Function Module)

Remote HeadQ CPU L CPU FX

Tree item Item Explanation Default Reference

Project

Common 
Setting

Automatically change 
language according to 
system*1

Language setting will be automatically 
changed according to system when edit 
Ladder/SFC program (Statement and 
Note) or device comment.

Selected –

Use Dedicated Instruction 
for GX Developer, GX IEC 
Developer

Dedicated Instruction for GX Developer, 
GX IEC Developer (Instructions that their 
name ends with '_M' and '_MD') can be 
used in the projects using the following 
function. Open Other Project, Read from 
PLC or PLC Type change.

Selected Section 4.7.1

Automatic 
Save

Save project after writing 
to PLC

Select whether to save the project 
automatically after writing to the 
programmable controller CPU.

Cleared Section 12.1

Save project after online 
change

Select whether to save the project 
automatically after completing online 
change to the programmable controller 
CPU.

Cleared Section 12.9.1

Save project after 
changes in TC setting 
values are written to PLC

Select whether to save the project 
automatically after changes in TC setting 
values have been written to the 
programmable controller CPU.

Cleared (Simple)

Change 
History

Revision is not Registered 
when Save Project Select whether to register the revision 

after saving a project.

Selected

Section 4.2.3

Revision is registered 
when Save Project Cleared

Display confirmation 
message showing 
whether to register history

Select whether to display a confirmation 
message of the revision registration after 
saving a project.

Cleared

Automatically set revision 
titles

Select whether to automatically set 
revision titles at revision registration after 
saving a project. Automatically-set titles 
can be changed on the Revision List 
window.

Cleared
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Program 
Editor

All Editors Device 
Comment

Program/Program File 
Name

Set a reference/reflection target of device 
comments for each program/program file.
Set a reference/reflection target 
according to the local device range of 
PLC parameter when set to "PLC 
parameter setting".
Within the local device range: local 
device comment
Outside the local device range: global 
device comment

MAIN

Section 9.1.1

Specify the reference/
reflection Global

Reference/reflect the 
other, when device 
comment is not set.

When it is checked, the behavior of each 
device will be the one as follows:
1) Refer the comment (Global/Local) 

specified in device comment field.
2) If device comment does not exist, 

the behavior will be the one as 
follows:
• When specified to Global 

Comment:
Refer Local Comment.

• When specified to Local 
Comment:
Refer Global Comment.

Cleared

Apply the current setting of reference/
reflection target for device comment to all 
programs/program files.

–

Set all reference/reflection target to 
'global' for device comment of selected 
program/program file name.

–

Set a all reference/reflection target to 
'local' for device comment of selected 
program/program file name.

–

Set all reference/reflection targets for 
device comment of target device of the 
selected program/program file name to 
"PLC parameter setting".
Target Device: Device can be specified 
within the local device range in the device 
setting of PLC parameter

–

Structured 
Ladder/
FBD/ST

Tool Hint

Monitored Value

Select display item in tool hint when 
mouse cursor is placed over label/device 
name.

Selected

(Structured)

Class Cleared

Device Selected

Address Cleared

Device Comment Selected

Data Type Cleared

Constant Value Cleared

Label Comment Selected

Remark Cleared

Tool Hint Display Format Select display lines on tool hint. Multi Line

Tree item Item Explanation Default Reference



21 - 6

GX Works2

21  SETTING OPTIONS

Program 
Editor

Structured 
Ladder/
FBD

Label

Display label name/
comment of contact or coil 
in multiline

Set display lines and characters per line. Cleared

(Structured)

Display labels and 
devices

Select whether to display labels and 
devices which are assigned to the labels, 
when 'Label' is selected from View mode.
* Users can neither edit the displayed 
devices nor set them to the Find/Replace 
target.

Cleared

Declare new label name
Select whether to display the label 
registration/selection dialog when 
entering new labels.

Selected

Structured 
Ladder/
FBD

FB/FUN

Wrap instance name for 
function block

Select whether to wrap function block 
instance name at the function block 
width.

Cleared

Specify the number of 
enable characters for 
label name/comment

Specify the number of display characters 
of function or function block label. Cleared

Automatic input/output 
labels

Select whether to add input/output label 
when function block or function is pasted. Selected

Automatic ENO labels Select whether to add ENO output label 
when function block or function is pasted. Cleared

Pin overwrites
Select whether to overwrite I/O label with 
a grid line when ruling a grid line over 
function or function block.

Selected

Double clicking opens 
header

Select whether a label editor is displayed 
when function or function block is double 
clicked.

Selected

Double clicking opens 
body

Select whether a program editor is 
displayed when function or function block 
is double clicked.

Cleared

Guided

Ladder Wrapping Select whether to wrap ladder. The edited 
ladder shall be object after changing the 
setting.

Selected

Return Contacts 8

Open Structured Ladder/
FBD Editor in guided 
mode

Set guided mode as default when open 
Structured Ladder/FBD editor. Cleared

Allow hotkey repeater Select whether to display grid line ruling 
dialog at drawing lines. Cleared

Enter label names after 
contacts and coils

Select whether to input label names or 
devices after entering contacts and coils. Selected

Auto Comment Block 
Width

Set the width of comment to be added in 
ladder block with grid numbers when 
adding ladder block.

8

ST

Auto Indention

Select whether to use the automatic 
indent when beginning a new line after 
entering ST control syntax such as IF or 
FOR, and when displaying template of 
inline structured text.

Selected

Instruction/label name 
prediction

Select whether to display listed label 
names starting with the input character 
when a character is input.
(Structured text: label name,
inline structured text: instruction and label 
name)

Selected

Tabulator Length in ST
Set tabulator length.
It is not available with inline structured 
text.

4

Tree item Item Explanation Default Reference
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Program 
Editor

Ladder/
SFC

Enter ladder

Check duplicated coil

Select whether to check duplicated coils 
when entering instruction. Unconverted 
ladder is not the object for duplicated coil 
check.

Cleared

(Simple)

Enter label comment and 
device comment

Select whether to enter label comment or 
device comment continuously after 
entering instructions.

Cleared

Do not display note in 
ladder input window when 
edit coil instructions.

Select whether to display note in ladder 
input window when edit coil instructions. Cleared

Check special relay/
special register 
compatible with A-PLC

When A-PLC Compatible Setting of PLC 
Parameter setting has not be enabled at 
the time of instruction inputting, check 
whether to display a confirming message 
to input special relay/special register 
compatible with A-PLC. MELSAP-L is an 
exception.

Cleared

Display available 
instruction tool hints in 
entering instruction

Select whether to automatically display 
tool hint of instruction in entering 
instruction.

Selected

Display available 
instructions in entering 
instruction

Select whether to automatically display 
available instructions in entering 
instruction.

Selected

Display available labels in 
entering instruction

Select whether to automatically display 
available defined labels in entering 
instruction.

Selected

Tool hint

Monitored Value

Select display item in tool hint when 
mouse cursor is placed over label name.
* Options for simple project (with label) or 
label program of structured project.
* As for function block, devices are 
excluded from display target in tool hint.

Selected

Class Cleared

Device Selected

Device Comment Selected

Data Type Cleared

Constant Value Cleared

Label Comment Cleared

Remark Cleared

Tool hint display format

Select the number of display lines in tool 
hint.
* Will be wrapped in 64 single-byte 
characters or 32 double-byte characters.

Multiple lines

Tree item Item Explanation Default Reference
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Program 
Editor

Ladder Comment

Device Comment
Select whether to display the label 
comment or the device comment at 
ladder editor.

Cleared

(Simple)

Note Select whether to display the note 
comment at ladder editor. Cleared

Statement Select whether to display the statement 
comment at ladder editor. Cleared

Device Comment Display 
Format

Set the display rows and columns for 
label comment or device comment.

Row: 4
Column: 8

Copy device comment in 
copying ladder

Select whether to copy device comment 
in copying ladder.
* Pasting device comments will be 
executed based on the setting of 
Reference/Reflection target for device 
comment.
* Pasting device comments will not be 
executed between different PLC types.
* Copying or pasting will not be executed 
for read-protected device comments.

Cleared

Ladder Ladder 
Diagram

Display Connection of 
Ladder Diagram

Set the number of contacts. ([Program 
Editor] ⇒ [SFC] ⇒ [Zoom]) 11 Contacts

Use the Switching Ladder 
Edit Mode (Read, Write, 
Monitor, Monitor (Write))

Select whether to switch Ladder Edit 
Mode (Read, Write, Monitor and Monitor 
(Write)). Will be the same operation as 
the ladder edit mode of GX Developer.
*Unable to set when security setting is 
enabled.

Selected

Display labels and 
devices

Select whether to display labels, and 
devices assigned to label. (Exclude 
function block.)
* Devices are excluded from Find/
Replace target.
* Options for simple project (with label) or 
label program of structured project.

Cleared

Display STL instruction in 
contact format
*Only applies to the 
FXCPU

Select whether to display STL instruction 
in contact format. This is valid for simple 
projects (Not using labels) only.
Contact format ladder block display for 
STL instruction is not wrap displayed.

Cleared

Display Instruction Help at 
symbol error occurrence

Select whether to automatically display 
Instruction Help when symbol errors 
occur.

Selected

Open Undefined Label 
Registration dialog at 
ladder entry

Select whether to open Undefined Label 
Registration dialog when labels used at 
ladder entry are undefined.

Selected

Set initial value to '1' for 
Enter HLine/Delete HLine 
dialogue.

Select whether to set initial value to '1' 
when Enter HLine/Delete HLine dialog is 
opened.

Cleared

Stop at the connection 
points (Instruction/Vertical 
Line) when enter or delete 
horizontal line.

Select whether to edit line by connection 
point (Instruction/Vertical Line) when 
Enter HLine/Delete HLine is executed.

Cleared

Tree item Item Explanation Default Reference
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Program 
Editor SFC

Comment
Block List Display device comment on SFC block 

list. Cleared

(Simple)

Step/Transition Display step/transition comment on SFC 
editor. Cleared

SFC 1

SFC Edit Area
Set SFC edit area when create SFC. 
Please change by "SFC Row Setting" 
after creating a SFC.

Col Number: 
10
Line Number: 
306

Tile SFC and Zoom 
vertically

Select whether to tile Zoom windows at 
the cursor position on SFC when creating 
SFC diagram. Checking this option 
changes the [Open Zoom with New 
Window] option into unchecked.

Selected

Arrange Select the type of tile for SFC and ZOOM 
window. Tile Vertically

SFC Display Window 
Ratio

Select window display ratio for SFC when 
Tile Vertically is selected. 30%

MELSAP-L Label/Device 
Display Format Set display lines for MELSAP-L program. 4

Jump to start destination 
block

Set whether to jump to start destination 
block when cursor is moved to block start 
step.

Cleared

SFC 2 Leave comment or step 
No. selected

Select whether to leave comment or step 
No. selected in Enter SFC Symbol screen 
when changing SFC symbol in 
MELSAP3.
Block or symbol must be left selected in 
Enter SFC Symbol screen when newly 
entering SFC symbol.

Cleared

Zoom

Open Zoom with New 
Window

Select whether to open a new window for 
each Zoom or to change the display in 
the fixed window when opening Zoom. 
Checking this option changes the "Tile 
SFC and Zoom vertically" option into 
unchecked.

Cleared

Number of Action/
Transition Contacts Set the number of contacts.

Same as the 
"Ladder 
Diagram" 
setting

Tree item Item Explanation Default Reference
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Device Comment Editor

Number of Device 
Comment Edit/Display 
Characters

Set the number of input and display 
characters for device comment. 32 Section 9.2.1

Extended Setting

• When "Standard mode" is selected.
Device comment up to 32K points per 
device can be registered. In total, up to 
1024K points per file can be registered.

• When "Extended mode" is selected.
Device comment up to 192K points per 
device can be registered. In total, up to 
2048K points per file can be registered.

Standard 
mode Section 9.4

Label Setting Editor

Automatic copy and 
increment when inserting 
a row

Select whether to copy the texts in the 
upper row after incrementing it when 
inserting a row.

Selected

(Simple)
(Structured)

Copy data type/comment 
items

Select if the data type, comment, and 
remark shall be object for auto copy. Selected

Default Length of String 
Data Type

Set the default string length for string data 
type. 32

Display last blank row

Select whether to display last blank row.
This setting is valid for global label and 
local label except the local label of 
function block, function and structured 
data type.

Cleared

Parameter

Use user defined 
parameter
*Only applies to the 
QCPU and LCPU

Display the User Defined Parameter 
Setting button and able to set it. Once the 
user set parameter is set, it will remain 
even after checking off the selection box.

Cleared –

Display number of 
columns for CC-Link list 
setting
*Only applies to the 
QCPU and LCPU

Select 4 columns or 2 columns to display 
number of columns in CC-Link list setting 
of network parameter. Please reopen the 
CC-Link list setting window to reflect 
changes.

4 Columns Section 6.3

Display number of rows 
for CC-Link station 
information

Select 16 rows or 8 rows to display 
number of rows in CC-Link list setting of 
network parameter. Please reopen the 
CC-Link list setting window to reflect 
changes.

16 Rows Section 6.3.1

Tree item Item Explanation Default Reference
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Monitor

Structured Ladder/FBD/
ST

Display Format of 
Monitoring Value

Select whether to display monitored value 
in Decimal or Hexadecimal. Decimal

(Structured)

Monitor buffer memory 
and link memory
*Only applies to the 
QCPU, LCPU, FX3U(C)

Select whether to monitor buffer memory 
and link memory during monitoring. Scan 
time of PLC will be lengthened depending 
on the setting.

Cleared

Significant Characters Set the number of displayable characters 
to monitor character-string data. 16

Verify with PLC setting 
before starting monitoring

• When "Always Verify with PLC" is 
selected.
Verify with PLC before starting 
monitoring. However, do not verify if 
simulator is running, selecting 
uncompiled program's POU, or 
unchanged POU. (Last verification 
status is held while editor is open.)

• When "Not Always Verify with PLC" is 
selected.
Start monitoring without verifying with 
PLC.

• When "Confirm whether to Verify with 
PLC" is selected.
Show a confirmation box whether to 
verify with PLC before starting 
monitoring. However, the confirmation 
box will not be displayed and do not 
verify if simulator is running, selecting 
uncompiled program's POU, or 
unchanged POU. (Last verification 
status is held while editor is open.)

Confirm 
whether to 
Verify with 
PLC

Ladder/SFC Set automatic registration 
destination

Label and device of ladder block (Ladder) 
in cursor, action/transition step (SFC) will 
be registered to watch window while 
monitoring watch window. (Caution1: 
Cursor move will be slow when setting is 
enabled. 2: Select FB instance for 
function block.)

Not Specified Section 14.6.2

Tree item Item Explanation Default Reference
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Monitor

Ladder

Display Format of 
Monitoring Value

Select the display format of the monitored 
value in decimal or hexadecimal. Decimal

(Simple)

Monitor buffer memory 
and link memory
*Only applies to the 
QCPU, LCPU, FX3U(C)

Select whether to monitor buffer memory 
and link memory during Ladder-
monitoring. Scan time of PLC will be 
lengthened depending on the setting.

Cleared

FXGP format Ladder 
monitor
*Only applies to the 
FXCPU

PLS/PLF instruction is displayed in 
GP(DOS) and FXGP(WIN) formats. If it is 
not checked, it is displayed in GX 
Developer form.

Cleared

Display monitored value 
by device/label name of 
contact/coil instruction.

In monitoring ladder, select whether to 
highlight contact/coil instruction based on 
the monitored value displayed by device/
label name.

Cleared

Display lines for 
monitoring current value

Select whether to display rows of the 
current value monitor during Ladder-
monitoring.

Show Always

SFC*2

Watch Step Not 
Transferring within 
Watching Time

Select whether to display a warning 
dialog when detect a step that does not 
transfer even if specified time passes 
while monitoring.

Cleared

(Simple)

Program/Program File 
Name Select watch target program/program file.

(SFC 
program 
name)

Target All Blocks Specify watch target block. Selected

Specify the Block
Specify watch target block. Cleared

Detailed Setting

Stop Transition Watch 
Monitor when Detected

Select whether to detect other step that 
does not transfer while displaying 
warning dialog.

Selected

Monitor block start with 
new window

Select whether to open a corresponding 
SFC window to monitor when the active 
step transfers to a block start step.

Cleared

PLC Read/Write

Keep last file selection for 
PLC read/write dialog

Select whether to store file selection 
status to PLC read/write dialog. Selected

Section 12.1
Turn PLC to STOP at time 
of PLC write after 
executing Rebuild All and 
do not execute remote 
RUN

Select whether to turn the PLC to STOP 
at the time of PLC write and not execute 
remote RUN because executing "Rebuild 
All" from the menu or icon changes the 
device assignment. PLC write cannot be 
executed in RUN with this option 
checked.

Cleared

When writing to PLC after 
a Rebuild All operation, 
clear the device ranges 
set in the Device/Label 
Auto-Assign setting to 0.
*Recommended setting: 
checked*3,*4

*Unnecessary for simple 
projects (Do not use label)

After executing a Rebuild All, when labels 
are reassigned to new devices, values 
from the previous program will remain in 
the previously assigned devices. This 
setting automatically clears the device 
ranges in the Device/Label Automatic-
Assign Setting.

Selected
Section 12.1.7

(Simple)
(Structured)

Check program cache 
memory when writing to 
PLC
*Only applies to Universal 
Model QCPU (Except for 
High-speed Universal 
model QCPU), QCPU, or 
LCPU

Select whether to execute automatically 
check program cache memory when 
writing to program memory. Automatic 
recovery is enabled in Write to PLC, 
Online program change, TC setting 
change, Write title, and Password/
Keyword.

Cleared
Manual of 

programmable 
controller CPU

Tree item Item Explanation Default Reference
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Online Change

Execute fall instruction
*Only applies to the 
QCPU and LCPU

Select whether to execute fall instruction 
(LDF, LDFI, ANDF, ANDFI, ORF, ORFI, 
MEF, PLF, FCALLP, EFCALLP) at online 
change.

Cleared

Section 12.9

Transfer program cache 
memory to program 
memory
*Only applies to the 
QCPU and LCPU

Select whether to transfer the program 
cache memory to program memory when 
online change completed.
* Message will be shown to confirm 
whether to transfer to or not if it is 
unchecked.

Selected

Execute online change 
based on relative step No.
*Ladder Only
*Only applies to the 
QCPU and LCPU

Select whether to execute online change 
based on relative step No. from pointer. 
Even if real step No. is different, online 
change is available as long as relative 
step No. from the pointer is 
corresponding.

Cleared

Execute online change by 
Compile
*Enabled when 'Switch 
the Ladder Edit Mode' is 
set

Select whether to execute Online 
Program Change when ladder program or 
SFC program is edited and compiled. Will 
be enabled when 'Switch Ladder Edit 
Mode' is checked. ([Options] ⇒ [Program 
Editor] ⇒ [Ladder] ⇒ [Ladder Diagram])

Cleared

Under booting, reflect 
changes to boot source 
during online program 
change
* Except for Q00UJ/Q00U/
Q01UCPU, basic model 
QCPU and FXCPU

Select whether to reflect the changes to 
boot source after online program change. Cleared

Symbolic Information

Setting for Writing 
Symbolic Information to 
PLC

Set the writing format for symbolic 
information. The capacity will be 
optimized by high speed mode support 
version but be read only by 1.45X or later. 
The capacity will not be optimized by 
compatible mode but be read by 1.44W 
or previous.
FXCPU support only high-speed mode.

High Speed 
Mode

Section 12.9.1

Setting for Save 
Destination of Symbolic 
Information to PLC

Set a PLC drive to store symbolic 
information. This setting can be changed 
when you connect to PLC. Program 
Memory/Device Memory will be selected 
in simulation mode if an unusable storage 
is specified.

Program 
Memory/
Device 
Memory

Save Destination of Device Comment

Set save destination of 
device comment to the 
target memory of PLC 
data

Under device comment selected status, 
select whether to change the target 
memory of PLC data to the one specified 
by Save Destination of Device Comment.

Cleared

Section 12.1.6

Save Destination of 
Device Comment

Set the target memory for device 
comment save destination.
Able to change it later.
In simulation mode, program/device 
memory will be selected if invalid 
destination is specified.
* This setting will not be saved by 'Set as 
User Default' setting.

Program 
Memory/
Device 
Memory

Tree item Item Explanation Default Reference
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Compile

Basic Setting

Function Block Call

Enable calling function block from ladder 
to ST or vice versa, from ladder to 
Structured Ladder/FBD or vice versa, 
using inline ST in ladder, reducing steps 
when using function block.
* Input label for VAR_IN_OUT remains 
equal to output label.

Selected (Structured)

Program Check

Check when program check is not 
needed after Build or Online Program 
Change. It can reduce the compile time 
depending on the setting.

Selected

(Simple)
(Structured)

Operational Setting

Select whether to use the same label 
name in global label and local label. 
When the same label is selected, local 
label will be given priority.

Cleared

Create Cross Reference 
Information

Creating cross reference information after 
compiling enables to reduce find time. 
The information can be found in 
uncompiled project. Specified find 
condition is treated as filter condition.
The setting will be canceled if find mode 
is 'Fast Find'.

Cleared Section 10.1.1

Output Result

Stop Build Set the number of error and warning to 
stop the compile.

Error: 25
Warning: 100

(Simple)
(Structured)Disable Warning and 

Notification Message

Register warning codes to invalidate. The 
registered warning codes shall not be 
displayed in output window.

(No setting)

Display the Use Status 
Notification of 
Automatic-Assign 
Device in Output 
Result

The use status of device automatic-
assign is displayed in output window. Selected –

Tree item Item Explanation Default Reference
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Compile

Ladder/
SFC

Compile 
Condition

Make sure that the 
instruction is not used 
beyond the device range 
assigned by the label*2

Select whether to display warnings or not 
when ladder/SFC program instruction is 
using devices out of device range 
assigned by the labels in instruction. Able 
to detect instructions that may use 
devices out of range and may overwrite 
other label’s value.

Cleared (Simple)

Structured 
Ladder/
FBD/ST

Compile 
Condition 1

Use lower-case device 
names as labels*5

Select whether to use device names 
typed with lower case characters as 
labels.
Only the device name outside device 
range is valid for Inline Structured Text.

Cleared

(Structured)

Function Output Setting
Select whether to connect directly from 
the objective function output to other 
input.

Selected

Allow VAR_OUTPUT at 
FB call (ST)

Select whether to allow VAR_OUTPUT at 
FB call.
Check: Able to specify VAR_OUTPUT as 
FB argument. (e.g. FBInst(FBVarOUT:= 
Variable);)
Uncheck: Compile error C8015 returns if 
VAR_OUTPUT is specified as FB 
argument.

Selected

Add temporary variables 
as arguments to use 
macrocode

For the ST or structure ladder FB call 
from structured ladder, set whether to 
add temporary variables as input 
argument, I/O argument, and output 
argument to use macrocode.

Cleared

Compile 
Condition 2

(D)INT_TO_BOOL_E,
(D)WORD_TO_BOOL_E,
TIME_TO_BOOL_E

Check the box to generate code that 
holds the output (SET). When 
unchecked, the instruction word output 
will be treated as a coil (OUT).

Selected

NOT_E Selected

LIMITAION_E,
MAXIMUM_E,
MINIMUM_E

Selected

EQ_E, NE_E, GT_E, 
GE_E, LT_E, LE_E Selected

AND_E, OR_E, XOR_E Selected

User Defined Function 
with EN/ENO

Select whether to generate a code which 
keeps bit type output of the target 
function.
(Codes keeping bit type are generated if 
output is in bit type array or in structure 
array, regardless of option setting.)

Selected

User Defined Function 
Block with EN/ENO

Select whether to generate a code which 
keeps bit type output of the target 
function block.
(Codes keeping bit type are generated if 
output is in bit type array or in structure 
array, regardless of option setting.)

Cleared

Compile 
Condition 3

Automatically assign each 
system device to output of 
functions that use EN/
ENO

Select whether to assign each system 
device to output functions of EN/ENO. 
Only functions enabled. (Function block is 
disabled.)
Only checked functions at [Generate 
Code That Holds the Output of the 
Following] are enabled when the output is 
bit type.

Selected

Tree item Item Explanation Default Reference
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● Options supported by communication head module and remote I/O module
The following option items are supported by projects for communication head module and remote I/O module.
• Project
• Parameter
• PLC Read/Write
• Intelligent Function Module

Intelligent 
Function 
Module*2

QD75/LD75 Type 
Positioning

Display Specification of 
Positioning Data

Set the range of positioning data to be 
displayed.

Data No.1 to 
100 (Intelligent)

Confirm PLC operation 
status when writing a Data

Select whether to check an operation 
status of programmable controller CPU 
and allow to be written in the status of 
STOP.

Selected

Section 12.1.4
Display a confirmation 
message when writing to 
flash ROM

Select to display a confirmation message 
when writing to flash ROM. Selected

Guidance Display intelligent function 
module guidance

Select whether to automatically display 
intelligent function module guidance. Selected (Intelligent)

iQ Works Interaction*2,*6
Enable an editing of 
parameters set in 
MELSOFT Navigator

Select whether enabling or not editing 
parameters set by MELSOFT Navigator. Selected Section 6.1

System Label Setting*6,*7

Use MELSOFT Navigator 
Option Information

Checking this option enables use of the 
option setting of MELSOFT Navigator. 
The option setting specified in MELSOFT 
Navigator at the time of opening this 
project is used.

Cleared

(Simple)
Structured)

System Label Name 
Setting

Set how to name system labels. When 
system labels are entered, system label 
names are determined based on this 
setting at the time of project save.

Use global 
names 
directly

Sampling Trace

Display a message to 
confirm operation 
contents at the start of 
trace.

Display a confirming message to start of 
trace. Selected

–

Display a message to 
confirm discard of the 
trace result at the start of 
trace.

Display a message to confirm discard of 
the trace result at the start of trace. Selected

Display a caution 
message in saving data 
as GX LogViewer format 
CSV file.

Display a caution message about data 
changes in saving data as GX LogViewer 
format CSV file.

Selected

*1 : Supported by Japanese version of GX Works2 only.
*2 : Not supported by FXCPU.
*3 : This setting is not required when the following operations are performed, and the programmable controller CPU is switched to RUN for 

writing programs to programmable controller CPU after compiling programs.
• For QCPU (Q mode)/LCPU: reset the programmable controller CPU, clear all device memories including latches, clear all file registers.
• For FXCPU: perform the PLC memory clear function.

*4 : 0 clear process may take a couple of minutes when a large amount of devices to be cleared exists.
*5 : Not supported by Simple project.
*6 : Not supported by High-speed Universal model QCPU.
*7 : For FXCPU, this item is supported by FX3G, FX3GC, FX3U, and FX3UConly.

Tree item Item Explanation Default Reference
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22 - 1

22 USING LIBRARIES
This chapter explains the overview of library function in GX Works2.

22.1 Libraries 22 - 2
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22  USING LIBRARIES

22.1 Libraries

FB library and user library are the libraries of GX Works2.
Work hours for creating programs can be reduced by using functions of library.
This section explains the overview of libraries.

The following table shows the applicability of libraries according to the project type.
: Applicable ×: Not applicable

Project type
Library

FB library User library

Simple project (without labels) × ×

Simple project (with labels) 

Section 22.1.1 ×

Structured project 

Section 22.1.1


Section 22.1.2
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22.1.1 FB libraries

FB libraries are the collection of function blocks prepared as MELSOFT Library and they can be used in 
projects with labels.
Contact your local Mitsubishi representative to obtain MELSOFT Library.
To use the FB library in a Structured project, import the library to a Simple project (with labels), and 
change the project type to a Structured project by selecting [Project] ⇒ [Change Project Type].

Programs can be created efficiently by using the FB libraries.
The following shows an example of using the FB library of QD70 positioning module (QD70P4).

For details of using the FB libraries, refer to the following manual.
GX Works2 Version 1 Operating Manual (Simple Project, Function Block)

Q CPU L CPU FXRemote FXHead FXFX

< Without FB libraries > < With FB libraries >
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22.1.2  User libraries

22.1.2 User libraries

User libraries are components which can be shared between multiple projects and they can be used in 
a Structured project only.
User libraries are created by a user.

Frequently-used components are stored and reused for programming efficiency.

The following data can be registered to user libraries.
• Global labels
• Structures
• POUs (program blocks, functions, function blocks)

For details of using user libraries, refer to the following manual.
GX Works2 Version 1 Operating Manual (Structured Project)

Q CPU L CPU FXFXRemote FXHead

Global label

Program setting

POU

Program block

Task

FB/FUN

Structure

< Project 1 >

Program

Global label

Global label

Program setting

POU

FB/FUN

Structure

Program

Global label

FB/FUN

Structure

Task

FB/FUN

Program block

Structure

Library fileLibrary Edit

< Project 2 >

Program

Global label

FB/FUN

Structure

Library

Store Reuse

Utilize

Library components

can be used.
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Appendix 1.1  Common toolbars and shortcut keys

Appendix 1 List of Toolbars and Shortcut Keys

This section shows the list of toolbars and shortcut keys that can be used for GX Works2.

For (Simple), (FB), (Structured), and (Intelligent) indicated in the Reference column, refer to the 
following manuals respectively:

Appendix 1.1 Common toolbars and shortcut keys

The following explains the toolbars that are available regardless of the editing target and the 
corresponding shortcut keys.

■ "Standard" toolbar icons

The following table shows the "Standard" toolbar icons and the corresponding shortcut keys.

(Simple) … GX Works2 Version 1 Operating Manual (Simple Project)
(FB) … GX Works2 Version 1 Operating Manual (Simple Project, Function Block)
(Structured) … GX Works2 Version 1 Operating Manual (Structured Project)
(Intelligent) … GX Works2 Version 1 Operating Manual (Intelligent Function Module)

Remote HeadQ CPU L CPU FX

Toolbar 
icon Shortcut key Corresponding menu Description Reference

+ New Create a new project. Section 4.2.1

+ Open Open an existing project. Section 4.2.2

+ Save Save the project. Section 4.2.3

+ Print Print data such as sequence programs and 
devices. Chapter 20

 GX Works2 Help Display the GX Works2 Help screen.
Section 3.4.1

- - Find Help for GX Works2 Search for help items with an entered keyword 
on the GX Works2 Help screen.
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■ "Program Common" toolbar icons

The following table shows the "Program Common" toolbar icons and the corresponding shortcut keys.

Toolbar 
icon Shortcut key Corresponding menu Description Reference

+ Cut Cut the selected data. –

+ Copy Copy the selected data. –

+ Paste Paste the cut/copied data at the cursor 
position. –

+ Undo Cancel the previous operation. –

+ Redo Perform the operation canceled by [Undo]. –

+ Find Device Search for a device. Section 10.3.1

– Find Instruction Search for an instruction.
Section 10.3.2

++ Find Contact or Coil Search for a contact or coil corresponding to a 
specified device.

– Write to PLC Write data to the programmable controller 
CPU.

Section 12.1
– Read from PLC Read data from the programmable controller 

CPU.

– Start Monitoring (All 
Windows) Start monitoring all windows being opened.

Section 14.2– Stop Monitoring (All 
Windows) Stop monitoring all windows being opened.

 Start Monitoring Start monitoring the window being operated.

+ Stop Monitoring Stop monitoring the window being operated.

– Device/Buffer Memory 
Batch Monitor Batch monitor device/buffer memories. Section 14.3

+ Modify Value
For ladder and SFC (Zoom) programs, change 
the ON/OFF and value of a device/label used 
in a program.

Section 16.1

 Build Compile/convert a program being edited.

Section 5.4+ Online Program Change Compile/convert a program and write it to the 
programmable controller CPU.

++ Rebuild All Compile/convert all programs in a project.

– Start/Stop Simulation Start/stop simulation. Section 15.2
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Appendix 1.1  Common toolbars and shortcut keys

■ "Docking Window/Switch Project Data" toolbar icons

The following table shows the "Docking Window/Switch Project Data" toolbar icons.

■ "Intelligent Function Module" toolbar icons

The following table shows the "Intelligent Function Module" toolbar icons.

Toolbar 
icon Shortcut key Corresponding menu Description Reference

– – Select data type Select a data type and data name to be 
displayed.

Section 3.2.2– – Select data name

– Display Display the editing screen of the selected data 
type and data name.

– Navigation Display/hide the Navigation window. Section 3.2.5

– Selection Display/hide the Function Block Selection 
window.

(FB)
(Structured)

– Output Display/hide the Output window. (Simple)
(Structured)

– Cross Reference Display/hide the Cross Reference window. Section 10.1

– Device List Display/hide the Device List window. Section 10.2

– CC-Link Device Reference 
Window

Display/hide the CC-Link Device Reference 
window. Section 6.3.5

– Watch Display/hide the Watch window. Section 14.6

– Intelligent Function Module 
Monitor

Display/hide the Intelligent Function Module 
Monitor window.

(Intelligent)
– Intelligent Function Module 

Guidance
Display/hide the Intelligent Function Module 
Guidance window.

– Find/Replace Display/hide the Find/Replace window. Section 10.3

Toolbar 
icon Shortcut key Corresponding menu Description Reference

– QD75/LD75 Positioning 
Module Wave Trace

Execute a wave trace of the QD75/LD75 
positioning module.

(Intelligent)

– QD75/LD75 Positioning 
Module Location Trace

Execute a location trace of the QD75/LD75 
positioning module.

– Serial Communication 
Module Circuit Trace

Execute a circuit trace of the serial 
communication module.

– QD75/LD75 Positioning 
Module Test Monitor

Execute a positioning monitor of the QD75/
LD75 positioning module.

– QD75/LD75 Positioning 
Module Test

Execute a positioning test of the QD75/LD75 
positioning module.

– Offset/Gain Setting of 
Temperature Input Module

Execute offset/gain setting of the temperature 
input module.

– Offset/Gain Setting of 
Analog Module

Execute offset/gain setting of the analog 
module.
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■ "Debug Function" toolbar icons

The following table shows the "Debug Function" toolbar icons.

■ Other shortcut keys

The following table shows other shortcut keys that are available regardless of the editing target.

Toolbar 
icon Shortcut key Corresponding menu Description Reference

– Stop Stop the step execution. Section 16.6.9

– Cancel Cancel the step execution. Section 16.6.7

– Break Execution Execute the break execution. Section 16.6.6

– Step Execution Execute the step execution. Section 16.6.5

– Execution Option Display the Execution Option screen of the 
step execution. Section 16.6.8

– Set/Cancel Break Point Set a break point at the cursor position, or 
cancel the set break point.

Section 16.6.2– Enable/Disable Break Point Enable/disable the break point at the cursor 
position.

– Cancel All Break Points Cancel all break points.

– Break Point Display the Break Point window.

– Cancel All Break Devices Cancel all break devices.
Section 16.6.3

– Break Device Display the Break Device window.

– Set/Cancel Skip Range Set a skip range, or cancel the set skip 
range.

Section 16.6.4– Enable/Disable Skip Range Enable/disable the skip range at the cursor 
position.

– Cancel All Skip Ranges Cancel all skip ranges.

– Skip Range Display the Skip Range window.

Toolbar 
icon Shortcut key Corresponding menu Description Reference

– 
Rename Change the name of the selected data or 

library on the Navigation window.
Section 4.3.3

Rename (Library) (Structured)

–  Delete Delete the selected data. Section 4.3.4

– ++ Copy Copy data in the project.
Section 4.3.2

– ++ Paste Paste the copied data to a folder.

– ++ Add New Module Add the intelligent function module data to the 
project being edited. (Intelligent)

– + Exit Close the project being edited and exits GX 
Works2. Section 3.1

– + Cross Reference Create the cross reference information. Section 10.1

– + Device List Display the device list. Section 10.2

– /+ – After creating cross reference information, 
move to the next cross reference information.

Section 10.1– +/
++ –

After creating cross reference information, 
move to the previous cross reference 
information.

– /+ –
After creating cross reference information, 
move focus between the Cross Reference 
window and work windows.

– + Find Device Search for a device/label in the program. Section 10.3.1

– ++ Find String Search for a string. Section 10.3.3
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Appendix 1.2 "Navigation Window" toolbar icons

The following table shows the "Navigation Window" toolbar icons.

– + Replace Device Replace a device/label in the program. Section 10.3.1

– ++ Replace String Replace a string. Section 10.3.3

– ++ –
After performing the search/replace function 
once, search for an item in the downward 
direction.

Section 10.3

– ++ –
After performing the search/replace function 
once, search for an item in the upward 
direction.

– + Start Watching
Start monitoring the current values of 
registered devices/labels and intelligent 
function module.

Section 14.6

– ++ Stop Watching
Stop monitoring the current values of 
registered devices/labels and intelligent 
function module.

– + Register Device Test with 
Execution Condition

Register the device test with execution 
condition. Section 16.3

– + – Close the window displayed on the uppermost 
position. –

– + – Move to the next uppermost window. –

Toolbar 
icon Shortcut key Corresponding menu Description Reference

Toolbar 
icon Shortcut key Corresponding menu Description Reference

– Add New Data Add data to the project. Section 4.3.1

– Copy Copy selected data.
Section 4.3.2

– Paste Paste copied data.

– Property Display a property of the selected data. Section 4.3.6

– Refresh Update the display content of the Navigation 
window. –

–

Project Property Display a property of the open project. –

Expand All Uncompiled 
Data

Expand all uncompiled data in the tree on the 
Project view and the User Library view.

Section 3.2.5
Collapse All Collapse all data in the tree on the Project view 

and the User Library view.
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Appendix 1.3 Toolbar icons and shortcut keys for setting labels

The following explains the toolbar icons and the corresponding shortcut keys for setting labels.

■ "Label" toolbar icons

The following table shows the "Label" toolbar icons and the corresponding shortcut keys.

■ Other shortcut keys

The following table shows other shortcut keys for setting labels.

Toolbar 
icon Shortcut key Corresponding menu Description Reference

+ New Declaration 
(Before) Add a row above the cursor position.

(Simple)
(Structured)

– New Declaration 
(After) Add a row below the cursor position.

+ Delete Row Delete the row at the cursor position.

– Read from CSV File Read label settings from the CSV file.

– Write to CSV File Write label settings to the CSV file.

–
Confirm Update of 
System Label 
Database

Apply system label information changed in 
another project to global labels.

– Import System Label Import system label information and apply it 
to global labels.

– Reservation to 
Register System Label

Reserve the selected global label for 
registration as a system label.

– Reservation to 
Release System Label

Reserve the selected global label for 
deregistration of system label.

Toolbar 
icon Shortcut key Corresponding menu Description Reference

– + Select All Select all rows.

(Simple)
(Structured)

–
+/

+ Num *1

*1 : 'Num' indicates keys in the numeric keypad.

– Display all lines of comment and remark of 
the selected line.

–
+/

+ Num *1 – Display only the first line of comment and 
remark of the selected line.
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Appendix 1.4 Toolbar icons and shortcut keys for setting device 
memory

The following explains the toolbar icons and the corresponding shortcut keys for setting device 
memory.

■ "Device Memory" toolbar icons

The following table shows the "Device Memory" toolbar icons and the corresponding shortcut keys.

■ Other shortcut key

The following table shows other shortcut key for setting device memory.

Toolbar 
icon Shortcut key Corresponding menu Description Reference

– Display Mode/Binary Display data in binary.

Section 7.2.5

– Display Mode/Octal Display data in octal.

– Display Mode/Decimal Display data in decimal.

– Display Mode/
Hexadecimal Display data in hexadecimal.

– Display Mode/Float Display data in real number.

– Display Mode/String Display data in character string.

– Display Mode/String
(ASCII only) Display data in ASCII string.

– Register/16-bit Display data in units of words.

– Register/32-bit Display data in units of double words.

– Register/64-bit Display data in units of 64 bits.

+ Input Device Enter a device. Section 7.2.2

– FILL Set the same value to continuous devices. Section 7.2.4

– Read Device Memory 
from PLC

Read data in device memory from a 
programmable controller CPU.

Section 7.4.1
– Write Device Memory 

to PLC
Write data in device memory to a 
programmable controller CPU.

– Read from Excel File Read data from an Excel file.
Section 7.4.2

– Write to Excel File Write data to an Excel file.

Toolbar 
icon Shortcut key Corresponding menu Description Reference

–  Insert Row Insert a row at the cursor position. Section 7.2
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Appendix 1.5 Toolbar icons and shortcut keys for verification result

The following table shows the toolbar icons and the corresponding shortcut keys for the verification 
result.

Appendix 1.6 Toolbar icons and shortcut keys for executing 
sampling trace

The following explains the toolbar icons and the shortcut keys for executing sampling trace.

■ Toolbar icons for executing sampling trace

The following table shows the toolbar icons for executing sampling trace.

Toolbar 
icon Shortcut key Corresponding menu Description Reference

+ Next Unmatch Move to the next mismatched data.

Section 4.2.7
Section 12.2

+ Previous Unmatch Move to the previous mismatched data.

+ Return to Result List Display the <<Verify Result List>>tab.

+ Close Detail Result Close the <<Detail Verify Result>>tab being 
displayed.

++ Close All Detail Result Close all <<Detail Verify Result>>tab.

– Write to CSV File Write verification result to a CSV file.

Toolbar 
icon Shortcut key Corresponding menu Description Reference

– Trace Setting Display the Trace Setting screen. Section 16.4.2

– Start Trace
Start sampling trace. To start sampling 
trace, the trace ready signal (SM800) must 
be ON.

Section 16.4.4– Stop Trace Stop sampling trace.

– Display Trace Buffer 
Condition

Display the Trace Data Storage Status 
screen.

– – Display the current sampling trace status

–– Buffer Status
Displayed when the trace data have been 
acquired up to the specified total number of 
samplings.

– Trigger Occurrence Displayed when a trigger is generated 
during sampling trace.

– Zoom Out Timing 
Chart Zoom the scale of timing chart

Section 16.4.4

– Zoom In Timing Chart

– Zoom Out Trend 
Graph Zoom the scale of trend graph

– Zoom In Trend Graph

– Switch Chart/Detail
Switch the trace result display on the 
Sampling Trace screen between the timing 
chart (graph) and the detailed data (value).
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■ Other shortcut keys

The following table shows the other shortcut keys for executing sampling trace.

Appendix 1.7 Toolbar icons and shortcut keys for program editors

The following explains the toolbar icons and the corresponding shortcut keys for program editors.

■ "Ladder" toolbar icons and shortcut keys

The following table shows the toolbar icons and the corresponding shortcut keys for the ladder editor.

Toolbar 
icon Shortcut key Corresponding menu Description Reference

– ++ – Move the vertical axis information line 10 
columns to the left.

Section 16.4.4

– ++ – Move the vertical axis information line 10 
columns to the right.

– + – Move the vertical axis information line 
100 columns to the left.

– + – Move the vertical axis information line 
100 columns to the right.

– + –

Move the vertical axis information line 
toward the left from the vertical axis 
information line to the columns of first 
data change.

– + –

Move the vertical axis information line 
toward the right from the vertical axis 
information line to the columns of first 
data change.

Toolbar 
icon Shortcut key Corresponding 

menu Description Reference

 Open Contact Insert an open contact at the cursor position.

(Simple)

+ Open Branch Insert an open contact branch at the cursor position.

 Close Contact Insert a closed contact at the cursor position.

+ Close Branch Insert a closed contact branch at the cursor position.

 Coil Insert a coil at the cursor position.


Application 
Instruction Insert an application instruction at the cursor position.

 Horizontal Line Insert a horizontal line at the cursor position.

+ Vertical Line Insert a vertical line at the cursor position.

+ Delete Horizontal 
Line Delete the horizontal line at the cursor position.

+ Delete Vertical Line Delete the vertical line at the cursor position.

+ Rising Pulse Insert a rising pulse at the cursor position.

+ Falling Pulse Insert a falling pulse at the cursor position.

+ Rising Pulse Branch Insert a rising pulse branch at the cursor position.

+ Falling Pulse Branch Insert a falling pulse branch at the cursor position.

++ Rising Pulse Close Insert a rising pulse close at the cursor position.

++ Falling Pulse Close Insert a falling pulse close at the cursor position.
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++ Rising Pulse Close 
Branch

Insert a rising pulse close branch at the cursor 
position.

(Simple)

++ Falling Pulse Close 
Branch

Insert a falling pulse close branch at the cursor 
position.

+ Operation Result 
Rising Pulse

Insert an operation result rising pulse at the cursor 
position.

++ Operation Result 
Falling Pulse

Insert an operation result falling pulse at the cursor 
position.

++ Invert Operation 
Results

Insert an operation result inversion at the cursor 
position.

 Edit Line Input a line at the cursor position.

+ Delete Line Delete the line at the cursor position.

+ Insert Inline 
Structured Text Box Insert an inline structured text box.

– Device Comment Edit device comments. Section 9.2.2

– Statement Edit statements.

(Simple)
– Note Edit notes.

– Statement/Note 
Batch Edit Batch-edit statements/notes.

+ Line Statement List Display the list of line statements used in the program.

++ Display Template Insert a template corresponds to the instruction/
function/control syntax.

(Structured)+ Mark Template (Left) Set an argument of the template in the selected status 
from the left by selecting the menu each time.

+ Mark Template 
(Right)

Set an argument of the template in the selected status 
from the right by selecting the menu each time.

+ Read Mode Switch the mode of the open window to "Read Mode".

(Simple)

 Write Mode Switch the mode of the open window to "Write Mode".

 Monitor Mode Switch the mode of the open window to "Monitor 
Mode" during monitoring.

+ Monitor (Write Mode) Switch the mode of the open window to "Monitor 
(Write Mode)" during monitoring.

++ Device Display Display devices assigned by compilation.

– Zoom Change the display magnification ratio of the ladder 
program.

– ++ Continuous Paste Increment the device number of device in the cut/
copied ladder block and paste it consecutively.

– + Insert Row Insert a row at the cursor position.

– + Delete Row Delete the row at the cursor position.

– + Insert Column Insert a column at the cursor position.

– + Delete Column Delete the column at the cursor position.

– ++ Connect Line to 
Right-Side Symbol

Connect a horizontal line to the element at the right of 
the cursor position.

– ++ Connect Line to Left-
Side Symbol

Connect a horizontal line to the element at the left of 
the cursor position.

– + Enter/Delete HLine 
Rightward Enter/delete a line at the right of the cursor position.

Toolbar 
icon Shortcut key Corresponding 

menu Description Reference
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– + Enter/Delete HLine 
Leftward Enter/delete a line at the left of the cursor position.

(Simple)

– + Enter/Delete VLine 
Downward

Enter/delete a line at the downward of the cursor 
position.

– + Enter/Delete VLine 
Upward

Enter/delete a line at the upward of the cursor 
position.

– + Switch Open/Close 
Contact

Switch a open contact to closed contact, and vice 
versa.

– + Switch Statement/
Note Type Change the type of a statement/note.

– ++ Instruction Partial 
Edit

Open the Enter Symbol screen in which the first 
argument is in the selected status.

– +/ –
Select a device/label on the Enter Symbol screen. 
Switch the device/label to be selected using the /
 button.

– +/ – Increment/decrement a device/label on the Enter 
Symbol screen.

– + – Display options of instruction/label on the Enter 
Symbol screen.

– +
/// – Move the cursor on the editing screen while the Enter 

Symbol screen is displayed.

– + Jump Display the specified row.

– ++ Jump to Next Ladder 
Block Start

Move the cursor from the current position to the start 
of the next ladder block.

– ++ Jump to Previous 
Ladder Block Start

Move the cursor from the current position to the start 
of the previous ladder block.

– ++ Next Device Move the cursor to the same device as the one at the 
cursor position.

– ++ Next Contact Move the cursor to the contact where the same device 
as the one at the cursor position is used.

– ++ Next Coil Move the cursor to the coil where the same device as 
the one at the cursor position is used.

– ++ Back
Return the cursor to the previous position before the 
[Next Device]/[Next Contact]/[Next Coil] function 
execution.

– + Comment Display device comments.

– + Statement Display statements.

– + Note Display notes.

–
+/

+Num*1
Non-Display Ladder 
Block Hide a ladder block.

–
+/

+Num*1 Display Ladder Block Display hidden a ladder block.

– + turn mouse 
scroll wheel upward Bigger Change the display size of text larger on the editing 

screen.

–
+ turn mouse 

scroll wheel 
downward

Smaller Change the display size of text smaller on the editing 
screen.

– ++ Tile FB Horizontally Tile the ladder editor and the function block program 
editor horizontally. (FB)

– + Back to Zoom SFC 
Block

Open the SFC diagram corresponds to the program 
on the Zoom editor window.

(Simple)
– ++

///
Moves up/down/left/
right

Move the cursor toward up/down/left/right of the SFC 
diagram.

– + Open Instruction 
Help Display the Instruction Help screen.

–  – Display the Find screen.

Toolbar 
icon Shortcut key Corresponding 

menu Description Reference
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–  Instruction Help Display details of instructions. Section 3.4.1

– ++ – Enter an assignment operator (:=) when editing the 
inline structured text program. (Structured)

*1 : 'Num' indicates keys in the numeric keypad.

Toolbar 
icon Shortcut key Corresponding 

menu Description Reference



App - 14

GX Works2

  APPENDIX

Appendix 1.7  Toolbar icons and shortcut keys for program editors

■ "ST" toolbar icons and shortcut keys

The following table shows the toolbar icons and the corresponding shortcut keys for the ST editor.

Toolbar 
icon Shortcut key Corresponding 

menu Description Reference

 List Operands Display the Label Registration/Selection 
screen.

(Structured)

+ Display Template Insert a template corresponds to the 
instruction/function/control syntax.

++ Mark Template (Left)
Set an argument of the template in the 
selected status from the left by selecting 
the menu each time.

++ Mark Template 
(Right)

Set an argument of the template in the 
selected status from the right by selecting 
the menu each time.

+ Toggle Bookmark
Set a bookmark at the cursor line. If a 
bookmark has already been set, delete the 
set bookmark.

– Bookmark List Jump to the specified bookmark from the 
bookmark list.

 Next Bookmark Display the next bookmark position.

+ Previous Bookmark Display the previous bookmark position.

++ Delete All Bookmarks Delete all bookmarks.

+ Num*1

*1 : 'Num' indicates keys in the numeric keypad.

Increase Zoom Zoom in the screen one level.

+ Num*1 Decrease Zoom Zoom out the screen one level.

– + Jump Jump to the specified line.

– + Zoom Header/Body 
Header

Open the label setting editor of the 
selected POU.

– + Copy Copy the selected data.

– + Cut Cut the selected data.

– + Paste Paste the cut/copied data at the cursor 
position.

–  Instruction Help Display details of instructions. Section 3.4.1

– ++ – Enter an assignment operator (:=) when 
editing the inline structured text program. (Structured)
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■ "Structured Ladder/FBD" toolbar icons and shortcut keys

The following table shows the toolbar icons and the corresponding shortcut keys for the Structured 
Ladder/FBD editor.

Toolbar 
icon Shortcut key Corresponding 

menu Description Reference

+ Select Mode Change the input mode for positioning 
contacts/coils.

(Structured)

+ Interconnect Mode Change the input mode for drawing lines.

++ Guided Mode/Guided 
Editing

Change the input mode for entry with 
keyboard.

++ Guided Mode/Auto 
Comment

Add a comment entry field at the start of 
the ladder block added in Guided editing.

+ Auto Connect Connect the start and end points to draw a 
line automatically.

+ Insert Row Insert a row into the ladder program being 
edited.

+ Insert Column Insert a column into the ladder program 
being edited.

++ New Ladder Block 
Before

Insert a new ladder block in front of the 
ladder block being edited.

++ New Ladder Block 
After

Insert a new ladder block after the ladder 
block being edited.

– Input Instruction Open the Input Instruction screen.

– Left Power Rail Display/hide the left power rail.

 Open Contact Insert an open contact at the cursor 
position.

 Close Contact Insert a closed contact at the cursor 
position.

 Open Branch Insert an open contact branch at the cursor 
position.

 Close Branch Insert a closed contact branch at the 
cursor position.


Vertical Line 
Segment Insert a vertical line at the cursor position.


Horizontal Line 
Segment

Insert a horizontal line at the cursor 
position

 Coil Insert a coil at the cursor position.

 Selection Display the Function Block Selection 
window.

 Input Label Insert an input variable at the cursor 
position.

 Output Label Insert an output variable at the cursor 
position.

– Rising Pulse Insert a rising pulse at the cursor position.

– Falling Pulse Insert a falling pulse at the cursor position.

– Rising Pulse Close Insert a rising pulse close at the cursor 
position.

– Falling Pulse Close Insert a falling pulse close at the cursor 
position.

+ Jump Insert a jump at the cursor position.
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+ Return Insert a return at the cursor position.

(Structured)

+ Comment Insert a comment entry field.

++ Ladder Block Label Display the Ladder Block screen.

 List Operands Display the Label Registration/Selection 
screen.

 Increment Pins Increment the number of arguments of 
functions and function blocks.

 Delete Pins Delete the number of arguments of 
functions and function blocks.

+ Num*1 Increase Zoom Zoom in the screen one level.

+ Num*1 Decrease Zoom Zoom out the screen one level.

– +/ – Narrow and widen the width of ladder block 
in the Guided mode.

– ++ Signal Configuration/
Configure Set the type of contact and coil.

– ++ Signal Configuration/
Toggle

Change the type of contact and coil in the 
order shown below:
• Contact: Open Contact → Close Contact
• Coil: Normal → Negation → Set → 

Reset

– + Jump Jump to the specified ladder block number.

– ++
Change Label-
Device-Address 
Mode

Switch the display format in order (label, 
device, address).

– ++ Change Label-
Comment Mode

Switch the display between label and 
comment.

– + Zoom Header/Body/
Header

Open the label setting editor screen for the 
selected POU.

– + Copy Copy the selected data.

– + Cut Cut the selected data.

– + Paste Paste the cut/copied data at the cursor 
position.

– 
Guided Mode/
Overwrite, Insert 
Mode

Switch the input mode between Overwrite/
Insert in the Guided mode.

– + Guided Mode/Line 
Mode

Change the input mode for drawing lines in 
Guided editing.

– + – Scroll a ladder block to the right.

– + – Scroll a ladder block to the left.

–  Instruction Help Display details of instructions. Section 3.4.1

*1 : 'Num' indicates keys in the numeric keypad.

Toolbar 
icon Shortcut key Corresponding 

menu Description Reference
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■ "SFC" toolbar icons and shortcut keys

The following table shows the toolbar icons and the corresponding shortcut keys for the SFC editor.

Toolbar 
icon Shortcut key Corresponding menu Description Reference

 [STEP] New Step Insert  at the cursor position.

(Simple)


[B] Block Start Step (with END 
check) Insert  at the cursor position.

+ [BS] Block Start Step (without END 
check) Insert  at the cursor position.

 [JUMP] Jump Insert  at the cursor position.

 [END] END Step Insert  at the cursor position.

+ [DUMMY] Dummy Step Insert  at the cursor position.

 [TR] Transition Insert  at the cursor position.

 [--D] Selection Divergence Insert a selection divergence.

 [==D] Simultaneous Divergence Insert a simultaneous divergence.

 [--C] Selection Convergence Insert a selection convergence.

 [==C] Simultaneous Convergence Insert a simultaneous convergence.

+ [|] Vertical Line Insert a vertical line.

+ No Attribute Set the step attribute to No Attribute.

+ Stored Coil Set the step attribute to Stored Coil.

+ Stored Operation (without 
Transition Check)

Set the step attribute to Stored Operation 
(SE).

+ Stored Operation (with Transition 
Check)

Set the step attribute to Stored Operation 
(ST).

+ Reset Reset the step attribute.

+ Vertical Line (Draw Line) Insert  at the cursor position.

+ Selection Divergence (Draw Line) Insert  at the cursor position.

+ Simultaneous Divergence (Draw 
Line) Insert  at the cursor position.

+ Selection Convergence (Draw Line) Insert  at the cursor position.

+ Simultaneous Convergence (Draw 
Line) Insert  at the cursor position.

+ Delete Line Delete the line at the cursor position.

– SFC Step/Transition Comment Edit the SFC step/transition comments.

– Sort SFC Step No. Sort the SFC block step numbers.

– SFC All Block Batch Monitoring Batch monitor all blocks in the SFC 
program.

– SFC Auto Scroll
Scroll the screen to display active steps 
automatically when they are out of the 
screen during monitoring.

+ Read Mode Switch the mode of the open window to 
"Read Mode".

 Write Mode Switch the mode of the open window to 
"Write Mode".

 Monitor Mode Switch the mode of the open window to 
"Monitor Mode" during monitoring.

+ Monitor (Write Mode) Switch the mode of the open window to 
"Monitor (Write Mode)" during monitoring.

– Zoom Change the display magnification ratio of 
the SFC diagram.
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■ SFC block list shortcut keys

The following table shows the shortcut keys for the SFC block list.

–
+ turn 

mouse scroll 
wheel upward

Bigger Enlarge the text display size on the editing 
screen.

(Simple)

–
+ turn 

mouse scroll 
wheel downward

Smaller Reduce the text display size on the editing 
screen.

– + Insert Row Insert a row at the cursor position.

– + Delete Row Delete the row at the cursor position.

– + Insert Column Insert a column at the cursor position.

– + Delete Column Delete the column at the cursor position.

– + Jump Move the cursor to the SFC step number/
transition number in the specified block

– + Find Jump Step Move the cursor to the step of the jump 
source.

– Numeric key – Move the cursor to the SFC step number/
transition number.

– ++ Convert Block Convert a single block only.

– + SFC Step/Transition Comment Display the SFC step/transition comments.

–
+/

+ double-
click

Open Zoom/Start Destination Block Display the Zoom editor window or the start 
destination block.

–  – Display the start destination block.

– + Back to Start SFC Block Display the start source block.

– ++ Program Display Display programs on the SFC diagram 
when editing in MELSAP-L.

Toolbar 
icon Shortcut key Corresponding menu Description Reference

Toolbar 
icon Shortcut key Corresponding menu Description Reference

– + Jump Jump to the specified block number/data 
name.

(Simple)– Numeric key – Jump to the selected block number.

– + SFC Block List Comment Display comments of the SFC block list.
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■ Other shortcut keys

The following table shows other shortcut keys for program editors.

Toolbar 
icon Shortcut key Corresponding 

menu Description Reference

– /// – Move the cursor in the arrow direction.

(Structured)

–  – Scroll up the screen.

–  – Scroll down the screen.

– + – Scroll the screen to the left.

– + – Scroll the screen to the right.

–  – Move the cursor to its leftmost position in 
the row.

–  – Move the cursor to its rightmost position 
in the row.

– + – Move the cursor to the start of the 
program.

– + – Move the cursor to the end of the 
program.

– +/// – Set a range.

– ++ – Select the range from the current 
position up to the start of the program.

– ++ – Select the range from the current 
position down to the end of the program.

–  – Delete the selected target.
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Appendix 1.8 Toolbar icons and shortcut keys for I/O system setting 
function

The following table shows the toolbar icons and the corresponding shortcut keys for the I/O system 
setting function.

Toolbar 
icon Shortcut key Corresponding menu Description Reference

+ New Create a new I/O system setting. Section 19.8.1

+ Open Open an existing I/O system setting. Section 19.8.2

+ Save Save the I/O system setting. –

+ Cut Cut the selected data.

Section 19.4.2+ Copy Copy the selected data.

+ Paste Paste the cut/copied data at the 
cursor position.

– Execute I/O System 
Setting

Execute the I/O system setting 
function and starts simulation. Section 19.6.1

– Disable I/O System 
Setting

Disable the execution of the I/O 
system setting function. Section 19.6.2

– Start Monitoring Start monitoring the I/O System 
Setting screen.

Section 19.7.1
– Stop Monitoring Stop monitoring the I/O System 

Setting screen.

– + Exit I/O System 
Settings Exit the I/O system setting. –
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Appendix 1.9 Shortcut keys for operating intelligent function module

The following explains the toolbar icons and the corresponding shortcut keys for editing intelligent 
function module data.

■ Toolbar icons for positioning monitor function

The following table shows the toolbar icons for the positioning monitor function.

■ Toolbar icons and shortcut keys for predefined protocol support function

The following table shows the toolbar icons and the corresponding shortcut keys for the predefined 
protocol support function.

Toolbar 
icon Shortcut key Corresponding menu Description Reference

– – Monitor the operating status of positioning 
module.

(Intelligent)

– – Monitor the start history.

– – Monitor the error history.

– – Monitor the warning history.

 – Start the positioning monitor.

+ – Stop the positioning monitor.

Toolbar 
icon Shortcut key Corresponding menu Description Reference

+ New Create a new communication protocol.

(Intelligent)

+ Open Open an existing communication protocol.

+ Save Save the protocol information.

+ Copy Copy the selected data.

+ Paste Paste the cut/copied data at the cursor 
position.

– Print Print the protocol information.

– Write to Module Write data to the module.

– Read from Module Read data from the module.
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Appendix 2 Simulation Function

The simulation function debugs sequence programs on the virtual programmable controller on the 
personal computer.
The created sequence programs can be debugged without connecting the personal computer to the 
programmable controller CPU.

This section explains the simulation function and the restrictions.

Appendix 2.1 Supported CPU functions

This section explains the programmable controller CPU functions that are supported by GX Works2 
simulation function.
The following tables show the functions that are supported by the simulation function.

: Supported : Supported with restrictions ×: Not supported

Q CPU L CPU FXFXRemote FXHead

Function name Function detail
Supported/

Not 
supported

Remarks

Programming

Memory

Program memory  –

Program cache memory × –

Memory card (RAM)  –

Memory card (ROM) × –

Standard RAM  –

Standard ROM  –

I/O number

I/O number assignment 
(automatic)  –

I/O number assignment 
(specified)  –

Number of points occupied by 
empty slots  –

Number of base slots  QCPU (Q mode) only

Interrupt program – × –

Multiple program execution

Program executing order setting  –

Initial execution type  –

Scan execution type  –

Standby type  –

Fixed scan execution type  –

Change (Set) by parameter  –

Change by instruction  –

Boot operation –  –

Programming language

Ladder Diagram  –

List × –

Sequential Function Chart 
(MELSAP3, MELSAP-L) *1 –

Structured Text  –

Communication with intelligent function 
module – × –
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Programmable controller CPU function

Constant scan – 
No operation is performed in 
actual time.

Watch dog timer (WDT) – 
30,000,000 instructions per 
scan

Latch function – 
Supported by device backup 
function.

Device initial value –  –

Service processing setting – × –

Output mode setting at STOP to RUN –  –

Input response time selection – × –

Error time output mode setting – × –

CPU operation mode at hardware error – × –

Switch setting of intelligent function 
module – × –

Monitor function –  –

Monitor condition setting – × –

Monitoring/testing local devices –  –

Remote password – × –

CPU module system display – × –

LED display –  –

Interrupt from intelligent function 
module – × –

Serial communication function – × –

Remote RUN/STOP –  –

Remote PAUSE – × –

Remote RESET –  –

Remote latch clear –  –

Scan time measurement – × –

Program list monitoring – 
No operation is performed in 
actual time.

Interrupt program list monitoring – × –

Monitoring/testing devices –  –

Forced ON/OFF of external I/O –  –

Device test with execution condition –  –

Sampling trace –  –

Online program change – 
SFC file batch online program 
change is not supported.

Debugging by multiple programming 
tools – × –

Self-diagnostic function –  –

Error history –  –

System protection – × –

Password registration – × –

Error reset –  –

LED control function –  –

Module error history collection function – × –

Local device batch read function – × –

Backing up latch data to standard ROM – × –

Function name Function detail
Supported/

Not 
supported

Remarks
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Programmable controller CPU function

Writing/Reading device data to 
standard ROM – 

Supported by device backup 
function.

Reading module name – × –

Clock function – 

Clock setting is not 
supported.
Extended clock setting (1/
1000 seconds) is not 
supported.

Battery long-life operation – × –

Memory check function – × –

LCPU data logging function – 

Only trigger logging is 
supported by sampling trace 
function.

LCPU built-in I/O function – × –

LCPU built-in Ethernet function – × –

LCPU built-in CC-Link function – × –

QCPU multiple CPU system – × –

QCPU network – × –

Device, Constant

A series CPU compatibility setting
(Special relay, special register) – × –

Device indexing
16-bit indexing  –

32-bit indexing  –

Pointer Local/Common pointer  –

Local device –  –

Floating point arithmetic processing
(Internal precision) –  Rounding error occurs.

Device setting –  –

Indirect specification –  –

File register setting –  –

Extended data register, extended link 
register (Use file registers) –  –

Extension of bit device points –  –

*1 : The following functions are not supported.
· Periodic execution program setting
· Operation mode at block/step concurrent start
· Step transition monitoring timer
· Control SFC type program
· Step/Transition comment read (instruction)

Function name Function detail
Supported/

Not 
supported

Remarks
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Appendix 2.2 Supported devices

This section explains the devices supported by the simulation function.
However, some devices may be restricted or not supported. No processing is performed for 
unsupported devices (NOP processing).
Unsupported devices used in a program and their used locations can be checked by selecting [Debug] 
⇒ [Instructions Unsupported by Simulation]. (Section 15.3)

● Device list (QCPU (Q mode)/LCPU)
Devices SM/SD1000 and later are not supported by the simulation function.

: Supported ×: Not supported –: Irrelevant

Category Type Device name Range set by 
parameter Support Remarks

Internal user 
device

Bit device

Input (X)

Applicable (within 29k 
words)

 Actual inputs are invalid.

Output (Y)  Actual outputs are invalid.

Internal relay (M)*1  –

Latch relay (L)  –

Annunciator (F)  –

Edge relay (V)*1  –

Step relay (S)  –

Link special relay (SB)  –

Link relay (B)  –

Word 
device

Timer (T)*1, *2 

No operation is performed in actual time.
The high-speed timer can be set in units of 
0.1ms (by parameter). (For Universal model 
QCPU and LCPU, in units of 0.01ms)

Retentive timer (ST)*2 

No operation is performed in actual time.
The high-speed retentive timer can be set in 
units of 0.1ms (by parameter). (For Universal 
model QCPU and LCPU, in units of 0.01ms)

Counter (C)*2  –

Data register (D)*1  –

Link register (W)  –

Link special register (SW)  –

Internal system 
device

Bit device

Function input (FX)

Not applicable

 –

Function output (FY)  –

Special relay (SM) 
For the supported special relays, refer to the 
Special relay list.

Word 
device

Function register (FD)  –

Special register (SD) 
For the supported special registers, refer to 
the Special register list.

Link direct 
device

Bit device

Link input (Jn\X)

Not applicable

× –

Link output (Jn\Y) × –

Link relay (Jn\B) × –

Link special relay (Jn\SB) × –

Word 
device

Link register (Jn\W) × –

Link special register (Jn\SW) × –

Intelligent 
function module 
device

Word 
device

Intelligent function module 
device (Un\G) Not applicable 

I/O assignment setting in PLC parameter is 
required.

Index register Word 
device Index register (Z) Not applicable  –
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File register Word 
device File register (ZR) 0 to 1017k points

(in units of 1k) 

File register setting in PLC parameter is 
required.
For Universal model QCPU and LCPU, 0 to 
4086k points

Nesting – Nesting (N) Not applicable  –

Pointer –
Pointer (P)

Not applicable
 –

Interrupt pointer (I) × –

Others

Bit device
SFC block device (BL)

Not applicable

 –

SFC transition device (TR) × –

–

Network number specified 
device (J) × –

I/O number specified device 
(U) × –

Macro instruction argument 
device (VD)  –

CPU shared memory (Un\G) 

Memory for reading/writing data among CPU 
modules in a multiple CPU system.
Enabled only when multiple CPU settings 
are made.
Not supported by LCPU.

Constant –

Decimal constant K-2147483648 to 
2147483647  –

Hexadecimal constant H0 to FFFFFFFF  –

Real constant

E±1.17550-38 to 
E±3.40282+38  –

E±2.22507-308 to 
E±1.79770+308 × –

String constant "ABC", "123"  Up to 32 characters per instruction

*1 : Devices that can be used for local devices
*2 : Timer/Retentive timer/Counter: Contact and coil are bit devices and current value is a word device.

Category Type Device name Range set by 
parameter Support Remarks
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● Device list (FXCPU)
: Supported ×: Not supported –: Irrelevant

Category Type Device name Purpose Support Remarks

Internal 
user device

Bit device

Input (X) –  Octal number. Actual inputs are invalid.

Output (Y) –  Octal number. Actual outputs are invalid.

Auxiliary relay (M)

General type*1 (changeable)  –

Latched type*2 (changeable)  –

General type (fixed)  –

Latched type*3 (fixed)  –

Special type  –

State (S)

Initial state*1  –

Initial state (latched)  –

General type*1  –

Latched type*2  –

Annunciator type*3  –

Latched type*3  –

Word 
device

Timer (T)

100ms  –

10ms  –

100ms/10ms  –

Retentive type for 1ms*3  –

Retentive type for 100ms*3  –

1ms*3  –

Counter (C)

16-bit up-counter*1  –

16-bit up-counter*2  –

32-bit bidirectional counter*1  –

32-bit bidirectional counter*2  –

High-speed counter × –

Data register (D) (32 bits 
when used in pairs)

16-bit general type*1  –

16-bit latched type*2  –

16-bit latched type*3  –

16-bit special type  –

File type*1  –

RAM file type  –

16-bit latched type
(extension register [R])  –

16-bit latched type
(extension file register [ER]) × –

Buffer memory  –

16-bit index type  –
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Nesting (N) Master control  –

Pointer
Pointer (P) JUMP or CALL branch  –

Interrupt pointer (I) Interruption × –

Decimal constant
16 bits  –

32 bits  –

Hexadecimal constant
16 bits  –

32 bits  –

Real number constant  –

Character string constant  –

*1 : Non-latched area. It can be changed to the latched area by parameter setting.
*2 : Latched area. It can be changed to the non-latched area by parameter setting.
*3 : Fixed latched area. The characteristics of latch cannot be changed.

Category Type Device name Purpose Support Remarks
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● Special relay list (QCPU (Q mode)/LCPU)
For details of special relays
User's Manual (Function Explanation, Program Fundamentals) of the CPU module to be used

No. Name Description

SM0 Diagnostic error

SM1 Self-diagnostic error

SM5 Error common 
information

SM16 Error individual 
information

SM50 Error reset OFF→ON: Error reset

SM56 Operation error

SM62 Annunciator detection

SM165 Program memory batch 
transfer execution status

SM202 LED OFF command OFF→ON: LED OFF

SM203 STOP contact STOP status

SM204 PAUSE contact PAUSE status

SM206 PAUSE enable coil

SM213 Clock data read request

SM250 Max. loaded I/O read

SM320 Presence/absence of 
SFC program

SM321 Start/stop SFC program

SM322 SFC program start status

SM323
Presence/absence of 
continuous transition for 
entire block

SM324 Continuous transition 
prevention flag

SM325 Output mode at block 
stop

SM326 SFC device clear mode

OFF: No error
ON : Error

OFF: No self-diagnostic 
error

ON : Self-diagnostic error

OFF: No error common 
information

ON : Error common 
information

OFF: No error individual 
information

ON : Error individual 
information

OFF: Normal
ON : Operation error

OFF: Not detected
ON : Detected

OFF: Completed
ON : Not being executed 

or not completed

OFF: PAUSE disabled
ON : PAUSE enabled

OFF: Ignored
ON : Read request

OFF: Ignored
ON : Read

OFF: SFC program absent
ON : SFC program present

OFF: SFC program not 
executed (stop)

ON : SFC program 
executed (start)

OFF: Initial start
ON : Resume start

OFF: Continuous transition 
not effective

ON : Continuous transition 
effective

OFF: When transition is 
executed

ON : When no transition

OFF: OFF
ON : Preserves

OFF: Clear device
ON : Preserves device

SM327 Output during end step 
execution

SM328 Clear processing mode 
when end step is reached

SM400 Always ON

SM401 Always OFF

SM402 After RUN, ON for only 1 
scan

SM403 After RUN, OFF for only 
1 scan

SM405
Low speed execution 
type program After RUN, 
OFF for 1 scan only

SM409*1 0.01 second clock

SM410*1 0.1 second clock

SM411*1 0.2 second clock

SM412*1 1 second clock

SM413*1 2 second clock

SM414*1 2n second clock

SM415*1 2n (ms) clock

SM420 User timing clock No. 0

SM421 User timing clock No. 1

SM422 User timing clock No. 2

SM423 User timing clock No. 3

SM424 User timing clock No. 4

SM430 User timing clock No. 5

SM431 User timing clock No. 6

SM432 User timing clock No. 7

SM433 User timing clock No. 8

SM434 User timing clock No. 9

SM510 Low speed program 
execution flag

SM600 Memory card usable 
flags

SM602 Drive 1 flag

No. Name Description

OFF: Hold step output 
turned OFF (cleared)

ON : Hold step output held

OFF: Clear processing is 
performed.

ON : Clear processing is 
not performed.

ON

OFF

ON

OFF

ON

OFF
1 scan

ON

OFF
1 scan

ON

OFF
1 scan

0.005 sec 0.005 sec

0.05 sec 0.05 sec

0.1 sec 0.1 sec

0.5 sec 0.5 sec

1 sec 1 sec

n sec n sec

n (ms) n (ms)

n2
scan

n2
scan

n1
scan

OFF: Completed or not 
executed

ON : Execution under way

OFF: Unusable
ON : Use enabled

OFF: No drive 1
ON : Drive 1 present
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SM603 Drive 2 flag

SM604 Memory card in-use flag

SM620 Drive 3/4 usable flags

SM621 Drive 3/4 protect flag

SM622 Drive 3 flag

SM623 Drive 4 flag

SM624 Drive 3/4 in-use flag

SM640 File register use

SM650 Comment use

SM672 Memory card file register 
access range flag

SM680 Program memory write 
error

SM681 Program memory writing 
flag

SM700 Carry flag

SM703 Sort order

SM704 Block comparison

SM722 BIN/DBIN instruction 
error disabling flag

SM776 Enable/disable local 
device at CALL

SM777
Enable/disable setting for 
local devices in interrupt 
program

SM800 Trace preparation

SM801 Trace start

SM802 Trace execution in 
progress

SM803 Trace trigger OFF → ON: Start

SM804 After trace trigger

No. Name Description

OFF: No drive 2
ON : Drive 2 present

OFF: Not used
ON : In use

OFF: Unusable
ON : Use enabled

OFF: Not protected
ON : Protected

OFF: No drive 3
ON : Drive 3 present

OFF: No drive 4
ON : Drive 4 present

OFF: Not used
ON : In use

OFF: File register not used
ON : File register in use

OFF: Comment not used
ON : Comment in use

OFF: Within access range
ON : Outside access 

range

OFF: Write not executed/
normal

ON : Write error

OFF: Write not executed
ON : During writing

OFF: Carry OFF
ON : Carry ON

OFF: Ascending order
ON : Descending order

OFF: Non-match found
ON : All match

OFF: Error detection 
performed

ON : Error detection not 
performed

OFF: Local device disabled
ON : Local device enabled

OFF: Local device disabled
ON : Local device enabled

OFF: Not ready
ON : Ready

OFF: Suspend
ON : Start

OFF: Suspend
ON : Start

OFF: Not after trigger
ON : After trigger

SM805 Trace completed

SM826 Trance error

SM829
Forced registration 
specification of trace 
setting

SM1500*2
Process control 
instruction
S.IN hold mode

SM1501*2
Process control 
instruction
S.OUT hold mode

SM1510*3 Operation mode

(Fixed to 'OFF')

SM1511*3 System A identification 
flag (Fixed to 'ON' (System A))*4

SM1512*3 System B identification 
flag

(Fixed to 'OFF' (System 
A))*4

SM1513*3 Debug mode status flag
(Fixed to 'ON')

SM1515*3

Operation system status

(Fixed to 'ON' (Control 
system))*5

SM1516*3 (Fixed to 'OFF' (Control 
system))*5

*1 : When the setting value of the constant scan is equal to the 
integral multiple of the clock time, the value of the special relay 
is OFF every scan. For the setting to turn the clock of the 
special relay ON/OFF, refer to Point in the next page.

*2 : These devices are for the process control instruction, and 
supported by Process CPU and Redundant CPU only.
When the program with the process control instruction is written 
to the programmable controller CPU other than Process CPU 
and Redundant CPU, a stop error occurs on the CPU from 
INSTRCT.CODE ERR (error code 4002).

*3 : Applicable for operations on Redundant CPU only. Fixed to the 
status in the parentheses.

*4 : The following shows the correspondences for the system A and 
the system B of Redundant system.
System A: When SM1511 is ON, or SM1512 is OFF.
System B: When SM1511 is OFF, or SM1512 is ON.
Unspecified system: When both SM1511 and SM1512 are 
OFF.

*5 : The following shows the correspondences for the operating 
status of CPU module.
Control system: When SM1515 is ON, or SM1516 is OFF.
Standby system: When SM1515 is OFF, or SM1516 is ON.
Unspecified system: When both SM1515 and SM1516 are 
OFF.

No. Name Description

OFF: Not completed
ON : End

OFF: Normal
ON : Error

OFF: Forced registration 
disabled

ON : Forced registration 
enabled

OFF: No-hold
ON : Hold

OFF: No-hold
ON : Hold

OFF: Backup mode, debug 
mode

ON : Separate mode

OFF: Not in debug mode
ON : Debug mode



Appendix 2  Simulation Function

Appendix 2.2  Supported devices App - 31

17

O
P

E
R

A
TI

N
G

 
PR

O
G

R
A

M
M

AB
LE

 
C

O
N

TR
O

LL
E

R
 C

P
U

18

DI
AG

NO
SI

NG
 

PR
OG

RA
M

M
AB

LE
 

CO
NT

RO
LL

ER
 S

TA
TU

S

19

SI
M

U
LA

TI
N

G
 

O
PE

R
AT

IO
N

S 
O

F 
EX

TE
R

N
AL

 D
EV

IC
ES

20

P
R

IN
TI

N
G

21

S
E

TT
IN

G
 O

P
TI

O
N

S

22

U
S

IN
G

 L
IB

R
A

R
IE

S

A

A
PP

E
N

D
IX

I

IN
D

EX

● Turning clock of special relay ON/OFF
To turn the clock of the special relay ON/OFF, set the constant scan setting value avoiding the integral multiple of the 
clock time, as described by the following example “Not equal to integral multiple” shown below.
• Example: Not equal to integral multiple

The following figure shows the behavior of the 0.1-second clock when the constant scan is 50ms.
The special relay repeats ON/OFF.

• Example: Equal to integral multiple
The following figure shows the behavior of the 0.1-second clock when the constant scan is 100ms (default).
The value of the special relay is OFF every scan.

● Contact scan setting
To set the constant scan setting value, select [PLC Parameter] ⇒ <<PLC RAS>> and set it.

0

50ms

Clock ON/OFF 
inversion and 
value of special 
relay

1 2

ON

3 4 5 6

0 0.05 0.1 0.15 0.2 0.25 0.3 (Second)

(Scan)

ON ONOFF OFF OFF

0.1-second clock

0

100ms

Clock ON/OFF 
inversion and 
value of special 
relay

1 2

0 0.05 0.1 0.15 0.2 0.25 0.3 (Second)

OFF OFF

0.1-second clock

3
(Scan)

OFF
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● Special relay list (FXCPU)
For details of special relays
FXCPU Structured Programming Manual [Device & Common]

No. Name Description

M8000 RUN monitor NO contact

M8001 RUN monitor NC contact

M8002 Initial pulse NO contact ON for only 1 scan after 
RUN

M8003 Initial pulse NC contact OFF for only 1 scan after 
RUN

M8004 Error occurrence ON while either one among 
M8060 to M8067 is ON

M8011 10ms clock

M8012 100ms clock

M8013 1 sec. clock

M8014 1 min. clock

M8018 Installation detection for 
real-time clock Always ON

M8020 Zero ON when the addition or 
subtraction result is 0

M8021 Borrow
ON when the subtraction 
result is less than the 
maximum negative value

M8022 Carry ON when "carry" occurs in 
the addition result

M8023 Floating-point calculation 
command

M8024 BMOV instruction 
execution direction

M8026 RAMP mode

M8028 Timer switch command

M8029 Instruction execution 
complete

M8031 Non-latched memory all 
clear

M8032 Latched memory all clear

M8033 Memory holding against 
STOP mode

M8034 All output disable

M8038 RAM file clear command

M8039 Constant scan mode

OFF: STOP
ON : RUN

OFF: RUN
ON : STOP

ON : Carry out floating-
point calculation

ON : Write
OFF: Read

ON : Hold output value
OFF: Reset value at output

OFF: 100ms timer
ON : 10ms timer

OFF: During executing
ON : Execution completed

OFF: Hold
ON : Clear

OFF: Hold
ON : Clear

OFF: Clear
ON : Hold

OFF: Enable output
ON : Disable output

OFF: Hold
ON : Clear

OFF: Normal scan
ON : Constant mode

M8040 Transfer disable

M8041 Transfer start (for IST 
instruction)

M8042 Start pulse (for IST 
instruction)

M8043
Zero point return 
complete (for IST 
instruction)

M8044 Zero point condition (for 
IST instruction)

M8045 All output reset disable 
(for IST instruction)

M8046 STL state ON

M8047 STL monitoring enable

M8048 Annunciator ON ON while either one among 
S900 to S999 is ON

M8049 Annunciator enable

M8067 Operation error

M8068 Operation error latch Hold occurrence of M8067

M8074 RAM file register setting

M8090 BKCMP instruction: 
Block comparison signal

M8091 Output character quantity 
selector signal

M8160 XCH instruction: SWAP 
function

M8161 8-bit processing mode
Processing mode in the 
ASC, ASCI, and HEX 
instructions

M8164
FROM and TO 
instructions: Transfer 
points variable mode

Transfer points switch 
command

M8168
SMOV instruction: 
Hexadecimal data 
handling function

Data shift in 4-bit units

M8200 Counter counting 
direction

No. Name Description

OFF: Enable transfer
ON : Disable transfer

OFF: Stop transfer
ON : Start transfer

ON : IST instruction start 
command

ON : IST instruction zero 
point return complete 
command

ON : Zero point
OFF: Zero point return is 

undetermined

ON : Disable reset
OFF: Enable reset

ON : ON while either one 
among S0 to S899 is 
ON

ON : Enable D8040 to 
D8047

ON : Enable D8049
OFF: Disable D8049

ON : Operation error
OFF: No operation error

ON : Use setting
OFF: Not use setting

ON : Comparison result 
matches

OFF: Comparison result 
does not match

ON : Change nothing
OFF: Write 00H (NULL)

ON : 8-bit conversion
OFF: Normal mode

ON : C200 is down-
counting

OFF: C200 is up-counting
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M8201 Counter counting 
direction

M8202 Counter counting 
direction

M8203 Counter counting 
direction

M8204 Counter counting 
direction

M8205 Counter counting 
direction

M8206 Counter counting 
direction

M8207 Counter counting 
direction

M8208 Counter counting 
direction

M8209 Counter counting 
direction

M8210 Counter counting 
direction

M8211 Counter counting 
direction

M8212 Counter counting 
direction

M8213 Counter counting 
direction

M8214 Counter counting 
direction

M8215 Counter counting 
direction

M8216 Counter counting 
direction

M8217 Counter counting 
direction

M8218 Counter counting 
direction

No. Name Description

ON : C201 is down-
counting

OFF: C201 is up-counting

ON : C202 is down-
counting

OFF: C202 is up-counting

ON : C203 is down-
counting

OFF: C203 is up-counting

ON : C204 is down-
counting

OFF: C204 is up-counting

ON : C205 is down-
counting

OFF: C205 is up-counting

ON : C206 is down-
counting

OFF: C206 is up-counting

ON : C207 is down-
counting

OFF: C207 is up-counting

ON : C208 is down-
counting

OFF: C208 is up-counting

ON : C209 is down-
counting

OFF: C209 is up-counting

ON : C210 is down-
counting

OFF: C210 is up-counting

ON : C211 is down-
counting

OFF: C211 is up-counting

ON : C212 is down-
counting

OFF: C212 is up-counting

ON : C213 is down-
counting

OFF: C213 is up-counting

ON : C214 is down-
counting

OFF: C214 is up-counting

ON : C215 is down-
counting

OFF: C215 is up-counting

ON : C216 is down-
counting

OFF: C216 is up-counting

ON : C217 is down-
counting

OFF: C217 is up-counting

ON : C218 is down-
counting

OFF: C218 is up-counting

M8219 Counter counting 
direction

M8220 Counter counting 
direction

M8221 Counter counting 
direction

M8222 Counter counting 
direction

M8223 Counter counting 
direction

M8224 Counter counting 
direction

M8225 Counter counting 
direction

M8226 Counter counting 
direction

M8227 Counter counting 
direction

M8228 Counter counting 
direction

M8229 Counter counting 
direction

M8230 Counter counting 
direction

M8231 Counter counting 
direction

M8232 Counter counting 
direction

M8233 Counter counting 
direction

M8234 Counter counting 
direction

No. Name Description

ON : C219 is down-
counting

OFF: C219 is up-counting

ON : C220 is down-
counting

OFF: C220 is up-counting

ON : C221 is down-
counting

OFF: C221 is up-counting

ON : C222 is down-
counting

OFF: C222 is up-counting

ON : C223 is down-
counting

OFF: C223 is up-counting

ON : C224 is down-
counting

OFF: C224 is up-counting

ON : C225 is down-
counting

OFF: C225 is up-counting

ON : C226 is down-
counting

OFF: C226 is up-counting

ON : C227 is down-
counting

OFF: C227 is up-counting

ON : C228 is down-
counting

OFF: C228 is up-counting

ON : C229 is down-
counting

OFF: C229 is up-counting

ON : C230 is down-
counting

OFF: C230 is up-counting

ON : C231 is down-
counting

OFF: C231 is up-counting

ON : C232 is down-
counting

OFF: C232 is up-counting

ON : C233 is down-
counting

OFF: C233 is up-counting

ON : C234 is down-
counting

OFF: C234 is up-counting
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● Special register list (QCPU (Q mode)/LCPU)
For details of special registers
User's Manual (Function Explanation, Program Fundamentals) of the CPU module to be used

No. Name Description

SD0 Diagnostic error Diagnostic error code

SD1 Clock time for 
diagnosis error 
occurrence

Clock time for diagnosis error 
occurrenceSD2

SD3

SD4 Error information 
categories Error information category code

SD5

Error common 
information Error common information

SD6

SD7

SD8

SD9

SD10

SD11

SD12

SD13

SD14

SD15

SD16

Error individual 
information Error individual information

SD17

SD18

SD19

SD20

SD21

SD22

SD23

SD24

SD25

SD26

SD50 Error reset Error code to be reset

SD62 Annunciator number Annunciator number

SD63 Number of 
annunciators Number of annunciators

SD64

Table of detected 
annunciator numbers Annunciator detection number

SD65

SD66

SD67

SD68

SD69

SD70

SD71

SD72

SD73

SD74

SD75

SD76

Table of detected 
annunciator numbers Annunciator detection number

SD77

SD78

SD79

SD200 Status of switch Status of CPU switch

SD201 LED status Status of CPU-LED

SD202 LED OFF command Bit pattern of LED that is turned 
OFF

SD203 Operating status of 
CPU Operating status of CPU*1

SD204 LED display color CPU-LED display color

SD207
LED display priority 
ranking

Priorities 1 to 4

SD208 Priorities 5 to 8

SD209 Priorities 9 to 11

SD210 Clock data Clock data (year, month)

SD211 Clock data Clock data (day, hour)

SD212 Clock data Clock data
(minute, second)

SD213 Clock data
Clock data
(higher digits of year, day of 
week)

SD220

LED display data LED display data

SD221

SD222

SD223

SD224

SD225

SD226

SD227

SD240 Base mode 0: Automatic mode
1: Detail mode

SD241 Extension stage 
number

0: Main base only
1 to 7: Extension stage number

SD242 A/Q base 
differentiation

SD243 No. of base slots
(Operation status) Number of base slots

SD244

SD250 Loaded maximum I/O Loaded maximum I/O number

SD286

Device assignment

Number of points assigned for M 
(for extension)SD287

SD288 Number of points assigned for B 
(for extension)SD289

SD290 Number of points assigned for X

SD291 Number of points assigned for Y

SD292 Number of points assigned for M

SD293 Number of points assigned for L

No. Name Description

0 : QA**B is installed (A mode)
1 : Q**B is installed (Q mode)
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SD294

Device assignment

Number of points assigned for B

SD295 Number of points assigned for F

SD296 Number of points assigned for SB

SD297 Number of points assigned for V

SD298 Number of points assigned for S

SD299 Number of points assigned for T

SD300 Number of points assigned for ST

SD301 Number of points assigned for C

SD302 Number of points assigned for D

SD303 Number of points assigned for W

SD304 Number of points assigned for 
SW

SD305 Device assignment
(Index register)

16-bit modification
Number of points assigned for Z

SD306 Device assignment
(Same as parameter 
contents)

Number of points assigned for ZR
(for extension)SD307

SD308 Device assignment
(Assignment including 
the number of points 
set to the extended 
data register and 
extended link register 
setting)

Number of points assigned for D 
(for inside + for extension)SD309

SD310
Number of points assigned for W 
(for inside + for extension)SD311

SD395 Multiple CPU system 
information

Multiple CPU number

SD396 No. 1 CPU operation status

SD412*2 1 second counter Number of counts in 1-second 
units

SD414*2 2n second clock 
setting 2n second clock units

SD415*2 2n millisecond clock 
setting 2n millisecond clock units

SD420 Scan counter Number of counts in each scan

SD430 Low speed scan 
counter Number of counts in each scan

SD500 Execution program 
No. Program number in execution

SD520*3
Current scan time

Current scan time (ms value)

SD521*3 Current scan time (μs value)

SD522*3
Initial scan time

Initial scan time (ms value)

SD523*3 Initial scan time (μs value)

SD524*3
Minimum scan time

Minimum scan time (ms value)

SD525*3 Minimum scan time (μs value)

SD526
Maximum scan time

Maximum scan time (ms value)

SD527 Maximum scan time (μs value)

SD528 Current scan time for 
low speed execution 
type programs

Current scan time (ms value)

SD529 Current scan time (μs value)

SD532 Minimum scan time for 
low speed execution 
type programs

Minimum scan time (ms value)

SD533 Minimum scan time (μs value)

SD534 Maximum scan time 
for low speed 
execution type 
programs

Maximum scan time (ms value)

SD535 Maximum scan time (μs value)

No. Name Description

SD600 Memory card type Memory card type

SD602 Drive 1 (Memory card 
RAM) capacity Drive 1 capacity

SD603 Drive 2 (Memory card 
ROM) capacity Drive 2 capacity

SD604 Memory card use 
conditions Memory card use conditions

SD620 Drive 3/4 type Drive 3/4 type

SD622 Drive 3 (Standard 
RAM) capacity Drive 3 capacity

SD623 Drive 4 (Standard 
ROM) capacity Drive 4 capacity

SD624 Drive 3/4 use 
conditions Drive 3/4 use conditions

SD640 File register drive Drive number

SD641
to
SD646

File register file name File register file name

SD647 File register capacity File register capacity

SD648 File register block 
number File register block number

SD650 Comment drive Comment drive number

SD651
to
SD656

Comment file name Comment file name

SD670 Parameter enable 
drive information Parameter enable drive number

SD681 Program memory write 
(transfer) status

Write (transfer) status display 
(percentage)

SD840 Debug function usage Debug function usage

SD1500
*4 Process control 

instruction
Basic period

Basic period for process control 
instructionSD1501

*4

SD1502
*4

Process control 
instruction
Detail error code

Detailed error code for process 
control instruction

SD1503
*4

Process control 
instruction
Generated error 
location

Generated error location for 
process control instruction

SD1506
*4

Dummy devices Dummy devices
SD1507
*4

SD1508
*4

Process control 
instruction
Function availability 
selection

b0
Bumpless function availability 
setting for the S.PIDP instruction
0: Enabled
1: Disabled
(Default: 0)

*1 : SD203 supports the operating status of CPU only. STOP/
PAUSE cause is fixed to 0.

*2 : Values are derived from the constant scan setting value and 
the number of scans.

*3 : All values are equal to the constant scan setting value.

No. Name Description
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*4 : These devices are for the process control instruction, and 
supported by Process CPU and Redundant CPU only.
When the program with the process control instruction is 
written to the programmable controller CPU other than Process 
CPU and Redundant CPU, a stop error occurs on the CPU 
from INSTRCT.CODE ERR (error code 4002).
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● Special register list (FXCPU)
For details of special registers
FXCPU Structured Programming Manual [Device & Common]

No. Name Description

D8000 Watchdog timer 200ms*1

D8001 PLC type and system 
version

*2

D8002 Memory capacity
Maximum capacity based 
on the programmable 
controller type

D8004 Error M number M8060 to M8068

D8006 Low battery voltage 
detection level 30 (Unit: 0.1 V)

D8010 Current scan time *3

D8011 Minimum scan time *3

D8012 Maximum scan time *3

D8013 Second data Operate as 1-second timer

D8014 Minute data Time data

D8015 Hour data Time data

D8016 Day data Time data

D8017 Month data Time data

D8018 Year data Time data

D8019 Day-of-the-week data Time data

D8028 Value of register Z Value of register Z

D8029 Value of register V Value of register V

D8030 Variable analog 
potentiometer VR1

*4

D8031 Variable analog 
potentiometer VR2

*4

D8039 Constant scan time
Initial value: 100ms
(Unit: 1ms)*5

D8040 ON state relay number 1 Value of STL monitor

D8041 ON state relay number 2 Value of STL monitor

D8042 ON state relay number 3 Value of STL monitor

D8043 ON state relay number 4 Value of STL monitor

D8044 ON state relay number 5 Value of STL monitor

D8045 ON state relay number 6 Value of STL monitor

D8046 ON state relay number 7 Value of STL monitor

D8047 ON state relay number 8 Value of STL monitor

D8049 Smallest active state 
relay number Value of STL monitor

D8067 Error code for operation 
error Error code number

D8068
Latched step number 
where operation error 
has occurred

Hold step number where 
operation error has 
occurred

D8069 Step number where error 
has occurred

Step number where error 
has occurred

D8101 PLC type and system 
version

*6

D8102 Memory capacity
Maximum capacity based 
on the programmable 
controller type

D8164

FROM and TO 
instructions: Transfer 
points quantity 
specification

Write transfer points

D8182 Value of register Z1 Value of register Z1

D8183 Value of register V1 Value of register V1

D8184 Value of register Z2 Value of register Z2

D8185 Value of register V2 Value of register V2

D8186 Value of register Z3 Value of register Z3

D8187 Value of register V3 Value of register V3

D8188 Value of register Z4 Value of register Z4

D8189 Value of register V4 Value of register V4

D8190 Value of register Z5 Value of register Z5

D8191 Value of register V5 Value of register V5

D8192 Value of register Z6 Value of register Z6

D8193 Value of register V6 Value of register V6

D8194 Value of register Z7 Value of register Z7

D8195 Value of register V7 Value of register V7

D8312 Latched step number 
where operation error 
has occurred

Lower

D8313 Upper

D8314 Step number where error 
has occurred 32 bits

Lower

D8315 Upper

*1 : Initialized to 200ms on every programmable controller type. The 
watchdog timer time can be changed, but the WDT check is 
never performed.

*2 : The value of D8001 differs according to the programmable 
controller type.

*3 : The value is always set to 100ms.
*4 : Operates as a general data register. Write a value between 0 

and 255 and test the operation using functions such as the 
Modify Value function of GX Works2.

*5 : The value can be changed, but a single scan is always 
executed in 100ms.

No. Name Description

Programmable 
controller CPU Value

FX0, FX0S 20000

FX0N 20000

FX1 21000

FXU, FX2C 20000

FX1S 22000

FX1N, FX1NC 26000

FX2N, FX2NC 24000

FX3G, FX3GC 26000

FX3U, FX3UC 24000
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*6 : The value of D8101 differs according to the programmable 
controller type.

Programmable 
controller CPU

Value
'***' indicates a 

version.

FX0, FX0S

0

FX0N

FX1

FXU, FX2C

FX1S

FX1N, FX1NC

FX2N, FX2NC

FX3G, FX3GC 26***

FX3U, FX3UC 16***
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■ Devices supported by the I/O system setting function

The following table shows the list of devices which can be used for conditions, the device value input, 
and timing chart input in the I/O system setting function.

● Device list (QCPU (Q mode)/LCPU)
: Supported ×: Not supported

Category Device name Symbol QCPU (Q mode)/LCPU

Internal user device

Input X 

Output Y 

Internal relay M 

Latch relay L 

Annunciator F 

Edge relay V ×

Step relay S ×

Link relay B 

Link special relay SB 

Timer

Current value TN 

Contact TS 

Coil TC ×

Counter

Current value CN 

Contact CS 

Coil CC ×

Retentive timer

Current value STN(SN) 

Contact STS(SS) 

Coil STC(SC) ×

Data register D 

Link register W 

Link special register SW 

Direct input DX ×

Direct output DY ×

Internal system device

Function input FX 

Function output FY 

Special relay SM 

Function register FD 

Special register SD 

Link direct device

Link input J\X ×

Link output J\Y ×

Link register J\W ×

Link special register J\SW ×

Link relay J\B ×

Link special relay J\SB ×

Intelligent function module 
device Intelligent function module device U\G 

Index register Index register Z 

File register File register
R 

ZR 

Nesting Nesting N ×

Pointer
Pointer P ×

Interrupt pointer I ×
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● Device list (FXCPU)
: Supported ×: Not supported

Others
SFC block device BL ×

SFC transition device TR ×

Constant

Decimal constant K 

Hexadecimal constant H 

Real constant E ×

Category Device name Symbol QCPU (Q mode)/LCPU

Category Device name Symbol FXCPU

Device

Input X 

Output Y 

Auxiliary relay M 

State S 

Timer

Current value TN 

Contact TS 

Coil TC ×

Counter

Current value CN 

Contact CS 

Coil CC ×

Data register D 

Direct specification of buffer memory U\G *1

*1 : Supported by FX3U and FX3UC only.

Index register Index register
V 

Z 

Extension register Extension register R *2

*2 : Supported by FX3U, FX3UC, FX3G, and FX3GC only.

Nesting Nesting N ×

Pointer
JUMP or CALL branch P ×

Interrupt pointer I ×

Constant

Decimal constant K 

Hexadecimal constant H 

Real number constant E ×
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Appendix 2.3 Supported instructions

This section explains the instructions supported by the simulation function.
Instructions/functions used in Structured projects can also be simulated.
However, some instructions may be restricted or not supported. No processing is performed for 
unsupported instructions (NOP processing).

When an unsupported instruction is used,  is displayed in the monitor status display. 
(Section 14.1.2)
Unsupported devices used in a program and their used locations can be checked by selecting [Debug] 
⇒ [Instructions Unsupported by Simulation]. (Section 15.3)

■ QCPU (Q mode)/LCPU

● Sequence instructions

● Basic instructions

Category Symbol Restrictions

Contact instruction LD, LDI, AND, ANI, OR, ORI, LDP, LDF, ANDP, ANDF, ORP, ORF, 
LDPI, LDFI, ANDPI, ANDFI, ORPI, and ORFI –

Bond instruction ANB, ORB, MPS, MRD, MPP, INV, MEP, MEF, EGP, and EGF –

Output instruction OUT, OUT T, OUT C, OUT F, OUTH T, SET, RST, SET F, RST F, PLS, 
PLF, and FF –

Shift instruction SFT(P) –

Master control instruction MC and MCR –

End instruction FEND and END –

Other instruction STOP, NOP, NOPLF, and PAGE –

Category Symbol Restrictions

Comparison operation 
instruction

=, <>, >, , <, , D=, D<>, D>, D , D<, D , E=, E<>, E>, 
E , E<, E , and BKCMP(P) –

$=, $<>, $>, $<=, $<, and $>= Not supported by Basic model QCPU.

Arithmetic operation 
instruction

+(P), −(P), D+(P), D−(P), *(P), /(P), D*(P), D/(P), B+(P), B−(P), DB+(P), 
DB−(P), B*(P), B/(P), DB*(P), DB/(P), E+(P), E−(P), E*(P), E/(P), 
BK+(P), BK−(P), INC(P), DEC(P), DINC(P), and DDEC(P)

–

$+(P) Not supported by Basic model QCPU.

Data conversion instruction
BCD(P), DBCD(P), BIN(P), DBIN(P), INT(P), DINT(P), FLT(P), DFLT(P), 
DBL(P), WORD(P), GRY(P), DGRY(P), GBIN(P), DGBIN(P), NEG(P), 
DNEG(P), ENEG(P), BKBCD(P), and BKBIN(P)

–

Data transfer instruction MOV(P), DMOV(P), EMOV(P), $MOV(P), CML(P), DCML(P), BMOV(P), 
FMOV(P), XCH(P), DXCH(P), BXCH(P), and SWAP(P) –

Program branch instruction CJ, SCJ, JMP, and GOEND –

Other convenient instruction MTR Not supported by Basic model QCPU.
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● Application instructions

Category Symbol Restrictions

Logical operation instruction WAND(P), DAND(P), BKAND(P), WOR(P), DOR(P), BKOR(P), 
WXOR(P), DXOR(P), BKXOR(P), WXNR(P), DXNR(P), and BKNXR(P) –

Rotation instruction ROR(P), RCR(P), ROL(P), RCL(P), DROR(P), DRCR(P), DROL(P), and 
DRCL(P) –

Shift instruction SFR(P), SFL(P), BSFR(P), BSFL(P), DSFR(P), and DSFL(P) –

Bit processing instruction BSET(P), BRST(P), TEST(P), DTEST(P), and BKRST(P) –

Data processing instruction

SER(P), DSER(P), SUM(P), DSUM(P), DECO(P), ENCO(P), SEG(P), 
DIS(P), UNI(P), NDIS(P), NUNI(P), WTOB(P), BTOW(P), MAX(P), 
MIN(P), DMAX(P), DMIN(P), SORT, DSORT, WSUM(P), and 
DWSUM(P)

The SORT and DSORT instructions 
are executed in one scan.

Structured instruction
FOR, NEXT, BREAK(P), CALL(P), RET, FCALL(P), and XCALL –

ECALL(P) and EFCALL(P) –

Data table operation 
instruction FIFW(P), FIFR(P), FPOP(P), FINS(P), and FDEL(P) –

Buffer memory access 
instruction FROM(P), DFRO(P), TO(P), and DTO(P) –

String processing instruction

STR(P), DSTR(P), VAL(P), DVAL(P), ESTR(P), and EVAL(P) –

BINDA(P), DBINDA(P), BINHA(P), DBINHA(P), BCDDA(P), 
DBCDDA(P), DABIN(P), DDABIN(P), HABIN(P), DHABIN(P), 
DABCD(P), DDABCD(P), LEN(P), ASC(P), HEX(P), RIGHT(P), 
LEFT(P), MIDR(P), MIDW(P), INSTR(P), EMOD(P), and EREXP(P)

Not supported by Basic model QCPU.

Special function instruction

SIN(P), COS(P), TAN(P), RAD(P), DEG(P), SQR(P), EXP(P), LOG(P), 
RND(P), and SRND(P) –

ASIN(P), ACOS(P), ATAN(P), BSQR(P), BDSQR(P), BSIN(P), 
BCOS(P), BTAN(P), BASIN(P), BACOS(P), and BATAN(P) Not supported by Basic model QCPU.

Data control instruction LIMIT(P), DLIMIT(P), BAND(P), DBAND(P), ZONE(P), and DZONE(P) –

Switch instruction RSET(P) and QDRSET(P)
The QDRSET(P) instruction is not 
supported by Basic model QCPU/
LCPU.

Clock instruction DATERD(P), DATE+(P), DATE−(P), SECOND(P), and HOUR(P) The DATERD(P) instruction reads the 
personal computer clock data.

Program control instruction PSTOP(P), POFF(P), and PSCAN(P) Not supported by Basic model QCPU.

Display instruction LEDR –

Process control instruction

S.IN, S.OUT1, S.PID, S.PHPL, S.LLAG, S.I, S.D, S.DED, S.FG, S.IFG, 
S.FLT, S.ENG, S.IENG, S.ABS, S.OUT2, S.MOUT, S.R, S.PIDP, S.SPI, 
S.IPD, S.BPI, S.HS, S.LS, S.MID, S.AVE, S.LIMT, S.VLMT1, S.VLMT2, 
S.ONF2, S.ONF3, S.DBND, S.PGS, S.SEL, S.BUMP, S.AMR, S.SUM, 
S.TPC, S.ADD, S.SUB, S.MUL, S.DIV, S.SQR, S.>, S.<, S.=, S.>=, 
S.<=, S.DUTY, S.BC, S.2PID, S.PSUM, S.AT1

Supported by Process CPU and 
Redundant CPU only.*1

Other instruction DUTY, ZRRDB(P), ZRWRB(P), ADRSET(P), ZPUSH(P), ZPOP(P), 
TIMCHK, WDT(P), TRACE, TRACER, and RBMOV(P)

• The RBMOV instruction operates as 
the BMOV instruction.

• The TRACE, TRACER, and 
RBMOV(P) are not supported by 
Basic model QCPU.

• The RBMOV(P) instruction is not 
supported by LCPU.

*1 : When the program is written to the programmable controller CPU other than Process CPU and Redundant CPU, a stop error occurs on 
the CPU from INSTRCT.CODE ERR (error code 4002).
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● SFC control instructions

● Multiple CPU dedicated instructions

Category Symbol Restrictions

Step operation status check 
instruction

LD, LDI, AND, ANI, OR, ORI
–

Block operation status check 
instruction –

Active step batch readout 
instruction MOV(P), DMOV(P), BMOV(P) –

Block START instruction SET –

Block END instruction RST –

Block STOP instruction PAUSE –

Block restart instruction START –

Step START instruction SET –

Step END instruction RST –

Category Symbol Restrictions

CPU shared memory access 
instruction FROM(P), DFRO(P), S(P), TO, TO(P), and DTO(P) Not supported by LCPU.
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■ FXCPU

For details of the instructions, refer to the following manual.
FXCPU Structured Programming Manual [Basic & Applied Instruction]

● Sequence instructions

● Application instructions
: Supported, –: Not supported

Category Symbol Restrictions

Contact instruction LD, LDI, AND, ANI, OR, ORI, LDP, LDF, ANDP, ANDF, ORP, and ORF –

Bond instruction
ANB, ORB, MPS, MPP, and INV –

MEP and MEF –

Output instruction OUT, SET, RST, PLS, and PLF –

Master control instruction MC and MCR –

Step ladder instruction STL and RET –

Other instruction END and NOP –

Category Symbol 32-bit instruction Pulse instruction execution

Program flow

CJ – 

CALL – 

SRET – –

FEND – –

FOR – –

NEXT – –

Move and compare

CMP  

ZCP  

MOV  

SMOV – 

CML  

BMOV – 

FMOV  

XCH  

BCD  

BIN  

Arithmetic and logical operation

ADD  

SUB  

MUL  

DIV  

INC  

DEC  

WAND  

WOR  

WXOR  

NEG  
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Rotation and shift operation

ROR  

ROL  

RCR  

RCL  

SFTR – 

SFTL – 

WSFR – 

WSFL – 

SFWR – 

SFRD – 

Data operation

ZRST – 

DECO – 

ENCO – 

SUM  

BON  

MEAN  

ANS – –

ANR – 

SQR  

FLT  

Handy instruction

IST – –

SER  

ABSD  –

INCD – –

TTMR – –

STMR – –

ALT – –

RAMP – –

SORT – –

External FX I/O device

ASC – –

FROM  

TO  

External Device (optional device)
ASCI – 

HEX – 

Data transfer 2
ZPUSH – 

ZPOP – 

Category Symbol 32-bit instruction Pulse instruction execution
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Floating point

ECMP  

EZCP  

EMOV  

ESTR  

EVAL  

EBCD  

EBIN  

EADD  

ESUB  

EMUL  

EDIV  

EXP  

LOGE  

LOG10  

ESQR  

ENEG  

INT  

SIN  

COS  

TAN  

ASIN  

ACOS  

ATAN  

RAD  

DEG  

WSUM  

WTOB – 

BTOW – 

UNI – 

DIS – 

SWAP  

Real time clock control

TCMP – 

TZCP – 

TADD – 

TSUB – 

HTOS  

STOH  

TRD – 

HOUR  –

External device
GRY  

GBIN  

Block data operation

BK+  

BK-  

BKCMP=  

BKCMP>  

BKCMP<  

BKCMP<>  

BKCMP<=  

BKCMP>=  

Category Symbol 32-bit instruction Pulse instruction execution
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Character string control

STR  

VAL  

$+ – 

LEN – 

RIGHT – 

LEFT – 

MIDR – 

MIDW – 

INSTR – 

$MOV – 

Data operation 3

FDEL – 

FINS – 

POP – 

SFR – 

SFL – 

Data comparison

LD=  –

LD>  –

LD<  –

LD<>  –

LD<=  –

LD>=  –

AND=  –

AND>  –

AND<  –

AND<>  –

AND<=  –

AND>=  –

OR=  –

OR>  –

OR<  –

OR<>  –

OR<=  –

OR>=  –

Data table operation

LIMIT  

BAND  

ZONE  

DABIN  

BINDA  

Data transfer 3
RBFM – –

WBFM – –

Category Symbol 32-bit instruction Pulse instruction execution
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Appendix 2.4 Enable/disable setting of parameter items

Some parameter setting items of GX Works2 are not applicable to the simulation function.
The following table shows the parameter setting items applicable to the simulation function.
The remote password is not supported.

■ QCPU (Q mode)/LCPU

● PLC parameter setting applicability
: Applicable ×: Not applicable

Parameter Item Applicability

PLC Name
Label ×

Comment ×

PLC System

Timer Limit Setting 

RUN-PAUSE Contacts 

Latch Data Backup Operation Valid Contact ×

Remote Reset Fixed to 'Allow'

Output Mode at STOP to RUN 

Floating Point Arithmetic Processing

Fixed to 'Perform 
internal arithmetic 

operations in double 
precision*1

Intelligent Function Module Setting (Interrupt Pointer Setting) ×

Module Synchronization ×

Built-in CC-Link Setting ×

Common Pointer No. 

Points Occupied by Empty Slot 

System Interrupt Settings ×

High Speed Interrupt Settings ×

Interrupt Program/Fixed Scan Program Setting ×

A-PLC Compatibility Setting ×

Service Processing Setting
Fixed to 'Execute it while 
waiting for contact scan 

setting'

PLC Module Change Setting ×

PLC File

File Register 

Transfer to Standard ROM at Latch data backup operation ×

Comment File Used in a Command 

Initial Device Value 

File for Local Device 

File used for SP.DEVST/S.DEVLD Instruction ×

PLC RAS

WDT (Watchdog Timer) Setting

WDT error occurs if 
30,000,000 or more 

instructions are 
executed during one 

scan.

Error Check ×

Operating Mode When There is an Error *2

Constant Scanning 

Error History 

Low Speed Program Execution Time ×

Module Error History Collection ×
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Boot File
Boot Option ×

Boot File Setting ×

Program Program *3

SFC

SFC Program Start Mode 

Start Conditions 

Output Mode When the Block is Stopped 

Device

Device Points 

Latch Start/End (possible to clear with latch clear) ×

Latch Start/End (disabled to clear with latch clear) ×

Local Device Start/End 

Extended Device Latch Start/End (possible to clear with latch clear) ×

Extended Device Latch Start/End (disabled to clear with latch clear) ×

I/O Assignment Setting

I/O Assignment *4

Base Setting *5

Switch Setting ×

Detailed Setting

Error Time Output Mode ×

PLC Operation Mode at H/W Error ×

I/O Response Time ×

Control PLC ×

Multiple CPU Setting

No. of PLC 

Host Station ×

Operation Mode ×

Multiple CPU Synchronous Startup Setting ×

Online Module Change ×

I/O Sharing When Using Multiple CPUs ×

Communication Area Setting (Refresh Setting) ×

Multiple CPU High Speed Transmission Area Setting 

Auto Refresh Setting ×

Built-in Ethernet Port Setting

IP Address Setting ×

Communication Data Code ×

Open Setting ×

FTP Setting ×

Time Setting ×

Built-in I/O Function Setting

Positioning ×

High-speed Counter ×

Input Signal ×

Output Signal ×

Serial Communication

Transmission Speed ×

Sum Check ×

Transmission Wait Time ×

Online Change ×

Acknowledge XY Assignment ×

*1 : Internal operations are performed with double precision. However, the processing speed does not change.
*2 : Supports "Computation Error" and "Intelligent Module Program Execution Error".
*3 : There are restrictions for "Low Speed" and "Fixed Scan" type programs. (Appendix 2.5)
*4 : Not supported by the "Branch Module" setting for LCPU.
*5 : Slots are assigned with a maximum number of slots when "Auto" is selected for "Base Mode".

Parameter Item Applicability
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● Network parameter setting applicability
: Applicable ×: Not applicable

■ FXCPU

● PLC parameter setting applicability
: Applicable ×: Not applicable

Parameter Item Applicability

Network Parameter
Ethernet/CC IE/MELSECNET ×

CC-Link ×

Parameter Item Applicability

Memory Capacity

Memory Capacity 

Comments Capacity 

File Register Capacity 

Program Capacity 

Special Function Memory Capacity 

Device Device 

PLC Name Title ×

PLC System (1)

Battery Less Mode ×

MODEM Initialized ×

RUN Terminal Input ×

PLC System (2)

Channel Setting ×

Operate Communication Setting ×

Protocol ×

Data Length ×

Parity ×

Stop Bit ×

Transmission Speed ×

Header ×

Terminator ×

Control Line ×

H/W Type ×

Control Mode ×

Sum Check ×

Transmission Control Procedure ×

Station Number Setting ×

Time Out Judge Time ×

Special Function Block
(Built-in CC-Link/LT Setting)

Unit Name ×

Address ×

Value ×

Size/Type ×

Check the identification code before initializing ×

Identification Code ×

Transmission Speed ×

Point Mode ×

Station Type ×

I/O Points ×

Specify Reserved Station ×
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● Network parameter setting applicability
: Applicable ×: Not applicable

Positioning

Bias Speed [Hz] ×

Max. Speed [Hz] ×

Creep Speed [Hz] ×

Zero Return Speed [Hz] ×

Acceleration Time [ms] ×

Deceleration Time [ms] ×

Interruption Input of DVIT Instruction ×

Rotation Direction Signal ×

Head Address ×

Positioning Instruction ×

Pulse [pls] ×

Frequency [Hz] ×

Positioning table settings will not be initialized when the PLC is 
powered ON ×

Ethernet Port Setting

Channel ×

IP Address Setting ×

Communication Data Code ×

Disable direct connection to MELSOFT ×

Do not respond to search for CPU on network ×

Open Setting ×

Time Setting ×

Log Record Setting ×

Parameter Item Applicability

Parameter Item Applicability

Network Parameter CC-Link ×
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Appendix 2.5 Restrictions and considerations

This section explains the restrictions and considerations on debugging programs using the simulation 
function.

● QCPU (Q mode)/LCPU

No. Item Debugging using the simulation function

1 Time processing Time processing of the timer instruction/function is performed by assuming that the scan time is 100ms.
If the constant scan time is set in parameter, the set constant scan time is used as the scan time.

2 Supported instructions Some instructions including the data refresh instruction are not supported by the simulation function. 
Unsupported instructions are processed as NOP. (Supported instructions Appendix 2.3)

3 Process control instructions

NSTRCT. CODE ERR (error code 4004) occurs when a device which cannot be used for instruction 
argument is specified.
For programmable controller CPU, this error occurs at the timing of CPU power ON/reset, switching 
from STOP to RUN, or instruction execution. For the simulation function, however, this error occurs 
only at the timing of instruction execution. Therefore, the error will not occur for the simulation function 
if the instruction with an inapplicable device is not executed, however, when that program is written to 
the programmable controller CPU, an error occurs even if the instruction is not executed.

4 Processing time

The time set for constant scan is used for updating the timer current value.

In the virtual programmable controller, the number of counts per scan of the timer instruction changes 
depending on the constant scan setting. When the constant scan time is set to 100ms, the count of the 
100ms timer is +1 per scan. The count of the same timer is +3 per scan when the constant scan time is 
set to 300ms.

5 Monitoring

• If [Local device not executed] is selected in the GX Works2 local device monitoring, the simulation 
function monitors the devices of the program executed at the end of each scan.
However, the function may monitor the devices of the low-speed execution type or fixed scan 
execution type programs processed at the end of each scan if these types of program are included in 
the programs for simulation.
For details, refer to 5 and 6 in this table.

• If a program for local device monitoring is specified in the GX Works2 local device monitoring, the 
simulation function monitors the local devices in the specified program regardless of the existence of 
a scan execution type program.

Scan1Scan1Scan1Scan1T0=1 Scan1Scan1Scan1T0=2 Scan1Scan1Scan1T0=3 Scan1Scan1Scan1T0=4 Scan1Scan1Scan1T0=5

Scan1Scan1Scan1Scan1T0=3 Scan1Scan1Scan1T0=6 Scan1Scan1Scan1T0=9 Scan1Scan1Scan1T0=12 Scan1Scan1Scan1T0=15

SM400

T0
K10

100ms

300ms

Constant scan Scan 1 Scan 2 Scan 3 Scan 5Scan 4
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6 Operation of low-speed 
execution type programs

In the virtual programmable controller, one low-speed execution type program is always executed after 
the execution of scan execution type programs. This execution is not affected by the constant scan 
time and the program execution time set for low-speed execution type programs.
The following shows the operation procedure of programs. (The procedure does not change in step 
operation.)

All scan execution type programs are executed in each scan, whereas one low-speed execution type 
program is executed. Therefore, when N number of low-speed execution type programs are set, the 
execution of all programs completes in N scans.

• Since a low-speed execution type program is always executed within one scan in the virtual 
programmable controller, the monitor value of SM510 remains OFF

7 Operation of fixed scan 
execution type programs

The simulation function measures the time at the end of scan execution type and low-speed execution 
type programs and judges whether to execute fixed scan execution type programs. The following 
shows the processing timing of the simulation function when the scan time is set to 100ms and the 
timing of fixed scan execution type programs is set to 200ms.

8 Automatic write at the start of 
simulation

At the start of simulation, PLC parameters and programs registered in the program setting of PLC 
parameter are written to the virtual programmable controller.
The file register specified in "Use the following file" on the <<PLC File>> tab of PLC parameter is 
automatically created.

9 Interrupt programs Not supported by the simulation function.
Even created, an interrupt program is not processed.

No. Item Debugging using the simulation function

Low-speed execution type i

Scan execution type 2

Scan execution type N

Initial execution type

(Assume that one scan takes 100ms, then five 

scans takes 500ms. Changing reference time 

is possible by changing the constant scan 

setting value. (Refer to No. 3.))

Scan execution type 1

Scan execution type

program

Low-speed execution 

type program A

Low-speed execution 

type program B

Scan 1 Scan 2 Scan 3 Scan 4

Scan execution 

type program

Low-speed execution 

type program

Fixed scan execution 

type program A 

(200ms cycle)

100ms

elapsed  

from 

reference 

time

200ms

elapsed  

from 

reference 

time

300ms

elapsed  

from 

reference 

time

400ms

elapsed  

from 

reference 

time

Fixed scan execution 

type program B

(200ms cycle)

Reference END 

processing

END 

processing

END 

processing

END 

processing



App - 54

GX Works2

  APPENDIX

Appendix 2.5  Restrictions and considerations

10 Floating point numbers
Since a rounding error always occurs in the operation result of an instruction using floating point 
numbers, the result does not match with the result of the operation executed on the programmable 
controller CPU.

11 Using memory card

The simulation is performed in the following capacity according to the programmable controller type.

For LCPU, a memory card cannot be used.

12 I/O module Not supported by the simulation function.

13 Network Not supported by the simulation function.

14 Intelligent function module 
(Intelligent parameters)

The virtual programmable controller has a buffer memory area of 64k points for 64 modules to be used 
for accessing intelligent function modules. This buffer memory can be used for saving and reading 
data.
To use intelligent function modules in the simulation function, the I/O assignment must be set on the 
<<I/O Assignment>> tab of PLC parameter.

15
Double-precision operation for 
the floating-point arithmetic 
processing

The double-precision operation of the simulation function performs the internal operation with double 
precision and converts the final result to the single precision.
The processing speed is not changed even if the double-precision operation is set not to be performed 
on the <<PLC System>> tab of PLC parameter.

16 Clock data Clock data can be read out to SD210-SD213 by the clock data read request (SM213).
However, the set clock function is not supported.

17 Intelligent function module

Buffer memory for the intelligent function module is stored with the setting on the <<I/O Assignment>> 
tab of PLC parameter. Buffer memory (U\G) cannot be accessed when the I/O assignment setting 
is not set.
Select 'Intelligent' as the module type and specify the point to create buffer memory in compliance with 
the specified points.
If the module type is not specified, it becomes an empty slot.
If the module type is specified but the point is not specified, the point of the specified module becomes 
equivalent to one specified for "Point Occupied by Empty Slot" on the <<PLC System>> tab of PLC 
parameter.

18 Watchdog timer When the program loops endlessly (when 30,000,000 or more instructions are executed during one 
scan), a WDT error may occur.

19 Operating status monitor

SD393, SD395, and SD396 are only supported.
: Supported ×: Not supported

No. Item Debugging using the simulation function

High Performance model QCPU : 2M
Universal model QCPU : 8M

Name/Description Device
Supported/

Not 
supported

Description

No. 1 CPU reset flag SM240 × Fixed to 'OFF'

No. 2 CPU reset flag SM241 × Fixed to 'OFF'

No. 3 CPU reset flag SM242 × Fixed to 'OFF'

No. 4 CPU reset flag SM243 × Fixed to 'OFF'

No. 1 CPU error flag SM244 × Fixed to 'OFF'

No. 2 CPU error flag SM245 × Fixed to 'OFF'

No. 3 CPU error flag SM246 × Fixed to 'OFF'

No. 4 CPU error flag SM247 × Fixed to 'OFF'

Multiple CPU system 
information

Number of multiple CPUs SD393 

CPU mounting 
information SD394 × Fixed to '0'

Multiple CPU number SD395  Fixed to '1'

No. 1 CPU operation 
status SD396 

No. 2 CPU operation 
status SD397 × Fixed to '0'

No. 3 CPU operation 
status SD398 × Fixed to '0'

No. 4 CPU operation 
status SD399 × Fixed to '0'
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20 Available drive volume

Difference of the drive volume may originate, for the file format is different from the actual 
programmable controller CPU. The following lists the available volume of each drive and the file size in 
the virtual programmable controller CPU.
• Available volume for users: Available space for users (free space after formatting)
• File size: Minimum size of one file
For details, refer to the User's Manual (Function Explanation, Program Fundamentals) of the CPU 
module to be used.
Since the available memory card is RAM only, memory card (ROM) on the drive 2 cannot be used.

21 Considerations for Online 
program change

At Online program change, fall instructions are executed regardless of options.
Secured steps for Online program change are 500 steps by default at the start up of the simulation 
function. Secured steps can be changed at "Allocate Memory for 'Online Change' (Write to PLC only)".

22 Program monitoring In ladder programs, line monitor is available even though the program written to the programmable 
controller CPU and one being edited are different.

23 Initial start for SFC programs
When 'Initial start' is selected for "SFC program start mode" and a set of operations 'STOP→Write to 
PLC→RUN' is performed, not 'Initial start' but 'Resume start' is adopted if programs written to the 
programmable controller CPU have no change.

24 Considerations for file batch 
online change

In the following cases, file batch online change cannot be performed.
• Program memory does not have free space larger than the program to be written.
• The maximum number of files has already been stored in program memory.

25 Operation error

Conditions of operation error occurrence is equal to ones with High Performance model QCPU.
(As 'D/ K-2147483648 K-1 D0' is operated, for example, an operation error does not occur with 
Universal model QCPU but occurs with High Performance model QCPU and virtual programmable 
controller CPU.)
Operation errors are No. 4100 at any time.

26 When "-0" is specified as the 
floating-point type real number No error occurs. (Processed as '0' in operation.)

27 Monitoring local devices

If [Local device not executed] is selected, the virtual programmable controller CPU monitors the 
devices of the program executed at the end of each scan.
However, it may monitor the devices of the low-speed execution type or fixed scan execution type 
programs processed at the end of each scan if these types of program are included in the programs for 
simulation. If a program for local device monitoring is specified in the local device monitor, the virtual 
programmable controller CPU monitors the local devices in the specified program regardless of the 
existence of a scan execution type program.

28 Assigning base units

Slots are assigned with a maximum number of slots when "Auto" is selected for "Base Mode" on the 
<<I/O Assignment>> tab of PLC parameter.
To avoid slots to be assigned with a maximum number of slots, select "Details" and set the number of 
slots.

*1 : The file size unit of program memory of Universal model QCPU/LCPU is 4 bytes (equal to Q26UDH).
*2 : The value shown at 'Standard ROM' of Basic model QCPU/High Performance QCPU is one after the writing to the ROM.

No. Item Debugging using the simulation function

–
Program 
memory*1

Memory 
card (RAM)

Standard 
RAM

Standard 
ROM*2

Drive 0 Drive 1 Drive 3 Drive 4

Basic model QCPU/
High Performance 

model QCPU

Available 
volume for 

users
1008k bytes 2034k bytes 256k bytes 1008k bytes

File size 2048 bytes 1024 bytes 1024 bytes 2048 bytes

Universal model 
QCPU (not equal to 

Q100UDEH)

Available 
volume for 

users
1040k bytes 8172k bytes 1280k bytes 4096k bytes

File size 512 bytes 4096 bytes 512 bytes 2048 bytes

Universal model 
QCPU (equal to 

Q100UDEH)

Available 
volume for 

users
4000k bytes 8172k bytes 1792k bytes 16384k bytes

File size 512 bytes 4096 bytes 512 bytes 2048 bytes

LCPU

Available 
volume for 

users
1040k bytes – 768k bytes 2048k bytes

File size 512 bytes – 512 bytes 2048 bytes
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● FXCPU

No. Item Debugging using the simulation function

1
Selection of programmable 
controller CPU and operation 
of FX series CPU

In the simulation function of FXCPU, the CPU-specific functions and device range operate according to 
the specifications of the selected FXCPU.
Application instructions can operate in the simulation function even they are not supported by the 
selected FXCPU.
Since a program may contain unsupported instructions after changing its programmable controller type 
from a top model to a low model, the program may cause a program error when it is written to the 
FXCPU even it can be performed in the simulation function.
For example, even the pulse execution type application instructions are not supported by FX0, FX0S, 
and FX0N they can be performed in the simulation function. However, a program error may occur due to 
the unsupported instructions when the program is written to the FXCPU.

2 Program check at STOP to 
RUN

The program check function at STOP to RUN detects a program error only when an MC/MCR exists in 
the STL instruction or the RET instruction is not input in response to the STL instruction. Note that other 
problems cannot be detected by the program check function at STOP to RUN, and check them in 
advance using the program check function of GX Works2.

3 Enable/disable setting of 
parameter items

Some parameter setting items of GX Works2 become disabled in the simulation function even they are 
set.

4 Program memory capacity The simulation function is performed with the maximum step capacity of each model.

5 Watchdog timer The watchdog timer (D8000) operates in 200ms with all CPUs. The setting value can be changed but 
the change is not applied to its operation.

6 Buffer memory monitor
In the simulation function, the buffer memory of a special extension device operates as a general 
register which can be read/written by the FROM/TO instruction. It does not have functions specific to 
the special extension device.

7 Variable analog potentiometer
The data register (D8030/D8031), which stores the value of the variable analog potentiometer built in 
FX0, FX0S, FX0N, FX1S, FX1N, and FX3G, operates as a general data register. Write a value between 0 
and 255 and test the operation using GX Works2.

8 High-speed counter The high-speed counter is not supported by the simulation function.

9 SORT/SORT2 instruction
The SORT/SORT2 instruction is executed over multiple scans on FXCPU. In the simulation function, 
however, its execution is always completed in one scan and M8029 (Instruction execution complete) 
turns ON immediately.

10 Latched type device A latched type device keeps holding its value when the simulation function is in STOP status.
It clears its value when the simulation function is ended.

11 Non-latch type device A non-latched type device clears its value when the simulation function is in STOP status or ended.

12 Clear PLC Memory
Execute the Clear PLC Memory function to clear and initialize user data written with the simulation 
function.
Execute it too when the operation of the simulation function is not stable.

13 Character string constant

Up to 16 characters can be processed as a character string constant in a program.
The 17th and later characters are ignored when the length of characters is 17 or more.
Example: $+ "12345678901234567" "abcdefghijklmnopq" D0
When the operation shown above is processed, the following data are stored in the devices starting 
from D0.
D0 to D15 = "1234567890123456abcdefghijklmnop"
(The 17th and later characters of each character string constant (“7” and “q”) are ignored.)

14 Write to PLC of device 
memory

The Write to PLC function does not support the device memory listed below.
• Input (X)
• Output (Y)
• Special relay (M8000 and later)
• Special register (D8000 and later)

15 Special Function Block Only the buffer memory of the special function block is supported by the simulation function.

Parameter Setting item

PLC Parameter

Memory Capacity All items are enabled

Device All items are enabled

PLC Name All items are disabled

PLC System (1) All items are disabled

PLC System (2) All items are disabled

Special Function Block All items are disabled

Positioning All items are disabled
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Appendix 3 ASCII Code Table

–

MSD

0 1 2 3 4 5 6 7

000 001 010 011 100 101 110 111

LSD

0 0000 NUL DLE (SP) 0 @ P ` p

1 0001 SOH DC1 ! 1 A Q a q

2 0010 STX DC2 " 2 B R b r

3 0011 ETX DC3 # 3 C S c s

4 0100 EOT DC4 $ 4 D T d t

5 0101 ENQ NAK % 5 E U e u

6 0110 ACK SYN & 6 F V f v

7 0111 BEL ETB ' 7 G W g w

8 1000 BS CAN ( 8 H X h x

9 1001 HT EM ) 9 I Y i y

A 1010 LF SUB * : J Z j z

B 1011 VT ESC + ; K [ k {

C 1100 FF FS , < L l |

D 1101 CR GS - = M ] m }

E 1110 SO RS . > N ^ n ~

F 1111 SI US / ? O _ o DEL

Remote HeadQ CPU L CPU FX
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Appendix 4 Considerations of GX Works2 and Differences with GX Developer

This section describes the considerations when using GX Works2 and the differences between GX 
Works2 and GX Developer.

Appendix 4.1 Before using GX Works2

Compared with GX Developer, GX Works2 has some differences in supported CPU modules, features, 
and operability. Please review the following considerations prior to use.
For (Intelligent) indicated in the Reference column, refer to the following manual.
GX Works2 Version 1 Operating Manual (Intelligent Function Module)

Remote HeadQ CPU L CPU FX

Item to be confirmed Reference

Supported CPU modules Appendix 4.2

Unsupported features Appendix 4.3

Supported project types
Appendix 4.4

Using project functions

Programming languages supported by each project type

Appendix 4.5

Using Ladder Diagram

Using Sequential Function Chart

Using labels

Using function blocks

Using device comments Appendix 4.6

Using device memory Appendix 4.7

Using device initial values Appendix 4.8

Using search/replace function Appendix 4.9

Using online function Appendix 4.10

Using monitor/debug function Appendix 4.11

Using printing function Appendix 4.12

Copying saved project data Appendix 4.13

Using change programmable controller type function Appendix 4.14

Using program check function Appendix 4.15

Using IC memory card function Appendix 4.16

Compatibility with GX Developer Appendix 4.17

Compatibility with GX IEC Developer Appendix 4.18

Compatibility with GX Configurator-QP (Intelligent)

Key operation Appendix 4.19

Program titles Appendix 4.20
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Appendix 4.2 Supported CPU modules

The following CPU modules are supported by GX Works2.

The following CPU modules are supported by starting GX Developer from GX Works2.
For details of using the following CPU modules, refer to Appendix 14.

Programmable controller series Programmable controller type

QCPU (Q mode)

Basic model QCPU
(Q00J, Q00, Q01)

High Performance model QCPU
(Q02, Q02H, Q06H, Q12H, Q25H)

Universal model QCPU
(Q00UJ, Q00U, Q01U, Q02U, Q03UD, Q03UDE, Q03UDV, Q04UDH, Q04UDEH, 
Q04UDV, Q06UDH, Q06UDEH, Q06UDV, Q10UDH, Q10UDEH, Q13UDH, 
Q13UDEH, Q13UDV, Q20UDH, Q20UDEH, Q26UDH, Q26UDEH, Q26UDV, 
Q50UDEH, Q100UDEH)

Remote I/O
(QJ72LP25, QJ72BR15)

Process CPU
(Q02PH, Q06PH, Q12PH, Q25PH)

Redundant CPU
(Q12PRH, Q25PRH)

LCPU L02S, L02, L02-P, L06, L26, L26-BT, L26-PBT, LJ72GF15-T2, LJ72MS15

FXCPU FX0, FX0S, FX0N, FX1, FXU, FX2C, FX1S, FX1N, FX1NC, FX2N, FX2NC, FX3G, 
FX3GC, FX3U, FX3UC

Programmable controller series Programmable controller type

QCPU (A mode) All programmable controller types

QSCPU All programmable controller types

QnACPU All programmable controller types

ACPU All programmable controller types

Motion controller (SCPU) All programmable controller types

CNC (M6, M7) All programmable controller types
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Appendix 4.3 Unsupported features

The following table shows the features that are not supported by GX Works2.
Use GX Developer, GX Simulator, or GX Configurator for the following features.

* In addition to the features mentioned above, the following features are not supported by FXCPU.
• Configuration function
• Sampling trace function

Unsupported feature Alternate S/W

Debug function for ladder program

Timing chart monitoring function

GX SimulatorSerial communication function

Device manager function

Intelligent function module 
programming function Protocol FB support GX Configurator-SC

Device initial value Device memory registration

GX Developer
Password Password registration for data in project

Interaction with GX Explorer Boot by GX Explorer

MEDOC print format import Import in MEDOC print format

Online Intelligent module diagnostics from system monitor GX Developer
GX Configurator

Sampling trace Sampling trace conditionally on step number GX Developer
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Appendix 4.4 Supported project types

The following table shows the supported project types in GX Works2.

■ Using project functions

Before using the project functions in GX Works2, please review the following considerations.

Project type Description

Simple project –

Without labels

This is the equivalent of the "Do not use label" project of GX Developer.
1) When a project created in the "Do not use label" of GX Developer is read with GX Works2, the 

project becomes the Simple project (without labels).
2) When a project created in the Simple project (without labels) of GX Works2 is read with GX 

Developer, the project becomes the "Do not use label" project.

With labels*1

*1 : Not supported by FX0, FX0S, FX0N, FXU, and FX2C.

This is the equivalent of the "Use label" project of GX Developer.*2

1) When a project created in the "Use label" of GX Developer is read with GX Works2, the 
project becomes the Simple project (with labels).

2) When a project created in the Simple project (with labels) of GX Works2 is read with GX 
Developer, the project becomes the "Use label" project.

*2 : "Use label" projects of GX Developer are not supported by FXCPU.

Structured project*3

*3 : Not supported by FX1.

In GX Works2, 'structured programming' is available. The structured programming proceeds while 
creating POUs and combining them (registering tasks in the program file).
The projects created in 'Structured project' of GX Works2 cannot be read with GX Developer.

Function
Description (differences between GX Developer and GX Works2)

GX Developer GX Works2

Protect projects
By installing as 'monitoring 
only', projects were protected 
on each personal computer.

By setting projects as 'read-only' with the 'Security' function, project-
by-project protection is now available.

Change project types
Project types cannot be 
changed from "Do not use 
label" to "Use label".

The following project type changes are now available.
1) Project type change from 'Simple project (without labels)' to 

'Simple project (with labels)'
2) Project type change from 'Simple project (with labels)' to 

'Structured project*1

Read GX Developer 
format projects –

Selecting [Project] ⇒ [Intelligent Function Module] ⇒ [Read GX 
Configurator-QP Data] enables GX Configurator-QP format data to 
be read out.
*GX Developer starts and a project is opened when a project of the 
following CPU types is specified: ACPU, QnACPU, QCPU (A mode), 
Motion Controller (SCPU), CNC (M6/M7), and Safety CPU.

Read GX 
Configurator-QP 
format projects*2

–
Selecting [Project] ⇒ [Intelligent Function Module] ⇒ [Read GX 
Configurator-QP Data] enables GX Configurator-QP format data to 
be read out.

Copy data in a project 
to different projects

It was enabled on the project 
copy dialog. Copy and paste is now available on the Navigation window.

*1 : Direct project type change from 'Simple project (without labels)' to 'Structured project' is not available.
*2 : Not supported by FXCPU.
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Appendix 4.5 Programming languages supported by each project 
type

The following table shows the programming languages that are supported by each project type of GX 
Works2.

The following programming languages are not supported by GX Works2.
Use GX Developer for the following programming languages.

Project type Supported programming language

Simple project –

Without labels Ladder Diagram, Sequential Function Chart (MELSAP3, MELSAP-L)*1, Sequential 
Function Chart (FXCPU)*2

With labels

Ladder Diagram, Sequential Function Chart (MELSAP3, MELSAP-L)*1, Structured Text*1

Structured project

Ladder Diagram*1, Sequential Function Chart (MELSAP3, MELSAP-L)*1, Structured 
Ladder/FBD, Structured Text

*1 : Not supported by FXCPU.
*2 : Not supported by QCPU (Q mode)/LCPU.

Supported program element

Label, structure, function block

Supported program element

Label, structure, function block, function, library

Unsupported programming 
language Description Alternate S/W

List

1) If GX Works2 reads out a program created with lists in GX 
Developer, it can be displayed or edited as a ladder program.

2) If GX Developer reads out a program created with ladder 
programs in GX Works2, it can be displayed or edited in list 
program.

GX Developer
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■ Using Ladder Diagram

Before using Ladder Diagram in GX Works2, please review the following considerations.

Function
Description (differences between GX Developer and GX Works2)

GX Developer GX Works2

Program giving devices 
an alias It was enabled by the 'Alias' function. Please use 'Label'.

Segment a part of 
program into POUs 
(macros)

It was enabled by the 'Macro definition/
import' function. Please use 'Function Block'.

Find/Replace instructions/
devices/labels

Find was enabled by directly typing an 
instruction/device/label in 'Read mode'.

Pressing the  key on the ladder editor allows the 
simple find.

The mode can be switched to "Read Mode" by setting the 
option.
Select "Use the Switching Ladder Edit Mode (Read, 
Write, Monitor, Monitor (Write))" under "Program Editor" 
⇒ "Ladder" ⇒ "Ladder Diagram" in the option setting.

Check use status of 
device/label

It was enabled by the 'Cross Reference 
List' function and 'List of Used Devices' 
function.

Please select [Find/Replace] ⇒ [Cross Reference], or 
[Find/Replace] ⇒ [Device List].

Select the range specified 
with the drag-and-drop 
operation

It was enabled by left-clicking the 
mouse while pressing the  key.

Selecting the frame of the target range enables the drag-
and-drop operation.

Select the range starting 
from the cursor specified 
by mouse under read 
status

It was enabled using the mouse while 
pressing the  key.

The range can be selected using only the mouse without 
pressing the  key.

Verify –

The verify result window clearly shows the following: 
'unmatched area of the programs', 'only verify source 
contains the program' and 'only verify destination contains 
the program'.

Register to Watch window –

Devices/labels in the ladder block at the cursor position 
are automatically registered to the Watch window.
To use this function, set "Setting for Automatic 
Registration to Watch Window" under "Monitor" ⇒ 
"Ladder" in the option setting.
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■ Using Sequential Function Chart

Before using Sequential Function Chart (MELSAP3), Sequential Function Chart (MELSAP-L), or 
Sequential Function Chart (FXCPU) in GX Works2, please review the following considerations.

Function
Description (differences between GX Developer and GX Works2)

GX Developer GX Works2

Change block number It was enabled by the 'copy and paste' 
function in block list.

Each block data is displayed on the Navigation window, 
and the block number can be changed in the property of 
each block data.
* Selecting [View] ⇒ [Open SFC Blocklist] can display the 
block list equivalent to that of GX Developer.

Open a start source block 
by block start No corresponding function. Selecting [View] ⇒ [Back to Start SFC Block] can open it.

Online change using SFC 
program No corresponding function. In SFC program, online change is possible in SFC block 

unit. Please execute from the menu of "Online Change".

Monitor during MELSAP-L 
display format

Device monitor was enabled by a split 
display.

Can monitor the device by registering to the Watch 
window.

Select the range specified 
with the drag-and-drop 
operation

It was enabled by left-clicking the 
mouse while pressing the  key.

Selecting the frame of the target range enables the drag-
and-drop operation.

Select the range starting 
from the cursor specified 
by mouse under read 
status

It was enabled using the mouse while 
pressing the  key.

The range can be selected using only the mouse without 
pressing the  key.

Open operation output/
transition condition 
programs

–

Multiple Zooms (operation output/transition condition 
data) can be simultaneously displayed.
* Changing the "Setting of Zoom Display" option can 
switch the display on a window in the same way as GX 
Developer.

Copy and paste Ladder 
programs in Zoom editor Ladder programs could not be pasted. Ladder programs can be pasted.

However, ladder block may not be displayed properly.
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■ Using labels

Before using labels in GX Works2, please review the following considerations.

■ Using function blocks

Before using function blocks in GX Works2, please review the following considerations.

Function
Description (differences between GX Developer and GX Works2)

GX Developer GX Works2

Check devices 
automatically assigned 
labels

It was enabled by the 'Show assigned 
device' function of label editor.

Please check on the ladder editor by selecting [View] ⇒ 
[Device Display].

Automatically assigned 
devices for input 
variables, output 
variables, and input/
output variables of 
function blocks

Devices are automatically assigned in 
the order that they are registered on 
the FB variable (FB label) setting 
window.

Labels registered on the Function/FB Label Setting 
screen are sorted in the order of 'VAR_INPUT', 
'VAR_IN_OUT', 'VAR_OUTPUT', 'VAR', and devices are 
automatically assigned.

Import/Export device 
comments to labels

It was enabled by the 'device comment 
import' function and 'device comment 
export' function.

Please use the copy and paste on the label editor and 
device comment editor.

Use pointer type labels Local pointers were assigned.

Common pointers are now assigned.
For projects with labels, points are set by default in 
"Common Pointer" in the "PLC Parameter" ⇒ "PLC 
System" setting.
(Points set by default differ vary according to the 
programmable controller type.)

Unusable reserved words 
for label name The definition of reserved words are different between GX Developer and GX Works2.

Function Description

Use function blocks created with Ladder 
Diagram

Function blocks created with ladder can be used for ladder program, 
Structured Ladder/FBD program, ST program, and SFC program operation 
outputs.
For FXCPU, they can be used for ladder programs only.

* When using function blocks created with Ladder Diagram for ladder, 
Structured Ladder/FBD or ST programs, select [Tool] ⇒ [Options], and 
select "Enable calling function block and using inline ST" under "Compile" ⇒ 
"Basic Setting".

Use function blocks created with Structured 
Ladder/FBD

Function blocks created with Structured Ladder/FBD can be used for ladder 
programs, Structured Ladder/FBD programs and ST programs.

* When using function blocks created with Structured Ladder/FBD for ladder 
programs, select [Tool] ⇒ [Options], and select "Enable calling function 
block and using inline ST" under "Compile" ⇒ "Basic Setting".

Use function blocks created with ST

Function blocks created with ST can be used for ladder programs, 
Structured Ladder/FBD programs, and ST programs.
For FXCPU, they can be used for Structured Ladder/FBD programs and ST 
programs.

* When using function blocks created with Structured Text for ladder 
programs, select [Tool] ⇒ [Options], and select "Enable calling function 
block and using inline ST" under "Compile" ⇒ "Basic Setting".

Set function block call option

When the VAR_IN_OUT input variable and output variable have different 
label/device, the input variable value is always equal to the output variable 
value.
This function is not supported by FXCPU.
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Appendix 4.6 Using device comments

Before using device comments in GX Works2, please review the following considerations.

Appendix 4.7 Using device memory

Before using the device memory in GX Works2, please review the following considerations.

Appendix 4.8 Using device initial values

Before using device initial values in GX Works2, please review the following considerations.

Function
Description (differences between GX Developer and GX Works2)

GX Developer GX Works2

Delete unused device 
comments

It was enabled by the 'Delete unused 
comments' function.

The Delete Unused Comment button is added on the 
Device List screen displayed by selecting [Find/Replace] 
⇒ [Device List].
(Select a program for "Find In" and the search operation 
needs to be performed in advance.)

Sample comment
Sample comments of special relay/
special register were provided in 
project format.

Comments of special relay/special register and intelligent 
function module can be imported by the 'Import from 
Sample Comment' function on the device comment editor.

Function Description

Device memory display

Multiple device ranges can be displayed on a window.

* By selecting "All Range" when entering a device, all the device range can be 
displayed on one window in the same way as that of GX Developer.

Copy and past device memory data to 
Excel

To copy and paste device memory data to Excel, please select [Tool] ⇒ [Read 
from Excel File] / [Write to Excel File].

Function
Description (differences between GX Developer and GX Works2)

GX Developer GX Works2

Maximum amount of 
device initial value data to 
be created

Only 1 data was able to be created. Up to 800 data can be created.

Restriction of device 
number

It was able to create within the range of 
maximum points for each 
programmable controller of devices.

It now can be created within the range of PLC parameter 
device setting.

PLC write/read
IC memory card write/
read

Only 1 data was able to be read and 
written. Selected multiple data can be read and written.
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Appendix 4.9 Using search/replace function

Before using the search/replace function in GX Works2, please review the following considerations.

Function
Description (differences between GX Developer and GX Works2)

GX Developer GX Works2

All Find The batch search function was not 
available. The batch search function is enabled by "All Find".

Specified Range 
Replacing

The replace function is enabled within 
a range of the specified step numbers.

The replace function is enabled within the selected range 
in a ladder program.

Find String
The following were the search targets:
1. Statements
2. Notes

The search targets are added as follows:
1. Statements
2. Notes
3. Device/Label names
4. Device/Label comments
5. Instruction names
6. Data types

Replace Device
Device Batch Replace

The following devices could not be 
specified for "Find Device" or "Replace 
Device":
devices with digit, index setting, or 
indirect specification.

The following devices can be specified for "Find Device" 
or "Replace Device":
devices with digit, index setting, or indirect specification. 
Note that, however, one of the specification needs to be a 
label.

Device Batch Replace

The device batch replace function is 
enabled by specifying a device for 
"Find Device" and a label for "Replace 
Device", and specifying two or more 
points for the number of points to be 
replaced.

1 is the only value that can be set for the number of points 
to be replaced when a label is specified for "Replace 
Device".
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Appendix 4.10 Using online function

Before using the online function in GX Works2, please review the following considerations.

Function
Description (differences between GX Developer and GX Works2)

GX Developer GX Works2

Connection destination 
setting

A project was able to contain only 1 
'transfer setup' information.

A project can contain multiple pieces of 'connection 
destination' information.
To change 'connection destination' information, select 
'Connection Destination' on the Navigation window.

Data write/read for 
intelligent function module

Data write/read was not able to be 
executed for CPU modules and 
intelligent function modules at once.

Selecting [Online] ⇒ [Write to PLC], allows simultaneous 
data write for CPU modules and intelligent function 
modules.
Selecting [Online] ⇒ [Read from PLC], allows 
simultaneous data read for CPU modules and intelligent 
function modules.

Flash ROM data write of 
CPU module

It was enabled by the 'PLC write (Flash 
ROM)' function.

The 'PLC write (Flash ROM)' function is now integrated in 
the 'Write to PLC' function.
Please select [Online] ⇒ [Write to PLC].

Remote Operation screen
PLC Diagnostics screen
System Monitor screen

–

Selecting [Online] ⇒ [Remote Operation] and 
[Diagnostics] ⇒ [System Monitor] / [PLC Diagnostics] can 
display the module image and the programmable 
controller CPU operation status is now easy to see.
The remote operation, memory operation, and clock setup 
can be started from the PLC Diagnostics screen.

System Monitor

As the system monitor function was not 
supported by LCPU, [Diagnostics] ⇒ 
[System Monitor] could not be 
selected.

The system monitor function has been supported by 
LCPU and the module image can be displayed by 
selecting [Diagnostics] ⇒ [System Monitor].

PLC Diagnostics
The continuation error information 
display function of "PLC Diagnostics" 
was not supported by LCPU.

Continuation error information can be displayed using the 
"PLC Diagnostics" function of LCPU.

Register/Cancel Display 
Module Menu

Registration /cancellation function of 
display module menus was not 
supported by LCPU.

Registration/cancellation function of display module 
menus has been supported by LCPU.
Select [Online] ⇒ [Register/Cancel Display Module 
Menu].

Read from PLC –

Symbolic information in GX Developer format does not 
include SFC programs.
Please read on the 'Simple project (without labels)'.

If symbolic information of GX Developer or GX IEC 
Developer is read out, the project becomes uncompiled.

The Read from PLC function in Simple projects (with 
labels) and Structured projects is supported by FXCPU of 
the following models only.
For FX3U/FX3UC (Version 3.00 or later)

GX Developer starts and a new project is created with 
data read from the programmable controller CPU when a 
programmable controller series of the following CPU 
types is specified: ACPU, QnACPU, QCPU (A mode), 
Motion Controller (SCPU), CNC (M6/M7), and Safety 
CPU.

Write to PLC –
Writing symbolic information to programmable controller 
CPU is supported by FXCPU of the following models only.
For FX3U/FX3UC (Version 3.00 or later)
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Appendix 4.11 Using monitor/debug function

Before using the monitor/debug function in GX Works2, please review the following considerations.

Appendix 4.12 Using printing function

Before using the printing function in GX Works2, please review the following considerations.

Function Description

Entry data monitor

The 'entry data monitor' function is now a dockable window as a 'watch' function so 
that it can be displayed without overlapping with the program editor.

Device/label is now enabled to be entered by dragging and dropping from the 
program editor and the ON/OFF status of bit device and current values of word 
device can be modified on the monitoring window.

Device batch monitoring
Buffer batch monitoring

The 'device batch monitor' and 'buffer memory batch monitor' functions are now 
integrated to realize the same operability.

ON/OFF status of bit device and current values of word device can be modified on 
the monitoring window.

Debug function*1

The debug function can be executed by starting the simulation function.

The break point setting and the break device setting functions become dockable 
windows, and they can be displayed without overlapping the program editor.

The debug function such as step execution can be executed from the debug 
function toolbar.

The STEP-RUN switch is not displayed on the GX Simulator2 screen. The 
operating status of the simulation switches to STEP-RUN automatically by 
executing the debug function from the debug function toolbar.

Monitor Condition Setting/Monitor Stop 
Condition Setting

The Monitor Stop Condition screen cannot be closed while setting the monitor stop 
condition.

The 'monitor stop condition' function cannot be performed when the monitoring 
function is not being executed.

The Monitor Condition Setting screen or the Monitor Stop Condition Setting screen 
cannot be opened when the following function is being performed or the screen is 
being opened.
• Online program change/program memory transfer
• Intelligent function module monitoring
• Program list monitoring
• Interrupt program list monitoring
• SFC all block batch monitoring
• The Modify Value screen
• The Forced Input Output Registration/Cancellation screen
• Sampling trace
• The CC-Link Diagnostics screen

The Monitor Condition Setting screen or the Monitor Stop Condition Setting screen 
cannot be opened in MELSAP-L.

*1 : Not supported by FXCPU.

Function Description

Additional information print such as 
statement and device comment

For the Print Window function, displayed image is subject to print/print window 
preview.
To print with additional information such as statement and device comment, please 
put the desired information on the screen and then select [Project] ⇒ [Print 
Window] / [Print Window Preview].
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Appendix 4.13 Copying saved project data

Before copying project data saved in GX Works2, please review the following considerations.

Appendix 4.14 Using PLC type change function

Before using the PLC type change function in GX Works2, please review the following considerations.

Appendix 4.15 Using program check function

Before using the program check function in GX Works2, please review the following considerations.

Appendix 4.16 Using IC memory card function

Before using the IC memory card function in GX Works2, please review the following considerations.

Function
Description (differences between GX Developer and GX Works2)

GX Developer GX Works2

Copy saved project data
Save project data was able to be 
copied by copying files under the 
project name folder.

Please copy all the workspace name folders and 
"workspacelist.xml" created in the same hierarchy as the 
workspace name folders.

* When only workspace name folders or project name 
folders are copied, it is enabled to open the project in the 
copy destination.
However, if saving after editing, the workspace name and 
the project name need to be specified again.

A project data can be copied by saving data as a single 
project with the "Save as a Single File Format Project" 
function on the Save As screen.

Function
Description (differences between GX Developer and GX Works2)

GX Developer GX Works2

Use PLC type change 
function

Intelligent function module data could 
not be transmitted.

Intelligent function module data can be transmitted in PLC 
type conversion of Q series PLC and L series PLC.

Function
Description (differences between GX Developer and GX Works2)

GX Developer GX Works2

Program check

Programs which follow the END 
instruction and do not affect sequence 
control were checked.

Programs which affect sequence control up to the END 
instruction are checked.
Programs which follow the END instruction and do not 
affect sequence control are not checked.

The duplicated coil error occurs when 
the same local label is used at two or 
more locations.

Since the same local label can be used at two or more 
locations when the function block is called with the same 
instance, the duplicated error does not occur.

Function
Description (differences between GX Developer and GX Works2)

GX Developer GX Works2

Read IC Memory Card Symbolic information could not be read. Symbolic information can be read.

Write IC Memory Card
Symbolic information could not be written. Symbolic information can be written.

Passwords could not be set for LCPU. Passwords can be set for LCPU.



Appendix 4  Considerations of GX Works2 and Differences with GX Developer

Appendix 4.17  Compatibility with GX Developer App - 71

17

O
P

E
R

A
TI

N
G

 
PR

O
G

R
A

M
M

AB
LE

 
C

O
N

TR
O

LL
E

R
 C

P
U

18

DI
AG

NO
SI

NG
 

PR
OG

RA
M

M
AB

LE
 

CO
NT

RO
LL

ER
 S

TA
TU

S

19

SI
M

U
LA

TI
N

G
 

O
PE

R
AT

IO
N

S 
O

F 
EX

TE
R

N
AL

 D
EV

IC
ES

20

P
R

IN
TI

N
G

21

S
E

TT
IN

G
 O

P
TI

O
N

S

22

U
S

IN
G

 L
IB

R
A

R
IE

S

A

A
PP

E
N

D
IX

I

IN
D

EX

Appendix 4.17 Compatibility with GX Developer

For the compatibility between GX Developer and GX Works2, please review the following 
considerations.
An error may occur at a compilation when a project which contains ST programs created in GX 
Developer is opened in GX Works2. For modifying instructions which cause a compilation error, refer to 
Appendix 19.

Function Description

Open other project

Before opening a GX Developer "Use label" project of which a program and 
function block have the same name, please change the data name in GX 
Developer.

Function names of Structured Text are different between GX Developer and GX 
Works2. Please compile and correct errors.
Alternatively, select "Use Dedicated Instruction for GX Developer, GX IEC 
Developer" under [Tool] ⇒ [Options] ⇒ "Project" ⇒ "Common Setting" ⇒ "Other 
Project Dedicated Instruction Setting".

For a program which contains a utilized FB, the compiled program is not identical 
with the program compiled with GX Developer.
To conform the compiled program to that compiled with GX Developer, select 
[Tool] ⇒ [Options] ⇒ "Compile" ⇒ "Basic Setting" and clear "Enable calling 
function block and using inline ST " in "Function Block Call".

For Q00UJ, Q00U, and Q01U projects, a compilation error may occur if the string 
type is used for the Boolean expression (conditional expression) in the conditional 
syntax or iteration syntax of the ST program.
When an error occurs, create a ladder program with a string comparison function 
block whose operation result is a Boolean value, and correct the program by using 
this operation result for the failed Boolean expression (conditional expression) in 
the conditional syntax or iteration syntax.

The setting of 'steps secured for Online program change' which is set on the [Read 
from PLC]/[Write to PLC] screen of GX Developer is not set.
Set the setting of 'steps secured for Online program change' on the [Read from 
PLC]/[Write to PLC] screen after performing the Open Other Project function in GX 
Works2.

Local labels of timer, counter, retentive timer, and pointer cannot be used for 
function blocks of ladder program to be utilized in an ST program.
Change local labels to global labels.

Before opening a project in which constants are set to the structures, delete the 
constants with GX Developer.

Export to GX Developer format file

Target projects are:
1) Simple project (without labels)

2) Compiled Simple project (with labels)*1
Note: Projects using labels in Sequential Function Chart are executed.

To execute, the following requirements must not be satisfied in the global label 
settings.
1) No device is set.
2) The lengths of label name exceeds 16 characters.
3) Label name contains a device name or reserved word.
4) An invalid character is used.
5) Data type that is not supported by GX Developer is used.
6) A value that is not constant is used in the constant.

Data registered to the global label is set as "Auto External" for all the local labels.

Projects which include inline structured text cannot be saved in GX Developer 
format.

Projects which include ladder programs whose function block calls function block 
cannot be saved in GX Developer format.

*1 : Not supported by FXCPU.
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Appendix 4.18 Compatibility with GX IEC Developer

For the compatibility between GX IEC Developer and GX Works2, please review the following 
considerations. Projects for FXCPU created with GX IEC Developer cannot be opened with GX 
Works2.

Appendix 4.19 Key operation

This section explains the differences of key operation between GX Developer and GX Works2.

Function Description

Open other project Function names of Structured Text are different between GX IEC Developer and 
GX Works2. Please compile and correct errors.

User library Before using GX IEC Developer user libraries with passwords enabled, please 
disable the passwords in GX IEC Developer.

Function Description
Shortcut key

GX Developer GX Works2

Edit
Read mode Change to the read mode. + +*1

Write mode Change to the write mode.  *1

Find/
Replace

Cross reference Display the cross reference. – +

Device List Display the device list. – +

Convert 
Block

Block conversion
(SFC block being edited)

Convert the SFC block being 
edited.  ++

View

Project data list Switch display/non-display of 
project data list. + –

Switch between project data list and 
window

Switch the project data list and each 
window. + –

Switch ladder program/list Switch the ladder/list screen. + –

Online

Monitor

Start Monitor (all 
windows)

Execute the program monitoring for 
all the opened programs. + –

Monitor (write mode) Change to the write mode during 
program monitoring. + +*1

Stop monitor (all windows) Stop the program monitoring for all 
the opened programs. ++ –

Debug

Device test Execute the device forced ON/OFF 
or the current value modification. + –

Skip execution Run selected sequence programs in 
skip execution. + –

Partial execution Run sequence programs partially. + –

Step run Run the programmable controller 
CPU in step run. + –

Remote operation Perform remote operations. + –

*1 : In GX Works2, select "Use the Switching Ladder Edit Mode (Read, Write, Monitor, Monitor (Write))" under "Program 
Editor" ⇒ "Ladder" ⇒ "Ladder Diagram" in the option setting to switch the read mode/write mode of the ladder editor and 
the SFC diagram editor.
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Appendix 4.20 Program titles

A title of data created under each execution type of Program Setting has the equivalent function to 
program titles of GX Developer. Titles can be set on the Property screen of each data.
The title being set is displayed on the Online Data Operation screen and written to/read from 
programmable controller CPU along with the program.
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Appendix 5 Compatibility with Projects Created with Existing Applications

This section explains the compatibility of GX Works2 projects with projects created with existing 
applications.

Appendix 5.1 Application compatibility

■ Reading projects created with existing application to GX Works2

● Reading projects created with GX Developer and IEC Developer
The following table shows the applicability of reading project files created with existing applications to 
GX Works2.
Projects and data created with the CPU types or programming languages not supported by GX 
Works2 cannot be read.
When ST programs created with GX Developer are read to GX Works2, they are opened as 
Structured projects with Version 1.08J or earlier and opened as Simple projects with Version 1.12N 
or later.
(For the method for reading projects created with existing applications, refer to the following section. 
Section 4.7)
● GX Developer

: Applicable
: Applicable with restrictions

Remote HeadQ CPU L CPU FX

Programmable controller type Application Reading 
applicability

Basic model QCPU
High Performance model QCPU, Q12PH, Q25PH GX Developer Version 8.00A or later *1

Q02PH, Q06PH GX Developer Version 8.68W or later *1

Q12PRH, Q25PRH GX Developer Version 8.17T or later *1

Q03UD, Q04UDH, and Q06UDH GX Developer Version 8.45X or later *1

Q02U GX Developer Version 8.48A or later *1

Q13UDH and Q26UDH GX Developer Version 8.62Q or later *1

Q03UDE, Q04UDEH, Q06UDEH, Q13UDEH, and 
Q26UDEH GX Developer Version 8.68W or later *1

Q00UJ, Q00U, Q01U, Q10UDH, Q10UDEH, 
Q20UDH, and Q20UDEH GX Developer Version 8.76E or later *1

L02, L26-BT GX Developer Version 8.88S or later *1

FX3U and FX3UC GX Developer Version 8.25B or later 

FX3G GX Developer Version 8.72A or later 

FX0, FX0S, FX0N, FX1, FXU, FX2C, FX1S, FX1N, 
FX1NC, FX2N, and FX2NC

GX Developer Version 8.00A or later 

*1 : When MELSAP-L format SFC programs are read with Version 1.24A or earlier, they are opened in the MELSAP3 
format.
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● GX IEC Developer
: Applicable

● Reading projects created with GX Configurator
GX Configurator flash ROM setting saved files (*.UMD) cannot be read in GX Works2.
To use GX Configurator flash ROM setting saved files in GX Works2, write the data to the intelligent 
function module with GX Configurator, and then read the data using GX Works2.
(Reading intelligent function module data Section 12.1.4)

Programmable controller type Application Reading 
applicability

Basic model QCPU
High Performance model QCPU, Q12PH, Q25PH GX IEC Developer Version 7.00A or later 

Q03UD, Q04UDH, and Q06UDH GX IEC Developer Version 7.03D 

Q02U GX IEC Developer Version 7.03D 

Q13UDH and Q26UDH GX IEC Developer Version 7.03D 

Q03UDE, Q04UDEH, Q06UDEH, Q13UDEH, and 
Q26UDEH GX IEC Developer Version 7.03D 
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■ Reading projects created with GX Works2 to existing applications

● Reading projects using GX Developer and IEC Developer
Projects created with GX Works2 can be read to GX Developer by saving them using "Export to GX 
Developer Format File". (Section 4.7)
Reading projects to GX IEC Developer or non-Windows applications such as GPPQ is not possible.

When reading projects with GX Developer, application versions that can read projects differ 
according to the programmable controller type of the project. The following table shows the relation 
between the programmable controller types of project and the read-applicable versions.

: Applicable
: Applicable with restrictions

● Reading projects using GX Configurator
As projects cannot be saved in formats such as the GX Configurator-QP format and the GX 
Configurator flash ROM setting saved file format (*.UMD) in GX Works2, data set in GX Works2 
cannot be read using GX Configurator.
To use GX Works2 data in GX Configurator, write the data to the intelligent function module with GX 
Works2, and then read the data using GX Configurator.
(Writing intelligent function module data Section 12.1.4)

Programmable controller type Application Reading 
applicability

Basic model QCPU
High Performance model QCPU, Q12PH, Q25PH GX Developer Version 8.00A or later *1

Q02PH, Q06PH GX Developer Version 8.68W or later *1

Q12PRH, Q25PRH GX Developer Version 8.17T or later *1

Q03UD, Q04UDH, and Q06UDH GX Developer Version 8.45X or later *1

Q02U GX Developer Version 8.48A or later *1

Q13UDH and Q26UDH GX Developer Version 8.62Q or later *1

Q03UDE, Q04UDEH, Q06UDEH, Q13UDEH, and 
Q26UDEH GX Developer Version 8.68W or later *1

Q00UJ, Q00U, Q01U, Q10UDH, Q10UDEH, 
Q20UDH, and Q20UDEH GX Developer Version 8.76E or later *1

L02, L26-BT GX Developer Version 8.88S or later *1

FX3U and FX3UC GX Developer Version 8.25B or later 

FX3G GX Developer Version 8.72A or later 

FX0, FX0S, FX0N, FX1, FXU, FX2C, FX1S, FX1N, 
FX1NC, FX2N, and FX2NC

GX Developer Version 8.00A or later 

*1 : For the restrictions in reading, refer to "SWD5C-GPPW Compatibility" of the GX Developer Operating Manual.
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Appendix 6 Compatibility of Data Read from Programmable Controller CPU

This section explains the compatibility between the data written on the programmable controller CPU 
using GX Developer or GX IEC Developer and the data read using GX Works2.

Appendix 6.1 Application compatibility

■ Reading data written on the programmable controller CPU using existing 
applications to GX Works2

The following table shows the applicability of reading data written on the programmable controller CPU 
using existing applications to GX Works2.
Data created with the CPU types or programming languages not supported by GX Works2 cannot be 
read.
● GX Developer

: Applicable
: Applicable with restrictions

Remote HeadQ CPU L CPU FX

Programmable controller type Application Reading 
applicability

Basic model QCPU
High Performance model QCPU, Q12PH, Q25PH GX Developer Version 8.00A or later *1

Q02PH, Q06PH GX Developer Version 8.68W or later *1

Q12PRH, Q25PRH GX Developer Version 8.17T or later *1

Q03UD, Q04UDH, and Q06UDH GX Developer Version 8.45X or later *1

Q02U GX Developer Version 8.48A or later *1

Q13UDH and Q26UDH GX Developer Version 8.62Q or later *1

Q03UDE, Q04UDEH, Q06UDEH, Q13UDEH, and 
Q26UDEH GX Developer Version 8.68W or later *1

Q00UJ, Q00U, Q01U, Q10UDH, Q10UDEH, 
Q20UDH, and Q20UDEH GX Developer Version 8.48A or later *1

L02, L26-BT GX Developer Version 8.88S or later *1

FX3U and FX3UC GX Developer Version 8.25B or later 

FX3G GX Developer Version 8.72A or later 

FX1S, FX1N, FX1NC GX Developer Version 6.00A or later 

FX0, FX0S, FX0N, FX1, FXU, FX2C, FX2N, and FX2NC GX Developer Version 2.00A or later 

*1 : When MELSAP-L format SFC programs are read with Version 1.24A or earlier, they are opened in the MELSAP3 
format.



App - 78

GX Works2

  APPENDIX

Appendix 6.1  Application compatibility

● GX IEC Developer
: Applicable

Programmable controller type Application Reading 
applicability

Basic model QCPU
High Performance model QCPU, Q12PH, Q25PH GX IEC Developer Version 7.00A or later 

Q03UD, Q04UDH, and Q06UDH GX IEC Developer Version 7.03D 

Q02U GX IEC Developer Version 7.03D 

Q13UDH and Q26UDH GX IEC Developer Version 7.03D 

Q03UDE, Q04UDEH, Q06UDEH, Q13UDEH, and 
Q26UDEH GX IEC Developer Version 7.03D 
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■ Reading data written on the programmable controller CPU using GX Works2 
to existing applications

The following table shows the applicability of reading data written on the programmable controller CPU 
using GX Works2 to existing applications.
Data created with the CPU types or programming languages not supported by existing applications 
cannot be read.
● GX Developer

: Applicable with restrictions

Programmable controller type Application Reading 
applicability

Basic model QCPU
High Performance model QCPU, Q12PH, Q25PH GX Developer Version 8.00A or later *1, *2, *3

Q02PH, Q06PH GX Developer Version 8.68W or later *1, *2, *3

Q12PRH, Q25PRH GX Developer Version 8.17T or later *1, *2, *3

Q03UD, Q04UDH, and Q06UDH GX Developer Version 8.45X or later *1, *2, *3

Q02U GX Developer Version 8.48A or later *1, *2, *3

Q13UDH and Q26UDH GX Developer Version 8.62Q or later *1, *2, *3

Q03UDE, Q04UDEH, Q06UDEH, Q13UDEH, and 
Q26UDEH GX Developer Version 8.68W or later *1, *2, *3

Q00UJ, Q00U, Q01U, Q10UDH, Q10UDEH, 
Q20UDH, and Q20UDEH GX Developer Version 8.48A or later *1, *2, *3

L02, L26-BT GX Developer Version 8.88S or later *1, *2, *3

FX3U and FX3UC GX Developer Version 8.25B or later *1, *4

FX3G GX Developer Version 8.72A or later *1

FX1S, FX1N, FX1NC GX Developer Version 6.00A or later *1

FX0, FX0S, FX0N, FX1, FXU, FX2C, FX2N, and FX2NC GX Developer Version 2.00A or later *1

*1 : Only execution programs can be read when programs written in Simple project (with labels) or Structured project are 
read from the programmable controller CPU.
They can be displayed/edited in ladder program or list.

*2 : Programs cannot be read to GX Developer Version 8.03D or later if projects are opened with the setting of "Use 
label". To enable reading of programs to GX Developer Version 8.03D or later, create projects without the "Use 
label" setting.

*3 : When Structured Ladder/FBD or ST programs are read from a programmable controller CPU using existing 
applications, there may be cases where ladder programs cannot be restored. Be sure to check the programs after 
they have been read from the programmable controller CPU using existing applications.
When programs are read from a programmable controller CPU using GX Developer, ladder blocks which cannot be 
displayed as ladder programs are displayed in yellow.

*4 : When a project in which a block password with the validated setting for "Read-protect the execution program" exists 
is written, the execution program cannot be read.
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● GX IEC Developer
: Applicable with restrictions

Programmable controller type Application Reading 
applicability

Basic model QCPU
High Performance model QCPU, Q12PH, Q25PH GX IEC Developer Version 7.00A or later *1

Q03UD, Q04UDH, and Q06UDH GX IEC Developer Version 7.03D *1

Q02U GX IEC Developer Version 7.03D *1

Q13UDH and Q26UDH GX IEC Developer Version 7.03D *1

Q03UDE, Q04UDEH, Q06UDEH, Q13UDEH, and 
Q26UDEH GX IEC Developer Version 7.03D *1

FX0, FX0S, FX0N, FX1, FXU, FX2C, FX2N, and FX2NC GX Developer Version 2.00A or later *1

*1 : Only execution programs can be read.
They can be displayed/edited as MELSEC-IL programs.
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Appendix 6.2 Data compatibility

■ Reading data written on the programmable controller CPU using GX 
Developer to GX Works2

The following table shows the reading applicability depending on the label setting when reading data 
written on the programmable controller CPU using GX Developer to GX Works2.
Data created with the CPU types or programming languages not supported by GX Works2 cannot be 
read.

● Reading data with labels
This function is not supported by FXCPU.

: Applicable
: Applicable with restrictions

×: Not applicable

Data

Project type of GX Works2

Simple project Structured 
projectWithout labels With labels

Label program
Label program
(GX Developer format symbolic 
information)

× *3,*5 *3,*5

Program

Ladder program *4 ×*5 ×*5

SFC program *1,*2

*1 : When MELSAP-L format SFC programs are read with Version 1.24A or earlier, they are opened in the MELSAP3 format.
*2 : Block statements written with GX Developer are read as SFC block comments in GX Works2.

×*3

*3 : SFC programs are not included in label programs of GX Developer. Use 'Simple project (without labels)' when reading 
programs in GX Works2.

×*3

ST Program *4

*4 : When a ladder program or ST program, in which labels of GX Developer are used, is read in Simple program (without 
labels), it becomes a ladder program without labels. By editing this ladder program and writing it to a programmable 
controller CPU again, this program becomes inconsistent with the label program written to a programmable controller 
CPU using GX Developer.

×*5

*5 : Ladder programs and ST programs, in which labels of GX Developer are used, are included in label programs. Read GX 
Developer format symbolic information when reading programs in GX Works2.

×*5

Parameter
PLC/Network/Remote password/
Redundant parameter   

Intelligent function module parameter   

Device comment

Common comment
(Global device comment)   

Comment by program
(Local device comment)   

Device memory Device memory   

Device initial value Device initial value   
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● Reading data without labels (QCPU (Q mode))
: Applicable

: Applicable with restrictions
×: Not applicable

● Reading data without labels (FXCPU)
: Applicable

×: Not applicable

Data

Project type of GX Works2

Simple project Structured 
projectWithout labels With labels

Program
Ladder program  × ×

SFC program *1, *2

*1 : When MELSAP-L format SFC programs are read with Version 1.24A or earlier, they are opened in the MELSAP3 format.
*2 : Block statements written with GX Developer are read as SFC block comments in GX Works2.

× ×

Parameter
PLC/Network/Remote password/
Redundant parameter   

Intelligent function module parameter   

Device comment

Common comment
(Global device comment)   

Comment by program
(Local device comment)   

Device memory Device memory   

Device initial value Device initial value   

Data

Project type of GX Works2

Simple project Structured 
projectWithout labels With labels

Program Program  × ×

Parameter PLC parameter  × ×

Device comment

Common comment
(Global device comment)  × ×

Comment by program
(Local device comment) × × ×

Device memory Device memory  × ×
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■ Reading data written on the programmable controller CPU using GX IEC 
Developer to GX Works2

The following table shows the applicability of reading data written on the programmable controller CPU 
using GX IEC Developer to GX Works2.
Data created with the CPU types or programming languages not supported by GX Works2 cannot be 
read.

● QCPU (Q mode)
: Applicable

: Applicable with restrictions
×: Not applicable

● FXCPU
: Applicable

×: Not applicable

Data

Project type of GX Works2

Simple project Structured 
projectWithout labels With labels

Parameter

PLC parameter   

Network parameter   

Intelligent function module parameter   

Program Program file *1

*1 : Only actual programs are read.

× ×

Symbolic 
information 
(Symbolic data)

- × × *2

*2 : Programs which contain data not supported by GX Works2 cannot be read.

Data
Project type of GX Works2

Simple project
(Without labels) Structured project

Parameter PLC parameter  ×

Program Program file  ×

Symbolic 
information 
(Symbolic data)

- × ×
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■ Reading data written on the programmable controller CPU using GX Works2 
to existing applications

The following table shows the applicability of reading data written on the programmable controller CPU 
using GX Works2 to existing applications.
Data created with the CPU types or programming languages not supported by existing applications 
cannot be read.

● GX Developer
: Applicable

: Applicable with restrictions
×: Not applicable

Data
Existing applications

QCPU
(Q mode) FXCPU

Symbolic information – × ×

Program
Program/Program file *1,*2,*3

*1 : Only execution programs can be read.
They can be displayed/edited in ladder program or list.

*2 : Programs cannot be read to GX Developer Version 8.03D or later if projects are opened with the setting of "Use label". To 
enable reading of programs to GX Developer Version 8.03D or later, create projects without the "Use label" setting.

*3 : When Structured Ladder/FBD or ST programs are read from a programmable controller CPU using existing applications, 
they are read as ladder programs, but there may be cases where the ladder programs cannot be restored. Be sure to 
check the programs after they have been read from the programmable controller CPU using existing applications.
When programs are read from a programmable controller CPU using GX Developer, ladder blocks which cannot be 
displayed as ladder programs are displayed in yellow.

*1,*3

SFC program/SFC program file *2, *4

*4 : SFC block titles set in "Simple project (with labels)" are not restored when programs are read from a programmable 
controller CPU in GX Developer. They are restored when the device comments are read using GX Developer, after they 
have been set to the BL device and written in GX Works2.

*5

*5 : SFC block titles are not restored when programs are read from a programmable controller CPU in GX Developer. The 
transition condition numbers are re-sorted in ascending order.

Parameter

PLC parameter - *6

*6 : Ethernet port setting cannot be read.

Network parameter  ×

Remote password  -

Redundant parameter  -

Intelligent function module parameter  -

Device comment
Global device comment (Common comment)  

Local device comment (Comment by program)  ×

Device memory Device memory  
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● GX IEC Developer
: Applicable

: Applicable with restrictions
×: Not applicable

Data
Existing applications

QCPU
(Q mode) FXCPU

Symbolic information – × ×

Program

Program/Program file *1

*1 : Only execution programs can be read.
They can be displayed/edited as MELSEC-IL programs.

-

Program file – *1

SFC program/SFC program file × –

Parameter

PLC/Network/Remote password  –

PLC parameter – 

Intelligent function module parameter  –

Device comment
Global device comment (Common comment) × ×

Local device comment (Comment by program) × ×

Device memory Device memory  



App - 86

GX Works2

  APPENDIX

Appendix 7 Compatibility with Existing Applications

This section explains the considerations when handling GX Works2 projects in earlier version of GX 
Works2.
Read the considerations in each following item to handle projects.
Note that, depending on the combination of project-created version and project-handled version, 
considerations for both versions need to be read.
For example, when handling the GX Works2 Version 1.08J project in GX Works2 Version 1.05F, read 
the considerations of '■ Handling GX Works2 Version 1.08J projects in GX Works2 Version 1.05F' and 
'■ Handling GX Works2 Version 1.12N projects in GX Works2 Version 1.08J or earlier'.

■ Handling GX Works2 Version 1.08J projects in GX Works2 Version 1.05F

Remote HeadQ CPU L CPU FX

Function Considerations

Open

• Projects for Q00UJ, Q00U, Q01U, Q10UDH, Q10UDEH, Q20UDH, Q20UDEH, and FXCPU 
cannot be opened in GX Works2 Version 1.05F.

• Projects whose path includes a semicolon (;) cannot be opened in GX Works2 Version 1.05F. 
Before opening a project in GX Works2 Version 1.05F, perform 'Save As' with GX Works2 
Version 1.08J or later so that its path does not include a semicolon (;).

Project Revision

The project revision function cannot be used when the length the full path of the project file 
(Project.gd2) exceeds 256 bytes.
Before using the project revision function with GX Works2 Version 1.05F, perform 'Save As' in GX 
Works2 Version 1.08J or later so that the length of the project file is 255 bytes or less.

Parameter

When a project in which the following parameters are set is opened in GX Works2 Version 1.05F, 
the parameters are changed to the default settings.
• When the duplicated network number is specified for 'Network No.' of the CC IE Control on the 

MELSECNET/CC IE/Ethernet Module Configuration screen.
• When any of 'Twist' is selected for MELSECNET/H in the baud rate setting on the 

MELSECNET/CC IE/Ethernet Module Configuration screen.
• When "Use serial communication" is selected in the serial communication setting with Q02U.
• When the PLC module change setting in the PLC system setting is specified with Universal 

model QCPU.
• When index registers are specified as local devices in the device setting with Universal model 

QCPU.
• When "Socket Communication" is selected for 'Open System' in the open setting of the built-in 

Ethernet port setting in projects with Built-in Ethernet port QCPU.

Instruction
When an instruction added due to Universal model QCPU (the first five digits of the serial number 
is '10102' or higher) compatible is used in a project, an instruction code error occurs as the project 
is opened in GX Works2 Version 1.05F.
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■ Handling GX Works2 Version 1.12N projects in GX Works2 Version 1.08J or 
earlier

■ Handling GX Works2 Version 1.15R projects in GX Works2 Version 1.12N or 
earlier

Function Considerations

Open

• Simple projects (with labels) written in Structured Text cannot be opened in GX Works2 Version 
1.08J or earlier.

• Projects that include inline structured text programs cannot be opened in GX Works2 Version 
1.08J or earlier.

• Simple projects (with labels) for FXCPU or projects for the FXCPU containing Sequential 
Function Chart cannot be opened in GX Works2 Version 1.08J or earlier.

Intelligent function module 
data

Newly added items in data of Q62AD-DGH/Q66AD-DG module cannot be displayed and changed 
in GX Works2 Version 1.08J or earlier. In addition, data of items newly added since Version 1.10L 
or later may be lost when data are written to the module in GX Works2 Version 1.05F or earlier.

Write to PLC/Read from 
PLC

Symbolic information of projects which include inline structured text programs and are created and 
written to the programmable controller CPU in GX Works2 Version 1.12N or later cannot be read 
from the programmable controller CPU.

Function Considerations

Open

• When a project is opened in GX Works2 Version 1.12N or earlier, system labels are read as 
global labels.
If a project which is saved after rows of global label are moved or deleted in GX Works2 Version 
1.12N or earlier, is opened in GX Works2 Version 1.15R or later, the relation with system labels 
is disabled.
If a project which is saved after global labels are edited in GX Works2 Version 1.12N or earlier, 
is opened in GX Works2 Version 1.15R or later, the relation with system labels can be resolved 
by executing the verification synchronous function.

• Contact instructions newly added for Structured Ladder and ST are not supported by GX 
Works2 Version 1.12N or earlier. A project which contains newly added contact instructions 
cannot be opened in GX Works2 Version 1.12N or earlier even if they have already been 
deleted.

Connection destination 
setting

When a project is opened in GX Works2 Version 1.12N or earlier, the connection destination 
setting to use the GOT (Ethernet) transparent is changed. Reconfigure the connection destination 
setting according to the actual communication route.

Write to PLC/Read from 
PLC

Symbolic information of projects which contain contact instructions newly added for Structured 
Ladder and ST cannot be read from the programmable controller CPU in GX Works2 Version 
1.12N or earlier.

Library A user library which contains contact instructions newly added for Structured Ladder and ST 
cannot be opened in GX Works2 Version 1.12N or earlier.
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■ Handling GX Works2 Version 1.24A projects in GX Works2 Version 1.15R or 
earlier

■ Handling GX Works2 Version 1.31H projects in GX Works2 Version 1.24A or 
earlier

Function Considerations

Open
• Projects for LCPU cannot be opened in GX Works2 Version 1.15R or earlier.
• Simple projects (with labels) for FXCPU that include inline structured text programs cannot be 

opened in GX Works2 Version 1.15R or earlier.

Intelligent function 
module data

When a project which contains the switch setting of Q62DA-FG/Q66DA-G module set to "4 to 20mA 
(extended mode)" or "1 to 5V (extended mode)" is opened in GX Works2 Version 1.15R or earlier, 
the setting is reset to default ("4 to 20mA").

Connection destination 
setting

When a project for FX3U/FX3UC is opened in GX Works2 Version 1.15R or earlier, the connection 
destination setting which is set for the Ethernet connection is reset to default.
Reconfigure the connection destination setting according to the actual communication route.

Function Considerations

Open

• Projects for Q50UDEH, Q100UDEH, and LJ72GF15-T2 cannot be opened in GX Works2 Version 
1.24A or earlier.

• Projects for LCPU in which system labels are set cannot be opened in GX Works2 Version 1.24A 
or earlier.

• When "MELSAP-L (Instruction Format)" or "MELSAP-L (Start Conditions Format)" is selected as 
the SFC display format, SFC is opened as MELSAP3 in GX Works2 Version 1.24A or earlier.

Parameter
When a project in which "CC IE Field (Master Station)" or "CC IE Field (Local Station)" is set in the 
network parameter is opened in GX Works2 Version 1.24A or earlier, the parameters are changed to 
the default settings.

Intelligent function 
module data

• When a project which contains LD62, LD62D, LD75D4, LD75P4, or LD77MH4 is opened in GX 
Works2 Version 1.24A or earlier, these modules become reserved modules.

• Projects cannot be handled in GX Works2 Version 1.24A or earlier when "Disconnection detection 
mode setting" and "Disconnection detection setting value" are set in the parameter setting of 
Q62DA-FG module.

• Projects cannot be handled in GX Works2 Version 1.24A or earlier when the following parameters 
are set in the parameter setting of QJ71C24N/QJ71C24N-R2.
• The echo back permit/prohibit specification or execution history option specification in the 

various control specification
• The predefined protocol function error code, send data storage area or receive data storage 

area in the auto refresh
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■ Handling GX Works2 Version 1.40S projects in GX Works2 Version 1.31H or 
earlier

Function Considerations

Open

• Projects for remote I/O module cannot be opened in GX Works2 Version 1.31H or earlier.
• Projects for Universal model QCPU (except for Q00U, Q00UJ, Q01U, Q02U) in which "Act at 

Block Multi-Activated" is set for SFC program property cannot be opened in GX Works2 Version 
1.31H or earlier.

• Be aware the following considerations when handling a project in which system labels are used for 
FXCPU.
System labels are read as global labels when a project is opened in GX Works2 Version 1.12N or 
earlier. If a project in which rows of global label are moved or deleted is saved in GX Works2 
Version 1.12N or earlier, the relation with system labels is disabled.
If a project is opened in GX Works2 Version 1.15R - 1.40S, system label information is resolved, 
but the operations related to system label functions cannot be performed.
If a project which is saved after global labels are edited in GX Works2 Version 1.31H or earlier, is 
opened in GX Works2 Version 1.40S or later, the relation with system labels can be resolved by 
executing the verification synchronous function.

Connection destination 
setting

When a project in which the communication route via Ethernet adapter module is set is opened in GX 
Works2 Version 1.31H or earlier, the communication route is changed to programmable controller 
direct connection setting.

Parameter

• When a project in which the number of points between 1K (1024) and 7K (7168) or exceeds 8K 
(8192) is set for S device on the PLC parameter is opened in GX Works2 Version 1.31H or earlier, 
the parameters are changed to the default settings.

• When a project in which "CC IE Control Ext. Mode (Control Station)" or "CC IE Control Ext. Mode 
(Normal Station)" is set in the network parameter is opened in GX Works2 Version 1.31H or 
earlier, the setting is deleted.

Device comment For Universal model QCPU, when a project in which bit-specified word device comments are set is 
opened in GX Works2 Version 1.31H or earlier, the bit-specified word device comments are deleted.

Build

• When a project in which the same name is used for data name and label name is opened and 
compiled in GX Works2 Version 1.31H or earlier, a C4110 error occurs. Compile the program after 
changing the data name and label name.

• When a project in which devices set with the "Device/Label Automatic-Assign Setting" function are 
used is opened and compiled in GX Works2 Version 1.31H or earlier, an error occurs. Compile the 
program after changing the devices not to duplicate with the ones set with the "Device/Label 
Automatic-Assign Setting" function.
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■ Handling GX Works2 Version 1.48A projects in GX Works2 Version 1.44W or 
earlier

■ Handling GX Works2 Version 1.53F projects in GX Works2 Version 1.49B or 
earlier

Function Considerations

Open

• When a ladder program whose "Display Connection of Ladder Diagram" setting is set to 13 or 
more is opened in GX Works2 Version 1.44W or earlier, the program is read with the 11 contacts 
as the number of displayed contacts.

• An FXCPU Simple project (with labels) which contains multiple programs cannot be opened in GX 
Works2 Version 1.44W or earlier.

• Even when an FXCPU Simple project (with labels) contains only a single program, if the program 
data name is not "MAIN", the project cannot be opened in GX Works2 Version 1.44W or earlier.

Intelligent function 
module data

When a project which contains QD65PD2 or LD77MH16 is opened in GX Works2 Version 1.44W or 
earlier, the module becomes a reserved module.

Connection destination 
setting

• When a project in which the communication route via CC-Link IE Field Network board is set is 
opened in GX Works2 Version 1.44W or earlier, the communication route is changed to 
programmable controller direct connection setting.

• When a project in which the communication route via GOT from Ethernet board is set is opened in 
GX Works2 Version 1.44W or earlier, the PLC side I/F of the connection destination setting is 
changed to CPU module. "GOT Transparent" is displayed on the status bar. This change does not 
affect the communication, however, correct the connection destination setting according to the 
actual communication route.

Write to PLC/Read from 
PLC

• When a ladder program whose "Display Connection of Ladder Diagram" setting is set to 13 or 
more is read from a programmable controller CPU using GX Works2 Version 1.44W or earlier, the 
program is displayed as an improper ladder program.

• When a project which is written to a programmable controller CPU using the high-speed mode is 
read from the programmable controller CPU using GX Works2 Version 1.44W or earlier, the 
symbolic information cannot be read.

Language selection

When a project with a condition described below is opened in GX Works2 Version 1.44W or earlier, 
the operation is not ensured.
• A language other than Japanese is selected, and characters other than one-byte characters are 

used.
• Two or more types of two-byte characters are mixed.

Function Considerations

Open A project in which multiple devices are selected with the "Device/Label Automatic-Assign Setting" 
function cannot be opened in GX Works2 Version 1.49B or earlier.

Intelligent function 
module data

When a project which contains QJ71MT91 or QJ71MB91 is opened in GX Works2 Version 1.49B or 
earlier, the module becomes a reserved module.

Connection destination 
setting

When a project in which the communication route via CC-Link IE Field Network master/local module 
is set for LCPU is opened in GX Works2 Version 1.49B or earlier, the communication route is 
changed to programmable controller direct connection setting.

Parameter
When a project in which "CC IE Field (Master Station)" and "CC IE Field (Local Station)" are set in 
the network parameter of LCPU is opened in GX Works2 Version 1.49B or earlier, the network 
parameters are changed to default settings.

Write to PLC/Read from 
PLC

A project in which multiple devices are selected with the "Device/Label Automatic-Assign Setting" 
function cannot be read from a programmable controller CPU in GX Works2 Version 1.49B or earlier.
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■ Handling GX Works2 Version 1.62Q projects in GX Works2 Version 1.55H or 
earlier

■ Handling GX Works2 Version 1.64S projects in GX Works2 Version 1.62Q or 
earlier

Function Considerations

Open

• Structured projects in which the operation to display/hide the left power rail is performed on the 
Structured Ladder/FBD editor cannot be opened in GX Works2 Version 1.55H or earlier.

• For FXCPU, a project in which a block password with the validated setting for "Read-protect the 
execution program" exists cannot be opened in GX Works2 Version 1.55H or earlier.

Intelligent function 
module data

• A project which contains Q64TCTTN, Q64TCTTBWN, Q64TCRTN, or Q64TCRTBWN opens as a 
project of Q64TCTTN, Q64TCTTBWN, Q64TCRTN, Q64TCRTBWN respectively.
Added items cannot be displayed or changed in GX Works2 Version 1.55H or earlier.

• When a project which contains L60TCTT4, L60TCTT4BW, L60TCRT4, or L60TCRT4BW is 
opened in GX Works2 Version 1.55H or earlier, those modules become reserved modules.

Parameter

• When a project in which the simple PLC communication setting is set on the PLC parameter of 
LCPU is opened in GX Works2 Version 1.55H or earlier, the parameters are changed to the 
default settings.

• When a project in which the serial communication setting is set on the PLC parameter of 
QnUD(H)CPU is opened in GX Works2 Version 1.55H or earlier, the parameters are changed to 
the default settings.

Function Considerations

Parameter
Projects cannot be handled in GX Works2 Version 1.62Q or earlier when the following parameters 
are set.
• When "Branch Module" is set for the I/O assignment setting on PLC parameter of LCPU.

Intelligent function 
module data

When a project which contains QD75P1N, QD75P2N, QD75P4N, QD75D1N, QD75D2N, or 
QD75D4N is opened in GX Works2 Version 1.62Q or earlier, these modules become reserved 
modules.

Device comment For LCPU, when a project in which bit-specified word device comments are set is opened in GX 
Works2 Version 1.62Q or earlier, the bit-specified word device comments are deleted.

Print
String patterns are printed as character strings when a project in which string pattern is set to the 
header/footer is opened in GX Works2 Version 1.62Q or earlier. Delete the entered string patterns 
and set the setting again.

Write to PLC/Read from 
PLC

For projects of LCPU, device comment files which contain bit-specified comments cannot be read 
from the programmable controller CPU in GX Works2 Version 1.62Q or earlier.
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■ Handling GX Works2 Version 1.73B projects in GX Works2 Version 1.64S or 
earlier

■ Handling GX Works2 Version 1.77F projects in GX Works2 Version 1.75D or 
earlier

Function Considerations

Open

• When a project which contains Q64ADH is opened in GX Works2 Version 1.64S or earlier, the 
module becomes a reserved module.

• Projects in which the auto refresh parameter of temperature control module is set in the Setting 
item reduction mode cannot be opened in GX Works2 Version 1.64S or earlier.

• Projects in which parameters are set in the FX3U/FX3UC network parameter cannot be opened in 
GX Works2 Version 1.64S or earlier.

Parameter

When a project in which the following parameters are set is opened in GX Works2 Version 1.64S or 
earlier, the parameters are changed to the default settings.
• When the station information of CC-Link is set on the CC-Link configuration window.
• When "Branch Module" is set on the <<I/O Assignment>> tab of PLC parameter for LCPU.

Compile
An error occurs when a program in which function blocks of ladder program are used in a Structured 
Ladder/FBD program, or function blocks of Structured Ladder/FBD program are used in a ladder 
program, is opened and compiled in GX Works2 Version 1.64S or earlier.

IC memory card write/
read

IC memory card data to which a password is set cannot be read in GX Works2 Version 1.64S or 
earlier.

Function Considerations

Parameter

When a project in which the following parameters are set is opened in GX Works2 Version 1.75D or 
earlier, the parameters are changed to the default settings.
• When "Use" is selected for the IP Packet Transfer setting on the <<Built-in Ethernet Port Setting>> 

tab of PLC parameter.
• When "CC IE Field (Sub-Master Station)" is selected for "Network Type" in the network parameter.
• When "Sub-Master Station" is selected for "Station Type" of "Network Configuration Settings".
• When the IP address is set for "Network Operation Settings".

Intelligent function 
module data

When a project which contains Q68CT, QD77MS2, QD77MS4, QD77MS16, LD75P1, LD75P2, 
LD75D1, or LD75D2 is opened in GX Works2 Version 1.75D or earlier, these modules become 
reserved modules.
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■ Handling GX Works2 Version 1.87R projects in GX Works2 Version 1.77F or 
earlier

Function Considerations

Open

• When opening a project in which the extended mode for device comments is set in GX Works2 
Version 1.77F or earlier, the comments which exceeded the number of points of device comment 
that can be set in the standard mode are deleted as described below.
• When the number of points of device comment per device exceeds the number of points that 

can be set in the standard mode, points over 32K points are deleted.
All bit-specified comments set to the device type which corresponds to the point at 32K + 1 are 
deleted.

• When the number of points of device comment per file exceeds the number of points that can be 
set in the standard mode, points over 1024K points are deleted.
All bit-specified comments set to the device type which corresponds to the point at 1024K + 1 
are deleted.

• Saved projects in which an element is added or a comment is edited for a structure registered to a 
system label cannot be opened in GX Works2 Version 1.77F or earlier.

• Projects in which structure array global labels are registered as system labels cannot be opened in 
GX Works2 Version 1.77F or earlier.

• The following functions cannot be used when a project which includes ladder programs whose 
function block calls function block is opened in GX Works2 Version 1.77F or earlier.
• Watch
• Monitor
• Modify value
• Sampling trace
• PLC Diagnostics
• Cross reference

• Projects for Q02PH, Q06PH, Q12PH, Q12PRH, Q25PH, and Q25PRH cannot be opened in GX 
Works2 Version 1.77F or earlier.

• Projects in which parameters are set in the FX3G/FX3GC network parameter cannot be opened in 
GX Works2 Version 1.77F or earlier.

Global label

When any of the following system labels is registered, the system label data base cannot be 
connected from the project in GX Works2 Version 1.77F or earlier.
• A system label in which an element is added or a comment is edited for a structure registered to a 

system label.
• A system label in which a structure array global label is set to the data type.

Verify

Project data of GX Works2 Version 1.87R cannot be verified against that of GX Works2 Version 
1.77F or earlier because of different naming methods of block data name in SFC program.
Copy the names of block data of project opened in GX Works2 Version 1.87R, paste them to block 
data of project opened in GX Works2 Version 1.77F or earlier as a block data name, and execute 
[Verify].

Write to PLC/Read from 
PLC

The following functions cannot be used when a project which includes ladder programs whose 
function block calls function block is read from a programmable controller CPU using GX Works2 
Version 1.77F or earlier.
• Watch
• Monitor
• Modify value
• Sampling trace
• PLC Diagnostics
• Cross reference

Parameter

When a project in which "CC IE Field (Local Station)" is selected for "Network Type", and "Specify 
station No. by program" is selected for 'specification method for station number' in the network 
parameter is opened in GX Works2 Version 1.77F or earlier, the parameters are changed to the 
default settings.

Intelligent function 
module data

When a project which contains QD73A1 is opened in GX Works2 Version 1.77F or earlier, the 
module becomes a reserved module.
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■ Handling GX Works2 Version 1.91V projects in GX Works2 Version 1.87R or 
earlier

Function Considerations

Open Simple projects (with labels) for Q02PH, Q06PH, Q12PH, Q12PRH, Q25PH, and Q25PRH cannot 
be opened in GX Works2 Version 1.87R or earlier.

Write to PLC/Read from 
PLC

When using GX Works2 Version 1.87R or earlier, data cannot be written to/read from a Process CPU 
or Redundant CPU to which symbolic information of Simple project (with labels) is written. Delete the 
symbolic information with the delete PLC data function before writing/reading data to/from the 
programmable controller CPU.

Parameter

• When a project in which the following parameters are set is opened in GX Works2 Version 1.87R 
or earlier, the parameters are changed to the default settings.
• When the network configuration of CC-Link IE Field Network is set on the CC IE Field 

configuration window.
• When the Ethernet adapter setting is set on the PLC parameter of FX3G, FX3GC, FX3U, or 

FX3UC.
• CSV files exported by the parameter processing of slave station on the CC-Link configuration 

window cannot be imported in GX Works2 Version 1.87R or earlier.

Intelligent function 
module data

When a project which contains QE81WH, QE84WH, QE81WH4W, QE83WH4W, or QE82LG is 
opened in GX Works2 Version 1.87R or earlier, these modules become reserved modules.
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■ Handling GX Works2 Version 1.98C projects in GX Works2 Version 1.91V or 
earlier

Function Considerations

Open

• The following projects cannot be opened in GX Works2 Version 1.91V or earlier.
• Structured projects for Q02PH, Q06PH, Q12PH, Q12PRH, Q25PH, and Q25PRH.
• Projects for Q03UDV, Q04UDV, Q06UDV, Q13UDV, Q26UDV, L02S, L06, L26, and 

LJ72MS15.
• When a project in which the reflection/reference targets of device comments are set to 'PLC 

parameter setting' is opened in GX Works2 Version 1.91V or earlier, the reflection/reference 
targets are set to "Local".

• The following functions may not be performed normally when a project, in which an inline 
structured text program is called from the function block created in a ladder program, or a function 
block created in an ST program is called from the function block created in a ladder program, is 
opened in GX Works2 Version 1.98C or earlier.
• Watch
• Monitor
• Modify value
• Sampling trace
• PLC Diagnostics
• Cross reference
• Print
• Deletion of inline structured text box in function block of ladder program

Write to PLC/Read from 
PLC

• When using GX Works2 Version 1.91V or earlier, data of the following projects cannot be written 
to a programmable controller CPU.
• QCPU project in which the IP address is set for "Network Operation Settings" of CC IE Control 

network parameter
• LCPU project in which Ethernet is set for the network parameter
• LCPU project in which the IP packet transfer is set for "Built-in Ethernet Port Setting" of PLC 

parameter
• LCPU project in which the IP address is set for "Network Operation Settings" of CC-Link IE Field 

Network parameter (master station, sub-master station)
• When using GX Works2 Version 1.91V or earlier, data cannot be written to/read from a Process 

CPU or Redundant CPU to which symbolic information of Structured project is written. Delete the 
symbolic information with the delete PLC data function before writing/reading data to/from the 
programmable controller CPU.

Verify

When any of the following projects is opened in GX Works2 Version 1.91V or earlier, the 
programmable controller data, projects, and revisions cannot be verified.
• LCPU project in which the IP packet transfer is set for "Built-in Ethernet Port Setting" of PLC 

parameter
• LCPU project in which the sub-master station is set for the network configuration of CC-Link IE 

Field Network parameter (master station, sub-master station)
• LCPU project in which the IP address is set for "Network Operation Settings" of CC-Link IE Field 

Network parameter (master station, sub-master station)

Parameter

• When any of the following project is opened in GX Works2 Version 1.91V or earlier, the 
parameters are set to default.
• QCPU project in which the IP address is set for "Network Operation Settings" of CC IE Control 

network parameter
• LCPU project in which Ethernet is set for the network parameter
• LCPU project in which the IP packet transfer is set for "Built-in Ethernet Port Setting" of PLC 

parameter
• LCPU project in which the sub-master station is set for the network configuration of CC-Link IE 

Field Network parameter (master station, sub-master station)
• LCPU project in which the IP address is set for "Network Operation Settings" of CC-Link IE Field 

Network parameter (master station, sub-master station)
• LCPU project in which the Auto Detect Setting of the Connected Device is set for "Operation 

Setting" of CC-Link network parameter
• Project contains AnyWireASLINK configuration data

• When a project in which the following parameter is set is opened in GX Works2 Version 1.91V or 
earlier, the parameters are changed to the default settings.
• CC IE Field (Motion Master Station) is set in the network parameter of Universal model QCPU.
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Intelligent function 
module data

• When a project which contains QD77GF16, Q64DAH, L60AD4-2GH, QJ51AW12AL, or 
LJ51AW12AL is opened in GX Works2 Version 1.91V or earlier, these modules become reserved 
modules

• QCPU waveform output data created in GX Works2 Version 1.98C or later cannot be read in GX 
Works2 Version 1.91V or earlier.

Remote password When a project in which the remote password for LJ71E71-100 is set is opened in GX Works2 
Version 1.91V or earlier, the module is changed to "LCPU" (Built-in Ethernet type CPU).

Function Considerations



Appendix 8  Considerations When Saving Projects in GX Developer Format

App - 97

17

O
P

E
R

A
TI

N
G

 
PR

O
G

R
A

M
M

AB
LE

 
C

O
N

TR
O

LL
E

R
 C

P
U

18

DI
AG

NO
SI

NG
 

PR
OG

RA
M

M
AB

LE
 

CO
NT

RO
LL

ER
 S

TA
TU

S

19

SI
M

U
LA

TI
N

G
 

O
PE

R
AT

IO
N

S 
O

F 
EX

TE
R

N
AL

 D
EV

IC
ES

20

P
R

IN
TI

N
G

21

S
E

TT
IN

G
 O

P
TI

O
N

S

22

U
S

IN
G

 L
IB

R
A

R
IE

S

A

A
PP

E
N

D
IX

I

IN
D

EX

Appendix 8 Considerations When Saving Projects in GX Developer Format

This section explains the considerations applied when saving projects in GX Developer format.
In cases other than those listed below when data cannot be saved, a message is displayed, and 
saving is canceled. In such cases, follow the instructions of the message.

GX Works2 data Considerations

Project
Title The 33rd and later characters are deleted.

Comment Deleted.

Parameter Comment Deleted.

Intelligent function 
module Intelligent function module data

Data other than intelligent function module parameters (initial setting, auto 
refresh) are deleted.
QD75P1N, QD75P2N, QD75P4N, QD75D1N, QD75D2N, and QD75D4N are 
saved as QD75P1, QD75P2, QD75P4, QD75D1, QD75D2, and QD75D4 
respectively.

Structured Data 
Types*1

*1 : Not supported by FXCPU.

Comment Deleted.

Label Comment The 65th and later characters are deleted.
If a line feed is entered, delete anything following the line feed.

Global Label*1

Number of data The data are combined into one unit.

Data name A fixed character string (label) is created to combine data into one unit.

Title Deleted.

Comment Deleted.

Label

Comment The 65th and later characters are deleted.
If a line feed is entered, delete anything following the line feed.

Remarks Deleted.

FB instance Deleted.

System label information Deleted.

FB*1

Comment Deleted.

Label*1
Comment The 65th and later characters are deleted.

If a line feed is entered, delete anything following the line feed.

FB instance Deleted*2.

*2 : The function block instances created for global labels in GX Works2 are created as local labels in GX Developer. However, in GX 
Developer, the function block instances are not displayed on the local label setting screen.

Program

Comment Deleted.

Label*1
Comment The 65th and later characters are deleted.

If a line feed is entered, delete anything following the line feed.

FB instance Deleted*2.

SFC program*1 Comment Deleted.

SFC block*1
Data name Deleted.

Comment Converted to a block statement.
(Characters exceeding 10 lines times 65 characters are deleted.)

Device Memory
Comment Deleted.

Duplicated devices Latter device is preferred.

RemoteQ CPU L CPU FXHead FX
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Appendix 8.1  ST instruction table for GX Works2 and GX Developer

Appendix 8.1 ST instruction table for GX Works2 and GX Developer

Instructions that can be used in ST programs differ in between GX Works2 and GX Developer. As a 
result, an error may occur when a project that includes an ST program and is saved in GX Developer 
format is read and compiled with GX Developer. In such case, correct the ST program according to the 
following table.

GX Works2 GX Developer GX Works2 GX Developer GX Works2 GX Developer

ACOS ACOS*1 DFLT DFLT_M INC INC_M

ASIN ASIN*1 DFRO DFRO_M LEFT LEFT*1

ATAN ATAN*1 DGBIN DGBIN_M LEN LEN*1

BACOS BACOS_MD DGRY DGRY_M LIMITATION LIMIT

BAND BAND_MD DI DI_M MAXIMUM MAX

BASIN BASIN_MD DINC DINC_M MIDR MIDR_M

BATAN BATAN_MD DIS DIS_M MIDW MIDW_M

BCD BCD_M DLIMIT DLIMIT_MD MINIMUM MIN

BCOS BCOS_MD DMAX DMAX_M NDIS NDIS_M

BDSQR BDSQR_MD DMIN DMIN_M NEG NEG_M

BIN BIN_M DNEG DNEG_M NUNI NUNI_M

BKAND BKAND_M DOR DOR_M OUT OUT_M

BKBCD BKBCD_M DRCL DRCL_M PLOW PLOW_M

BKBIN BKBIN_M DRCR DRCR_M POFF POFF_M

BKOR BKOR_M DROL DROL_M PSCAN PSCAN_M

BKRST BKRST_M DROR DROR_M PSTOP PSTOP_M

BKXNR BKXNR_M DSER DSER_M QCDSET QCDSET_M

BKXOR BKXOR_M DSFL DSFL_M QDRSET QDRSET_M

BMOV BMOV_M DSFR DSFR_M RCL RCL_M

BRST BRST_M DSORT DSORT_M RCR RCR_M

BSET BSET_M DSUM DSUM_M RFS RFS_M

BSFL BSFL_M DTEST DTEST_MD RIGHT RIGHT*1

BSFR BSFR_M DTO DTO_M RND RND_M

BSIN BSIN_MD DWSUM DWSUM_M ROL_E ROL*1

BSQR BSQR_MD DXCH DXCH_M ROR_E ROR*1

BTAN BTAN_MD DXNR DXNR_M RSET RSET_MD

BTOW BTOW_MD DXOR DXOR_M RST RST_M

BXCH BXCH_M DZONE DZONE_MD SECOND SECOND_M

CML CML_M EI EI_M SEG SEG_M

COM COM_M EMOD EMOD_M SER SER_M

COS COS*1 ENCO ENCO_M SET SET_M

DATERD DATERD_MD ENEG ENEG_M SFL SFL_M

DATEWR DATEWR_MD EREXP EREXP_M SFR SFR_M

DBAND DBAND_MD ESTR ESTR_M SFT SFT_M

DBCD DBCD_M EVAL EVAL_M SIN SIN*1

DBIN DBIN_M EXP EXP*1 SORT SORT_M

DBL DBL_M FLT FLT_M SRND SRND_M

DCML DCML_M FMOV FMOV_M STOP STOP_M

DDEC DDEC_M FROM FROM_M SUM SUM_M

DEC DEC_M GBIN GBIN_M SWAP SWAP_MD

DECO DECO_M GRY GRY_M TAN TAN*1

DELTA DELTA_M HOUR HOUR_M TEST TEST_MD
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UNI UNI_M WSUM WSUM_M WXOR WXOR_M

WAND WAND_M WTOB WTOB_MD XCH XCH_M

WDT WDT_M WXNR WXNR_M ZONE ZONE_MD

WOR WOR_M

*1 : Devices/labels need to be changed according to the arguments of GX Developer instructions.

GX Works2 GX Developer GX Works2 GX Developer GX Works2 GX Developer
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Appendix 9 Character Strings that cannot be Used for Label Names and Data Names

Character strings used for application function names, common instruction names, special 
instruction names, instructions and so on are called reserved words.
These reserved words cannot be used for label names or data names. If the character string defined 
as a reserved word is used for a label name or data name, an error occurs during registration or 
compilation.
The following tables shows character strings that cannot be used for label names or data names.
The numbers from  to  in the tables indicate the following label names and data names.

: Applicable, : With restrictions, ×: Not applicable

Remote HeadQ CPU L CPU FX

<Label name and data name>
 Project file name
 Program file name (Simple (without labels))
 Program file name (Simple (with labels))
 Program file name (structure)
 Task name
 Global label data name
 Structure name
 POU name
 Label name

Category Character string         

Class identifier

VAR, VAR_RETAIN, VAR_ACCESS, VAR_CONSTANT, 
VAR_CONSTANT_RETAIN, VAR_INPUT, 
VAR_INPUT_RETAIN, VAR_OUTPUT, 
VAR_OUTPUT_RETAIN, VAR_IN_OUT, VAR_IN_EXT, 
VAR_EXTERNAL, VAR_EXTERNAL_CONSTANT, 
VAR_EXTERNAL_CONSTANT_RETAIN, 
VAR_EXTERNAL_RETAIN, VAR_GLOBAL, 
VAR_GLOBAL_CONSTANT, 
VAR_GLOBAL_CONSTANT_RETAIN, 
VAR_GLOBAL_RETAIN

×  × × × × × × ×

Data type

BOOL, BYTE, INT, SINT, DINT, LINT, UINT, USINT, UDINT, 
ULINT, WORD, DWORD, LWORD, ARRAY, REAL, LREAL, 
TIME, STRING, TIMER, COUNTER, RETENTIVETIMER, 
POINTER, Bit, Word [Unsigned]/Bit String [16-bit], Double 
Word [Unsigned]/Bit String [32-bit], Word [Signed], Double 
Word [Signed], FLOAT (Single Precision), FLOAT (Double 
Precision), String, Time, Timer, Counter, Retentive Timer, 
Pointer

  × × × × × × ×

Data type hierarchy
ANY, ANY_NUM, ANY_BIT, ANY_REAL, ANY_INT, 
ANY_DATE   × × × × × × ×

ANY_SIMPLE, ANY16, ANY32        *1 ×

Device name
X, Y, D, M, T, B, C, F, L, P, V, Z, W, I, N, U, J, K, H, E, A, SD, 
SM, SW, SB, FX, FY, DX, DY, FD, TR, BL, SG, VD, ZR, ZZ*2        *1 ×

Character string 
recognized as device
(Device name + 
Numeral)

Such as X0   × × × × × *3 ×

ST operator
NOT, MOD   × × × × × × ×

(, ), -        *1 ×

IL operator

LD, LDN, ST, STN, S, S1, R, R1, AND, ANDN, OR, ORN, 
XOR, XORN, ADD, SUB, MUL, DIV, GT, GE, EQ, NE, LE, LT, 
JMP, JMPC, JMPCN, CAL, CALC, CALCN, RET, RETC, 
RETCN

×  × × × × × × ×

LDI, LDP, LDF, ANI, ANDP, ANDF, ANB, ORI, ORP, ORF, 
ORB, MPS, MRD, MPP, INV, MEP, MEF, EGP, EGF, 
OUT(H), SET, RST, PLS, PLF, FF, DELTA(P), SFT(P), MC, 
MCR, STOP, PAGE, NOP, NOPLF

       *1 ×
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Application 
instruction in GX 
Works2

Application instructions such as DMOD, PCHK, and INC(P)
MELSEC-Q/L Programming Manual (Common 
Instructions), MELSEC-Q/L Structured Programming Manual 
(Common Instructions)

       *1 ×

SFC instruction

SFCP, SFCPEND, BLOCK, BEND, TRANL, TRANO, TRANA, 
TRANC, TRANCA, TRANOA, SEND, TRANOC, TRANOCA, 
TRANCO, TRANCOC, STEPN, STEPD, STEPSC, STEPSE, 
STEPST, STEPR, STEPC, STEPG, STEPI, STEPID, 
STEPISC, STEPISE, STEPIST, STEPIR, TRANJ, TRANOJ, 
TRANOCJ, TRANCJ, TRANCOJ, TRANCOCJ

       *1 ×

ST code body

RETURN, IF, THEN, ELSE, ELSIF, END_IF, CASE, OF, 
END_CASE, FOR, TO, BY, DO, END_FOR, WHILE, 
END_WHILE, REPEAT, UNTIL, END_REPEAT, EXIT, TYPE, 
END_TYPE, STRUCT, END_STRUCT, RETAIN, 
VAR_ACCESS, END_VAR, FUNCTION, END_FUNCTION, 
FUNCTION_BLOCK, END_FUNCTION_BLOCK, STEP, 
INITIAL_STEP, END_STEP, TRANSITION, 
END_TRANSITION, FROM, UNTILWHILE

  × × × × × × ×

Function name in 
application function

Function names in application functions such as AND_E and 
NOT_E       × × ×

Function block name 
in application 
function

Function block names in application functions such as CTD 
and CTU       × × ×

Symbol

/, \, *, ?, <, >, |, ", :, [, ], ,, =, +, %, ', ~, @, {, }, &, ^, ., tab 
character × × × × × × × × ×

;  × × × × × × × ×

!, #, $, `     ×  × × ×

Date and time literal DATE, DATE_AND_TIME, DT, TIME, TIME_OF_DAY, TOD ×  × × × × × × ×

Others

ACTION, END_ACTION, CONFIGURATION, 
END_CONFIGURATION, CONSTANT, F_EDGE, R_EDGE, 
AT, PROGRAM, WITH, END_PROGRAM, TRUE, FALSE, 
READ_ONLY, READ_WRITE, RESOURCE, 
END_RESOURCE, ON, TASK, EN, ENO, BODY_CCE, 
BODY_FBD, BODY_IL, BODY_LD, BODY_SFC, BODY_ST, 
END_BODY, END_PARAMETER_SECTION, 
PARAM_FILE_PATH, PARAMETER_SECTION, SINGLE, 
RETAIN, INTERVAL

×  × × × × × × ×

String that starts with 
K1 to K8 Such as K1AAA        *1 ×

Address Such as %IX0  × × × × × × × ×

Statement in Ladder 
Diagram

;FB BLK START, ;FB START, ;FB END, ;FB BLK END,
;FB IN, ;FB OUT, ;FB_NAME, ;INSTANCE_NAME,
;FB, ;INSTANCE

 × × × × × × × ×

Common instruction Such as MOV   ×   × × *3 ×

Windows® reserved 
word

COM1, COM2, COM3, COM4, COM5, COM6, COM7, COM8, 
COM9, LPT1, LPT2, LPT3, LPT4, LPT5, LPT6, LPT7, LPT8, 
LPT9, AUX, CON, PRN, NUL

× × × × × × × × 

*1 : Functions cannot be used.
*2 : Whether to handle a device name indexed with ZZ device as a reserved word depends on the parameter setting.

When Z device is specified for 32-bit index setting: Not handled as a reserved word
When ZZ device is specified for 32-bit index setting: Handled as a reserved word

*3 : Applicable to Simple projects without labels only.

Category Character string         
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■ Considerations for using labels

● In a function, the same name as the function cannot be used for a label.
● Inapplicable character strings differ between label names and data names such as function 

block names and structure names. Therefore, if a label name which contains a function block 
name or a structure name is set when setting a label of instance or structure, an error may 
occur.

● A space cannot be used.
● A numeral cannot be used at the beginning of label name.
● A label name is not case-sensitive. An error may occur at compilation when the same label 

names with different cases (example: 'AAA' and 'aaa') are declared.
● In Structured Ladder/FBD and ST programs, the same label name can be used for a global 

label and local label by setting the following option*1.
*1 : Select "Use the same label name in global label and local label" under [Tool] ⇒ [Options] ⇒ "Compile" ⇒ "Basic 

Setting".

● An underscore (_) cannot be used at the beginning or end of label name.
Consecutive underscores (_) cannot be used for a data name or a label name.

● For Simple projects, function names and function block names in common instructions and 
application functions can be used.
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Appendix 10 Restrictions When Changing Programmable Controller Type

*1 : CC IE Field head module only

The following explains the restrictions applied when changing a programmable controller series or 
type.
For the restrictions applied when changing a programmable controller type between QCPU (Q mode)/
LCPU and QCPU (Q mode)/LCPU, refer to Appendix 10.1 and the following table.
For the restrictions applied when changing a programmable controller type between QCPU (Q mode)/
LCPU and CC IE Field head module, refer to Appendix 10.11.
For the restrictions applied when changing a programmable controller type of FXCPU, refer to 
Appendix 10.12.

HeadQ CPU L CPU FX
*1

Remote

Old 
programmable 
controller type

New programmable controller type

Basic model QCPU High Performance model 
QCPU Process CPU Redundant CPU

Basic model 
QCPU Table App.10.9-1 Table App.10.8-4 Table App.10.7-1 Table App.10.6-1

High Performance 
model QCPU

Table App.10.9-1
Table App.10.9-2 – Table App.10.7-1 Table App.10.6-1

Process CPU Table App.10.9-1
Table App.10.9-5 Table App.10.8-3 – Table App.10.6-1

Table App.10.6-3

Redundant CPU Table App.10.9-1
Table App.10.9-4 Table App.10.8-2 Table App.10.7-1

Table App.10.7-3 –

QnUD(H)CPU Table App.10.9-1
Table App.10.9-3 Table App.10.8-1 Table App.10.7-1 Table App.10.6-1

Q00U, Q00UJ, 
Q01U, Q02U

Table App.10.9-1
Table App.10.9-3 Table App.10.8-1 Table App.10.7-1 Table App.10.6-1

QnUDE(H)CPU Table App.10.9-1
Table App.10.9-3 Table App.10.8-1 Table App.10.7-1 Table App.10.6-1

High-speed 
Universal model 

QCPU

Table App.10.9-1
Table App.10.9-3 Table App.10.8-1 Table App.10.7-1

Table App.10.7-2
Table App.10.6-1
Table App.10.6-2

LCPU Table App.10.9-1
Table App.10.9-6 Table App.10.8-5 Table App.10.7-1 Table App.10.6-1

Old programmable 
controller type

New programmable controller type

QnUD(H)CPU Q00U,Q00UJ,
Q01U,Q02U QnUDE(H)CPU

High-speed 
Universal model 

QCPU
LCPU

Basic model QCPU Table App.10.2-7 Table App.10.3-1
Table App.10.3-8 Table App.10.4-6 Table App.10.5-5 Table App.10.10-1

Table App.10.10-9

High Performance 
model QCPU Table App.10.2-1 Table App.10.3-1

Table App.10.3-2 Table App.10.4-1 Table App.10.5-1 Table App.10.10-1
Table App.10.10-2

Process CPU Table App.10.2-6 Table App.10.3-1
Table App.10.3-7 Table App.10.4-5 Table App.10.5-4 Table App.10.10-1

Table App.10.10-8

Redundant CPU Table App.10.2-5 Table App.10.3-1
Table App.10.3-6 Table App.10.4-4 Table App.10.5-3 Table App.10.10-1

Table App.10.10-7

QnUD(H)CPU – Table App.10.3-1
Table App.10.3-3 – – Table App.10.10-1

Table App.10.10-3

Q00U,Q00UJ,
Q01U,Q02U Table App.10.2-2 Table App.10.3-1 Table App.10.4-2 Table App.10.5-2 Table App.10.10-1

Table App.10.10-4

QnUDE(H)CPU Table App.10.2-3 Table App.10.3-1
Table App.10.3-4 – – Table App.10.10-1

Table App.10.10-5

High-speed Universal 
model QCPU Table App.10.2-4 Table App.10.3-1

Table App.10.3-5 Table App.10.4-3 – Table App.10.10-1
Table App.10.10-6
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Appendix 10.1 Common restrictions when changing programmable 
controller series/types

The following table shows the common restrictions applied when changing a programmable controller 
series or type.

Table App.10.1-1 
: With restrictions

LCPU Table App.10.2-8 Table App.10.3-1
Table App.10.3-9 Table App.10.4-7 Table App.10.5-6 Table App.10.10-1

Old programmable 
controller type

New programmable controller type

QnUD(H)CPU Q00U,Q00UJ,
Q01U,Q02U QnUDE(H)CPU

High-speed 
Universal model 

QCPU
LCPU

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

Connection destination 
setting

• Connection destination data other than "Connection 1" 
are deleted. Connection 1 is changed to the setting for 
accessing the programmable controller CPU directly to a 
personal computer.

• If the changed programmable controller type is Basic 
model QCPU/FXCPU, 'RS-232' is set to "PC side IF".

• If the changed programmable controller type is other 
than Basic model QCPU/FXCPU, 'USB' is set for "PC 
side IF".

  

Compilation status • Programs are set in the uncompiled status. –  

Saved project status • Programs are changed in the project-unsaved status.   

Password/Keyword status • Passwords returns to the registered status if unlocked.   

Program
• Unsupported instructions, devices outside the range, and 

unsupported index settings are changed to SM1255 or 
SD1255 (SM999 or SD999).

 – –

Ladder Diagram

• If a program exceeds the program capacity of the 
changed programmable controller type, the exceeding 
ladder blocks are deleted.

 – –

• A ladder block containing an unsupported instruction is 
displayed in yellow.
(Motion dedicated sequence instructions for changing 
from QnUD(H)CPU or Built-in Ethernet port QCPU to 
LCPU are excluded.)

• Instructions with devices outside the range or 
unsupported index settings are deleted, and the ladder 
block is displayed in yellow.

–  

Structured Ladder/FBD • An x mark is appended on an element of an unsupported 
instruction. – – 

Library
• Common instructions/application functions are changed 

to libraries appropriate for the changed programmable 
controller type.

– – 

Global Device Comment

• Devices not supported by the changed programmable 
controller type and those outside the range are deleted.   

Local Device Comment

Device Memory

Device Initial Value



Appendix 10  Restrictions When Changing Programmable Controller Type

Appendix 10.1  Common restrictions when changing programmable controller series/types App - 105

17

O
P

E
R

A
TI

N
G

 
PR

O
G

R
A

M
M

AB
LE

 
C

O
N

TR
O

LL
E

R
 C

P
U

18

DI
AG

NO
SI

NG
 

PR
OG

RA
M

M
AB

LE
 

CO
NT

RO
LL

ER
 S

TA
TU

S

19

SI
M

U
LA

TI
N

G
 

O
PE

R
AT

IO
N

S 
O

F 
EX

TE
R

N
AL

 D
EV

IC
ES

20

P
R

IN
TI

N
G

21

S
E

TT
IN

G
 O

P
TI

O
N

S

22

U
S

IN
G

 L
IB

R
A

R
IE

S

A

A
PP

E
N

D
IX

I

IN
D

EX

PLC Parameter
Network Parameter

• Settings are changed to those appropriate for the 
changed programmable controller type.

• The default values in the changed programmable 
controller series/type are set to the data which cannot be 
edited in the changed programmable controller series/
type.

• Network types which cannot be set for the changed 
programmable controller type are deleted.

• When the module set as "Valid Module During Other 
Station Access" is to be deleted at the programmable 
controller type change (module not supported by the 
changed programmable controller type), the first module 
is set as the valid module.

• If the number of device points set for the refresh device is 
outside the range or the device is not available, the 
setting for the refresh device is deleted.

  

Device/Label Automatic-
Assign Setting

• Settings are changed to those appropriate for the 
changed programmable controller type.

• The default values in the changed programmable 
controller series/type are set to the data which cannot be 
edited in the changed programmable controller series/
type.

–  

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels
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Appendix 10.2 Restrictions when changing to QnUD(H)CPU

The following tables show the restrictions applied when changing a programmable controller series/
type to QnUD(H)CPU.

■ Changing from High Performance model QCPU

Table App.10.2-1 
: With restrictions

■ Changing from Q00U, Q00UJ, Q01U, or Q02U

Table App.10.2-2 
: With restrictions

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

Program
• If "Convert motion dedicated sequence instruction" is 

selected, S.instructions are converted to D.instructions.
(Appendix 11)

 – –

Sequential Function 
Chart

• The property settings "SFC Program Type Setting", "Periodic 
Execution Block", "Act at Block Multi-Activated", and "Act at 
Step Multi-Activated" are deleted.

  

PLC Parameter – – – –

PLC System
• If the constant scan time is set in the PLC RAS setting, 

"Execute it while waiting for constant scan setting" is set to 
the service processing setting in the PLC System setting.

  

Program • If "Low Speed" is set to "Execute Type" in the Program 
setting, it is changed to "Standby".   

Boot File • If "Standard ROM" is set to "Transfer from", it is changed to 
"Memory Card (ROM)".   

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

Program

• A series-compatible SM/SD devices (SM/SD1000 to SM/
SD1255) are changed to the corresponding devices for Q 
series.

• If "Convert motion dedicated sequence instruction" is 
selected, S.instructions are converted to D.instructions. 
(Appendix 11)

 – –

Remote Password • Any existing settings are cleared.   
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■ Changing from QnUDE(H)CPU

Table App.10.2-3 
: With restrictions

■ Changing from High-speed Universal model QCPU

Table App.10.2-4 
 : With restrictions

■ Changing from Redundant CPU

Table App.10.2-5 
: With restrictions

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

Remote Password • Only the settings of Built-in Ethernet type CPU are cleared.   

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

Remote Password • Only the settings of Built-in Ethernet type CPU are cleared.   

PLC Parameter – – – –

Device

• If the value exceeds the capacity of changed programmable 
controller type is set for "File Register Extended Setting", the 
maximum value is set and all points are set as file register 
(ZR(R)). The setting of the latch range is cleared.

  

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

Program - – – –

Sequential Function 
Chart

• The property settings "SFC Program Type Setting", "Periodic 
Execution Block", "Act at Block Multi-Activated", and "Act at 
Step Multi-Activated" are deleted.

  

PLC Parameter – – – –

PLC System
• If the constant scan time is set in the PLC RAS setting, 

"Execute it while waiting for constant scan setting" is set to 
the service processing setting in the PLC System setting.

  

Boot File • If "Standard ROM" is set to "Transfer from", it is changed to 
"Memory Card (ROM)".   

I/O Assignment
• Settings on the slot 0 are deleted.
• If any slot after the slot 1 is set, "Empty" is set for "Type" and 

"0 Point" is set for "Points" on the slot 0.
  

Network Parameter – – – –

Ethernet • "Ethernet (Main Base)" or "Ethernet (Extension Base)" is 
changed to "Ethernet".   

CC-Link • "Master station (Extension Base)" is changed to "Master 
Station".   
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■ Changing from Process CPU

Table App.10.2-6 
: With restrictions

■ Changing from Basic model QCPU

Table App.10.2-7 
: With restrictions

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

Program
• If "Convert motion dedicated sequence instruction" is 

selected, S.instructions are converted to D.instructions.
(Appendix 11)

 – –

Sequential Function 
Chart

• The property settings "SFC Program Type Setting", "Periodic 
Execution Block", "Act at Block Multi-Activated", and "Act at 
Step Multi-Activated" are deleted.

  

PLC Parameter – – – –

PLC System
• If the constant scan time is set in the PLC RAS setting, 

"Execute it while waiting for constant scan setting" is set to 
the service processing setting in the PLC System setting.

  

Program • If "Low Speed" is set to "Execute Type" in the Program 
setting, it is changed to "Standby".   

Boot File • If "Standard ROM" is set to "Transfer from", it is changed to 
"Memory Card (ROM)".   

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

Program
• If "Convert motion dedicated sequence instruction" is 

selected, S.instructions are converted to D.instructions.
(Except for Q00J. Appendix 11)

 – –

PLC Parameter – – – –

PLC File

• When changing from Q00 or Q01, "Use the following file" is 
selected and "Corresponding Memory: Standard RAM", "File 
Name: MAIN", and "Capacity: 64K Points" are set in the file 
register setting.

  

Boot File

• If "Do boot from standard ROM" is selected before changing 
the programmable controller type, "Type: Sequence", "Data 
Name: MAIN", "Transfer From: Memory Card (ROM)", and 
"Transfer To: Program Memory" are set.

  
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■ Changing from LCPU

Table App.10.2-8 
: With restrictions

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

Remote Password

• When changing from L02/L02-P or L02S, any existing 
settings are cleared.

• When changing from L06, L26, or L26-BT/L26-PBT, the 
following settings are set.
• The settings of the built-in Ethernet are cleared.
• The settings of LJ71C24 are replaced to the settings of 

QJ71C24/CMO.
• The settings of LJ71E71 are replaced to the settings of 

QJ71E71.

  

PLC Parameter – – – –

I/O Assignment • Settings of "Built-in I/O Function Setting" and "Built-in CC-
Link Setting" are deleted.   

Network Parameter – – – –

CC-Link IE Field 
Network

• If the number of modules is one and "Start I/O No." is outside 
the range, its maximum value is set. If the number of 
modules is two, "Start I/O No." is set starting from 0000.

• The IP address setting of "Network Operation Settings" for 
CC IE Field (Master Station) is deleted.

  

CC-Link • If "H/W Test" or "Loop Test" is set to "Mode", the setting is 
deleted.   
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Appendix 10.3 Restrictions when changing to Q00U, Q00UJ, Q01U, or 
Q02U

The following tables show the restrictions applied when changing a programmable controller series/
type to Q00U, Q00UJ, Q01U, or Q02U.

■ Common restrictions when changing to Q00U, Q00UJ, Q01U, or Q02U

Table App.10.3-1 
: With restrictions

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

Remote Password • Any existing settings are cleared.   

PLC Parameter – – – –

I/O Assignment

• If a multiple CPU is set to "Type", it is deleted and closed up.
• If a value which exceeds the maximum base number for the 

changed programmable controller type is set, the exceeding 
base settings are deleted.

  

Multiple CPU • If the number of multiple CPUs exceeds the allowable 
number, the settings are set to default.   

Network Parameter – – – –

Ethernet

• When changing to Q02U, the third and later Ethernet 
modules in the module settings are deleted.

• When changing to Q00UJ/Q00U/Q01U, the second and later 
Ethernet modules in the module setting are deleted.

  

MELSECNET/10(H), 
CC-Link IE Controller 
Network

• When changing to Q02U, the third and later modules out of 
total of MELSECNET/10(H) and CC-Link IE Controller 
Network modules are deleted.

• When changing to Q00UJ/Q00U/Q01U, the second and later 
modules out of total of MELSECNET/10(H) and CC-Link IE 
Controller Network modules are deleted.

  

CC-Link

• When changing to Q02U, the fifth and later modules are 
deleted.

• When changing to Q00UJ/Q00U/Q01U, the third and later 
modules are deleted.

  
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■ Changing from High Performance model QCPU

Table App.10.3-2 
: With restrictions

■ Changing from QnUD(H)CPU

Table App.10.3-3 
: With restrictions

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

Program – – – –

Sequential Function 
Chart

• The property settings "SFC Program Type Setting", "Periodic 
Execution Block", "Act at Block Multi-Activated", and "Act at 
Step Multi-Activated" are deleted.

  

PLC Parameter – – – –

PLC System
• If the constant scan time is set in the PLC RAS setting, 

"Execute it while waiting for constant scan setting" is set to 
the service processing setting in the PLC System setting.

  

Program

• If the number of programs exceeds the allowable number, 
the exceeding settings are deleted.

• If "Low Speed" is set to "Execute Type" in the Program 
setting, it is changed to "Standby".

  

Boot File • If "Standard ROM" is set to "Transfer from", it is changed to 
"Memory Card (ROM)". (Q02U only)   

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

Program
• If "Convert motion dedicated sequence instruction" is 

selected, D.instructions are converted to S.instructions.
(Except for Q00UJ. Appendix 11)

 – –

PLC Parameter – – – –

PLC File
• If "Capacity" exceeds 16K points in "File used for SP.DEVST/

S.DEVLD Instruction", the setting is set to 16K points for 
Q02U, and 1K points for Q00U, Q00UJ, and Q01U.

  

Program • If the number of programs exceeds the allowable number, 
the settings are set to default.   

Device • If the points exceeding 8K points are specified for S device, 
the setting is set to 8K points.   
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■ Changing from QnUDE(H)CPU

Table App.10.3-4 
: With restrictions

■ Changing from High-speed Universal model QCPU

Table App.10.3-5 
 : With restrictions

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

Program
• If "Convert motion dedicated sequence instruction" is 

selected, D.instructions are converted to S.instructions.
(Except for Q00UJ. Appendix 11)

 – –

PLC Parameter – – – –

PLC System
• If a device that exceed the range of the Device setting is set 

to "Latch Data Backup Operation Valid Contact", the setting 
is deleted.

  

PLC File
• If the capacity exceeds 16K points in "File used for 

SP.DEVST/S.DEVLD Instruction", the setting is set to 16K 
points for Q02U, and 1K points for Q00U, Q00UJ, and Q01U.

  

Program • If the number of programs exceeds the allowable number, 
the settings are set to default.   

Device • If the points exceeding 8K points are specified for S device, 
the setting is set to 8K points.   

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

Program
• If "Convert motion dedicated sequence instruction" is 

selected, D.instructions are converted to S.instructions.
(Except for Q00UJ.Appendix 11)

 – –

Remote Password • Any existing settings are cleared.   

PLC Parameter – – – –

PLC System
• If a device that exceed the range of the Device setting is set 

to "Latch Data Backup Operation Valid Contact", the setting 
is deleted.

  

PLC File
• If the capacity exceeds 16K points in "File used for 

SP.DEVST/ S.DEVLD Instruction", the setting is set to 16K 
points for Q02U, and 1K points for Q00U, Q00UJ, and Q01U.

  

Program • If the number of programs exceeds the allowable number, 
the settings are set to default.   

Device

• If the value exceeds the capacity of changed programmable 
controller type is set for "File Register Extended Setting", the 
maximum value is set and all points are set as file register 
(ZR(R)). The setting of the latch range is cleared.

• If the points exceeding 8K points are specified for S device, 
the setting is set to 8K points.

  
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■ Changing from Redundant CPU

Table App.10.3-6 
: With restrictions

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

Program – – – –

Sequential Function 
Chart

• The property settings "SFC Program Type Setting", "Periodic 
Execution Block", "Act at Block Multi-Activated", and "Act at 
Step Multi-Activated" are deleted.

  

PLC Parameter – – – –

PLC System
• If the constant scan time is set in the PLC RAS setting, 

"Execute it while waiting for constant scan setting" is set to 
the service processing setting in the PLC System setting.

  

Program • If the number of programs exceeds the allowable number, 
the exceeding settings are deleted.   

Boot File • If "Standard ROM" is set to "Transfer from", it is changed to 
"Memory Card (ROM)".   

I/O Assignment
• Settings on the slot 0 are deleted.
• If any slot after the slot 1 is set, "Empty" is set for "Type" and 

"0 Point" is set for "Points" on the slot 0.
  

Network Parameter – – – –

Ethernet • "Ethernet (Main Base)" or "Ethernet (Extension Base)" is 
changed to "Ethernet".   

CC-Link • "Master station (Extension Base)" is changed to "Master 
Station".   
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■ Changing from Process CPU

Table App.10.3-7 
: With restrictions

■ Changing from Basic model QCPU

Table App.10.3-8 
: With restrictions

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

Program – – – –

Sequential Function 
Chart

• The property settings "SFC Program Type Setting", "Periodic 
Execution Block", "Act at Block Multi-Activated", and "Act at 
Step Multi-Activated" are deleted.

  

PLC Parameter – – – –

PLC System
• If the constant scan time is set in the PLC RAS setting, 

"Execute it while waiting for constant scan setting" is set to 
the service processing setting in the PLC System setting.

  

Program

• If the number of programs exceeds the allowable number, 
the exceeding settings are deleted.

• If "Low Speed" is set to "Execute Type" in the Program 
setting, it is changed to "Standby".

  

Boot File • If "Standard ROM" is set to "Transfer from", it is changed to 
"Memory Card (ROM)".   

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

PLC Parameter – – – –

PLC File

• When changing from Q00 or Q01 to other than Q00UJ, "Use 
the following file" is selected and "Corresponding Memory: 
Standard RAM", "File Name: MAIN", and "Capacity: 64K 
Points" are set in the File Register setting.

• When changing from Q00 or Q01 to Q00UJ, "Not Used" is 
selected in the File Register setting.

  

Device/Label Automatic-
Assign Setting

• When changing from Q00 or Q01 to Q00UJ, the default value 
is set. –  



Appendix 10  Restrictions When Changing Programmable Controller Type

Appendix 10.3  Restrictions when changing to Q00U, Q00UJ, Q01U, or Q02U App - 115

17

O
P

E
R

A
TI

N
G

 
PR

O
G

R
A

M
M

AB
LE

 
C

O
N

TR
O

LL
E

R
 C

P
U

18

DI
AG

NO
SI

NG
 

PR
OG

RA
M

M
AB

LE
 

CO
NT

RO
LL

ER
 S

TA
TU

S

19

SI
M

U
LA

TI
N

G
 

O
PE

R
AT

IO
N

S 
O

F 
EX

TE
R

N
AL

 D
EV

IC
ES

20

P
R

IN
TI

N
G

21

S
E

TT
IN

G
 O

P
TI

O
N

S

22

U
S

IN
G

 L
IB

R
A

R
IE

S

A

A
PP

E
N

D
IX

I

IN
D

EX

■ Changing from LCPU

Table App.10.3-9 
: With restrictions

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

Remote Password

• When changing from L02/L02-P to Q00U or Q01U, the 
remote password set for the built-in Ethernet of CPU module 
is cleared.

• When changing from L02/L02-P or L02S to Q00U or Q01U, 
the following settings are set.
• The settings of LJ71C24 are replaced to the settings of 

QJ71C24/CMO.
• The settings of LJ71E71 are replaced to the settings of 

QJ71E71.

  

PLC Parameter – – – –

PLC System

• If "Start I/O No." in the interrupt pointer setting of the 
intelligent function module setting is outside the range, the 
setting is deleted.

• When changing to Q00UJ, if the number of points is outside 
the range, its maximum point is set.

  

PLC File

• When changing to Q00U, Q00UJ, or Q01U, if an item other 
than "Program Memory" or "Standard ROM" is set to 
"Corresponding Memory" in the initial device value setting, it 
is changed to "Program Memory".

• When changing to Q00U, Q00UJ, or Q01U, if the capacity 
exceeds 1K points in "File used for SP.DEVST/S.DEVLD 
Instruction", the setting is set to 1K point.

• When changing from L06, L26, or L26-BT/L26-PBT to Q02U, 
if the capacity exceeds 16K points in "File used for 
SP.DEVST/ S.DEVLD Instruction", the setting is set to 16K 
points.

  

PLC RAS

• When changing to Q00UJ, "System Memory" is set to 
"Corresponding Memory".

• When changing to Q00U, Q00UJ, or Q01U, if the number of 
samplings is outside the range, its maximum number is set.

• When changing to Q00UJ, if the number of revisions is 
outside the range, its maximum number is set. If the number 
of revisions is less than '40', '40' is set.

  

Program • If the number of programs exceeds the allowable number, 
the exceeded programs are deleted.   

I/O Assignment • Settings of "Built-in I/O Function Setting" and "Built-in CC-
Link Setting" are deleted.   
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Network Parameter – – – –

CC-Link IE Field 
Network

• If the number of modules is one and "Start I/O No." is outside 
the range, its maximum value is set. If the number of 
modules is two, "Start I/O No." is set starting from 0000.

• The IP address setting of "Network Operation Settings" for 
CC IE Field (Master Station) is deleted.

  

CC-Link

• If "H/W Test" or "Loop Test" is set to "Mode", the setting is 
deleted.

• When changing to Q00UJ, or when changing from L06, L26, 
or L26-BT/L26-PBT, if the number of modules is one and 
"Start I/O No." is outside the range, its maximum value is set. 
If the number of modules is two or more and the start I/O 
number is outside the range, "Start I/O No." is set starting 
from 0000.

• When changing from L06, L26, or L26-BT/L26-PBT, if the 
number of slots exceeds the maximum number of slots of the 
changed programmable controller type, the exceeded setting 
is deleted.

  

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels
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Appendix 10.4 Restrictions when changing to QnUDE(H)CPU

The following tables show the restrictions applied when changing a programmable controller series/
type to QnUDE(H)CPU.

■ Changing from High Performance model QCPU

Table App.10.4-1 
: With restrictions

■ Changing from Q00U, Q00UJ, Q01U, or Q02U

Table App.10.4-2 
: With restrictions

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

Program
• If "Convert motion dedicated sequence instruction" is 

selected, S.instructions are converted to D.instructions.
(Appendix 11)

 – –

Sequential Function 
Chart

• The property settings "SFC Program Type Setting", "Periodic 
Execution Block", "Act at Block Multi-Activated" and "Act at 
Step Multi-Activated" are deleted.

  

PLC Parameter – – – –

PLC System
• If the constant scan time is set in the PLC RAS setting, 

"Execute it while waiting for constant scan setting" is set to 
the service processing setting in the PLC System setting.

  

Program • If "Low speed" is set to "Execute Type" in the Program 
setting, it is changed to "Standby".   

Boot File • If "Standard ROM" is set to "Transfer from", it is changed to 
"Memory Card (ROM)".   

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

Program

• A series-compatible SM/SD devices (SM/SD1000 to SM/
SD1255) are changed to the corresponding devices for Q 
series.

• If "Convert motion dedicated sequence instruction" is 
selected, S.instructions are converted to D.instructions. 
(Appendix 11)

 – –

Remote Password • Any existing settings are cleared.   
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■ Changing from High-speed Universal model QCPU

Table App.10.4-3 
 : With restrictions

■ Changing from Redundant CPU

Table App.10.4-4 
: With restrictions

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

PLC Parameter – – – –

Device

• If the value exceeds the capacity of changed programmable 
controller type is set for "File Register Extended Setting", the 
maximum value is set and all points are set as file register 
(ZR(R)). The setting of the latch range is cleared.

  

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

Program – – – –

Sequential Function 
Chart

• The property settings "SFC Program Type Setting", "Periodic 
Execution Block", "Act at Block Multi-Activated", and "Act at 
Step Multi-Activated" are deleted.

  

PLC Parameter – – – –

PLC System
• If the constant scan time is set in the PLC RAS setting, 

"Execute it while waiting for constant scan setting" is set to 
the service processing setting in the PLC System setting.

  

Boot File • If "Standard ROM" is set to "Transfer from", it is changed to 
"Memory Card (ROM)".   

I/O Assignment
• Settings on the slot 0 are deleted.
• If any slot after the slot 1 is set, "Empty" is set for "Type" and 

"0 Point" is set for "Points" on the slot 0.
  

Network Parameter – – – –

Ethernet • "Ethernet (Main Base)" or "Ethernet (Extension Base)" is 
changed to "Ethernet".   

CC-Link • "Master station (Extension Base)" is changed to "Master 
Station".   
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■ Changing from Process CPU

Table App.10.4-5 
: With restrictions

■ Changing from Basic model QCPU

Table App.10.4-6 
: With restrictions

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

Program
• If "Convert motion dedicated sequence instruction" is 

selected, S.instructions are converted to D.instructions.
(Appendix 11)

 – –

Sequential Function 
Chart

• The property settings "SFC Program Type Setting", "Periodic 
Execution Block", "Act at Block Multi-Activated", and "Act at 
Step Multi-Activated" are deleted.

  

PLC Parameter – – – –

PLC System
• If the constant scan time is set in the PLC RAS setting, 

"Execute it while waiting for constant scan setting" is set to 
the service processing setting in the PLC System setting.

  

Program • If "Low Speed" is set to "Execute Type" in the Program 
setting, it is changed to "Standby".   

Boot File • If "Standard ROM" is set to "Transfer from", it is changed to 
"Memory Card (ROM)".   

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

Program
• If "Convert motion dedicated sequence instruction" is 

selected, S.instructions are converted to D.instructions.
(Except for Q00J. Appendix 11)

 – –

PLC Parameter – – – –

PLC File

• When changing from Q00 or Q01, "Use the following file" is 
selected and "Corresponding Memory: Standard RAM", "File 
Name: MAIN", and "Capacity: 64K Points" are set in the file 
register setting.

  
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■ Changing from LCPU

Table App.10.4-7 
: With restrictions

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

Remote Password

• When changing from L02/L02-P or L02S, any existing 
settings are cleared.

• When changing from L06, L26, or L26-BT/L26-PBT, the 
following settings are set.
• The settings of the built-in Ethernet are replaced to the 

settings appropriate for the changed programmable 
controller type.

• The settings of LJ71C24 are replaced to the settings of 
QJ71C24/CMO.

• The settings of LJ71E71 are replaced to the settings of 
QJ71E71.

  

PLC Parameter – – – –

I/O Assignment • Settings of "Built-in I/O Function Setting" and "Built-in CC-
Link Setting" are deleted.   

Network Parameter – – – –

CC-Link IE Field 
Network

• If the number of modules is one and "Start I/O No." is outside 
the range, its maximum value is set. If the number of 
modules is two, "Start I/O No." is set starting from 0000.

  

CC-Link • If "H/W Test" or "Loop Test" is set to "Mode", the setting is 
deleted.   
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Appendix 10.5 Restrictions when changing to High-speed Universal 
model QCPU

The following tables show the restrictions applied when changing a programmable controller series/
type to High-speed Universal model QCPU.

■ Changing from High Performance model QCPU

Table App.10.5-1 
 : With restrictions

■ Changing from Q00U, Q00UJ, Q01U, or Q02U

Table App.10.5-2 
 : With restrictions

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

Program
• If "Convert motion dedicated sequence instruction" is 

selected, S.instructions are converted to D.instructions. 
(Appendix 11)

 – –

Sequential Function 
Chart

• The property settings of "SFC Program Type Setting", 
"Periodic Execution Block", and "Act at Step Multi-Activated" 
are deleted.

  

PLC Parameter – – – –

PLC System
• If the constant scan time is set in the PLC RAS setting, 

"Execute it while waiting for constant scan setting" is set to 
the service processing setting in the PLC System setting.

  

Program • If "Low speed" is set to "Execute Type" in the Program 
setting, it is changed to "Standby".   

Boot File • The setting of "Transfer From" is set to "Memory Card (SD)".   

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

Program

• A series-compatible SM/SD devices (SM/SD1000 to SM/ 
SD1255) are changed to the corresponding devices for Q 
series.

• If "Convert motion dedicated sequence instruction" is 
selected, S.instructions are converted to D.instructions. 
(Appendix 11)

 – –

Remote Password • Any existing settings are cleared.   
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■ Changing from Redundant CPU

Table App.10.5-3 
 : With restrictions

■ Changing from Process CPU

Table App.10.5-4 
 : With restrictions

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

Program – – – –

Sequential Function 
Chart

• The property settings of "SFC Program Type Setting", 
"Periodic Execution Block", and "Act at Step Multi-Activated" 
are deleted.

  

PLC Parameter – – – –

PLC System
• If the constant scan time is set in the PLC RAS setting, 

"Execute it while waiting for constant scan setting" is set to 
the service processing setting in the PLC System setting.

  

Boot File • The setting of "Transfer From" is set to "Memory Card (SD)".   

I/O Assignment
• Settings on the slot 0 are deleted.
• If any slot after the slot 1 is set, "Empty" is set for "Type" and 

"0 Point" is set for "Points" on the slot 0.
  

Network Parameter – – – –

Ethernet • "Ethernet (Main Base)" or "Ethernet (Extension Base)" is 
changed to "Ethernet".   

CC-Link • "Master station (Extension Base)" is changed to "Master 
Station".   

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

Program
If "Convert motion dedicated sequence instruction" is selected, 
S.instructions are converted to D.instructions. 
(Appendix 11)

 – –

Sequential Function 
Chart

• The property settings of "SFC Program Type Setting", 
"Periodic Execution Block", and "Act at Step Multi-Activated" 
are deleted.

  

PLC Parameter – – – –

PLC System
• If the constant scan time is set in the PLC RAS setting, 

"Execute it while waiting for constant scan setting" is set to 
the service processing setting in the PLC System setting.

  

Program • If "Low Speed" is set to "Execute Type" in the Program 
setting, it is changed to "Standby".   

Boot File • "Transfer from" is set to "Memory Card (SD)".   
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■ Changing from Basic model QCPU

Table App.10.5-5 
 : With restrictions

■ Changing from LCPU

Table App.10.5-6 
 : With restrictions

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

Remote Password
If "Convert motion dedicated sequence instruction" is selected, 
S.instructions are converted to D.instructions.
(Except for Q00J.Appendix 11)

 – –

PLC Parameter – – – –

PLC File

• When changing from Q00 or Q01, "Use the following file" is 
selected and "Corresponding Memory: Standard RAM", "File 
Name: MAIN", and "Capacity: 64K Points" are set in the file 
register setting.

  

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

Remote Password

• When changing from L02/L02-P or L02S, any existing 
settings are cleared.

• When changing from L06, L26, or L26-BT/L26-PBT, the 
following settings are set.
• The settings of the built-in Ethernet are replaced to the 

settings appropriate for the changed programmable 
controller type.

• The settings of LJ71C24 are replaced to the settings of 
QJ71C24/CMO.

• The settings of LJ71E71 are replaced to the settings of 
QJ71E71.

  

PLC Parameter – – – –

I/O Assignment • Settings of "Built-in I/O Function Setting" and "Built-in CC-
Link Setting" are deleted.   

Network Parameter – – – –

CC-Link IE Field 
Network

• If the number of modules is one and "Start I/O No." is outside 
the range, its maximum value is set. If the number of 
modules is two or more, "Start I/O No." is set starting from 
0000.

  

CC-Link • If "H/W Test" or "Loop Test" is set to "Mode", the setting is 
deleted.   
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Appendix 10.6 Restrictions when changing to Redundant CPU

The following tables show the restrictions applied when changing a programmable controller series/
type to Redundant CPU.

■ Common restrictions when changing to Redundant CPU

Table App.10.6-1 
: With restrictions

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

Program – – – –

Ladder

• A series-compatible SM/SD devices (SM/SD1000 to 
SM/SD1255) are changed to the corresponding devices for Q 
series.

• Unsupported instructions are changed to the OUT 
instructions.

  

PLC Parameter – – – –

I/O Assignment

• Settings on the slot 0 are deleted.
• "Redundant" is set for "Type" and "0 Point" is set for "Points" 

on the slot 0. Note that, if the slot 0 is set, "Type" of the slot 0 
on the Switch Setting for I/O and Intelligent Function Module 
screen and the Intelligent Function Module Detailed Setting 
screen is set to "Empty".

  

Network Parameter – – – –

Ethernet

• "Ethernet" is changed to "Ethernet (Main Base)".
• Set a number (system A station number + 1) for the system B 

station number. If the system A station number is 64, set 1.
• Assign the IP address as indicated below according to the 

address of system A.
• If the address of system A is 255.255.255.255, assign the 

same address to the system B.
• If the address of system A is 0.0.0.255 or 

255.255.255.254, assign 192.0.1.254 to the system B.
• If the address of system A is *.*.*.254, assign *.*.*.253 to 

the system B. (*.*.*. is the same numerical string for 
system A and B.)

• If the address of system A is *.*.*.255, assign *.*.*.254 to 
the system B. (*.*.*. is the same numerical string for 
system A and B.)

• If the address of system A is other than any of the above 
addresses, assign the address (4th number of system A 
address + 1) to the system B.

  

CC-Link IE Controller 
Network

• If the station number is 64, 63 is set. If 63 is set on the higher 
number side in the network range assignment setting, 
"Disable" is set for "Pairing".

  

CC-Link • "Master Station" is changed to "Master station (Extension 
Base)".   
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■ Changing from High-speed Universal model QCPU

Table App.10.6-2 
 : With restrictions

■ Changing from Process CPU

Table App.10.6-3 
: With restrictions

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

Remote Password • Any existing settings are cleared.   

PLC Parameter – – – –

Device

• If the value exceeds the capacity of changed programmable 
controller type is set for "File Register Extended Setting", the 
maximum value is set and all points are set as file register 
(ZR(R)). The setting of the latch range is cleared.

  

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

PLC Parameter – – – –

PLC RAS
• If the value of "Capacity to be checked at one time" under 

"Memory Check" exceeds the maximum value, set the 
maximum value.

  

Program

• If "Low Speed" is set to "Execute Type" in the Program 
setting, it is changed to "Standby".

• If the number of programs exceeds the allowable number, 
the exceeding settings are deleted.

  
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Appendix 10.7 Restrictions when changing to Process CPU

The following tables show the restrictions applied when changing a programmable controller series/
type to Process CPU.

■ Common restrictions when changing to Process CPU

Table App.10.7-1 
: With restrictions

■ Changing from High-speed Universal model QCPU

Table App.10.7-2 
 : With restrictions

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

PLC Parameter – – – –

Program • If the number of programs exceeds the allowable number, 
the exceeding settings are deleted.   

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

Remote Password • Any existing settings are cleared.   

PLC Parameter – – – –

Device

• If the value exceeds the capacity of changed programmable 
controller type is set for "File Register Extended Setting", the 
maximum value is set and all points are set as file register 
(ZR(R)). The setting of the latch range is cleared.

  
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■ Changing from Redundant CPU

Table App.10.7-3 
: With restrictions

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

PLC Parameter – – – –

PC RAS
• If the value of "Capacity to be checked at one time" under 

"Memory Check" exceeds the maximum value, set the 
maximum value.

  

I/O Assignment
• Settings on the slot 0 are deleted.
• If any slot after the slot 1 is set, "Empty" is set for "Type" and 

"0 Point" is set for "Points" on the slot 0.
  

Network Parameter – – – –

Ethernet • "Ethernet (Main Base)" or "Ethernet (Extension Base)" is 
changed to "Ethernet".   

CC-Link • "Master station (Extension Base)" is changed to "Master 
Station".   
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Appendix 10.8 Restrictions when changing to High Performance 
model QCPU

The following tables show the restrictions applied when changing a programmable controller series/
type to High Performance model QCPU.

■ Changing from Universal model QCPU

Table App.10.8-1 
: With restrictions

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

Program

• If "Convert motion dedicated sequence instruction" is 
selected, D.instructions are converted to S.instructions.
(Except for Q00U, Q00UJ, Q01U, and Q02U. 
Appendix 11)

 – –

Device comment Bit-specified word device comments are deleted.   

Remote Password Only the settings of Built-in Ethernet type CPU are cleared.   

PLC Parameter – – – –

PLC System
• The setting value of "High Speed" in the timer limit setting is 

rounded up to the range 0.1 to 100ms.
(Example: 0.01ms → 0.1ms)

  

PLC File • If the capacity of the file register exceeds 1019K points, the 
setting is set to 1018K points.   

Program
• When changing to Q02, Q02H, or Q06H, the Program setting 

and file usability setting for programs exceed the supported 
program number are deleted.

  

Device • 8K is specified for S device.   

Network Parameter – – – –

Ethernet
• In the news setting in the E-mail setting, condition devices 

outside the device range in the changed programmable 
controller type are deleted.

  

CC-Link IE Controller 
Network

• The third and later CC-Link IE Controller Network modules in 
the module setting are deleted.

• Modules whose station numbers are set in programs 
("Specify station No. by program") are deleted.

• When "Total stations" is 65 or more, 64 is set.
• The 65th and later settings are deleted in the network range 

assignment setting.
• The 65th and later I/O master stations are deleted in the LX/

LY setting in the network range assignment setting.
• When '0800' or larger is specified for "Start" of SB/SW in the 

PLC side device range in the refresh parameters setting, the 
specified range is deleted. When '0800' or larger is specified 
for "End" of SB/SW, it is replaced to '07FF'. Devices out of 
the range are also deleted.

• The settings of "Network Operation Settings" are deleted.

  

MELSECNET/10(H)

• When '0800' or larger is specified for "Start" of SB/SW in the 
PLC side device range in the refresh parameters setting, the 
specified range is deleted. When '0800' or larger is specified 
for "End" of SB/SW, it is replaced to '07FF'. Devices out of 
the range are also deleted.

  



Appendix 10  Restrictions When Changing Programmable Controller Type

Appendix 10.8  Restrictions when changing to High Performance model QCPU App - 129

17

O
P

E
R

A
TI

N
G

 
PR

O
G

R
A

M
M

AB
LE

 
C

O
N

TR
O

LL
E

R
 C

P
U

18

DI
AG

NO
SI

NG
 

PR
OG

RA
M

M
AB

LE
 

CO
NT

RO
LL

ER
 S

TA
TU

S

19

SI
M

U
LA

TI
N

G
 

O
PE

R
AT

IO
N

S 
O

F 
EX

TE
R

N
AL

 D
EV

IC
ES

20

P
R

IN
TI

N
G

21

S
E

TT
IN

G
 O

P
TI

O
N

S

22

U
S

IN
G

 L
IB

R
A

R
IE

S

A

A
PP

E
N

D
IX

I

IN
D

EX

■ Changing from Redundant CPU

Table App.10.8-2 
: With restrictions

■ Changing from Process CPU

Table App.10.8-3 
: With restrictions

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

PLC Parameter – – – –

Program • If the number of programs exceeds the allowable number, 
the exceeding settings are deleted.   

I/O Assignment
• Settings on the slot 0 are deleted.
• If any slot after the slot 1 is set, "Empty" is set for "Type" and 

"0 Point" is set for "Points" on the slot 0.
  

Network Parameter – – – –

Ethernet • "Ethernet (Main Base)" or "Ethernet (Extension Base)" is 
changed to "Ethernet".   

CC-Link • "Master station (Extension Base)" is changed to "Master 
Station".   

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

PLC Parameter – – – –

Program

• If "Low Speed" is set to "Execute Type" in the Program 
setting, it is changed to "Standby".

• If the number of programs exceeds the allowable number, 
the exceeding settings are deleted.

  
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■ Changing from Basic model QCPU

Table App.10.8-4 
: With restrictions

■ Changing from LCPU

Table App.10.8-5 
: With restrictions

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

PLC Parameter – – – –

PLC File

• When changing from Q00 or Q01, "Use the following file" is 
selected and "Corresponding Memory: Standard RAM", "File 
Name: MAIN", and "Capacity: 64K Points" are set in the file 
register setting.

  

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

Device comment Bit-specified word device comments are deleted.   

Remote Password

• When changing from L02/L02-P or L02S, any existing 
settings are cleared.

• When changing from L06, L26, or L26-BT/L26-PBT, the 
following settings are set.
• The settings of the built-in Ethernet are cleared.
• The settings of LJ71C24 are replaced to the settings of 

QJ71C24/CMO.
• The settings of LJ71E71 are replaced to the settings of 

QJ71E71.

  

PLC Parameter – – – –

Boot File

• When changing from L02/L02-P, L06, L26, or L26-BT/L26- 
PBT, if 'Symbolic Information' is set to "Type", the setting is 
deleted. If "Standard ROM" is set to "Transfer To", it is 
changed to "Program Memory".

  

Program • If the number of programs exceeds the allowable number, 
the exceeded programs are deleted.   

I/O Assignment • Settings of "Built-in I/O Function Setting" and "Built-in CC-
Link Setting" are deleted.   

Network Parameter – – – –

CC-Link • If "H/W Test" or "Loop Test" is set to "Mode", the setting is 
deleted.   
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Appendix 10.9 Restrictions when changing to Basic model QCPU

The following tables show the restrictions applied when changing a programmable controller series/
type to Basic model QCPU.

■ Common restrictions when changing to Basic model QCPU

Table App.10.9-1 
: With restrictions

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

Program • When changing to Q00J, file registers (R/ZR) are changed to 
SD999.  – –

Device Initial Value

• If the name of the device initial value data is other than 
'MAIN', the file is deleted.

• If the setting exceeds the editable range of device initial 
values in the changed programmable controller type, the 
exceeding range is deleted.

  

Global Device Comment • Global device comments are deleted.   

Remote Password • Any existing settings are cleared.   

PLC Parameter – – – –

PLC File • If an item other than "Not Used" is set in the initial device 
value setting, it is changed to "Used".   

Device/Label Automatic-
Assign Setting

• If the Device setting or the setting for the file register capacity 
in the PLC File setting in the PLC parameter is changed, the 
default value is set.

–  
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■ Changing from High Performance model QCPU

Table App.10.9-2 
: With restrictions

■ Changing from Universal model QCPU

Table App.10.9-3 
: With restrictions

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

Program – – – –

Ladder Diagram
• If instructions not supported by the changed programmable 

controller type are used, they are deleted and displayed in 
yellow.

–  

Sequential Function 
Chart

• The property settings "SFC Program Type Setting", "Periodic 
Execution Block", "Act at Block Multi-Activated" and "Act at 
Step Multi-Activated" are deleted.

  

• The block title in the property setting is deleted.
• If device points not supported by Q00J/Q00/Q01 are used for 

"Block Information" in the property setting, the setting is 
deleted.

 – –

PLC Parameter – – – –

PLC System • The setting values of "Fixed Scan Interval" are rounded out 
to the one in "System Interrupt Settings".   

Boot File

• If "Type: Sequence", "Data Name: MAIN", "Transfer From: 
Standard ROM", and "Transfer To: Program Memory" are set 
before changing the programmable controller type, "Do boot 
from standard ROM" is selected.

  

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

Program

• If "Convert motion dedicated sequence instruction" is 
selected, D.instructions are converted to S.instructions.
(Except for Q00U, Q00UJ, Q01U, and Q02U. 
Appendix 11)

 – –

Ladder Diagram
• If instructions not supported by the changed programmable 

controller type are used, they are deleted and displayed in 
yellow.

–  

Sequential Function 
Chart

• The property setting "Act at Block Multi-Activated" is deleted.   

• The property setting "Block Setting" is deleted.
• If device points not supported by Q00J/Q00/Q01 are used, 

the setting is deleted.
 – –

Device comment Bit-specified word device comments are deleted.   

PLC Parameter – – – –

PLC System

• The setting value is rounded out to the tenth in "Timer Limit 
Setting (High Speed)".

• The setting values of "Fixed Scan Interval" are rounded out 
to the one in "System Interrupt Settings".

  

Boot File • Any specified settings are deleted.   

Device • 2K is set for S device.   
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■ Changing from Redundant CPU

Table App.10.9-4 
: With restrictions

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

Program – – – –

Ladder Diagram
• If instructions not supported by the changed programmable 

controller type are used, they are deleted and displayed in 
yellow.

–  

Sequential Function 
Chart

• The property settings "SFC Program Type Setting", "Periodic 
Execution Block", "Act at Block Multi-Activated" and "Act at 
Step Multi-Activated" are deleted.

  

• The block title in the property setting is deleted.
• If device points not supported by Q00J/Q00/Q01 are used for 

"Block Information" in the property setting, the setting is 
deleted.

 – –

PLC Parameter – – – –

PLC System • The setting values of "Fixed Scan Interval" are rounded out 
to the one in "System Interrupt Settings".   

Boot File

• If "Type: Sequence", "Data Name: MAIN", "Transfer From: 
Standard ROM", and "Transfer To: Program Memory" are set 
before changing the programmable controller type, "Do boot 
from standard ROM" is selected.

  

Program • If the number of programs exceeds the allowable number, 
the exceeding settings are deleted.   

I/O Assignment
• Settings on the slot 0 are deleted.
• If any slot after the slot 1 is set, "Empty" is set for "Type" and 

"0 Point" is set for "Points" on the slot 0.
  

Network Parameter – – – –

Ethernet • "Ethernet (Main Base)" or "Ethernet (Extension Base)" is 
changed to "Ethernet".   

CC-Link • "Master station (Extension Base)" is changed to "Master 
Station".   
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■ Changing from Process CPU

Table App.10.9-5 
: With restrictions

■ Changing from LCPU

Table App.10.9-6 
: With restrictions

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

Program – – – –

Ladder Diagram
• If instructions not supported by the changed programmable 

controller type are used, they are deleted and displayed in 
yellow.

–  

Sequential Function 
Chart

• The property settings "SFC Program Type Setting", "Periodic 
Execution Block", "Act at Block Multi-Activated" and "Act at 
Step Multi-Activated" are deleted.

  

• The block title in the property setting is deleted.
• If device points not supported by Q00J/Q00/Q01 are used for 

"Block Information" in the property setting, the setting is 
deleted.

 – –

PLC Parameter – – – –

PLC System • The setting values of "Fixed Scan Interval" are rounded out 
to the one in "System Interrupt Settings".   

Boot File

• If "Type: Sequence", "Data Name: MAIN", "Transfer From: 
Standard ROM", and "Transfer To: Program Memory" are set 
before changing the programmable controller type, "Do boot 
from standard ROM" is selected.

  

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

Device comment Bit-specified word device comments are deleted.   

PLC Parameter – – – –

PLC System

• If "Start I/O No." in the interrupt pointer setting of the 
intelligent function module setting is outside the range, the 
setting is deleted.

• When changing to Q00J, if the number of points is outside 
the range, its maximum point is set.

  

Boot File

• If "Type: Sequence", "Data Name: MAIN", "Transfer From: 
Standard ROM", and "Transfer To: Program Memory" are set 
before changing the programmable controller type, "Do boot 
from standard ROM" is selected.

  

I/O Assignment • Settings of "Built-in I/O Function Setting" and "Built-in CC-
Link Setting" are deleted.   
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Network Parameter – – – –

CC-Link

• If "H/W Test" or "Loop Test" is set to "Mode", the setting is 
deleted.

• When changing to Q00J, or when changing from L06, L26, or 
L26-BT/L26-PBT, if the number of modules is one and "Start 
I/O No." is outside the range, its maximum value is set. If the 
number of modules is two or more and the start I/O number is 
outside the range, "Start I/O No." is set starting from 0000.

• When changing from L06, L26, or L26-BT/L26-PBT, if the 
number of slots exceeds the maximum number of slots of the 
changed programmable controller type, the exceeded setting 
is deleted.

  

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels
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Appendix 10.10Restrictions when changing to LCPU

The following tables show the restrictions applied when changing a programmable controller series/
type to LCPU.

■ Common restrictions when changing to LCPU

Table App.10.10-1 
: With restrictions

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

PLC Parameter – – – –

PLC System

• If "Start I/O No." in the interrupt pointer setting of the 
intelligent function module setting is outside the range, the 
setting is deleted.

• When changing to L02/L02-P or L02S, if "Backup Start Setup 
Contact" and "Backup Start Contact" in the PLC module 
change setting are outside the range, the device settings are 
deleted.

  

PLC File

• If "Use the same file name as the program" is set in the file 
register setting, it is changed to "Not Used".

• If an item other than "Memory Card (ROM)" and "Standard 
ROM" is set to "Corresponding Memory" in the comment file 
used in a comment setting, it is changed to "Memory Card 
(SD)".

• If "Memory Card (RAM)" is set to "Corresponding Memory" in 
the initial device value setting, it is changed to "Memory Card 
(SD)".

  

Program • If "Low Speed" is set to "Execute Type" in the Program 
setting, it is changed to "Standby".   

Device

• If the capacity of the file register setting before changing the 
programmable controller type exceeds the maximum 
capacity of the setting of the changed programmable 
controller type, the following settings are set.
• The number of normal device points is set to default.
• The number of extended device points is set to the 

maximum point that can be set for file register.
• The settings for Latch (1) and Latch (2) are initialized.

  

I/O Assignment

• When changing to L02/L02-P, L02S, L06, or L26, "Type" of 
the slot 1 is set to "Built-in I/O Function", and "Points" is set 
to "16 Points". All settings of start XY are deleted.

• When changing to L26-BT/L26-PBT, "Type" of the slot 1 is 
set to "Built-in I/O Function", and "Points" is set to "32 
Points". All settings of start XY are deleted.

  

Network Parameter – – – –

Ethernet

• When changing to L02/L02-P or L02S, the second and later 
Ethernet modules in the module settings are deleted.

• When changing to L06, L26, or L26-BT/L26-PBT, the third 
and later Ethernet modules in the module settings are 
deleted.

  

CC-Link

• When changing to L02/L02-P or L02S, if the number of 
modules is one and "Start I/O No." is outside the range, its 
maximum value is set. If the number of modules is two or 
more and the start I/O number is outside the range, "Start I/ 
O No." is set starting from 0000.

  
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■ Changing from High Performance model QCPU

Table App.10.10-2 
: With restrictions

Device/Label Automatic-
Assign Setting

• If the Device setting or the setting for the file register capacity 
in the PLC File setting in the PLC parameter is changed, the 
default value is set.

–  

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

Remote Password

• When changing to L02/L02-P or L02S, any existing settings 
are cleared.

• When changing to L06, L26, or L26-BT/L26-PBT, the 
following settings are set.
• The settings of the Ethernet module are cleared.
• The settings of QJ71C24/CMO are replaced to the settings 

of LJ71C24.
• The settings of QJ71E71 are replaced to the settings of 

LJ71E71.

  

PLC Parameter – – – –

Boot File
• When changing to L02/L02-P, L06, L26, or L26-BT/L26-PBT, 

the setting of "Transfer From" in the Boot File setting is 
changed to "Memory Card (SD)".

  

PLC System • When changing to L02/L02-P or L02S, if the number of 
points is outside the range, its maximum point is set.   

Program • If the number of programs exceeds the allowable number, 
the exceeded programs are deleted.   

Network Parameter – – – –

CC-Link
• If the number of slots exceeds the maximum number of slots 

of the changed programmable controller type, the exceeded 
setting is deleted.

  
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■ Changing from QnUD(H)CPU

Table App.10.10-3 
: With restrictions

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

Remote Password

• When changing to L02/L02-P or L02S, any existing settings 
are cleared.

• When changing to L06, L26, or L26-BT/L26-PBT, the 
settings of Ethernet module are deleted. The settings of 
QJ71C24/CMO are replaced to the settings of LJ71C24.

  

PLC Parameter – – – –

Boot File
• When changing to L02/L02-P, L06, L26, or L26-BT/L26-PBT, 

the setting of "Transfer From" in the Boot File setting is 
changed to "Memory Card (SD)".

  

Device • If the points between 1K and 7K or exceeding 8K points are 
specified for S device, the setting is set to 8K points.   

PLC System • When changing to L02/L02-P or L02S, if the number of 
points is outside the range, its maximum point is set.   

PLC File

• If the file capacity of file register is outside the range, its 
maximum capacity is set, and the drive is changed to 
"Standard RAM".

• When changing to L02/L02-P, L06, L26, or L26-BT/L26-PBT, 
if "Memory Card (RAM)" is set to "Corresponding Memory" in 
the initial device value setting, it is changed to "Memory Card 
(SD)".

• When changing to L02S, if an item other than "Program 
Memory" or "Standard ROM" is set to "Corresponding 
Memory" in the initial device value setting, it is changed to 
"Standard ROM".

• When changing to L02/L02-P or L02S, if the capacity 
exceeds 16K points in "File used for SP.DEVST/S.DEVLD 
Instruction", the setting is set to 16K point.

  

Program • If the number of programs exceeds the allowable number, 
the exceeded programs are deleted.   

Network Parameter – – – –

CC-Link IE Field 
Network

• If the number of modules is one and "Start I/O No." is outside 
the range, its maximum value is set. If the number of 
modules is two, "Start I/O No." is set starting from 0000.

  

CC-Link
• If the number of slots exceeds the maximum number of slots 

of the changed programmable controller type, the exceeded 
setting is deleted.

  
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■ Changing from Q00U, Q00UJ, Q01U, or Q02U

Table App.10.10-4 
: With restrictions

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

Remote Password

• When changing from Q00U or Q01U to L02/L02-P or L02S, 
the following settings are set.
• The settings of QJ71C24/CMO are replaced to the settings 

of LJ71C24.
• The settings of QJ71E71 are replaced to the settings of 

LJ71E71.
• When changing from Q00UJ or Q02U to L02/L02-P or L02S, 

any existing settings are cleared.
• When changing to L06, L26, or L26-BT/L26-PBT, any 

existing settings are cleared.

  

PLC Parameter – – – –

Boot File
• When changing from Q02U to L02/L02-P, L06, L26, or L26- 

BT/L26-PBT, the setting of "Transfer From" in the Boot File 
setting is changed to "Memory Card (SD)".

  

Device • If the points between 1K and 8K are specified for S device, 
the setting is set to 8K points.   

PLC System

• When changing from Q00U, Q01U, or Q02U to L02/L02-P or 
L02S, if the number of points is outside the range, its 
maximum point is set.

• When changing from Q02U, if "Start I/O No." in the interrupt 
pointer setting of the intelligent function module setting is 
outside the range, the setting is deleted.

  

PLC File

• When changing from Q02U, if the file capacity of file register 
is outside the range, its maximum capacity is set, and the 
drive is changed to "Standard RAM".

• When changing from Q02U to L02/L02-P, L06, L26, or L26- 
BT/L26-PBT, if an item other than "Memory Card (ROM)" 
and "Standard ROM" is set to "Corresponding Memory" in 
the comment file used in a comment setting, it is changed to 
"Memory Card (SD)".

  

Network Parameter – – – –

CC-Link IE Field 
Network

• If the number of modules is one and "Start I/O No." is outside 
the range, its maximum value is set. If the number of 
modules is two, "Start I/O No." is set starting from 0000.

  

CC-Link

• When changing from Q02U to L02/L02-P or L02S, if the 
number of modules is one and "Start I/O No." is outside the 
range, its maximum value is set. If the number of modules is 
two or more and the start I/O number is outside the range, 
"Start I/O No." is set starting from 0000.

• When changing from Q02U to L02/L02-P or L02S, if the 
number of slots exceeds the maximum number of slots of the 
changed programmable controller type, the exceeded setting 
is deleted.

  
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■ Changing from QnUDE(H)CPU

Table App.10.10-5 
: With restrictions

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

Remote Password

• When changing to L02/L02-P or L02S, any existing settings 
are cleared.

• When changing to L06, L26, or L26-BT/L26-PBT, the 
following settings are set
• The settings of the built-in Ethernet are replaced to the 

settings appropriate for the changed programmable 
controller type.

• The settings of QJ71C24/CMO are replaced to the settings 
of LJ71C24.

• The settings of QJ71E71 are replaced to the settings of 
LJ71E71.

  

PLC Parameter – – – –

PLC System

• If a device that exceeds the range of the Device setting is set 
to "Latch Data Backup Operation Valid Contact", the setting 
is deleted.

• When changing to L02/L02-P or L02S, if the number of 
points is outside the range, its maximum point is set.

  

Boot File
• When changing to L02/L02-P, L06, L26, or L26-BT/L26-PBT, 

the setting of "Transfer From" in the Boot File setting is 
changed to "Memory Card (SD)".

  

Device • If the points between 1K and 7K or exceeding 8K points are 
specified for S device, the setting is set to 8K points.   

Built-in Ethernet Port 
Setting

• If the IP address is outside the range of 0.0.0.1 to 
223.255.255.254, the default is set.   

PLC File

• If the file capacity of file register is outside the range, its 
maximum capacity is set, and the drive is changed to 
"Standard RAM".

• When changing to L02/L02-P, L06, L26, or L26-BT/L26-PBT, 
if an item other than "Memory Card (ROM)" and "Standard 
ROM" is set to "Corresponding Memory" in the comment file 
used in a comment setting, it is changed to "Memory Card 
(SD)".

• When changing to L02/L02-P or L02S, if the capacity 
exceeds 16K points in "File used for SP.DEVST/S.DEVLD 
Instruction", the setting is set to 16K point.

  

Program • If the number of programs exceeds the allowable number, 
the exceeded programs are deleted.   

Network Parameter – – – –

CC-Link IE Field 
Network

• If the number of modules is one and "Start I/O No." is outside 
the range, its maximum value is set. If the number of 
modules is two, "Start I/O No." is set starting from 0000.

  

CC-Link
• If the number of slots exceeds the maximum number of slots 

of the changed programmable controller type, the exceeded 
setting is deleted.

  
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■ Changing from High-speed Universal model QCPU

Table App.10.10-6 
 : With restrictions

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

Remote Password

• When changing to L02/L02-P or L02S, any existing settings 
are cleared.

• When changing to L06, L26, or L26-BT/L26-PBT, the 
following settings are set.
• The settings of the built-in Ethernet are replaced to the 

settings appropriate for the changed programmable 
controller type.

• The settings of QJ71C24/CMO are replaced to the settings 
of LJ71C24.

• The settings of QJ71E71 are replaced to the settings of 
LJ71E71.

  

PLC Parameter – – – –

PLC System

• If a device that exceed the range of the Device setting is set 
to "Latch Data Backup Operation Valid Contact", the setting 
is deleted.

• When changing to L02/L02-P or L02S, if the number of 
points is outside the range, its maximum point is set.

  

Device

• If the value exceeds the capacity of changed programmable 
controller type is set for "File Register Extended Setting", the 
maximum value is set and all points are set as file register 
(ZR(R)). The setting of the latch range is cleared.

• If the points between 1K and 7K or exceeding 8K points are 
specified for S device, the setting is set to 8K points.

  

Built-in Ethernet Port 
Setting

• If the IP address is outside the range of 0.0.0.1 to 
223.255.255.254, the default is set.   

PLC File

• If the file capacity of file register is outside the range, its 
maximum capacity is set, and the drive is changed to 
"Standard RAM".

• When changing to L02/L02-P or L02S, if the capacity 
exceeds 16K points in "File used for SP.DEVST/S.DEVLD 
Instruction", the setting is set to 16K point.

  

Program • If the number of programs exceeds the allowable number, 
the exceeded programs are deleted.   

Network Parameter – – – –

CC-Link IE Field 
Network

• If the number of modules is one and "Start I/O No." is outside 
the range, its maximum value is set. If the number of 
modules is two or more, "Start I/O No." is set starting from 
0000.

  

CC-Link
• If the number of slots exceeds the maximum number of slots 

of the changed programmable controller type, the exceeded 
setting is deleted.

  
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■ Changing from Redundant CPU

Table App.10.10-7 
: With restrictions

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

Remote Password

• When changing to L02/L02-P or L02S, any existing settings 
are cleared.

• When changing to L06, L26, or L26-BT/L26-PBT, the 
following settings are set.
• The settings of QJ71C24/CMO are replaced to the settings 

of LJ71C24.
• The settings of QJ71E71 are replaced to the settings of 

LJ71E71.

  

PLC Parameter – – – –

Boot File • The setting of "Transfer From" in the Boot File setting is 
changed to "Memory Card (SD)".   

Program • If the number of programs exceeds the allowable number, 
the exceeding settings are deleted.   

PLC File

• When changing to L02/L02-P, L06, L26, or L26-BT/L26-PBT, 
if "Memory Card (RAM)" is set to "Corresponding Memory" in 
the initial device value setting, it is changed to "Memory Card 
(SD)".

• When changing to L02S, if an item other than "Program 
Memory" or "Standard ROM" is set to "Corresponding 
Memory" in the initial device value setting, it is changed to 
"Standard ROM".

  

Network Parameter – – – –

Ethernet • "Ethernet (Main Base)" or "Ethernet (Extension Base)" is 
changed to "Ethernet".   

CC-Link • "Master station (Extension Base)" is changed to "Master 
Station".   
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■ Changing from Process CPU

Table App.10.10-8 
: With restrictions

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

Remote Password

• When changing to L02/L02-P or L02S, any existing settings 
are cleared.

• When changing to L06, L26, or L26-BT/L26-PBT, the 
following settings are set.
• The settings of QJ71C24/CMO are replaced to the settings 

of LJ71C24.
• The settings of QJ71E71 are replaced to the settings of 

LJ71E71.

  

PLC Parameter – – – –

Boot File • The setting of "Transfer From" in the Boot File setting is 
changed to "Memory Card (SD)".   

Program • If the number of programs exceeds the allowable number, 
the exceeding settings are deleted.   

PLC File

• When changing to L02/L02-P, L06, L26, or L26-BT/L26-PBT, 
if "Memory Card (RAM)" is set to "Corresponding Memory" in 
the initial device value setting, it is changed to "Memory Card 
(SD)".

• When changing to L02S, if an item other than "Program 
Memory" or "Standard ROM" is set to "Corresponding 
Memory" in the initial device value setting, it is changed to 
"Standard ROM".

  
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■ Changing from Basic model QCPU

Table App.10.10-9 
: With restrictions

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

Remote Password • Any existing settings are cleared.   

PLC Parameter – – – –

PLC File

• When changing from Q00 or Q01, "Use the following file" is 
selected and "Corresponding Memory: Standard RAM" and 
"File Name: MAIN" are set in the file register setting.

• If "Used" is set in the initial device value setting, "Use the 
following file" is selected and "Corresponding Memory: 
Program Memory" and "File Name: MAIN" are set.

  

PLC System
• When changing from Q00 or Q01 to L02/L02-P or L02S, if 

the number of points is outside the range, its maximum point 
is set.

  

Boot File

• When changing to L02/L02-P, L06, L26, or L26-BT/L26-PBT, 
if "Do boot from standard ROM" is selected before changing 
the programmable controller type, "Type: Sequence", "Data 
Name: MAIN", "Transfer From: Memory Card (SD)", and 
"Transfer To: Program Memory" are set.

  
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Appendix 10.11Restrictions when changing between QCPU (Q mode)/
LCPU and CC IE Field head module

The following tables show the restrictions applied when changing QCPU (Q mode)/LCPU to CC IE 
Field head module and when changing communication head module to QCPU (Q mode)/LCPU.

■ Changing from QCPU (Q mode)/LCPU to CC IE Field head module

Table App.10.11-1 
: With restrictions

■ Changing from CC IE Field head module to QCPU (Q mode)/LCPU

Table App.10.11-2 
: With restrictions

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

Device Comment

• All data are deleted.  – –Device Memory

Device Initial Value

Remote Password • Any existing settings are cleared.  – –

PLC Parameter, Network 
Parameter • All parameters are set to default.  – –

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

Remote Password • Any existing settings are cleared.  – –

PLC Parameter, Network 
Parameter • All parameters are set to default.  – –
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Appendix 10.12Restrictions when changing to FXCPU (FXCPU ⇔ 
FXCPU)

The following tables show the restrictions applied when changing FXCPU to FXCPU.

Table App.10.12-1 
: With restrictions

Item Restrictions

Project type

Simple project
Structured 

projectWithout 
labels

With 
labels

Program – – – –

Ladder Diagram • Programs which exceed the program capacity of the 
changed programmable controller type are deleted.  – –

Global Device Comment • Devices not supported and these outside the range are 
deleted.   

Local Device Comment

PLC Parameter – – – –

Memory Capacity

• If the program capacity set before changing the 
programmable controller type is not supported by the 
changed programmable controller type, it is changed to the 
maximum value of the changed programmable controller 
type.

  

Ethernet Port
• When the device range set in the log record setting cannot 

be applied as it is after the programmable controller type is 
changed, the log record setting is set to default.

  

Network Parameter – – – –

CC-Link

• When the number of stations set for "Station Information 
Setting" exceeds the maximum number for the 
programmable controller type, all CC-Link parameter settings 
are set to default.

  

System label
• FX3G, FX3GC, FX3U, and FX3UC whose projects contain 

system labels cannot be changed to FX0, FX0S, FX0N, FX1, 
FXU, FX2C, FX1S, FX1N, FX1NC, FX2N, or FX2NC.

–  

Block password
• A project in which a block password with the validated setting 

for "Read-protect the execution program" exists can be used 
in FX3U and FX3UC only.

–  
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Appendix 11 Instruction Conversion Lists

The following tables show the instructions that can be converted when changing the programmable 
controller type.

Appendix 11.1 Instruction conversion for Universal model QCPU ⇔ 
CPU other than Universal model QCPU conversion

This section shows the lists of instructions which are converted based on selecting/clearing "Convert 
motion dedicated sequence instruction" when the programmable controller type of a Simple project 
(without label) is changed.

■ Instruction conversion list for conversion to Universal model QCPU

Q CPU FXFXHeadRemoteL CPU

Basic model QCPU (Except for Q00J),
High Performance model QCPU,

Process CPU,
Universal model QCPU

(Q00U, Q01U, Q02U)

Universal model QCPU
(Except for Q00U, Q00UJ, Q01U, Q02U)

Before conversion
After conversion

Selected Cleared

Motion dedicated 
instruction

S(P).SFCS D(P).SFCS S(P).SFCS

S(P).SVST D(P).SVST S(P).SVST

S(P).CHGV D(P).CHGV S(P).CHGV

S(P).CHGT D(P).CHGT S(P).CHGT

S(P).CHGA D(P).CHGA S(P).CHGA

S(P).DDWR D(P).DDWR S(P).DDWR

S(P).DDRD D(P).DDRD S(P).DDRD

S(P).GINT D(P).GINT S(P).GINT
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Appendix 11.1  Instruction conversion for Universal model QCPU ⇔ CPU other than Universal model QCPU conversion

■ Instruction conversion list for conversion from Universal model QCPU

Universal model QCPU
(Except for Q00U, Q00UJ, Q01U, Q02U)

Basic model QCPU (Except for Q00J),
High Performance model QCPU,

Process CPU,
Universal model QCPU

(Q00U, Q01U Q02U)

Before conversion
After conversion

Selected Cleared

Motion dedicated 
instruction

D(P).SFCS S(P).SFCS*1 SM1255

D(P).SVST S(P).SVST*2 SM1255

D(P).CHGV S(P).CHGV*2 SM1255

D(P).CHGT S(P).CHGT*2 SM1255

D(P).CHGA S(P).CHGA*2 SM1255

D(P).DDWR S(P).DDWR*3 SM1255

D(P).DDRD S(P).DDRD*3 SM1255

D(P).GINT S(P).GINT*4 SM1255

*1 : When the number of arguments is 2, correct the arguments after the programmable controller type is changed.
*2 : When the number of arguments is 3, correct the arguments after the programmable controller type is changed.
*3 : When a character string is used in an argument, correct the argument after the programmable controller type is changed.
*4 : When the number of arguments is 3 or more, correct the arguments after the programmable controller type is changed.
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Appendix 11.2 Instruction conversion for Redundant CPU ⇔ CPU 
other than Redundant CPU conversion

■ Instruction conversion list for conversion to Redundant CPU

The following instructions are converted to "OUT SM1255".

Description Instruction 
name

QCPU instruction

Program load PLOADP

Program unload PUNLOADP

Load + unload PSWAPP

Motion dedicated instruction

Data write to host CPU shared memory S.TO

Other CPU device data read to host CPU device S.DDRD

Host CPU device data write to other CPU device S.DDWR

Motion SFC program start request S.SFCS

Torque limit value change during operation/stop in real mode S.CHGT

Servo program start request S.SVST

Axis speed change during positioning or JOG operation S.CHGV

Current value change for stopping axis/synchronous encoder/cam axis S.CHGA

Other CPU interrupt program start request S.GINT

Display instruction
ASCII code print instruction PR

Comment print instruction PRC

Peripheral device instruction Key input from peripheral device KEY

Other convenient instruction

1-phase input up/down counter UDCNT1

2-phase input up/down counter UDCNT2

Teaching timer TTMR

Special function timer STMR

Rotary table shortest direction control ROTC

Ramp signal RAMP

Pulse density measurement SPD

Fixed cycle pulse output PLSY

Pulse width modulation PWM

Matrix input MTR

Program control instruction Program low-speed execution registration instruction PLOW
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Appendix 11.2  Instruction conversion for Redundant CPU ⇔ CPU other than Redundant CPU conversion

■ Instruction conversion list for conversion from Redundant CPU

Before conversion After conversion

Redundant CPU Basic model QCPU High Performance 
model QCPU Process CPU

Control system 
switching instruction SP.CONTSW OUT SM999 OUT SM1255

OUT SM1255
PID control instruction

PIDINIT PIDINIT PIDINIT

PIDCONT PIDCONT PIDCONT

PIDSTOP PIDSTOP PIDSTOP

PIDRUN PIDRUN PIDRUN

PIDPRMW PIDPRMW PIDPRMW

S.PIDINIT S.PIDINIT S.PIDINIT

S.PIDCONT S.PIDCONT S.PIDCONT

S.PIDSTOP S.PIDSTOP S.PIDSTOP

S.PIDRUN S.PIDRUN S.PIDRUN

S.PIDPRMW S.PIDPRMW S.PIDPRMW
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Appendix 12 Functions Added Since Previous Versions

This section shows major functions added/changed with upgrade.
For (Simple), (FB), (Structured), and (Intelligent) described in the Reference column, refer to the 
following manuals respectively.

Remote HeadQ CPU L CPU FX

(Simple) …GX Works2 Version 1 Operating Manual (Simple Project)
(FB) …GX Works2 Version 1 Operating Manual (Simple Project, Function Block)
(Structured)…GX Works2 Version 1 Operating Manual (Structured Project)
(Intelligent) …GX Works2 Version 1 Operating Manual (Intelligent Function Module)

Version Major function added/
changed Description Reference

Version 1.05F Label comment display Label comments can be displayed in Structured projects. (Structured)

Version 1.08J

Programmable controller type Q00UJ, Q00U, Q01U, Q10UDH, Q10UDEH, Q20UDH, 
Q20UDEH, and FX series are supported. –

Intelligent function module Q68TD-G-H02 is supported. –

Change PLC Type The programmable controller type can be changed from Universal 
model QCPU to High Performance model QCPU. Section 4.2.8

Verify The parts that do not match can be searched.
Section 4.2.7
Section 4.6.5
Section 12.2

Parameter

The following parameters are supported by Universal model 
QCPU.
• The CPU module can be replaces using a memory card.
• Index registers can be specified as local devices.
• The A-PLC compatibility Setting is supported.

Section 6.1.1

Twist-bus-compatible modules are supported by MELSECNET/H. Section 6.3.1

Ladder

With the easy edit function, the following functions can be 
operated by a one-step operation (menu/shortcut key).
• Draw line
• Change open/close contact
• Switch statement/note type
• Instruction partial edit (Simple)
Ladder blocks can be displayed/hidden in units of one ladder 
block.

The ladder editor and function block can be displayed 
horizontally.

The instruction help can be opened from the menu.

ST Arguments of a template can be selected one-by-one by the menu 
or shortcut key.

(Structured)
Structured Ladder The wrapping positions for printing can be checked on the 

Structured Ladder editor.

Monitoring

The program list can be monitored. Section 14.4

The interrupt program list monitor can be monitored. Section 14.5

The intelligent function modules can be monitored. Section 14.7

Debugging
The forced input/output can be registered/canceled. Section 16.2

The device test with execution condition is supported by the 
Universal model QCPU. Section 16.3

CC-Link/
CC-Link/LT Diagnostics

The screen for the CC-Link/CC-Link/LT diagnostics is modified.

Section 18.5

The CC-Link/CC-Link/LT diagnostics support the following 
functions.
• Obtain transmission speed setting
• Status logging
• Create check sheet
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Version 1.08J

System monitor The error reset function can be performed on the Module’s 
Detailed Information screen. Section 18.8

Shortcut key customize With the shortcut key customize function, shortcut keys can be 
registered arbitrarily. Section 3.2.8

Parameter The socket communication through Ethernet is supported by Built-
in Ethernet port QCPU. Section 6.1.1

FB library FB libraries are supported. Section 22.1.1
(FB)

Version 1.12N

Programmable controller type Q00J, Q00, and Q01 are supported. –

Intelligent function module Q64AD2DA and Q61LD are supported. –

Programming language

• Structured Text is supported by Simple projects (with labels) of 
QCPU (Q mode).

• Sequential Function Chart is supported by Simple projects 
(without labels) of FXCPU.

(Simple)

Project type Simple projects (with labels) are supported by FXCPU.

Navigation window The Project window is modified, and its name is changed to 
Navigation window. –

Change PLC Type
Motion dedicated instructions can be converted when the 
programmable controller type of a Simple project (without label) is 
changed.

Section 4.2.8

Print Device initial value can be printed. Chapter 20

Saving projects The project compression/decompression function is supported. Section 4.2.4

Parameter The module error history collection function for the intelligent 
function module is supported by Universal model QCPU. Section 6.1.1

Program editor The default font color of labels is changed. –

Ladder

The following instructions are supported.
• Rising pulse close instruction
• Falling pulse close instruction
• Rising pulse close branch instruction
• Falling pulse close branch instruction

(Simple)

• Simplified edit of devices/labels is supported by the Enter 
Symbol screen.

• An undefined label can be registered following an element entry 
operation.

• A list of possible candidates of instructions/labels can be 
displayed at entering elements.

• A tooltip for arguments of an instruction can be displayed at 
entering instructions.

The line statement list function is supported.

The cursor can jump to the start of the next ladder block or the 
start of the previous ladder block.

The change TC setting function is supported.

The Inline structured text function is supported.

SFC

• The SFC editor window and the Zoom editor window can be 
displayed vertically at opening the SFC window.

• An SFC block can be displayed automatically at auto scroll 
monitoring.

Version Major function added/
changed Description Reference
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Version 1.12N

ST The bookmark list function is supported.
(Structured)

Structured Ladder A list of possible candidates of instructions/labels can be 
displayed at entering elements.

All Device Display
In a ladder program or Structured Ladder program, the display of 
labels on all program editors being opened can be switched to the 
device display simultaneously.

(Simple)

Find/Replace
In all programming languages, Find String/Replace String, Find 
Device/Replace Device, Find Instruction/Replace Instruction, and 
Change Open/Close Contact are supported.

Section 10.3

Device Memory
A character string can be entered to device memory. Section 7.2.3

The FILL function is supported. Section 7.2.4

Write to PLC In a project (with labels), file sizes can be displayed/hidden on the 
Write to PLC screen. Section 12.1

Confirm Memory Size The memory size required when data is written to the 
programmable controller CPU can be calculated. Section 12.10

Monitoring Detailed information of such as an error can be confirmed from 
the Intelligent Function Module Monitor window. Section 14.7

Simulation function

The minimized display at start up of simulation is supported. Section 15.2

The saving/reading device memory/buffer memory function is 
supported.

Section 15.2.1
Section 15.2.2

The I/O system setting function is supported. Chapter 19

Scan Time Measurement The scan time measurement function is supported. Section 16.5

CC-Link IE Control 
Diagnostics The Logging screen of another station can be displayed. Section 18.3

CC-Link/
CC-Link/LT Diagnostics

• Up to 64 modules can be displayed.
• The system configuration can be output in a check sheet.

Section 18.5

System monitor The module information at time of the error occurrence can be 
displayed in the error history list. Section 18.8

Shortcut key customize User-created shortcut key settings can be registered to a 
template. Section 3.2.8

Intelligent function module 
tool

• The Q61LD two-point calibration setting of the analog module is 
supported.

• The auto tuning function of the temperature control module is 
supported.

• The preset function of the counter module is supported.
• The positioning test, wave trace, location trace, offline 

simulation, automatic command speed calculation, and 
automatic sub arc calculation of QD75 positioning module are 
supported.

• The circuit trace function of the serial communication module is 
supported.

(Intelligent)

FB library Components of the FB libraries can be imported to a project being 
edited using the function to obtain the libraries to a project.

Chapter 22
(FB)

Version Major function added/
changed Description Reference
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Version 1.15R

Parameter The function to apply the parameters of MELSOFT Navigator is 
supported. Section 6.1

Transfer setting The GOT (Ethernet) transparent mode is supported. Section 11.9.1

ST
The following instructions are supported.
• Negated rising edge instruction
• Negated falling edge instruction

(Structured)

Structured Ladder

The following contact symbols are added.
• Rising edge
• Falling edge
• Negated rising edge
• Negated falling edge

The following instructions are supported.
• Negated rising edge instruction
• Negated falling edge instruction

Global label System labels are supported. (Simple)
(Structured)

Version 1.24A

Programmable controller type L02 and L26-BT are supported. –

Intelligent function module L64AD4, L60DA4, LJ71C24, and LJ71C24-R2 are supported. (Intelligent)

Ladder

• The Inline structured text function is supported by FXCPU.
• The following functions are supported by the Inline structured 

text function.
• Verifying projects
• Verifying revisions
• Replacing character strings

Section 4.2.7
Section 4.6

Section 10.3.3

ST
• The compilation result can be displayed in list format.
• The ST control syntax templates are supported.

(Simple)

Structured Ladder
• The compilation result can be displayed in list format.
• Function blocks can be dragged and dropped from the Project 

view.
(Structured)

Saving projects A title of the change history of the project can automatically be set 
when it is overwritten. Section 4.2.3

Device List
• The number of uses of a coil which uses the device can be 

displayed.
• Devices which are used in the parameters can be indicated.

Section 10.2

Colors and fonts The color and font settings can be reset to default. Section 3.2.7

Write to PLC A project can automatically be saved after it is written to the 
programmable controller CPU. Chapter 12

Simulation function The simulation function is supported by FXCPU.
Chapter 15
Chapter 19
Appendix 2

Intelligent function module 
tools

• The offset/gain setting can be performed from the menu.
• The predefined protocol support function of the serial 

communication module is supported.
(Intelligent)

Help The detailed explanation of instructions can be opened from the 
program editor or the Function Block Selection window. –

Version Major function added/
changed Description Reference
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Version 1.31H

Programmable controller type Q50UDEH, Q100UDEH, and LJ72GF15-T2 are supported. –

Intelligent function module LD62, LD62D, LD75P4, LD75D4, and LD77MH4 are supported. (Intelligent)

Ladder In projects (with labels), the function which enables the device 
display in uncompiled state is supported. –

SFC The display format "MELSAP-L (Instruction Format)" / "MELSAP-
L (Start Conditions Format)" are supported. (Simple)

Global labels System labels are supported by LCPU. (Simple)
(Structured)

Change PLC Type
The programmable controller type of a project which contains 
intelligent function modules can be changed between 
programmable controller series.

Section 4.2.8

Parameter In the network parameter, "CC IE Field (Master Station)" and "CC 
IE Field (Local Station)" are supported by Universal model QCPU. Section 6.3

Intelligent function module 
data

• The disconnection detection mode setting and Disconnection 
detection setting value setting are supported by Q62DA-FG.

• The following settings are supported by QJ71C24N/
QJ71C24N-R2.
• The echo back permit/prohibit specification and the 

execution history option specification are supported by the 
various control specification.

• The predefined protocol function error code, the send data 
storage area, and the receive data storage area are 
supported by the auto refresh.

(Intelligent)

Cross Reference In projects (with labels), the cross reference information can be 
displayed in uncompiled state. Section 10.1

Local Device Batch Read
The function which reads local device data from the 
programmable controller CPU and saves the data on the personal 
computer is supported by Universal model QCPU.

Section 12.12

CC IE Field Diagnostics The CC-Link IE Field Network diagnostics is supported by 
Universal model QCPU. Section 18.4

Options

For QCPU (Q mode)/LCPU, the following option is added.
[Tool] ⇒ [Options] ⇒ "PLC Read/Write" ⇒ "When writing to PLC 
after a Rebuild All operation, clear the device ranges set in the 
Device/Label Auto-Assign setting to 0."

Section 12.1.7
Section 21.2

(Simple)
(Structured)

Version 1.40S

Operating environment Windows® 7 is supported. –

Programmable controller type Remote I/O module is supported. –

Ethernet adapter module 
configuration tool Ethernet adapter module configuration tool is supported. Section 17.8

Label The Read from CSV File and Write to CSV File functions are 
supported.

(Simple)
(Structured)

Device comment Bit-specified word device comments are supported by Universal 
model QCPU.

Section 9.2.1
Section 12.1.3

Ladder
The template function in the inline structured text program is 
supported. (Structured)

The drag-and-drop operation from the ladder editor is changed. Section 14.6.2

SFC "Act at Block Multi-Activated" can be set for Universal model 
QCPU. (Simple)

ST The menu title [Create Template] is changed to [Display 
Template]. (Structured)

Structured Ladder
The line connection function in "Select Mode" is supported. (Structured)

The automatic line connection function when entering elements is 
supported. (Structured)

Version Major function added/
changed Description Reference
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Version 1.40S

Compile

A compilation error does not occur when the same name is used 
for label name and data name. –

The option to check whether devices are used exceeding the 
device range assigned to labels in the data transfer instruction 
such as DMOV is added.

Section 21.2

Opening existing projects
Projects in the workspace folder/project folder which is copied or 
moved using Windows® Explorer can be forcibly opened.

Section 4.2.2

Opening projects in other 
formats

GX Developer option setting "Copy source/display source of 
reference during comment edit" is utilized to GX Works2 option 
setting: "Program Editor" ⇒ "Ladder/SFC" ⇒ "Comment" ⇒ 
"Reference of Device Comment".

Section 4.7.1

Verify

Intelligent function module parameters (initial setting, auto 
refresh), QD75/LD75 positioning module set data can be verified 
in the following verification function.
• Project verification
• Revision verification
• Programmable controller CPU data verification

Section 4.2.7
Section 4.6.5
Section 12.2

Parameter

The extended setting of step relay (S device) is supported by 
Universal model QCPU. –

"CC IE Control Ext. Mode (Control station)" and "CC IE Control 
Ext. Mode (Normal Station)" are added. –

The loopback function setting is added to the supplementary 
setting of CC-Link IE Field. –

Cross Reference The Cross Reference window can be displayed vertically. Section 10.1

Find/Replace

The focus is not moved to the editor side after executing the 
search/replace function.

Section 10.3.1
Section 10.3.2
Section 10.3.3
Section 10.3.4

The device search/replace function can be executed for indexed 
devices without canceling "Digit" or "Double Word" option. Section 10.3.1

The search function can be executed on different items when the 
devices are being displayed on the ladder editor. –

Find Device, Replace Device, Find Instruction, Replace 
Instruction, Change Open/Close Contact, and Device Batch 
Replace functions are supported by the inline structured text 
function.

Section 10.3

Online Program Change SFC block Online program change is supported by Universal 
model QCPU. Section 12.9.1

Simulation function Local device data can be read. Section 12.12

Global label System labels are supported by FX3G, FX3U, and FX3UC. (Simple)
(Structured)

Version Major function added/
changed Description Reference
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Version 1.48A

Intelligent function module QD65PD2 and LD77MH16 are supported. (Intelligent)

Navigation window

• Titles set in the property are displayed on the Navigation 
window.

• The color of the characters on the title bar is displayed in red 
when an uncompiled data exists.

Section 3.2.5

Open other project The secured steps for Online program change and the writing 
range of device comment set in GX Developer can be utilized. Section 4.7.1

Transfer setting
CC-Link IE Field Network board is supported.

Section 2.2
Section 2.3

Section 11.1

Ethernet connection between personal computer and GOT is 
supported.

Section 11.9.1
Section 11.9.2

Device comment Sample comments of input/output signals can be utilized for 
intelligent function module. Section 9.5.2

Ladder

• The number of displayed contacts in a ladder program can be 
set to 13, 17, or 21 contacts.

• For FXCPU Simple project (with labels), execution program can 
be divided into multiple programs.

(Simple)

Verify
The following functions are supported on the Verify Result screen.
• Copy data
• Write data to CSV file

Section 4.2.7

Print

The following information can be added when printing a ladder 
program.
• Device comment
• Statement/note
• Contact/coil usage destination

Section 20.8.1

The print preview and the print functions are supported on the 
Device List screen.

Section 20.9
Section 20.7

Cross reference For project without labels, a device on which the cursor is placed 
in the program editor can be searched automatically. Section 10.1

Write to PLC/Online program 
change

• 'High-speed mode' is supported when writing symbolic 
information to a programmable controller CPU.

• A default setting of target memory can be set in the option 
setting for Online program change.

Section 12.1.5

Watch window
• The automatic registration function is supported.
• The list of devices/labels registered to Watch window can be 

write to/read from CSV files.

Section 14.6.2
Section 14.6.4

PLC diagnostics
When the error jump is executed from the PLC Diagnostics 
screen, the PLC Diagnostics screen is down sized to be able to 
specify the error location in the program easily.

Section 18.1

Intelligent function module 
tool

• The monitoring function (positioning monitor) dedicated to 
QD75/LD75 positioning module is supported.

• The user protocol library function is supported for the 
predefined protocol support function.

(Intelligent)

Language selection

Characters of the following languages are not corrupted by 
selecting a project language.
• English
• Chinese (simplified characters)
• Korean

Section 3.3
Appendix 18

Version Major function added/
changed Description Reference
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Incorporation with GX 
Developer

GX Developer can be installed at the same time as installation of 
GX Works2. Appendix 14

GX Developer is used for the following functions when the 
programmable controller type is not supported by GX Works2.
• Creating a new project
• Opening a project
• Opening a project in other formats
• Creating a new project with data read from programmable 

controller CPU

Section 4.2.1
Section 4.2.2
Section 4.7.1

Intelligent function module QJ71MT91 and QJ71MB91 are supported. (Intelligent)

Ladder

Changes of function block names and deletions of function blocks 
are automatically applied to the target program. –

Changes of the function block label setting are applied to the 
target program at compilation. –

SFC
When copying and pasting SFC block data, whether to overwrite 
block data with the same block number, or to add data with 
unused block number can be selected.

–

Structured Ladder Operability of the Label Registration/Selection screen is 
improved. (Structured)

Print
The print function to batch print project data is supported. Chapter 20

The print preview and the print functions are supported on the 
Cross Reference screen. Section 10.1

Parameter In the network parameter, "CC IE Field (Master Station)" and "CC 
IE Field (Local Station)" are supported by LCPU. Section 6.3

Search/Replace

The search/replace function can be executed for digit-specified bit 
devices, devices with index setting, and devices with indirect 
specification.
Note that either a searched device or a replaced device needs to 
be a label when replacing devices. Section 10.3
Devices, instructions, strings, contacts, and coils can be searched 
from the shortcut menu by right-clicking the ladder editor or SFC 
(Zoom) editor.

The default setting for "Find In" is changed to "(Entire Project)".

Debug The debugging function can be executed during the program 
simulation. Section 16.6

CC IE Field Diagnostics
LJ71GF11-T2 is supported.

Section 18.4"Selected Station Communication Status Monitor" function is 
supported by Ethernet adapter module.

Device/label automatic-
assign setting

Multiple devices can be set in the device/label automatic assign 
setting for QCPU (Q mode) and LCPU.

(Simple)
(Structured)

Language selection

The applicability of data names and label names to be used in a 
language-changed project is checked when selecting the 
language.

–

The applicability of language of the data name in a project to 
which the data is pasted is checked when data are copied 
between projects.

–

Version Major function added/
changed Description Reference
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Version 1.62Q

Project
A project can be overwritten when a project is saved with an 
existing project name. Section 4.2.3

A project can be saved in the single file format. Section 4.2

Programmable controller type L02-P and L26-PBT are supported. –

Intelligent function module
Q64TCTTN, Q64TCRTN, Q64TCTTBWN, Q64TCRTBWN, 
L60TCTT4, L60TCTT4BW, L60TCRT4, and L60TCRT4BW are 
supported.

(Intelligent)

Comment The automatic start function which converts the language at the 
entry of device comments, statements and notes is supported. Section 21.2

Device comment When a device comment is edited in a ladder or SFC program, the 
edited information is reflected to the referred device comment. Section 9.2.2

Ladder

"Read Mode", "Write Mode", "Monitor Mode", and "Monitor (Write 
Mode)" are supported.

(Simple)

Line statements can be displayed on the Navigation window.

The initial value for the Enter HLine screen and the Delete HLine 
screen can be set to "1".

Entry or deletion of horizontal line can be stopped at the 
instruction or vertical line.

The option setting to disable the display of note on the Enter 
Symbol screen when editing a coil instruction is added.

SFC

"Read Mode", "Write Mode", "Monitor Mode", and "Monitor (Write 
Mode)" are supported.

(Simple)An SFC diagram and a Zoom editor can be tiled horizontally.

The jump step search function is added.

Structured Ladder

The display of the programming language name is changed from 
"Structured Ladder" to "Structured Ladder/FBD".

(Structured)The function to display/hide the left power rail is added.

Labels and devices assigned to labels can be displayed 
simultaneously.

Label
The program does not become in an uncompiled status even 
when information in "Comment" and "Remark" is changed.

(Simple)
(Structured)

Cells can be selected and copied on the label editor. –

Print

The following data can be batch printed.
• Cover
• PLC parameter
• Network parameter
• Structured Ladder/FBD
• Device memory
• Device initial value
• TC setting value
• Device list
• Cross reference
• Project content list
• Product information list

Chapter 20

When printing ladder programs, blank device comment lines are 
not printed in the default setting.

Parameter
The simple PLC communication setting is supported by LCPU. Section 6.1

The serial communication setting is supported by QnUD(H)CPU. Section 6.1.1

Device List

When searching for devices in a specified program, device 
comments can be entered in the device list.

Section 10.2When searching for devices in a specified program, device 
comments of devices which are not used in the program can be 
deleted.

Version Major function added/
changed Description Reference
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Search/Replace

The function to search/replace devices/labels/instructions 
downward from the top of the editor is added. Section 10.3

Data can also be searched in other programs in the project with 
the space key search function on the ladder editor. (Simple)

Write to PLC/Read from PLC Symbolic information can be written to/read from a programmable 
controller CPU with FX3U/FX3UC version 3.00 or later. Section 12.1

CC IE Field Diagnostics The configuration including CC-Link IE Field Network 
communication units can be diagnosed. Section 18.4

Block password Execution programs can be protected on FX3U/FX3UC version 
3.00 or later. Section 4.12

Intelligent Function Module 
Tool

The sensor correction function of temperature control module is 
supported. (Intelligent)

Help The MELSOFT help function is supported. Section 3.4

Version 1.64S

Product Makeup Data are supplied with two CD-ROMs. GX Works2 
Installation 
InstructionsOperation Environment Required HDD free space for the installation is changed to 2.5GB 

or more.

Intelligent Function Module QD75P1N, QD75P2N, QD75P4N, QD75D1N, QD75D2N, and 
QD75D4N are supported. (Intelligent)

Print

• Print job output can be selected.
• Print conditions for device memory data are added.
• Whether to print or not to print 'start destination block' can be 

selected on the SFC block list.
• Setting values of timer, retentive timer, and counter can be 

printed according to devices when printing TC setting values.

Chapter 20

Parameter • For LCPU, "Branch Module" can be selected for the I/O 
assignment setting on PLC parameter. Section 6.1.1

Intelligent Function Module 
Data

QD75/LD75 positioning module data can be saved to/read from 
the file. (Intelligent)

Device comment
• For LCPU, bit-specified word device comment is supported.
• Device comments can be saved to/read from the file.

Section 9.2.1
Section 12.1.3

Transfer setting A personal computer can be connected to a programmable 
controller CPU via a phone line. Section 11.10

Verify

For QCPU (Q mode)/LCPU, the following functions are supported.
• The following data can be verified when verifying projects or 

revisions.
• Device comment
• Device memory

• The following data can be verified when verifying 
programmable controller data.
• Device comment
• Device memory
• File register

Section 4.2.7
Section 4.6.5
Section 12.2

System monitor For LCPU, extension blocks can be monitored. Section 18.8

Version Major function added/
changed Description Reference
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Version 1.73B

Intelligent Function Module
• Q64ADH is supported.
• A parameter item is added for Q62HLC.

(Intelligent)

Transfer Setup

For FX3U and FX3UC, programmable controller CPU connections 
via CC-Link are supported. Section 11.3

For FXCPU, the Ethernet connection between a personal 
computer and a GOT is supported. Section 11.9

Ladder

• Ladder blocks can be pasted consecutively with incremented 
device numbers on the ladder editor.

• Ladder programs can be saved to/read from CSV files in list 
format (Simple)

SFC
• SFC blocks can be copied/pasted on the SFC block list.
• SFC diagrams can be converted in SFC block unit.

Structured Ladder
Function blocks of ladder program can be used in a Structured 
Ladder program, and function blocks of Structured Ladder 
program can be used in a ladder program.

(Structured)

Parameter

• Station information of CC-Link is displayed graphically on the 
CC-Link configuration window.

• Assignment information of CC-Link refresh devices can be 
checked easily on the Acknowledge CC-Link Device 
Assignment window.

• Default parameters can be set in batch to the PLC parameter 
and the network parameter.

Section 6.3.3
Section 6.3.5
Section 6.7

For FXCPU, the CC-Link setting is supported by the network 
parameter. Section 6.3

The I/O assignment setting and the acknowledge XY assignment 
of PLC parameter can be saved to CSV files. Section 6.6

Device comment Device comment data being displayed can be deleted in batch. Section 9.3.2

Cross reference

• For Simple projects (with labels), the time to create cross 
reference information can be reduced by selecting "Fast Find". 
Cross reference information can be created even when a 
program is uncompiled.

• Cross reference of SFC program block information is 
supported.

• Elements of instructions in which devices are used in a ladder 
program can be displayed.

Section 10.1

Device List The device points to be searched can be selected. Section 10.2

Write to PLC The number of characters of device comment to be written can be 
specified when writing data to a programmable controller CPU. Section 12.1.3

Monitoring

• The Entry Ladder Monitor function to monitor registered ladder 
blocks is supported by Simple project (without labels).

• For QCPU (Q mode)/LCPU, monitoring condition/monitoring 
stop condition can be set.

(Simple)

CC-Link/
CC-Link/LT Diagnostics • For FXCPU, the CC-Link/CC-Link/LT diagnostic is supported. Section 18.5

Write/read IC memory card 
data

• A password can be set to data when writing data to an IC 
memory card.

• Data can be written to/read from an IC memory card by 
specifying a folder.

• Symbolic information can be written to/read from an IC memory 
card.

Section 12.11.1

Options The setting to enable compilation when opening a project 
contains ST programs of GX Developer is added. Section 21.2

Merge Data Multiple ladder program data or device comment data can be 
merged and added to the project. Section 4.3.5

Intelligent function module 
data

The Setting item reduction mode can be set for the auto refresh 
parameter of temperature control. (Intelligent)

Version Major function added/
changed Description Reference
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Programmable controller type FX3GC is supported. –

Intelligent function module Q68CT, LD75P1, LD75P2, LD75D1, LD75D2, QD77MS2, 
QD77MS4, and QD77MS16 are supported. (Intelligent)

Parameter

The IP Packet Transfer setting can be set on the <<Built-in 
Ethernet Port Setting>> tab of PLC parameter. Section 6.1.1

• CC IE Field (sub-master station) is supported by Universal 
model QCPU in the network parameter.

• The IP Packet Transfer setting can be set in the network 
parameter for Built-in Ethernet port QCPU in CC-Link IE Field 
Network.

Section 6.3.1

The operation at reconnection can be set in "Network 
Configuration Settings" for Universal model QCPU when "CC-IE 
Filed (Master Station)" is selected for "Network Type".

–

Intelligent function module 
data

Positioning module data can be saved as a GX Configurator-QP 
format project file. (Intelligent)

Label
• Labels can be sorted in ascending or descending order.
• Blank rows below the last row to which the label is set on the 

label setting editor can be deleted to a single blank row.

(Simple)
(Structured)

Read from PLC
When a project, in which the setting of "Compile" under [Tool] ⇒ 
[Options] has been changed, is read from a programmable 
controller CPU, the project will not be an uncompiled project.

–

CC IE Field Diagnostics
Sub-master stations are supported. Section 18.4

The IP communication test is supported. Section 18.4.2

Version 1.87R

Toolbar Editing screens can be displayed from the toolbar in Simple 
projects. Section 3.2.2

Navigation window Tasks in a program file can be sorted in the execution order. Section 3.2.5

Open other project

• For QCPU (Q mode)/LCPU, GX Developer projects with GX 
Works2 invalid characters can be opened.

• SFC block names are set with sequential number without 
appending a program name.

• A project can be opened with the connection destination 
settings saved in the GX Developer format.

Section 4.7.1

Device Memory Device values can be set by specifying a device range on the cell Section 7.2.2

Device comment

The setting method of "Specify the reference/reflection" is 
improved. Section 9.1.1

The number of points of device comment that can be set in the 
project can be extended. Section 9.4

Applicable number of characters to be entered is limited for the 
device comment editing mode. Section 9.2.2

Find/Replace Block information set on the Property screen of SFC block can be 
searched.

(Simple)

Ladder

• Labels and devices can be displayed simultaneously.
• Detailed information of the label can be displayed with the 

tooltip when the cursor is placed on the label.
• List of instructions/labels and tooltip for instructions can be 

displayed/hide when entering an element.
• Device comments can be copied and pasted along with the 

copied elements.
• Programs in ladder block unit can be displayed/edited in the list 

format.
• The cursor position does not change when switching the mode 

to "Read Mode", "Write Mode", "Monitor Mode", or "Monitor 
(Write Mode)" in the ladder editor.

A function block can be called from a function block in the ladder 
program.

(Structured)
(FB)

Version Major function added/
changed Description Reference
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Version 1.87R

SFC

• SFC step/transition comments can be pasted along with the 
copied blocks on the SFC block list.

• Text size on the editing screen can be changed.
• The comment or the step number on the Enter SFC Symbol 

screen can be displayed as it is in selected status when 
changing the SFC symbol in MELSAP3.

(Simple)

Inline structured text The compilation result can be displayed from the shortcut menu.

ST The compilation result can be displayed from the shortcut menu.

(Structured)
Structured Ladder

• The compilation result can be displayed from the shortcut 
menu.

• The tool button to connect lines automatically is added.

Security Access authority of multiple items can be set in batch. Section 4.10.4

Block password A block password can be set for POUs in batch. Section 4.12.1

Cross Reference

• Devices set in simple PLC communication setting of PLC 
parameter can be searched.

• A search range can be specified in program file unit.
• Block start steps of SFC blocks can be searched.
• The setting to search devices other than the start device is 

added under "Find Condition" on the <<Condition Setting>> 
tab.

Section 10.1

Device List

• Devices set in simple PLC communication setting of PLC 
parameter can be searched.

• All SFC blocks are searched when an SFC program is set for 
the search location.

Section 10.2

Monitor

• The display format can be changed by the button on the 
Device/Buffer Memory Batch Monitor screen.

• Device comments of monitored devices can be displayed on 
the Device/Buffer Memory Batch Monitor screen.

Section 14.3

Devices and labels on the SFC editor window are automatically 
registered to the Watch window. Section 14.6.2

Options

The setting in which the program cache memory is checked and 
automatically fixed when a program is written to a programmable 
controller CPU is added.

Section 21.2

For FXCPU, the following option can be set.
When reading a project saved with GX Works 2 which does not 
support the following option, the item is selected.
[Tool] ⇒ [Options] ⇒ "PLC Read/Write" ⇒ "When writing to PLC 
after a Rebuild All operation, clear the device ranges set in the 
Device/Label Auto-Assign setting to 0."

Section 12.1.7
Section 21.2

(Simple)
(Structured)

Read from PLC Programs which are closed when performing the read from PLC 
function are reopened. –

Installation When upgrading GX Works2, the information of color and fonts of 
the previous version is retained. –

Version Major function added/
changed Description Reference
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Programmable controller type For Simple project (without labels), Q02PH, Q06PH, Q12PH, 
Q12PRH, Q25PH, and Q25PRH are supported. –

Intelligent Function Module QD73A1 is supported. (Intelligent)

Verify

For FXCPU, the following functions are supported.
• The following data can be verified when verifying 

programmable controller data, projects, or revisions.
• Device comment
• Device memory

Section 4.2.7
Section 4.6.5
Section 12.2

Saving projects in other 
formats

A project in GX Developer format can be saved along with the 
connection destination settings. Section 4.8

Transfer Setup For FX3G and FX3GC, a programmable controller CPU can be 
connected via CC-Link. Section 11.3

Write/read IC memory card 
data

For LCPU, projects can be saved on/loaded from SD memory 
card using the batch save/batch load function. Section 12.11.2

Print

The print function can be activated from the toolbar or the shortcut 
menu.

Chapter 20

The following data can be printed in batch.
• Redundant parameter
• Program setting
• User library content list

User libraries can be printed for the following print items.
• ST
• Structured Ladder/FBD
• FB/FUN program
• Label

For MELSAP3 and MELSAP-L, SFC block lists of Structured 
project can be printed.

Section 20.5.8
Section 20.5.9SFC program settings can be printed when "Property (SFC 

Program)" is selected under SFC Diagram Print Item for printing 
MELSAP3 or MELSAP-L.

Parameter

The following functions are added to the I/O assignment setting.
• The I/O assignment setting and the base setting can be set by 

selecting a programmable controller type, module, and module 
type.

• Intelligent function module data on the Navigation window are 
updated regarding added/deleted/changed modules.

Section 6.1.1
(Intelligent)

The editing operations (Undo/Cut/Paste) can be performed on the 
MELSECNET/CC IE/Ethernet Module Configuration screen.

Section 6.3A number of columns to be displayed on the Setting for the CC-
Link List screen can be changed to either 4 or 2 columns 
according to the option setting.

A number of rows to be displayed on the CC-Link station 
information screen can be changed to either 16 or 8 rows 
according to the option setting. Section 6.3.1
A station number can be set for local station in the CC-Link IE 
setting of a program.

The operability of the CC-Link configuration window is improved. Section 6.3.3

Label

Unused labels can be extracted and batch deleted. (Simple)

Devices assigned to structure are not cleared even when 
elements of structure are changed on the Structure Setting 
screen.

(Simple)
(Structured)

Color and Font The import and export functions are added. Section 3.2.7

Help FXCPU instruction help is supported by the GX Works2 help 
function. Section 3.4.1

Version Major function added/
changed Description Reference
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Version 1.87R

Intelligent function module 
tool Waveform output data can be created for analog module L60DA4. (Intelligent)

Structured Ladder/FBD or ST Step relay devices can be monitored. (Structured)

Global label

• The operability of system label registration/deregistration is 
improved.

• For structures registered to data type of system label, elements 
of structure can be added and comments can be edited.

• Structure array can be used for system label.

(Simple)
(Structured)

Version 1.91V

Programmable controller type
For Simple project (with labels), Process CPU (Q02PH, Q06PH, 
Q12PH, Q25PH) and Redundant CPU (Q12PRH, Q25PRH) are 
supported.

–

Toolbar All toolbars can be displayed. The display positions of toolbars 
can be maintained. Section 3.2.2

Transfer Setup For FX3G, FX3GC, FX3U, and FX3UC, a CPU can be connected via 
Ethernet adapter. Section 11.2.2

Intelligent Function Module

• Energy measuring modules (QE81WH, QE81WH4W, QE82LG, 
QE83WH4W, and QE84WH) are supported.

• The number of parameter settings for the initial setting of 
temperature control modules (Q64TCTTN, Q64TCTTBWN, 
Q64TCRTN, and Q64TCRTBWN) is added by 1.

(Intelligent)

Device comment A target memory to write data to a programmable controller CPU 
can be specified in advance. Section 12.1.6

Instruction

• For Universal model QCPU and LCPU, the data write/read 
instruction for devices targeted for auto-refresh is supported.

• For Universal model QCPU (excluding Q00UJ, Q00U, Q01U, 
and Q02U), programs with motion dedicated instructions 
(Command generation axis speed change during positioning or 
JOG operation, Present value change of stopped command 
generation axis) can be used.

–

Parameter The Ethernet adapter setting is supported by FX3G, FX3GC, FX3U, 
and FX3UC. Section 6.1.1

Network Parameter

Network configuration of CC-Link IE Field Network can be set 
graphically on the CC IE Field configuration window. Section 6.3.2

Parameter data set on the CC-Link configuration window can be 
copied. –

Global label
Duplications of device names assigned to global labels can be 
checked.

(Simple)
(Structured)

Registered system labels can be deleted. –

Ladder

• When "A-PLC Compatibility Setting" on the <<PLC System>> 
tab of PLC parameter is not selected, entries of special relays/
special registers can be checked on the Enter Symbol screen 
and the Enter List screen.

• The [Undo] operation can be performed up to 30 times when 
editing a program on the ladder editor.

• Device comments can be displayed/hidden using tooltips on the 
ladder editor. (Simple)

SFC

• The number of contacts to be displayed on a single rung can be 
changed on the SFC (Zoom) editor window.

• The window display operations of the SFC editor window and 
the Zoom editor window are linked.

• Device comments can be displayed/hidden using tooltips on the 
Zoom editor window.

Version Major function added/
changed Description Reference



App - 166

GX Works2

  APPENDIX

Version 1.91V

ST
• VAR_OUTPUT can be used for an argument of function block. (Simple)

(Structured)

• Device names, monitored values, and device comments can be 
checked using tooltips on the ST editor.

(Structured)
Structured Ladder/FBD Device comments can be checked using tooltips on the 

Structured Ladder/FBD editor.

Compile The usage of automatically assigned devices is displayed after 
programs are compiled.

(Simple)
(Structured)

Verify

Among the rows with mismatched devices in programs/program 
files of project with labels, the cursor skips the rows whose 
mismatched devices are within the range of devices automatically 
assigned to labels.

Section 4.2.7
Section 4.6.5

Cross Reference

Constant (K) and constant (H) can be specified and searched for 
devices/labels. –

• Two or more search locations can be selected.
• The search result can be displayed in the order of program 

setting.
Section 10.1

Device List
• Items (contacts, coils, etc.) can be displayed/hidden.
• Two or more search locations can be selected.

Section 10.2

The default setting for "Find In" is set as "Current window". –

Find/Replace

Devices, such as pointers, which are not related to the search 
option can be searched disregarding the option setting such as 
"Digit" and "Multiple word".

Section 10.3.1

Two or more search locations can be selected. Section 10.3

Online Program Change
For Universal model QCPU (excluding Q00UJ/Q00U/Q01UCPU)/
LCPU, the changes can be applied to the boot source after 
performing Online program change.

Section 12.9.1

Monitor ON/OFF status of device names of contacts/coils can be 
displayed with the monitoring function of ladder program. (Simple)

Sampling Trace

• CSV files can be output in the format which can be used to read 
data from GX LogViewer.

• Changes on global device comments or label comments of 
global labels/local labels are applied to device comments or 
label comments on the Sampling Trace screen.

• After data under the "Device/Label" column is edited on the 
Sampling Trace screen, the cursor moves to the next row.

• Two or more data can be selected to be copied or to change 
settings of trend graph registration on the Sampling Trace 
screen.

• When scrolling vertically on the Sampling Trace screen, the 
vertical axis information line is not scrolled.

• The cursor jumps to the specified position by entering a value 
to the cell of 'currently selected number of data acquisitions'.

• The setting to cancel the display of the confirmation message at 
the sampling trace start is applicable.

• The trace result on the Sampling Trace screen can be scrolled 
using the shortcut keys.

Section 16.4

Ethernet Diagnostics The Ethernet adapter diagnostics is supported by FX3G, FX3GC, 
FX3U, and FX3UC.

Section 18.6
Section 18.6.2
Section 18.6.3

CC IE Field Diagnostics
• Remote device station is supported.
• The display of data link unexecuted stations is modified.

Section 18.4

CC-Link/
CC-Link/LT Diagnostics

The CC-Link diagnostics is continued on CC-Link modules 
mounted on the slots following the empty slot on the extension 
base unit.

Section 18.5

System monitor Q24DHCCPU-V can be monitored with QCPU (except for 
Q00JCPU and Q00UJCPU). Section 18.8

Merge Data Information of "Target Data List" can be displayed on tooltips. Section 4.3.5

Version Major function added/
changed Description Reference
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Version 1.98C

Programmable controller type

• High-speed Universal model QCPU (Q03UDV, Q04UDV, 
Q06UDV, Q13UDV, Q26UDV) is supported.

• L02S, L06, L26, and LJ72MS15 are supported.
• For Structured project, Process CPU (Q02PH, Q06PH, Q12PH, 

Q25PH) and Redundant CPU (Q12PRH, Q25PRH) are 
supported.

–

Transfer Setup For FXCPU, the GOT (Ethernet) transparent function is 
supported. Section 11.9.1

Intelligent Function Module

• L60AD4-2GH, Q64DAH, QD77GF16, QJ51AW12AL, and 
LJ51AW12AL are supported.

• The auto refresh item is added for QD77MS2, QD77MS4, and 
QD77MS16.

(Intelligent)

Security
For High-speed Universal model QCPU (Q03UDV, Q04UDV, 
Q06UDV, Q13UDV, Q26UDV), projects and programmable 
controller CPUs can be locked/unlocked with security keys.

Section 4.11
Section 13.5

Menu Menu names and positions are unified between GX Works2 and 
iQ Works. –

Parameter

For LCPU, the IP packet transfer setting on the <<Built-in 
Ethernet Port Setting>> tab of PLC Parameter is supported. Section 6.1.1

• For Universal model QCPU, the network operation setting is 
supported by the CC IE Control network parameter.

• For LCPU, Ethernet can be set in the network parameter.
• For LCPU, CC IE Field (Sub-Master Station) is supported by 

the network parameter.
• For LCPU, the IP address setting is supported by "Network 

Operation Settings" of CC-Link IE Field Network parameter 
(master station, sub-master station).

Section 6.3.1

• Network configuration of AnyWireASLINK can be set 
graphically on the AnyWireASLINK configuration window.

• The configuration of the actual system connected to CC-Link 
can be applied to the CC-Link configuration window.

Section 6.3.3

For Universal model QCPU, CC IE Field (motion master station) is 
supported in the network parameter. –

Write to PLC
The set values of XY devices can be written when writing data to 
a programmable controller CPU on which the simulation function 
is in operation.

Section 12.1.2

Block password For FXCPU, a block password can be set for POUs in batch. Section 4.12.1

Ladder

• For FXCPU, programs in ladder block unit can be displayed/ 
edited in the list format.

• The different sections of the same program can be monitored 
simultaneously using the reference window of the ladder editor.

• The cursor position can be jumped to the position where the 
next specified device/label is used only with the shortcut key.

(Simple)

• Inline structured text programs can be called from function 
blocks created in ladder programs.

• Function blocks created in ST programs can be called from 
function blocks created in ladder programs.

–

SFC For FXCPU, SFC diagrams can be converted in SFC block unit. (Simple)

ST Monitoring conditions can be set.

(Structured)
Structured Ladder/FBD

• Temporary arguments can be assigned for the arguments when 
calling function blocks in Structured project.

• Monitoring conditions can be set.

CC IE Control Diagnostics The IP communication test is supported. Section 18.3

CC IE Field Diagnostics
CC-Link IE Field Network CC-Link Bridge module, CC-Link IE 
Field Network High Speed Counter module, and Simple Motion 
module are supported.

Section 18.4

Ethernet Diagnostics L series Ethernet module is supported. Section 18.6.1

Version Major function added/
changed Description Reference
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Version 1.98C

Sensor/Device Monitor Sensors and equipments on AnyWireASLINK or CC-Link can be 
monitored. Section 18.7

Print Operation outputs and transition conditions can be appended on 
the print of SFC diagram. Section 20.5.8

Intelligent function module 
tool

Waveform output data of QCPU (Q mode) can be created for 
analog module Q64DAH. (Intelligent)

FB library
For QCPU (Q mode)/LCPU Simple project (with labels), FBs 
created in another project can be added to the project being 
edited on the Install screen.

(FB)

Unused label list For Structured project, extracted unused labels can be deleted in 
batch. (Structured)

Cross reference
When the Auto-tracking mode is selected, cross reference 
information can be updated only when the cursor is moved by 
clicking the mouse or pressing the key.

Section 10.1.2

Watch
The display format (numerical display (1/0)/ ON/OFF display/
symbol display (/)) of the current value of bit device can be 
changed.

Section 14.6.4

Monitor
The program can be verified with the program on the 
programmable controller CPU before starting the monitoring of 
the Structured Ladder/FBD editor or the ST editor.

(Structured)

Intelligent function module 
monitoring

For QD73A1, the required items for the accumulated pulse error 
detection function can be monitored. –

Shortcut key customize The template on which the MEDOC format shortcut keys can be 
set is added. Section 3.2.8

Options

For QCPU (Q mode)/LCPU, by setting the reference/reflection 
targets of device comments for 'PLC parameter setting', device 
comments can be referred/reflected according to the range of 
local devices specified on the <<Device>> tab of PLC parameter.

Section 21.2

Version Major function added/
changed Description Reference
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Appendix 13 Supported Versions of Modules

The following table shows the modules which are supported according to the upgrades.
Modules can be used in the corresponding and later versions of GX Works2.

Supported version
Supported module

CPU module/Remote I/O module/
Communication head module Intelligent function module

Version 1.05F
Q02(H), Q02U, Q03UD, Q03UDE, Q04UDH, 
Q04UDEH, Q06H, Q06UDH, Q06UDEH, Q12H, 
Q13UDH, Q13UDEH, Q25H, Q26UDH, Q26UDEH

• Analog
Q64AD, Q68ADV, Q68ADI, Q64AD-GH, 
Q62AD-DGH, Q68AD-G, Q66AD-DG, Q62DAN, 
Q64DAN, Q68DAVN, Q68DAIN, Q62DA, Q64DA, 
Q68DAV, Q68DAI, Q62DA-FG, Q66DA-G

• Temperature input
Q64RD, Q64RD-G, Q64TD, Q64TDV-GH, 
Q68TD-G-H01, Q68RD3-G

• Temperature control
Q64TCTT, Q64TCTTBW, Q64TCRT, 
Q64TCRTBW, Q62HLC

• Counter
QD62, QD62E, QD62D, QD63P6, QD64D2, 
QD60P8-G

• QD75 type positioning
QD75P1, QD75P2, QD75P4, QD75D1, QD75D2, 
QD75D4, QD75M1, QD75M2, QD75M4, 
QD75MH1, QD75MH2, QD75MH4

• QD70 type positioning
QD70P4, QD70P8, QD70D4, QD70D8, QD72P3C3

• Serial communication/modem interface
QJ71C24N, QJ71C24N-R2, QJ71C24N-R4, 
QJ71C24, QJ71C24-R2, QJ71CMON, QJ71CMO

• AS-i master
QJ71AS92

• FL-net (OPCN-2) interface
QJ71FL71-F01, QJ71FL71-T-F01, 
QJ71FL71-B2-F01, QJ71FL71-B5-F01, QJ71FL71, 
QJ71FL71-T, QJ71FL71-B2, QJ71FL71-B5

Version 1.08J

Q00UJ, Q00U, Q01U, Q10UDH, Q10UDEH, 
Q20UDH, Q20UDEH

• Temperature input
Q68TD-G-H02

FX0, FX0S, FX0N, FX1, FXU, FX2C, FX1S, FX1N, 
FX1NC, FX2N, FX2NC, FX3G, FX3U, FX3UC

–

Version 1.12N Q00J, Q00, Q01 • Analog
Q64AD2DA, Q61LD

Version 1.15R – –

Version 1.24A L02, L26-BT

• Analog
L64AD4, L60DA4

• Serial communication
LJ71C24, LJ71C24-R2

Version 131H

Q50UDEH, Q100UDEH –

LJ72GF15-T2

• Counter
LD62, LD62D

• LD75 type positioning
LD75P4, LD75D4

• Simple motion
LD77MH4

Version 1.40S QJ72LP25, QJ72BR15 –

Remote HeadQ CPU L CPU FX
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Version 1.48A –

• Counter
QD65PD2

• Simple motion
LD77MH16

Version 1.53F – • MODBUS® interface
QJ71MT91, QJ71MB91

Version 1.62Q

–
• Temperature control

Q64TCTTN, Q64TCRTN, Q64TCTTBWN, 
Q64TCRTBWN,

L02-P, L26-PBT
• Temperature control

L60TCTT4, L60TCTT4BW, L60TCRT4, 
L60TCRT4BW

Version 1.64S –
• QD75 type positioning

QD75P1N, QD75P2N, QD75P4N, QD75D1N, 
QD75D2N, QD75D4N

Version 1.73B – • Analog
Q64ADH

Version 1.77F

–

• Analog
Q68CT

• Simple motion
QD77MS2, QD77MS4, QD77MS16

– • LD75 type positioning
LD75P1, LD75P2, LD75D1, LD75D2

FX3GC –

Version 1.87R Q02PH*1, Q06PH*1, Q12PH *1, Q25PH*1, Q12PRH*1, 
Q25PRH*1

• QD70 type positioning
QD73A1

Version 1.91V Q02PH*2, Q06PH*2, Q12PH*2, Q25PH*2, Q12PRH*2, 
Q25PRH*2

• Energy measuring
QE81WH, QE81WH4W, QE84WH, QE83WH4W, 
QE82LG

Version 1.98C

Q02PH*3, Q06PH*3, Q12PH*3, Q25PH*3, Q12PRH*3, 
Q25PRH*3, Q03UDV, Q04UDV, Q06UDV, Q13UDV, 
Q26UDV

• Analog
Q64DAH

• Simple motion
QD77GF16

• AnyWireASLINK interface
QJ51AW12AL

L02S, L06, L26, LJ72MS15

• Analog
L60AD4-2GH

• AnyWireASLINK interface
LJ51AW12AL

*1 : Simple projects (without labels) are supported.
*2 : Simple projects are supported.
*3 : Simple projects and Structured projects are supported.

Supported version
Supported module

CPU module/Remote I/O module/
Communication head module Intelligent function module
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Appendix 14 Procedure to Use GX Works2 Unsupported Programmable Controller Type

For programmable controller types which are not supported by GX Works2 (CPUs such as ACPU, 
QnACPU, and Safety CPU), use GX Developer.
When GX Developer Version 8.95Z or later is installed, and a new project is created in GX Works2 with 
a selection of an unsupported programmable controller type, GX Developer starts automatically and a 
new project is created. (Section 4.2.1)

Appendix 14.1 Installing GX Developer

GX Developer can be installed at the same time as the installation of GX Works2.

Operating procedure

1. Select "Install GX Developer" on the following screen displayed during the 
installation of GX Works2.
Select the items under "Select Components" as necessary.

2. Click the  button, and continue the installation.
GX Developer is installed after GX Works2 is installed.

● Installing updated version of GX Works2
When installing GX Developer at the same time as the installation of updated version of GX Works2, the product 
version of GX Developer needs to be installed in advance.
When the product version of GX Developer is not installed, install GX Developer from the product version CD-ROM, or 
install GX Developer included on the GX Works2 CD-ROM (Disc 1) before installing the updated version of GX Works2.
For installing GX Developer included on the GX Works2 CD-ROM (Disc 1), refer to Appendix 14.2.

HeadRemoteQ CPU L CPU FX
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Appendix 14.2  Installing GX Developer separately

Appendix 14.2 Installing GX Developer separately

GX Developer is included on the GX Works2 CD-ROM.

■ For GX Works2 Version 1.53F or later

The installation file is included in the "GXD1" folder on the CD-ROM (Disc 1). The following is the 
installation procedure.

Operating procedure

• Run '\SUPPORT\GXD1\SETUP.EXE' on the CD-ROM (Disc 1).
The installation of GX Developer starts.
For details of the installation procedure, refer to the following manual.
Use the product ID of GX Works2 for the installation.
GX Developer Version 8 Operating Manual (Startup)

■ For GX Works2 Version 1.48A or earlier

The installation file is included in the "Others" folder on the CD-ROM. The following is the installation 
procedure.

Operating procedure

1. Copy the GX Developer compressed file on the CD-ROM to the HDD on the personal 
computer.
The path for the GX Developer compressed file on the CD-ROM is "\Others\d8-xxx.dat"*1.

*1 : "xxx" is an alphanumeric string.

2. Change the extension of the copied file from "dat" to "exe".
The file name is changed from "d8-xxx.dat" to "d8-xxx.exe".

3. Double-click the "d8-xxx.exe" file and decompress the file to the specified folder.

4. Run the decompressed "SETUP.EXE" file.
The installation of GX Developer starts.
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Appendix 14.3 Utilizing programs of GX Works2 unsupported 
programmable controller type in GX Works2

Programs of GX Works2 unsupported programmable controller type created with GX Developer can be 
utilized in GX Works2 by the following procedure.
The following is an example of utilizing an ACPU program created with GX Developer in the QCPU (Q 
mode) project of GX Works2.

Operating procedure

1. Change the programmable controller type of the project from ACPU to QCPU (Q 
mode) with GX Developer.
To change the programmable controller type, select [Project] ⇒ [Change PLC type].

2. Save the project with GX Developer.
To save the project, select [Project] ⇒ [Save As].

3. With GX Works2, read the project for QCPU (Q mode) created with GX Developer.
To read a GX Developer project with GX Works2, select [Project] ⇒ [Open Other Data] ⇒ [Open 
Other Project]. (Section 4.7.1)
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Appendix 15 Considerations of Installation

This section explains the considerations of installation.

■ Installing a MELSOFT product for the first time

At the first installation of a MELSOFT product, the following screen may be displayed during 
installation. To continue the installation, click the  button on the Software Installation 
screen. (We have checked the operation and assured that the system operates without any problems 
by performing this procedure.)
The Software Installation screen may be displayed behind another screen. Press the + keys to 
bring it to the front.

Remote HeadQ CPU L CPU FX
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■ Procedure for continuing installation when it is not completed correctly

When the installation of a MELSOFT product or another software is not completed correctly, the 
following screen is displayed and the installation cannot continue unless the personal computer is 
restarted.
In this case, restart the personal computer and start the installation again.

■ Considerations when installing on Windows Vista® or Windows® 7

When installing on Windows Vista® or Windows® 7, the following screen may be displayed after the 
completion of the installation. In this case, select "This program installed correctly" and restart the 
personal computer.

When "Reinstall using recommended settings" is erroneously selected, the Windows XP SP2 
compatibility mode is automatically set. Disable the Windows XP SP2 compatibility mode by following 
the procedure described below, and perform the reinstallation.
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Operating procedure

1. Right-click on the setup.exe icon of the installation 
target on Windows® Explorer.
The setup Properties screen is displayed.

2. Click the  button on the 
<<Compatibility>> tab.

3. Clear "Run this program in compatibility mode for:" 
and click the  button.

4. Click the  button.
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Appendix 16 USB Driver Installation

In order to communicate with a programmable controller CPU via USB, a USB driver needs to be 
installed.
The following explains the procedure of USB driver installation.
Drivers of FX3U-USB-BD and FX-USB-AW which are supported by FXCPU differ from the USB driver 
described in this section. For details, refer to Section 2.1.2 and Section 2.1.8.

■ When using Windows® 2000 Professional

Operating procedure

1. Connect the personal computer and the programmable controller CPU with a USB 
cable, and then turn on the programmable controller CPU.

2. The Found New Hardware Wizard screen is displayed. Select "Specify a location".

3. Click the  button and set "Easysocket\USBdrivers" in the folder where GX 
Works2 has been installed to "Copy manufacturer's files from:", and then click the 

 button. If multiple MELSOFT products are installed previously, refer to 
their installed location.

● Considerations when installing USB driver
If the USB driver cannot be installed, confirm the following Windows® settings.
• If "Block - Prevent installation of unsigned files" is selected under [Control Panel] - [System] - [Hardware] - [Driver 

Subscription], the USB driver may not be installed.
Select "Ignore - Install all files, regardless of file signature", or "Warn - Display a message before installing an 
unsigned files" in [Driver Subscription], and execute the USB driver installation.
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■ When using Windows® XP

Operating procedure

1. Connect the personal computer and the programmable controller CPU with a USB 
cable, and then turn on the programmable controller CPU.

2. The Found New Hardware Wizard screen is displayed. Select "Install from a list or 
specific location (Advanced)".

3. Select "Search for the best driver in these locations" on the displayed screen.
Select "Include this location in the search", and then set "Easysocket\USBdrivers" 
in the folder where GX Works2 has been installed. If multiple MELSOFT products 
are installed previously, refer to their installed location.

● Considerations when installing USB driver
If the USB driver cannot be installed, confirm the following Windows® settings.
• If "Block - Never install unsigned driver software" is selected under [Control Panel] - [System] - [Hardware] - [Driver 

Signing], the USB driver may not be installed.
Select "Ignore - Install the software anyway and don't ask for my approval", or "Warn - Prompt me each time to 
choose an action" in [Driver Signing], and execute the USB driver installation.
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■ When using Windows Vista®

Operating procedure

1. Connect the personal computer and the programmable controller CPU with a USB 
cable, and then turn on the programmable controller CPU.

2. The Found New Hardware screen is displayed. Select "Locate and install driver 
software (recommended)".

3. Select "Browse my computer for driver software (advanced)" on the Found New 
Hardware screen.

4. Specify "Easysocket\USBdrivers" in the folder where GX Works2 has been installed 
on the displayed screen. If multiple MELSOFT products are installed previously, 
refer to their installed location. Select "Include subfolders".

● Considerations when installing USB driver
When the Windows can’t verify the publisher of this driver software screen is displayed during the installation, select 
"Install this driver software anyway".
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■ When using Windows® 7

Operating procedure

1. Connect the personal computer and the programmable controller CPU with a USB 
cable, and then turn on the programmable controller CPU.

2. From Windows® Control Panel, select [System and Security] - [Device Manager]. 
Right-click "Unknown device" and click "Update Driver Software".

3. The Update Driver Software screen is displayed. Select "Browse my computer for 
driver software" and specify "Easysocket\USBdrivers" in the folder where GX 
Works2 has been installed on the displayed screen. If multiple MELSOFT products 
are installed previously, refer to their installed location.
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Appendix 17 Considerations When Using English Version of GX Works2

This section explains the considerations when using project data, which is created in Japanese 
version of GX Works2, in English version of GX Works2.
Refer to the considerations described in this section when using Japanese version of GX Works2 
Version 1.42U or earlier, or English version of GX Works2 Version 1.44W or earlier.
Note that, however, project data created in Japanese version of GX Works2 Version 1.45X or later 
which satisfy the following conditions can be used in English version of GX Works2 Version 1.48A or 
later.
● Data names listed in the section 'Section Appendix 16.1' match with the project language selected 

for the "Language Selection" function.
● The font of the project language selected for the "Language Selection" function is installed in the 

operating system.
Use the programmable controller types applicable to English version of GX Works2 when using 
project data created in Japanese version of GX Works2 in English version of GX Works2.

Remote HeadQ CPU L CPU FX
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Appendix 17.1 Data to which double byte character and half-width 
Japanese kana character are applicable

The following tables show all data to which double byte characters are applicable. When data 
described in the following table contains a double byte character, any symptom described in 
Appendix 17.2 occur.
When using Japanese version of GX Works2 Version 1.42U or earlier, or English version of GX Works2 
Version 1.44W or earlier, refer to the considerations in Appendix 17.2.
However, if a project data created in Japanese version of GX Works2 satisfies the following conditions, 
the project can be used in English version of GX Works2 Version 1.48A or later without any symptom 
described in Appendix 17.2.
• When the language used for data with  indicated in the 'Project language is unchangeable' column 

of the following table matches with the project language set for "Language Selection".
• When the font of the specified project language is installed to the operating system.

Note that; however, when data other than alphanumeric character is used for the data with  indicated 
in the 'Project language is unchangeable' column of the following table, an error occurs at the change of 
project language for Japanese version of GX Works2 Version 1.45X or later. Change the project 
language after correcting the data name to match the changed project language.

● Data to which double byte character and half-width Japanese kana character are applicable
: Unchangeable –: Changeable

Item Data name
Changeable/

unchangeable 
project language

Workspace Workspace name –

Project

GX Works2 project name –

GX Developer project name –

Compressed project name –

Property (Title/Comment) –

Project revision Detailed information (Title/Comment) –

Program Program name 

Ladder, ST, Structured Ladder/FBD, SFC 
(Zoom)

Statement/Note/Comment/Label name –

FB instance name –

SFC

SFC block name 

SFC step/Transition comment –

Property (Block information) –

Parameter

● PLC parameter data –

● Network parameter data –

Property (Title/Comment) –

Intelligent function module data ● Intelligent function module data –

Device comment
Local device comment name –

Device comment –

Device memory
Device memory name –

Property (Title/Comment) –

Device initial value
Device initial value name –

Comment –
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Global label/Local label/Structure

Global label name/Structure name 

Label name 

Constant value –

Data type –

Comment –

Remark –

FB/FUN
Function block name/Function name 

Property (Result Type) –

Program file/Task
(Structured project)

Program file name/Task name 

Program name 

Comment –

User library
(Structured project)

User library name 

Library file name (*.SUL) –

Property (Help path) –

Intelligent function module tool – –

QD75/LD75 positioning module
Wave trace file name –

Location trace file name –

Serial communication module

Circuit trace data –

Protocol setting file name
(Predefined protocol support function) –

Manufacturer/Model/Protocol name/Packet name/
Element name 
(Predefined protocol support function)

–

User data (Example: *.xls) File name –

Backup data for PLC Module Change Setting 
function Title –

Target memory for online operations Title –

IC memory card drive for IC memory card 
operation Title –

I/O system setting I/O system setting file name –

CSV file that can be created in Diagnostic 
function

Product information in System monitor –

PLC diagnostics –

Module error history –

Shortcut key Template file name –

Item Data name
Changeable/

unchangeable 
project language
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● PLC parameter data
: Unchangeable –: Changeable

● Network parameter data
: Unchangeable –: Changeable

● Intelligent function module data
: Unchangeable –: Changeable

Tab name Item Data name
Changeable/

unchangeable 
project language

PLC Name –
Label –

Comment –

PLC System PLC Module Change Setting Title Setting –

PLC File

File Register File Name –

Comment File Used in a Command File Name –

Initial Device Value File Name –

File for Local Device File Name –

PLC RAS Error History File Name –

Boot File – Data Name –

Program – Program Name –

I/O Assignment

I/O Assignment Type –

Base Setting

Model Name –

Power Model Name –

Extension Cable –

Type Item Data name
Changeable/

unchangeable 
project language

Ethernet/CC IE/MELSECNET

Network Range Assignment Parameter Name –

Network Configuration Settings
Alias –

Comment –

Network Operation Settings Parameter Name –

Station Inherent Parameters Parameter Name –

FTP Parameters Login Name –

E-mail Setting
SMTP Server Name –

POP Server Name –

News Setting Attached File Name –

CC-Link Operation Setting Parameter Name –

Module type Item Data name
Changeable/

unchangeable 
project language

Positioning module Positioning Data Positioning Comment –

Serial communication module/Modem 
interface module

Modem Function

Initialization command –

Telephone number –

Message –

Comment –

User Register Frame Content User registration frame –

FL-net (OPCN-2) interface module Parameter Node name (Equipment 
name) –
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Appendix 17.2 Considerations

The English version of GX Works2 (SW1DNC-GXW2-E) does not support double byte character and 
half-width Japanese kana character. Therefore, when using the project data, which has been created in 
the Japanese version of GX Works2 (SW1DNC-GXW2-J) using double byte character or half-width 
Japanese kana character, in the English version of GX Works2, change all the double byte character 
and half-width Japanese kana character to single byte alphanumeric character in the Japanese version 
of GX Works2. After characters are changed, execute [Compile] ⇒ [Rebuild All] or [Build] in the 
Japanese version of GX Works2 and save the project in a condition without any errors.

The following are the considerations when reading project data, in which double byte character or half-
width Japanese kana character is used, from the programmable controller CPU.
• The symbolic information created in the Japanese version of GX Works2 and written to the 

programmable controller CPU, cannot be read to the English version of GX Works2. In this case, 
save the project created in the Japanese version of GX Works2 using the English version of GX 
Works2, then write the symbolic information to the programmable controller CPU.

■ Symptom example

The following are examples when using the project data, which is created using double byte character 
or half-width Japanese kana character, in the English version of GX Works2.
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● Displayed as garbled characters
When double byte character or half-width Japanese kana character is set in the statement or label, 
they are displayed as garbled characters.

● Data name is not displayed
When double byte character or half-width Japanese kana character is used in data names of user 
library files, data names cannot be displayed and user library cannot be operated.

● Data cannot be opened
When opening saved project data in which double byte character or half-width Japanese kana 
character is used in workspace names or project names, the message shown below is displayed and 
the workspace cannot be opened.

● Compilation error
When compiling the project data in which double byte character or half-width Japanese kana 
character is used in label names, compilation error occurs and compilation cannot be completed 
normally.

<Japanese version of GX Works2> <English version of GX Works2>

<Japanese version of GX Works2> <English version of GX Works2>

<English version of GX Works2>

<English version of GX Works2>
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Appendix 18 Considerations for Selecting Project Language

This section explains the considerations for selecting a project language.
'language of GX Works2' in the table indicates the language of installed GX Works2.

Remote HeadQ CPU L CPU FX

Category Item Considerations

OS

Windows® 2000
All characters of the selected language are corrupted when the 
language package is not installed.

The operation is ensured for Japanese language only.

Windows® XP
All characters of the selected language are corrupted when the 
language package is not installed.

Windows Vista® All characters of the selected language are corrupted when the 
language package is not installed.
The language package is pre-installed.Windows® 7

Programmable 
controller CPU File name

When a file with a name using other than Japanese characters 
or one-byte alphanumeric characters is written to a 
programmable controller CPU, the file cannot be read from the 
programmable controller CPU, and the performance of the 
online function may not be normal.

Operation after 
installation

Language of Windows® operating system and 
'language of GX Works2' are different.

When using GX Works2 in Japanese language, check the 
following settings.
• "Language for non-Unicode programs"*1 of Windows® 

operating system is set to Japanese.
• The project language is set to Japanese under [Tool] ⇒ 

[Language Selection] in GX Works2.

When using the following functions, use alphanumeric 
characters or Japanese characters for folder names and file 
names.
• Open data in other format
• Save project in GX Developer format
• Read/write IC memory card
• Local device batch read + save CSV

For "Language for non-Unicode programs"*1 setting, set the 
same language as the one set for the 'language of GX Works2' 
in advance. By this setting, error messages can be displayed 
in the 'language of GX Works2'.

Entered language

Mixing different languages

Only one language with double-byte characters can be used in 
a project. Japanese, Chinese (simplified characters), and 
Korean cannot be mixed.
A language with one-byte characters and a language with 
double byte characters can be mixed. For example, English 
(one-byte alphanumeric characters) and Japanese.

When entering data in a language other than 
the one set for the project language.

The operation is ensured only when the project language 
which is set for the language selection is used. Do not use 
characters of the language other than the one set for the 
project language.
Note that alphanumeric characters and one-byte symbols can 
be used in all languages.
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Font

Korean is selected for project language.
(Regarding the font 'BatangChe' which is set 
automatically.)

Including fixed characters such as menus, some of the 
characters of Japanese and Chinese (simplified characters) 
are displayed in smaller size.

Displayed characters are different depending 
on the font even when they are the same 
character.

Displayed characters may be different between the ones on 
the screen in which font can be changed and the ones on the 
screen in which font cannot be changed. Change the font on 
the Color and Font screen.

Example) With Korean is selected as the project language, 
when " " is entered in the label editor and a 
compilation error is performed, " " is displayed 
on the Output window.

The entered text may be truncated on the screen on which 
fonts cannot be specified.

Function

[Verify]
Projects whose project languages are different 
are verified.

When the same character strings with double-byte character 
are verified, the result will be a match, however, the character 
strings may not be displayed normally.
Select the same language for projects to be verified.

[Install]
User library which contains characters of 
different language is imported to project.

The operation of user library import is ensured when the 
project language set for the language selection is used for user 
library file names and data in the user library.
User library which contains file names and data with 
alphanumeric characters and one-byte symbol can be used in 
a project in any language.

[Read from PLC], [Read IC Memory Card]
Data contains characters in different language 
is imported, and the Read from PLC or Read 
IC Memory Card is executed.

The operation of Read from PLC or Read IC Memory Card 
function is ensured when the project language set for the 
language selection is used for characters in a target data.
Set the same language as the one used in a target data to be 
read.
Target data of the data read function which contains 
alphanumeric characters and one-byte symbol can be used in 
a project in any language.

[Open Other Project]
The project language selected for "Language 
Selection" and the operating system language 
are different.

Other format projects which can be opened in GX Works2: 
projects whose data name and label name are written in 
alphanumeric code.

[Read from CSV File]
(When reading a program which is written in 
list format.)

The operation is ensured only when the project languages for 
the Write to CSV File function and Read from CSV File 
function are the same.

Project language 
selection

A language is selected while the project is 
being displayed.

Screens which are opened from the Project view and the User 
Library view are closed automatically when a language is 
selected. Close all other open screens.
The selected language is applied by reopening the screens.

Data names, label names

When characters other than alphanumeric characters are used 
for data names and label names in a project before selecting a 
project language, the operation is not ensured after the 
language is selected.

Simulation function

Project language setting is invalidated.

Interaction with LCPU logging configuration 
tool

Interaction with Ethernet adapter module 
configuration tool

Predefined protocol support function

Interaction with iQ Works

*1 : Set "Language for non-Unicode programs" by the following procedure.
[start] of Windows® operating system ⇒ [Control Panel] ⇒ [Regional and Language Options] ⇒ <<Advanced>> ⇒ "Language for 
non-Unicode programs".

Category Item Considerations
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Appendix 19 Modifying Instructions of Projects in Other Formats

This section explains instructions which require modification and how to modify them when using 
projects in other formats in GX Works2.

An X mark may appear on a POU or an error may occur at a compilation when a project which 
contains ST programs or Structured Ladder/FBD programs created in GX Developer or GX IEC 
Developer is opened in GX Works2. In this case, instructions or arguments need to be modified.
The following table shows the modification methods and reference sections. For instructions which 
require modification, read the corresponding reference.

● Compiling programs with instructions which do not require modification
For the instructions which do not require modification, perform the following operation to compile programs 
without correcting the programs.
Select "Use Dedicated Instruction for GX Developer, GX IEC Developer" under [Tool] ⇒ [Options] ⇒ 
"Project" ⇒ "Common Setting", and restart GX Works2.

Modification method Reference

Replacing instruction names Appendix 19.1

Adding devices/labels Appendix 19.2

Changing positions of devices/labels Appendix 19.3

Changing arguments to constants Appendix 19.4

Changing label data types to double-precision real number Appendix 19.5

Changing label data types Appendix 19.6

Changing number of array elements of array data type labels Appendix 19.7

Changing label data type to array data type Appendix 19.8

Q CPU L CPU FXFXRemote FXHead
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Appendix 19.1 Replacing instruction names

When using any of the following GX Developer or GX IEC Developer instruction, replace the instruction 
with the GX Works2 instruction.

● Replacing an instruction in Structured Ladder/FBD program

Operation
1. Select an instruction to be modified.

2. Select [Edit] ⇒ [Input Instruction].
The Input Instruction [Replace] screen is displayed.

3. Enter a GX Works2 instruction name.

4. Click the  button.
The instruction is replaced with the GX Works2 instruction.

● Replacing an instruction in ST program

Operation
• Replace the instruction with the GX Works2 instruction.

● Considerations when replacing instructions in Structured Ladder/FBD programs
The size of function/function block may be changed. Adjust the position of function/function block if a function/function 
block with a replaced instruction overlaps with the connected function/function block.

● Replacing instructions in Structured Ladder/FBD programs
The Input Instruction [Replace] screen can also be displayed by selecting an instruction and entering an instruction 
name from the keyboard.

● Replacing instructions using the Replace Instruction function
Instructions can also be replaced using the Replace Instruction function. (Section 10.3.2)

Instruction to be replaced
GX Works2 instruction

GX Developer instruction/GX IEC Developer instruction

LIMIT LIMITATION

MAX MAXIMUM

MIN MINIMUM
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Appendix 19.2 Adding devices/labels

When using any of the following GX Developer or GX IEC Developer instruction, add or change device/
label according to the argument of the GX Works2 instruction.
For Structured Ladder/FBD programs, instructions also need to be changed.

● Modifying an instruction in Structured Ladder/FBD program

Operation
1. Replace the instruction with the GX Works2 instruction. (Appendix 19.1)

2. Connect the device/label set to EN to the argument .

3. Connect the device/label set to ENO to the argument .

4. Select [Edit] ⇒ [ladder Symbol] ⇒ [Input Label] ( ), and add an input label to EN.

5. Set TRUE to EN.

Instruction to be modified
GX Works2 instruction

GX Developer instruction/GX IEC Developer instruction

COS COS

LEFT LEFT

LEN LEN

RIGHT RIGHT

ROL ROL_E

ROR ROR_E

SIN SIN

TAN TAN

ACOS ACOS

ASIN ASIN

ATAN ATAN

EXP EXP

s

d
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● Modifying an instruction in ST program

Operation
• Adjust the position of the argument, and add TRUE to EN.

In GX Works2, a return value of an instruction is ENO, not an operation result.
Programs in which instructions are nested should be rewritten as shown below.
<ST before modification>
Var_Real := COS(Var_s_Real) + 1.23;

<ST after modification>
COS(TRUE, Var_s_Real, Var_cos_Real);Var_Real := Var_cos_Real + 1.23;
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Appendix 19.3 Changing positions of devices/labels

When using any of the following GX IEC Developer instruction, replace the instruction with the GX 
Works2 instruction, and change the position of device/label according to the corresponding argument.

● Modifying an instruction in Structured Ladder/FBD program

Operation
1. Replace the instruction with the GX Works2 instruction. (Appendix 19.1)

2. Change the position of the device/label according to the argument of the instruction.
If an input label or output label does not exist at the position of argument, add it by selecting 
[Edit] ⇒ [Ladder Symbol] ⇒ [Input Label] ( )/[Output Label] ( ).
For G_GETE in the following example, move "D12" of the argument  to , and move "M12" 
which is not connected to the argument .

● Modifying an instruction in ST program

Operation
• Replace the instruction with the GX Works2 instruction.

Only for RISEND(_P)_MD, switch the positions of 4th argument and 5th argument.

Instruction to be modified GX Works2 
instruction

Argument 
with different 

position
New position for argument

GX IEC Developer instruction

GETE_M G_GETE s2

Change the position of the device/label from 
the right side to the left side of the POU 
according to the position of the argument.

GETEP_M GP_GETE s2

BUFRCV_M ZP_BUFRCV s2

BUFSND_M ZP_BUFSND s3

CLOSE_M ZP_CLOSE s2

RISEND_MD G_RISEND d1
Change the position of the device/label from 
the left side to the right side of the POU 
according to the position of the argument.

RISEND_P_MD GP_RISEND d1

RITO_MD G_RITO d

RITO_P_MD GP_RITO d

d s2

d
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Appendix 19.4 Changing arguments to constants

When using any of the following GX IEC Developer instruction, replace the instruction with the GX 
Works2 instruction, and change the data type of argument to constant.

● Modifying an instruction in Structured Ladder/FBD program

Operation
1. Replace the instruction with the GX Works2 instruction. (Appendix 19.1)

2. Change the argument n to constant. When a label is set to the argument n, change the 
class of the label to "VAR_CONSTANT" or "VAR_GLOBAL_CONSTANT" on the label 
setting editor.

● Modifying an instruction in ST program

Operation
1. Replace the instruction with the GX Works2 instruction.

2. Change the argument n to constant. When a label is set to the argument n, change the 
class of the label to "VAR_CONSTANT" or "VAR_GLOBAL_CONSTANT" on the label 
setting editor.

Instruction to be modified
GX Works2 instruction Argument to which constant is to be 

setGX IEC Developer instruction

MEAN_M MEAN n

MEANP_M MEANP n

BMOV_E BMOV_E n
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Appendix 19.5 Changing label data types to double-precision real 
number

When using any of the following GX IEC Developer instruction, replace the instruction with the GX 
Works2 instruction, and change the data type of argument to double-precision real number.

Instruction to be modified
GX Works2 instruction Argument to which double-precision 

real number is to be setGX IEC Developer instruction

LD_EDEQ_M LDED=*1

*1 : For ST program, the instruction does not need to be changed to a GX Works2 instruction.

s1, s2

LD_EDGE_M LDED>=*1

LD_EDGT_M LDED>*1

LD_EDLE_M LDED<=*1

LD_EDLT_M LDED<*1

LD_EDNE_M LDED<>*1

AND_EDEQ_M ANDED=*1

AND_EDGE_M ANDED>=*1

AND_EDGT_M ANDED>*1

AND_EDLE_M ANDED<=*1

AND_EDLT_M ANDED<*1

AND_EDNE_M ANDED<>*1

OR_EDEQ_M ORED=*1

OR_EDGE_M ORED>=*1

OR_EDGT_M ORED>*1

OR_EDLE_M ORED<=*1

OR_EDLT_M ORED<*1

OR_EDNE_M ORED<>*1

EDPLUS_M –*2

*2 : The instruction does not need to be changed to a GX Works2 instruction.

s1, s2
EDPLUSP_M –*2

EDPLUS_3_M ED+*1
s1, s2, d

EDPLUSP_3_M ED+P*1

EDMINUS_M –*2
s, d

EDMINUSP_M –*2

EDMINUS_3_M ED-*1
s1, s2, d

EDMINUSP_3_M ED-P*1

EDDIV_M ED/*1

s1, s2, d
EDDIVP_M ED/P*1

EDMUL_M ED*1

EDMULP_M ED*P*1

FLTD_M FLTD

d

FLTDP_M FLTDP

DFLTD_M DFLTD

DFLTDP_M DFLTDP

EDNEG_M EDNEG

EDNEGP_M EDNEGP

EDMOV_M EDMOV
s, d

EDMOVP_M EDMOVP
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● Modifying an instruction in Structured Ladder/FBD program

Operation
1. Replace the instruction with the GX Works2 instruction. (Appendix 19.1)

2. Change the class of the label to "FLOAT (Double Precision)" on the label setting editor.

● Modifying an instruction in ST program

Operation
1. Replace the instruction with the GX Works2 instruction.

2. Change the class of the label to "FLOAT (Double Precision)" on the label setting editor.
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Appendix 19.6 Changing label data types

When using any of the following GX IEC Developer instruction, replace the instruction with the GX 
Works2 instruction, and change the data type according to the data type of the argument.

● Modifying an instruction in Structured Ladder/FBD program

Operation
1. Replace the instruction with the GX Works2 instruction. (Appendix 19.1)

2. Change the data type of the label to the corresponding data type on the label setting 
editor.

● Modifying an instruction in ST program

Operation
1. Replace the instruction with the GX Works2 instruction.

2. Change the data type of the label to the corresponding data type on the label setting 
editor.

Instruction to be modified
GX Works2 
instruction

Argument 
whose data 
type is to be 

changed

Argument data type

GX IEC Developer instruction Before change After change

FLTD_M FLTD s ANY16 Word [signed]

FLTDP_M FLTDP s ANY16 Word [signed]

DFLTD_M DFLTD s ANY32 Double word [signed]

DFLTDP_M DFLTDP s ANY32 Double word [signed]

OUT_M OUT d ANY_SIMPLE Bit
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Appendix 19.7 Changing number of array elements of array data type 
labels

When using any of the following GX IEC Developer instruction, replace the instruction with the GX 
Works2 instruction, and change the number of array elements according to the data type of the 
argument.

● Modifying an instruction in Structured Ladder/FBD program

Operation
1. Replace the instruction with the GX Works2 instruction. (Appendix 19.1)

2. Change the number of array element of the array data type label on the label setting 
editor.

● Modifying an instruction in ST program

Operation
1. Replace the instruction with the GX Works2 instruction.

2. Change the number of array element of the array data type label on the label setting 
editor.

● Considerations when changing the number of array elements
When the number of array elements is reduced by the modification, the program needs to be modified according to the 
change.
Example: For the argument  of REQ_JP_M, the program which accesses the 7th array element needs to be 
modified.

Instruction to be modified
GX Works2 
instruction

Argument whose 
number of array 
elements is to be 

changed

Argument data type

GX IEC Developer instruction Before change After change

REQ_JP_M
JP_REQ s2 ARRAY[1..7] OF ANY16

ANY16(0..5)*1
JP_REQ d1 ARRAY[1..4] OF ANY16

REQ_UP_M
GP_REQ s2 ARRAY[1..7] OF ANY16

GP_REQ d1 ARRAY[1..4] OF ANY16

*1 : The index of the array does not need to be started from 0 if the number of array elements matches. A change of the 
program is not necessary when the index of the array is set to 1 to match with the previous index.

d
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Appendix 19.8 Changing label data type to array data type

When using any of the following GX IEC Developer instruction, replace the instruction with the GX 
Works2 instruction, and change the data type of the argument to the array data type.

Instruction to be modified GX Works2 
instruction

Argument whose data 
type is to be changed 

to array data type

Argument data type

GX IEC Developer instruction Before change After change

TEACH1_P_M ZP_TEACH1 s

ANY16 ANY16(0..3)
TEACH2_P_M ZP_TEACH2 s

TEACH3_P_M ZP_TEACH3 s

TEACH4_P_M ZP_TEACH4 s

PSTRT1_P_M ZP_PSTRT1 s

ANY16 ARRAY[0..2] OF ANY16
PSTRT2_P_M ZP_PSTRT2 s

PSTRT3_P_M ZP_PSTRT3 s

PSTRT4_P_M ZP_PSTRT4 s

BIDIN_M G_BIDIN d2

BOOL ARRAY[0..1] OF BOOL

BIDINP_M GP_BIDIN d2

BIDOUT_M G_BIDOUT d

BIDOUTP_M GP_BIDOUT d

INPUT_M G_INPUT d2

ONDEMAND_M G_ONDEMAND d

ONDEMANDP_M GP_ONDEMAND d

OUTPUT_M G_OUTPUT d

OUTPUTP_M GP_OUTPUT d

PRR_M G_PRR d

PRRP_M GP_PRR d

PUTE_M G_PUTE d

PUTEP_M GP_PUTE d

READ_JP_M JP_READ d2

READ_UP_M GP_READ d2

RECV_JP_M JP_RECV d2

RECV_UP_M GP_RECV d2

REMFR_MD Z_REMFR d2

REMFR_P_MD ZP_REMFR d2

REMTO_MD Z_REMTO d2

REMTO_P_MD ZP_REMTO d2

REQ_JP_M JP_REQ d2

REQ_UP_M GP_REQ d2

SEND_JP_M JP_SEND d

SEND_UP_M GP_SEND d

SREAD_JP_M JP_SREAD d2

SREAD_UP_M GP_SREAD d2

SWRITE_JP_M JP_SWRITE d2

SWRITE_UP_M GP_SWRITE d2

WRITE_JP_M JP_WRITE d2

WRITE_UP_M GP_WRITE d2

ZNRD_J_M J_ZNRD d2

ZNRD_JP_M JP_ZNRD d2

ZNWR_J_M J_ZNWR d2

ZNWR_JP_M JP_ZNWR d2
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● Modifying an instruction in Structured Ladder/FBD program

Operation
1. Replace the instruction with the GX Works2 instruction. (Appendix 19.1)

2. Change the label data type to array data type on the label setting editor.

● Modifying an instruction in ST program

Operation
1. Replace the instruction with the GX Works2 instruction.

2. Change the label data type to array data type on the label setting editor.

● Considerations when changing data type
Since the label data type is changed to array data type, labels used in the program needs to be modified according to 
the array data type.
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[A]
access authority ............................................................. 4-67
Access levels ................................................................. 4-59
accessing a programmable controller CPU ................... 11-2
accessing a programmable controller CPU via GOT ... 11-38

FXCPU .................................................................. 11-40
QCPU (Q mode)/LCPU ..............................11-41, 11-43

Accessing Programmable Controller CPU via Phone Line
 ..................................................................................... 11-44
accessing the programmable controller CPU on the host
station ............................................................................ 11-7

FXCPU .................................................................... 11-8
QCPU (Q mode)/LCPU ........................................... 11-8

Acknowledge XY Assignment ..............6-3, 6-16, 6-19, 6-21
Administrators ................................................................ 4-59
All Find ......................................................................... 10-16
All Replace ................................................................... 10-16
Allocating memory for Online program change .............. 12-6
Always ON ................................................................... 19-30
ASCII Code ................................................................App-57
ATA card ...........................................................12-31, 12-68

[B]
backup ........................................................................... 4-45
backup device memory .................................................. 15-6
block password .....................................................4-77, 4-78
buffer memory .....................................................14-8, 21-12
Build ................................................................................. 5-9

[C]
Cable test ..................................................................... 18-43
Canceling keyword ....................................................... 13-16
canceling password ............................................13-6, 13-11
CC IE Field configuration window .................................. 6-29
CC-Link configuration window ....................................... 6-42
CC-Link IE ............................................................ A-33, 6-19
change ......................................................................... 19-21
Change Project Type ..................................................... 4-44
Change to General CC-Link Module .............................. 6-46
Changing colors ............................................................. 3-24
Changing fonts ............................................................... 3-24
Changing Modules Online .......................................... 18-100
Changing project data names ........................................ 4-37
Characters for password ................................................ 6-58
Check Parameter ........................................................... 6-59
Clear All Parameters ...................................................... 6-62
Clear All (All Devices) .................................................... 9-14
Closing projects ............................................................. 4-19
Command Execution of Slave Station ........................... 6-49
Comment verify type .................................................... 12-28
comments by program ..................................................... 9-4
common comments .......................................................... 9-4
communication head module ............................... A-33, 6-10

Communication test .............................. 18-20, 18-30, 18-41
compare source ........................................................... 19-11
Compatibility .................................................App-74, App-77
Compile .................................................................5-9, 21-14
Compile Condition ........................................................ 21-15
compression ................................................................... 4-16
condition ......................................................................... 19-4
Configurations for USB connection .................................. 2-4
connecting station information ..................................... 18-50
Connection Channel List ................................................ 11-4
Connection Destination view .......................................... 3-20
Connection from an I/F Boards ...................................... 2-13
Connection test .............................................................. 11-5
conventional debugging ................................................. 19-2
Copy ......................................................................4-35, 4-36
COS curve .................................................................... 19-21
Creating check sheets .................................................. 18-59
Creating projects .............................................................. 4-9
Cross Reference ............................................................ 10-2
cycle scan .................................................................... 19-21

[D]
data entry method for direct data entry ........................ 19-14
Data Names .............................................................App-100
Data Paste ..................................................................... 4-35
Data Security Setting ..................................................... 4-67
debugging ...................................................................... 15-2
debugging with I/O system setting function .................... 19-2
decompressing ......................................................4-16, 4-17
decompressing divided compressed files ...................... 4-18
Delete ............................................................................. 4-37
Delete PLC Data .......................................................... 12-29
Delete PLC User Data .................................................. 12-31
Deleting Device Comments ............................................ 9-14
Deleting projects ............................................................ 4-18
Deleting revision information .......................................... 4-49
Developers (Level 1) ...................................................... 4-59
Developers (Level 2) ...................................................... 4-59
Developers (Level 3) ...................................................... 4-59
device batch replace .................................................... 10-28
Device Comment .....................................................9-2, 21-7
Device Comment Display Format .................................. 21-8
device comment editing mode ....................................... 9-12
device comment to be referenced .................................... 9-6
Device Initial Values ......................................................... 8-2
device list ..................................................................... 10-13
device memory .................................................. 7-2, 8-4, 8-5
device memory editor ..................................................... 7-14
device of which a value is to be changed ..................... 19-14
Device Specification screen ......................................... 19-11
device test with execution condition ............................... 16-9
device value input .......................................................... 19-8
devices that can be replaced or batch replaced ........... 10-20
diagnosing bridge modules .......................................... 18-52
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Diagnosing CC-Link and CC-Link/LT ...........................18-49
Diagnosing CC-Link IE Controller Network ..................18-26
Diagnosing CC-Link IE Field Network ..........................18-36
Diagnosing Ethernet .....................................................18-62
Diagnosing Programmable Controller CPU ....................18-2
digit ...............................................................................10-17
direct data entry ............................................................19-11
disabled scans ..............................................................19-22
Display Format .............................................................21-12
Display Lines of Monitored Current Value ....................21-12
display size ........................................................... 7-10, 7-13
Displaying editing screens with the toolbar ....................3-10
dockable windows ..........................................................3-17
duplicated coil .................................................................21-7

[E]
edit timing chart format ..................................... 19-15, 19-17
enabling high-speed monitoring from another station ....17-9
enabling Online program change of multiple blocks .......17-9
English Version of GX Works2 ................................ App-181
Enter Device screen .....................................................19-17
Error History .................................................................18-64
error history monitoring ................................................18-22
Error icons .......................................................... 18-8, 18-94
Error Information ............................................................18-4
Ethernet adapter ............................................................ A-33
Ethernet adapter module ............................................... A-33
Ethernet Adapter Module Configuration Tool ...............17-18
examples of device search ...........................................10-19
examples of instruction search .....................................10-23
execution type .......................................................... 4-5, 4-8
Export CSV Data ..........................................................16-25
Export to GX Developer Format File ..............................4-57
Export to ROM Format .................................................12-30
Extending Number of Points of Device Comment ..........9-15

[F]
FB libraries .....................................................................22-3
File Password 32 ............................................................13-8
file under editing .............................................................19-8
file under execution ........................................................19-8
Filtering condition .........................................................10-12
Filtering display ............................................................10-11
Format types ..................................................................17-9
Formatting a memory card .............................................17-9
Functions to Protect Data ...............................................13-2
FX manuals ....................................................................3-32
FX series ....................................................................... A-32

[G]
global device comment .....................................................9-2
GOT transparent function .............................................11-39
GX LogViewer format CSV file .....................................16-25

GX Simulator ...........................................19-9, 19-23, 19-30
GX Simulator2 ............................................................... A-32
GX Works2 format CSV file ..........................................16-25

[I]
inline structured text .....................................................10-16
instruction conversion list ........................................ App-147
intelligent function module .................................. 4-43, 12-13
invalid character .............................................................4-55
IP communication test ...................................... 18-31, 18-42
I/O system setting file ....................................... 19-27, 19-30

[K]
keep ..............................................................................19-15

[L]
L series .......................................................................... A-32
Label Names ........................................................... App-100
label programming ............................................................1-5
ladder editing mode ........................................................9-13
Latch Data Backup .......................................................12-35
LED status ....................................................................18-65
Libraries ..........................................................................22-2
link memory ...................................................... 21-11, 21-12
Link start/stop ...............................................................18-32
List of link devices ..........................................................6-53
List of slave stations .......................................................6-53
Logging .........................................................................18-34
Logging in projects .........................................................4-66
logs ................................................................... 10-30, 10-32
Loop test .......................................................................18-16
loop test/transmission speed test .................................18-55
Loopback test ...............................................................18-80

[M]
Managing block passwords ............................................4-78
MELSECNET Diagnostics ............................................18-12
Merge Data .....................................................................4-38
module error history ......................................... 18-91, 18-92
module error history collection function
 ..............................................................18-91, 18-92, 18-98
Monitoring Intelligent Function Modules .......................14-23
Monitoring Interrupt Program List .................................14-15
Monitoring line (host station) ........................................18-49
Monitoring Program List ...............................................14-12
Monitoring Value ..........................................................21-12
Multiple word ................................................................10-17

[N]
Navigation window ................................................. 3-4, 3-20
Network event history ...................................................18-45
network parameter .........................................................6-19

CC-Link ......................................................... 6-27, 6-28
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CC-Link IE .............................................................. 6-23
Ethernet .................................................................. 6-25
MELSECNET/10 ..................................................... 6-24
MELSECNET/H ...................................................... 6-24
Remote I/O ............................................................. 6-25

Network route ................................................................. 11-4
Network test ................................................................. 18-14
New ................................................................................ 4-33
New project creation with data read from programmable 
controller CPU ................................................................ 4-11
number of contacts ........................................................ 21-8
number of scans .......................................................... 19-17
number of scans of timing chart ................................... 19-22

[O]
obtain transmission speed setting ................................ 18-56
Online Program Change ...... 5-9, 12-40, 12-41, 12-43, 17-9
ON/OFF cycle .............................................................. 19-20
Opening existing projects ............................................... 4-12
Opening projects in other formats .................................. 4-54
option (find/replace) ..........................................10-17, 10-24
Options ........................................................................... 21-2
Other station .................................................................. 11-3
other station information .............................................. 18-24
Other Station (Co-existence Network) ........................... 11-3
Other Station (Single Network) ...................................... 11-3

[P]
Parameter Processing of Slave Station ................6-37, 6-47
parameter status ...............................................18-63, 18-69
Parameter Verify Level ................................................ 12-27
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